04-二层技术-以太网交换配置举例

01-S12500_QinQ典型配置举例

本章节下载  (189.41 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500/Configure/Typical_Configuration_Example/H3C_S12500-R7129-6W100/04/201309/796603_30005_0.htm

01-S12500_QinQ典型配置举例


1  简介

本文档介绍了QinQ的配置举例。

QinQ将用户的私网报文封装上外层VLAN Tag,使其携带两层VLAN Tag穿越运营商网络(公网),从而为用户提供了一种简单的二层VPN隧道技术。

2  配置前提

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文假设您已了解QinQ特性。

3  QinQ配置举例

3.1  组网需求

图1所示:

·     公司A的两个分支机构通过运营商网络进行通信,该公司各业务使用的VLAN为VLAN 10~70;公司B的两个分支机构也通过运营商网络进行通信,该公司各业务使用的VLAN为VLAN 30~90。

·     PE 1和PE 2为运营商网络的边缘设备,且二者通过TPID(Tag Protocol Identifier,标签协议标识符)值为0x8200的第三方厂商设备进行连接。

使用QinQ技术实现:

·     运营商网络分别用VLAN 100和200来承载公司A和公司B的流量,使两个公司的流量二层隔离。

·     公司A、B的两个分支机构之间,用户VLAN报文能跨运营商网络实现透明传输。

图1 QinQ配置组网图

 

3.2  配置思路

为了运行QINQ,只需在PE设备的用户侧接口上使能QINQ。

为了使PE设备的公网侧接口允许多个运营商VLAN通过,将其配置为Trunk口或Hybrid口。

缺省情况下S12500添加的外层VLAN Tag的TPID值为0x8100,而公网中的第三方厂商设备的TPID值为0x8200。两种设备的TPID值不同会造成两者之间的VLAN报文无法正常互通,因此需要在PE 1和PE 2上修改TPID值为0x8200。TPID值应该在PE设备的公网侧接口上配置。

3.3  使用版本

本举例是在S12500-CMW710-R7129版本上进行配置和验证的。

3.4  配置注意事项

·     使能QINQ的接口的链路类型可以为Access、Trunk或Hybrid(无论哪种链路类型,QinQ均使用相同机制为收到的报文加上一层端口缺省VLAN的Tag)。

·     当用户侧接口是Trunk口或Hybrid口时,需要配置该端口的缺省VLAN为运营商VLAN ID,并禁止VLAN 1通过该端口来避免错误的报文转发(缺省情况下设备的所有端口都属于VLAN 1)。

·     在QinQ报文的传输路径上,需要配置各接口的MTU值为至少1504字节(为报文加上外层VLAN Tag后,报文长度将增加4个字节)。

·     在修改TPID值之前,请确保PE设备连接用户侧和公网侧的接口在同一块单板上。

3.5  配置步骤

假设用户VLAN已在CE设备上正确配置。

3.5.1  配置PE 1

1. 配置用户侧端口GE3/0/1

# 配置端口为Trunk口,仅允许VLAN 100的报文通过。

<PE1> system-view

[PE1] vlan 100

[PE1-vlan100] quit

[PE1] interface GigabitEthernet3/0/1

[PE1-GigabitEthernet3/0/1] undo shutdown

[PE1-GigabitEthernet3/0/1] port link-type trunk

[PE1-GigabitEthernet3/0/1] undo port trunk permit vlan 1

[PE1-GigabitEthernet3/0/1] port trunk permit vlan 100

# 配置端口的缺省VLAN为VLAN 100。

[PE1-GigabitEthernet3/0/1] port trunk pvid vlan 100

# 使能端口的QinQ功能。

[PE1-GigabitEthernet3/0/1] qinq enable

[PE1-GigabitEthernet3/0/1] quit

2. 配置公网侧端口GE3/0/2

# 配置端口为Trunk口,且允许VLAN 100和VLAN 200的报文通过。

[PE1] interface GigabitEthernet3/0/2

[PE1-GigabitEthernet3/0/2] undo shutdown

[PE1-GigabitEthernet3/0/2] port link-type trunk

[PE1-GigabitEthernet3/0/2] port trunk permit vlan 100 200

# 配置外层VLAN Tag的TPID值为0x8200。

[PE1-GigabitEthernet3/0/2] qinq ethernet-type service-tag 8200

[PE1-GigabitEthernet3/0/2] quit

3. 配置用户侧端口GE3/0/3

# 配置端口为Trunk口,仅允许VLAN 200的报文通过。

[PE1] vlan 200

[PE1-vlan200] quit

[PE1] interface GigabitEthernet3/0/3

[PE1-GigabitEthernet3/0/3] undo shutdown

[PE1-GigabitEthernet3/0/3] port link-type trunk

[PE1-GigabitEthernet3/0/3] undo port trunk permit vlan 1

[PE1-GigabitEthernet3/0/3] port trunk permit vlan 200

# 配置端口的缺省VLAN为VLAN 200。

[PE1-GigabitEthernet3/0/3] port trunk pvid vlan 200

# 使能端口的QinQ功能。

[PE1-GigabitEthernet3/0/3] qinq enable

[PE1-GigabitEthernet3/0/3] quit

3.5.2  配置PE 2

1. 配置用户侧端口GE3/0/1

# 配置端口为Trunk口,仅允许VLAN 200的报文通过。

<PE2> system-view

[PE2] vlan 200

[PE2-vlan200] quit

[PE2] interface GigabitEthernet3/0/1

[PE2-GigabitEthernet3/0/1] undo shutdown

[PE2-GigabitEthernet3/0/1] port link-type trunk

[PE2-GigabitEthernet3/0/1] undo port trunk permit vlan 1

[PE2-GigabitEthernet3/0/1] port trunk permit vlan 200

# 配置端口的缺省VLAN为VLAN 200。

[PE2-GigabitEthernet3/0/1] port trunk pvid vlan 200

# 使能端口的QinQ功能。

[PE2-GigabitEthernet3/0/1] qinq enable

[PE2-GigabitEthernet3/0/1] quit

2. 配置公网侧端口GE3/0/2

# 配置端口为Trunk口,且允许VLAN 100和VLAN 200的报文通过。

[PE2] interface GigabitEthernet3/0/2

[PE2-GigabitEthernet3/0/2] undo shutdown

[PE2-GigabitEthernet3/0/2] port link-type trunk

[PE2-GigabitEthernet3/0/2] port trunk permit vlan 100 200

# 配置外层VLAN Tag的TPID值为0x8200。

[PE2-GigabitEthernet3/0/2] qinq ethernet-type service-tag 8200

[PE2-GigabitEthernet3/0/2] quit

3. 配置用户侧端口GE3/0/3

# 配置端口为Trunk口,仅允许VLAN 100的报文通过。

[PE2] vlan 100

[PE2-vlan100] quit

[PE2] interface GigabitEthernet3/0/3

[PE2-GigabitEthernet3/0/3] undo shutdown

[PE2-GigabitEthernet3/0/3] port link-type trunk

[PE2-GigabitEthernet3/0/3] undo port trunk permit vlan 1

[PE2-GigabitEthernet3/0/3] port trunk permit vlan 100

# 配置端口的缺省VLAN为VLAN 100。

[PE2-GigabitEthernet3/0/3] port trunk pvid vlan 100

# 使能端口的QinQ功能。

[PE2-GigabitEthernet3/0/3] qinq enable

[PE2-GigabitEthernet3/0/3] quit

3.5.3  配置第三方厂商设备

对于PE 1与PE 2之间的第三方厂商设备,其关键配置如下:在连通PE 1与PE 2的端口上,都允许VLAN 100和VLAN 200的报文携带VLAN Tag通过。

3.6  验证配置

(1)     同一个公司跨越运营商网络的两个分支机构的PC进行互相ping操作,如果两台PC处于同一网段且用户VLAN相同,可以ping通。可见用户VLAN信息能够跨运营商网络进行透明传输。

(2)     A公司和B公司的处于同一网段且用户VLAN相同(例如VLAN 30)的PC互相进行跨公司ping操作。在PC上查看ARP表项,发现它没有学到对方公司PC的MAC地址,可见两个公司的流量被二层隔离。

3.7  配置文件

·     PE1

#

vlan 100

#

vlan 200

#

interface GigabitEthernet3/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100

 port trunk pvid vlan 100

 qinq enable

#

interface GigabitEthernet3/0/2

port link-mode bridge

port link-type trunk

port trunk permit vlan 100 200

qinq ethernet-type service-tag 8200

#

interface GigabitEthernet3/0/3

port link-mode bridge

port link-type trunk

undo port trunk permit vlan 1

port trunk permit vlan 200

port trunk pvid vlan 200

qinq enable

#

·     PE2

#

vlan 100

#

vlan 200

#

interface GigabitEthernet3/0/1

port link-mode bridge

port link-type trunk

undo port trunk permit vlan 1

port trunk permit vlan 200

port trunk pvid vlan 200

qinq enable

#

interface GigabitEthernet3/0/2

port link-mode bridge

port link-type trunk

port trunk permit vlan 100 200

qinq ethernet-type service-tag 8200

#

interface GigabitEthernet3/0/3

port link-mode bridge

port link-type trunk

undo port trunk permit vlan 1

port trunk permit vlan 100

port trunk pvid vlan 100

qinq enable

#

4  相关资料

·     《H3C S12500系列路由交换机  二层技术-以太网交换配置指导》中的“QinQ”

·     《H3C S12500系列路由交换机  二层技术-以太网交换命令参考》中的“QinQ”

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们