• 产品与解决方案
  • 行业解决方案
  • 服务
  • 支持
  • 合作伙伴
  • 新华三人才研学中心
  • 关于我们

H3C S9500 产品配置举例-RELEASE1628及以上版本(V1.21)

13-灵活QINQ配置举例

本章节下载  (135.56 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S9500/S9500/Configure/Typical_Configuration_Example/S9500_1628_Typical_Configuration_Example(V1.21)/200711/318145_30005_0.htm

13-灵活QINQ配置举例

目  录

1 特性简介... 1

2 适用版本... 1

3 注意事项... 1

4 配置举例... 2

4.1 组网需求... 2

4.2 组网图... 2

4.3 配置步骤... 3

4.4 完整配置... 4


 

灵活QinQ配置举例

1  特性简介

使用普通的QinQ虽然可以解决VLAN的扩展和简单二层VPN的功能,但对一个端口只能增加固定的外层Tag,无法满足对不同业务的用户增加不同外层VLAN Tag的要求。如VLAN 100~200为一种业务的用户,要求打上外层标签10;VLAN 201~300为另一业务,要求打上外层标签20;VLAN 10~20的业务要求不打标签,这种应用需求QinQ就无法做到。

灵活QINQ可以通过配置特定的ACL规则,让匹配ACL规则的报文增加我们指定的vlan Tag或把进入的报文的vlan Tag修改成我们指定的vlan Tag,来达到我们灵活应用的目的。

2  适用版本

软件版本:S9500-CMW310-R1628版本及以后升级版本(R2126及以上版本不支持)

硬件版本:S9500交换机D类业务板

注意事项

l              灵活QinQ功能只有D类单板能够支持;

l              因为启用灵活QinQ的端口只允许VLAN Tag修改后的报文通过,为了使从端口进入的各种VLAN的数据可以被处理,需要把端口的VLAN过滤功能关闭;

l              为了让通过灵活QinQ增加VLAN Tag的报文的回应报文在出端口(连接DSLAM的端口)去掉外层Tag,需要把端口设置为hybrid端口,使端口对应外层Tag的VLAN为untagged模式。

配置举例

4.1  组网需求

图4-1所示,DSLAM上通过VLAN隔离每个用户,VLAN 1000~1999为普通上网业务,要求到达S9500后增加外层Tag 101送BRAS处理;VLAN 2000~2999为VIP用户,需要进行Qos保证,要求到达S9500后增加外层Tag 102送BRAS处理;BTV业务由GSR通过VLAN 3000送到DSLAM,由DSLAM进行组播复制,把组播流复制到用户VLAN。

实现以上业务,S9500需要对端口g2/1/1进入的vlanID为1000~1999的报文增加Tag 101后通过VLAN 101转发到BRAS处理;vlanID为2000~2999的报文增加Tag 102后通过VLAN 102转发到BRAS处理;vlanID为3000的报文则不增加Tag,可以在VLAN 3000进行二层组播报文转发。针对这种需求,S9500可以使用灵活QinQ的功能来实现。

4.2  组网图

图4-1 灵活QinQ典型配置示意图

4.3  配置步骤

(1)        配置DSLAM设备

DSLAM设置上网用户映射到VLAN 10002999;配置组播VLAN 3000,组播子VLANVLAN 1000-2999;上行口连接S9500,要求允许VLAN 10003000通过。

(2)        配置S9500设备

# 配置匹配VLAN 10001999VLAN 2000~2999ACL

[S9500] acl number 4000

[S9500-acl-link-4000] rule 0 permit ingress 1000 to 1999

[S9500-acl-link-4000] rule 1 permit ingress 2000 to 2999

# 创建VLAN 101、102和3000。

[S9500] vlan 101 102 3000

# 配置连接DSLAM的端口,端口允许VLAN 101、102和VLAN 3000通过,取消端口的VLAN过滤属性,配置nested-vlan使匹配ACL 4000 rule 0的报文增加VLAN Tag 101、使匹配ACL 4000 rule 1的报文增加VLAN Tag 102。

[S9500] interface GigabitEthernet 2/1/1

[S9500-GigabitEthernet2/1/1] port link-type hybrid

[S9500-GigabitEthernet2/1/1] port hybrid vlan 101 102 untagged

[S9500-GigabitEthernet2/1/1] port hybrid vlan 3000 tagged

[S9500-GigabitEthernet2/1/1] vlan filter disable

[S9500-GigabitEthernet2/1/1] traffic-redirect inbound link-group 4000 rule 0 nested-vlan 101

[S9500-GigabitEthernet2/1/1] traffic-redirect inbound link-group 4000 rule 1 nested-vlan 102

# 分别配置连接GSR和BRAS的端口。

[S9500] interface g2/1/2

[S9500-GigabitEthernet2/1/2] port link-type trunk

[S9500-GigabitEthernet2/1/2] port trunk permit vlan 3000

[S9500-GigabitEthernet2/1/2] interface g2/1/3

[S9500-GigabitEthernet2/1/3] port link-type trunk

[S9500-GigabitEthernet2/1/3] port trunk permit vlan 101 102

# 在VLAN 3000上启用二层组播。

[S9500] igmp-snooping enable

[S9500] vlan 3000

[S9500-vlan3000] igmp-snooping enable

(3)        配置BRAS和GSR设备

配置BRAS可以处理带双VLAN Tag 的报文,并终结PPPOE报文。配置GSR启用三层组播,作为组播路由器。

4.4  完整配置

#

 igmp-snooping enable

#

acl number 4000

 rule 0 permit ingress 1000 to 1999 egress any

rule 1 permit ingress 2000 to 2999 egress any

#

vlan 1

#

vlan 101

#

vlan 102

#

vlan 3000

 igmp-snooping enable

#

interface GigabitEthernet2/1/1

 port link-type hybrid

 port hybrid vlan 3000 tagged

 port hybrid vlan 1 101 102 untagged

 vlan filter disable

 traffic-redirect inbound link-group 4000 rule 0 system-index 1 nested-vlan 101

traffic-redirect inbound link-group 4000 rule 1 system-index 2 nested-vlan 102

#

interface GigabitEthernet2/1/2

 port link-type trunk

 port trunk permit vlan 1 3000

#

interface GigabitEthernet2/1/3

 port link-type trunk

 port trunk permit vlan 1 101 102

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们