国家 / 地区

06-IP组播配置举例

05-H3C_S12500_IPv6组播VLAN典型配置举例

本章节下载  (180.89 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500/Configure/Typical_Configuration_Example/H3C_S12500-R7328P02-6W100/06/201411/845391_30005_0.htm

05-H3C_S12500_IPv6组播VLAN典型配置举例


1  简介

本文档介绍了基于子VLAN的IPv6组播VLAN的配置举例。

2  配置前提

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文假设您已了解IPv6 组播VLAN特性。

3  基于子VLAN的IPv6组播VLAN

3.1  组网需求

3.1.1  现网描述

图1所示,某楼层分布了两个不同的部门,通过在Switch B上配置不同的VLAN来区分这两个部门,其中用户VLAN 10、VLAN 20分别标识了部门1、部门2。交换机Switch A上配置了VLAN 10、VLAN 20对应的VLAN虚接口,分别作为用户VLAN的网关。

由于业务需要,部门1中有多台主机需要同时接收网络中某一发送源发送的数据。该企业采用了IPv6组播的传输方式:在Switch A的Vlan-interface10上运行MLDv1。同时为避免组播数据在数据链路层的广播问题,该企业在交换机Switch B的VLAN 10内开启了版本1的MLD Snooping功能。

图1 仅用户VLAN 10内有组播接收者的配置组网图

 

目前由于业务拓展,如图2所示,部门2内的用户主机同样需要接收该组播源发送的组播数据。为满足该业务需求,可以在Switch A的Vlan-interface20上运行MLDv1并在交换机Switch B的VLAN 20内开启版本1的MLD Snooping功能。按照这样方法进行配置会增加Switch A复制组播数据的工作负荷,并且在Switch A与Switch B之间的链路上会存在大量相同的组播数据。

为降低Switch A复制组播数据的工作负荷,同时提高Switch A与Switch B之间的链路带宽的有效利用率,考虑在Switch B上配置基于子VLAN的IPv6组播VLAN来实现上述需求。

图2 基于子VLAN的IPv6组播VLAN配置组网图

 

3.2  配置思路

·     分别在Switch A、Switch B上创建VLAN 30,配置Switch A、Switch B直连的端口允许VLAN 10、VLAN 20与VLAN 30的报文带Tag通过。

·     在Switch A上创建Vlan-interface30,并在Vlan-interface30上使能MLD功能。

·     使能Switch B上VLAN 10、VLAN 20与VLAN 30内的MLD Snooping功能。

·     在Switch B上将VLAN 30配置为IPv6组播VLAN,并将用户VLAN 10、VLAN 20配置为组播VLAN 30的子VLAN。

3.3  使用版本

本举例是在S12500-CMW710-R7328P02版本上进行配置和验证的。

3.4  配置注意事项

·     在已使能了IPv6组播路由的设备上不建议再配置IPv6组播VLAN。

·     请提前准备IPv6 组播VLAN对应的VLAN虚接口的IPv6地址,该地址仅需满足用户网络中IPv6地址的唯一性即可。

3.5  配置步骤

(1)     配置准备

# 配置交换机Switch A上Vlan-int10、Vlan-int20的接口地址,使之成为用户VLAN 10、VLAN 20的网关,具体配置过程略。

# 配置组播源与接收者之间的单播路由,并确保组播源到接受者的单播路由可达,具体配置过程略。

(2)     配置Switch A

# 使能IPv6组播路由功能。

<SwitchA> system-view

System View: return to User View with Ctrl+Z.

[SwitchA]ipv6 multicast routing

[SwitchA -mrib6]quit

# 创建VLAN 30,配置端口Ten-GigabitEthernet3/0/1允许VLAN 10VLAN 20VLAN 30的报文带Tag通过。

[SwitchA] vlan 30

[SwitchA-vlan30] quit

[SwitchA] interface ten-gigabitethernet 3/0/1

[SwitchA-Ten-GigabitEthernet3/0/1] port link-type hybrid

[SwitchA-Ten-GigabitEthernet3/0/1] port hybrid vlan 10 20 30 tagged

# 配置接口Vlan-interface30IPv6地址,并使能MLD功能。

[SwitchA] interface vlan-interface 30

[SwitchA-Vlan-interface30] ipv6 address 2001::1 64

[SwitchA-Vlan-interface30] mld enable

[SwitchA-Vlan-interface30] quit

# 创建VLAN 40,将端口Ten-GigabitEthernet3/0/2加入到该VLAN中。

[SwitchA] vlan 40

[SwitchA-vlan40] port ten-gigabitethernet 3/0/2

[SwitchA-vlan40] quit

# 配置接口Vlan-interface40IPv6地址,在该接口上配置IPv6 pim dm功能。

[SwitchA] interface vlan-interface 40

[SwitchA-Vlan-interface40] ipv6 address 1::1 64

[SwitchA-Vlan-interface40] ipv6 pim dm

[SwitchA-Vlan-interface40] quit

(1)     配置Switch B

# 全局使能MLD Snooping。

<SwitchB> system-view

[SwitchB] mld-snooping

[SwitchB-mld-snooping] quit

# 在VLAN 10内使能MLD Snooping

[SwitchB] vlan 10

[SwitchB-vlan10] mld-snooping enable

[SwitchB-vlan10] quit

# 在VLAN 20内使能MLD Snooping

[SwitchB] vlan 20

[SwitchB-vlan20] mld-snooping enable

[SwitchB-vlan20] quit

# 创建VLAN 30,在VLAN 30内使能MLD Snooping功能。

[SwitchB] vlan 30

[SwitchB-vlan30] mld-snooping enable

[SwitchB-vlan30] quit

# 配置端口Ten-GigabitEthernet3/0/1允许VLAN 10VLAN 20VLAN 30的报文带Tag通过。

[SwitchB] interface ten-gigabitethernet 3/0/1

[SwitchB-Ten-GigabitEthernet3/0/1] port link-type hybrid

[SwitchA-Ten-GigabitEthernet3/0/1] port hybrid vlan 10 20 30 tagged

# 配置VLAN 30为组播VLAN,并把VLAN 10VLAN 20都配置为该组播VLAN的子VLAN

[SwitchB] ipv6 multicast-vlan 30

[SwitchB-ipv6-mvlan-30] subvlan 10 20

[SwitchB-ipv6-mvlan-30] quit

3.6  验证配置

# 显示Switch B上所有IPv6组播VLAN的信息。

[SwitchB] display ipv6 multicast-vlan

Total 1 IPv6 multicast VLANs.

 

IPv6 multicast VLAN 30:

  Sub-VLAN list(2 in total):

     10,20

  Port list(0 in total):

# 显示Switch B上IPv6组播VLAN转发表项的信息。

[SwitchB] display ipv6 multicast-vlan group

Total 1 entries.

 

IPv6 multicast VLAN 30: Total 1 entries.

  (::, FF1E::101)

    Sub-VLANs (2 in total):

      VLAN 10

      VLAN 20

由此可见,IPv6组播VLAN(VLAN 30)在各子VLAN(VLAN 10、VLAN 20)内维护表项。

3.7  配置文件

·     Switch A:

#

vlan 10

#

vlan 20

#

vlan 30

#

vlan 40

#

interface Vlan-interface10

 ipv6 address 2002::1/64

#

interface Vlan-interface20

 ipv6 address 2003::1/64

#

interface Vlan-interface30

 ipv6 address 2001::1/64

 mld enable

#

interface Vlan-interface40

 ipv6 address 1::1/64

 ipv6 pim dm

#

interface Ten-GigabitEthernet3/0/1

 port link-mode bridge

port link-type hybrid

 port hybrid vlan 10 20 30 tagged

 port hybrid vlan 1 untagged

#

interface Ten-GigabitEthernet3/0/2

port link-mode bridge

port access vlan 40

#

ipv6 multicast routing

#

·     Switch B:

#

mld-snooping

#

vlan 10

 mld-snooping enable

#

vlan 20

 mld-snooping enable

#

vlan 30

 mld-snooping enable

#

ipv6 multicast-vlan 30

 subvlan 10 20

#

interface Ten-GigabitEthernet3/0/1

 port link-mode bridge

port link-type hybrid

port hybrid vlan 10 20 30 tagged

port hybrid vlan 1 untagged

#

interface Ten-GigabitEthernet3/0/2

 port link-mode bridge

 port access vlan 10

#

interface Ten-GigabitEthernet3/0/3

 port link-mode bridge

 port access vlan 10

#

interface Ten-GigabitEthernet3/0/4

 port link-mode bridge

 port access vlan 20

#

interface Ten-GigabitEthernet3/0/5

 port link-mode bridge

 port access vlan 20

#

4  相关资料

·     H3C S12500系列路由交换机 IP组播配置指导-Release 7328

·     H3C S12500系列路由交换机 IP组播命令参考-Release 7328

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部