选择区域语言: EN CN HK

04-三层技术-IP业务配置举例

03-H3C_S12500_GRE和OSPF结合使用典型配置举例

本章节下载  (157.59 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500/Configure/Typical_Configuration_Example/H3C_S12500-R7328P02-6W100/04/201411/845374_30005_0.htm

03-H3C_S12500_GRE和OSPF结合使用典型配置举例


1  简介

本文档介绍了GRE隧道和OSPF相结合使用的典型配置举例。

2  配置前提

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文假设您已了解GRE隧道和OSPF的相关特性。

3  配置举例

3.1  组网需求

图1所示,Device A为某机构总部网关,Device B和Device C为分支网关,运营商为各网关分配了公网IP地址,并保证网关之间可以通信,要求:

·     总部和分支之间建立GRE隧道,通过隧道使各总部、分支机构可以实现互访;

·     配置OSPF协议使网关上存在通过Tunnel接口到达目的地址的路由表项。

图1 GRE和OSPF结合使用典型配置举例组网图

 

 

设备

接口

IP地址

设备

接口

IP地址

Device A

Vlan-int 10

191.2.1.1/24

Device B

Vlan-int 10

191.3.1.1/24

 

Vlan-int 20

10.1.1.1/24

 

Vlan-int 20

10.7.1.1/24

 

Tunnel 1

10.5.1.1/24

 

Tunnel 1

10.5.1.2/24

 

Tunnel 2

10.6.1.1/24

 

 

 

Device C

Vlan-int 10

191.4.1.1/24

 

 

 

 

Vlan-int 20

10.8.1.1/24

 

 

 

 

Tunnel 2

10.6.1.2/24

 

 

 

 

3.2  使用版本

本举例是在S12500-CMW710-R7328P02版本上进行配置和验证的。

3.3  配置步骤

3.3.1  配置准备

配置网关设备之间的IPv4路由协议,确保设备之间IPv4报文能够正常交互,具体配置过程略。

3.3.2  配置Device A

# 配置接口Vlan-interface 10的IP地址。

<DeviceA> system-view

[DeviceA] vlan 10

[DeviceA-vlan 10] port gigabitethernet3/0/1

[DeviceA-vlan 10] quit

[DeviceA] interface vlan-interface 10

[DeviceA-Vlan-interface10] ip address 191.2.1.1 255.255.255.0

[DeviceA-Vlan-interface10] quit

# 请参考以上方法配置上图中Device A其它接口的IP地址,配置步骤这里省略。

# 创建Tunnel1接口,并指定隧道模式为GRE over IPv4隧道。

[DeviceA] interface tunnel 1 mode gre

# 配置Tunnel1接口的IP地址。

[DeviceA-Tunnel1] ip address 10.5.1.1 24

# 配置Tunnel1接口的源接口为Vlan-interface 10。

[DeviceA-Tunnel1] source vlan-interface 10

# 配置Tunnel1接口的目的端地址。

[DeviceA-Tunnel1] destination 191.3.1.1

[DeviceA-Tunnel1] quit

# 创建Tunnel2接口,并指定隧道模式为GRE over IPv4隧道。

[DeviceA] interface tunnel 2 mode gre

# 配置Tunnel2接口的IP地址。

[DeviceA-Tunnel2] ip address 10.6.1.1 24

# 配置Tunnel2接口的源接口为Vlan-interface 10。

[DeviceA-Tunnel2] source vlan-interface 10

# 配置Tunnel2接口的目的端地址。

[DeviceA-Tunnel2] destination 191.4.1.1

[DeviceA-Tunnel2] quit

# 启动OSPF,并配置其Router ID10.6.1.1

[DeviceA] router-id 10.6.1.1

[DeviceA] ospf 1

[DeviceA-ospf-1] area 0

[DeviceA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255

[DeviceA-ospf-1-area-0.0.0.0] network 10.5.1.0 0.0.0.255

[DeviceA-ospf-1-area-0.0.0.0] network 10.6.1.0 0.0.0.255

3.3.3  配置Device B

# 配置接口Vlan-interface 10的IP地址。

<DeviceB> system-view

[DeviceB] vlan 10

[DeviceB-vlan 10] port gigabitethernet3/0/1

[DeviceB-vlan 10] quit

[DeviceB] interface vlan-interface 10

[DeviceB-Vlan-interface10] ip address 191.3.1.1 255.255.255.0

[DeviceB-Vlan-interface10] quit

# 请参考以上方法配置上图中Device B其它接口的IP地址,配置步骤这里省略。

# 创建Tunnel1接口,并指定隧道模式为GRE over IPv4隧道。

[DeviceB] interface tunnel 1 mode gre

# 配置Tunnel1接口的IP地址。

[DeviceB-Tunnel1] ip address 10.5.1.2 24

# 配置Tunnel1接口的源接口为Vlan-interface 10

[DeviceB-Tunnel1] source vlan-interface 10

# 配置Tunnel1接口的目的端地址。

[DeviceB-Tunnel1] destination 191.2.1.1

[DeviceB-Tunnel1] quit

# 启动OSPF,并配置其Router ID10.7.1.1

[DeviceB] router-id 10.7.1.1

[DeviceB] ospf 1

[DeviceB-ospf-1] area 0

[DeviceB-ospf-1-area-0.0.0.0] network 10.7.1.0 0.0.0.255

[DeviceB-ospf-1-area-0.0.0.0] network 10.5.1.0 0.0.0.255

3.3.4  配置Device C

# 配置接口Vlan-interface 10的IP地址。

<DeviceC> system-view

[DeviceC] vlan 10

[DeviceC-vlan 10] port gigabitethernet3/0/1

[DeviceC-vlan 10] quit

[DeviceC] interface vlan-interface 10

[DeviceC-Vlan-interface10] ip address 191.4.1.1 255.255.255.0

[DeviceC-Vlan-interface10] quit

# 请参考以上方法配置上图中Device C其它接口的IP地址,配置步骤这里省略。

# 创建Tunnel2接口,并指定隧道模式为GRE over IPv4隧道。

[DeviceC] interface tunnel 2 mode gre

# 配置Tunnel2接口的IP地址。

[DeviceC-Tunnel2] ip address 10.6.1.2 24

# 配置Tunnel1接口的源接口为Vlan-interface 10。

[DeviceC-Tunnel2] source vlan-interface 10

# 配置Tunnel2接口的目的端地址。

[DeviceC-Tunnel2] destination 191.2.1.1

[DeviceC-Tunnel2] quit

# 启动OSPF,并配置其Router ID10.8.1.1

[DeviceC] router-id 10.8.1.1

[DeviceC] ospf 1

[DeviceC-ospf-1] area 0

[DeviceC-ospf-1-area-0.0.0.0] network 10.8.1.0 0.0.0.255

[DeviceC-ospf-1-area-0.0.0.0] network 10.6.1.0 0.0.0.255

3.4  验证配置

(1)     从Host A可以pingHost B

C:\> ping 10.7.1.2

 

Pinging 10.7.1.2 with 32 bytes of data:

 

Reply from 10.7.1.2: bytes=32 time=19ms TTL=253

Reply from 10.7.1.2: bytes=32 time<1ms TTL=253

Reply from 10.7.1.2: bytes=32 time<1ms TTL=253

Reply from 10.7.1.2: bytes=32 time<1ms TTL=253

 

Ping statistics for 10.7.1.2:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 19ms, Average = 4ms

 

(2)     从Host A可以pingHost C

C:\> ping 10.8.1.2

 

Pinging 10.8.1.2 with 32 bytes of data:

 

Reply from 10.8.1.2: bytes=32 time=18ms TTL=253

Reply from 10.8.1.2: bytes=32 time<1ms TTL=253

Reply from 10.8.1.2: bytes=32 time<1ms TTL=253

Reply from 10.8.1.2: bytes=32 time<1ms TTL=253

 

Ping statistics for 10.8.1.2:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 19ms, Average = 4ms

(3)     从Host B可以pingHost C

C:\> ping 10.8.1.2

 

Pinging 10.8.1.2 with 32 bytes of data:

 

Reply from 10.8.1.2: bytes=32 time=20ms TTL=251

Reply from 10.8.1.2: bytes=32 time<1ms TTL=251

Reply from 10.8.1.2: bytes=32 time<1ms TTL=251

Reply from 10.8.1.2: bytes=32 time<1ms TTL=251

 

Ping statistics for 10.8.1.2:

Packets: Sent = 4, Received = 4, Lost = 0 0% loss,

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 19ms, Average = 4ms

3.5  配置文件

·     Device A

#

vlan 10

#

vlan 20

#

interface GigabitEthernet3/0/1

 port link-mode bridge

 port access vlan 10

#

interface GigabitEthernet3/0/2

 port link-mode bridge

 port access vlan 20

#

interface Vlan-interface 10

 port link-mode route

 ip address 191.2.1.1 255.255.255.0

#

interface Vlan-interface 20

 port link-mode route

 ip address 10.1.1.1 255.255.255.0

#

interface Tunnel1 mode gre

 source Vlan-interface 10

 destination 191.3.1.1

 ip address 10.5.1.1 255.255.255.0

#

interface Tunnel2 mode gre

 source Vlan-interface 10

 destination 191.4.1.1

 ip address 10.6.1.1 255.255.255.0

#

ospf 1

 area 0.0.0.0

network 10.1.1.0 0.0.0.255

network 10.5.1.0 0.0.0.255

network 10.6.1.0 0.0.0.255

#

·     Device B

#

vlan 10

#

vlan 20

#

interface GigabitEthernet3/0/1

 port link-mode bridge

 port access vlan 10

#

interface GigabitEthernet3/0/2

 port link-mode bridge

 port access vlan 20

#

interface Vlan-interface 10

 port link-mode route

 ip address 191.3.1.1 255.255.255.0

#

interface Vlan-interface 20

 port link-mode route

 ip address 10.7.1.1 255.255.255.0

#

interface Tunnel1 mode gre

 source Vlan-interface 10

 destination 191.2.1.1

 ip address 10.5.1.2 255.255.255.0

#

ospf 1

 area 0.0.0.0

network 10.7.1.0 0.0.0.255

network 10.5.1.0 0.0.0.255

#

 

·     Device C

#

vlan 10

#

vlan 20

#

interface GigabitEthernet3/0/1

 port link-mode bridge

 port access vlan 10

#

interface GigabitEthernet3/0/2

 port link-mode bridge

 port access vlan 20

#

interface Vlan-interface 10

 port link-mode route

 ip address 191.4.1.1 255.255.255.0

#

interface Vlan-interface 20

 port link-mode route

 ip address 10.8.1.1 255.255.255.0

#

interface Tunnel2 mode gre

 source Vlan-interface 10

 destination 191.2.1.1

 ip address 10.6.1.2 255.255.255.0

#

ospf 1

 area 0.0.0.0

network 10.8.1.0 0.0.0.255

network 10.6.1.0 0.0.0.255

#

4  相关资料

·     H3C S12500系列路由交换机 三层技术-IP业务配置指导-Release 7328

·     H3C S12500系列路由交换机 三层技术-IP业务命令参考-Release 7328

·     H3C S12500系列路由交换机 三层技术-IP路由配置指导-Release 7328

·     H3C S12500系列路由交换机 三层技术-IP路由命令参考-Release 7328

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!