选择区域语言: EN CN HK

04-三层技术-IP业务配置举例

02-H3C_S12500_ISATAP和6to4相结合使用的典型配置举例

本章节下载  (193.5 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500/Configure/Typical_Configuration_Example/H3C_S12500-R7328P02-6W100/04/201411/845373_30005_0.htm

02-H3C_S12500_ISATAP和6to4相结合使用的典型配置举例


1  简介

本文档介绍了ISATAP隧道和6to4隧道相结合使用的典型配置举例。

2  配置前提

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文假设您已了解ISATAP隧道和6to4隧道的相关特性。

3  ISATAP隧道和6to4隧道相结合使用的典型配置举例

3.1  组网需求

图1所示,要求:

·     通过配置6to4隧道使各6to4网络分支机构与总部中的主机能够互通。

·     Device A提供ISATAP接入服务使一些IPv4网络中的双协议栈主机可以访问总部。

图1 ISATAP隧道和6to4隧道相结合使用的配置组网图

设备

接口

IP地址

设备

接口

IP地址

Device A

Vlan-int10

2.1.1.1/24

Device B

Vlan-int10

3.1.1.1/24

 

Vlan-int20

2002:0201:0101:1::1/64

 

Vlan-int20

2002:0301:0101:1::1/64

 

Vlan-int30

2002:0201:0101:2::1/64

 

Vlan-int30

2002:0301:0101:2::1/64

 

Tunnel 1

3001::1/64

 

Tunnel 1

3001::2/64

 

Tunnel 2

2001::5EFE:0201:0101/64

 

 

 

 

3.2  配置思路

·     组网中的6to4网络可以表示为2002:IPv4地址::/64,其中内嵌在IPv6地址中的IPv4地址作为6to4隧道中封装后的IPv4报文头中的目的IP地址。

·     组网中的ISATAP主机地址的IPv6前缀可通过向ISATAP路由器发送请求得到,IPv4地址作为接口ID,其格式为:Prefix:0:5EFE:IPv4-destination-address。该IPv4地址可以作为ISATAP隧道的目的端地址。

·     为保证同一网络中的主机使用相同的地址前缀,在Device A和Device B上取消对RA消息发布的抑制,使得网络中的主机可以通过Device A和Device B发布的RA消息获取地址前缀等信息。

3.3  使用版本

本举例是在S12500-CMW710-R7328P02版本上进行配置和验证的。

3.4  配置步骤

说明

配置之前,请确保网关设备之间IPv4报文路由可达。

 

(1)     配置Device A

# 配置接口Vlan-interface10的IP地址。

<DeviceA> system-view

[DeviceA] vlan 10

[DeviceA-vlan10] port GigabitEthernet 1/0/1

[DeviceA-vlan10] quit

[DeviceA] interface vlan-interface 10

[DeviceA-Vlan-interface10] ip address 2.1.1.1 24

[DeviceA-Vlan-interface10] quit

# 请参考以上方法配置图1中Device A其它接口的IP地址,配置步骤这里省略。

# 创建模式为6to4隧道的接口Tunnel1。

[DeviceA] interface tunnel 1 mode ipv6-ipv4 6to4

# 配置Tunnel1接口的IPv6地址。

[DeviceA-Tunnel1] ipv6 address 3001::1/64

# 配置Tunnel1接口的源接口为Vlan-interface10(封装后的IPv4报文头中的源IP地址为配置的源接口的IP地址)。

[DeviceA-Tunnel1] source vlan-interface 10

[DeviceA-Tunnel1] quit

# 配置到目的地址2002:0301:0101::/48,下一跳为Tunnel1接口的静态路由。

[DeviceA] ipv6 route-static 2002:0301:0101:: 48 tunnel 1

# 创建模式为ISATAP隧道的接口Tunnel2。

[DeviceA] interface tunnel 2 mode ipv6-ipv4 isatap

# 配置Tunnel2接口的IPv6地址。

[DeviceA-Tunnel2] ipv6 address 2001::5EFE:0201:0101 64

# 配置Tunnel2接口的源接口为Vlan-interface10(封装后的IPv4报文头中的源IP地址为配置的源接口的IP地址)。

[DeviceA-Tunnel2] source  vlan-interface 10

[DeviceA-Tunnel2] quit

# 配置到目的地址2001::/16,下一跳为Tunnel2接口的静态路由。

[DeviceA] ipv6 route-static 2001:: 16 tunnel 2

# 取消对RA消息发布的抑制,使主机可以通过交换机发布的RA消息获取地址前缀等信息。

[DeviceA] interface Tunnel 2

[DeviceA-Tunnel2] undo ipv6 nd ra halt

[DeviceA-Tunnel2] quit

[DeviceA] interface vlan-interface 20

[DeviceA-Vlan-interface20] undo ipv6 nd ra halt

[DeviceA-Vlan-interface20] quit

[DeviceA] interface  vlan-interface 30

[DeviceA-Vlan-interface30] undo ipv6 nd ra halt

[DeviceA-Vlan-interface30] quit

(2)     配置Device B

# 配置接口Vlan-interface10的IP地址。

<DeviceB> system-view

[DeviceB] vlan 10

[DeviceB-vlan10] port GigabitEthernet 1/0/1

[DeviceB-vlan10] quit

[DeviceB] interface  vlan-interface 10

[DeviceB-Vlan-interface10] ip address 3.1.1.1 24

[DeviceB-Vlan-interface10] quit

# 请参考以上方法配置图1中Device B其它接口的IP地址,配置步骤这里省略。

# 创建模式为6to4隧道的接口Tunnel1。

[DeviceB] interface tunnel 1 mode ipv6-ipv4 6to4

# 配置Tunnel1接口的IPv6地址。

[DeviceB-Tunnel1] ipv6 address 3001::2/64

# 配置Tunnel1接口的源接口为Vlan-interface10(封装后的IPv4报文头中的源IP地址为配置的源接口的IP地址)。

[DeviceB-Tunnel1] source  vlan-interface 10

[DeviceB-Tunnel1] quit

# 配置到目的地址2002:0201:0101::/48,下一跳为Tunnel1接口的静态路由。

[DeviceB] ipv6 route-static 2002:0201:0101:: 48 tunnel 1

# 取消对RA消息发布的抑制,使主机可以通过交换机发布的RA消息获取地址前缀等信息。

[DeviceB] interface vlan-interface 20

[DeviceB-Vlan-interface20] undo ipv6 nd ra halt

[DeviceB-Vlan-interface20] quit

[DeviceB] interface vlan-interface 30

[DeviceB-Vlan-interface30] undo ipv6 nd ra halt

[DeviceB-Vlan-interface30] quit

(3)     配置ISATAP主机

ISATAP主机上的具体配置与主机的操作系统有关,下面仅以Windows XP操作系统为例进行说明。

# 在主机上安装IPv6协议。

C:\>ipv6 install

# 配置ISATAP隧道。

C:\>netsh interface ipv6 isatap set router 2.1.1.1

# 完成上述配置后,查看ISATAP接口的信息。

C:\>ipv6 if 2

Interface 2: Automatic Tunneling Pseudo-Interface

  Guid {48FCE3FC-EC30-E50E-F1A7-71172AEEE3AE}

  does not use Neighbor Discovery

  uses Router Discovery

  routing preference 1

  EUI-64 embedded IPv4 address: 1.1.1.2

  router link-layer address: 2.1.1.1

    preferred global 2001::5efe:1.1.1.2, life 29d23h59m46s/6d23h59m46s (public)

    preferred link-local fe80::5efe:1.1.1.2, life infinite

  link MTU 1500 (true link MTU 65515)

  current hop limit 255

  reachable time 42500ms (base 30000ms)

  retransmission interval 1000ms

  DAD transmits 0

  default site prefix length 48

我们可以看到主机获取了2001::/64的前缀,自动生成全球单播地址2001::5efe:1.1.1.2,同时还有一行信息“uses Router Discovery”表明主机启用了路由器发现。

# 查看主机上的IPv6路由信息。

C:\>ipv6 rt

2001::/64 -> 2 pref 1if+8=9 life 29d23h59m43s (autoconf)

::/0 -> 2/fe80::5efe:1.1.1.1 pref 1if+256=257 life 29m43s (autoconf)

3.5  验证配置

# 完成以上配置之后,Host A与Host B可以互相Ping通。

D:\>ping6 -s 2002:0201:0101:1::2 2002:0301:0101:1::2

 

Pinging 2002:0301:0101:1::2

from 2002:0201:0101:1::2 with 32 bytes of data:

 

Reply from 2002:0301:0101:1::2: bytes=32 time=13ms

Reply from 2002:0301:0101:1::2: bytes=32 time=1ms

Reply from 2002:0301:0101:1::2: bytes=32 time=1ms

Reply from 2002:0301:0101:1::2: bytes=32 time<1ms

 

Ping statistics for 2002:0301:0101:1::2:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum = 13ms, Average = 3ms

# 在ISATAP主机上Ping Host A的地址,可以Ping通。

C:\Documents and Settings\Administrator>pingv6 2002:0201:0101:1::2

 

Pinging 2002:0201:0101:1::2 with 32 bytes of data:

 

Reply from 2002:0201:0101:1::2: time=33ms

Reply from 2002:0201:0101:1::2: time=32ms

Reply from 2002:0201:0101:1::2: time=32ms

Reply from 2002:0201:0101:1::2: time=33ms

 

Ping statistics for 2002:0201:0101:1::2:

 Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

 Minimum = 32ms, Maximum = 33ms, Average = 32ms

3.6  配置文件

·     Device A

#

vlan 10

#

vlan 20

#

vlan 30

#

interface Vlan-interface10

 ip address 2.1.1.1 255.255.255.0

#

interface Vlan-interface20

 ipv6 address 2002:201:101:1::1/64

 undo ipv6 nd ra halt

#

interface Vlan-interface30

 ipv6 address 2002:201:101:2::1/64

 undo ipv6 nd ra halt

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port access vlan 10

#

interface GigabitEthernet1/0/2

 port link-mode bridge

 port access vlan 20

#

interface GigabitEthernet1/0/3

 port link-mode bridge

 port access vlan 30

#

interface Tunnel1 mode ipv6-ipv4 6to4

 source Vlan-interface10

 ipv6 address 3001::1/64

#

interface Tunnel2 mode ipv6-ipv4 isatap

 source Vlan-interface10

 ipv6 address 2001::5EFE:201:101/64

 undo ipv6 nd ra halt

#

 ipv6 route-static 2001:: 16 Tunnel2

 ipv6 route-static 2002:301:101:: 48 Tunnel1

#                               

·     Device B

#

vlan 10

#

vlan 20

#

vlan 30

#

interface Vlan-interface10

 ip address 3.1.1.1 255.255.255.0

#

interface Vlan-interface20

 ipv6 address 2002:301:101:1::1/64

 undo ipv6 nd ra halt

#

interface Vlan-interface30

 ipv6 address 2002:301:101:2::1/64

 undo ipv6 nd ra halt

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port access vlan 10

#

interface GigabitEthernet1/0/2

 port link-mode bridge

 port access vlan 20

#

interface GigabitEthernet1/0/3

 port link-mode bridge

 port access vlan 30

#

interface Tunnel1 mode ipv6-ipv4 6to4

 source Vlan-interface10

 ipv6 address 3001::2/64

#

 ipv6 route-static 2002:201:101:: 48 Tunnel1

#

4  相关资料

·     H3C S12500系列路由交换机 三层技术-IP业务配置指导-Release 7328

·     H3C S12500系列路由交换机 三层技术-IP业务命令参考-Release 7328

 

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!