10-High availability

HomeSupportResource CenterH3C Access Controllers Configuration Examples(V7)-6W10210-High availability
Table of Contents
Related Documents
16-Dual-Link Backup OAuth-Based Portal Authentication in Centralized Forwarding Configuration Examples

 

H3C Access Controllers

Comware 7 Dual-Link Backup OAuth-Based Portal Authentication in Centralized Forwarding

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example for configuring OAuth-based portal authentication in a dual-link backup network enabled with centralized forwarding.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of WLAN high availability, AAA, portal, and WLAN access.

Example: Configuring OAuth-based portal authentication for dual-link AC backup and centralized forwarding

Network configuration

As shown in Figure 1, the AP and the client obtain IP addresses from the DHCP server. The IMC server acts as the portal authentication server, portal Web server, and RADIUS server.

Configure the devices to meet the following requirements:

·     The AP associates with both ACs and the two ACs to back up each other. When the master AC fails, the backup AC takes over, and the AP can provide services correctly through the backup AC.

·     Before passing portal authentication, the client can access only the portal Web server. After passing the authentication, the client can access other network resources.

·     The client can access network resources through any Layer 2 ports in its access VLAN without re-authentication.

·     The IMC server can dynamically modify user authorization information and log off clients.

Figure 1 Network diagram

 

Analysis

·     To allow an authenticated user to access network resources on any Layer 2 ports in its access VLAN without re-authentication, you must enable the portal roaming feature.

·     To avoid possible authentication failure caused by frequent logins and logouts of portal clients in a short time, disable the Rule ARP entry feature.

·     To allow the RADIUS server to modify user authorization information and log off users, enable the RADIUS session-control feature.

·     For dual-link backup to operate correctly, you must configure manual AP or auto AP settings on both ACs. This ensures that the AP can establish CAPWAP tunnels with both ACs.

Software versions used

This configuration example was created and verified on B064D029SP26.

Restrictions and guidelines

When you configure OAuth-based portal authentication for dual-link AC backup and centralized forwarding, follow these restrictions and guidelines:

·     Use the serial ID labeled on the AP's rear panel to specify an AP.

·     If you configure manual APs, make sure the manual APs configured on the two ACs have the same AP name and identifier (serial ID or MAC address).

Procedures

Configuring AC 1

1.     Configure VLANs and interfaces:

# Create VLAN 100 and VLAN-interface 100. Assign the VLAN interface an IP address. The AC will use this IP address to establish a CAPWAP tunnel with the AP.

<AC1> system-view

[AC1] vlan 100

[AC1-vlan100] quit

[AC1] interface vlan-interface 100

[AC1-Vlan-interface100] ip address 2.2.1.1 24

[AC1-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200. Assign the VLAN interface an IP address. This VLAN will be used for wireless client access.

[AC1] vlan 200

[AC1-vlan200] quit

[AC1] interface vlan-interface 200

[AC1-Vlan-interface200] ip address 2.2.2.1 24

[AC1-Vlan-interface200] quit

2.     Configure a static route to the IMC server.

[AC1] ip route-static 192.168.0.0 255.255.0.0 2.2.2.100

3.     Configure DNS server settings. (Details not shown.)

4.     Configure wireless services:

# Create service template st1 and enter its view.

[AC1] wlan service-template st1

# Specify the SSID as service.

[AC1-wlan-st-st1] ssid service

# Assign clients coming online through the service template to VLAN 200.

[AC1-wlan-st-st1] vlan 200

[AC1-wlan-st-st1] quit

# Create an AP named office, and specify the AP model and serial ID.

[AC1] wlan ap office model WA5320

[AC1-wlan-ap-office] serial-id 219801A0CNC138011454

# Enter radio view of radio 2.

[AC1-wlan-ap-office] radio 2

# Bind service template st1 to radio 2 and enable the radio.

[AC1-wlan-ap-office-radio-2] service-template st1

[AC1-wlan-ap-office-radio-2] radio enable

[AC1-wlan-ap-office-radio-2] quit

5.     Configure dual-link backup:

# Set the AP connection priority for the AC to 7.

[AC1-wlan-ap-office] priority 7

# Enable master CAPWAP tunnel preemption.

[AC1-wlan-ap-office] wlan tunnel-preempt enable

# Specify AC 2 as the backup AC for AC 1.

[AC1-wlan-ap-office] backup-ac ip 2.2.1.2

[AC1-wlan-ap-office] quit

6.     Configure portal authentication:

# Create domain dm1 and enter its view.

[AC1] domain dm1

# Configure the authentication, authorization, and accounting methods as none for portal users.

[AC1-isp-dm1] authentication portal none

[AC1-isp-dm1] authorization portal none

[AC1-isp-dm1] accounting portal none

[AC1-isp-dm1] quit

# Create a portal Web server named newpt, specify the server's URL as http://192.168.0.111/wsmAuth/protocol, and specify the server type as OAuth.

[AC1] portal web-server newpt

[AC1-portal-websvr-newpt] url http://192.168.0.111:8080/wsmAuth/protocol

[AC1-portal-websvr-newpt] server-type oauth

# Enable the optimized captive-bypass feature for iOS users.

[AC1-portal-websvr-newpt] captive-bypass ios optimize enable

[AC1-portal-websvr-newpt] quit

# Create an HTTP-based local portal Web service and enter its view.

[AC1] portal local-web-server http

[AC1-portal-local-websvr-http] quit

# Configure destination-based portal-free rule to permit traffic to the DNS server.

[AC1] portal free-rule 2 destination ip any udp 53

[AC1] portal free-rule 3 destination ip any tcp 53

# Configure portal safe-redirect to reduce the workload of the authentication server.

[AC1] portal safe-redirect enable

[AC1] portal safe-redirect method get post

[AC1] portal safe-redirect user-agent CaptiveNetworkSupport

[AC1] portal safe-redirect user-agent MicroMessenger

[AC1] portal safe-redirect user-agent Mozilla

[AC1] portal safe-redirect user-agent WeChat

[AC1] portal safe-redirect user-agent iPhone

[AC1] portal safe-redirect user-agent micromessenger

# Specify the NAS-ID. Make sure the NAS-ID is the same as the ID in file iMC\client\conf\wiportal\conf.properties.

[AC1] wlan global-configuration

[AC1-wlan-global-configuration] nas-id wiportal

[AC1-wlan-global-configuration] quit

# Set the user synchronization interval to 60 seconds for portal authentication using OAuth.

[AC1] portal oauth user-sync interval 60

# Configure a destination-based portal-free rule: specify the rule number as 0 and IP address as 192.168.0.111. This rule allows users to reach the portal Web server.

[AC1] portal free-rule 0 destination ip 192.168.0.111 32

# Configure a destination-based portal-free rule: specify the rule number as 1 and IP address as 2.2.2.1. This rule allows users to reach AC 1.

[AC1] portal free-rule 1 destination ip 2.2.2.1 32

# Configure a destination-based portal-free rule: specify the rule number as 4 and IP address as 2.2.2.2. This rule allows users to reach AC 2.

[AC1] portal free-rule 4 destination ip 2.2.2.2 32

# Enable intra-VLAN roaming for portal users.

[AC1] portal roaming enable

# Disable the Rule ARP entry feature for portal clients.

[AC1] undo portal refresh arp enable

# Enable RADIUS session control.

[AC1] radius session-control enable

# Enable direct IPv4 portal authentication for service template st1.

[AC1] wlan service-template st1

[AC1-wlan-st-st1] portal enable method direct

# Configure the authentication domain for IPv4 portal users as dm1 on service template st1.

[AC1-wlan-st-st1] portal domain dm1

# Apply portal Web server newpt to service template st1.

[AC1-wlan-st-st1] portal apply web-server newpt

# Enable portal temporary pass and set the temporary pass period to 300 seconds.

[AC1-wlan-st-st1] portal temp-pass period 300 enable

# On the service template, configure the BAS-IP attribute as 2.2.2.1 for portal packets sent to the portal authentication server.

[AC1-wlan-st-st1] portal bas-ip 2.2.2.1

# Enable the service template.

[AC1–wlan-st-st1] service-template enable

[AC1-wlan-st-st1] quit

Configuring AC 2

1.     Configure VLANs and interfaces:

# Create VLAN 100 and VLAN-interface 100. Assign the VLAN interface an IP address. The AC will use this IP address to establish a CAPWAP tunnel with the AP.

<AC2> system-view

[AC2] vlan 100

[AC2-vlan100] quit

[AC2] interface vlan-interface 100

[AC2-Vlan-interface100] ip address 2.2.1.2 24

[AC2-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200. Assign the VLAN interface an IP address. This VLAN will be used for wireless client access.

[AC2] vlan 200

[AC2-vlan200] quit

[AC2] interface vlan-interface 200

[AC2-Vlan-interface200] ip address 2.2.2.2 24

[AC2-Vlan-interface200] quit

2.     Configure a static route to the IMC server.

[AC2] ip route-static 192.168.0.0 255.255.0.0 2.2.2.100

3.     Configure DNS server settings. (Details not shown.)

4.     Configure wireless services:

# Create service template st1 and enter its view.

[AC2] wlan service-template st1

# Specify the SSID as service.

[AC2-wlan-st-st1] ssid service

# Assign clients coming online through the service template to VLAN 200.

[AC2-wlan-st-st1] vlan 200

[AC2-wlan-st-st1] quit

# Create an AP named office, and specify the AP model and serial ID.

[AC2] wlan ap office model WA5320

[AC2-wlan-ap-office] serial-id 219801A0CNC138011454

# Enter radio view of radio 2.

[AC2-wlan-ap-office] radio 2

# Bind service template st1 to radio 2 and enable the radio.

[AC2-wlan-ap-office-radio-2] service-template st1

[AC2-wlan-ap-office-radio-2] radio enable

[AC2-wlan-ap-office-radio-2] quit

5.     Configure dual-link backup:

# Set the AP connection priority for the AC to 6.

[AC2-wlan-ap-office] priority 6

# Enable master CAPWAP tunnel preemption.

[AC2-wlan-ap-office] wlan tunnel-preempt enable

# Specify AC 2 as the backup AC for AC 1.

[AC2-wlan-ap-office] backup-ac ip 2.2.1.1

[AC2-wlan-ap-office] quit

6.     Configure portal authentication:

# Create domain dm1 and enter its view.

[AC2] domain dm1

# Configure the authentication, authorization, and accounting methods as none for portal users.

[AC2-isp-dm1] authentication portal none

[AC2-isp-dm1] authorization portal none

[AC2-isp-dm1] accounting portal none

[AC2-isp-dm1] quit

# Create a portal Web server named newpt, specify the server's URL as http://192.168.0.111/wsmAuth/protocol, and specify the server type as OAuth. (The URL is for illustration only.)

[AC2] portal web-server newpt

[AC2-portal-websvr-newpt] url http://192.168.0.111:8080/wsmAuth/protocol

[AC2-portal-websvr-newpt] server-type oauth =

# Enable the optimized captive-bypass feature for iOS users.

[AC2-portal-websvr-newpt] captive-bypass ios optimize enable

[AC2-portal-websvr-newpt] quit

# Create an HTTP-based local portal Web service and enter its view.

[AC2] portal local-web-server http

[AC2-portal-local-websvr-http] quit

# Configure destination-based portal-free rule to permit traffic to the DNS server.

[AC2] portal free-rule 2 destination ip any udp 53

[AC2] portal free-rule 3 destination ip any tcp 53

# Configure portal safe-redirect to reduce the workload of the authentication server.

[AC2] portal safe-redirect enable

[AC2] portal safe-redirect method get post

[AC2] portal safe-redirect user-agent CaptiveNetworkSupport

[AC2] portal safe-redirect user-agent MicroMessenger

[AC2] portal safe-redirect user-agent Mozilla

[AC2] portal safe-redirect user-agent WeChat

[AC2] portal safe-redirect user-agent iPhone

[AC2] portal safe-redirect user-agent micromessenger

# Specify the NAS-ID. Make sure the NAS-ID is the same as the ID in file iMC\client\conf\wiportal\conf.properties.

[AC2] wlan global-configuration

[AC2-wlan-global-configuration] nas-id wiportal

[AC2-wlan-global-configuration] quit

# Set the user synchronization interval to 60 seconds for portal authentication using OAuth.

[AC2] portal oauth user-sync interval 60

# Configure a destination-based portal-free rule: specify the rule number as 0 and IP address as 192.168.0.111. This rule allows users to reach the portal Web server.

[AC2] portal free-rule 0 destination ip 192.168.0.111 32

# Configure a destination-based portal-free rule: specify the rule number as 1 and IP address as 2.2.2.1. This rule allows users to reach AC 1.

[AC2] portal free-rule 1 destination ip 2.2.2.1 32

# Configure a destination-based portal-free rule: specify the rule number as 4 and IP address as 2.2.2.2. This rule allows users to reach AC 2.

[AC2] portal free-rule 4 destination ip 2.2.2.2 32

# Enable intra-VLAN roaming for portal users.

[AC2] portal roaming enable

# Disable the Rule ARP entry feature for portal clients.

[AC2] undo portal refresh arp enable

# Enable validity check on wireless portal clients.

[AC2] radius session-control enable

# Enable direct IPv4 portal authentication for service template st1.

[AC2] wlan service-template st1

[AC2-wlan-st-st1] portal enable method direct

# Configure the authentication domain for IPv4 portal users as dm1 on service template st1.

[AC2-wlan-st-st1] portal domain dm1

# Apply portal Web server newpt to service template st1.

[AC2-wlan-st-st1] portal apply web-server newpt

# Enable portal temporary pass and set the temporary pass period to 300 seconds.

[AC2-wlan-st-st1] portal temp-pass period 300 enable

# On the service template, configure the BAS-IP attribute as 2.2.2.2 for portal packets sent to the portal authentication server.

[AC2-wlan-st-st1] portal bas-ip 2.2.2.2

# Enable the service template.

[AC2–wlan-st-st1] service-template enable

[AC2-wlan-st-st1] quit

Configuring the switch

# Create VLAN 100 for forwarding CAPWAP tunnel traffic between AC and AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# Create VLAN 200 for forwarding client traffic.

[Switch] vlan 200

[Switch-vlan200] quit

# Create VLAN 2 for forwarding client traffic.

[Switch] vlan 2

[Switch-vlan2] quit

# Add the interface that connects the switch to the IMC server to VLAN 2. (Details not shown.)

# Configure GigabitEthernet 1/0/1 that connects the switch to AC 1 as a trunk port, and assign it to VLAN 100 and VLAN 200.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 that connects the switch to the AP as an access port, and assign the interface to VLAN 100.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# Enable PoE on GigabitEthernet 1/0/2.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

# Configure GigabitEthernet 1/0/3 that connects the switch to the AC 2 as a trunk port, and assign the interface to VLAN 100 and VLAN 200.

[Switch] interface gigabitethernet 1/0/3

[Switch-GigabitEthernet1/0/3] port link-type trunk

[Switch-GigabitEthernet1/0/3] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/3] quit

# Configure GigabitEthernet 1/0/4 that connects the switch to the DHCP server as a trunk port, and assign it to VLAN 100 and VLAN 200.

[Switch] interface gigabitethernet 1/0/4

[Switch-GigabitEthernet1/0/4] port link-type trunk

[Switch-GigabitEthernet1/0/4] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/4] quit

# Assign an IP address to VLAN-interface 200.

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 2.2.2.100 255.255.255.0

[Switch-Vlan-interface200] quit

# Assign an IP address to VLAN-interface 2.

[Switch] interface vlan-interface 2

[Switch-Vlan-interface2] ip address 192.168.0.100 255.255.255.0

[Switch-Vlan-interface2] quit

Configuring the DHCP server

# Configure GigabitEthernet 1/0/1 that connects the server to the switch as a trunk port, and assign the interface to VLAN 100 and VLAN 200.

[DHCP] interface gigabitethernet 1/0/1

[DHCP-GigabitEthernet1/0/1] port link-type trunk

[DHCP-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[DHCP-GigabitEthernet1/0/1] quit

# Assign an IP address to VLAN-interface 100.

[DHCP] interface vlan-interface 100

[DHCP-Vlan-interface100] ip address 2.2.1.200 255.255.255.0

[DHCP-Vlan-interface100] quit

# Assign an IP address to VLAN-interface 200.

[DHCP] interface vlan-interface 200

[DHCP-Vlan-interface200] ip address 2.2.2.200 255.255.255.0

[DHCP-Vlan-interface200] quit

# Enable DHCP.

[DHCP] dhcp enable

# Create a DHCP address pool named VLAN100, specify the DHCP server as the gateway, and exclude AC and DHCP server addresses from dynamic allocation. The server will use this address pool to assign address to the AP.

[DHCP] dhcp server ip-pool VLAN100

[DHCP-dhcp-pool-vlan100] gateway-list 2.2.1.200

[DHCP-dhcp-pool-vlan100] network 2.2.1.0 mask 255.255.255.0

[DHCP-dhcp-pool-vlan100] forbidden-ip 2.2.1.1 2.2.1.2

[DHCP-dhcp-pool-vlan100] quit

# Create a DHCP address pool named VLAN200, specify the switch as the gateway, specify the DNS server address as 8.8.8.8, and exclude AC and DHCP server addresses from dynamic allocation. The server will use this address pool to assign address to the client.

[DHCP] dhcp server ip-pool VLAN200

[DHCP-dhcp-pool-vlan200] gateway-list 2.2.2.100

[DHCP-dhcp-pool-vlan200] network 2.2.2.0 mask 255.255.255.0

[DHCP-dhcp-pool-vlan200] dns-list 8.8.8.8

[DHCP-dhcp-pool-vlan200] forbidden-ip 2.2.2.100 2.2.2.1 2.2.2.2

[DHCP-dhcp-pool-vlan200] quit

Configuring the IMC server

In this example, the IMC server runs IMC PLAT 7.3 (E0605) and IMC IPM 7.3 (E0516).

To configure the IMC server:

1.     Add an access user:

a.     Log in to IMC and click the Service tab.

b.     From the navigation tree, select Intelligent Portal Management > User Management > Users.

c.     Click Add to open the Add User page.

d.     Enter username Client and password admin@123.

e.     Use the default settings for other parameters.

f.     Click OK.

Figure 2 Adding an access user

 

2.     Add an authentication page template:

a.     From the navigation tree, select Intelligent Portal Management > Page Template List.

b.     Click Add to open the Add Theme page.

c.     Enter template name theme in the Theme Name field.

d.     Use the default settings for other parameters.

e.     Click OK to open the page for editing the template.

Figure 3 Adding an authentication page template

 

f.     On the theme page, click the Authentication icon  in the Basic Controls area.

g.     Click Edit in authentication edit area, select Other and Account in the Authentication Method area, click OK, and then click Save Page.

h.     Use the default settings for other configuration.

i.     Click Confirm Release.

Figure 4 Editing the template

 

3.     Add an authentication policy:

a.     From the navigation tree, select Intelligent Portal Management > Authentication Policies.

b.     Click Add to open the Add Authentication Policy page.

c.     Enter authentication policy name policy1, and select theme from the Page Template list.

d.     Use the default settings for other parameters.

e.     Click OK.

Figure 5 Adding an authentication policy

 

4.     Add a site:

a.     From the navigation tree, select Intelligent Portal Management > Site Management.

b.     Click Add to open the Add Site page.

c.     Enter the site name, the site address, the expected number of clients to be supported, and the telephone number.

d.     Click OK.

Figure 6 Adding a site

 

e.     In the Associated APs area, click Add to associate an AP.

f.     Enter the serial number and MAC address of the AP.

g.     Click OK.

Figure 7 Adding an AP

 

i.     In the Bind Authentication Policy area, click Add to bind the AP to an authentication policy.

j.     Select authentication policy policy1.

k.     Use the default settings for other parameters.

l.     Click OK.

Figure 8 Binding the AP to an authentication policy

 

Verifying the configuration

# Make the AP come online.

# Verify that the AP state is R/M on AC 1 and R/B on AC 2.

<AC1> display wlan ap all

Total number of APs: 38

Total number of connected APs: 35

Total number of connected manual APs: 35

Total number of connected auto APs: 0

Total number of connected common APs: 9

Total number of connected WTUs: 23

Total number of inside APs: 0

Maximum supported APs: 6144

Remaining APs: 6112

Total AP licenses: 2048

Local AP licenses: 2048

Server AP licenses: 0

Remaining Local AP licenses: 2033.25

Sync AP licenses: 0

                                 AP information

 State : I = Idle,      J  = Join,       JA = JoinAck,    IL = ImageLoad

         C = Config,    DC = DataCheck,  R  = Run,   M = Master,  B = Backup

AP name                        APID  State Model           Serial ID

office                         1     R/M   WA5320          219801A0CNC138011454

<AC2> display wlan ap all

Total number of APs: 38

Total number of connected APs: 35

Total number of connected manual APs: 35

Total number of connected auto APs: 0

Total number of connected common APs: 9

Total number of connected WTUs: 23

Total number of inside APs: 0

Maximum supported APs: 6144

Remaining APs: 6112

Total AP licenses: 2048

Local AP licenses: 2048

Server AP licenses: 0

Remaining Local AP licenses: 2033.25

Sync AP licenses: 0

                                 AP information

 State : I = Idle,      J  = Join,       JA = JoinAck,    IL = ImageLoad

         C = Config,    DC = DataCheck,  R  = Run,   M = Master,  B = Backup

AP name                        APID  State Model           Serial ID

office                         1     R/B   WA5320          219801A0CNC138011454

# Verify that all Web requests are redirected to the portal authentication page (http://192.168.0.111:8080/portal) before you pass portal authentication, and you can access Internet resources after being authenticated.

# View online port user information generated on the ACs. This example displays the command output on AC 1.

[AC1] display portal user all

Total portal users: 1

Username: Client

  Portal server: newpt

  State: Online

  VPN instance: N/A

  MAC             IP                    VLAN    Interface

  0021-6330-0933  2.2.2.3               200     Vlan-interface200

  Authorization information:

    DHCP IP pool: N/A

    User profile: N/A

    Session group profile: N/A

    ACL number: N/A

    Inbound CAR: N/A

    Outbound CAR: N/A

Configuration files

·     AC 1:

#

vlan 100

#

vlan 200

#

wlan service-template st1

 ssid service

 vlan 200

 portal enable method direct

 portal domain dm1

 portal bas-ip 2.2.2.1

 portal apply web-server newpt

 portal temp-pass period 300 enable

 service-template enable

#

interface Vlan-interface100

 ip address 2.2.1.1 255.255.255.0

#

interface Vlan-interface200

 ip address 2.2.2.1 255.255.255.0

#

interface gigabitethernet 1/0/1

 port link-type trunk

 port trunk permit vlan 100 200

#

 ip route-static 192.168.0.0 16 2.2.2.100

#

 radius session-control enable

#

domain dm1

 authentication portal none

 authorization portal none

 accounting portal none

#

portal free-rule 0 destination ip 192.168.0.111 255.255.255.255

portal free-rule 1 destination ip 2.2.2.1 255.255.255.255

portal free-rule 2 destination ip any udp 53

portal free-rule 3 destination ip any tcp 53

portal free-rule 4 destination ip 2.2.2.2 255.255.255.255

portal safe-redirect enable

portal safe-redirect method get post

portal safe-redirect user-agent CaptiveNetworkSupport

portal safe-redirect user-agent MicroMessenger

portal safe-redirect user-agent Mozilla

portal safe-redirect user-agent WeChat

portal safe-redirect user-agent iPhone

portal safe-redirect user-agent micromessenger

#

portal web-server newpt

 url http://192.168.0.111:8080/wsmAuth/protocol

 captive-bypass ios optimize enable

 service-type oauth

#

portal local-web-server http

#

wlan ap office model WA5320

 wlan tunnel-preempt enable

 priority 7

 backup-ac ip 2.2.1.2

 serial-id 219801A0CNC138011454

 radio 1

 radio 2

  radio enable

  service-template st1

#

·     AC 2:

#

vlan 100

#

vlan 200

#

wlan service-template st1

 ssid service

 vlan 200

 portal enable method direct

 portal domain dm1

 portal bas-ip 2.2.2.2

 portal apply web-server newpt

 portal temp-pass period 300 enable

 service-template enable

#

interface Vlan-interface100

 ip address 2.2.1.2 255.255.255.0

#

interface Vlan-interface200

 ip address 2.2.2.2 255.255.255.0

#

 ip route-static 192.168.0.0 16 2.2.2.100

#

 radius session-control enable

#

domain dm1

 authentication portal none

 authorization portal none

 accounting portal none

#

portal free-rule 0 destination ip 192.168.0.111 255.255.255.255

portal free-rule 1 destination ip 2.2.2.1 255.255.255.255

portal free-rule 2 destination ip any udp 53

portal free-rule 3 destination ip any tcp 53

portal free-rule 4 destination ip 2.2.2.2 255.255.255.255

portal safe-redirect enable

portal safe-redirect method get post

portal safe-redirect user-agent CaptiveNetworkSupport

portal safe-redirect user-agent MicroMessenger

portal safe-redirect user-agent Mozilla

portal safe-redirect user-agent WeChat

portal safe-redirect user-agent iPhone

portal safe-redirect user-agent micromessenger

#

portal web-server newpt

 url http://192.168.0.111:8080/wsmAuth/protocol

 captive-bypass ios optimize enable

 service-type oauth

#

portal local-web-server http

#

wlan ap office model WA5320

 wlan tunnel-preempt enable

 priority 6

 backup-ac ip 2.2.1.1

 serial-id 219801A0CNC138011454

 radio 1

 radio 2

  radio enable

  service-template st1

#

·     Switch:

#

vlan 2

#

vlan 100

#

vlan 200

#

interface Vlan-interface2

 ip address 192.168.0.100 255.255.255.0

#

interface Vlan-interface200

 ip address 2.2.2.100 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 100 200

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

 poe enable

#

interface GigabitEthernet1/0/3

 port link-type trunk

 port trunk permit vlan 100 200

#

interface GigabitEthernet1/0/4

 port link-type trunk

 port trunk permit vlan 100 200

#

·     DHCP server:

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200

#

interface vlan-interface 100

 ip address 2.2.2.200 255.255.255.0

#

interface vlan-interface 200

 ip address 2.2.2.200 255.255.255.0

#

dhcp enable

#

dhcp server ip-pool vlan100

 network 2.2.1.0 mask 255.255.255.0

 forbidden-ip 2.2.1.1

 forbidden-ip 2.2.1.2

#

dhcp server ip-pool vlan200

 gateway-list 2.2.2.100

 network 2.2.2.0 mask 255.255.255.0

 dns-list 8.8.8.8

 forbidden-ip 2.2.2.1

 forbidden-ip 2.2.2.2

 forbidden-ip 2.2.2.100

#

Related documentation

·     User Access and Authentication Command Reference in H3C Access Controllers Command References

·     User Access and Authentication Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Access Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN High Availability Command Reference in H3C Access Controllers Command References

·     WLAN High Availability Configuration Guide in H3C Access Controllers Configuration Guides