10-High availability

HomeSupportResource CenterConfigure & DeployConfiguration ExamplesH3C Access Controllers Configuration Examples(V7)-6W10210-High availability
Table of Contents
Related Documents
05-Dual-Link Backup Configuration Examples
Title Size Download
05-Dual-Link Backup Configuration Examples 82.75 KB

 

H3C Access Controllers

Comware 7 Dual-Link Backup and AP License Synchronization

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.



Introduction

The following information provides a dual-link backup and AP license synchronization configuration example.

Prerequisites

This document applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

This document assumes that you have basic knowledge of AP management, WLAN high availability, and AP license synchronization features.

Example: Configuring dual-link backup and AP license synchronization

Network requirements

As shown in Figure 1, configure AC 1 as the master AC and AC 2 as the backup AC. When AC 1 fails and AC 2 takes over, the AP can communicate through AC 2. Configure the master CAPWAP tunnel preemption feature on the two ACs so that the AP reconnects to AC 1 when AC 1 recovers.

Enable AP license synchronization on AC 1 and AC 2 for the two ACs to back up licenses for each other.

Figure 1 Network diagram

 

Restrictions and guidelines

When you configure dual-link backup and AP license synchronization, follow these restrictions and guidelines:

·     Make sure the device model is compatible with the software version.

·     Use the serial ID labeled on the AP's rear panel to specify an AP.

·     If you use a manual AP to establish CAPWAP tunnels with the ACs, make sure the name of the AP is the same on the two ACs and either a serial ID or MAC address is configured for the AP on the two ACs.

·     As a best practice, install a license on the master AC before enabling AP license synchronization.

·     Before enabling AP license synchronization, you must specify IP addresses and roles for the AC and its member ACs in the AP license synchronization group.

·     Configure both AC 1 and AC 2 as the master in the AP license synchronization group.

·     When the master AC fails, the backup AC takes over and becomes the new master AC. The licenses synchronized to the new master AC will be valid for a 30-day grace period.

·     Dual-link backup is applicable to both centralized forwarding and local forwarding. This example uses centralized forwarding.

Procedures

Configuring AC 1

Installing a license

# Install a license on AC 1. (Details not shown.)

Configuring interfaces on AC 1

# Configure VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. AC 1 will use this IP address to establish CAPWAP tunnels with APs.

<AC1> system-view

[AC1] vlan 100

[AC1-vlan100] quit

[AC1] interface vlan-interface 100

[AC1-Vlan-interface100] ip address 10.1.1.1 16

[AC1-Vlan-interface100] quit

# Configure GigabitEthernet 1/0/1 that connects AC 1 to the switch as a trunk port, and assign it to all VLANs.

[AC1] interface gigabitethernet 1/0/1

[AC1-GigabitEthernet1/0/1] port link-type trunk

[AC1-GigabitEthernet1/0/1] port trunk permit vlan all

[AC1-GigabitEthernet1/0/1] quit

Configuring dual-link backup

# Create AP group group1, and set the connection priority to 7.

[AC1] wlan ap-group group1

[AC1-wlan-ap-group-group1] priority 7

# Specify a backup AC.

[AC1-wlan-ap-group-group1] backup-ac ip 10.1.1.2

# Enable master CAPWAP tunnel preemption.

[AC1-wlan-ap-group-group1] wlan tunnel-preempt enable

# Create an AP grouping rule by AP names.

[AC1-wlan-ap-group-group1] ap ap1

[AC1-wlan-ap-group-group1] quit

Configuring AP license synchronization

# Enable AP license synchronization on AC 1 and configure AC 1 as the master AC.

[AC1] wlan ap-license-group

[AC1-wlan-als-group] local ip 10.1.1.1

[AC1-wlan-als-group] member ip 10.1.1.2

[AC1-wlan-als-group] ap-license-synchronization enable

[AC1-wlan-als-group] quit

Configuring a manual AP

# Create an AP named ap1, and specify the AP model and serial ID.

[AC1] wlan ap ap1 model WA6320

[AC1-wlan-ap-ap1] serial-id 219801A28N819CE0002T

Configuring AC 2

(Optional.) Installing a license

# Install a license on AC 2. (Details not shown.)

Configuring interfaces on AC 2

# Configure VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. AC 2 will use this IP address to establish CAPWAP tunnels with APs.

<AC2> system-view

[AC2] vlan 100

[AC2-vlan100] quit

[AC2] interface Vlan-interface 100

[AC2-Vlan-interface100] ip address 10.1.1.2 16

[AC2-Vlan-interface100] quit

# Configure GigabitEthernet 1/0/1 that connects AC 2 to the switch as a trunk port, and assign it to all VLANs.

[AC2] interface gigabitethernet 1/0/1

[AC2-GigabitEthernet1/0/1] port link-type trunk

[AC2-GigabitEthernet1/0/1] port trunk permit vlan all

[AC2-GigabitEthernet1/0/1] quit

Configuring dual-link backup

# Create AP group group1, and specify a backup AC. Use the default setting for the connection priority.

[AC2] wlan ap-group group1

[AC2-wlan-ap-group-group1] backup-ac ip 10.1.1.1

# Create an AP grouping rule by AP names.

[AC2-wlan-ap-group-group1] ap ap1

[AC2-wlan-ap-group-group1] quit

Configuring AP license synchronization

# Enable AP license synchronization on AC 1 and configure AC 1 as the master AC.

[AC2] wlan ap-license-group

[AC2-wlan-als-group] local ip 10.1.1.2

[AC2-wlan-als-group] member ip 10.1.1.1

[AC2-wlan-als-group] ap-license-synchronization enable

[AC2-wlan-als-group] quit

Configuring a manual AP

# Create an AP named ap1, and specify the AP model and serial ID.

[AC2] wlan ap ap1 model WA6320

[AC2-wlan-ap-ap1] serial-id 219801A28N819CE0002T

Configuring the switch

Configuring interfaces on the switch

# Create VLAN 100. The switch will use this VLAN to forward the traffic on the CAPWAP tunnels between the AC and AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# Create VLAN interface 100, and assign it an IP address.

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 10.1.1.3 16

[Switch-Vlan-interface100] quit

# Configure GigabitEthernet 1/0/1 that connects the switch to AC 1 as a trunk port, and assign the trunk port to all VLANs.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan all

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 that connects the switch to AC 2 as a trunk port, and assign the port to all VLANs.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type trunk

[Switch-GigabitEthernet1/0/2] port trunk permit vlan all

[Switch-GigabitEthernet1/0/2] quit

# Configure GigabitEthernet 1/0/3 that connects the switch to the AP as an access port, and assign the port to VLAN 100.

[Switch] interface gigabitethernet 1/0/3

[Switch-GigabitEthernet1/0/3] port link-type access

[Switch-GigabitEthernet1/0/3] port access vlan 100

# Enable the PoE feature.

[Switch-GigabitEthernet1/0/3] poe enable

[Switch-GigabitEthernet1/0/3] quit

Configuring DHCP

# Create DHCP address pool 100. Specify the 10.1.0.0/16 subnet for the pool.

[Switch] dhcp server ip-pool 100

[Switch-dhcp-pool-100] network 10.1.0.0 mask 255.255.0.0

[Switch-dhcp-pool-100] quit

# Enable DHCP.

[Switch] dhcp enable

Verifying the configuration

# Display AP license synchronization group information on AC 1 to verify that the number of licenses in the group is the sum of licenses installed on AC 1 and AC 2.

<AC1> display wlan ap-license-group

 Group total licenses: 256

 Group used licenses: 1

 AP license synchronization: Enabled

 Local IP: 10.1.1.1

 Local role: Master

 Member information: 1

 IP address        Total      Used      Member role      State      Online duration

 10.1.1.2           0          0          Master            UP         00hr 1min 51sec

# Verify that the AP state is R/M on AC 1.

<AC1> display wlan ap all

Total number of APs: 1

Total number of connected APs: 1

Total number of connected manual APs: 1

Total number of connected auto APs: 0

Total number of connected common APs: 1

Total number of connected WTUs: 0

Total number of inside APs: 0

Maximum supported APs: 384

Remaining APs: 383

Total AP licenses: 256

Local AP licenses: 256

Server AP licenses: 0

Remaining local AP licenses: 255

Sync AP licenses: 0 

 

                                 AP information

 State : I = Idle,       J  = Join,       JA = JoinAck,    IL = ImageLoad

         C = Config,     DC = DataCheck,  R  = Run   M = Master,  B = Backup

 

AP name                        APID  State Model           Serial ID

ap1                            1     R/M   WA6320          219801A28N819CE0002T

# Verify that the AP state is R/M on AC 1 and R/B on AC 2, and the number of licenses is 256.

<AC2> display wlan ap all

Total number of APs: 1

Total number of connected APs: 1

Total number of connected manual APs: 1

Total number of connected auto APs: 0

Total number of connected common APs: 1

Total number of connected WTUs: 0

Total number of inside APs: 0

Maximum supported APs: 384

Remaining APs: 383

Total AP licenses: 256

Local AP licenses: 256

Server AP licenses: 0

Remaining local AP licenses: 256

Sync AP licenses: 256 

 

                                 AP information

 State : I = Idle,       J  = Join,       JA = JoinAck,    IL = ImageLoad

         C = Config,     DC = DataCheck,  R  = Run   M = Master,  B = Backup

 

AP name                        APID  State Model           Serial ID

ap1                            1     R/B   WA6320          219801A28N819CE0002T

# Shut down VLAN-interface 1 on AC 2 and wait for no longer than 30 seconds, during which service interruption occurs. Verify that the AP is in R/M state.

<AC2> display wlan ap all

Total number of APs: 1

Total number of connected APs: 1

Total number of connected manual APs: 1

Total number of connected auto APs: 0

Total number of connected common APs: 1

Total number of connected WTUs: 0

Total number of inside APs: 0

Maximum supported APs: 384

Remaining APs: 383

Total AP licenses: 256

Local AP licenses: 256

Server AP licenses: 0

Remaining local AP licenses: 255

Sync AP licenses: 256 

 

                                 AP information

 State : I = Idle,       J  = Join,       JA = JoinAck,    IL = ImageLoad

         C = Config,     DC = DataCheck,  R  = Run   M = Master,  B = Backup

 

AP name                        APID  State Model           Serial ID

ap1                            1     R/M   WA6320          219801A28N819CE0002T

# Bring up VLAN-interface 1 on AC 1. Verify that the AP state is R/M on AC 1 and R/B on AC 2. (Details not shown.)

Configuration files

·     AC 1:

#

vlan 100

#

interface Vlan-interface100

 ip address 10.1.1.1 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan all

#

wlan ap-group group1                                                           

 priority 7                                                                    

 wlan tunnel-preempt enable                                                    

 backup-ac ip 10.1.1.2                                                         

 ap ap1

#

wlan ap ap1 model WA6320

 serial-id 219801A28N819CE0002T

#

wlan ap-license-group                                                          

 local ip 10.1.1.1                                                              

 member ip 10.1.1.2                                                            

 ap-license-synchronization enable                                             

#

·     AC 2:

#

vlan 100

#

interface Vlan-interface100

 ip address 10.1.1.2 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan all

#

wlan ap-group group1                                                           

 backup-ac ip 10.1.1.1                                                         

 ap ap1

#

wlan ap ap1 model WA6320

 serial-id 219801A28N819CE0002T

#

wlan ap-license-group                                                          

 local ip 10.1.1.2                                                             

 member ip 10.1.1.1                                                            

 ap-license-synchronization enable                                             

#

·     Switch

#

 dhcp enable

#

vlan 100

#

dhcp server ip-pool 100

 network 10.1.0.0 mask 255.255.0.0

#

interface Vlan-interface100

 ip address 10.1.1.3 255.255.0.0

#

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan all

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan all

#

interface GigabitEthernet1/0/3

 port link-type access

 port access vlan 100

 poe enable

#

Related documentation

·     AP License Synchronization Command Reference in H3C Access Controllers Command References

·     AP License Synchronization Configuration Guide in H3C Access Controllers Configuration Guides

·     AP Management Command Reference in H3C Access Controllers Command References

·     AP Management Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN High Availability Command Reference in H3C Access Controllers Command References

·     WLAN High Availability Configuration Guide in H3C Access Controllers Configuration Guides