07-Local forwarding

HomeSupportResource CenterH3C Access Controllers Configuration Examples(V7)-6W10207-Local forwarding
03-Local Forwarding Mode Direct Portal Authentication (IPv6) Configuration Examples

 

H3C Access Controllers

Comware 7 Local Forwarding Mode Direct Portal Authentication (IPv6)

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides examples for configuring direct IPv6 portal authentication in a wireless network where APs directly forward client traffic.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of AAA, portal, and WLAN.

Example: Configuring local forwarding mode direct IPv6 portal authentication

Network configuration

As shown in Figure 1:

·     The AP and the client obtain IPv6 addresses from the DHCPv6 server.

·     The AP directly forwards traffic of the client.

·     The IMC server acts as the portal authentication server, portal Web server, and RADIUS server.

·     The AC performs direct IPv6 portal authentication on clients. Before passing IPv6 portal authentication, the client can access only the portal Web server. After passing IPv6 portal authentication, the client can access other network resources.

·     The client user can access network resources on any Layer 2 ports in its access VLAN without re-authentication.

·     The IMC server can dynamically change authorization information for the user and can log out the user.

Figure 1 Network diagram

 

Analysis

To allow an authenticated user to access network resources on any Layer 2 ports in its access VLAN without re-authentication, enable the portal roaming feature.

To allow the RADIUS server to modify user authorization information and log out users, enable the RADIUS session-control feature.

To add GigabitEthernet 1/0/1 of the AP to the local forwarding VLAN (VLAN 200), edit the AP's configuration file and upload it to the AC's storage medium.

To allow portal users to access both IPv4 and IPv6 networks after passing one type (IPv4 or IPv6) of portal authentication, enable portal to support IPv4/IPv6 dual stack.

Configure DNS if necessary. In this example, DNS is not required.

Restrictions and guidelines

When you configure direct portal authentication, follow these restrictions and guidelines:

·     Use the serial ID labeled on the AP's rear panel to specify an AP.

·     The portal authentication server type and portal Web server type configured on the AC must be the same as the types of the servers actually used.

·     By default, the portal Web server URL redirected to users does not carry parameters. You can configure the parameters to be carried in the redirection URL as needed.

Procedures

Configuring IMC

This example uses the IMC server to describe the RADIUS server and portal server configuration. The IMC server runs on IMC PLAT 7.1(E0303), IMC EIA 7.1(E0304), and IMC EIP 7.1(E0304).

Configuring the RADIUS server

1.     Add an access device:

a.     Log in to IMC and click the User tab.

b.     From the navigation tree, select User Access Policy > Access Device Management > Access Device.

c.     Click Add.

The Add Access Device page opens.

d.     Configure the shared key as radius.

The shared key must be the same as that configured for the RADIUS server on the AC.

e.     In the Device List area, click Add IPv6 Dev to open the Add Access Device Manually page. Enter the start IPv6 address 2001::1 and click OK.

f.     Use the default settings for other parameters.

g.     Click OK.

Figure 2 Adding an access device

 

2.     Add an access policy:

a.     From the navigation tree, select User Access Policy > Access Policy.

b.     Click Add to open the Add Access Policy page.

c.     Enter the policy name, select the service group, and use the default settings for other parameters.

d.     Click OK.

Figure 3 Adding an access policy

 

3.     Add an access service:

a.     From the navigation tree, select User Access Policy > Access Service.

b.     Click Add to open the Add Access Service page.

c.     Enter the service name, select the access policy configured in the previous step as the default access policy, and use the default settings for other parameters.

d.     Click OK.

Figure 4 Adding an access service

 

4.     Add an access user:

a.     From the navigation tree, select Access User > All Access Users.

b.     Click Add to open the Add Access User page.

c.     Click Select to select an existing user from the User Name list or click Add User to add a new user.

d.     Enter the account name.

e.     Enter and confirm the password.

f.     Use the default settings for other parameters.

g.     Click OK.

Figure 5 Adding an access user

 

Configuring the portal server

1.     Configure the portal authentication service:

a.     Log in to IMC and click the User tab.

b.     From the navigation tree, select User Access Policy > Portal Service > Server.

c.     Configure the portal server parameters.

This example uses the default settings.

d.     Click OK.

Figure 6 Configuring the portal server

 

2.     Configure an IP group:

a.     From the navigation tree, select User Access Policy > Portal Service > IP Group to open the portal IP group configuration page.

b.     Click Add to open the Add IP Group page.

c.     Enter the IP group name.

d.     Select Yes from the IPv6 field.

e.     Enter the start IP address and end IP address of the IP group.

Make sure the client IP address is in the IP group.

f.     Select a service group.

This example uses the default group Ungrouped.

g.     Click OK.

Figure 7 Adding an IP group

 

3.     Add a portal device:

a.     Select User Access Policy > Portal Service > Device from the navigation tree to open the portal device configuration page.

b.     Click Add to open the Add Device page.

c.     Enter the device name.

d.     Select Portal 3.0 from the Version list.

e.     Enter the IP address of the AC's interface connected to the client.

f.     Select whether to support server heartbeat and user heartbeat functions.

In this example, select No for both Support Server Heartbeat and Support User Heartbeat.

g.     Enter the key, which must be the same as that configured on the AC.

h.     Select Directly Connected from the Access Method list.

i.     Use the default settings for other parameters.

j.     Click OK.

Figure 8 Adding a portal device

 

4.     Associate the portal device with the IP group:

a.     In the device list on the portal device configuration page, click the Port Group icon in the Operation field of device NAS, as shown in Figure 9.

Figure 9 Device list

 

The port group configuration page opens.

Figure 10 Adding a port group

 

b.     Click Add to open the Add Port Group page as shown in Figure 11.

c.     Enter the port group name.

d.     Select the configured IP group.

The IP address used by the user to access the network must be within this IP group.

e.     Use the default settings for other parameters.

f.     Click OK.

Figure 11 Adding a port group

 

5.     From the navigation tree, select User Access Policy > Service Parameters > Validate to commit the configuration changes.

Editing the AP configuration file

# Use a text editor to edit the AP's configuration file. Name the configuration file map.txt, and then upload the file to the storage medium of the AC.

The content of the configuration file is as follows:

System-view

vlan 200

interface gigabitethernet1/0/1

port link-type trunk

port trunk permit vlan 200

Configuring the AC

1.     Configuring VLANs and interfaces:

# Create VLAN 100 and VLAN-interface 100. Assign the VLAN interface an IPv6 address. The AC will establish CAPWAP tunnels with APs in this VLAN.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ipv6 address 2001::1 64

# Disable RA message suppression.

[AC-Vlan-interface100] undo ipv6 nd ra halt

# Set the M flag to 1 and the O flag to 1 in RA advertisements to be sent on VLAN-interface 100.

[AC-Vlan-interface100] ipv6 nd autoconfig managed-address-flag

[AC-Vlan-interface100] ipv6 nd autoconfig other-flag

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200. Assign the VLAN interface an IPv6 address. This VLAN will be used for wireless client access.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ipv6 address 2004::1 64

# Disable RA message suppression.

[AC-Vlan-interface200] undo ipv6 nd ra halt

# Set the M flag to 1 and the O flag to 1 in RA advertisements to be sent on VLAN-interface 200.

[AC-Vlan-interface200] ipv6 nd autoconfig managed-address-flag

[AC-Vlan-interface200] ipv6 nd autoconfig other-flag

[AC-Vlan-interface200] quit

2.     Configure a static route to reach the IMC:

[AC] ipv6 route-static 2003:: 64 2004::2

3.     Configure the wireless service:

# Create a service template named st1 and enter its view.

[AC] wlan service-template st1

# Configure the SSID of the service template as service.

[AC-wlan-st-st1] ssid service

# Assign clients coming online through the service template to VLAN 200.

[AC-wlan-st-st1] vlan 200

# Enable snooping DHCPv6 and ND packets.

[AC-wlan-st-st1] client ipv6-snooping dhcpv6-learning enable

[AC-wlan-st-st1] client ipv6-snooping nd-learning enable

# Configure APs to forward client data traffic from all VLANs.

[AC–wlan-st-st1] client forwarding-location ap

[AC-wlan-st-st1] quit

# Create an AP named office with model WA4320i-ACN, and set its serial ID.

[AC] wlan ap office model WA4320i-ACN

[AC-wlan-ap-office] serial-id 219801A0CNC138011454

# Deploy configuration file map.txt to the AP.

[AC-wlan-ap-office] map-configuration map.txt

# Enter the view of radio 2.

[AC-wlan-ap-office] radio 2

# Bind service template st1 to radio 2 and enable the radio.

[AC-wlan-ap-office-radio-2] service-template st1

[AC-wlan-ap-office-radio-2] radio enable

[AC-wlan-ap-office-radio-2] quit

[AC-wlan-ap-office] quit

4.     Configure the RADIUS scheme:

# Create a RADIUS scheme named rs1 and enter its view.

[AC] radius scheme rs1

# Configure the primary authentication and accounting servers and shared keys used for secure communication with the servers.

[AC-radius-rs1] primary authentication ipv6 2003::2

[AC-radius-rs1] primary accounting ipv6 2003::2

[AC-radius-rs1] key authentication simple radius

[AC-radius-rs1] key accounting simple radius

# Configure the AC to remove the domain name from the usernames sent to the RADIUS servers.

[AC-radius-rs1] user-name-format without-domain

# Specify 2001::1 as the source IPv6 address of outgoing RADIUS packets.

[AC-radius-rs1] nas-ip ipv6 2001::1

[AC-radius-rs1] quit

# Enable the RADIUS session-control feature.

[AC] radius session-control enable

# Enable the RADIUS DAE server feature and enter RADIUS DAE server view.

[AC] radius dynamic-author server

# Specify a RADIUS DAE client at IPv6 address 2003::2 and configure the shared key for secure communication with the client as radius.

[AC-radius-da-server] client ipv6 2003::2 key simple radius

[AC-radius-da-server] quit

5.     Configure the authentication domain:

# Create an ISP domain named dm1 and enter its view.

[AC] domain dm1

# Configure the authentication and authorization methods as RADIUS and the accounting method as none for portal users.

[AC-isp-dm1] authentication portal radius-scheme rs1

[AC-isp-dm1] authorization portal radius-scheme rs1

[AC-isp-dm1] accounting portal none

# Configure the idle cut feature for users. Log out a user if the user's traffic is less than 1024 bytes in 15 minutes.

[AC-isp-dm1] authorization-attribute idle-cut 15 1024

[AC-isp-dm1] quit

6.     Configure portal authentication:

# Create a portal authentication server named newpt and specify the server's IPv6 address as 2003::2.

[AC] portal server newpt

[AC-portal-server-newpt] ipv6 2003::2 key simple 123456

[AC-portal-server-newpt] quit

# Create a portal Web server named newpt and specify the server's URL as http://[2003::2]:8080/portal.

[AC] portal web-server newpt

[AC-portal-websvr-newpt] url http://[2003::2]:8080/portal

# Configure the portal redirection URL to carry the ssid, wlanuserip, and wlanacname parameters, and their values are the AP's SSID, the user's IPv6 address, and the AC's name.

[AC-portal-websvr-newpt] url-parameter ssid ssid

[AC-portal-websvr-newpt] url-parameter wlanuserip source-address

[AC-portal-websvr-newpt] url-parameter wlanacname value AC

# Enable the portal roaming feature.

[AC] portal roaming enable

# Configure two portal-free rules to allow users to access the DNS server without authentication.

[AC] portal free-rule 1 destination ip any udp 53

[AC] portal free-rule 2 destination ip any tcp 53

# Configure a portal-free rule. Set the rule number to 3 and the source interface to aggregate interface 1. This rule allows users on the aggregate interface to access the network resources without authentication.

[AC] portal free-rule 3 source interface Bridge-Aggregation1

# Enable direct IPv6 portal authentication on service template st1.

[AC] wlan service-template st1

[AC-wlan-st-st1] portal ipv6 enable method direct

# Configure the authentication domain for portal users as dm1.

[AC-wlan-st-st1] portal ipv6 domain dm1

# Specify portal Web server newpt on service template st1.

[AC-wlan-st-st1] portal ipv6 apply web-server newpt

# Enable portal to support IPv4/IPv6 dual stack on service template st1.

[AC-wlan-st-st1] portal dual-stack enable

# Configure the BAS-IPv6 attribute as 2001::1.

[AC-wlan-st-st1] portal bas-ipv6 2001::1

# Enable service template st1.

[AC–wlan-st-st1] service-template enable

[AC-wlan-st-st1] quit

Configuring the switch

# Create VLAN 100. The switch will use this VLAN to forward traffic on the CAPWAP tunnel between the AC and AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# Create VLAN 200. The switch will use this VLAN to forward traffic of wireless clients.

[Switch] vlan 200

[Switch-vlan200] quit

# Create VLAN 2.

[Switch] vlan 2

[Switch-vlan2] quit

# Configure GigabitEthernet 1/0/1 (the port connected to the AC) as a trunk port. Assign the trunk port to VLAN 100 and VLAN 200.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 (the port connected to the AP) as an access port. Assign the access port to VLAN 100.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# Enable PoE on the access port.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

# Create VLAN-interface 200 and assign it an IPv6 address.

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ipv6 address 2004::2 64

[Switch-Vlan-interface200] quit

# Create VLAN-interface 2 and assign it an IPv6 address.

[Switch] interface vlan-interface 2

[Switch-Vlan-interface2] ipv6 address 2003::2 64

[Switch-Vlan-interface2] quit

Verifying the configuration

# Use the configured username and password to perform portal authentication through a Web browser on the client. Before passing authentication, all Web accesses are redirected to the portal authentication page (http://[2003::2]:8080/portal). After passing authentication, you can access other network resources.

# Display the online portal user information on the AC.

[AC] display portal user all

Total portal users: 1

Username: Client

  AP name: office

  Radio ID: 2

  SSID: service

  Portal server: newpt

  State: Online

  VPN instance: N/A

  MAC             IP                    VLAN    Interface

  0021-6330-0933  2004::2               200     WLAN-BSS1/0/16

  Authorization information:

    DHCP IP pool: N/A

    User profile: N/A

    Session group profile: N/A

    ACL number: N/A

    Inbound CAR: N/A

    Outbound CAR: N/A

The output shows that the client successfully passes portal authentication and comes online.

# Display portal filtering rules on the AC and the AP.

[AC] display portal rule all ap office

Slot 1:

[AP] display portal rule all

 

IPv6 portal rules on WLAN-BSS1/0/16:

Rule 1:

 Type                : Static

 Action              : Permit

 Protocol            : Any

 Status              : Active

 Source:

    IP             : ::

    Prefix length  : 0

    Port           : Any

    MAC            : 0000-0000-0000

    Interface      : WLAN-BSS1/0/16

    VLAN           : Any

 Destination:

    IP             : 2003::2

    Prefix length  : 128

    Port           : Any

 

Rule 2:

 Type                : Dynamic

 Action              : Permit

 Status              : Active

 Source:

    IP             : 2004::2

    MAC            : 0021-6330-0933

    Interface      : WLAN-BSS1/0/16

    VLAN           : Any

The output shows that the AC does not have portal filtering rules for the AP and the AP has the portal filtering rules. This is because the local forwarding mode is used.

Configuration files

·     AC:

#

vlan 100

#

vlan 200

#

wlan service-template st1

 ssid service

 vlan 200

 client forwarding-location ap

 client ipv6-snooping nd-learning enable

 client ipv6-snooping dhcpv6-learning enable

 portal ipv6 enable method direct

 portal ipv6 domain dm1

 portal bas-ipv6 2001::1

 portal ipv6 apply web-server newpt

 portal dual-stack enable

 service-template enable

#

interface Vlan-interface100

 ipv6 address 2001::1/64

 ipv6 nd autoconfig managed-address-flag

 ipv6 nd autoconfig other-flag

 undo ipv6 nd ra halt

#

interface Vlan-interface200

 ipv6 address 2004::1/64

 ipv6 nd autoconfig managed-address-flag

 ipv6 nd autoconfig other-flag

 undo ipv6 nd ra halt

#

 ipv6 route-static 2003:: 64 2002::2

#

 radius session-control enable

#

radius scheme rs1

 primary authentication ipv6 2003::2

 primary accounting ipv6 2003::2

 key authentication cipher $c$3$Sqgqz7lDs4XPnethmAgyAKVlke7qwEkYbQ==

 key accounting cipher $c$3$4J/JBRGwqB4F213furJMkB6JWYXBFjWE6g==

 user-name-format without-domain

 nas-ip ipv6 2001::1

#

radius dynamic-author server

 client ip ipv6 2003::2 key cipher $c$3$AkTEB7OgMYnCqsfDeplhoAgXUek/rVrLZw==

#

domain dm1

 authorization-attribute idle-cut 15 1024

 authentication portal radius-scheme rs1

 authorization portal radius-scheme rs1

 accounting portal none

#

portal free-rule 1 destination ip any udp 53

portal free-rule 2 destination ip any tcp 53

portal free-rule 3 source interface Bridge-Aggregation1

#

 portal web-server newpt

 url http://[2003::2]:8080/portal

 url-parameter ssid ssid

 url-parameter wlanacname value AC

 url-parameter wlanuserip source-address

#

portal server newpt

 ipv6 2003::2 key cipher $c$3$wu1Cg6I4PTcPTgPeKRF/7w9jIqIEq2xlTw==

#

wlan ap office model WA4320i-ACN

 serial-id 219801A0CNC138011454

 map-configuration flash:/map.txt

 radio 1

 radio 2

  radio enable

  service-template st1

#

·     Switch:

#

vlan 2

#

vlan 100

#

vlan 200

#

interface Vlan-interface2

 ipv6 address 2003::1 64

#

interface Vlan-interface200

 ipv6 address 2004::2 64

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 100 200

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

 poe enable

#

Related documentation

·     User Access and Authentication Command Reference in H3C Access Controllers Command References

·     User Access and Authentication Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Access Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides