06-Wireless authentication

HomeSupportResource CenterH3C Access Controllers Configuration Examples(V7)-6W10206-Wireless authentication
Table of Contents
Related Documents
15-Portal Fail-Permit Configuration Examples
Title Size Download
15-Portal Fail-Permit Configuration Examples 372.75 KB

 

H3C Access Controllers

Comware 7 Portal Fail-Permit

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example of configuring portal fail-permit for wireless clients when the portal Web server is unreachable.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of AAA, portal, and WLAN features.

Example: Configuring portal fail-permit

Network configuration

As shown in Figure 1, the AP and the client obtain IP addresses from the DHCP server.

To implement remote portal authentication, perform the following tasks:

·     Configure direct portal authentication.

·     Configure a portal authentication server and a portal Web server on IMC.

·     Configure a RADIUS server as the authentication server and accounting server.

·     Enable the AC to detect the reachability of the portal Web server and send a log message and a trap massage after server reachability status changes.

¡     When the AC detects that the portal Web server is unreachable, it stops portal authentication for wireless users. The AC allows users to have network access without portal authentication.

¡     After the portal Web server becomes reachable, the AC restarts portal authentication for wireless users that access the network. A user must pass portal authentication to access the network.

Figure 1 Network diagram

 

Analysis

To allow an authenticated user to access network resources on any Layer 2 ports in its access VLAN without re-authentication, enable portal roaming.

To avoid possible authentication failure caused by frequent logins and logouts of portal clients in a short time, disable the Rule ARP entry feature for portal clients.

For the RADIUS server to dynamically change user authorization information or forcibly disconnect users, enable the RADIUS session-control feature.

Restrictions and guidelines

Use the serial ID labeled on the AP's rear panel to specify an AP.

Make sure the types of the portal authentication server and portal Web server specified on the AC are the same as those actually used. (This example uses CMCC servers.)

By default, the portal Web server URL redirected to users does not include parameters. You can configure the parameters to be included in the redirection URL as needed.

Procedures

Configuring IMC

In this example, the IMC server runs IMC PLAT 7.1 (E0303p13), IMC EIA 7.1 (F0302p08), and IMC EIP 7.1 (F0302p08).

Configuring the RADIUS server

1.     Add an access device:

a.     Log in to IMC and click the User tab.

b.     From the navigation tree, select User Access Policy > Access Device Management > Access Device.

c.     Click Add to open the page as shown in Figure 2.

d.     In the Device List area, click Add Manually to open the Add Access Device Manually page. Enter 2.2.2.1 in the Start IP field and then click OK.

e.     In the Access Configuration area, set the shared key to radius, which must be the same as that configured on the AC.

f.     Use the default settings for other parameters.

g.     Click OK.

Figure 2 Adding an access device

 

2.     Add an access policy:

a.     From the navigation tree, select User Access Policy > Access Policy.

b.     Click Add to open the page as shown in Figure 3.

c.     Enter the access policy name.

d.     Select a service group. This example uses the default setting (Ungrouped).

e.     Use the default settings for other parameters.

f.     Click OK.

Figure 3 Adding an access policy

 

3.     Add an access service:

a.     From the navigation tree, select User Access Policy > Access Service.

b.     Click Add to open the page as shown in Figure 4.

c.     Enter the service name.

d.     Use the default settings for other parameters.

e.     Click OK.

Figure 4 Adding an access service

 

4.     Add an access user:

a.     From the navigation tree, select Access User > Access User.

b.     Click Add to open the page as shown in Figure 5.

c.     Select an existing access user or click Add User to add a new access user.

d.     Set the password.

e.     In the Access Service area, select the configured access service.

f.     Use the default settings for other parameters.

g.     Click OK.

Figure 5 Adding an access user

 

Configuring the portal server

1.     Configure the portal authentication service:

a.     From the navigation tree, select User Access Policy > Portal Service > Server to open the portal server configuration page, as shown in Figure 6.

b.     Configure the portal server parameters as needed.

This example uses the default settings.

c.     Click OK.

Figure 6 Configuring the portal server

 

2.     Configure the IP address group:

a.     From the navigation tree, select User Access Policy > Portal Service > IP Group.

b.     Click Add to open the page as shown in Figure 7.

c.     Enter the IP group name.

d.     Enter the start IP address and end IP address of the IP group.

Make sure the client IP address is in the IP group.

e.     Select a service group.

This example uses the default group Ungrouped.

f.     Select Normal from the Action list.

g.     Click OK.

Figure 7 Adding an IP address group

 

3.     Add a portal device:

a.     From the navigation tree, select User Access Policy > Portal Service > Device.

b.     Click Add to open the page as shown in Figure 8.

c.     Enter the device name.

d.     Select CMCC 1.0 from the Version list.

e.     Enter the IP address of the AC's interface connected to the client.

f.     Set whether to support the portal server heartbeat and user heartbeat functions.

In this example, select No for both Support Server Heartbeat and Support User Heartbeat.

g.     Enter the key, which must be the same as that configured on the AC.

h.     Select Directly Connected for Access Method.

i.     Use the default settings for other parameters.

j.     Click OK.

Figure 8 Adding a portal device

 

4.     Associate the portal device with the IP address group:

a.     Click the Port Group icon in the Operation field of device NAS, as shown in Figure 9.

Figure 9 Device list

 

b.     Click Add to open the page as shown in Figure 10.

c.     Enter the port group name.

d.     Select the configured IP address group.

The IP address used by the user to access the network must be within this IP address group.

e.     Use the default settings for other parameters.

f.     Click OK.

Figure 10 Adding a port group

 

Configuring the AC

1.     Configure interfaces on the AC:

# Create VLAN 100 and VLAN-interface 100. Assign an IP address to the VLAN interface. The AC will use this IP address to establish CAPWAP data and control tunnels with the AP.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 2.2.1.1 24

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200. Assign an IP address to the VLAN interface. The AC will use VLAN 200 for client access.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 2.2.2.1 24

[AC-Vlan-interface200] quit

2.     Configure a static route to reach the IMC server.

[AC] ip route-static 192.168.0.0 255.255.0.0 2.2.2.100

3.     Configure a wireless service:

# Create a service template named st1 and enter its view.

[AC] wlan service-template st1

# Set the SSID of service template st1 to service.

[AC-wlan-st-st1] ssid service

# Assign clients coming online through service template st1 to VLAN 200.

[AC-wlan-st-st1] vlan 200

[AC-wlan-st-st1] quit

# Create an AP named office with model WA4320i-ACN and set its serial ID to 219801A0CNC138011454.

[AC] wlan ap office model WA4320i-ACN

[AC-wlan-ap-office] serial-id 219801A0CNC138011454

# Enter the view of radio 2.

[AC-wlan-ap-office] radio 2

# Bind service template st1 to radio 2 and enable the radio.

[AC-wlan-ap-office-radio-2] service-template st1

[AC-wlan-ap-office-radio-2] radio enable

[AC-wlan-ap-office-radio-2] quit

[AC-wlan-ap-office] quit

4.     Configure a RADIUS scheme:

# Create a RADIUS scheme named rs1 and enter its view.

[AC] radius scheme rs1

# Specify the primary authentication server and primary accounting server, and configure the keys for communication with the servers.

[AC-radius-rs1] primary authentication 192.168.0.111

[AC-radius-rs1] primary accounting 192.168.0.111

[AC-radius-rs1] key authentication simple radius

[AC-radius-rs1] key accounting simple radius

# Configure the AC to remove the domain name from the usernames sent to the RADIUS servers.

[AC-radius-rs1] user-name-format without-domain

# Specify 2.2.2.1 as the source IP address for outgoing RADIUS packets sent to the RADIUS servers.

[AC-radius-rs1] nas-ip 2.2.2.1

[AC-radius-rs1] quit

# Enable the RADIUS session-control feature.

[AC] radius session-control enable

5.     Configure an authentication domain:

# Create an ISP domain named dm1 and enter its view.

[AC] domain dm1

# Configure the authentication, authorization, and authorization methods as RADIUS for portal users in the ISP domain, and specify RADIUS scheme rs1.

[AC-isp-dm1] authentication portal radius-scheme rs1

[AC-isp-dm1] authorization portal radius-scheme rs1

[AC-isp-dm1] accounting portal radius-scheme rs1

# Configure the idle cut feature for users in the ISP domain. Log out a user if the user's traffic is less than 1024 bytes in 15 minutes.

[AC-isp-dm1] authorization-attribute idle-cut 15 1024

[AC-isp-dm1] quit

6.     Configure portal authentication:

# Create a portal authentication server named newpt, specify IP address 192.168.0.111 as the IP address of the authentication server, and specify 50100 as the portal service port number.

[AC] portal server newpt

[AC-portal-server-newpt] ip 192.168.0.111 key simple radius

[AC-portal-server-newpt] port 50100

# Specify CMCC as the type of portal authentication server newpt.

[AC-portal-server-newpt] server-type cmcc

[AC-portal-server-newpt] quit

# Create a portal Web server named newpt and specify http://192.168.0.111:8080/portal as the URL of the server.

[AC] portal web-server newpt

[AC-portal-websvr-newpt] url http://192.168.0.111:8080/portal

# Add parameters ssid, wlanuserip, and wlanacname to the URL of portal Web server newpt. Specify the AP's SSID, the IP address of the client, and the AC's name as the values for the parameters, respectively. (The parameters are required to be included in the URL of a portal Web server of the CMCC type.)

[AC-portal-websvr-newpt] url-parameter ssid ssid

[AC-portal-websvr-newpt] url-parameter wlanuserip source-address

[AC-portal-websvr-newpt] url-parameter wlanacname value AC

# Enable server detection for portal Web server newpt, set the detection interval to 60 seconds, and set the maximum number of consecutive detection failures to 2. Configure the AC to send a log message and a trap massage after server reachability status changes.

[AC-portal-websvr-newpt] server-detect interval 60 retry 2 log

# Specify CMCC as the type of portal Web server newpt.

[AC-portal-websvr-newpt] server-type cmcc

[AC-portal-websvr-newpt] quit

# Configure a destination-based portal-free rule numbered 0 to permit traffic destined for IP address 192.168.0.111 (the portal Web server).

[AC] portal free-rule 0 destination ip 192.168.0.111 24

# Configure destination-based portal-free rules to permit traffic destined for the DNS server.

[AC] portal free-rule 1 destination ip any udp 53

[AC] portal free-rule 2 destination ip any tcp 53

# Enable portal roaming.

[AC] portal roaming enable

# Disable the Rule ARP entry feature for portal clients.

[AC] undo portal refresh arp enable

# Enable validity check on wireless portal clients.

[AC] portal host-check enable

# Enable direct portal authentication in service template st1.

[AC] wlan service-template st1

[AC-wlan-st-st1] portal enable method direct

# Specify portal Web server newpt in service template st1 for portal authentication.

[AC-wlan-st-st1] portal apply web-server newpt

# Configure the BAS-IP attribute as 2.2.2.1 for portal packets sent to portal authentication server newpt.

[AC-wlan-st-st1] portal bas-ip 2.2.2.1

# Specify ISP domain dm1 as the portal authentication domain.

[AC-wlan-st-st1] portal domain dm1

# Enable portal fail-permit for the portal Web server on the service template.

[AC-wlan-st-st1] portal fail-permit web-server

# Enable service template st1.

[AC–wlan-st-st1] service-template enable

[AC-wlan-st-st1] quit

Configuring the switch

# Create VLAN 100. The switch will use this VLAN to forward traffic on the CAPWAP tunnels between the AC and the AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# Create VLAN 200. The switch will use this VLAN to forward client traffic.

[Switch] vlan 200

[Switch-vlan200] quit

# Create VLAN 2.

[Switch] vlan 2

[Switch-vlan2] quit

# Configure GigabitEthernet 1/0/1 (the port connected to the AC) as a trunk port and assign the trunk port to VLAN 100 and VLAN 200.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 (the port connected to the AP) as an access port and assign the access port to VLAN 100.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# Enable PoE on GigabitEthernet 1/0/2.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

# Create VLAN-interface 200 and assign an IP address to the VLAN interface.

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 2.2.2.100 255.255.255.0

[Switch-Vlan-interface200] quit

# Create VLAN-interface 2 and assign an IP address to the VLAN interface.

[Switch] interface vlan-interface 2

[Switch-Vlan-interface2] ip address 192.168.0.100 255.255.255.0

[Switch-Vlan-interface2] quit

Verifying the configuration

# Verify that the portal Web server is reachable. When the portal Web server is reachable, the value for the IPv4 status field is Up.

[AC] display portal web-server newpt

Portal Web server: newpt

    Type: CMCC

    URL: http://192.168.0.111:8080/portal

    URL parameters:

        ssid=ssid

        wlanuserip=source-address

        wlanacname=AC

    VPN instance: Not configured

    Server detection:

       Interval: 60s

       Attempts: 2

       Action: log

       Detection URL: Not configured

       Detection type: TCP

    IPv4 status: Up

    IPv6 status: N/A

    Captive-bypass: Disabled

    If-match: Not configured

# Make the portal Web server and the AC unreachable. (Details not shown.)

# Verify that the AC can detect the reachability status change of the portal Web server. When the portal Web server is unreachable, the value for the IPv4 status field is Down.

[AC] display portal web-server newpt

Portal Web server: newpt

    Type: CMCC

    URL: http://192.168.0.111:8080/portal

    URL parameters:

        ssid=ssid

        wlanuserip=source-address

        wlanacname=AC

    VPN instance: Not configured

    Server detection:

       Interval: 60s

       Attempts: 2

       Action: log

       Detection URL: Not configured

       Detection type: TCP

    IPv4 status: Down

    IPv6 status: N/A

    Captive-bypass: Disabled

    If-match: Not configured

# Verify that the AC send a log message and a trap massage after server reachability status changes. (Details not shown.)

# Verify that the AC allows wireless users to have network access without portal authentication through service template st1. (Details not shown.)

# Make the portal Web server and the AC reachable. (Details not shown.)

# Verify that wireless users must pass portal authentication to access the network through service template st1. (Details not shown.)

Configuration files

·     AC:

#

vlan 100

#

vlan 200

#

wlan service-template st1

 ssid service

 vlan 200

 portal enable method direct

 portal domain dm1

 portal bas-ip 2.2.2.1

 portal apply web-server newpt

 portal fail-permit web-server

 service-template enable

#

interface Vlan-interface100

 ip address 2.2.1.1 255.255.255.0

#

interface Vlan-interface200

 ip address 2.2.2.1 255.255.255.0

#

 ip route-static 192.168.0.0 16 2.2.2.100

#

 radius session-control enable

#

radius scheme rs1

 primary authentication 192.168.0.111

 primary accounting 192.168.0.111

 key authentication cipher $c$3$Sqgqz7lDs4XPnethmAgyAKVlke7qwEkYbQ==

 key accounting cipher $c$3$4J/JBRGwqB4F213furJMkB6JWYXBFjWE6g==

 user-name-format without-domain

 nas-ip 2.2.2.1

#

domain dm1

authorization-attribute idle-cut 15 1024

 authentication portal radius-scheme rs1

 authorization portal radius-scheme rs1

 accounting portal radius-scheme rs1

#

portal host-check enable

portal free-rule 0 destination ip 192.168.0.0 255.255.255.0

portal free-rule 1 destination ip any udp 53

portal free-rule 2 destination ip any tcp 53

#

 portal roaming enable

 undo portal refresh arp enable

#

portal web-server newpt

 url http://192.168.0.111:8080/portal

 server-detect interval 60 retry 2 log

 server-type cmcc

 url-parameter ssid ssid

 url-parameter wlanacname value AC

 url-parameter wlanuserip source-address

#

portal server newpt

 ip 192.168.0.111 key cipher $c$3$Q82T/9AHq5HT7uFX7nho8K0Y6jziycoJTw==

 server-type cmcc

#

wlan ap office model WA4320i-ACN

 serial-id 219801A0CNC138011454

 radio 1

 radio 2

  radio enable

  service-template st1

#

·     Switch:

#

vlan 100

#

vlan 200

#

interface Vlan-interface200

 ip address 2.2.2.100 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 100 200

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

 poe enable

Related documentation

·     User Access and Authentication Configuration Guide in H3C Access Controllers Configuration Guides

·     User Access and Authentication Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Access Command Reference in H3C Access Controllers Command References