05-WLAN access

HomeSupportResource CenterH3C Access Controllers Configuration Examples(V7)-6W10205-WLAN access
09-Scheduled WLAN Access Services Configuration Examples

 

H3C Access Controllers

Scheduled WLAN Access Services

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example for configuring scheduled WLAN access services.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of DHCP and WLAN access.

Example: Configuring scheduled WLAN access services

Network configuration

As shown in Figure 1, the AC connects to the Layer 2 switch and the Layer 3 switch acts as a DHCP server to assign IP addresses to the AP and the client.

Configure network settings to meet the following requirements:

·     The client accesses the WLAN over VLAN 200.

·     The AC and the AP communicate with each other over VLAN 100.

·     The Layer 2 switch supplies power to the AP through PoE.

·     The AP provides WLAN access services only from 8:00 to 20:00 every day.

Figure 1 Network diagram

 

Analysis

·     For the Layer 3 switch to act as a DHCP server, enable the DHCP server feature on the switch.

·     For the Layer 2 switch to supply power to the AP, enable the PoE feature on the switch.

·     Create two schedules to enable and disable the WLAN service template on the AC at specific time points.

Restrictions and guidelines

When you configure a serial ID for the AP, use the serial ID labeled on the AP's rear panel.

Procedures

Configuring the Layer 3 switch

1.     Configure Layer 3 switch interfaces:

# Create VLAN 100 and VLAN-interface 100, and assign IP address 192.168.10.1 to the interface. The switch communicates with the AC over VLAN 100.

<L3 switch> system-view

[L3 switch] vlan 100

[L3 switch-vlan100] quit

[L3 switch] interface vlan-interface 100

[L3 switch-Vlan-interface100] ip address 192.168.10.1 255.255.255.0

[L3 switch-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign IP address 192.168.20.1 to the interface. The client will use this VLAN to access the WLAN.

[L3 switch] vlan 200

[L3 switch-vlan200] quit

[L3 switch] interface vlan-interface 200

[L3 switch-Vlan-interface200] ip address 192.168.20.1 255.255.255.0

[L3 switch-Vlan-interface200] quit

# Set the link type of GigabitEthernet 1/0/1 that connects the switch to the Layer 2 switch to trunk. Remove the port from VLAN 1 and assign the port to VLAN 100 and VLAN 200.

[L3 switch] interface gigabitEthernet 1/0/1

[L3 switch-GigabitEthernet1/0/1] port link-type trunk

[L3 switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[L3 switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[L3 switch-GigabitEthernet1/0/1] quit

2.     Configure the DHCP server feature:

# Enable DHCP server.

[L3 switch] dhcp enable

# Create DHCP address pool 1 for dynamic IP allocation to the AP. Specify 192.168.10.0/24 as the subnet and 192.168.10.1 as the gateway address in the address pool.

[L3 switch] dhcp server ip-pool 1

[L3 switch-dhcp-pool-1] network 192.168.10.0 mask 255.255.255.0

[L3 switch-dhcp-pool-1] gateway-list 192.168.10.1

# Exclude the IP address of VLAN-interface 100 on the AC from dynamic IP allocation in DHCP address pool 1.

[L3 switch-dhcp-pool-1] forbidden-ip 192.168.10.2

[L3 switch-dhcp-pool-1] quit

# Create DHCP address pool 2 for dynamic IP allocation to the client. Specify 192.168.20.0/24 as the subnet and 192.168.20.1 as the gateway address in the address pool, and then specify the address of the DNS server. In this example, the gateway also acts as the DNS server.

[L3 switch] dhcp server ip-pool 2

[L3 switch-dhcp-pool-2] network 192.168.20.0 mask 255.255.255.0

[L3 switch-dhcp-pool-2] gateway-list 192.168.20.1

[L3 switch-dhcp-pool-2] dns-list 192.168.20.1

[L3 switch-dhcp-pool-2] quit

Configuring the AC

1.     Configure AC interfaces:

# Create VLAN 100 and VLAN-interface 100, and assign IP address 192.168.10.2 to the interface. The AC will establish a CAPWAP tunnel with the AP in this VLAN.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.168.10.2 255.255.255.0

[AC-Vlan-interface100] quit

# Create VLAN 200. The client will use this VLAN to access the WLAN.

[AC] vlan 200

[AC-vlan200] quit

# Set the link type of GigabitEthernet 1/0/1 that connects the AC to the Layer 2 switch to trunk. Remove the port from VLAN 1 and assign the port to VLAN 100 and VLAN 200.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

2.     Configure a wireless service:

# Create service template 1 and enter its view.

[AC] wlan service-template 1

# Set the SSID to service1.

[AC-wlan-st-1] ssid service1

# Enable service template 1.

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

3.     Configure AP settings:

# Create AP officeap, and specify the AP model and serial ID.

[AC] wlan ap officeap model WA6320

[AC-wlan-ap-officeap] serial-id 209801A28N819CE0002T

# Bind service template 1 and VLAN 200 to radio 1.

[AC-wlan-ap-officeap] radio 1

[AC-wlan-ap-officeap-radio-1] service-template 1 vlan 200

# Enable radio 1.

[AC-wlan-ap-officeap-radio-1] radio enable

[AC-wlan-ap-officeap-radio-1] quit

[AC-wlan-ap-officeap] quit

4.     Configure the AC to enable service template 1 at a specific time point.

# Create job officeap_service_enable to enable service template 1.

[AC] scheduler job officeap_service_enable

[AC-job-officeap_service_enable] command 1 system-view

[AC-job-officeap_service_enable] command 2 wlan service-template 1

[AC-job-officeap_service_enable] command 3 service-template enable

[AC-job-officeap_service_enable] command 4 quit

[AC-job-officeap_service_enable] quit

# Create schedule officeap_service_enable and assign job officeap_service_enable to the schedule. The AC will enable service template 1 at 8:00 a.m. every day.

[AC] scheduler schedule officeap_service_enable

[AC-schedule-officeap_service_enable] job officeap_service_enable

[AC-schedule-officeap_service_enable] time repeating at 08:00

[AC-schedule-officeap_service_enable] quit

5.     Configure the AC to disable service template 1 at a specific time point.

# Create job officeap_service_disable to disable service template 1.

[AC] scheduler job officeap_service_disable

[AC-job-officeap_service_disable] command 1 system-view

[AC-job-officeap_service_disable] command 2 wlan service-template 1

[AC-job-officeap_service_disable] command 3 undo service-template enable

[AC-job-officeap_service_disable] command 4 quit

[AC-job-officeap_service_disable] quit

# Create schedule officeap_service_disable and assign job officeap_service_disable to the schedule. The AC will disable service template 1 at 20:00 every day.

[AC] scheduler schedule officeap_service_disable

[AC-schedule-officeap_service_disable] job officeap_service_disable

[AC-schedule-officeap_service_disable] time repeating at 20:00

[AC-schedule-officeap_service_disable] quit

[AC] quit

Configuring the Layer 2 switch

# Create VLAN 100 and VLAN 200. The switch will use VLAN 100 to forward traffic between the AC and other devices. The client will use VLAN 200 to access the WLAN.

<L2 switch> system-view

[L2 switch] vlan 100

[L2 switch-vlan100] quit

[L2 switch] vlan 200

[L2 switch-vlan200] quit

# Set the link type of GigabitEthernet 1/0/1 that connects the switch to the AC to trunk. Remove the port from VLAN 1 and assign the port to VLAN 100 and VLAN 200.

[L2 switch] interface gigabitEthernet 1/0/1

[L2 switch-GigabitEthernet1/0/1] port link-type trunk

[L2 switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[L2 switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[L2 switch-GigabitEthernet1/0/1] quit

# Set the link type of GigabitEthernet 1/0/2 that connects the switch to the AP to access. Assign the port to VLAN 100 and enable PoE.

[L2 switch] interfac gigabitEthernet 1/0/2

[L2 switch-GigabitEthernet1/0/2] port link-type access

[L2 switch-GigabitEthernet1/0/2] port access vlan 100

[L2 switch-GigabitEthernet1/0/2] poe enable

[L2 switch-GigabitEthernet1/0/2] quit

# Set the link type of GigabitEthernet 1/0/3 that connects the switch to the Layer 3 switch to trunk. Remove the port from VLAN 1 and assign the port to VLAN 100 and VLAN 200.

[L2 switch] interface gigabitEthernet 1/0/3

[L2 switch-GigabitEthernet1/0/3] port link-type trunk

[L2 switch-GigabitEthernet1/0/3] undo port trunk permit vlan 1

[L2 switch-GigabitEthernet1/0/3] port trunk permit vlan 100 200

[L2 switch-GigabitEthernet1/0/3] quit

Verifying the configuration

# Use the display wlan ap all command to view AP information on the AC. If the AP has connected to the AC, the state of the AP is R/M.

<AC> display wlan ap all

Total number of APs: 1

Total number of connected APs: 1

Total number of connected manual APs: 1

Total number of connected auto APs: 0

Total number of connected common APs: 1

Total number of connected WTUs: 0

Total number of inside APs: 0

Maximum supported APs: 3072

Remaining APs: 3071

Total AP licenses: 512

Remaining AP licenses: 511

 

                                 AP information

 State : I = Idle,      J  = Join,       JA = JoinAck,    IL = ImageLoad

         C = Config,    DC = DataCheck,  R  = Run,   M = Master,  B = Backup

 

AP name                AP ID   State   Model             Serial ID

officeap               1       R/M     WA6320            209801A28N819CE0002T

# During the period when the AC is scheduled to provide WLAN services, use the display wlan service-template command to view service template information on the AC. Service template 1 is enabled.

<AC> display wlan service-template 1

Service template name           SSID                                    Status

1                               service1                                Enabled

# During the period when the AC is scheduled to provide WLAN services, use the display wlan client command to view client information on the AC. The client has connected to radio 1 of the AP.

<AC> display wlan client

Total number of clients: 1

MAC address    User name            AP name               R IP address      VLAN

109a-dd9d-fc68 N/A                  officeap              1 192.168.20.2    200

# During the period when the AC is scheduled to not provide WLAN services, use the display wlan service-template command to view service template information on the AC. Service template 1 is disabled.

<AC> display wlan service-template 1

Service template name           SSID                                    Status

1                               service1                                Disabled

# During the period when the AC is scheduled to not provide WLAN services, use the display wlan client command to view client information on the AC. No client is online because service template 1 is disabled.

<AC> display wlan client

<AC>

Configuration files

·     L3 switch

#

 dhcp enable

#

vlan 1

#

vlan 100

#

vlan 200

#

dhcp server ip-pool 1

 gateway-list 192.168.10.1

 network 192.168.10.0 mask 255.255.255.0

 forbidden-ip 192.168.10.2

#

dhcp server ip-pool 2

 gateway-list 192.168.20.1

 network 192.168.20.0 mask 255.255.255.0

 dns-list 192.168.20.1

#

interface Vlan-interface100

 ip address 192.168.10.1 255.255.255.0

#

interface Vlan-interface200

 ip address 192.168.20.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

#

·     AC

#

vlan 100

#

vlan 200

#

wlan service-template 1

 ssid service1

 service-template enable

#

interface Vlan-interface1

#

interface Vlan-interface100

 ip address 192.168.10.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

#

scheduler job officeap_service_disable

 command 1 system-view

 command 2 wlan service-template 1

 command 3 undo service-template enable

 command 4 quit

#

scheduler job officeap_service_enable

 command 1 system-view

 command 2 wlan service-template 1

 command 3 service-template enable

 command 4 quit

#

scheduler schedule officeap_service_disable

 user-role network-operator

 user-role network-admin

 job officeap_service_disable

 time repeating at 20:00

#

scheduler schedule officeap_service_enable

 user-role network-operator

 user-role network-admin

 job officeap_service_enable

 time repeating at 08:00

#

wlan ap officeap model WA6320

 serial-id 209801A28N819CE0002T

vlan 1

 radio 1

  radio enable

  service-template 1 vlan 200

#

·     L2 switch

#

vlan 100

#

vlan 200

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

 poe enable

#

interface GigabitEthernet1/0/3

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

#

Related documentation

·     AP and WT Management Command Reference in H3C Access Controllers Command References

·     AP and WT Management Configuration Guide in H3C Access Controllers Configuration Guides

·     Network Connectivity Command Reference in H3C Access Controllers Command References

·     Network Connectivity Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Access Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides