国家 / 地区

02 IRF配置指导

01-IRF配置

本章节下载  (1.14 MB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S5560/S5560-EI/Configure/Operation_Manual/H3C_S5560-EI_CG-Release_11xx-6W104/02/201908/1222660_30005_0.htm

01-IRF配置


1 IRF

1.1  IRF简介

IRF(Intelligent Resilient Framework,智能弹性架构)是H3C自主研发的软件虚拟化技术。它的核心思想是将多台设备连接在一起,进行必要的配置后,虚拟化成一台设备。使用这种虚拟化技术可以集合多台设备的硬件资源和软件处理能力,实现多台设备的协同工作、统一管理和不间断维护。

为了便于描述,这个“虚拟设备”也称为IRF。所以,本文中的IRF有两层意思,一个是指IRF技术,一个是指IRF设备。

1.1.1  IRF的优点

IRF主要具有以下优点:

·            简化管理。IRF形成之后,用户通过任意成员设备的任意端口都可以登录IRF系统,对IRF内所有成员设备进行统一管理。

·            1:N备份。IRF由多台成员设备组成,其中,主设备负责IRF的运行、管理和维护,从设备在作为备份的同时也可以处理业务。一旦主设备故障,系统会迅速自动选举新的主设备,以保证业务不中断,从而实现了设备的1:N备份。

·            跨成员设备的链路聚合。IRF和上、下层设备之间的物理链路支持聚合功能,并且不同成员设备上的物理链路可以聚合成一个逻辑链路,多条物理链路之间可以互为备份也可以进行负载分担,当某个成员设备离开IRF,其它成员设备上的链路仍能收发报文,从而提高了聚合链路的可靠性。

·            强大的网络扩展能力。通过增加成员设备,可以轻松自如的扩展IRF的端口数、带宽。因为各成员设备都有CPU,能够独立处理协议报文、进行报文转发,所以IRF还能轻松自如的扩展处理能力。

1.1.2  IRF的应用

图1-1所示,主设备和从设备组成IRF,对上、下层设备来说,它们就是一台设备——IRF。

图1-1 IRF组网应用示意图

 

1.1.3  IRF基本概念

IRF虚拟化技术涉及如下基本概念:

1. 角色

IRF中每台设备都称为成员设备。成员设备按照功能不同,分为两种角色:

·            主用设备(简称为主设备):负责管理整个IRF。

·            从属设备(简称为从设备):作为主设备的备份设备运行。当主设备故障时,系统会自动从从设备中选举一个新的主设备接替原主设备工作。

主设备和从设备均由角色选举产生。一个IRF中同时只能存在一台主设备,其它成员设备都是从设备。关于设备角色选举过程的详细介绍请参见“1.2.3  角色选举”。

2. IRF端口

一种专用于IRF成员设备之间进行连接的逻辑接口,每台成员设备上可以配置两个IRF端口,分别为IRF-Port1和IRF-Port2。它需要和物理端口绑定之后才能生效。

3. IRF物理端口

与IRF端口绑定,用于IRF成员设备之间进行连接的物理接口。通常情况下,接口负责向网络中转发业务报文,将它们与IRF端口绑定后就作为IRF物理端口,可转发的报文包括IRF相关协商报文以及需要跨成员设备转发的业务报文。

由于IRF物理端口上不能开启STP或其它环路控制协议,IRF成员设备需要根据接收和发送报文的端口以及IRF的当前拓扑,来判断报文在发送后是否会产生环路。如果判断结果为会产生环路,设备将在位于环路路径上的发送端口处将报文丢弃。该方式会造成大量广播报文在IRF物理端口上被丢弃,此为正常现象。在使用SNMP工具监测设备端口的收发报文记录时,取消对IRF物理端口的监测,可以避免收到大量丢弃报文的告警信息。

4. IRF

域是一个逻辑概念,一个IRF对应一个IRF域。

为了适应各种组网应用,同一个网络里可以部署多个IRF,IRF之间使用域编号(DomainID)来以示区别。如图1-2所示,Device A和Device B组成IRF 1,Device C和Device D组成IRF 2。如果IRF 1和IRF 2之间有MAD检测链路,则两个IRF各自的成员设备间发送的MAD检测报文会被另外的IRF接收到,从而对两个IRF的MAD检测造成影响。这种情况下,需要给两个IRF配置不同的域编号,以保证两个IRF互不干扰。

图1-2 多IRF域示意图

 

5. IRF合并

图1-3所示,两个(或多个)IRF各自已经稳定运行,通过物理连接和必要的配置,形成一个IRF,这个过程称为IRF合并。

图1-3 IRF合并示意图

 

6. IRF分裂

图1-4所示,一个IRF形成后,由于IRF链路故障,导致IRF中两相邻成员设备不连通,一个IRF变成两个IRF,这个过程称为IRF分裂。

图1-4 IRF分裂示意图

 

7. 成员优先级

成员优先级是成员设备的一个属性,主要用于角色选举过程中确定成员设备的角色。优先级越高当选为主设备的可能性越大。

设备的缺省优先级均为1,如果想让某台设备当选为主设备,则在组建IRF前,可以通过命令行手工提高该设备的成员优先级。

1.2  IRF工作原理

IRF系统将经历物理连接拓扑收集角色选举IRF的管理与维护四个阶段。成员设备之间需要先建立IRF物理连接,然后会自动进行拓扑收集和角色选举,完成IRF的建立,此后进入IRF管理和维护阶段。

1.2.1  物理连接

要形成一个IRF,需要先连接成员设备的IRF物理端口。

1. 选择IRF物理端口

在S5560-EI系列交换机上可用的IRF物理端口如表1-1所示。并请注意“1.3  2. 选择IRF物理端口时的注意事项”。

表1-1 S5560-EI系列交换机可用的IRF物理端口

设备型号

可用的IRF物理端口

·      S5560-30S-EI

·      S5560-54S-EI

·      前面板上的SFP+口

·      后面板的QSFP+口

·      S5560-30C-EI

·      S5560-30C-PWR-EI

·      S5560-30F-EI

·      S5560-54C-EI

·      S5560-54C-PWR-EI

·      前面板上的SFP+口

·      后面板上通过插入接口模块扩展卡获得的10GBase-T以太网口/SFP+口/QSFP+口

S5560-54QS-EI

前面板上的SFP+口和QSFP+口

 

2. 连接介质

根据选用的IRF物理端口类型,S5560-EI系列交换机可以使用6A类及以上级别的双绞线、SFP+/QSFP+电缆或者SFP+/QSFP+模块和光纤来实现IRF连接。双绞线、SFP+/QSFP+电缆长度较短,性能和稳定性高,适用于机房内部短距离的IRF连接;而SFP+/QSFP+模块和光纤的组合则更加灵活,可以用于较远距离的IRF连接。

说明

·      有关SFP+/QSFP+模块的详细介绍,请参见《H3C光模块手册》。

·      H3C SFP+/QSFP+模块和SFP+/QSFP+电缆的种类随着时间变化有更新的可能性,所以,若您需要准确的模块种类信息,请咨询H3C公司市场人员或技术支援人员。

 

3. 连接要求

本设备上与IRF-Port1口绑定的IRF物理端口只能和邻居成员设备IRF-Port2口上绑定的IRF物理端口相连,本设备上与IRF-Port2口绑定的IRF物理端口只能和邻居成员设备IRF-Port1口上绑定的IRF物理端口相连,如图1-5所示。否则,不能形成IRF。

图1-5 IRF物理连接示意图

 

一个IRF端口可以与一个或多个IRF物理端口绑定,以提高IRF链路的带宽以及可靠性。本系列交换机最多可以将一个IRF端口与4个IRF物理端口进行绑定。

4. 连接拓扑

IRF的连接拓扑有两种:链形连接和环形连接,如图1-6所示。

·            链形连接对成员设备的物理位置要求比环形连接低,主要用于成员设备物理位置分散的组网。

·            环形连接比链形连接更可靠。因为当链形连接中出现链路故障时,会引起IRF分裂;而环形连接中某条链路故障时,会形成链形连接,IRF的业务不会受到影响。

图1-6 IRF连接拓扑示意图

 

1.2.2  拓扑收集

每个成员设备和邻居成员设备通过交互IRF Hello报文来收集整个IRF的拓扑。IRF Hello报文会携带拓扑信息,具体包括IRF端口连接关系、成员设备编号、成员设备优先级、成员设备的桥MAC等内容。

每个成员设备在本地记录自己已知的拓扑信息。设备刚启动时只记录了自身的拓扑信息。当IRF端口状态变为up后,设备会将已知的拓扑信息周期性的从up状态的IRF端口发送出去;邻居收到该信息后,会更新本地记录的拓扑信息;如此往复,经过一段时间的收集,所有成员设备都会收集到完整的拓扑信息。

此时会进入角色选举阶段。

1.2.3  角色选举

确定成员设备角色为主设备或从设备的过程称为角色选举。角色选举会在以下情况下进行:IRF建立、主设备离开或者故障、两个IRF合并等。

角色选举规则如下:

(1)       当前主设备优先,IRF不会因为有新的成员设备加入而重新选举主设备。不过,当IRF形成时,因为没有主设备,所有加入的设备都认为自己是主设备,则继续下一条规则的比较。

(2)       成员优先级大的优先。如果优先级相同,则继续下一条规则的比较。

(3)       系统运行时间长的优先。在IRF中,成员设备启动时间间隔精度为10分钟,即10分钟之内启动的设备,则认为它们是同时启动的,则继续下一条规则的比较。

(4)       CPU MAC小的优先。

通过以上规则选出的最优成员设备即为主设备,其它成员设备则均为从设备。

在角色选举完成后,IRF形成,进入IRF管理与维护阶段。

说明

·      IRF合并的情况下(分裂后重新合并的情况除外),每个IRF的主设备间会进行竞选,竞选仍然遵循角色选举的规则,竞选失败方的所有成员设备自动重启后均以从设备的角色加入获胜方,最终合并为一个IRF。

·      不管设备与其它设备一起形成IRF,还是加入已有IRF,如果该设备被选为从设备,则该设备会使用主设备的配置重新启动,以保证和主设备上的配置一致,本设备上的配置文件还在,但不再生效。

 

1.2.4  IRF的管理与维护

角色选举完成之后,IRF形成,所有的成员设备组成一台虚拟设备存在于网络中,所有成员设备上的资源归该虚拟设备拥有并由主设备统一管理。

1. 成员编号

在运行过程中,IRF使用成员编号来标识成员设备,以便对其进行管理。例如,IRF中接口的编号会加入成员编号信息:当设备独立运行时,接口编号第一维参数的值通常为1,加入IRF后,接口编号第一维参数的值会变成成员编号的值。所以,在IRF中必须保证所有设备成员编号的唯一性。

如果建立IRF时存在编号相同的成员设备,则不能建立IRF;如果新设备加入IRF,但是该设备与已有成员设备的编号冲突,则该设备不能加入IRF。请在建立IRF前,请统一规划各成员设备的编号,并逐一进行手工配置,以保证各设备成员编号的唯一性。

2. 接口命名规则

对于单独运行的设备(即没有加入任何IRF),接口编号采用设备编号/槽位编号/接口序号的格式,其中:

·            缺省情况下,设备编号为1。

·            如果设备曾经加入过IRF,则在退出IRF后,仍然会使用在IRF中时的成员编号作为自身的设备编号。

·            槽位编号:接口所在槽位的编号。对于S5560-EI系列交换机,前面板固定端口的槽位编号为0,后面板接口模块扩展卡插槽的槽位编号为1。

·            接口序号与各型号交换机支持的接口数量相关,请查看设备前面板上的丝印。

比如,要将单独运行的设备Sysname的接口GigabitEthernet1/0/1的接口链路类型设置为Trunk,可参照以下步骤:

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type trunk

对于IRF中的成员设备,接口编号仍然采用成员设备编号/槽位编号/接口序号的格式,其中:

·            成员设备编号用来标志不同成员设备上的接口。

·            槽位编号和接口序号的含义和取值与单独运行时的一样。

比如,将成员编号为3的从设备前面板上第一个端口的链路类型设置为Trunk,可参照以下步骤:

<Sysname> system-view

[Sysname] interface gigabitethernet 3/0/1

[Sysname-GigabitEthernet3/0/1] port link-type trunk

3. 文件系统命名规则

对于单独运行的设备,直接使用存储介质的名称就可以访问设备的文件系统(存储介质的命名请参见“基础配置指导”中的“文件系统管理配置”)。

对于IRF中的成员设备,直接使用存储介质的名称可以访问主设备的文件系统,使用“slotMember-ID#存储介质的名称”才可以访问从设备的文件系统。

比如:

(1)       创建并访问IRF中主设备存储介质Flash根目录下的test文件夹,可参照以下步骤:

<Master> mkdir test

Creating directory flash:/test... Done.

<Master> dir

Directory of flash:                                                            

   0 -rw-    43548660 Jan 01 2011 08:21:29   system.ipe                          

   1 drw-           - Jan 01 2011 00:00:30   diagfile                          

   2 -rw-         567 Jan 02 2011 01:41:54   dsakey                            

   3 -rw-         735 Jan 02 2011 01:42:03   hostkey                           

   4 -rw-          36 Jan 01 2011 00:07:52   ifindex.dat                        

   5 -rw-           0 Jan 01 2011 00:53:09   lauth.dat                         

   6 drw-           - Jan 01 2011 06:33:55   log                           

   7 drw-           - Jan 02 2000 00:00:07   logfile                            

   8 -rw-    23724032 Jan 01 2011 00:49:47   switch-cmw710-system.bin 

   9 drw-           - Jan 01 2000 00:00:07   seclog                            

  10 -rw-         591 Jan 02 2011 01:42:03   serverkey                         

  11 -rw-        4609 Jan 01 2011 00:07:53   startup.cfg                       

  12 -rw-        3626 Jan 01 2011 01:51:56   startup.cfg_bak                   

  13 -rw-       78833 Jan 01 2011 00:07:53   startup.mdb                       

  14 drw-           - Jan 01 2011 00:15:48   test                              

  25 drw-           - Jan 01 2011 04:16:53   versionInfo                       

                                                                               

524288 KB total (365292 KB free)                  

(2)       创建并访问IRF中从设备(成员编号为3)存储介质Flash根目录下的test文件夹,可参照以下步骤:

<Master> mkdir slot3#flash:/test

Creating directory slot3#flash:/test... Done.

<Master> cd slot3#flash:/test

<Master> pwd

slot3#flash:/test

或者:

<Master> cd slot3#flash:/

<Master> mkdir test

Creating directory slot3#flash:/test... Done.

(3)       Master的test.ipe文件拷贝到该从设备Flash的根目录下,可参照以下步骤:

<Master> pwd

slot3#flash:

// 以上显示信息表明,当前的工作路径是编号为3的从设备的Flash的根目录

<Master> cd flash:/

<Master> pwd

flash:

// 以上操作表明,当前的工作路径已经回到了主设备Flash的根目录

<Master> copy test.ipe slot3#flash:/

Copy flash:/test.ipe to slot3#flash:/test.ipe?[Y/N]:y     

Copying file flash:/test.ipe to slot3#flash:/test.ipe... Done.  

4. 配置文件的同步

IRF技术使用了严格的配置文件同步机制,来保证IRF中的多台设备能够像一台设备一样在网络中工作,并且在主设备出现故障之后,其余设备仍能够正常执行各项功能。

·            IRF中的从设备在启动时,会自动寻找主设备,并将主设备的当前配置文件同步到本地并执行;如果IRF中的所有设备同时启动,则从设备会将主设备的起始配置文件同步至本地并执行。

·            IRF正常工作后,用户所进行的任何配置,都会记录到主设备的当前配置文件中,并同步到IRF中的各个设备执行。

通过即时的同步,IRF中所有设备均保存有相同的配置文件,即使主设备出现故障,其它设备仍能够按照相同的配置文件执行各项功能。

5. IRF拓扑维护

如果某成员设备A故障或者IRF链路故障,其邻居设备会立即将“成员设备A离开”的信息广播通知给IRF中的其它设备。获取到离开消息的成员设备会根据本地维护的IRF拓扑信息表来判断离开的是主设备还是从设备,如果离开的是主设备,则触发新的角色选举,再更新本地的IRF拓扑;如果离开的是从设备,则直接更新本地的IRF拓扑,以保证IRF拓扑能迅速收敛。

说明

IRF端口的状态由与它绑定的IRF物理端口的状态决定。与IRF端口绑定的所有IRF物理端口状态均为down时,IRF端口的状态才会变成down。

 

1.2.5  MAD功能

IRF链路故障会导致一个IRF变成多个新的IRF。这些IRF拥有相同的IP地址等三层配置,会引起地址冲突,导致故障在网络中扩大。为了提高系统的可用性,当IRF分裂时我们就需要一种机制,能够检测出网络中同时存在多个IRF,并进行相应的处理,尽量降低IRF分裂对业务的影响。MAD(Multi-Active Detection,多Active检测)就是这样一种检测和处理机制。它主要提供以下功能:

1. 分裂检测

通过LACP(Link Aggregation Control Protocol,链路聚合控制协议)、BFD(Bidirectional Forwarding Detection,双向转发检测)、ARP(Address Resolution Protocol)或者ND(Neighbor Discovery Protocol)来检测网络中是否存在多个IRF。同一IRF中可以配置一个或多个检测机制,详细信息,请参考“1.5.9  MAD配置”。

2. 冲突处理

IRF分裂后,通过分裂检测机制IRF会检测到网络中存在其它正常工作的IRF。

·            对于LACP MAD检测,冲突处理会先比较两个IRF中成员设备的数量,数量多的IRF继续工作;数量少的迁移到Recovery状态(即禁用状态);如果成员数量相等,则主设备成员编号小的IRF继续正常工作;其它IRF迁移到Recovery状态(即禁用状态)。

·            对于BFD MAD/ ARP MAD/ND MAD检测,冲突处理会直接让主设备成员编号小的IRF继续正常工作;其它IRF迁移到Recovery状态(即禁用状态)。

IRF迁移到Recovery状态后会关闭该IRF中所有成员设备上除保留端口以外的其它所有物理端口(通常为业务接口),以保证该IRF不能再转发业务报文。缺省情况下,只有IRF物理端口是保留端口,可通过mad exclude interface命令配置。

3. MAD故障恢复

IRF链路故障导致IRF分裂,从而引起多Active冲突。因此修复故障的IRF链路,让冲突的IRF重新合并为一个IRF,就能恢复MAD故障。

·            如果出现故障的是继续正常工作的IRF,则在进行MAD故障恢复前,可以通过命令行先启用Recovery状态的IRF,让它接替原IRF工作,以便保证业务尽量少受影响,再恢复MAD故障。

·            如果在MAD故障恢复前,处于Recovery状态的IRF也出现了故障,则需要将故障IRF和故障链路都修复后,才能让冲突的IRF重新合并为一个IRF,恢复MAD故障。

关于LACP的详细介绍请参见“二层技术-以太网交换配置指导”中的“以太网链路聚合”;关于BFD的详细介绍请参见“可靠性配置指导”中的“BFD”;关于ARP的详细介绍请参见“三层技术-IP业务配置指导”中的“ARP”;关于ND的详细介绍请参见“三层技术-IP业务配置指导”中的“IPv6基础”。

1.3  配置限制和指导

1. 组建IRF时的注意事项

·            本系列交换机仅能与相同系列的交换机之间建立IRF。

·            IRF中所有成员设备的软件版本必须相同,如果有软件版本不同的设备要加入IRF,请确保IRF的启动文件同步加载功能处于使能状态。

·            如果两个IRF的桥MAC地址相同,请修改其中一个IRF的桥MAC地址,否则,它们不能合并为一个IRF。

·            在多台设备形成IRF之前,请确保在各设备上以下功能的配置保持一致。

¡  表项容量(通过switch-mode命令配置)。

¡  最大等价路由条数(通过max-ecmp-num命令配置)。

¡  IPv4等价路由增强模式(通过ecmp mode命令配置)。

¡  前缀大于64位的IPv6路由功能(通过switch-routing-mode命令配置)。

说明

关于表项容量的配置,请参见“基础配置指导”中的“设备管理配置”。关于最大等价路由条数、IPv4等价路由增强模式和前缀大于64位的IPv6路由功能的配置,请参见“三层技术-IP路由配置指导”中的“IP路由基础配置”。

 

2. 选择IRF物理端口时的注意事项

在选择IRF物理端口时,需要注意的是:

·            10GBase-T以太网口和SFP+口只有工作在10Gbps速率时才能够作为IRF物理端口;QSFP+口只有工作在40Gbps速率时才能作为IRF物理端口。

·            S5560-54QS-EI交换机上,两个QSFP+口不能组成聚合IRF端口,在四个SFP+口中,编号为49和50的端口可以形成聚合IRF端口,编号为51和52的端口可以形成聚合IRF端口,不支持其它形式的组合。

·            S5560-EI系列交换机的其它款型上,只要IRF物理端口的速率相同,即可以组成聚合IRF端口。

3. IRF形成后的配置限制和指导

·            以太网接口作为IRF物理端口与IRF端口绑定后,只支持shutdowndescriptionpriority-flow-controlflow-interval命令,这些命令的详细介绍,请参见“二层技术-以太网交换命令参考”中的“以太网接口命令”。

·            如果在IRF建立后,用户需要拔出IRF物理端口所在的接口模块扩展卡,请先拔掉用于IRF连接的线缆,或者先在IRF物理端口视图下执行shutdown命令关闭该端口后,再进行拔出接口模块扩展卡的操作。

·            因为LACP MAD和BFD MAD、ARP MAD、ND MAD冲突处理的原则不同,请不要同时配置。BFD MAD、ARP MAD、ND MAD这三种方式独立工作,彼此之间互不干扰,可以同时配置。

·            LACP MAD、ARP MAD和ND MAD检测组网中,如果中间设备本身也是一个IRF系统,则必须通过配置确保其IRF域编号与被检测的IRF系统不同,否则可能造成检测异常,甚至导致业务中断。在BFD MAD检测组网中,IRF域编号为可选配置。

·            IRF域编号是一个全局变量,IRF中的所有成员设备都共用这个IRF域编号。在任何成员设备上通过irf domainmad enablemad arp enable或者mad nd enable命令均可修改全局IRF域编号。因此,请按照网络规划来修改IRF域编号,不要随意修改。

·            IRF迁移到Recovery状态后会关闭该IRF中所有成员设备上除保留端口以外的其它所有物理端口(通常为业务接口),保留端口可通过mad exclude interface命令配置。

·            如果接口因为多Active冲突被关闭,则只能等IRF恢复到正常工作状态后,接口才能自动被激活,不能通过undo shutdown命令来激活。

1.4  IRF配置任务简介

建议用户使用以下步骤来建立IRF

(1)       进行网络规划,明确使用哪台设备作为主设备、各成员设备的编号以及各成员设备上的IRF物理端口;

(2)       修改设备的成员编号(成员编号修改后需要重启设备才能生效);

(3)       修改设备的成员优先级,将希望被选为主设备的设备的成员优先级设置为较大值;

(4)       安装接口模块扩展卡(可选)

(5)       连接IRF线缆,确保IRF物理端口之间是连通的;

(6)       配置IRF端口;

(7)       将当前配置保存到下次启动配置文件,以便设备重启后,IRF配置能够继续生效;

(8)       激活IRF端口下的配置(会引起IRF合并,竞选失败的设备重启后重新加入IRF);

(9)       IRF形成,访问IRF;

(10)    配置MAD。

表1-2 IRF配置任务简介

配置任务

说明

详细配置

配置成员编号

必选

1.5.1 

配置成员优先级

可选

1.5.2 

配置IRF端口

必选

1.5.3 

配置成员设备的描述信息

可选

1.5.3 

配置IRF链路的负载分担类

可选

1.5.5 

配置IRF的桥MAC保留时间

可选

1.5.6 

使能IRF系统启动软件的自动加载功能

可选

1.5.7 

配置IRF链路down延迟上报功能

可选

1.5.8 

MAD配置

必选

1.5.9 

访问IRF

必选

1.6 

 

1.5  IRF配置

1.5.1  配置成员编号

注意

IRF中以成员编号标识设备,IRF端口和成员优先级的配置也和成员编号紧密相关。所以,修改设备成员编号可能导致配置发生变化或者失效,请慎重使用。

 

请确认IRF中的成员设备编号唯一。如果存在相同的成员编号,则不能建立IRF。如果新设备加入IRF,但是该设备与已有成员设备的编号冲突,则该设备不能加入IRF。

·            修改成员编号后,但是没有重启本设备,则原编号继续生效,各物理资源仍然使用原编号来标识。

·            修改成员编号后,如果保存当前配置,重启本设备,则新的成员编号生效,需要用新编号来标识物理资源;配置文件中,只有IRF端口的编号以及IRF端口下的配置、成员优先级会继续生效,其它与成员编号相关的配置(比如普通物理接口的配置等)不再生效,需要重新配置。

表1-3 配置成员编号

操作

命令

说明

进入系统视图

system-view

-

配置成员编号

irf member member-id renumber new-member-id

缺省情况下,设备的成员编号均为1

 

说明

 

1.5.2  配置成员优先级

在主设备选举过程中,优先级数值大的成员设备将优先被选举成为主设备。

表1-4 配置成员优先级

操作

命令

说明

进入系统视图

system-view

-

配置IRF中指定成员设备的优先级

irf member member-id priority priority

缺省情况下,设备的成员优先级均为1

 

1.5.3  配置IRF端口

IRF端口是一个逻辑的概念,只有配置IRF端口(即将IRF端口与IRF物理端口绑定)之后,设备的IRF功能才能使能。

表1-5 配置IRF端口

操作

命令

说明

进入系统视图

system-view

-

进入IRF物理端口视图

interface interface-type interface-number

在使用QSFP+口作为IRF物理端口时,请进入端口视图

在使用10GBase-T以太网口或SFP+口作为IRF物理端口时,请进入对应一组接口的接口批量配置视图

在将一个IRF端口与多个物理端口进行绑定时,通过接口批量配置视图可以更快速的完成关闭和开启多个端口的操作

进入对应一组接口的接口批量配置视图

interface range { interface-type interface-number [ to interface-type interface-number ] } &<1-5>

关闭接口

shutdown

缺省情况下,接口处于激活状态

退回系统视图

quit

-

进入IRF端口视图

irf-port member-id/port-number

-

将IRF端口和IRF物理端口绑定

port group interface interface-type interface-number

缺省情况下,IRF端口没有和任何IRF物理端口绑定

多次执行该命令,可以将IRF端口与多个IRF物理端口绑定,以实现IRF链路的备份或负载分担,从而提高IRF链路的带宽和可靠性。在本系列交换机上,最多可以将4个IRF物理端口与一个IRF端口进行绑定。当绑定的物理端口数达到上限时,该命令将执行失败

退回到系统视图

quit

-

进入IRF物理端口视图

interface interface-type interface-number

在使用QSFP+口作为IRF物理端口时,请进入端口视图

在使用10GBase-T以太网口或SFP+口作为IRF物理端口时,请进入对应一组接口的接口批量配置视图

进入对应一组接口的接口批量配置视图

interface range { interface-type interface-number [ to interface-type interface-number ] } &<1-5>

激活接口

undo shutdown

-

退回系统视图

quit

-

保存当前配置

save

激活IRF端口会引起IRF合并,进而设备需要重启。为了避免重启后配置丢失,请在激活IRF端口前先将当前配置保存到下次启动配置文件

激活IRF端口下的配置

irf-port-configuration active

IRF物理线缆连接好,并将IRF物理端口添加到IRF端口后,必须通过该命令手工激活IRF端口的配置才能形成IRF

 

说明

在对IRF物理端口执行shutdown操作时,需要首先在主设备或是距离主设备较近(跳数较少)的设备上对IRF物理端口进行操作。

 

1.5.4  配置成员设备的描述信息

当网络中存在多个IRF或者同一IRF中存在多台成员设备且物理位置比较分散(比如在不同楼层甚至不同建筑)时,为了确认成员设备的物理位置,在组建IRF时可以将物理位置设置为成员设备的描述信息,以便后期维护。

表1-6 配置成员设备的描述信息

操作

命令

说明

进入系统视图

system-view

-

配置IRF中指定成员设备的描述信息

irf member member-id description text

缺省情况下,成员设备没有描述信息

 

1.5.5  配置IRF链路的负载分担类型

当IRF端口与多个IRF物理端口绑定时,成员设备之间就会存在多条IRF链路。通过改变IRF链路负载分担的类型,可以灵活地实现成员设备间流量的负载分担。用户既可以指定系统按照报文携带的IP地址、MAC地址等信息之一或其组合来选择所采用的负载分担类型,也可以指定系统按照报文类型(如二层、IPv4、IPv6等)自动选择所采用的负载分担类型。

目前设备上支持配置的负载分担类型包括:

·            根据报文类型自动匹配负载分担类型;

·            根据源IP地址进行负载分担;

·            根据目的IP地址进行负载分担;

·            根据源MAC地址进行负载分担;

·            根据目的MAC地址进行负载分担;

·            根据源IP地址与目的IP地址进行负载分担;

·            根据源MAC地址与目的MAC地址进行负载分担;

用户可以通过全局配置(系统视图下)和端口下(IRF端口视图下)配置的方式设置IRF链路的负载分担类型:

·            在系统视图下的配置对所有IRF端口生效;

·            IRF端口视图下的配置只对当前IRF端口下的IRF链路生效;

·            IRF端口会优先采用端口下的配置。如果端口下没有配置,则采用全局配置。

说明

·      IRF链路的负载分担功能对所有报文均能生效(包括单播、组播和广播报文)。

·      在同一视图下多次配置irf-port load-sharing mode命令,以最新的配置为准。

·      对于设备不支持的负载分担类型,系统将提示用户不支持。

 

表1-7 全局配置IRF链路的负载分担类型

操作

命令

说明

进入系统视图

system-view

-

配置IRF链路的负载分担类型

irf-port global load-sharing mode { destination-ip | destination-mac | source-ip | source-mac } *

缺省情况下,本系列交换机在处理报文时通过报文类型来进行负载分担

 

表1-8 端口下配置IRF链路的负载分担类型

操作

命令

说明

进入系统视图

system-view

-

进入IRF端口视图

irf-port member-id/port-number

-

配置IRF链路的负载分担类型

irf-port load-sharing mode { destination-ip | destination-mac | source-ip | source-mac } *

缺省情况下,本系列交换机在处理报文时通过报文类型来进行负载分担

在IRF端口下配置负载分担类型前,IRF端口必须至少和一个IRF物理端口绑定。否则,负载分担类型将配置失败。

 

说明

如果需要在IRF链路的负载分担算法中,将报文的TCP/UDP端口号作为报文类型特征进行计算,可以通过下面两种配置方法来实现:

·      IRF聚合负载分担类型保持为缺省值。

·      IRF负载分担类型配置为源IP/目的IP或二者的组合,将全局聚合负载分担类型配置为源服务端口号/目的服务端口号或二者的组合。

关于全局聚合负载分担类型的配置,请参见“二层技术-以太网交换配置指导”中的“以太网链路聚合”。

 

1.5.6  配置IRF的桥MAC保留时间

注意

·      MAC变化可能导致流量短时间中断,请谨慎配置。

·      如果两个IRF的桥MAC相同,则它们不能合并为一个IRF。

 

桥MAC是设备作为网桥与外界通信时使用的MAC地址。一些二层协议(例如LACP)会使用桥MAC标识不同设备,所以网络上的桥设备必须具有唯一的桥MAC。如果网络中存在桥MAC相同的设备,则会引起桥MAC冲突,从而导致通信故障。

IRF作为一台虚拟设备与外界通信,也具有唯一的桥MAC,称为IRF桥MAC。IRF会选用某台成员设备的桥MAC作为IRF的桥MAC,这台成员设备被称为IRF桥MAC拥有者。通常情况下,IRF使用主设备的桥MAC作为IRF桥MAC。

因为桥MAC冲突会引起通信故障,桥MAC的切换又会导致流量中断。因此,用户需要根据网络实际情况配置IRF桥MAC的保留时间:

·            如果配置了IRF桥MAC保留时间为6分钟,则当IRF桥MAC拥有者离开IRF时,IRF桥MAC在6分钟内保持不变化;如果6分钟后IRF桥MAC拥有者没有回到IRF,则使用IRF中当前主设备的桥MAC作为IRF桥MAC。该配置适用于IRF桥MAC拥有者短时间内离开又回到IRF的情况(比如重启或者链路临时故障等),可以减少不必要的桥MAC切换导致的流量中断。

·            如果配置了IRF桥MAC保留时间为永久,则不管IRF桥MAC拥有者是否离开IRF,IRF桥MAC始终保持不变。

·            如果配置了IRF桥MAC不保留,则当IRF桥MAC拥有者离开IRF时,系统会立即使用IRF中当前主设备的桥MAC做IRF桥MAC。

表1-9 配置IRF的桥MAC保留时间

操作

命令

说明

进入系统视图

system-view

-

配置IRF的桥MAC会永久保留

irf mac-address persistent always

缺省情况下,IRF的桥MAC的保留时间为6分钟

配置IRF的桥MAC的保留时间为6分钟

irf mac-address persistent timer

配置IRF的桥MAC不保留,会立即变化

undo irf mac-address persistent

 

注意

·      当使用ARP MAD/ND MAD和生成树综合组网时,需要将IRF配置为桥MAC立即改变,即配置undo irf mac-address persistent命令。

·      当使用链型拓扑搭建IRF,且IRF与其他设备之间有聚合链路存在时,如果需要重启主设备,请先配置IRF的桥MAC为永久保留,避免因为桥MAC变化造成数据传输的延时甚至丢包。

 

1.5.7  使能启动软件的自动加载功能

注意

 

如果新设备加入IRF,并且新设备的软件版本和主设备的软件版本不一致,则新加入的设备不能正常启动。此时:

·            如果没有使能启动软件的自动加载功能,则需要用户手工升级新设备后,再将新设备加入IRF。或者在主设备上使能启动软件的自动加载功能,重启新设备,让新设备重新加入IRF。

·            如果已经使能了启动软件的自动加载功能,则新设备加入IRF时,会与主设备的软件版本号进行比较,如果不一致,则自动从主设备下载启动软件,然后使用新的系统启动软件重启,重新加入IRF。如果新下载的启动软件的文件名与设备上原有启动软件文件名重名,则原有启动软件会被覆盖。

为了能够自动加载成功,请确保从设备存储介质上有足够的空闲空间用于存放新的启动软件。如果从设备存储介质上空闲空间不足,系统会自动删除从设备的当前启动软件来完成加载。如果删除从设备的当前启动软件后空间仍然不足,从设备将无法进行自动加载。此时,需要管理员重启从设备并进入从设备的Boot ROM菜单,删除一些不重要的文件后,再让从设备重新加入IRF。

表1-10 使能IRF系统启动软件的自动加载功能

操作

命令

说明

进入系统视图

system-view

-

使能IRF系统启动软件的自动加载功能

irf auto-update enable

缺省情况下,IRF系统启动软件的自动加载功能处于使能状态

 

1.5.8  配置IRF链路down延迟上报功能

配置IRF链路down延迟上报功能后,

·            如果IRF链路状态从up变为down,端口不会立即向系统报告链路状态变化。经过一定的时间间隔后,如果IRF链路仍然处于down状态,端口才向系统报告链路状态的变化,系统再做出相应的处理;

·            如果IRF链路状态从down变为up,链路层会立即向系统报告。

该功能用于避免因端口链路层状态在短时间内频繁改变,导致IRF分裂/合并的频繁发生。

表1-11 配置IRF链路down延迟上报功能

操作

命令

说明

进入系统视图

system-view

-

配置IRF链路down延迟上报时间

irf link-delay interval

缺省情况下,IRF链路down延迟上报时间为4秒

当IRF链路down延迟时间为缺省值时,如果IRF链路的不稳定状态持续时间不超过4秒,则不会导致IRF分裂;但如果某些协议配置的超时时间小于4秒(例如CFD、VRRP、OSPF等),该协议将超时。此时请适当调整IRF链路down的延迟上报时间或者该协议的超时时间,使IRF链路down的延迟上报时间小于协议超时时间,保证协议状态不会发生不必要的切换

在对主备倒换速度和IRF链路切换速度要求较高,或部署了BFD、GR功能的环境中,建议将IRF链路down延迟上报时间配置为0

在执行关闭IRF物理端口或重启IRF成员设备的操作之前,请首先将IRF链路down延迟上报时间配置为0,待操作完成后再将其恢复为之前的值

 

1.5.9  MAD配置

设备支持的MAD检测方式有:LACP MAD检测、BFD MAD检测、ARP MAD检测和ND MAD检测。几种MAD检测机制各有特点,用户可以根据现有组网情况进行选择。因为LACP MAD和BFD MAD、ARP MAD、ND MAD冲突处理的原则不同,请不要同时配置。BFD MAD、ARP MAD、ND MAD这三种方式独立工作,彼此之间互不干扰,可以同时配置。

表1-12 MAD检测机制的比较

MAD检测方式

优势

限制

LACP MAD

检测速度快,利用现有聚合组网即可实现,无需占用额外接口,利用聚合链路同时传输普通业务报文和MAD检测报文(扩展LACP报文)

组网中需要使用H3C设备作为中间设备,每个成员设备都需要连接到中间设备

BFD MAD

检测速度较快,组网形式灵活,对其它设备没有要求

配置专用三层接口,这些接口不能再传输普通业务流量

·      如果不使用中间设备,则要求成员设备间是全链接,即每个成员设备都必须和其它所有成员设备相连。该链路专用于MAD检测,不能再传输普通业务流量。该方式适用于成员设备少,并且物理距离比较近的组网环境

·      如果使用中间设备,组网时每个成员设备都需要连接到中间设备,这些BFD链路专用于MAD检测

ARP MAD

非聚合的IPv4组网环境,和MSTP配合使用,无需占用额外端口。在使用中间设备的组网中对中间设备没有要求

检测速度慢于前两种

ND MAD

非聚合的IPv6组网环境,和MSTP配合使用,无需占用额外端口。在使用中间设备的组网中对中间设备没有要求

检测速度慢于前两种

 

1. LACP MAD检测

(1)       LACP MAD检测原理

LACP MAD检测是通过扩展LACP协议报文内容实现的,即在LACP协议报文的扩展字段内定义一个新的TLV(Type/Length/Value,类型/长度/值)数据域——用于交互IRF的DomainID(域编号)和ActiveID(等于主设备的成员编号)。

使能LACP MAD检测后,成员设备通过LACP协议报文和其它成员设备交互DomainID和ActiveID信息。

·            当成员设备收到LACP协议报文后,先比较DomainID。如果DomainID相同,再比较ActiveID;如果DomainID不同,则认为报文来自不同IRF,不再进行MAD处理。

·            如果ActiveID相同,则表示IRF正常运行,没有发生多Active冲突;如果ActiveID值不同,则表示IRF分裂,检测到多Active冲突。

(2)       LACP MAD检测组网要求

注意

LACP MAD检测组网中,如果中间设备本身也是一个IRF系统,则必须通过配置确保其IRF域编号与被检测的IRF系统不同,否则可能造成检测异常,甚至导致业务中断。

 

LACP MAD检测方式组网中需要使用H3C设备作为中间设备。通常采用如图1-7所示的组网:成员设备之间通过Device交互LACP扩展报文。

图1-7 LACP MAD检测组网示意图

 

(3)       配置LACP MAD检测

LACP MAD检测的配置步骤为:

·            配置IRF域编号;

·            创建聚合接口;(中间设备上也需要进行该项配置)

·            将聚合接口的工作模式配置为动态聚合模式;(中间设备上也需要进行该项配置)

·            在动态聚合接口下使能LACP MAD检测功能;

·            给聚合组添加成员端口。(中间设备上也需要进行该项配置)

表1-13 配置LACP MAD检测

操作

命令

说明

进入系统视图

system-view

-

配置IRF域编号

irf domain domain-id

缺省情况下,IRF的域编号为0

创建并进入聚合接口视图

进入二层聚合接口视图

interface bridge-aggregation interface-number

二者选其一

进入三层聚合接口视图

interface route-aggregation interface-number

配置聚合组工作在动态聚合模式下

link-aggregation mode dynamic

缺省情况下,聚合组工作在静态聚合模式下

使能LACP MAD检测功能

mad enable

缺省情况下,LACP MAD检测未使能

退回系统视图

quit

-

进入以太网接口视图

interface interface-type interface-number

-

将以太网接口加入聚合组

port link-aggregation group number

-

 

2. BFD MAD检测

(1)       BFD MAD检测原理

BFD MAD检测是通过BFD协议来实现的。要使BFD MAD检测功能正常运行,除在三层接口下使能BFD MAD检测功能外,还需要在该接口上配置MAD IP地址。MAD IP地址与普通IP地址不同的地方在于:MAD IP地址与成员设备是绑定的,IRF中的每个成员设备上都需要配置,且所有成员设备的MAD IP必须属于同一网段。

·            IRF正常运行时,只有主设备上配置的MAD IP地址生效,从设备上配置的MAD IP地址不生效,BFD会话处于down状态;(使用display bfd session命令查看BFD会话的状态。如果Session State显示为Up,则表示激活状态;如果显示为Down,则表示处于down状态)

·            IRF分裂形成多个IRF时,不同IRF中主设备上配置的MAD IP地址均会生效,BFD会话被激活,此时会检测到多Active冲突。

(2)       BFD MAD检测组网要求

BFD MAD检测方式可以使用中间设备来进行连接,也可以不使用中间设备。在使用中间设备时,可以使用以太网端口或管理用以太网口来实现BFD MAD检测,如图1-8所示。

用于BFD MAD检测的以太网端口需要属于同一VLAN,在该VLAN接口视图下为不同成员设备配置同一网段内的不同MAD IP地址。

如果使用管理用以太网口实现BFD MAD检测,只需要为每台成员设备的管理用以太网口配置同一网段内的不同MAD IP地址即可。

图1-8 使用中间设备实现BFD MAD检测组网示意图

 

在没有中间设备时,需要采用如图1-9所示的组网方式:每台成员设备必须和其它所有成员设备之间使用以太网端口建立BFD MAD检测链路(即成员设备之间是全连接组网)。这些链路连接的接口必须属于同一VLAN,在该VLAN接口视图下给不同成员设备配置同一网段下的不同IP地址。

图1-9 不使用中间设备实现BFD MAD检测组网示意图

 

·      除管理用以太网口外,使能BFD MAD检测功能的三层接口只能专用于BFD MAD检测,这些接口下建议只配置mad bfd enablemad ip address命令。如果用户配置了其它命令,可能会影响该业务以及BFD MAD检测功能的运行。

·      用于BFD MAD检测的三层接口对应的VLAN中只能包含BFD MAD检测链路上的端口,请不要将其它端口加入该VLAN。当某个业务端口需要使用port trunk permit vlan all命令允许所有VLAN通过时,请使用undo port trunk permit命令将用于BFD MAD的VLAN排除。

 

注意

BFD MAD检测组网中,如果中间设备本身也是一个IRF系统,则必须通过配置确保其IRF域编号与被检测的IRF系统不同,否则可能造成检测异常,甚至导致业务中断。

 

(3)       配置BFD MAD检测

配置BFD MAD检测时,请遵循以下要求:

·            使能了BFD MAD检测功能的VLAN接口以及对应VLAN内的端口上不支持包括ARP和LACP在内的所有的二层或三层协议应用。

·            不允许在Vlan-interface1接口上使能BFD MAD检测功能。

·            BFD MAD检测功能与VPN功能互斥,请不要将使能了BFD MAD检测功能的三层接口与VPN实例进行绑定。

·            BFD MAD检测功能与生成树功能互斥,在使能了BFD MAD检测功能的VLAN接口绑定的二层以太网接口上,请关闭生成树协议。

·            如果网络中存在多个IRF,在配置BFD MAD时,各IRF必须使用不同的VLAN作为BFD MAD检测专用VLAN。

·            在用于BFD MAD检测的接口下必须使用mad ip address命令配置MAD IP地址,而不要配置其它IP地址(包括使用ip address命令配置的普通IP地址等),以免影响MAD检测功能。

使用以太网端口进行BFD MAD检测功能的配置顺序为:

·            创建一个新VLAN,专用于BFD MAD检测;(对于使用中间设备的组网,中间设备上也需要进行该项配置)

·            确定哪些物理端口用于BFD MAD检测,并将这些端口都添加到BFD MAD检测专用VLAN中;(如果用到中间设备组网,中间设备上也需要进行该项配置)

·            为BFD MAD检测专用VLAN创建VLAN接口,在接口下使能BFD MAD检测功能,并配置MAD IP地址。

表1-14 配置BFD MAD检测

操作

命令

说明

进入系统视图

system-view

-

(可选)配置IRF域编号

irf domain domain-id

缺省情况下,IRF的域编号为0

创建一个新VLAN专用于BFD MAD检测

vlan vlan-id

缺省情况下,设备上只存在VLAN 1

VLAN 1不能用于BFD MAD检测

退回系统视图

quit

-

进入以太网接口视图

interface interface-type interface-number

-

将端口加入BFD MAD检测专用VLAN

Access端口

port access vlan vlan-id

请根据端口的当前链路类型选择对应的配置命令

BFD MAD检测对检测端口的链路类型没有要求,不需要刻意修改端口的当前链路类型。缺省情况下,端口端的链路类型为Access端口

Trunk端口

port trunk permit vlan vlan-id

Hybrid端口

port hybrid vlan vlan-id { tagged | untagged }

退回系统视图

quit

-

进入VLAN接口视图

interface vlan-interface interface-number

-

使能BFD MAD检测功能

mad bfd enable

缺省情况下,没有使能BFD MAD检测功能

给指定成员设备配置MAD IP地址

mad ip address ip-address { mask | mask-length } member member-id

缺省情况下,没有为接口配置MAD IP地址

 

使用管理用以太网口进行BFD MAD检测功能的配置顺序为:

·            将IRF中所有成员设备的管理用以太网口连接到同一台中间设备

·            将中间设备上与IRF成员设备相连的端口配置在一个VLAN内

·            在管理用以太网口下使能BFD MAD检测功能,并为各成员设备配置MAD IP地址。

说明

仅Release 1121及以上版本支持使用管理用以太网口实现BFD MAD检测。

 

表1-15 配置使用管理用以太网口进行BFD MAD检测

操作

命令

说明

进入系统视图

system-view

-

进入管理用以太网口的接口视图

interface M-GigabitEthernet interface-number

-

使能BFD MAD检测功能

mad bfd enable

缺省情况下,没有使能BFD MAD检测功能

给指定成员设备配置MAD IP地址

mad ip address ip-address { mask | mask-length } member member-id

缺省情况下,没有为接口配置MAD IP地址

 

3. ARP MAD检测

(1)       ARP MAD检测原理

ARP MAD检测是通过扩展ARP协议报文内容实现的,即使用ARP协议报文中未使用的字段来交互IRF的DomainID和ActiveID。

使能ARP MAD检测后,成员设备可以通过ARP协议报文和其它成员设备交互DomainID和ActiveID信息。

·            当成员设备收到ARP协议报文后,先比较DomainID。如果DomainID相同,再比较ActiveID;如果DomainID不同,则认为报文来自不同IRF,不再进行MAD处理。

·            如果ActiveID相同,则表示IRF正常运行,没有发生多Active冲突;如果ActiveID值不同,则表示IRF分裂,检测到多Active冲突。

(2)       ARP MAD检测组网要求

注意

ARP MAD检测组网中,如果中间设备本身也是一个IRF系统,则必须通过配置确保其IRF域编号与被检测的IRF系统不同,否则可能造成检测异常,甚至导致业务中断。

 

ARP MAD检测方式可以使用中间设备来进行连接,也可以不使用中间设备。通常采用如图1-10所示的组网:成员设备之间通过Device交互ARP报文,Device、主设备和从设备上都要配置生成树功能,以防止形成环路。

图1-10 ARP MAD检测组网示意图

 

(3)       配置ARP MAD检测

配置ARP MAD检测时,请遵循以下要求:

·            ARP MAD检测组网使用中间设备进行连接时,可使用以太网端口或管理用以太网口实现ARP MAD检测;当不使用中间设备时,需要使用以太网端口在所有的成员设备之间建立两两互联的ARP MAD检测链路。

·            如果使用以太网端口和中间设备相连来实现ARP MAD功能,在IRF和中间设备上均需配置生成树功能,并确保配置生成树功能后,只有一条ARP MAD检测链路处于转发状态,能够转发ARP MAD检测报文。关于生成树功能的详细描述和配置请参见“二层技术-以太网交换配置指导”中的“生成树”。

使用以太网端口实现ARP MAD检测功能的配置顺序为:

·            创建一个新VLAN,专用于ARP MAD检测;(对于使用中间设备的组网,中间设备上也需要进行该项配置)

·            确定哪些物理端口用于ARP MAD检测,并将这些端口都添加到ARP MAD检测专用VLAN中;(如果用到中间设备组网,中间设备上也需要进行该项配置)

·            为ARP MAD检测专用VLAN创建VLAN接口,在接口下使能ARP MAD检测功能,并配置IP地址。

表1-16 配置ARP MAD检测

操作

命令

说明

进入系统视图

system-view

-

配置IRF域编号

irf domain domain-id

缺省情况下,IRF的域编号为0

将IRF配置为MAC地址立即改变

undo irf mac-address persistent

缺省情况下,IRF的桥MAC会保留6分钟

创建一个新VLAN专用于ARP MAD检测

vlan vlan-id

缺省情况下,设备上只存在VLAN 1

VLAN 1不能用于ARP MAD检测

退回系统视图

quit

-

进入以太网接口视图

interface interface-type interface-number

-

端口加入ARP MAD检测专用VLAN

Access端口

port access vlan vlan-id

请根据端口的当前链路类型选择对应的配置命令

ARP MAD检测对检测端口的链路类型没有要求,不需要刻意修改端口的当前链路类型。缺省情况下,端口端的链路类型为Access端口

Trunk端口

port trunk permit vlan vlan-id

Hybrid端口

port hybrid vlan vlan-id { tagged | untagged }

退回系统视图

quit

-

进入VLAN接口视图

interface vlan-interface interface-number

-

配置IP地址

ip address ip-address { mask | mask-length }

缺省情况下,没有为接口配置IP地址

使能ARP MAD检测功能

mad arp enable

缺省情况下,ARP MAD检测未使能

 

使用管理用以太网口进行ARP MAD检测功能的配置顺序为:

·            将IRF中所有成员设备的管理用以太网口连接到同一台中间设备

·            将中间设备上与IRF成员设备相连的端口配置在一个VLAN内

·            在管理用以太网口下配置IP地址,并使能ARP MAD检测功能。

说明

仅Release 1121及以上版本支持使用管理用以太网口实现ARP MAD检测。

 

表1-17 配置使用管理用以太网口进行ARP MAD检测

操作

命令

说明

进入系统视图

system-view

-

配置IRF域编号

irf domain domain-id

缺省情况下,IRF的域编号为0

将IRF配置为MAC地址立即改变

undo irf mac-address persistent

缺省情况下,IRF的桥MAC会保留6分钟

进入管理用以太网口的接口视图

interface M-GigabitEthernet interface-number

-

配置IP地址

ip address ip-address { mask | mask-length }

缺省情况下,没有为管理用以太网口配置IP地址

使能ARP MAD检测功能

mad arp enable

缺省情况下,没有使能ARP MAD检测功能

 

4. ND MAD检测

(1)       ND MAD检测原理

ND MAD检测是通过扩展ND协议报文内容实现的,即使用ND的NS协议报文携带扩展选项数据来交互IRF的DomainID和ActiveID。

使能ND MAD检测后,成员设备可以通过ND协议报文和其它成员设备交互DomainID和ActiveID信息。

·            当成员设备收到ND协议报文后,先比较DomainID。如果DomainID相同,再比较ActiveID;如果DomainID不同,则认为报文来自不同IRF,不再进行MAD处理。

·            如果ActiveID相同,则表示IRF正常运行,没有发生多Active冲突;如果ActiveID值不同,则表示IRF分裂,检测到多Active冲突。

(2)       ND MAD检测组网要求

注意

ND MAD检测组网中,如果中间设备本身也是一个IRF系统,则必须通过配置确保其IRF域编号与被检测的IRF系统不同,否则可能造成检测异常,甚至导致业务中断。

 

ND MAD检测方式可以使用中间设备来进行连接,也可以不使用中间设备。通常采用如图1-11所示的组网:成员设备之间通过Device交互ND报文,Device、主设备和从设备上都要配置生成树功能,以防止形成环路。

图1-11 ND MAD检测组网示意图

 

(3)       配置ND MAD检测

配置ND MAD检测时,请遵循以下要求:

·            ND MAD检测组网使用中间设备进行连接时,可使用普通的数据链路作为ND MAD检测链路;当不使用中间设备时,需要在所有的成员设备之间建立两两互联的ND MAD检测链路。

·            如果使用中间设备组网,在IRF和中间设备上均需配置生成树功能。并确保配置生成树功能后,只有一条ND MAD检测链路处于转发状态,能够转发ND MAD检测报文。关于生成树功能的详细描述和配置请参见“二层技术-以太网交换配置指导”中的“生成树”。

ND MAD检测功能的配置顺序为:

·            创建一个新VLAN,专用于ND MAD检测;(对于使用中间设备的组网,中间设备上也需要进行该项配置)

·            确定哪些物理端口用于ND MAD检测,并将这些端口都添加到ND MAD检测专用VLAN中;(如果用到中间设备组网,中间设备上也需要进行该项配置)

·            为ND MAD检测专用VLAN创建VLAN接口,在接口下使能ND MAD检测功能,并配置IP地址。

表1-18 配置ND MAD检测

操作

命令

说明

进入系统视图

system-view

-

配置IRF域编号

irf domain domain-id

缺省情况下,IRF的域编号为0

将IRF配置为MAC地址立即改变

undo irf mac-address persistent

缺省情况下,IRF的桥MAC会保留6分钟

创建一个新VLAN专用于ND MAD检测

vlan vlan-id

缺省情况下,设备上只存在VLAN 1

VLAN 1不能用于ND MAD检测

退回系统视图

quit

-

进入以太网接口视图

interface interface-type interface-number

-

端口加入ND MAD检测专用VLAN

Access端口

port access vlan vlan-id

请根据端口的当前链路类型选择对应的配置命令

ND MAD检测对检测端口的链路类型没有要求,不需要刻意修改端口的当前链路类型。缺省情况下,端口端的链路类型为Access端口

Trunk端口

port trunk permit vlan vlan-id

Hybrid端口

port hybrid vlan vlan-id { tagged | untagged }

退回系统视图

quit

-

进入VLAN接口视图

interface vlan-interface interface-number

-

配置IP地址

ipv6 address { ipv6-address/pre-length | ipv6 address pre-length }

缺省情况下,没有为接口配置IPv6地址

使能ND MAD检测功能

mad nd enable

缺省情况下,ND  MAD检测未使能

 

5. 配置保留接口

IRF系统在进行多Active处理的时候,缺省情况下,会关闭Recovery状态设备上的所有业务接口。如果接口有特殊用途需要保持up状态(比如Telnet登录接口等),则用户可以通过命令行将这些接口配置为保留接口。

表1-19 配置保留接口

操作

命令

说明

进入系统视图

system-view

-

配置保留接口,当设备进入Recovery状态时,该接口不会被关闭

mad exclude interface interface-type interface-number

缺省情况下,设备进入Recovery状态时会自动关闭本设备上所有的业务接口

IRF物理端口自动作为保留接口,不需要配置

 

说明

·      IRF物理端口自动作为保留接口,不需要配置。

·      如果要求处于Recovery状态的IRF中的某个VLAN接口能够继续收发报文(比如使用该VLAN接口进行远程登录),则需要将该VLAN接口以及该VLAN接口对应的以太网端口都配置为保留接口。但如果在正常工作状态的IRF中该VLAN接口也处于UP状态,则在网络中会产生IP地址冲突。

 

6. MAD故障恢复

IRF链路故障将一个IRF分裂为两个IRF,从而导致多Active冲突。当系统检测到多Active冲突后,两个冲突的IRF会进行竞选,主设备成员编号小的获胜,继续正常运行,失败的IRF会转入Recovery状态,暂时不能转发业务报文。此时通过修复IRF链路可以恢复IRF系统(设备会尝试自动修复IRF链路,如果修复失败的话,则需要用户手工修复)。

IRF链路修复后,处于Recover状态的IRF会自动重启,从而与处于正常工作状态的IRF重新合并为一个IRF,原Recovery状态IRF中被强制关闭的业务接口会自动恢复到真实的物理状态,如图1-12所示。

图1-12 MAD故障恢复(IRF链路故障)

 

如果在MAD故障还未修复的情况下,处于Active的IRF也出现故障(原因可能是设备故障或者上下行线路故障),可以在IRF 2(处于Recovery状态的IRF)上执行mad restore命令,让IRF 2恢复到正常状态,先接替IRF 1工作。然后再修复IRF 1和IRF链路,修复后,两个IRF发生合并,整个IRF系统恢复,如图1-13所示。

图1-13 MAD故障恢复(IRF链路故障+正常工作状态的IRF故障)

 

表1-20 手动恢复处于Recovery状态的设备

操作

命令

说明

进入系统视图

system-view

-

将IRF从Recovery状态恢复到正常工作状态

mad restore

-

 

1.6  访问IRF

IRF的访问方式如下:

·            本地登录:通过任意成员设备的Console口登录。

·            远程登录:给任意成员设备的任意三层接口配置IP地址,并且路由可达,就可以通过Telnet、SNMP等方式进行远程登录。

不管使用哪种方式登录IRF,实际上登录的都是主设备。主设备是IRF系统的配置和控制中心,在主设备上配置后,主设备会将相关配置同步给从设备,以便保证主设备和从设备配置的一致性。

1.7  IRF显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后IRF的运行情况,通过查看显示信息验证配置的效果。

表1-21 IRF显示和维护

操作

命令

显示IRF中所有成员设备的相关信息

display irf

查看IRF的拓扑信息

display irf topology

显示IRF链路信息

display irf link

显示IRF配置信息

display irf configuration

显示IRF链路的负载分担类型

display irf-port load-sharing mode [ irf-port [ member-id/port-number ] ]

显示MAD配置信息

display mad [ verbose ]

 

1.8  IRF典型配置举例

1.8.1  IRF典型配置举例(LACP MAD检测方式)

1. 组网需求

由于公司人员激增,接入层交换机提供的端口数目已经不能满足PC的接入需求。现需要在保护现有投资的基础上扩展端口接入数量,并要求网络易管理、易维护。

2. 组网图

图1-14 IRF典型配置组网图(LACP MAD检测方式)

 

3. 配置思路

·            Device A提供的接入端口数目已经不能满足网络需求,需要另外增加三台设备Device B、Device C和Device D。

·            鉴于IRF技术具有管理简便、网络扩展能力强、可靠性高等优点,所以本例使用IRF技术构建接入层(即在四台设备上配置IRF功能)。

·            为了防止IRF链路故障导致IRF分裂,网络中存在两个配置冲突的IRF,需要启用MAD检测功能。因为网络中有一台中间设备Device E,支持LACP协议,因此可采用LACP MAD检测。

·            为提高IRF链路的性能和可靠性,在成员设备间使用聚合IRF链路方式进行连接。

4. 配置步骤

(1)       配置Device A

# 根据图1-14选定IRF物理端口并关闭这些端口。为便于配置,下文中将使用接口批量配置功能关闭和开启物理端口,关于接口批量配置的介绍,请参见“二层技术-以太网交换配置指导”。

 

<Sysname> system-view

[Sysname] interface range ten-gigabitethernet 1/0/49 to ten-gigabitethernet 1/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口1/1,并将它与物理端口Ten-GigabitEthernet1/0/49和Ten-GigabitEthernet1/0/50绑定。

[Sysname] irf-port 1/1

[Sysname-irf-port1/1] port group interface Ten-GigabitEthernet 1/0/49

[Sysname-irf-port1/1] port group interface Ten-GigabitEthernet 1/0/50

[Sysname-irf-port1/1] quit

# 配置IRF端口1/2,并将它与物理端口Ten-GigabitEthernet1/0/51和Ten-GigabitEthernet1/0/52绑定。

[Sysname] irf-port 1/2

[Sysname-irf-port1/2] port group interface Ten-GigabitEthernet 1/0/51

[Sysname-irf-port1/2] port group interface Ten-GigabitEthernet 1/0/52

[Sysname-irf-port1/2] quit

# 开启Ten-GigabitEthernet1/0/49~Ten-GigabitEthernet1/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 1/0/49 to Ten-GigabitEthernet 1/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(2)       配置Device B

# 将Device B的成员编号配置为2,并重启设备使新编号生效。

<Sysname> system-view

[Sysname] irf member 1 renumber 2

Renumbering the member ID may result in configuration change or loss. Continue? [Y/N]:y

[Sysname] quit

<Sysname> reboot

# 根据图1-14选定IRF物理端口并进行物理连线。

# 重新登录到设备,关闭选定的所有IRF物理端口。

<Sysname> system-view

[Sysname] interface range Ten-GigabitEthernet 2/0/49 to Ten-GigabitEthernet 2/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口2/1,并将它与物理端口Ten-GigabitEthernet2/0/51和Ten-GigabitEthernet2/0/52绑定。

[Sysname] irf-port 2/1

[Sysname-irf-port2/1] port group interface Ten-GigabitEthernet 2/0/51

[Sysname-irf-port2/1] port group interface Ten-GigabitEthernet 2/0/52

[Sysname-irf-port2/1] quit

# 配置IRF端口2/2,并将它与物理端口Ten-GigabitEthernet2/0/49和Ten-GigabitEthernet2/0/50绑定。

[Sysname] irf-port 2/2

[Sysname-irf-port2/2] port group interface Ten-GigabitEthernet 2/0/49

[Sysname-irf-port2/2] port group interface Ten-GigabitEthernet 2/0/50

# 开启Ten-GigabitEthernet2/0/49~Ten-GigabitEthernet2/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 2/0/49 to Ten-GigabitEthernet 2/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(3)       Device A和Device B间将会进行主设备竞选,竞选失败的一方将重启,重启完成后,IRF形成。

(4)       配置Device C

# 将Device C的成员编号配置为3,并重启设备使新编号生效。

<Sysname> system-view

[Sysname] irf member 1 renumber 3

Renumbering the member ID may result in configuration change or loss. Continue? [Y/N]:y

[Sysname] quit

<Sysname> reboot

# 根据图1-14选定IRF物理端口并进行物理连线。

# 重新登录到设备,关闭选定的所有IRF物理端口。

<Sysname> system-view

[Sysname] interface range Ten-GigabitEthernet 3/0/49 to Ten-GigabitEthernet 3/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口3/1,并将它与物理端口Ten-GigabitEthernet3/0/51和Ten-GigabitEthernet3/0/52绑定。

[Sysname] irf-port 3/1

[Sysname-irf-port3/1] port group interface Ten-GigabitEthernet 3/0/51

[Sysname-irf-port3/1] port group interface Ten-GigabitEthernet 3/0/52

[Sysname-irf-port3/1] quit

# 配置IRF端口3/2,并将它与物理端口Ten-GigabitEthernet3/0/49和Ten-GigabitEthernet3/0/50绑定。

[Sysname] irf-port 3/2

[Sysname-irf-port3/2] port group interface Ten-GigabitEthernet 3/0/49

[Sysname-irf-port3/2] port group interface Ten-GigabitEthernet 3/0/50

[Sysname-irf-port3/2] quit

# 开启Ten-GigabitEthernet3/0/49~Ten-GigabitEthernet3/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 3/0/49 to Ten-GigabitEthernet 3/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(5)       Device C将自动重启,加入Device A和Device B已经形成的IRF。

(6)       配置Device D

# 将Device D的成员编号配置为4,并重启设备使新编号生效。

<Sysname> system-view

[Sysname] irf member 1 renumber 4

Renumbering the member ID may result in configuration change or loss. Continue? [Y/N]:y

[Sysname] quit

<Sysname> reboot

#根据图1-14选定IRF物理端口并进行物理连线。

# 重新登录到设备,关闭选定的所有IRF物理端口。

<Sysname> system-view

[Sysname] interface range Ten-GigabitEthernet 4/0/49 to Ten-GigabitEthernet 4/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口4/1,并将它与物理端口Ten-GigabitEthernet4/0/49和Ten-GigabitEthernet4/0/50绑定。

[Sysname] irf-port 4/1

[Sysname-irf-port4/1] port group interface Ten-GigabitEthernet 4/0/49

[Sysname-irf-port4/1] port group interface Ten-GigabitEthernet 4/0/50

[Sysname-irf-port4/1] quit

# 配置IRF端口4/2,并将它与物理端口Ten-GigabitEthernet4/0/51和Ten-GigabitEthernet4/0/52绑定。

[Sysname] irf-port 4/2

[Sysname-irf-port4/2] port group interface Ten-GigabitEthernet 4/0/51

[Sysname-irf-port4/2] port group interface Ten-GigabitEthernet 4/0/52

[Sysname-irf-port4/2] quit

# 开启Ten-GigabitEthernet4/0/49~Ten-GigabitEthernet4/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 4/0/49 to Ten-GigabitEthernet 4/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(7)       Device D将自动重启,加入Device A、Device B和Device C已经形成的IRF。

(8)       配置LACP MAD

# 设置IRF域编号为1。

<Sysname> system-view

[Sysname] irf domain 1

# 创建一个动态聚合接口,并使能LACP MAD检测功能。

[Sysname] interface bridge-aggregation 2

[Sysname-Bridge-Aggregation2] link-aggregation mode dynamic

[Sysname-Bridge-Aggregation2] mad enable

 You need to assign a domain ID (range: 0-4294967295)

 [Current domain is: 1]:  

 The assigned  domain ID is: 1

 Info: MAD LACP only enable on dynamic aggregation interface.

[Sysname-Bridge-Aggregation2] quit

# 在聚合接口中添加成员端口GigabitEthernet1/0/2、GigabitEthernet2/0/1、GigabitEthernet3/0/2和GigabitEthernet4/0/1,用于Device A和Device B实现LACP MAD检测。

[Sysname] interface range gigabitethernet 1/0/2 gigabitethernet 2/0/1 gigabitethernet 3/0/2 gigabitethernet 4/0/1

[Sysname-if-range] port link-aggregation group 2

[Sysname-if-range] quit

(9)       配置中间设备Device E

Device E作为中间设备来转发、处理LACP协议报文,协助IRF中的四台成员设备进行多Active检测。从节约成本的角度考虑,使用一台支持LACP协议扩展功能的交换机即可。

注意

如果中间设备是一个IRF系统,则必须通过配置确保其IRF域编号与被检测的IRF系统不同。

 

# 创建一个动态聚合接口。

<Sysname> system-view

[Sysname] interface bridge-aggregation 2

[Sysname-Bridge-Aggregation2] link-aggregation mode dynamic

[Sysname-Bridge-Aggregation2] quit

# 在聚合接口中添加成员端口GigabitEthernet1/0/1~GigabitEthernet1/0/4,用于帮助LACP MAD检测。

[Sysname] interface range gigabitethernet 1/0/1 to gigabitethernet 1/0/4

[Sysname-if-range] port link-aggregation group 2

[Sysname-if-range] quit

1.8.2  IRF典型配置举例(BFD MAD检测方式)

1. 组网需求

由于网络规模迅速扩大,当前中心交换机(Device A)转发能力已经不能满足需求,现需要在保护现有投资的基础上将网络转发能力提高一倍,并要求网络易管理、易维护。

2. 组网图

图1-15 IRF典型配置组网图(BFD MAD检测方式)

 

3. 配置思路

·            Device A处于局域网的汇聚层,为了将汇聚层的转发能力提高三倍,需要另外增加三台设备Device B、Device C和Device D。

·            鉴于IRF技术具有管理简便、网络扩展能力强、可靠性高等优点,所以本例使用IRF技术构建网络汇聚层(即在四台设备上配置IRF功能),每台成员设备与上层设备Device E之间均有一条上行链路连接。

·            为了防止IRF链路故障导致IRF分裂,网络中存在两个配置冲突的IRF,需要启用MAD检测功能。本例中我们采用BFD MAD检测方式来监测IRF的状态,并使用成员设备与上层设备间的专用链路传递BFD MAD报文。

4. 配置步骤

(1)       配置Device A

# 根据图1-15选定IRF物理端口并关闭这些端口。

<Sysname> system-view

[Sysname] interface range Ten-GigabitEthernet 1/0/49 to Ten-GigabitEthernet 1/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口1/1,并将它与物理端口Ten-GigabitEthernet1/0/49和Ten-GigabitEthernet1/0/50绑定。

[Sysname] irf-port 1/1

[Sysname-irf-port1/1] port group interface Ten-GigabitEthernet 1/0/49

[Sysname-irf-port1/1] port group interface Ten-GigabitEthernet 1/0/50

[Sysname-irf-port1/1] quit

# 配置IRF端口1/2,并将它与物理端口Ten-GigabitEthernet1/0/51和Ten-GigabitEthernet1/0/52绑定。

[Sysname] irf-port 1/2

[Sysname-irf-port1/2] port group interface Ten-GigabitEthernet 1/0/51

[Sysname-irf-port1/2] port group interface Ten-GigabitEthernet 1/0/52

[Sysname-irf-port1/2] quit

# 开启Ten-GigabitEthernet1/0/49~Ten-GigabitEthernet1/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 1/0/49 to Ten-GigabitEthernet 1/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(2)       配置Device B

# 将Device B的成员编号配置为2,并重启设备使新编号生效。

<Sysname> system-view

[Sysname] irf member 1 renumber 2

Renumbering the member ID may result in configuration change or loss. Continue? [Y/N]:y

[Sysname] quit

<Sysname> reboot

# 根据图1-15选定IRF物理端口并进行物理连线。

# 重新登录到设备,关闭选定的所有IRF物理端口。

<Sysname> system-view

[Sysname] interface range Ten-GigabitEthernet 2/0/49 to Ten-GigabitEthernet 2/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口2/1,并将它与物理端口Ten-GigabitEthernet2/0/51和Ten-GigabitEthernet2/0/52绑定。

[Sysname] irf-port 2/1

[Sysname-irf-port2/1] port group interface Ten-GigabitEthernet 2/0/51

[Sysname-irf-port2/1] port group interface Ten-GigabitEthernet 2/0/52

[Sysname-irf-port2/1] quit

# 配置IRF端口2/2,并将它与物理端口Ten-GigabitEthernet2/0/49和Ten-GigabitEthernet2/0/50绑定。

[Sysname] irf-port 2/2

[Sysname-irf-port2/2] port group interface Ten-GigabitEthernet 2/0/49

[Sysname-irf-port2/2] port group interface Ten-GigabitEthernet 2/0/50

# 开启Ten-GigabitEthernet2/0/49~Ten-GigabitEthernet2/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 2/0/49 to Ten-GigabitEthernet 2/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(3)       Device A和Device B间将会进行主设备竞选,竞选失败的一方将重启,重启完成后,IRF形成。

(4)       配置Device C

# 将Device C的成员编号配置为3,并重启设备使新编号生效。

<Sysname> system-view

[Sysname] irf member 1 renumber 3

Renumbering the member ID may result in configuration change or loss. Continue? [Y/N]:y

[Sysname] quit

<Sysname> reboot

# 根据图1-15选定IRF物理端口并进行物理连线。

# 重新登录到设备,关闭选定的所有IRF物理端口。

<Sysname> system-view

[Sysname] interface range Ten-GigabitEthernet 3/0/49 to Ten-GigabitEthernet 3/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口3/1,并将它与物理端口Ten-GigabitEthernet3/0/51和Ten-GigabitEthernet3/0/52绑定。

[Sysname] irf-port 3/1

[Sysname-irf-port3/1] port group interface Ten-GigabitEthernet 3/0/51

[Sysname-irf-port3/1] port group interface Ten-GigabitEthernet 3/0/52

[Sysname-irf-port3/1] quit

# 配置IRF端口3/2,并将它与物理端口Ten-GigabitEthernet3/0/49和Ten-GigabitEthernet3/0/50绑定。

[Sysname] irf-port 3/2

[Sysname-irf-port3/2] port group interface Ten-GigabitEthernet 3/0/49

[Sysname-irf-port3/2] port group interface Ten-GigabitEthernet 3/0/50

[Sysname-irf-port3/2] quit

# 开启Ten-GigabitEthernet3/0/49~Ten-GigabitEthernet3/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 3/0/49 to Ten-GigabitEthernet 3/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(5)       Device C将自动重启,加入Device A和Device B已经形成的IRF。

(6)       配置Device D

# 将Device D的成员编号配置为4,并重启设备使新编号生效。

<Sysname> system-view

[Sysname] irf member 1 renumber 4

Renumbering the member ID may result in configuration change or loss. Continue? [Y/N]:y

[Sysname] quit

<Sysname> reboot

# 根据图1-15选定IRF物理端口并进行物理连线。

# 重新登录到设备,关闭选定的所有IRF物理端口。

<Sysname> system-view

[Sysname] interface range Ten-GigabitEthernet 4/0/49 to Ten-GigabitEthernet 4/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口4/1,并将它与物理端口Ten-GigabitEthernet4/0/49和Ten-GigabitEthernet4/0/50绑定。

[Sysname] irf-port 4/1

[Sysname-irf-port4/1] port group interface Ten-GigabitEthernet 4/0/49

[Sysname-irf-port4/1] port group interface Ten-GigabitEthernet 4/0/50

[Sysname-irf-port4/1] quit

# 配置IRF端口4/2,并将它与物理端口Ten-GigabitEthernet4/0/51和Ten-GigabitEthernet4/0/52绑定。

[Sysname] irf-port 4/2

[Sysname-irf-port4/2] port group interface Ten-GigabitEthernet 4/0/51

[Sysname-irf-port4/2] port group interface Ten-GigabitEthernet 4/0/52

[Sysname-irf-port4/2] quit

# 开启Ten-GigabitEthernet4/0/49~Ten-GigabitEthernet4/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 4/0/49 to Ten-GigabitEthernet 4/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(7)       Device D将自动重启,加入Device A、Device B和Device C已经形成的IRF。

(8)       配置BFD MAD

# 创建VLAN 3,并将端口GigabitEthernet1/0/1、GigabitEthernet2/0/1、GigabitEthernet3/0/1和GigabitEthernet4/0/1加入VLAN 3中。

[Sysname] vlan 3

[Sysname-vlan3] port gigabitethernet 1/0/1 gigabitethernet 2/0/1 gigabitethernet 3/0/1 gigabitethernet 4/0/1

[Sysname-vlan3] quit

# 创建VLAN接口3,并配置MAD IP地址。

[Sysname] interface vlan-interface 3

[Sysname-Vlan-interface3] mad bfd enable

[Sysname-Vlan-interface3] mad ip address 192.168.2.1 24 member 1

[Sysname-Vlan-interface3] mad ip address 192.168.2.2 24 member 2

[Sysname-Vlan-interface3] mad ip address 192.168.2.3 24 member 3

[Sysname-Vlan-interface3] mad ip address 192.168.2.4 24 member 4

[Sysname-Vlan-interface3] quit

# 因为BFD MAD和生成树功能互斥,所以在GigabitEthernet1/0/1、GigabitEthernet2/0/1、GigabitEthernet3/0/1和GigabitEthernet4/0/1端口上关闭生成树协议。

[Sysname] interface range gigabitethernet 1/0/1 gigabitethernet 2/0/1 gigabitethernet 3/0/1 gigabitethernet 4/0/1

[Sysname-if-range] undo stp enable

[Sysname-if-range] quit

(9)       配置中间设备Device E

Device E作为中间设备来透传BFD MAD报文,协助IRF中的四台成员设备进行多Active检测。

注意

如果中间设备是一个IRF系统,则必须通过配置确保其IRF域编号与被检测的IRF系统不同。

 

# 创建VLAN 3,并将端口GigabitEthernet1/0/1~GigabitEthernet1/0/4加入VLAN 3中,用于转发BFD MAD报文。

<DeviceE> system-view

[DeviceE] vlan 3

[DeviceE-vlan3] port gigabitethernet 1/0/1 to gigabitethernet 1/0/4

[DeviceE-vlan3] quit

1.8.3  IRF典型配置举例(ARP MAD检测方式)

1. 组网需求

由于网络规模迅速扩大,当前中心交换机(Device A)转发能力已经不能满足需求,现需要在保护现有投资的基础上提高网络转发能力,并要求网络易管理、易维护。

2. 组网图

图1-16 IRF典型配置组网图(ARP MAD检测方式)

 

3. 配置思路

·            Device A处于局域网的汇聚层,为了将汇聚层的转发能力提高三倍,需要另外增加三台设备Device B、Device C和Device D。

·            鉴于IRF技术具有管理简便、网络扩展能力强、可靠性高等优点,所以本例使用IRF技术构建网络接入层(即在四台设备上配置IRF功能),每台成员设备与上层设备Device E之间均有一条上行链路连接。

·            为了防止IRF链路故障导致IRF分裂,网络中存在两个配置冲突的IRF,需要启用MAD检测功能。本例中我们采用ARP MAD检测方式来监测IRF的状态,复用上行链路传递ARP MAD报文。为防止环路发生,在IRF和Device E上启用生成树功能。

·            为提高IRF链路的性能和可靠性,在成员设备间使用聚合IRF链路方式进行连接。

4. 配置步骤

(1)       配置Device A

# 根据图1-16选定IRF物理端口并关闭这些端口。

<Sysname> system-view

[Sysname] interface range Ten-GigabitEthernet 1/0/49 to Ten-GigabitEthernet 1/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口1/1,并将它与物理端口Ten-GigabitEthernet1/0/49和Ten-GigabitEthernet1/0/50绑定。

[Sysname] irf-port 1/1

[Sysname-irf-port1/1] port group interface Ten-GigabitEthernet 1/0/49

[Sysname-irf-port1/1] port group interface Ten-GigabitEthernet 1/0/50

[Sysname-irf-port1/1] quit

# 配置IRF端口1/2,并将它与物理端口Ten-GigabitEthernet1/0/51和Ten-GigabitEthernet1/0/52绑定。

[Sysname] irf-port 1/2

[Sysname-irf-port1/2] port group interface Ten-GigabitEthernet 1/0/51

[Sysname-irf-port1/2] port group interface Ten-GigabitEthernet 1/0/52

[Sysname-irf-port1/2] quit

# 开启Ten-GigabitEthernet1/0/49~Ten-GigabitEthernet1/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 1/0/49 to Ten-GigabitEthernet 1/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(2)       配置Device B

# 将Device B的成员编号配置为2,并重启设备使新编号生效。

<Sysname> system-view

[Sysname] irf member 1 renumber 2

Renumbering the member ID may result in configuration change or loss. Continue? [Y/N]:y

[Sysname] quit

<Sysname> reboot

# 根据图1-16选定IRF物理端口并进行物理连线。

# 重新登录到设备,关闭选定的所有IRF物理端口。

<Sysname> system-view

[Sysname] interface range Ten-GigabitEthernet 2/0/49 to Ten-GigabitEthernet 2/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口2/1,并将它与物理端口Ten-GigabitEthernet2/0/51和Ten-GigabitEthernet2/0/52绑定。

[Sysname] irf-port 2/1

[Sysname-irf-port2/1] port group interface Ten-GigabitEthernet 2/0/51

[Sysname-irf-port2/1] port group interface Ten-GigabitEthernet 2/0/52

[Sysname-irf-port2/1] quit

# 配置IRF端口2/2,并将它与物理端口Ten-GigabitEthernet2/0/49和Ten-GigabitEthernet2/0/50绑定。

[Sysname] irf-port 2/2

[Sysname-irf-port2/2] port group interface Ten-GigabitEthernet 2/0/49

[Sysname-irf-port2/2] port group interface Ten-GigabitEthernet 2/0/50

# 开启Ten-GigabitEthernet2/0/49~Ten-GigabitEthernet2/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 2/0/49 to Ten-GigabitEthernet 2/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(3)       Device A和Device B间将会进行主设备竞选,竞选失败的一方将重启,重启完成后,IRF形成。

(4)       配置Device C

# 将Device C的成员编号配置为3,并重启设备使新编号生效。

<Sysname> system-view

[Sysname] irf member 1 renumber 3

Renumbering the member ID may result in configuration change or loss. Continue? [Y/N]:y

[Sysname] quit

<Sysname> reboot

# 根据图1-16选定IRF物理端口并进行物理连线。

# 重新登录到设备,关闭选定的所有IRF物理端口。

<Sysname> system-view

[Sysname] interface range Ten-GigabitEthernet 3/0/49 to Ten-GigabitEthernet 3/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口3/1,并将它与物理端口Ten-GigabitEthernet3/0/51和Ten-GigabitEthernet3/0/52绑定。

[Sysname] irf-port 3/1

[Sysname-irf-port3/1] port group interface Ten-GigabitEthernet 3/0/51

[Sysname-irf-port3/1] port group interface Ten-GigabitEthernet 3/0/52

[Sysname-irf-port3/1] quit

# 配置IRF端口3/2,并将它与物理端口Ten-GigabitEthernet3/0/49和Ten-GigabitEthernet3/0/50绑定。

[Sysname] irf-port 3/2

[Sysname-irf-port3/2] port group interface Ten-GigabitEthernet 3/0/49

[Sysname-irf-port3/2] port group interface Ten-GigabitEthernet 3/0/50

[Sysname-irf-port3/2] quit

# 开启Ten-GigabitEthernet3/0/49~Ten-GigabitEthernet3/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 3/0/49 to Ten-GigabitEthernet 3/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(5)       Device C将自动重启,加入Device A和Device B已经形成的IRF。

(6)       配置Device D

# 将Device D的成员编号配置为4,并重启设备使新编号生效。

<Sysname> system-view

[Sysname] irf member 1 renumber 4

Renumbering the member ID may result in configuration change or loss. Continue? [Y/N]:y

[Sysname] quit

<Sysname> reboot

# 根据图1-16选定IRF物理端口并进行物理连线。

# 重新登录到设备,关闭选定的所有IRF物理端口。

<Sysname> system-view

[Sysname] interface range Ten-GigabitEthernet 4/0/49 to Ten-GigabitEthernet 4/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口4/1,并将它与物理端口Ten-GigabitEthernet4/0/49和Ten-GigabitEthernet4/0/50绑定。

[Sysname] irf-port 4/1

[Sysname-irf-port4/1] port group interface Ten-GigabitEthernet 4/0/49

[Sysname-irf-port4/1] port group interface Ten-GigabitEthernet 4/0/50

[Sysname-irf-port4/1] quit

# 配置IRF端口4/2,并将它与物理端口Ten-GigabitEthernet4/0/51和Ten-GigabitEthernet4/0/52绑定。

[Sysname] irf-port 4/2

[Sysname-irf-port4/2] port group interface Ten-GigabitEthernet 4/0/51

[Sysname-irf-port4/2] port group interface Ten-GigabitEthernet 4/0/52

[Sysname-irf-port4/2] quit

# 开启Ten-GigabitEthernet4/0/49~Ten-GigabitEthernet4/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 4/0/49 to Ten-GigabitEthernet 4/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(7)       Device D将自动重启,加入Device A、Device B和Device C已经形成的IRF。

(8)       配置ARP MAD

# 在IRF上全局使能生成树协议,并配置MST域,以防止环路的发生。

<Sysname> system-view

[Sysname] stp global enable

[Sysname] stp region-configuration

[Sysname-mst-region] region-name arpmad

[Sysname-mst-region] instance 1 vlan 3

[Sysname-mst-region] active region-configuration

# 将IRF配置为桥MAC立即改变。

[Sysname] undo irf mac-address persistent

# 设置IRF域编号为1。

[Sysname] irf domain 1

# 创建VLAN 3,并将端口GigabitEthernet1/0/2、GigabitEthernet2/0/1、GigabitEthernet3/0/2和GigabitEthernet4/0/1加入VLAN 3中。

[Sysname] vlan 3

[Sysname-vlan3] port gigabitethernet 1/0/2 gigabitethernet 2/0/1 gigabitethernet 3/0/2 gigabitethernet 4/0/1

[Sysname-vlan3] quit

# 创建VLAN-interface3,并配置IP地址,使能ARP MAD检测功能。

[Sysname] interface vlan-interface 3

[Sysname-Vlan-interface3] ip address 192.168.2.1 24

[Sysname-Vlan-interface3] mad arp enable

 You need to assign a domain ID (range: 0-4294967295)

 [Current domain is: 1]:

 The assigned  domain ID is: 1

(9)       配置中间设备Device E

Device E作为中间设备来转发、处理ARP报文,协助IRF中的四台成员设备进行多Active检测。从节约成本的角度考虑,使用一台支持ARP功能的交换机即可。

注意

如果中间设备是一个IRF系统,则必须通过配置确保其IRF域编号与被检测的IRF系统不同。

 

# 在全局使能生成树协议,并配置MST域,以防止环路的发生。

<DeviceE> system-view

[DeviceE] stp global enable

[DeviceE] stp region-configuration

[DeviceE-mst-region] region-name arpmad

[DeviceE-mst-region] instance 1 vlan 3

[DeviceE-mst-region] active region-configuration

# 创建VLAN 3,并将端口GigabitEthernet1/0/1~GigabitEthernet1/0/4加入VLAN 3中,用于转发ARP MAD报文。

[DeviceE] vlan 3

[DeviceE-vlan3] port gigabitethernet 1/0/1 to gigabitethernet 1/0/4

[DeviceE-vlan3] quit

1.8.4  IRF典型配置举例(ND MAD检测方式)

1. 组网需求

IPv6网络中,由于网络规模迅速扩大,当前中心交换机(Device A)转发能力已经不能满足需求,现需要在保护现有投资的基础上提高网络转发能力,并要求网络易管理、易维护。

2. 组网图

图1-17 IRF典型配置组网图(ND MAD检测方式)

3. 配置思路

·            Device A处于局域网的汇聚层,为了将汇聚层的转发能力提高一倍,需要另外增加三台设备Device B、Device C和Device D。

·            鉴于IRF技术具有管理简便、网络扩展能力强、可靠性高等优点,所以本例使用IRF技术构建网络接入层(即在四台设备上配置IRF功能),每台成员设备与上层设备Device E之间均有一条上行链路连接。

·            为了防止IRF链路故障导致IRF分裂,网络中存在两个配置冲突的IRF,需要启用MAD检测功能。在IPv6环境我们采用ND MAD检测方式来监测IRF的状态,复用上行链路传递ND MAD报文。为防止环路发生,在IRF和Device E上启用生成树功能。

·            为提高IRF链路的性能和可靠性,在成员设备间使用聚合IRF链路方式进行连接。

4. 配置步骤

(1)       配置Device A

# 根据图1-17选定IRF物理端口并关闭这些端口。

<Sysname> system-view

[Sysname] interface range Ten-GigabitEthernet 1/0/49 to Ten-GigabitEthernet 1/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口1/1,并将它与物理端口Ten-GigabitEthernet1/0/49和Ten-GigabitEthernet1/0/50绑定。

[Sysname] irf-port 1/1

[Sysname-irf-port1/1] port group interface Ten-GigabitEthernet 1/0/49

[Sysname-irf-port1/1] port group interface Ten-GigabitEthernet 1/0/50

[Sysname-irf-port1/1] quit

# 配置IRF端口1/2,并将它与物理端口Ten-GigabitEthernet1/0/51和Ten-GigabitEthernet1/0/52绑定。

[Sysname] irf-port 1/2

[Sysname-irf-port1/2] port group interface Ten-GigabitEthernet 1/0/51

[Sysname-irf-port1/2] port group interface Ten-GigabitEthernet 1/0/52

[Sysname-irf-port1/2] quit

# 开启Ten-GigabitEthernet1/0/49~Ten-GigabitEthernet1/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 1/0/49 to Ten-GigabitEthernet 1/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(2)       配置Device B

# 将Device B的成员编号配置为2,并重启设备使新编号生效。

<Sysname> system-view

[Sysname] irf member 1 renumber 2

Renumbering the member ID may result in configuration change or loss. Continue? [Y/N]:y

[Sysname] quit

<Sysname> reboot

# 根据图1-17选定IRF物理端口并进行物理连线。

# 重新登录到设备,关闭选定的所有IRF物理端口。

<Sysname> system-view

[Sysname] interface range Ten-GigabitEthernet 2/0/49 to Ten-GigabitEthernet 2/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口2/1,并将它与物理端口Ten-GigabitEthernet2/0/51和Ten-GigabitEthernet2/0/52绑定。

[Sysname] irf-port 2/1

[Sysname-irf-port2/1] port group interface Ten-GigabitEthernet 2/0/51

[Sysname-irf-port2/1] port group interface Ten-GigabitEthernet 2/0/52

[Sysname-irf-port2/1] quit

# 配置IRF端口2/2,并将它与物理端口Ten-GigabitEthernet2/0/49和Ten-GigabitEthernet2/0/50绑定。

[Sysname] irf-port 2/2

[Sysname-irf-port2/2] port group interface Ten-GigabitEthernet 2/0/49

[Sysname-irf-port2/2] port group interface Ten-GigabitEthernet 2/0/50

[Sysname-irf-port2/2] quit

# 开启Ten-GigabitEthernet2/0/49~Ten-GigabitEthernet2/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 2/0/49 to Ten-GigabitEthernet 2/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(3)       Device A和Device B间将会进行主设备竞选,竞选失败的一方将重启,重启完成后,IRF形成。

(4)       配置Device C

# 将Device C的成员编号配置为3,并重启设备使新编号生效。

<Sysname> system-view

[Sysname] irf member 1 renumber 3

Renumbering the member ID may result in configuration change or loss. Continue? [Y/N]:y

[Sysname] quit

<Sysname> reboot

# 根据图1-17选定IRF物理端口并进行物理连线。

# 重新登录到设备,关闭选定的所有IRF物理端口。

<Sysname> system-view

[Sysname] interface range Ten-GigabitEthernet 3/0/49 to Ten-GigabitEthernet 3/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口3/1,并将它与物理端口Ten-GigabitEthernet3/0/51和Ten-GigabitEthernet3/0/52绑定。

[Sysname] irf-port 3/1

[Sysname-irf-port3/1] port group interface Ten-GigabitEthernet 3/0/51

[Sysname-irf-port3/1] port group interface Ten-GigabitEthernet 3/0/52

[Sysname-irf-port3/1] quit

# 配置IRF端口3/2,并将它与物理端口Ten-GigabitEthernet3/0/49和Ten-GigabitEthernet3/0/50绑定。

[Sysname] irf-port 3/2

[Sysname-irf-port3/2] port group interface Ten-GigabitEthernet 3/0/49

[Sysname-irf-port3/2] port group interface Ten-GigabitEthernet 3/0/50

[Sysname-irf-port3/2] quit

# 开启Ten-GigabitEthernet3/0/49~Ten-GigabitEthernet3/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 3/0/49 to Ten-GigabitEthernet 3/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(5)       Device C将自动重启,加入Device A和Device B已经形成的IRF。

(6)       配置Device D

# 将Device D的成员编号配置为4,并重启设备使新编号生效。

<Sysname> system-view

[Sysname] irf member 1 renumber 4

Renumbering the member ID may result in configuration change or loss. Continue? [Y/N]:y

[Sysname] quit

<Sysname> reboot

# 根据图1-17选定IRF物理端口并进行物理连线。

# 重新登录到设备,关闭选定的所有IRF物理端口。

<Sysname> system-view

[Sysname] interface range Ten-GigabitEthernet 4/0/49 to Ten-GigabitEthernet 4/0/52

[Sysname-if-range] shutdown

[Sysname-if-range] quit

# 配置IRF端口4/1,并将它与物理端口Ten-GigabitEthernet4/0/49和Ten-GigabitEthernet4/0/50绑定。

[Sysname] irf-port 4/1

[Sysname-irf-port4/1] port group interface Ten-GigabitEthernet 4/0/49

[Sysname-irf-port4/1] port group interface Ten-GigabitEthernet 4/0/50

[Sysname-irf-port4/1] quit

# 配置IRF端口4/2,并将它与物理端口Ten-GigabitEthernet4/0/51和Ten-GigabitEthernet4/0/52绑定。

[Sysname] irf-port 4/2

[Sysname-irf-port4/2] port group interface Ten-GigabitEthernet 4/0/51

[Sysname-irf-port4/2] port group interface Ten-GigabitEthernet 4/0/52

[Sysname-irf-port4/2] quit

# 开启Ten-GigabitEthernet4/0/49~Ten-GigabitEthernet4/0/52端口,并保存配置。

[Sysname] interface range Ten-GigabitEthernet 4/0/49 to Ten-GigabitEthernet 4/0/52

[Sysname-if-range] undo shutdown

[Sysname-if-range] quit

[Sysname] save

# 激活IRF端口下的配置。

[Sysname] irf-port-configuration active

(7)       Device D将自动重启,加入Device A、Device B和Device C已经形成的IRF。

(8)       配置ND MAD

# 在IRF上全局使能生成树协议,并配置MST域,以防止环路的发生。

<Sysname> system-view

[Sysname] stp global enable

[Sysname] stp region-configuration

[Sysname-mst-region] region-name arpmad

[Sysname-mst-region] instance 1 vlan 3

[Sysname-mst-region] active region-configuration

# 将IRF配置为桥MAC立即改变。

[Sysname] undo irf mac-address persistent

# 设置IRF域编号为1。

[Sysname] irf domain 1

# 创建VLAN 3,并将端口GigabitEthernet1/0/2、GigabitEthernet2/0/1、GigabitEthernet3/0/2和GigabitEthernet4/0/1加入VLAN 3中。

[Sysname] vlan 3

[Sysname-vlan3] port gigabitethernet 1/0/2 gigabitethernet 2/0/1 gigabitethernet 3/0/2 gigabitethernet 4/0/1

[Sysname-vlan3] quit

# 创建VLAN-interface3,并配置IPv6地址,使能ND MAD检测功能。

[Sysname] interface vlan-interface 3

[Sysname-Vlan-interface3] ipv6 address 2001::1 64

[Sysname-Vlan-interface3] mad nd enable

 You need to assign a domain ID (range: 0-4294967295)

 [Current domain is: 1]:

 The assigned  domain ID is: 1

(9)       配置中间设备Device E

Device E作为中间设备来转发、处理ND报文,协助IRF中的四台成员设备进行多Active检测。从节约成本的角度考虑,使用一台支持ND功能的交换机即可。

注意

如果中间设备是一个IRF系统,则必须通过配置确保其IRF域编号与被检测的IRF系统不同。

 

# 在全局使能生成树协议,并配置MST域,以防止环路的发生。

<DeviceE> system-view

[DeviceE] stp global enable

[DeviceE] stp region-configuration

[DeviceE-mst-region] region-name arpmad

[DeviceE-mst-region] instance 1 vlan 3

[DeviceE-mst-region] active region-configuration

# 创建VLAN 3,并将端口GigabitEthernet1/0/1~GigabitEthernet1/0/4加入VLAN 3中,用于转发ND MAD报文。

[DeviceE] vlan 3

[DeviceE-vlan3] port gigabitethernet 1/0/1 to gigabitethernet 1/0/4

[DeviceE-vlan3] quit

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!