- Table of Contents
- Related Documents
-
Title | Size | Download |
---|---|---|
03-S12500_Smart_Link_and_Monitor_Link_Configuration_Examples | 116.67 KB |
Introduction
This document provides Smart Link and Monitor Link configuration examples.
Prerequisites
The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.
This document assumes that you have basic knowledge of Smart Link and Monitor Link.
Example: Configuring Smart Link and Monitor Link
Network requirements
As shown in Figure 1, in an enterprise network, VLAN 10 and VLAN 11 are assigned to the finance department and the marketing department, respectively. To improve connection reliability, Device A at the access layer provides two uplinks to Device D at the distribution layer.
· Configure Smart Link to implement link redundancy and load sharing. When the link between Device A and Device B and the link between Device A and Device C are both available, the finance and marketing departments' traffic flows are forwarded along different paths. When one link fails, link switchover occurs. When the link recovers, traffic flows are switched to the original path.
· Configure Monitor Link to adapt the state of port GE 9/0/1 to the state of port GE 9/0/2 on Device B and Device C. If a link failure occurs, Smart Link performs link switchover to avoid traffic interruption.
|
Port |
VLAN |
|
Port |
VLAN |
Device A |
GE9/0/1 |
VLANs 10 and 11 |
Device C |
GE9/0/1 |
VLANs 10 and 11 |
|
GE9/0/2 |
VLANs 10 and 11 |
|
GE9/0/2 |
VLANs 10 and 11 |
|
GE9/0/3 |
VLAN 10 |
Device D |
GE9/0/1 |
VLANs 10 and 11 |
|
GE9/0/4 |
VLAN 11 |
|
GE9/0/2 |
VLANs 10 and 11 |
Device B |
GE9/0/1 |
VLANs 10 and 11 |
|
GE9/0/3 |
VLANs 10 and 11 |
|
GE9/0/2 |
VLANs 10 and 11 |
|
|
|
Requirements analysis
To implement link load sharing on the two uplinks, create two smart link groups with the same members on Device A. The role of the same port must be different in the two smart link groups.
To switch traffic to the original path upon link recovery, enable role preemption for the two smart link groups.
To notify the upstream device to refresh MAC address forwarding entries and ARP/ND entries when link switchover occurs in a smart link group, enable flush message sending on Device A, and enable flush message receiving on ports of the primary and secondary links from Device A to Device D.
Software version used
This configuration example was created and verified on S12500-CMW520-R1825P01.
Configuration restrictions and guidelines
When you configure Smart Link and Monitor Link, follow these restrictions and guidelines:
· Before specifying a multiple spanning tree instance (MSTI), configure the MSTI.
· Configure the VLANs to which the member ports of a smart link group are assigned as the protected VLANs of the smart link group.
· STP- or RRPP-enabled ports and link aggregation group member ports cannot be assigned to a smart link group as member ports.
· You cannot enable flush message receiving on a link aggregation group member port.
· Make sure the control VLANs already exist and assign the flush message receiving-enabled ports to the control VLANs.
Configuration procedures
Configuring Device A
# Configure ports GigabitEthernet 9/0/1 and GigabitEthernet 9/0/2 as trunk ports, assign them to VLANs 10 and 11, and disable STP. Configure ports GigabitEthernet 9/0/3 and GigabitEthernet 9/0/4 as access ports and assign them to VLAN 10 and VLAN 11, respectively.
<DeviceA> system-view
[DeviceA] vlan 10 to 11
Please wait... Done.
[DeviceA] interface GigabitEthernet 9/0/1
[DeviceA-GigabitEthernet9/0/1] port link-type trunk
[DeviceA-GigabitEthernet9/0/1] port trunk permit vlan 10 11
[DeviceA-GigabitEthernet9/0/1] undo port trunk permit vlan 1
[DeviceA-GigabitEthernet9/0/1] undo stp enable
[DeviceA-GigabitEthernet9/0/1] undo shutdown
[DeviceA-GigabitEthernet9/0/1] quit
[DeviceA] interface GigabitEthernet 9/0/2
[DeviceA-GigabitEthernet9/0/2] port link-type trunk
[DeviceA-GigabitEthernet9/0/2] port trunk permit vlan 10 11
[DeviceA-GigabitEthernet9/0/2] undo port trunk permit vlan 1
[DeviceA-GigabitEthernet9/0/2] undo stp enable
[DeviceA-GigabitEthernet9/0/2] undo shutdown
[DeviceA-GigabitEthernet9/0/2] quit
[DeviceA] interface GigabitEthernet 9/0/3
[DeviceA-GigabitEthernet9/0/3] port access vlan 10
[DeviceA-GigabitEthernet9/0/3] undo shutdown
[DeviceA-GigabitEthernet9/0/3] quit
[DeviceA] interface GigabitEthernet 9/0/4
[DeviceA-GigabitEthernet9/0/4] port access vlan 11
[DeviceA-GigabitEthernet9/0/4] undo shutdown
[DeviceA-GigabitEthernet9/0/4] quit
# Map VLAN 10 to MSTI 1 and VLAN 11 to MSTI 2.
[DeviceA] stp region-configuration
[DeviceA-mst-region] instance 1 vlan 10
[DeviceA-mst-region] instance 2 vlan 11
[DeviceA-mst-region] active region-configuration
[DeviceA-mst-region] quit
# Create smart link group 1, and configure VLAN 10 that is mapped to MSTI 1 as a protected VLAN for smart link group 1.
[DeviceA] smart-link group 1
[DeviceA-smlk-group1] protected-vlan reference-instance 1
# Configure GigabitEthernet 9/0/1 as the primary port and GigabitEthernet 9/0/2 as the secondary port.
[DeviceA-smlk-group1] port GigabitEthernet 9/0/1 master
[DeviceA-smlk-group1] port GigabitEthernet 9/0/2 slave
# Enable flush message sending and configure VLAN 10 as the transmit control VLAN for smart link group 1.
[DeviceA-smlk-group1] flush enable control-vlan 10
# Enable role preemption and use the default preemption delay.
[DeviceA-smlk-group1] preemption mode role
[DeviceA-smlk-group1] quit
# Create smart link group 2, and configure VLAN 11 that is mapped to MSTI 2 as a protected VLAN for smart link group 1.
[DeviceA] smart-link group 2
[DeviceA-smlk-group2] protected-vlan reference-instance 2
# Configure GigabitEthernet 9/0/2 as the primary port and GigabitEthernet 9/0/1 as the secondary port.
[DeviceA-smlk-group2] port GigabitEthernet 9/0/2 master
[DeviceA-smlk-group2] port GigabitEthernet 9/0/1 slave
# Enable flush message sending and configure VLAN 11 as the transmit control VLAN for smart link group 2.
[DeviceA-smlk-group2] flush enable control-vlan 11
# Enable role preemption and use the default preemption delay.
[DeviceA-smlk-group2] preemption mode role
[DeviceA-smlk-group2] quit
Configuring Device B
# Configure ports GigabitEthernet 9/0/1 and GigabitEthernet 9/0/2 as trunk ports, and assign them to VLAN 10 and VLAN 11. Enable flush message receiving on the ports, and configure VLANs 10 and 11 as the receive control VLANs.
<DeviceB> system-view
[DeviceB] vlan 10 to 11
Please wait... Done.
[DeviceB] interface GigabitEthernet 9/0/1
[DeviceB-GigabitEthernet9/0/1] port link-type trunk
[DeviceB-GigabitEthernet9/0/1] port trunk permit vlan 10 11
[DeviceB-GigabitEthernet9/0/1] undo port trunk permit vlan 1
[DeviceB-GigabitEthernet9/0/1] smart-link flush enable control-vlan 10 11
[DeviceB-GigabitEthernet9/0/1] undo shutdown
[DeviceB-GigabitEthernet9/0/1] quit
[DeviceB] interface GigabitEthernet 9/0/2
[DeviceB-GigabitEthernet9/0/2] port link-type trunk
[DeviceB-GigabitEthernet9/0/2] port trunk permit vlan 10 11
[DeviceB-GigabitEthernet9/0/2] undo port trunk permit vlan 1
[DeviceB-GigabitEthernet9/0/2] smart-link flush enable control-vlan 10 11
[DeviceB-GigabitEthernet9/0/2] undo shutdown
[DeviceB-GigabitEthernet9/0/2] quit
# Create monitor link group 1.
[DeviceB] monitor-link group 1
# Configure GigabitEthernet 9/0/2 as an uplink port and GigabitEthernet 9/0/1 as a downlink port.
[DeviceB-mtlk-group1] port GigabitEthernet 9/0/2 uplink
[DeviceB-mtlk-group1] port GigabitEthernet 9/0/1 downlink
Configuring Device C
# Configure ports GigabitEthernet 9/0/1 and GigabitEthernet 9/0/2 as trunk ports, and assign them to VLAN 10 and VLAN 11. Enable flush message receiving on the ports, and configure VLANs 10 and 11 as the receive control VLANs.
<DeviceC> system-view
[DeviceC] vlan 10 to 11
Please wait... Done.
[DeviceC] interface GigabitEthernet 9/0/1
[DeviceC-GigabitEthernet9/0/1] port link-type trunk
[DeviceC-GigabitEthernet9/0/1] port trunk permit vlan 10 11
[DeviceC-GigabitEthernet9/0/1] undo port trunk permit vlan 1
[DeviceC-GigabitEthernet9/0/1] smart-link flush enable control-vlan 10 11
[DeviceC-GigabitEthernet9/0/1] undo shutdown
[DeviceC-GigabitEthernet9/0/1] quit
[DeviceC] interface GigabitEthernet 9/0/2
[DeviceC-GigabitEthernet9/0/2] port link-type trunk
[DeviceC-GigabitEthernet9/0/2] port trunk permit vlan 10 11
[DeviceC-GigabitEthernet9/0/2] undo port trunk permit vlan 1
[DeviceC-GigabitEthernet9/0/2] smart-link flush enable control-vlan 10 11
[DeviceC-GigabitEthernet9/0/2] undo shutdown
[DeviceC-GigabitEthernet9/0/2] quit
# Create monitor link group 1.
[DeviceC] monitor-link group 1
# Configure GigabitEthernet 9/0/2 as an uplink port and GigabitEthernet 9/0/1 as a downlink port.
[DeviceC-mtlk-group1] port GigabitEthernet 9/0/2 uplink
[DeviceC-mtlk-group1] port GigabitEthernet 9/0/1 downlink
Configuring Device D
# Configure ports GigabitEthernet 9/0/1, GigabitEthernet 9/0/2, and GigabitEthernet 9/0/3 as trunk ports, and assign the ports to VLAN 10 and VLAN 11. Enable flush message receiving and configure VLANs 10 and 11 as the receive control VLANs on GigabitEthernet 9/0/1 and GigabitEthernet 9/0/2.
<DeviceD> system-view
[DeviceD] vlan 10 to 11
Please wait... Done.
[DeviceD] interface GigabitEthernet 9/0/1
[DeviceD-GigabitEthernet9/0/1] port link-type trunk
[DeviceD-GigabitEthernet9/0/1] port trunk permit vlan 10 11
[DeviceD-GigabitEthernet9/0/1] undo port trunk permit vlan 1
[DeviceD-GigabitEthernet9/0/1] smart-link flush enable control-vlan 10 11
[DeviceD-GigabitEthernet9/0/1] undo shutdown
[DeviceD-GigabitEthernet9/0/1] quit
[DeviceD] interface GigabitEthernet 9/0/2
[DeviceD-GigabitEthernet9/0/2] port link-type trunk
[DeviceD-GigabitEthernet9/0/2] port trunk permit vlan 10 11
[DeviceD-GigabitEthernet9/0/2] undo port trunk permit vlan 1
[DeviceD-GigabitEthernet9/0/2] smart-link flush enable control-vlan 10 11
[DeviceD-GigabitEthernet9/0/2] undo shutdown
[DeviceD-GigabitEthernet9/0/2] quit
[DeviceD] interface GigabitEthernet 9/0/3
[DeviceD-GigabitEthernet9/0/3] port link-type trunk
[DeviceD-GigabitEthernet9/0/3] port trunk permit vlan 10 11
[DeviceD-GigabitEthernet9/0/3] undo port trunk permit vlan 1
[DeviceD-GigabitEthernet9/0/3] undo shutdown
[DeviceD-GigabitEthernet9/0/3] quit
Verifying the configuration
# Display the smart link configuration on Device A.
[DeviceA] display smart-link group all
Smart link group 1 information:
Device ID: 0020-6455-0000
Preemption mode: ROLE
Preemption delay: 1(s)
Control VLAN: 10
Protected VLAN: Reference Instance 1
Member Role State Flush-count Last-flush-time
-----------------------------------------------------------------------------
GigabitEthernet9/0/1 MASTER ACTIVE 0 NA
GigabitEthernet9/0/2 SLAVE STANDBY 0 NA
Smart link group 2 information:
Device ID: 0020-6455-0000
Preemption mode: ROLE
Preemption delay: 1(s)
Control VLAN: 11
Protected VLAN: Reference Instance 2
Member Role State Flush-count Last-flush-time
-----------------------------------------------------------------------------
GigabitEthernet9/0/2 MASTER ACTIVE 0 NA
GigabitEthernet9/0/1 SLAVE STANDBY 0 NA
# Display the monitor link configuration on Device B.
[DeviceB] display monitor-link group all
Monitor link group 1 information:
Group status: UP
Last-up-time: 16:49:24 2009/01/16
Last-down-time: -
Member Role Status
------------------------------------------
GigabitEthernet9/0/2 UPLINK UP
GigabitEthernet9/0/1 DOWNLINK UP
# Display the monitor link configuration on Device C.
[DeviceC] display monitor-link group all
Monitor link group 1 information:
Group status: UP
Last-up-time: 16:53:13 2009/01/16
Last-down-time: -
Member Role Status
------------------------------------------
GigabitEthernet9/0/2 UPLINK UP
GigabitEthernet9/0/1 DOWNLINK UP
After completing the configurations, send traffic of VLAN 10 and VLAN 11 to GigabitEthernet 9/0/3 and GigabitEthernet 9/0/4 on Device A, respectively. Traffic of VLAN 10 reaches Device D through Device B, and traffic of VLAN 11 reaches Device D through Device C.
Configuration files
· Device A:
#
vlan 1
#
vlan 10 to 11
#
stp region-configuration
instance 1 vlan 10
instance 2 vlan 11
active region-configuration
#
smart-link group 1
preemption mode role
protected-vlan reference-instance 1
flush enable control-vlan 10
smart-link group 2
preemption mode role
protected-vlan reference-instance 2
flush enable control-vlan 11
#
interface GigabitEthernet9/0/1
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 10 to 11
stp disable
port smart-link group 1 master
port smart-link group 2 slave
#
interface GigabitEthernet9/0/2
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 10 to 11
stp disable
port smart-link group 1 slave
port smart-link group 2 master
#
· Device B:
#
vlan 1
#
vlan 10 to 11
#
monitor-link group 1
#
interface GigabitEthernet9/0/1
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 10 to 11
smart-link flush enable control-vlan 10 to 11
port monitor-link group 1 downlink
#
interface GigabitEthernet9/0/2
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 10 to 11
smart-link flush enable control-vlan 10 to 11
port monitor-link group 1 uplink
#
· Device C:
#
vlan 1
#
vlan 10 to 11
#
monitor-link group 1
#
interface GigabitEthernet9/0/1
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 10 to 11
smart-link flush enable control-vlan 10 to 11
port monitor-link group 1 downlink
#
interface GigabitEthernet9/0/2
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 10 to 11
smart-link flush enable control-vlan 10 to 11
port monitor-link group 1 uplink
#
· Device D:
#
vlan 1
#
vlan 10 to 11
#
interface GigabitEthernet9/0/1
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 10 to 11
smart-link flush enable control-vlan 10 to 11
#
interface GigabitEthernet9/0/2
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 10 to 11
smart-link flush enable control-vlan 10 to 11
#
interface GigabitEthernet9/0/3
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 10 to 11
#
Related documentation
· H3C S12500 Routing Switch Series High Availability Configuration Guide
· H3C S12500 Routing Switch Series High Availability Command Reference
· H3C S12500 Routing Switch Series Layer 2—LAN Switching Configuration Guide
· H3C S12500 Routing Switch Series Layer 2—LAN Switching Command Reference