• 产品与解决方案
  • 行业解决方案
  • 服务
  • 支持
  • 合作伙伴
  • 新华三人才研学中心
  • 关于我们

02-网络管理命令参考

  • 发布时间:2021/12/22 16:30:50
  • 浏览量:
  • 下载量:

01-接口命令

本章节下载  (251.94 KB)

docurl=/cn/Service/Document_Software/Document_Center/IP_Security/ACG/H3C_SecPath_ACG1000/Command/Command_Manual/H3C_ACG1000_CR(F6610)-797/02/202112/1510141_30005_0.htm

01-接口命令


1 接口

1.1  以太网端口配置命令

1.1.1  allow access

allow access命令用来配置端口管理访问方式。

no allow access命令用来取消端口管理访问方式。

【命令】

allow access { center-monitor | http | https | ping | telnet | ssh | all }

no allow access { center-monitor | http | https | ping | telnet | ssh | all }

【缺省情况】

缺省情况下,未使能任何访问方式。

【视图】

接口视图

【参数】

center-monitor:允许或者禁止集中网管来管理设备。

http:允许或者禁止通过HTTP方式管理设备。

https:允许或者禁止通过HTTPS方式管理设备。

ping:允许或者禁止外面设备ping本设备。

telnet:允许或者禁止通过telnet方式管理设备。

ssh:允许或者禁止通过ssh方式管理设备。

all:允许或者禁止外面设备开启所有访问控制。

【使用指导】

·     端口的管理访问是用来控制通过该端口访问和管理设备的权限。通过配置端口的管理访问可以限制对端口的某类访问,保护设备的安全运行。

·     以上这些权限在同一个端口上可以同时打开多个,可以组合使用。

【举例】

# ge0端口开启所有访问控制。

host# system-view

host(config)# interface ge0

host(config-ge0)#allow access all

1.1.2  auto-negotiate

auto-negotiate 命令用来启用/禁用端口自协商。

【命令】

auto-negotiate { on | off }

【缺省情况】

缺省情况下,以太网接口的自协商模式为on。

【视图】

接口视图

【参数】

on:启用端口自协商功能。

off禁用端口自协商功能。

【使用指导】

光类型接口不支持自协商off模式。

【举例】

# 关闭ge0接口的自协商功能。

host# system-view

host(config)# interface ge0

host(config-ge0)#auto-negotiate off

1.1.3  duplex

duplex命令用来设置端口的双工模式。

【命令】

duplex { full | half }

【视图】

接口视图

【参数】

full:全双工。

half:半双工。

【使用指导】

·     只有在关闭端口的自协商功能的情况下,才能进行双工的配置。

·     与共享式HUB相连时,应设置以太网口为半双工方式;与交换式LAN SWITCH相连时,一般设置以太网口为全双工方式。

【举例】

# 设置ge0接口为全双工模式。

host# system-view

host(config)# interface ge0

host(config-ge0)#duplex full

1.1.4  ip address

ip address命令用来配置端口的IP地址。

no ip address命令用来取消端口的IP地址。

【命令】

ip address address [ secondary ]

no ip address address [ secondary ]

【视图】

接口视图

【参数】

address:接口IP地址。

secondary:辅助IP地址。

【使用指导】

·     接口除了配置主IP外还能配置多个辅IP,用于一个物理端口下接多个网段的机器。

·     需要先配置主IP地址才能配置辅IP地址。

【举例】

# ge0端口配置静态IP地址10.1.1.10。

host# system-view

host(config)# interface ge0  

host(config-ge0)#ip address 10.1.1.10/24

1.1.5  ip address dhcp

ip address dhcp命令用来配置接口通过DHCP方式从DHCP服务器获取IP地址。

no ip address dhcp命令用来取消接口通过DHCP方式获取IP地址。

【命令】

ip address dhcp distance distance-range gw { reset | default } dns  { reset | default }

【视图】

接口视图

【参数】

distance-range:通过DHCP获取地址的优先级,取值范围1~255。

reset:使用DHCP服务器指定的网关或DNS。

default:使用系统原有的网管或DNS。

【举例】

# ge0端口配置dhcp模式获取IP地址。

host# system-view

host(config)# interface ge0

host(config-ge0)#ip address dhcp distance 1 gw reset dns reset

1.1.6  ip address pppoe

ip address pppoe命令用来配置接口通过PPPOE方式从服务器获取IP地址。

no ip address pppoe命令用来取消接口通过PPPOE方式获取IP地址。

【命令】

ip address pppoe

no ip address pppoe

【视图】

接口视图

【参数】

无。

【使用指导】

·     通过PPPOE从服务器获取IP地址,同时也能取到网关和DNS设置。

·     在启用PPPOE方式时不可以指定IP地址;可通过PPPOE方式获取地址。

【举例】

# ge0端口配置为PPPOE模式。

host# system-view

host(config)# interface ge0

host(config-ge0)#ip address pppoe

1.1.7  pppoe default_gateway

pppoe default_gateway命令用来配置自动下发pppoe路由。

no pppoe default_gateway命令用来取消配置自动下发pppoe路由。

【命令】

pppoe default_gateway

no pppoe default_gateway

【视图】

接口视图

【参数】

【使用指导】

·     配置pppoe default_gateway,接口pppoe拨号成功后,会自动一条创建pppoe接口的默认路由。

【举例】

# ge0端口配置pppoe自动下发路由。

host# system-view

host(config)# interface ge0

host(config-ge0)# pppoe default_gateway

 

1.1.8  pppoe dns

pppoe dns命令用来配置自动获取DNS。

no pppoe dns命令用来取消配置自动获取DNS。

【命令】

pppoe dns

no pppoe dns

【视图】

接口视图

【参数】

【使用指导】

·     配置pppoe dns,接口pppoe拨号成功后,会自动从pppoe服务器获取DNS配置。

【举例】

# ge0端口配置pppoe 自动获取DNS。

host# system-view

host(config)# interface ge0

host(config-ge0)# pppoe dns

 

1.1.9  pppoe distance

pppoe distance命令用来配置pppoe路由优先级。

no pppoe distance命令用来取消配置pppoe路由优先级。

【命令】

pppoe distance id

no pppoe distance

【视图】

接口视图

【参数】

id:路由优先级,范围为1-255,默认为1。优先级为1时优先级最高,取值越大,优先级越低。

【使用指导】

·     配合更新网关命令pppoe default_gateway来使用,只有自动下发pppoe路由的情况下,路由优先级的配置才会生效。

【举例】

# ge0端口配置pppoe路由优先级为10。

host# system-view

host(config)# interface ge0

host(config-ge0)# pppoe distance 10

1.1.10  pppoe weight

pppoe weight命令用来配置pppoe路由权重值。

no pppoe weight命令用来取消配置pppoe路由权重值。

【命令】

pppoe weight id

no pppoe weight

【视图】

接口视图

【参数】

id:路由权重值范围为1-100。

【使用指导】

·     配合更新网关命令pppoe default_gateway来使用,只有自动下发pppoe路由的情况下,路由权重值的配置才会生效。

【举例】

# ge0端口配置pppoe路由权重值为20。

host# system-view

host(config)# interface ge0

host(config-ge0)# pppoe weight 20

 

1.1.11  ipv6 address

ipv6 address命令用来配置端口的IP地址。

no ipv6 address命令用来取消端口的IP地址。

【命令】

ipv6 address address [ secondary ]

no ipv6 address address [ secondary ]

【视图】

接口视图

【参数】

address:接口IP地址。

secondary:辅助IP地址。

【使用指导】

·     接口除了配置主IP外还能配置多个辅IP,用于一个物理端口下接多个网段的机器。

·     需要先配置主IP地址才能配置辅IP地址。

【举例】

# ge0端口配置静态IPv6地址2003:7856::1/64和一个辅IPv6地址4005:8899::1/64。

host# system-view

host(config)# interface ge0

host(config-ge0)#ipv6 address 2003:7856::1/64

host(config-ge0)#ipv6 address 4005:8899::1/64 secondary

1.1.12  mtu

mtu命令用来配置端口的MTU值,用于控制接口的最大报文发送长度。

【命令】

mtu mtu-range

【缺省情况】

缺省情况下,MTU值为1500字节。

【视图】

接口视图

【参数】

mtu-range:MTU值,取值范围12801500字节

【举例】

# 配置ge0端口的MTU值为1400字节。

host# system-view

host(config)# interface ge0

host(config-ge0)#mtu 1400

1.1.13  display interface

display interface命令用来显示接口信息。

【命令】

display interface interface-name

【视图】

任意视图

【参数】

interface-name:接口名称。

【举例】

# 显示端口ge0的信息。

host# display interface ge0

----------------------------------------------------------------------

interface ge0

description:

        Admin UP   Link UP

        MTU: 1400

        MAC address: 00:21:45:c2:e7:40

        Auto negotiate: OFF

        Speed: 100  Duplex: FULL

        media type: COMBO(COPPER)

        Listen Mode: OFF

        Link-local address: fe80::221:45ff:fec2:e740/64

表1-1 display interface命令显示信息描述表

字段

描述

Admin UP

接口物理状态,有Link UP和Link DOWN两种情况

kernel ID

设备内核接口创建时的序号

MTU

接口MTU值

IP address

接口IPv4地址

MAC address

接口MAC地址

Auto negotiate

接口自协商方式,有ON和OFF两种方式

Speed

接口速率

Duplex

接口双工模式

media type

接口类型,有电口和光口两种类型

Listen Mode

接口监听模式,有ON和OFF两种方式

Traffic Mode

接口属性,有内网口和外网口两种属性

Link-local address

接口的链路本地地址,配置IPv6地址后显示

Global unicast address

接口IPv6地址

 

1.1.14  shutdown

shutdown命令用来关闭端口收发包功能。

no shutdown命令用来打开端口收发包功能。

【命令】

shutdown

no shutdown

【缺省情况】

缺省情况下,端口为开启状态。

【视图】

接口视图

【举例】

# 关闭ge0接口。

host# system-view

host(config)# interface ge0

host(config-ge0)#shutdown

1.1.15  speed

speed命令用来配置接口收发包的速率。

【命令】

speed { 10 | 100 | 1000 }

【视图】

接口视图

【参数】

10:端口收发包速率10M。

100:端口收发包速率100M。

1000:端口收发包速率1000M。

【使用指导】

只有在自协商模式为off时可配置。

【举例】

# 设置ge0接口的速率为100M。

host# system-view

host(config)# interface ge0

host(config-ge0)#speed 100

1.2  聚合接口配置命令

1.2.1  aggregate-group

aggregate-group命令用来把端口加入聚合接口。

no aggregate-group命令用来把端口移除聚合接口。

【命令】

aggregate-group id

no aggregate-group id

【视图】

接口视图

【参数】

id:聚合接口,取值范围0~255。

【使用指导】

配置聚合接口后,需要将实际物理接口或VLAN接口加入聚合接口中,这些接口被称为聚合组端口。

所有加入到Aggregate接口的物理子接口都可以接收报文,并且在发送报文时,轮询发送,即从第一个物理子接口到最后一个物理子接口依次发送。

将一个端口加入聚合接口时,该端口的所有IP地址将被删除。

【举例】

# 将ge1加入聚合接口agg0内。

host# system-view

host(config)# interface ge1

host(config-ge1)#aggregate-group 0

1.2.2  interface

interface命令用来创建接口,并进入接口视图,如果创建的接口已经存在,则直接进入接口视图。

no interface命令用来删除指定接口。

【命令】

interface name

no interface name

【视图】

系统视图

【参数】

name:聚合接口名,以agg开头,后面添加0~255的数字。

【举例】

# 创建聚合接口agg0。

host# system-view

host(config)# interface agg0

1.3  VLAN接口配置命令

1.3.1  interface

interface命令用来创建VLAN接口,并进入接口视图,如果创建的接口已经存在,则直接进入接口视图。

no interface命令用来删除指定的VLAN接口。

【命令】

interface name.vlanid

no interface name.vlanid

【视图】

系统视图

【参数】

name:接口名称。

vlanidVLAN ID,范围1~4094。

【使用指导】

如果要让设备识别带VLAN标识的包,需要创建一个以太网子接口,并且为其指定一个VLAN ID,则可以通过该子接口接收/转发带VLAN的包。

【举例】

# 创建一个物理以太网接口ge的VLAN子接口,VLAN ID为10。

host# system-view

host(config)# interface ge0.10

1.4  透明网桥配置命令

1.4.1  bridge forward-delay

bridge max-time命令用来修改透明网桥转发时延。

【命令】

bridge forward-delay delay-time

【缺省情况】

缺省情况下,缺省时间为15S。

【视图】

透明网桥视图

【参数】

delay -time:端口状态转换时延,范围4~30秒。

【使用指导】

端口转换时延是指开启STP后,端口从listening到learning到forwarding变化的时间间隔。

【举例】

# 修改网桥bvi0的状态转换时延为20秒。

host# system-view

host(config)# interface bvi0

host(config-bvi0)#bridge forward-delay 20

1.4.2  bridge hello-time

bridge hello-time命令用来修改透明网桥配置发送bpdu hello时间。

【命令】

bridge hello-time hello-time

【缺省情况】

缺省情况下,缺省时间为2S。

【视图】

透明网桥视图

【参数】

hello-time:发送hello bpdu时间间隔,范围1~10秒。

【举例】

# 修改网桥bvi0的hello-time为2秒。

host# system-view

host(config)# interface bvi0

host(config-bvi0)#bridge hello-time 2

1.4.3  bridge max-age

bridge max-age命令用来修改透明网桥最大老化时间。

【命令】

bridge max-age age-time

【缺省情况】

缺省情况下,缺省时间为20S。

【视图】

透明网桥视图

【参数】

age-time:最大老化时间,范围6-40秒。

【举例】

# 修改网桥bvi0的age-time为30秒。

host# system-view

host(config)# interface bvi0

host(config-bvi0)#bridge max-age 30

1.4.4  bridge priority

bridge priority命令用来修改网桥的优先级。

【命令】

bridge priority priority-rang

【缺省情况】

缺省情况下,优先级默认为32767。

【视图】

透明网桥视图

【参数】

priority-rang:桥接口优先级,范围为0~65535。

【举例】

# 修改网桥bvi0的优先级为1000。

host# system-view

host(config)# interface bvi0

host(config-bvi0)#bridge priority 1000

1.4.5  bridge stp

bridge stp命令用来开启或关闭网桥STP功能。

【命令】

bridge stp { enable | disable }

【缺省情况】

缺省情况下, 网桥STP功能为disable。

【视图】

透明网桥视图

【参数】

enable:开启stp功能。

disable:关闭stp功能。

【举例】

# 开启网桥bvi0的STP功能。

host# system-view

host(config)# interface bvi0

host(config-bvi0)#bridge stp enable

1.4.6  bridge-group

bridge-group命令用来把端口加入透明网桥接口。

no bridge-group命令用来把端口移除透明网桥接口。

【命令】

bridge-group id

no bridge-group id

【视图】

接口视图

【参数】

id:网桥接口索引,取值范围0~255。

【举例】

# 将ge1作为网桥组端口加入网桥。

host# system-view

host(config)# interface ge1

host(config-ge1)#bridge-group 0

1.4.7  interface

interface命令用来创建透明网桥接口,并进入网桥视图,如果创建的网桥接口已经存在,则直接进入网桥接口视图。

no interface命令用来删除指定的网桥接口。

【命令】

interface name

no interface name

【视图】

系统视图

【参数】

name:网桥接口名,以bvi开头,后面添加0~255的数字。

【使用指导】

配置透明网桥后,需要将实际物理接口或VLAN接口加入网桥中,这些接口被称为网桥组端口。

网桥组端口的ID由两部分组成:1字节的优先级和1字节的端口号。当网桥有两个端口都连接在LAN上从而形成回路时,可以通过网桥端口ID来影响端口的选择,ID越小的端口越有可能成为指定端口。因此,如果网桥端口的优先级越小,则网桥端口的ID越小,越有可能成为指定端口。

同一个接口只能加入到一个网桥组。

将一个端口加入网桥时,该端口的所有IP地址将被删除。

【举例】

# 创建一个网桥接口bvi0。

host# system-view

host(config)# interface bvi0

1.4.8  display bridge-group

display bridge-group命令用来指定桥组信息。

【命令】

display bridge-group group-id

【视图】

任意视图

【参数】

Group-id:网桥组ID,范围0~255。

【使用指导】

分别显示了桥组名、STP启用状态、桥ID、指定的根、FDB老化时间及该桥组所包含的端口及端口的状态。

【举例】

# 显示网桥组bvi0的信息。

host# display bridge-group 0

Bridge: bvi0

 STP: enabled

 bridge id               : 0001.002145c2e741

 designated root         : 0001.002145c2e741

 Ageing time: 300

 Hello time: 2

 Max age: 20

 Forward delay: 20

 Bridge ports:

        ge1                     <forwarding>

表1-2 display bridge-group命令显示信息描述表

字段

描述

Bridge

桥组名称

STP

接口STP的状态,有enable和disable两种

bridge id

指定桥ID

designated root

指定根桥

Hello time

发送hello包的间隔

Max age

最大老化时间

Forward delay

状态转换时延

Bridge ports

桥接口

 

1.5  隧道接口配置命令

1.5.1  interface tunnel

interface tunnel命令用来创建隧道接口,并进入隧道视图,如果创建的隧道接口已经存在,则直接进入隧道接口视图。

no interface tunnel命令用来删除指定的隧道接口。

【命令】

interface tunnel tunnel-id mode { gre | ipsec | ipv6ip { manual | 6to4 | isatap } }

no interface tunnel tunnel-name

【视图】

系统视图

【参数】

tunnel-id:tunnel接口id,范围为0~1023。

tunnel-name:隧道名称。

gre:gre封装方式。

ipsec:ipsec封装方式。

ipv6ip:ipv6封装模式。

manual:手动隧道。

6to4:6to4隧道

isatap:isatap隧道。

【使用指导】

每个接口都能分别配置不同的封装模式,但每次只能配置一种方式,且在接口创建时就指定,不能修改。

IPv6手动隧道是点到点的隧道模式,隧道的两端都必须配置才能成功通信,否则隧道的另一端会认为该报文不是自己的报文而被丢弃。手动隧道必须由管理员手动配置封装IPv6报文的IPv4源和目的地址。

6to4采用特殊的IPv6地址使在IPv4海洋中的IPv6孤岛能相互连接。此时IPv6的出口路由器与其他的IPv6域建立隧道连接。IPv4隧道的末端可从IPv6域的地址前缀中自动提取,因为站点的IPv4地址包含在IPv6地址前缀中。

ISATAP ( Intra-Site Automatic Tunnel Addressing Protocol,站内自动隧道寻址协议)是一种地址分配和主机到主机、主机到路由器和路由器到主机的自动隧道技术,它为IPv6主机之间提供了跨越IPv4内部网络的单播IPv6连通性ISATAP一般用于IPv4网络中的IPv6/IPv4节点间的通信。

【举例】

# 创建一个6to4模式的tunnel接口。

host# system-view

host(config)# interface tunnel 2 mode ipv6ip 6to4

1.5.2  display interface

display interface命令用来显示接口信息。

【命令】

display interface tunnel-name

【视图】

任意视图

【参数】

tunnel -name:隧道接口名称。

【举例】

# 显示端口tunnel0的信息。

host# display interface tunnel0

----------------------------------------------------------------------

interface tunnel0

description:

        Admin UP   Link DOWN

        MTU: 1480

        tunnel mode: manual(ipv6)

        tunnel source-dev: ge0 (192.168.1.85)

        tunnel destination addr: 10.1.1.1

表1-3 display interface命令显示信息描述表

字段

描述

Admin UP

接口物理状态,Link UP和Link DOWN两种情况

MTU

接口MTU值

tunnel mode

隧道模式,有manual,6to4和isatap三种

tunnel source-dev

隧道的源接口或地址

tunnel destination addr

隧道的目的地址

 

1.5.3  tunnel destination

tunnel destination命令用来指定隧道接口的目的地址。

no tunnel destination命令用来删除隧道接口的目的地址。

【命令】

tunnel destination address

no tunnel destination

【视图】

隧道接口视图

【参数】

address:隧道目的地址。

【使用指导】

只有配置为manual模式的隧道才能配置目的地址。

【举例】

# 创建tunnel0隧道,并配置它的目的地址为10.1.1.1。

host# system-view

host(config)# interface tunnel 0 mode ipv6ip manual

host(config-tunnel0)#tunnel destination 10.1.1.1

 

1.5.4  tunnel source

tunnel source命令用来指定隧道接口的源地址或源接口。

no tunnel source命令用来删除隧道接口的源地址或源接口。

【命令】

tunnel source { address | interface-name }

no tunnel source

【视图】

隧道接口视图

【参数】

address:隧道源地址。

interface-name:接口名称。

【举例】

# 配置一个6to4模式的tunnel接口,并将ge0接口作为隧道源接口。

host# system-view

host(config)# interface tunnel 2 mode ipv6ip 6to4

host(config-tunnel2)#tunnel source ge0

 

1.5.5  next-tunnel

next-tunnel命令用来指定GRE隧道的下一跳。

no next-tunnel命令用来删除GRE隧道的下一跳。

【命令】

next-tunnel tunnel tunnel-id

no next-tunnel

【视图】

隧道接口视图

【参数】

tunnel-id:tunnel接口id,范围为0~1023。

【使用指导】

只有配置为GRE模式的隧道才能配置下一跳。

【举例】

#配置tunnel0的下一跳为tunnel1

host# system-view

host (config)# interface tunnel 0 mode gre

host (config-tunnel0)# next-tunnel tunnel 1

1.6  虚拟网线命令

1.6.1  virtual-line

virtual-line命令用来配置虚拟网线名称。

【命令】

virtual-line name

【视图】

config视图。

【参数】

name:所创建虚拟网线的名称,为1~31个字符的字符串,且不能包含“%!"#$&`*+,/:;<=>?\^'{}!”。

【使用指导】

该命令可以创建一条虚拟网线配置。

【举例】

# 配置一条名为“test”的虚拟网线。

host# configure terminal

host(config)# virtual-line test

【相关命令】

·     display virtual-line

1.6.2  description

description命令用来添加此条虚拟网线的描述。

【命令】

description DESCRIPTION

【视图】

vline视图

【参数】

DESCRIPTION:虚拟网线描述,为0~127个字符的字符串。

【使用指导】

仅写入描述。

【举例】

# 创建一条“test”的描述

host(config)# virtual-line test

host(vline-test)# description test

【相关命令】

·     display virtual-line

1.6.3  interface

interface 命令用来选择接口

【命令】

Interface first_interface second_interface

【视图】

vline视图

【参数】

first_interface:加入虚拟网线的物理接口1。

second_interface:加入虚拟网线的物理接口2。

【使用指导】

仅作为选择端口联动使用。

【举例】

# 创建ge10、ge11接口。

host(config)# virtual-line test

host(vline-test)#interface ge10 ge11

【相关命令】

·     display virtual-line

1.6.4  interface-linkage

interface-linkage enable命令用来开启端口联动。

interface-linkage disable命令用来关闭端口联动。

 

【命令】

Interface-linkage enable

Interface-linkage disable

【视图】

vline视图

【使用指导】

加入接口后选择开启端口联动。

【举例】

# 配置ge10、ge11接口联动。

host(config)# virtual-line test

host(vline-test)# interface ge10 ge11

host(vline-test)#interface-linkage enable

【相关命令】

·     display virtual-line

1.6.5  vlan

vlan命令用来配置虚拟网线允许的vlan 范围。

【命令】

vlan VLAN-LIST

【视图】

vline视图

【参数】

VLAN-LIST:虚拟网线可以控制允许通过的vlan范围。

【举例】

# 配置可允许通过的vlan范围为“0-4094”:

host(config)# virtual-line test

host(vline-test)# interface ge10 ge11

host(vline-test)#interface-linkage enable

host(vline-test)#vlan 0-4094

【相关命令】

·     display virtual-line

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

新华三官网
联系我们