H3C低端以太网交换机典型配置案例(V1.04)

08-Voice VLAN典型配置案例

本章节下载  (297.05 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S5600/S5600/Configure/Typical_Configuration_Example/S5600_Typical_Configuration_Example(V1.04)/200809/615975_30005_0.htm

08-Voice VLAN典型配置案例


Voice VLAN典型配置举例

关键词:VLAN802.1qVoice VLAN

摘  要:本文主要介绍H3C系列以太网交换机的Voice VLAN基本原理以及在具体组网中的应用配置。

缩略语:VLANVitrual LAN,虚拟局域网)

 


第1章  Voice VLAN功能介绍

1.1  适用产品

本配置举例适用于以下支持Voice VLAN功能的H3C系列交换机:

l              S3600

l              S5600

l              S5100-EI

l              E352/E328

l              S3100-EI

l              E126A

1.2  Voice VLAN配置

&  说明:

l      在配置Voice VLAN的过程中,会涉及到VLAN及端口类型等相关功能的配置,请参考产品的操作手册。

l      不同型号的设备,配置的方法会有差异,这里以S3600系列交换机作为举例。其它型号交换机的配置请参见产品的操作手册。

l      下文只列出了基本的配置步骤,有关各个功能的基本原理和作用,请参见各产品的操作、命令手册。

 

1.2.1  配置自动模式下的Voice VLAN

表1-1 配置自动模式下的Voice VLAN

操作

命令

说明

进入系统视图

system-view

-

设置Voice VLAN可识别的其他OUI地址

voice vlan mac-address oui mask oui-mask [ description text ]

可选

缺省情况下,交换机按照缺省的OUI地址来判断语音流

开启Voice VLAN的安全模式

voice vlan security enable

可选

缺省情况下,端口的Voice VLAN安全模式开启

设置Voice VLAN的老化时间

voice vlan aging minutes

可选

缺省情况下,老化时间为1440分钟

开启全局Voice VLAN

voice vlan vlan-id enable

必选

进入以太网端口视图

interface interface-type interface-number

-

开启端口的Voice VLAN功能

voice vlan enable

必选

缺省情况下,端口的Voice VLAN处于关闭状态

开启端口的Voice VLAN legacy功能

voice vlan legacy

可选

缺省情况下,端口的Voice VLAN legacy功能处于关闭状态

设定端口Voice VLAN的工作模式为自动模式

voice vlan mode auto

可选

缺省情况下,端口的Voice VLAN工作模式为自动模式

 

1.2.2  配置手动模式下的Voice VLAN

表1-2 配置手动模式下的Voice VLAN

操作

命令

说明

进入系统视图

system-view

-

设置Voice VLAN识别的其他OUI地址

voice vlan mac-address oui mask oui-mask [ description text ]

可选

如不设置,则交换机按照缺省的OUI地址来判断语音流

开启Voice VLAN的安全模式

voice vlan security enable

可选

缺省情况下,端口的Voice VLAN安全模式开启

设置Voice VLAN的老化时间

voice vlan aging minutes

可选

缺省情况下,老化时间为1440分钟

开启全局Voice VLAN

voice vlan vlan-id enable

必选

进入以太网端口视图

interface interface-type interface-number

-

开启端口的Voice VLAN功能

voice vlan enable

必选

缺省情况下,端口的Voice VLAN处于关闭状态

开启端口的Voice VLAN legacy功能

voice vlan legacy

可选

缺省情况下,端口的Voice VLAN legacy功能处于关闭状态

设定端口Voice VLAN的工作模式为手动模式

undo voice vlan mode auto

必选

缺省情况下,端口的Voice VLAN工作模式为自动模式

退回到系统视图

quit

-

将手动模式端口加入Voice VLAN

access端口

进入VLAN视图

vlan vlan-id

必选

将端口加入VLAN

port interface-list

Trunk或Hybrid端口

进入端口视图

interface interface-type interface-number

将端口加入VLAN

port trunk permit vlan vlan-id

port hybrid vlan vlan-id { tagged | untagged }

设定Voice VLAN为端口默认VLAN

port trunk pvid vlan vlan-id

port hybrid pvid vlan vlan-id

可选

 

 


第2章  配置举例

2.1  Voice VLAN综合配置举例

组网需求某公司准备在办公位和会议室内部署IP电话,为保证通话质量,需要将语音数据在专用的VLAN中传输,并且这个VLAN中不能传输非语音数据。同时要将会议室和办公区的IP电话划分到两个网段中。

l              办公区IP电话组网需求

在员工的办公位上,需要部署自动获取IP地址和Voice VLAN信息的IP电话,该电话可以发送带有VLAN Tag的语音流。员工的PC与IP电话连接后再接入交换机端口,要求该端口在100分钟内没有语音流通过的情况下,自动退出语音VLAN

l              会议室IP电话组网需求

在两个会议室中,分别部署IP电话,其中会议室一部署手工配置IP地址的电话,发送不带VLAN Tag的语音流,该品牌IP电话的OUI地址为00e3-f200-0000。会议室二部署可以自动获取IP地址和Voice VLAN的Cisco IP电话,发送带有VLAN Tag的语音流。

l              整体网络组网需求

办公区的IP电话和PC通过SwitchA接入公司网络,两个会议室的电话通过SwitchB接入公司网络。Core Switch作为网络中心,连接SwitchA、SwitchB,以及XE语音服务器,并通过出口路由器连接到Internet。Core Switch还作为DHCP服务器,为自动获取IP地址的IP电话分配IP地址以及相应的Voice VLAN配置。

2.1.1  组网图

图2-1 Voice VLAN配置举例组网图

2.1.2  配置思路

1. SwitchA的配置

图2-2 SwitchA组网示意图

SwitchA上接入的是自动获取IP地址的IP电话,根据IP电话获取IP地址的一般步骤,需要首先发送不带Tag的DHCP请求报文,由DHCP服务器分配给电话一个临时IP地址,同时告知IP电话Voice VLAN的编号以及语音服务器的IP地址。IP电话收到回复后,将放弃第一次得到的IP地址,重新构造DHCP请求,并携带Voice VLAN的Tag。在Voice VLAN内获取到IP地址后,IP电话即可与语音服务器进行正常通信。

&  说明:

以上仅对一般情况下IP电话获取地址的过程进行描述,不同厂商的IP电话产品,其工作原理可能与上面的描述有所差异,具体情况请参见IP电话的用户手册。

 

因此,在本组网中,要求SwitchA的Ethernet1/0/10端口同时转发缺省VLAN和Voice VLAN的报文,可以将其配置为Trunk或Hybrid端口。这里以Hybrid端口为例:PC发出的报文不带VLAN Tag,因此会在端口的缺省VLAN内传输,我们将缺省VLAN设置为100,用来传输员工PC发出的业务数据,并设置端口在发送缺省VLAN的报文时不带VLAN Tag;由于IP电话在Voice VLAN内获取IP地址后,会发送带有Tag的语音流,因此我们将SwitchA的Voice VLAN设置为200,同时配置Ethernet1/0/10端口工作在Voice VLAN的自动模式,使其能按照语音流量自动加入/退出Voice VLAN。

&  说明:

工作在Voice VLAN自动模式的Hybrid端口在接收到语音流之后,将自动以tagged的方式加入Voice VLAN,即在发送Voice VLAN的报文时保留VLAN Tag,无须手工设置。

 

SwitchA的GigabitEthernet1/1/1端口上行到Core Switch,负责传输业务数据和语音数据,为准确区分数据类型,配置其为Trunk端口,并加入VLAN100和VLAN200,且不要将这两个VLAN设置为缺省VLAN,避免在发送时将Tag去掉。

综上所述,SwitchA上可以使用的端口配置如2-1所示。

表2-1 SwitchA的端口配置

端口

Voice VLAN模式

端口类型

允许通过的VLAN及加入方式

Ethernet1/0/10

自动模式

Trunk/Hybrid

l      VLAN100:pvid,untagged

GigabitEthernet1/1/1

-

Trunk

l      VLAN100:tagged

l      VLAN200:tagged

 

&  说明:

上表中加入方式的类型请参考下面的解释:

l      pvid:表示将此VLAN设置为该端口的缺省VLAN

l      untagged:表示端口在发送此VLAN的报文时去掉VLAN Tag

l      tagged:表示端口在发送此VLAN的报文时保留VLAN Tag

有关端口缺省VLAN的设置以及在发送报文时保留/去掉VLAN Tag的设置,请参考各产品的操作手册。下文中不再赘述。

 

在下面的配置步骤中,对Ethernet1/0/10端口将以Hybrid端口为例进行配置。

2. SwitchB的配置

图2-3 SwitchB组网示意图

SwitchB接入两种类型的电话,因此对Ethernet1/0/1端口和Ethernet1/0/2端口的配置需要分别进行分析:

l              Ethernet1/0/1端口

该端口接入的是手工配置IP地址,发出不带Tag语音流的IP电话,由于自动模式的端口不支持接收不带Tag的语音流,所以Ethernet1/0/1端口只能配置为手动模式,同时将缺省VLAN设置为Voice VLAN。

l              Ethernet1/0/2端口

该端口接入的情况与SwitchA上的Ethernet1/0/10端口类似,但由于该端口只接入IP电话,为保证语音通信的稳定,可以将该端口手动加入Voice VLAN。对于Cisco公司的IP电话,可以开启交换机端口的Voice VLAN legacy功能与其进行通信,告知其Voice VLAN的编号,使其可以直接在Voice VLAN内请求IP地址。因为IP电话在通信时发出的是带Tag的语音流,所以该端口在发送Voice VLAN的报文时应该保留VLAN Tag。

l              GigabitEthernet1/1/2端口

该端口负责发送SwitchB收到的语音报文,根据组网需求,办公区和会议室需要使用不同的Voice VLAN,因此将SwitchB的Voice VLAN配置为VLAN 400,并配置GigabitEthernet1/1/2端口在发送VLAN400的报文时保留VLAN Tag。

综上所述,SwitchB上可以使用的端口配置如2-2所示。

表2-2 SwitchB的端口配置

端口

Voice VLAN模式

端口类型

允许通过的VLAN及加入方式

Ethernet1/0/1

手动模式

Access/Hybrid/Trunk

VLAN400:pvid untagged

Ethernet1/0/2

手动模式

Trunk/Hybrid

VLAN400:tagged

GigabitEthernet1/1/2

-

Trunk/Hybrid

VLAN400:tagged

 

在下面的配置步骤中,对Ethernet1/0/1端口将以Access端口为例进行配置,对Ethernet1/0/2和GigabitEthernet1/1/2端口将以Trunk端口为例进行配置。

3. Core Switch的配置

图2-4 CoreSwitch组网示意图

Core Switch的主要作用是转发网络中的数据,同时为IP电话分配IP地址,并指定Voice VLAN、语音服务器地址等信息。

根据SwitchA和SwitchB上的配置,Core Switch需要转发VLAN100、VLAN200和VLAN400的数据,同时需要为VLAN200和VLAN400中的IP电话分配IP地址。

通过上面的分析,IP电话开机后,首先是在缺省VLAN、即VLAN100中获取IP地址,此时DHCP Server应该在为其分配IP地址的同时携带Voice VLAN、语音服务器地址等信息,因此需要Core Switch在为VLAN100的设备分配IP地址时使用Option 184选项(该选项主要用于告知语音设备Voice VLAN以及语音服务器等信息)。

在IP电话获取到Voice VLAN信息后,将在Voice VLAN内第二次申请IP地址,此时Core Switch应该在VLAN200和VLAN400内为两个区域内的IP电话分配不同网段的IP地址。

Core Switch同时连接了XE语音服务器和网络的出口路由器,因此需要再创建两个VLAN接口,并将GigabitEthernet1/0/3和GigabitEthernet1/0/4分别加入到相应的两个VLAN中,实现对网络中报文的三层转发功能。

综上所述,Core Switch上可以使用的的接口和端口配置如2-3所示。

表2-3 Core Switch的接口和端口配置

VLAN接口

IP地址及网段

包含的端口

端口类型

端口加入VLAN的方式

Vlan-interface100

192.168.1.1/24

GigabitEthernet1/0/1

Trunk

tagged

Vlan-interface200

192.168.2.1/24

GigabitEthernet1/0/1

Trunk

tagged

Vlan-interface400

192.168.4.1/24

GigabitEthernet1/0/2

Trunk

tagged

Vlan-interface300

192.168.3.1/24

GigabitEthernet1/0/3

Access

untagged

Vlan-interface500

192.168.5.1/24

GigabitEthernet1/0/4

Access

untagged

 

2.1.3  配置步骤

1. 使用的设备及版本

本举例中SwitchA和SwitchB均使用S3600系列以太网交换机,Core Switch使用S5600系列以太网交换机,软件版本均为Release 1510。

2. 配置过程

l              配置SwitchA

# 创建VLAN100、VLAN200。

<SwitchA> system-view

[SwitchA] vlan 100

[SwitchA-vlan100] quit

[SwitchA] vlan 200

[SwitchA-vlan200] quit

# 根据2-1中的配置将Ethernet1/0/10和GigabitEthernet1/1/1端口分别加入指定的VLAN。

[SwitchA] interface GigabitEthernet 1/1/1

[SwitchA-GigabitEthernet1/1/1] port link-type trunk

[SwitchA-GigabitEthernet1/1/1] port trunk permit vlan 100 200

[SwitchA-GigabitEthernet1/1/1] quit

[SwitchA] interface Ethernet 1/0/10

[SwitchA-Ethernet1/0/10] port link-type hybrid

[SwitchA-Ethernet1/0/10] port hybrid vlan 100 untagged

[SwitchA-Ethernet1/0/10] port hybrid pvid vlan 100

[SwitchA-Ethernet1/0/10] quit

# 开启Ethernet1/0/10端口的Voice VLAN功能。

[SwitchA-Ethernet1/0/10] voice vlan enable

# 配置Voice VLAN的老化时间为100分钟。

[SwitchA-Ethernet1/0/10] quit

[SwitchA] voice vlan aging 100

# 开启Voice VLAN的安全模式,保证Voice VLAN中只传输语音数据(可选,缺省情况下安全模式开启)。

[SwitchA] voice vlan security enable

# 开启全局的Voice VLAN功能。

[SwitchA] voice vlan 200 enable

l              配置SwitchB

# 在SwitchB上创建VLAN100、VLAN400。

<SwitchB> system-view

[SwitchB] vlan 100

[SwitchB-vlan100] quit

[SwitchB] vlan 400

[SwitchB-vlan400] quit

# 根据2-2中将Ethernet1/0/1、Ethernet1/0/2和GigabitEthernet1/1/2加入相应的VLAN。

[SwitchB] interface Ethernet 1/0/1

[SwitchB-Ethernet1/0/1] port access vlan 400

[SwitchB-Ethernet1/0/1] quit

[SwitchB] interface Ethernet 1/0/2

[SwitchB-Ethernet1/0/2] port link-type trunk

[SwitchB-Ethernet1/0/2] port trunk permit vlan 100 400

[SwitchB-Ethernet1/0/2] quit

[SwitchB] interface GigabitEthernet1/1/2

[SwitchB-GigabitEthernet1/1/2] port link-type trunk

[SwitchB-GigabitEthernet1/1/2] port trunk permit vlan 100 400

[SwitchB-GigabitEthernet1/1/2] quit

# 开启Ethernet1/0/2端口的Voice VLAN legacy功能。

[SwitchB] interface Ethernet 1/0/2

[SwitchB-Ethernet1/0/2] voice vlan legacy

[SwitchB-Ethernet1/0/2] quit

# 将Ethernet1/0/1、Ethernet1/0/2端口的Voice VLAN工作模式设置为手动模式,并开启这两个端口的Voice VLAN功能。

[SwitchB] interface Ethernet 1/0/1

[SwitchB-Ethernet1/0/1] undo voice vlan mode auto

[SwitchB-Ethernet1/0/1] voice vlan enable

[SwitchB-Ethernet1/0/1] quit

[SwitchB] interface Ethernet 1/0/2

[SwitchB-Ethernet1/0/2] undo voice vlan mode auto

[SwitchB-Ethernet1/0/2] voice vlan enable

[SwitchB-Ethernet1/0/2] quit

# 全局增加一个语音OUI地址为00e3-f200-0000,描述字符为“Meeting room1”。

[SwitchB] voice vlan mac-address 00e3-f200-0000 mask ffff-ff00-0000 description Meeting room1

# 开启Voice VLAN的安全模式,保证Voice VLAN中只传输语音数据(可选,缺省情况下安全模式开启)。

[SwitchB] voice vlan security enable

# 全局开启Voice VLAN功能。

[SwitchB] voice vlan 400 enable

l              配置Core-Switch

# 在CoreSwitch上创建VLAN100、VLAN200、VLAN300、VLAN400和VLAN500,并根据2-3中的配置将指定端口加入VLAN,配置方法这里不再赘述。

# 根据2-3中的配置创建各VLAN的VLAN接口,并配置相应的IP地址,配置方法这里不再赘述。

# 开启全局的DHCP Server功能。

<CoreSwitch> system-view

[CoreSwitch] dhcp enable

# 创建全局地址池,名为“vlan100”,为缺省VLAN内的设备分配192.168.1.1/24网段的地址。

[CoreSwitch] dhcp server ip-pool vlan100

[CoreSwitch-dhcp-pool-vlan100] network 192.168.1.0 mask 255.255.255.0

# 在该地址池内配置Option184选项,分配Voice VLAN为200,语音服务器地址为192.168.3.3。

[CoreSwitch-dhcp-pool-vlan100] voice-config ncp-ip 192.168.3.3

[CoreSwitch-dhcp-pool-vlan100] voice-config voice-vlan 200 enable

[CoreSwitch-dhcp-pool-vlan100] quit

# 配置Vlan-interface100接口工作在全局地址池模式。

[CoreSwitch] interface Vlan-interface 100

[CoreSwitch-Vlan-interface100] dhcp select global

[CoreSwitch-Vlan-interface100] quit

# 创建VLAN200和VLAN400的接口地址池,为办公区和会议室二的IP电话分配IP地址。

[CoreSwitch] interface Vlan-interface 200

[CoreSwitch-Vlan-interface200] dhcp select interface

[CoreSwitch-Vlan-interface200] quit

[CoreSwitch] interface Vlan-interface 400

[CoreSwitch-Vlan-interface400] dhcp select interface

&  说明:

有关DHCP配置的详细介绍,请参见S3600系列以太网交换机的操作、命令手册。

 

经过以上配置,CoreSwitch不但能够为VLAN200和VLAN400内的IP电话分配IP地址、Voice VLAN编号和语音服务器地址等内容,同时可以对语音报文进行三层转发。必要时可以在CoreSwitch上配置相应的动态路由协议,这里不进行具体描述。

3. 配置说明

经过上述配置,各区域内的IP电话已经可以与语音服务器建立连接,获取电话号码,进行正常通信。语音服务器上的配置请参见H3C XE语音服务器的用户手册。

建议用户在SwitchA和SwitchB上配置DHCP-Snooping功能以及一些相关的安全功能,保证只有从Core Switch自动获取IP地址的合法电话才能够进行通信,避免恶意用户侦听电话内容。

 


第3章  相关资料

3.1  相关协议和标准

IEEE 802.1Q Virtual Bridged Local Area Networks

 

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们