H3C低端以太网交换机典型配置案例(V1.04)

01-DHCP典型配置案例

本章节下载  (380.39 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S5600/S5600/Configure/Typical_Configuration_Example/S5600_Typical_Configuration_Example(V1.04)/200809/615968_30005_0.htm

01-DHCP典型配置案例


DHCP典型配置举例

关键词:DHCP,Option82

摘  要:本文主要介绍以太网交换机的DHCP功能在具体组网中的应用配置,根据设备在网络中担当的不同角色,分别介绍DHCP Server、DHCP Relay、DHCP Snooping功能,以及DHCP Option82的功能及应用。

缩略语:DHCP(Dynamic Host Configuration Protocol,动态主机配置协议)

 


第1章  DHCP功能介绍

1.1  支持能力

1.1.1  H3C低端交换机支持的DHCP功能列表

表1-1 H3C低端交换机支持的DHCP功能列表

功能

产品型号

DHCP Server

DHCP Relay

DHCP Snooping

S3600-EI

l

l

l

S3600-SI

-

l

l

S5600

l

l

l

S5100

-

-

l

S3100-SI

-

-

l

S3100-52P

-

-

l

E352/E328

-

l

l

E126

-

-

l

E152

-

-

l

 

H3C低端以太网交换机根据设备型号的不同,可以支持以下部分或全部DHCP功能。

DHCP Server:

l              支持使用全局地址池/接口地址池的DHCP Server

l              支持配置IP地址租期

l              支持为DHCP客户端分配网关地址、DNS服务器地址、WINS服务器地址

l              支持对特殊地址进行静态绑定

l              支持DHCP Server安全功能:伪DHCP Server检测、IP重复分配检测

DHCP Relay:

l              支持DHCP Relay

l              支持DHCP Relay安全功能:地址匹配检查、服务器端握手功能、用户地址表项定时刷新功能

l              支持DHCP Option82

DHCP Snooping:

l              支持DHCP Snooping

l              支持DHCP Snooping安全功能:DHCP Snooping表项更新、ARP源检查

l              支持DHCP Option82

&  说明:

有关各款交换机支持的DHCP功能的详细介绍,请参见各产品的用户手册。

 

1.2  配置指南

&  说明:

l      不同型号的设备,配置的方法会有差异,这里以S3600系列交换机作为举例。其它型号交换机的配置请参见产品的操作手册。

l      下文只列出了基本的配置步骤,有关各个功能的基本原理和作用,请参见各产品的操作、命令手册。

 

1.2.1  DHCP Server配置

对于DHCP Server设备,可以使用全局地址池和接口地址池进行地址分配。这两种配置方法的适用情况是:

l              如果DHCP Client和DHCP Server在同一网段,这两种配置方法都适用;

l              如果DHCP Client 与DHCP Server不在同一网段,那么只能用基于全局地址池的DHCP Server配置。

(1)        使用全局地址池分配地址的配置过程:

表1-2 使用全局地址池分配地址的配置过程

操作

命令

说明

进入系统视图

system-view

-

使能DHCP服务

dhcp enable

可选

缺省情况下,DHCP服务处于使能状态

创建DHCP地址池并进入DHCP地址池视图

dhcp server ip-pool pool-name

必选

缺省情况下,没有创建DHCP全局地址池

配置动态分配的IP地址范围

network ip-address [ mask-length | mask mask ]

必选

缺省情况下,没有配置动态分配的IP地址范围,即没有可供分配的地址

配置动态分配的IP地址租用有效期限

expired { day day [ hour hour [ minute minute ] ] | unlimited }

可选

缺省情况下,IP地址租用有效期限为1天

配置为DHCP客户端分配的域名

domain-name domain-name

必选

缺省情况下,没有配置为DHCP客户端分配的域名

配置为DHCP客户端分配的DNS服务器地址

dns-list ip-address&<1-8>

必选

缺省情况下,没有配置DNS服务器地址

配置为DHCP客户端分配的WINS服务器地址

nbns-list ip-address&<1-8>

必选

缺省情况下,没有配置WINS服务器地址

配置DHCP客户端的NetBIOS节点类型

netbios-type { b-node | h-node | m-node | p-node }

可选

缺省情况下,交换机不指定DHCP客户端的NetBIOS节点类型,客户端采用h类节点(h-node

配置为DHCP客户端分配的网关地址

gateway-list ip-address&<1-8>

必选

缺省情况下,没有配置DHCP客户端的网关地址

配置DHCP自定义选项

option code { ascii ascii-string | hex hex-string&<1-10> | ip-address ip-address&<1-8> }

必选

缺省情况下,没有配置DHCP自定义选项

配置静态绑定的IP地址

退出至系统视图

quit

可选

缺省情况下,没有配置静态绑定的MAC地址或客户端ID

需要注意的是:

l      配置绑定的IP地址必须与绑定的MAC地址或客户端ID二者之一共同配置才能生效

l      一个静态绑定地址池中只能配置一对IP地址与MAC/客户端ID的绑定关系

创建静态绑定的地址池

dhcp server ip-pool pool-name

配置静态绑定的IP地址

static-bind ip-address ip-address [ mask-length | mask mask ]

配置静态绑定的MAC地址或客户端ID

配置静态绑定的客户端MAC地址

static-bind mac-address mac-address

配置静态绑定的客户端ID

static-bind client-identifier client-identifier

退回至系统视图

quit

-

配置DHCP地址池中不参与自动分配的IP地址

dhcp server forbidden-ip low-ip-address [ high-ip-address ]

可选

缺省情况下,DHCP地址池中的所有IP地址都参与自动分配

配置接口工作在全局地址池模式

配置当前接口

interface interface-type interface-number

可选

缺省情况下,接口工作在DHCP服务器全局地址池模式

dhcp select global

quit

系统视图下同时配置多个接口

dhcp select global { interface interface-type interface-number [ to interface-type interface-number ] | all }

使能伪DHCP服务器检测功能

dhcp server detect

必选

缺省情况下,禁止伪DHCP服务器检测功能

配置IP地址重复分配检测功能

配置DHCP服务器ping操作的次数

dhcp server ping packets number

可选

缺省情况下,ping操作的次数为2

配置DHCP服务器等待响应的时间

dhcp server ping timeout milliseconds

可选

缺省情况下,等待ping响应的最长时间为500毫秒

配置DHCP服务器支持Option 82功能

dhcp server relay information enable

可选

缺省情况下,DHCP服务器支持Option 82功能

 

(2)        使用接口地址池分配地址的配置过程:

表1-3 使用接口地址池分配地址的配置过程

操作

命令

说明

进入系统视图

system-view

-

使能DHCP服务

dhcp enable

可选

缺省情况下,DHCP服务处于使能状态

同时配置多个VLAN接口工作在接口地址池模式

dhcp select interface { interface interface-type interface-number [ to interface-type interface-number ] | all }

可选

配置单个VLAN接口工作在接口地址池模式

interface interface-type interface-number

必选

缺省情况下,VLAN接口工作在全局地址池模式

dhcp select interface

配置静态绑定的IP地址

dhcp server static-bind ip-address ip-address { client-identifier client-identifier | mac-address mac-address }

可选

缺省情况下,没有配置静态绑定

配置动态分配的IP地址租用有效期限

配置当前接口

dhcp server expired { day day [ hour hour [ minute minute ] ] | unlimited }

可选

缺省情况下,IP地址租用有效期限为1天

系统视图下配置多个接口

quit

dhcp server expired { day day [ hour hour [ minute minute ] ] | unlimited } { interface interface-type interface-number [ to interface-type interface-number ] | all }

退出至系统视图

quit

-

配置DHCP地址池中不参与自动分配的IP地址

dhcp server forbidden-ip low-ip-address [ high-ip-address ]

可选

缺省情况下,接口地址池中的所有IP地址都参与自动分配

配置为DHCP客户端分配的域名

配置单个接口

interface interface-type interface-number

可选

缺省情况下,没有配置为DHCP客户端分配的域名

dhcp server domain-name domain-name

quit

配置多个接口

dhcp server domain-name domain-name { interface interface-type interface-number [ to interface-type interface-number ] | all }

配置为DHCP客户端分配的DNS服务器地址

配置单个接口

interface interface-type interface-number

可选

缺省情况下,没有配置DNS服务器的地址

dhcp server dns-list ip-address&<1-8>

quit

配置多个接口

dhcp server dns-list ip-address&<1-8> { interface interface-type interface-number [ to interface-type interface-number ] | all }

配置为DHCP客户端分配的WINS服务器地址

配置单个接口

interface interface-type interface-number

可选

缺省情况下,没有配置WINS服务器的IP地址

dhcp server nbns-list ip-address&<1-8>

quit

配置多个接口

dhcp server nbns-list ip-address&<1-8> { interface interface-type interface-number [ to interface-type interface-number ] | all }

配置DHCP客户端的NetBIOS节点类型

配置单个接口

interface interface-type interface-number

可选

缺省情况下,交换机不指定接口DHCP地址池的客户端NetBIOS节点类型,客户端采用h类节点(h-node

dhcp server netbios-type { b-node | h-node | m-node | p-node }

quit

配置多个接口

dhcp server netbios-type { b-node | h-node | m-node | p-node } { interface interface-type interface-number [ to interface-type interface-number ] | all }

配置DHCP自定义选项

配置单个接口

interface interface-type interface-number

可选

缺省情况下,没有配置DHCP自定义选项

dhcp server option code { ascii ascii-string | hex hex-string&<1-10> | ip-address ip-address&<1-8> }

quit

配置多个接口

dhcp server option code { ascii ascii-string | hex hex-string&<1-10> | ip-address ip-address&<1-8> } { interface interface-type interface-number [ to interface-type interface-number ] | all }

配置伪DHCP服务器检测功能

dhcp server detect

可选

缺省情况下,禁止伪DHCP服务器检测功能

配置IP地址重复分配检测功能

配置DHCP服务器ping操作的次数

dhcp server ping packets number

可选

缺省情况下,ping操作的次数为2

配置DHCP服务器等待响应的时间

dhcp server ping timeout milliseconds

可选

缺省情况下,等待ping响应的最长时间为500毫秒

配置DHCP服务器支持Option 82功能

dhcp server relay information enable

可选

缺省情况下,DHCP服务器支持Option 82功能

 

1.2.2  DHCP Relay配置

对工作在DHCP Relay模式下的交换机,需要进行以下的配置。

表1-4 DHCP Relay配置

操作

命令

说明

进入系统视图

system-view

-

使能DHCP服务

dhcp enable

可选

缺省情况下,DHCP服务处于使能状态

配置DHCP服务器组中DHCP服务器的地址

dhcp-server groupNo ip ip-address&<1-8>

必选

缺省情况下,没有配置DHCP服务器组中的服务器的IP地址

配置DHCP用户地址表项

dhcp-security static ip-address mac-address

可选

缺省情况下,没有配置DHCP用户地址表项

使能DHCP Relay握手功能

dhcp relay hand enable

可选

缺省情况下,交换机上DHCP Relay握手功能处于使能状态

配置DHCP中继动态用户地址表项的定时刷新周期

dhcp-security tracker { interval | auto }

可选

缺省情况下,根据表项的数目自动计算握手时间间隔。

使能伪DHCP服务器检测功能

dhcp-server detect

必选

缺省情况下,禁止伪DHCP服务器检测功能

配置DHCP中继支持option 82功能

dhcp relay information enable

必选

缺省情况下,DHCP中继不支持option 82功能

配置DHCP中继对包含option 82的请求报文的处理策略

dhcp relay information strategy { drop | keep | replace }

可选

缺省情况下,处理策略为replace

进入VLAN接口视图

interface interface-type interface-number

-

配置接口与DHCP服务器组的归属关系

dhcp-server groupNo

必选

缺省情况下,VLAN接口没有与任何一个DHCP服务器组建立归属关系

使能DHCP中继的地址匹配检查功能

address-check enable

必选

缺省情况,禁止DHCP中继的地址匹配检查功能

 

1.2.3  DHCP Snooping配置

对工作在DHCP Snooping模式下的设备,需要做以下的配置。

表1-5 DHCP Snooping配置

操作

命令

说明

进入系统视图

system-view

-

开启交换机DHCP-Snooping功能

dhcp-snooping

必选

缺省情况下,以太网交换机的DHCP-Snooping功能处于禁止状态

进入以太网端口视图

interface interface-type interface-number

-

指定连接到DHCP服务器方向的端口为信任端口

dhcp-snooping trust

可选

缺省情况下,交换机的端口均为不信任端口

 


第2章  配置举例

2.1  DHCP Server配置举例

2.1.1  组网需求

位于公司总部(HQ)的S3600交换机作为DHCP Server,为总部机构及分支机构(Branch)的工作站分配IP地址,并作为网关转发总部设备的报文,具体需求如下:

l              为总部机构分配10.214.10.0/24网段的IP地址,有效期为2天,其中DNS Server、WINS Server和Mail Server的IP地址设置为不可分配地址。

l              使用静态绑定方式为总部的DNS/WINS/Mail Server分配IP地址。

l              为分支机构分配10.210.10.0/24网段的地址,有效期为3天,其中分支机构的文件服务器使用IP与MAC绑定的方式静态分配。

l              为总部和分支机构的工作站在分配地址时同时分配网关地址、DNS Server地址、WINS Server地址。

l              启用伪DHCP Server检测功能,避免私自架设的DHCP Server分配无效地址。

2.1.2  组网图

图2-1 DHCP Server配置举例组网示例图

2.1.3  配置步骤

1. 使用的版本

本举例中使用的设备为S3600系列以太网交换机,软件版本为Release 1510。

2. 配置DHCP Server

l              配置为总部设备分配地址

# 配置总部DHCP Server的Vlan-interface10接口的IP地址。

<H3C> system-view

[H3C] interface Vlan-interface 10

[H3C-Vlan-interface10] ip address 10.214.10.1 24

# 配置该接口工作在接口地址池模式下,为总部设备分配10.214.10.0/24网段的IP地址。

[H3C-Vlan-interface10] dhcp select interface

# 配置该地址池的有效期,并配置指定的DNS、WINS服务器。

[H3C-Vlan-interface10] dhcp server expired day 2  

[H3C-Vlan-interface10] dhcp server dns-list 10.214.10.3

[H3C-Vlan-interface10] dhcp server nbst-list 10.214.10.4

由于工作在接口地址池的接口会自动将自身作为DHCP客户端的网关,并把信息发送给客户端,因此无需进行客户端网关的配置操作。

# 使用IP地址与MAC地址绑定的方式为DNS/WINS/Mail Server分配IP地址。

[H3C-Vlan-interface10] dhcp server static-bind ip-address 10.214.10.3 mac-address 000d-85c7-4e20

[H3C-Vlan-interface10] dhcp server static-bind ip-address 10.214.10.4 mac-address 0013-4ca8-9b71

[H3C-Vlan-interface10] dhcp server static-bind ip-address 10.214.10.5 mac-address 002e08d20-54c6

# 配置DNS/WINS/Mail Server的静态IP地址为不可分配地址。

[H3C-Vlan-interface10] quit

[H3C] dhcp server forbidden-ip 10.214.10.3 10.214.10.5

l              配置为分支机构分配地址

# 为分支机构创建名为“br”的全局地址池,并指定可分配的地址范围及有效期。

[H3C] dhcp server ip-pool br

[H3C-dhcp-pool-br] network 10.210.10.0 mask 255.255.255.0

[H3C-dhcp-pool-br] expired day 3  

# 创建静态绑定地址池名为“br-static”,将分支机构的文件服务器的IP地址配置为与MAC地址静态绑定分配方式。

[H3C-dhcp-pool-br] quit

[H3C] dhcp server ip-pool br-static

[H3C-dhcp-pool-br-static] static-bind ip-address 10.214.10.4 mask 255.255.255.0

[H3C-dhcp-pool-br-static] static-bind mac-address 000d-88f8-4e71

# 为分支机构工作站指定网关、DNS、WINS服务器。

[H3C-dhcp-pool-br-static] quit

[H3C] dhcp server ip-pool br

[H3C-dhcp-pool-br] gateway-list 10.210.10.1

[H3C-dhcp-pool-br] dns-list 10.214.10.3

[H3C-dhcp-pool-br] nbst-list 10.214.10.4

# 配置分支机构的Gateway的静态IP为不可分配地址。

[H3C-dhcp-pool-br] quit

[H3C] dhcp server forbidden-ip 10.210.10.1

# 配置伪DHCP Server检测功能。

[H3C] dhcp server detect

# 配置Vlan-interface100接口工作在全局地址池模式。

[H3C] interface Vlan-interface 100

[H3C-Vlan-interface100] dhcp select global

需要注意的是:

在完成DHCP配置后,总部到分支机构必须具备可达的路由,才能够为其分配IP地址。

3. 配置DHCP Relay

本节主要介绍DHCP Server的配置,对于举例中的DHCP Relay设备配置,只进行最简单的介绍,保证其可以将DHCP请求转发至DHCP Server。有关DHCP Relay的更多具体功能配置,请参见2.2  DHCP Relay/Snooping综合配置举例的介绍。

<H3C> system-view

[H3C] dhcp-server 1 ip 10.214.10.1

[H3C] interface Vlan-interface 5

[H3C-Vlan-interface5] dhcp-server 1

2.2  DHCP Relay/Snooping综合配置举例

2.2.1  组网需求

位于总部的Cisco Catalyst 3745交换机作为DHCP Server为分支机构的办公区域工作站分配IP地址,分支机构采用IRF架构作为中心结点,并作为DHCP Relay转发工作站的DHCP请求。同时分支机构采用自己的DHCP Server为实验室设备分配独立IP网段的地址。具体需求如下:

l              总部的DHCP Server为办公室设备分配192.168.10.0/24网段的地址,有效期为12小时,并指定该地址池的DNS和WINS服务器分别为192.169.100.2和192.168.100.3。

l              分支机构的IRF由四台设备构成,作为DHCP Relay转发办公室工作站和实验室设备的DHCP请求,并配置伪DHCP Server检测功能。

l              Lab1内有一台以太网交换机作为Lab DHCP Server,为Lab1的设备分配192.168.17.0/24网段的地址,有效期1天;为Lab2的设备分配192.168.19.0/24网段的地址,有效期2天。Lab DHCP Server与IRF架构使用172.16.2.4/30网段进行互连。

l              配置DHCP Relay的地址检查功能,使通过DHCP Server获得合法IP地址的设备才可以访问外部网络。

l              配置DHCP Relay表项定时刷新功能,每隔1分钟向DHCP Server进行地址表项刷新。

l              配置DHCP Snooping支持DHCP Option82,将本地的端口信息添加到DHCP报文的Option82字段中。

l              配置DHCP Relay设备支持DHCP Option82,Relay在接收到携带有DHCP Option82选项的DHCP报文时,保留原有字段不作替换。

l              配置DHCP Server支持DHCP Option82,为Snooping设备端口Ethernet0/11接入的客户端分配192.168.10.2~192.168.10.25之间的地址,为Ethernet0/12端口接入的客户端分配192.168.10.100~192.168.10.150之间的地址。

2.2.2  组网图

图2-2 DHCP Relay/Snooping 综合配置举例组网示意图

2.2.3  配置步骤

本举例中IRF架构中的设备为S3600,软件版本为Release 1510;DHCP Snooping设备使用Quidway S3552设备,软件版本为Release 0028;Lab DHCP Server为Quidway S3528设备,软件版本为Release 0028。

为方便阅读,下文配置中的各设备名称分别为:

l              IRF中的设备分别为SwitchA、SwitchB、SwitchC、SwitchD

l              DHCP Snooping设备的名称为“Snooping”

l              Lab DHCP Server设备的名称为“LAB”

1. 配置IRF

S3600支持IRF特性,可以将四台设备互连成为一个Fabric,用户可以对Fabric中的设备进行集中管理。详细介绍及配置过程请见S3600系列以太网交换机操作手册中的介绍。

2. 配置DHCP Relay

图2-3 DHCP Relay组网

IRF内的设备可以实现配置互相同步的功能,因此这里只在SwitchA上进行配置。

# 配置将办公室内的DHCP请求报文转发至HQ的DHCP Server。

<SwitchA> system-view

[SwitchA] dhcp-server 1 ip 192.168.0.3

[SwitchA] interface Vlan-interface10

[SwitchA-Vlan-interface10] ip address 192.168.10.1 24

[SwitchA-Vlan-interface10] dhcp-server 1

# 配置将Lab2内的DHCP请求报文转发至Lab DHCP Server。

[SwitchA-Vlan-interface10] quit

[SwitchA] dhcp-server 2 ip 192.168.17.1

[SwitchA] interface Vlan-interface 25

[SwitchA-Vlan-interface25] ip address 192.168.19.1 24

[SwitchA-Vlan-interface25] dhcp-server 2

# 配置Vlan-interface17的接口地址为172.16.2.5/30,用于与Lab DHCP Server转发跨网段的DHCP报文。

[SwitchA-Vlan-interface25] quit

[SwitchA] interface Vlan-interface 17

[SwitchA-Vlan-interface17] ip add 172.16.2.5 30

# 配置DHCP Relay的地址检查功能,这里注意要将DHCP Server的IP地址和MAC地址作为静态表项配置到安全功能中。

[SwitchA-Vlan-interface17] quit

[SwitchA] dhcp-security static 192.168.0.3 000D-88F8-4E71

[SwitchA] dhcp-security static 192.168.17.1 0010-5ce9-1dea

[SwitchA] interface Vlan-interface 10

[SwitchA-Vlan-interface10] address-check enable

[SwitchA-Vlan-interface10] quit

[SwitchA] interface Vlan-interface 25

[SwitchA-Vlan-interface25] address-check enable

[SwitchA-Vlan-interface25] quit

# 配置DHCP Relay的地址表项定时刷新功能。

[SwitchA] dhcp relay hand enable

[SwitchA] dhcp-security tracker 60

# 配置DHCP Relay支持DHCP Option82,并在收到带有Option82内容的DHCP报文时采取保留原字段的策略。

[SwitchA] dhcp relay information enable

[SwitchA] dhcp relay information strategy keep

# 配置DHCP Relay的伪DHCP Server检测功能

[SwitchA] dhcp-server detect

# 启动UDP-Helper功能,使IRF能够正常工作在DHCP Relay模式。

[SwitchA] udp-helper enable

# 为保证跨网段的DHCP报文能够正确转发,需要配置路由协议,并将本设备的接口网段进行发布。这里以RIP为例。其他路由协议的配置方法请参考产品手册的路由协议部分。

[SwitchA] rip

[SwitchA-rip] network 192.168.10.0

[SwitchA-rip] network 192.168.19.0

[SwitchA-rip] network 172.16.0.0

&  说明:

在使用IRF构架的DHCP Relay与总部的DHCP Server之间,通过IP网络进行互联,也需要保证报文路由可达,这部分配置由运营商或用户进行操作,这里不进行介绍。

 

3. 配置Lab DHCP Server

图2-4 Lab DHCP Server组网

# 配置Lab2的地址池,并配置地址范围、有效期,网关地址。

<LAB> system-view

[LAB] dhcp enable

[LAB] dhcp server ip-pool lab2

[LAB-dhcp-lab2] network 192.168.19.0 255.255.255.0

[LAB-dhcp-lab2] expired day 2

[LAB-dhcp-lab2] gateway-list 192.168.19.1

# 配置Vlan-interface17的IP地址为172.16.2.6/30,并使其工作在全局地址池模式

[LAB-dhcp-lab2] quit

[LAB] interface Vlan-interface 17

[LAB-Vlan-interface17] ip address 172.16.2.6 30

[LAB-Vlan-interface17] dhcp select global

# 由于Lab1连接到Vlan-interface15接口,因此,只需要配置Vlan-interface15接口工作在接口地址池模式,即可为Lab1的设备分配192.168.17.0/24网段的地址。

[LAB-Vlan-interface17] quit

[LAB] interface Vlan-interface 15

[LAB-Vlan-interface15] ip address 192.168.17.1 24

[LAB-Vlan-interface15] dhcp select interface

[LAB-Vlan-interface15] quit

# 为保证该服务器能够正常转发DHCP报文,需要配置路由协议,参照Relay的配置,这里以RIP为例。其他路由协议的配置方法请参考产品手册中的描述。

[LAB] rip

[LAB-rip] network 192.168.17.0

[LAB-rip] network 172.16.0.0

4. 配置DHCP Snooping

图2-5 DHCP Snooping组网

# 启动DHCP Snooping功能,并配置DHCP-Snooping支持Option 82功能。(S3552设备在开启Option82功能的同时,需要同时开启DHCP报文重定向功能)

<Snooping> system-view

[Snooping] dhcp-snooping

[Snooping] dhcp-snooping information enable

[Snooping] dhcp-packet redirect Ethernet 0/11 to 0/13

5. 配置HQ DHCP Server。

# H3C系列产品在DHCP Option82选项中添加端口编号、VLAN编号和Snooping/Relay设备MAC地址。一条完整的Option82信息由两个子选项的数值组合构成:

Circuit ID子选项,这里主要标识客户端所在的VLAN和接入DHCP-Snooping设备的端口编号。

图2-6 Circuit ID子选项报文结构

例如,由端口Ethernet0/11接入的客户端,增加了Option82信息的DHCP报文中Circuit ID子选项信息应为:0x0106000400010010,其中01060004为固定取值,0001标识接入的端口所在VLAN为VLAN1,0010为端口的绝对编号,比实际端口编号小1,即实际连接端口为Ethernet0/11。

Remote ID子选项,这里主要标识客户端接入的DHCP-Snooping设备的MAC地址。

图2-7 Remote ID子选项报文结构

例如,由MAC地址为000f-e234-bc66的DHCP-Snooping设备接入的DHCP客户端,增加了Option82信息的DHCP报文中Remote ID子选项信息应为:02080006000fe234bc66,其中02080006为固定取值,000fe234bc66为DHCP-Snooping设备的MAC地址。

本举例中只需根据端口编号进行IP地址的分配,因此,在DHCP Server上只需对Circuit ID子选项中标识端口编号的字段进行匹配即可。

&  说明:

下面列举的是Cisco Catalyst 3745设备上的配置,对应的软件版本为IOS 12.3(11)T2版本,如果使用其他型号或其他版本的设备,请参考随机资料中的用户手册进行操作。

 

# 配置DHCP Server功能,并配置使用Option82信息进行地址分配。

Switch> enable

Switch(config)# configure terminal

Enter Configuration commands, one per line. End with CNTL/Z.

Switch(config)# service dhcp

Switch(config)# ip dhcp use class

# 为从Snooping设备的Ethernet0/11端口接入的客户端建立DHCP分类,并配置匹配的Option82信息为Circuit ID 子选中的端口编号,无需匹配的内容可以使用通配符“*”代替。

Switch(config)# ip dhcp class office1

Switch(dhcp-class)# relay agent information hex 0106000400010010*

Swtich(dhcp-class)# exit

# 为从Snooping设备的Etherent0/12端口接入的客户端配置分类和匹配信息,方法与上面命令相似,只将Option82信息中的端口标识由10改为11。

Switch(config)# ip dhcp class office2

Switch(dhcp-class)# relay agent information hex 0106000400010011*

# 创建Office地址池,并为两个DHCP分类分别指定地址范围。

Switch(config)# ip dhcp pool office

Switch(dhcp-pool)# network 192.168.10.0

Switch(dhcp-pool)# class office1

Switch(dhcp-pool-class)# address range 192.168.10.2 192.168.10.25

Switch(dhcp-pool-class)# exit

Switch(dhcp-pool)# class office2

Switch(dhcp-pool-class)# address range 192.168.10.100 192.168.10.150

Switch(dhcp-pool-class)# exit

# 为DHCP地址池配置租约期限,网关、DNS和WINS服务器地址。

Switch(dhcp-pool)# lease 0 12

Switch(dhcp-pool)# default-router 192.168.10.1

Switch(dhcp-pool)# dns-server 192.168.100.2

Switch(dhcp-pool)# netbios-name-server 192.168.100.3

经过上述配置后,DHCP服务器即可为Office区域的设备自动分配IP地址及网关、DNS、WINS服务器地址。

2.3  注意事项

2.3.1  DHCP Relay与IRF的配合

l              在IRF(Intelligent Resilient Framework,可扩展弹性网络)系统中,DHCP Relay同时运行在Fabric系统内的所有Unit上,但只有运行在Master上的DHCP Relay能够收发报文,完成全部DHCP Relay的功能,而运行在Slave上的DHCP Relay只是作为运行在Master上的任务的备份。

l              DHCP协议是基于UDP的应用层协议,作为Slave的Unit收到DHCP请求报文后,UDP-Helper会将报文重定向到Master Unit上,由Master上的DHCP Relay响应此请求并将需要备份的信息实时发送到各个Slave Unit上。这样当Master Unit出现故障时,由Slave变为Master的Unit能够马上承担起DHCP Relay的角色。因此,在IRF系统中使用DHCP Server/Relay时,一定要注意先使能UDP-Helper功能。

 


第3章  相关资料

3.1  相关协议和标准

l              RFC2131:Dynamic Host Configuration Protocol

l              RFC2132:DHCP Options and BOOTP Vendor Extensions

l              RFC3046:DHCP Relay Agent Information Option

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们