选择区域语言: EN CN HK

H3C WA系列Fat AP典型配置案例集-6W104

04-H3C WA系列PPPoE Client配置举例

本章节下载  (136.75 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Configure/Typical_Configuration_Example/H3C_WA_Fat_AP-6W104/201909/1225111_30005_0.htm

04-H3C WA系列PPPoE Client配置举例

H3C WA系列 PPPoE Client配置举例

关键词:PPPoE,PPPoE Client,AP

摘   要:PPPoE是Point-to-Point Protocol over Ethernet的简称,它可以通过一个远端接入设备为以太网上的主机提供因特网接入服务,并对接入的每个主机实现控制、计费功能。由于很好地结合了以太网的经济性及PPP良好的可扩展性与管理控制功能,PPPoE在包括小区组网建设等一系列应用中被广泛采用。

缩略语:

缩略语

英文全名

中文解释

ADSL

Asymmetric Digital Subscriber Line

不对称数字用户线

AP

Access Point

无线接入点

PPP

Point-to-Point Protocol

点对点协议

PPPoE

Point-to-Point Protocol over Ethernet

以太网上承载PPP协议

 



1 特性简介

PPPoE是Point-to-Point Protocol over Ethernet的简称,它可以通过一个远端接入设备为以太网上的主机提供因特网接入服务,并对接入的每个主机实现控制、计费功能。由于很好地结合了以太网的经济性及PPP良好的可扩展性与管理控制功能,PPPoE在包括小区组网建设等一系列应用中被广泛采用。

PPPoE协议采用Client/Server方式,将PPP报文封装在以太网帧之内,在以太网上提供点对点的连接。

2 应用场合

PPPoE在ADSL宽带接入中被广泛使用。通常情况下,一台主机如果要通过ADSL接入Internet,必须在主机上安装PPPoE客户端拨号软件。设备AP实现了PPPoE Client功能(即PPPoE的客户端拨号功能),用户可以不用在Host上安装PPPoE客户端软件即可接入Internet。

3 配置举例

3.1  组网需求

本配置举例中的AP使用的是WA2200X-AG无线局域网接入点。

 

Router的Ethernet 0/1接口连接IP网络,AP的Ethernet 1/0/1通过Modem连接到PSTN网络,DSLAM连接PSTN网络与IP网络。要求Router用PAP、CHAP两种方式验证AP。使AP作为PPPoE客户端连接上PPPoE Server。假设整个网络所使用的IP地址都处于同一网段。

图3-1 PPPoE Client配置举例组网图

 

3.2  配置思路

PPPoE Client的配置包括配置拨号接口和配置PPPoE会话。

在配置PPPoE会话之前,需要先配置一个Dialer接口,并在接口上配置Dialer bundle。每个PPPoE会话唯一对应一个Dialer bundle,而每个Dialer bundle又唯一对应一个Dialer接口。这样就相当于通过一个Dialer接口可以创建一个PPPoE会话。

PPPoE的认证方式有两种:PAP和CHAP。下文的配置步骤会对这两种情况分开说明。

3.3  使用版本

3.3.1  Router版本

<Router>display version

Huawei Versatile Routing Platform Software

VRP Software, Version 5.20, Beta 1505L01, Standard

Copyright (c) 1998-2007 Huawei Tech. Co., Ltd. All rights reserved.

Quidway AR19-61 uptime is 0 week, 0 day, 0 hour, 43 minutes

Last reboot 2008/04/21 09:57:02

System returned to ROM By Power-up.

 

CPU type: FREESCALE PowerPC 8248 400MHz

384M bytes SDRAM Memory

4M bytes Flash Memory

Pcb               Version:  3.0

Logic             Version:130.0

Basic    BootROM  Version:  2.11

Extended BootROM  Version:  2.11

[SLOT  0]CON            (Hardware)3.0,   (Driver)1.0,    (Cpld)130.0

[SLOT  0]AUX            (Hardware)3.0,   (Driver)1.0,    (Cpld)130.0

[SLOT  0]ETH0/0         (Hardware)3.0,   (Driver)1.0,    (Cpld)130.0

[SLOT  0]ETH0/1         (Hardware)3.0,   (Driver)1.0,    (Cpld)130.0  

3.3.2  AP版本

<AP> display version

H3C Comware Platform Software

Comware Software, Version 5.00, 0001

Copyright (c) 2004-2007 Hangzhou H3C Tech. Co., Ltd. All rights reserved.

WA2200X-AG uptime is 0 week, 0 day, 3 hours, 45 minutes

 

 CPU type: AMCC PowerPC 266MHz

 64M bytes SDRAM Memory

 8M bytes Flash Memory

 Pcb             Version:  Ver.A

 Basic  BootROM  Version:  1.00

 Extend BootROM  Version:  1.01

 [SLOT  1]CON           (Hardware)Ver.A, (Driver)1.0

 [SLOT  1]RADIO1/0/1    (Hardware)Ver.N/A,       (Driver)1.0

 [SLOT  1]RADIO1/0/2    (Hardware)Ver.N/A,       (Driver)1.0

 [SLOT  1]ETH1/0/1      (Hardware)Ver.A, (Driver)1.0

 [SLOT  1]ETH1/0/2      (Hardware)Ver.A, (Driver)1.0

3.4  配置步骤

3.4.1  配置Router

1. 配置信息

方案一:PAP认证

[Router]display  current-configuration

……

local-user user2

 password simple hello

 service-type ppp

……

interface Ethernet0/1

 port link-mode route

 pppoe-server bind Virtual-Template 1

#

interface Virtual-Template1

 ppp authentication-mode pap

 remote address 1.1.1.2

 ip address 1.1.1.1 255.0.0.0

#

……            

2. 主要配置步骤

方案一:PAP认证

(1)        增加一个PPPoE用户。

<Router> system-view

# 添加名称为user2的本地用户。

[Router] local-user user2

# 设置名称为user2的密码为明文显示,密码为hello。

[Router-luser-user2] password simple hello

# 指定用户可以使用PPP服务。

[Router-luser-user2] service-type ppp

[Router-luser-user2] quit

(2)        配置虚拟模板参数。

# 创建虚拟接口模板1。

[Router] interface virtual-template 1

# 采用PAP方法验证对端设备。

[Router-Virtual-Template1] ppp authentication-mode pap

# 配置本端的IP地址为1.1.1.1/8。

[Router-Virtual-Template1] ip address 1.1.1.1 255.0.0.0

# 配置为对端分配的IP地址为1.1.1.2。

[Router-Virtual-Template1] remote address 1.1.1.2

[Router-Virtual-Template1] quit

(3)        配置PPPoE Server。

[Router] interface ethernet 0/1

# 在接口Ethernet0/1上使能PPPoE,将接口Ethernet0/1与虚拟模板接口Virtual-Template1绑定。

[Router-Ethernet0/1] pppoe-server bind virtual-template 1

方案二:CHAP认证

(4)        增加一个PPPoE用户。

<Router> system-view

# 添加名称为user2的本地用户。

[Router] local-user user2

# 设置名称为user2的密码为明文显示,密码为hello。

[Router-luser-user2] password simple hello

# 指定用户可以使用PPP服务。

[Router-luser-user2] service-type ppp

[Router-luser-user2] quit

(5)        配置虚拟模板参数。

# 创建虚拟接口模板1。

[Router] interface virtual-template 1

# 采用CHAP方法验证对端设备。

[Router-Virtual-Template1] ppp authentication-mode chap

# 配置进行CHAP验证时的用户名为user1。

[Router-Virtual-Template1] ppp chap user user1

# 配置本端的IP地址为1.1.1.1/8。

[Router-Virtual-Template1] ip address 1.1.1.1 255.0.0.0

# 配置为对端分配的IP地址为1.1.1.2。

[Router-Virtual-Template1] remote address 1.1.1.2

[Router-Virtual-Template1] quit

(6)        配置PPPoE Server。

[Router] interface ethernet 0/1

# 在接口Ethernet0/1上使能PPPoE,将接口Ethernet0/1与虚拟模板接口Virtual-Template1绑定。

[Router-Ethernet0/1] pppoe-server bind virtual-template 1

[Router-Ethernet0/1] quit

3.4.2  配置AP

1. 配置信息

方案一:PAP认证

[AP]display current-configuration

……

interface Dialer1

 link-protocol ppp

 ppp pap local-user user2 password simple hello

 ip address ppp-negotiate

 dialer user user2

 dialer-group 1

 dialer bundle 1

#

interface Vlan-interface1

 pppoe-client dial-bundle-number 1

#

dialer-rule 1 ip permit

#

return

[AP]                   

方案二:CHAP认证

[AP]display current-configuration

……

local-user user1

#

……

interface Dialer1

 link-protocol ppp

 ppp chap user user2

 ip address ppp-negotiate

 dialer user user2

 dialer-group 1

 dialer bundle 1

#

interface NULL0

#

interface Vlan-interface1

 pppoe-client dial-bundle-number 1

#

interface Ethernet1/0/1

……  

2. 主要配置步骤

方案一:PAP认证

(1)        配置AP作为PPPoE Client

<AP> system-view

# 设置Dialer-rule1,允许IP协议报文通过。

[AP] dialer-rule 1 ip permit

# 创建一个Dialer接口1。

[AP] interface dialer 1

# 设置对端用户名为“user2”。

[AP-Dialer1] dialer user user2

# 将接口Dialer1置入Dialer Access Group 1。

[AP-Dialer1] dialer-group 1

# 在接口Dialer1上配置该接口使用Dialer bundle3。

[AP-Dialer1] dialer bundle 1

# 为接口Dialer1配置IP地址可协商属性。

[AP-Dialer1] ip address ppp-negotiate

# 配置本地设备被对端以PAP方式验证时发送的用户名为user2,口令为hello。

[AP-Dialer1] ppp pap local-user user2 password simple hello

[AP-Dialer1] quit

(2)        配置PPPoE会话。

[AP] interface Vlan-interface 1

# 建立一个PPPoE会话,并且指定该会话所对应的Dialer Bundle。

[AP-Vlan-interface1] pppoe-client dial-bundle-number 1

方案二:CHAP认证

(3)         配置AP作为PPPoE Client

<AP> system-view

# 设置Dialer-rule1,允许IP协议报文通过。

[AP] dialer-rule 1 ip permit

# 创建一个Dialer接口1。

[AP] interface dialer 1

# 设置对端用户名为“user2”。

[AP-Dialer1] dialer user user2

# 将接口Dialer1置入Dialer Access Group 1。

[AP-Dialer1] dialer-group 1

# 在接口Dialer1上配置该接口使用Dialer bundle1。

[AP-Dialer1] dialer bundle 1

# 为接口Dialer1配置IP地址可协商属性。

[AP-Dialer1] ip address ppp-negotiate

# 配置接口Dialer1进行CHAP验证时的用户名为user2。

[AP-Dialer1] ppp chap user user2

[AP-Dialer1] quit

# 添加名称为user2的本地用户,密码为明文密码hello

[AP] local-user user2

[AP-luser-user1] password simple hello

[AP-luser-user1] quit

(4)        配置PPPoE会话。

[AP] interface Vlan-interface 1

# 建立一个PPPoE会话,并且指定该会话所对应的Dialer Bundle。

[AP-Vlan-interface1] pppoe-client dial-bundle-number 1

3.5  验证结果

可以有两种方式来验证该配置的结果:

(1)        通过查看接口、看拨号接口是否UP、是否获取IP地址

[AP]display brief interface

The brief information of interface(s) under route mode:

Interface            Link      Protocol-link  Protocol type    Main IP

Dia1                 UP        UP             PPP              1.1.1.2

NULL0                UP        UP(spoofing)   NULL             --

Vlan1                UP        DOWN           ETHERNET         --

WLAN-Radio1/0/1      UP        UP             DOT11            --

WLAN-Radio1/0/2      UP        UP             DOT11            --

 

The brief information of interface(s) under bridge mode:

Interface            Link      Speed     Duplex   Link-type  PVID

Eth1/0/1             UP        100M(a)   full(a)  access     1

(2)        直接ping服务器端接口的IP地址,看能否ping通

[AP]ping 1.1.1.1

  PING 1.1.1.1: 56  data bytes, press CTRL_C to break

    Reply from 1.1.1.1: bytes=56 Sequence=1 ttl=255 time=3 ms

    Reply from 1.1.1.1: bytes=56 Sequence=2 ttl=255 time=3 ms

    Reply from 1.1.1.1: bytes=56 Sequence=3 ttl=255 time=3 ms

    Reply from 1.1.1.1: bytes=56 Sequence=4 ttl=255 time=3 ms

    Reply from 1.1.1.1: bytes=56 Sequence=5 ttl=255 time=3 ms

 

  --- 1.1.1.1 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 3/3/3 ms

4 相关资料

4.1  其它相关资料

l              《H3C WA系列无线局域网接入点设备 用户手册》“接入分册”中的“PPP”。

l              《H3C WA系列无线局域网接入点设备 用户手册》“安全分册”中的“AAA”。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!