选择区域语言: EN CN HK

07-MPLS配置指导

10-VPLS配置

本章节下载  (634.08 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500X-AF/Configure/Operation_Manual/H3C_S12500X-AF_CG(R320x)-6W100/07/201905/1181942_30005_0.htm

10-VPLS配置


1 VPLS

1.1  VPLS简介

VPLS(Virtual Private LAN Service,虚拟专用局域网服务)是在MPLS或IP骨干网上提供的一种点到多点的L2VPN业务。服务提供商通过在骨干网上为一个用户网络模拟一台连接多个异地站点的虚拟交换机来为用户网络提供VPLS服务。骨干网对于用户网络的站点来说是透明的,用户网络的各个站点就像工作在一个局域网中一样。

1.1.1  VPLS的基本架构

图1-1 VPLS基本架构示意图

 

VPLS的基本架构如图1-1所示,其中包括如下主要组成部分:

·            CE(Customer Edge,用户网络边缘)设备

直接与服务提供商网络相连的用户网络侧设备。

·            PE(Provider Edge,服务提供商网络边缘)设备

与CE相连的服务提供商网络侧设备。PE主要负责VPN业务的接入,完成报文从用户网络到公网隧道、从公网隧道到用户网络的映射与转发。在分层VPLS组网下,PE可以细分为UPE和NPE。

·            AC(Attachment Circuit,接入电路)

连接CE和PE的物理电路或虚拟电路,例如Ethernet接口、VLAN。

·            PW(Pseudowire,伪线)

两个PE之间的虚拟双向连接。MPLS PW由一对方向相反的单向LSP构成。

·            公网隧道(Tunnel)

穿越IP或MPLS骨干网、用来承载PW的隧道。一条公网隧道可以承载多条PW,公网隧道可以是LSP、MPLS TE、GRE隧道等。

·            VPLS实例

用户网络可能包括分布在不同地理位置的多个站点(如图1-1中的Site 1和Site 3)。在骨干网上可以利用VPLS技术将这些站点连接起来,为用户提供一个二层VPN。这个二层VPN称为一个VPLS实例。不同VPLS实例中的站点不能二层互通。

·            VSI(Virtual Switch Instance,虚拟交换实例)

VSI是PE设备上为一个VPLS实例提供二层交换服务的虚拟实例。VSI可以看做是PE设备上的一台虚拟交换机,它具有传统以太网交换机的所有功能,包括源MAC地址学习、MAC地址老化、泛洪等。VPLS通过VSI实现在VPLS实例内转发二层数据报文。

1.1.2  PW的创建

在VPLS网络中,PE之间需要建立PW,以便为不同站点之间的报文转发提供虚拟连接。

PW的创建过程为:

(1)       通过发现机制确定远端PE的地址。对于同一个VPLS实例内的远端PE设备,可以通过手工配置来指定远端PE地址,也可以通过自动发现协议发现远端PE。目前主要采用BGP协议作为自动发现协议。

(2)       在两端PE上通过静态配置方式为PW指定出、入两个方向的PW标签,以创建PW;或自动分配标签后利用LDP或者BGP信令协议将分配的PW标签与PW的绑定关系通告给远端PE,以建立单向的LSP,一对单向的LSP建立成功后,便成功创建PW。

1.1.3  PW的分类

根据远端PE发现机制和PW标签分发信令的不同,PW分为静态PW、LDP PW、BGP PW和BGP自动发现LDP信令PW。

1. 静态PW

手工指定远端PE的地址,并静态配置PW出、入两个方向的PW标签。

2. LDP PW

手工指定远端PE的地址,并通过LDP信令协议将PW标签与PW的绑定关系等信息通告给远端PE。两端PE均收到对端通告的PW标签后,就成功建立了LDP PW。

建立LDP PW时,LDP消息中的FEC类型为携带PW ID字段的PWid FEC Element,即FEC 128,通过PW ID来标识与PW标签绑定的PW。

3. BGP PW

通过BGP协议将标签块等信息通告给远端PE。两端PE均收到对端通告的标签块后,根据标签块计算PW出、入两个方向的标签,这样就成功建立了BGP PW。

建立BGP PW时,通过BGP发布标签块等信息可以同时实现远端PE的自动发现和PW标签的通告。

4. BGP自动发现LDP信令PW

通过BGP协议自动发现远端PE后,利用LDP信令协议将PW标签与PW的绑定关系等信息通告给远端PE。两端PE均收到对端通告的PW标签后,就成功建立了PW。

BGP协议发布的自动发现信息中包括本端PE的标识(如LSR ID)、标识本端PE所属VPLS实例的VPLS ID等信息。远端PE接收到该信息后,如果两端PE的VPLS ID相同,则会继续利用LDP信令协议在二者之间建立PW;否则,不会建立PW。

建立BGP自动发现LDP信令PW时,LDP消息中的FEC类型为Generalized PWid FEC Element,即FEC 129。该FEC携带VPLS ID、SAII(Source Attachment Individual Identifier,源转发实例本地标识符)和TAII(Target Attachment Individual Identifier,目的转发实例本地标识符)等信息。其中,SAII用来标识本地PE,为本地PE的LSR ID;TAII用来标识远端PE,为远端PE通过BGP协议发布的PE标识。VPLS ID+SAII+TAII可以唯一标识VPLS实例内的一条与PW标签绑定的PW。

1.1.4  源MAC地址学习、MAC地址老化和回收

1. 源MAC地址学习

VPLS通过源MAC地址学习来提供可达性。PE为每个VSI维护一张MAC地址表。

图1-2所示,源MAC地址学习过程包含两部分:

·            与PE直接相连的本地站点的源MAC地址学习

本地站点的源MAC地址学习与传统以太网交换机相同。PE从CE接收到报文后,如果MAC地址表中不存在报文源MAC地址,则将该报文的源MAC地址学习到PE连接CE的AC链路上。

·            通过PW连接的远端站点的源MAC地址学习

VSI将PW看作是逻辑以太网接口。PE从PW上接收到报文后,如果MAC地址表中不存在报文源MAC地址,则将该报文的源MAC地址学习到VSI的PW逻辑以太网接口上。

图1-2 PE的源MAC地址学习过程

 

2. MAC地址老化

如果在MAC地址的老化定时器超时时,没有接收到报文刷新该MAC地址表项,则删除该MAC地址表项,以尽可能减少占用的MAC地址表资源。

3. MAC地址回收

在AC或PW状态变为down时,LDP协议会发送地址回收消息通知VPLS实例内的所有远端PE删除指定VSI内的指定MAC地址,以加快MAC地址表的收敛速度。

1.1.5  流量转发和泛洪

1. 单播流量的转发和泛洪

PE从AC接收到单播报文后,在与AC关联的VSI内查找MAC地址表,从而确定如何转发报文:

·            如果查找到目的MAC地址对应的表项,则根据该表项转发报文。

¡  表项的出接口为PW逻辑以太网接口时,为报文封装该PW的PW标签,并添加公网隧道封装后,通过PW将该报文转发给远端PE。如果PW由LSP或MPLS TE隧道承载,则通过PW转发报文时将为报文封装两层标签:内层标签为PW标签,用来决定报文所属的PW,从而将报文转发给正确的VSI;外层标签为公网LSP或MPLS TE隧道标签,用来保证报文在PE之间正确传送。

¡  表项的出接口为连接本地站点的接口时,直接通过出接口将报文转发给本地站点。

·            如果没有找到目的MAC地址对应的表项,则向VSI内的所有其他AC对应的接口和所有PW逻辑以太网接口泛洪该报文。

PE从PW接收到单播报文后,在PW所属的VSI内查找MAC地址表,从而确定如何转发报文:

·            如果查找到目的MAC地址对应的表项,则根据该表项转发报文。该表项的出接口应为连接本地站点的接口,PE通过该出接口将报文转发给本地站点。

·            如果没有找到目的MAC地址对应的表项,则向VSI内所有AC对应的接口泛洪该报文。

2. 组播和广播流量的泛洪

PE从AC上接收到组播或广播报文后,向该AC关联的VSI内的所有其他AC对应的接口和所有PW逻辑以太网接口泛洪该报文。

PE从PW上接收到组播或广播报文后,向该PW所属的VSI内所有AC对应的接口泛洪该报文。

1.1.6  PW全连接和水平分割

为了避免环路,一般的二层网络都要求使用环路预防协议,比如STP(Spanning Tree Protocol,生成树协议)。但是在骨干网的PE上部署环路预防协议,会增加管理和维护的难度。因此,VPLS采用如下方法避免环路:

·            PE之间建立全连接的PW,即一个VPLS实例内的每两个PE之间必须都建立PW。

·            采用水平分割转发规则,即从PW上收到的报文禁止向同一个VSI内的其他PW上转发,只能转发到AC。

1.1.7  PW冗余保护

如果两个CE之间只存在一条PW,则当PE节点、PE与CE之间的链路、或PE之间的PW出现故障时,CE之间将无法通信。PW冗余保护功能通过部署主备两条PW,实现当主PW出现故障后,将流量立即切换到备份PW,使得流量转发得以继续。目前,只有静态PW和LDP PW支持PW冗余保护功能。

图1-3所示,在两个CE之间建立两条PW链路,正常情况下,CE使用主PW与远端CE通信;当PE 1检测出到PE 2的PW不可用(可能是PE 2节点故障,也可能是PW故障,或PE 2与CE 2之间的链路故障),PE 1将启用备份PW,通过备份PW将CE 1的报文转发给PE 3,再由PE 3转发给CE 2。CE 2接收到报文后,通过更新MAC地址表项等方式将发送给CE 1的报文切换到备份PW转发,从而保证通信不会中断。

图1-3 VPLS PW冗余保护

 

VPLS根据控制平面的LDP会话状态,或者数据平面连通性检测结果等来判断当前使用的PW是否可以继续使用。在当前使用的PW不可用的情况下,将流量切换到备用的另一条PW上。在以下情况下,将启用备份PW:

·            承载主PW的公网隧道被拆除或通过BFD等检测机制检测到公网隧道出现故障,导致主PW的状态变为down;

·            控制平面拆除主PW(如主PW两端PE之间的LDP会话down导致主PW被删除),或利用BFD等链路检测机制检测到主PW故障;

·            执行命令手工切换主备PW。

主备PW的状态分为Active和Standby。PE根据上述条件确定本地主备PW的状态。

·            Active:表示该PW可以用于业务传送。

·            Standby:表示该PW处于备份状态,不能用于业务传送。

对于LDP PW,PW两端的PE通过LDP通告消息协商主备PW的状态。在主从操作模式下,其中一个PE作为主节点,另一个PE作为从节点。主节点决定了本地PW的Active状态、Standby状态后,通过LDP通知消息将该状态通告给从节点。从节点接收到主节点的LDP通知消息后,保持本地的PW状态与主节点一致,从而保证主、从节点均在相同的、处于Active状态的PW上传送客户业务。

1.1.8  H-VPLS

1. H-VPLS简介

VPLS要求同一个VPLS实例中的所有PE之间PW全连接。在网络规模比较大的情况下,PW的数目会非常多,PW信令开销也会很大,网络的管理和扩展都将变得复杂。H-VPLS(Hierarchical VPLS,分层VPLS)通过将网络化分为骨干域和边界域,避免了建立过多的PW,简化了网络管理,提高了网络的扩展性。

目前,只有静态PW和LDP PW支持H-VPLS。

在H-VPLS组网中:

·            边界域负责将用户网络接入到骨干域。

·            骨干域中的NPE(Network Provider Edge,网络核心侧PE)之间需要建立全连接。NPE之间建立的PW称为N-PW。

·            边界域的UPE(User facing-Provider Edge,靠近用户侧的PE)只需与相邻的NPE建立连接。

2. H-VPLS的接入方式

H-VPLS有如下两种接入方式:

·            MPLS网络作为边界域的MPLS接入方式

图1-4所示,在MPLS接入方式中,UPE只与NPE 1建立一条PW——U-PW,不需要与其它所有的远端PE建立PW。UPE从CE接收到报文后,为报文添加U-PW的PW标签,并通过公网隧道将报文转发到NPE 1;NPE 1根据报文中的PW标签将报文映射到相应的VSI,查找该VSI的MAC地址表,决定如何转发该报文。

图1-4 MPLS接入方式

 

提示

由于NPE需要在U-PW和N-PW之间转发报文,因此,在NPE上配置与UPE建立U-PW时,需要指定通过该U-PW转发报文时,不采用水平分割方式。

 

·            以太网作为边界域的以太网接入方式

图1-5所示,在以太网接入方式中,UPE和NPE 1之间建立点到点的以太网QinQ连接(即在UPE面向CE的接口上使能QinQ,在与UPE直连的NPE 1上使用VLAN接入模式)。UPE从CE接收到报文后,为报文打上外层VLAN Tag,并将报文转发到NPE 1;由于NPE 1上配置了VLAN接入模式,NPE 1将外层VLAN Tag当作服务提供商VLAN Tag,根据该VLAN Tag将报文映射到相应的VSI,查找该VSI的MAC地址表,决定如何转发该报文。

图1-5 以太网接入方式

 

3. UPE双归属和冗余保护

UPE与NPE之间只有单条链路连接的方案具有明显的弱点:一旦该接入链路出现故障,UPE连接的用户网络站点都将丧失连通性。因此,可以将UPE与两台NPE相连,实现U-PW和NPE节点的冗余保护。

图1-6所示,MPLS接入方式的H-VPLS提供了冗余保护方案。在正常情况下,设备只使用主用U-PW(Main U-PW)转发流量。当主用U-PW出现故障时,将启用备用U-PW(Backup U-PW)继续转发用户网络站点的流量。

图1-6 MPLS接入方式的UPE双归属和冗余保护

 

1.2  VPLS配置限制和指导

PE不会通过VPLS网络透传LACP和LLDP协议报文。

如果在PE上全局开启了生成树协议,则只有执行stp transparent enable命令开启端口透传生成树报文功能后,PE才会通过VPLS网络透传STP协议报文;否则,PE不会通过VPLS网络透传STP协议报文。stp transparent enable命令的详细介绍,请参见“二层技术-以太网交换命令参考”中的“STP”。

1.3  VPLS配置任务简介

请在PE设备上进行如下配置:

(1)       开启L2VPN功能

(2)       配置AC

(3)       配置VSI

(4)       配置PW

请在静态PW、LDP PW、BGP PW和BGP自动发现LDP信令PW中至少选择一项进行配置:

¡  (可选)配置PW模板

¡  配置静态PW

¡  配置LDP PW

¡  配置BGP PW

¡  配置BGP自动发现LDP信令PW

¡  (可选)配置BGP L2VPN地址族

配置BGP PW和BGP自动发现LDP信令PW时,可以执行本配置以控制BGP L2VPN地址族的路由发布和路由选择。

¡  (可选)维护BGP会话

采用BGP PW和BGP自动发现LDP信令PW时,如果BGP配置发生变化,则可以通过软复位或复位BGP会话使新的配置生效。

(5)       配置AC与VSI关联

UPE以MPLS接入方式进行H-VPLS接入时,UPE接入的NPE上可以不进行本配置。

(6)       (可选)配置PW冗余保护

(7)       (可选)配置MAC地址学习功能

(8)       (可选)开启L2VPN告警功能

1.4  VPLS配置准备

配置VPLS前,需要完成以下任务:

·            在VPLS网络中的各台设备上配置IGP(Interior Gateway Protocol,内部网关协议),实现骨干网的IP连通性。

·            在VPLS网络中的各台设备上配置MPLS基本功能、LDP、GRE或MPLS TE等,在骨干网上建立公网隧道。

·            如果公网隧道为GRE隧道,则需要在PE设备上通过mpls lsr-id命令配置本节点的LSR ID,并在PE连接公网的接口上通过mpls enable命令使能该接口的MPLS能力。mpls lsr-id命令和mpls enable命令的详细介绍,请参见“MPLS命令参考”中的“MPLS基础”。

1.5  开启L2VPN功能

(1)       进入系统视图。

system-view

(2)       开启L2VPN功能。

l2vpn enable

缺省情况下,L2VPN功能处于关闭状态。

1.6  配置AC

1.6.1  配置以太网服务实例

1. 功能简介

PE通过二层以太网接口或二层聚合接口连接CE时,可以配置以太网服务实例,以便将一个二层以太网接口或二层聚合接口上接收到的、符合以太网服务实例匹配规则的报文关联到同一个VSI。以太网服务实例为以太网帧关联VSI提供了非常灵活的匹配方法。

2. 配置限制和指导

请不要在同一个二层以太网接口/二层聚合接口上同时配置以下功能:

·            VLAN映射、以太网服务实例与VSI

·            QinQ、以太网服务实例与VSI

否则,可能导致这些功能不可用。

执行本配置时,需要注意:对于以太网服务实例所匹配的VLAN,在设备上需要创建对应的VLAN,并在创建以太网服务实例的接口配置允许该VLAN通过。

配置以太网服务实例的报文匹配规则时需要注意的事项请参见“MPLS命令参考”中的“VPLS”。

3. 配置步骤

(1)       进入系统视图。

system-view

(2)       进入接口视图。

¡  进入二层以太网接口视图。

interface interface-type interface-number

¡  进入二层聚合接口视图。

interface bridge-aggregation interface-number

(3)       创建以太网服务实例,并进入以太网服务实例视图。

service-instance instance-id

(4)       配置以太网服务实例的报文匹配规则。

¡  匹配报文的外层VLAN tag。

encapsulation s-vid vlan-id-list [ only-tagged ]

¡  同时匹配报文的外层和内层VLAN tag。

encapsulation s-vid vlan-id-list c-vid vlan-id

¡  匹配携带VLAN tag的所有报文。

encapsulation tagged

¡  匹配未匹配到接口上其他以太网服务实例的所有报文。

encapsulation default

同一个接口上最多只能有一个服务实例采用缺省的报文匹配规则。

如果接口上只存在一个配置了encapsulation default规则的以太网服务实例,则该接口上的所有报文都匹配该以太网服务实例。

缺省情况下,未配置报文匹配规则。

(5)       (可选)配置AC上流量的最大带宽。

bandwidth bandwidth

缺省情况下,未配置AC上流量的最大带宽,即不限制AC上的流量。

1.7  配置VSI

1. 配置限制和指导

如果在VSI视图下同时执行了bandwidth命令和restrain命令,则对于广播、组播或未知单播流量,仅通过restrain命令限制该类流量,bandwidth命令不能限制该类流量。bandwidth命令仅能控制未通过restrain命令限制的流量。

2. 配置步骤

(1)       进入系统视图。

system-view

(2)       创建一个VSI,并进入VSI视图。

vsi vsi-name

(3)       (可选)配置VSI的描述信息。

description text

缺省情况下,未配置VSI的描述信息。

(4)       (可选)配置VSI的缺省PW ID。

default-pw-id default-pw-id

缺省情况下,未配置VSI的缺省PW ID。

(5)       配置VSI内流量的最大带宽。

bandwidth bandwidth

缺省情况下,未配置VSI内流量的最大带宽,即不限制VSI内的流量。

(6)       配置VSI的MTU值。

mtu size

缺省情况下,VSI的MTU值为1500字节。

(7)       配置VSI的广播、组播或未知单播抑制带宽。

restrain { broadcast | multicast | unknown-unicast } bandwidth

缺省情况下,不抑制VSI的广播、组播和未知单播流量。

(8)       (可选)开启VSI。

undo shutdown

缺省情况下,VSI处于开启状态。

1.8  配置PW

1.8.1  配置PW模板

1. 功能简介

在PW模板中可以指定PW的属性,如PW的数据封装类型、是否使用控制字等。具有相同属性的PW可以通过引用相同的PW模板,实现对PW属性的配置,从而简化配置。

2. 配置步骤

(1)       进入系统视图。

system-view

(2)       创建PW模板,并进入PW模板视图。

pw-class class-name

(3)       (可选)开启控制字功能。

control-word enable

缺省情况下,控制字功能处于关闭状态。

(4)       (可选)PW数据封装类型。

pw-type { ethernet | vlan }

缺省情况下,PW数据封装类型为VLAN。

1.8.2  配置静态PW

(1)       进入系统视图。

system-view

(2)       进入VSI视图。

vsi vsi-name

(3)       指定VSI采用静态配置方式建立PW,并进入VSI静态配置视图。

pwsignaling static

缺省情况下,未指定VSI使用的PW信令协议。

(4)       配置VPLS的PW,并进入VSI静态PW视图。

peer ip-address [ pw-id pw-id ] in-label label-value out-label label-value [ no-split-horizon | pw-class class-name | tunnel-policy tunnel-policy-name ] *

参数

使用说明

pw-id pw-id

如果在VSI视图下通过default-pw-id命令配置了缺省PW ID,则执行peer命令时可以不指定pw-id pw-id参数,采用缺省的PW ID;否则,执行peer命令时必须指定该参数

no-split-horizon

在NPE上配置与UPE建立U-PW时,需要通过no-split-horizon参数指定通过该U-PW转发报文时,不采用水平分割方式

 

(5)       (可选)配置PW的期望带宽。

bandwidth bandwidth-value

缺省情况下,PW的期望带宽为10000000kbps。

1.8.3  配置LDP PW

1. 配置准备

在配置LDP PW之前,需要在PE上使能全局和接口的MPLS LDP能力,详细配置方法请参见“MPLS配置指导”中的“LDP”。

2. 配置步骤

(1)       进入系统视图。

system-view

(2)       进入VSI视图。

vsi vsi-name

(3)       指定VSI使用LDP信令建立PW,并进入VSI LDP信令视图。

pwsignaling ldp

缺省情况下,未指定VSI使用的PW信令协议。

(4)       配置VPLS的PW,并进入VSI LDP PW视图。

peer ip-address [ pw-id pw-id ] [ no-split-horizon | pw-class class-name | tunnel-policy tunnel-policy-name ] *

参数

使用说明

pw-id pw-id

如果在VSI视图下通过default-pw-id命令配置了缺省PW ID,则执行peer命令时可以不指定pw-id pw-id参数,采用缺省的PW ID;否则,执行peer命令时必须指定该参数

no-split-horizon

在NPE上配置与UPE建立U-PW时,需要通过no-split-horizon参数指定通过该U-PW转发报文时,不采用水平分割方式

 

(5)       (可选)配置PW的期望带宽。

bandwidth bandwidth-value

缺省情况下,PW的期望带宽为10000000kbps。

1.8.4  配置BGP PW

1. 配置BGP发布VPLS标签块信息

(1)       进入系统视图。

system-view

(2)       启动BGP实例,并进入BGP实例视图。

bgp as-number [ instance instance-name ]

缺省情况下,系统没有运行BGP。

本命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

(3)       将远端PE配置为对等体。

peer { group-name | ip-address [ mask-length ] } as-number as-number

本命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

(4)       创建BGP L2VPN地址族,并进入BGP L2VPN地址族视图。

address-family l2vpn

(5)       开启本地路由器与指定对等体/对等体组交换BGP L2VPN信息的能力。

peer { group-name | ip-address [ mask-length ] } enable

缺省情况下,本地路由器不能与对等体/对等体组交换BGP L2VPN信息。

本命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

(6)       开启本地路由器与指定对等体/对等体组交换标签块信息的能力。

peer { group-name | ip-address [ mask-length ] } signaling

缺省情况下,本地路由器具有与BGP L2VPN对等体/对等体组交换标签块信息的能力。

(7)       (可选)配置BGP L2VPN地址族。

本配置的详细介绍请参见“1.8.6  配置BGP L2VPN地址族”。

(8)       (可选)维护BGP会话。

本配置的详细介绍请参见“1.8.7  维护BGP会话”。

2. 采用BGP信令协议建立PW

(1)       进入系统视图。

system-view

(2)       进入VSI视图。

vsi vsi-name

(3)       指定VSI采用BGP方式自动发现邻居,并进入VSI自动发现视图。

auto-discovery bgp

缺省情况下,VSI不会采用BGP方式自动发现邻居。

(4)       为VSI的BGP方式配置RD。

route-distinguisher route-distinguisher

缺省情况下,未指定VSI BGP方式的RD。

(5)       为VSI的BGP方式配置Route Target属性。

vpn-target vpn-target&<1-8> [ both | export-extcommunity | import-extcommunity ]

缺省情况下,未指定VSI BGP方式的Route Target属性。

(6)       (可选)指定引用的PW模板。

pw-class class-name

缺省情况下,未引用PW模板。

(7)       (可选)指定引用的隧道策略。

tunnel-policy tunnel-policy-name

缺省情况下,未引用隧道策略。

(8)       配置采用BGP信令协议与自动发现的远端PE建立PW,并进入VSI自动发现BGP信令视图。

signaling-protocol bgp

缺省情况下,未指定与自动发现的远端PE建立PW时采用的信令协议。

(9)       创建本地站点。

site site-id [ range range-value ] [ default-offset default-offset ]

1.8.5  配置BGP自动发现LDP信令PW

1. 配置准备

在配置BGP自动发现LDP信令PW之前,需要在PE上使能全局和接口的MPLS LDP能力,详细配置方法请参见“MPLS配置指导”中的“LDP”。

2. 配置BGP发布VPLS PE信息

(1)       进入系统视图。

system-view

(2)       启动BGP实例,并进入BGP实例视图。

bgp as-number [ instance instance-name ]

缺省情况下,系统没有运行BGP。

本命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

(3)       将远端PE配置为对等体。

peer { group-name | ip-address [ mask-length ] } as-number as-number

本命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

(4)       创建BGP L2VPN地址族,并进入BGP L2VPN地址族视图。

address-family l2vpn

(5)       开启本地路由器与指定对等体/对等体组交换BGP L2VPN信息的能力。

peer { group-name | ip-address [ mask-length ] } enable

缺省情况下,本地路由器不能与对等体/对等体组交换BGP L2VPN信息。

本命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

(6)       开启本地路由器与指定对等体/对等体组交换VPLS PE信息的能力。

peer { group-name | ip-address [ mask-length ] } auto-discovery [ non-standard ]

缺省情况下,本地路由器具有与BGP L2VPN对等体/对等体组交换VPLS PE信息的能力,并且采用RFC 6074中定义的MP_REACH_NLRI格式交换VPLS PE信息。

(7)       (可选)配置BGP L2VPN地址族。

本配置的详细介绍请参见“1.8.6  配置BGP L2VPN地址族”。

(8)       (可选)维护BGP会话。

本配置的详细介绍请参见“1.8.7  维护BGP会话”。

3. 采用LDP信令协议建立PW

(1)       进入系统视图。

system-view

(2)       进入VSI视图。

vsi vsi-name

(3)       指定VSI采用BGP方式自动发现邻居,并进入VSI自动发现视图。

auto-discovery bgp

缺省情况下,VSI不会采用BGP方式自动发现邻居。

(4)       为VSI的BGP方式配置RD。

route-distinguisher route-distinguisher

缺省情况下,未指定VSI BGP方式的RD。

(5)       为VSI的BGP方式配置Route Target属性。

vpn-target vpn-target&<1-8> [ both | export-extcommunity | import-extcommunity ]

缺省情况下,未指定VSI BGP方式的Route Target属性。

(6)       (可选)指定引用的PW模板。

pw-class class-name

缺省情况下,未引用PW模板。

(7)       (可选)指定引用的隧道策略。

tunnel-policy tunnel-policy-name

缺省情况下,未引用隧道策略。

(8)       配置采用LDP信令协议与自动发现的远端PE建立PW,并进入VSI自动发现LDP信令视图。

signaling-protocol ldp

缺省情况下,未指定与自动发现的远端PE建立PW时采用的信令协议。

(9)       配置VSI的VPLS ID。

vpls-id vpls-id

缺省情况下,未指定VSI的VPLS ID。

1.8.6  配置BGP L2VPN地址族

1. 功能简介

配置BGP PW和BGP自动发现LDP信令PW时,可以执行本配置以控制BGP L2VPN地址族的路由发布和路由选择。

本配置中各命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

2. 配置步骤

(1)       进入系统视图。

system-view

(2)       进入BGP实例视图。

bgp as-number [ instance instance-name ]

(3)       进入BGP L2VPN地址族视图。

address-family l2vpn

(4)       配置对于从对等体/对等体组接收的BGP消息,允许本地AS号在该消息的AS_PATH属性中出现,并配置允许出现的次数。

peer { group-name | ip-address [ mask-length ] } allow-as-loop [ number ]

缺省情况下,不允许本地AS号在接收消息的AS_PATH属性中出现。

(5)       开启BGP L2VPN信息的VPN-Target过滤功能。

policy vpn-target

缺省情况下,BGP L2VPN信息的VPN-Target过滤功能处于开启状态。

(6)       配置BGP路由反射功能。

¡  配置本机作为路由反射器,对等体/对等体组作为路由反射器的客户机。

peer { group-name | ip-address [ mask-length ] } reflect-client

缺省情况下,没有配置路由反射器及其客户机。

¡  允许路由反射器在客户机之间反射L2VPN信息。

reflect between-clients

缺省情况下,允许路由反射器在客户机之间反射L2VPN信息。

¡  配置路由反射器的集群ID。

reflector cluster-id { cluster-id | ip-address }

缺省情况下,每个路由反射器都使用自己的Router ID作为集群ID。

¡  创建路由反射器的反射策略。

rr-filter ext-comm-list-number

缺省情况下,路由反射器不会对反射的L2VPN信息进行过滤。

(7)       配置BGP路由延迟优选

route-select delay delay-value

缺省情况下,延迟时间为0秒,即路由优选不延迟。

本命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

1.8.7  维护BGP会话

1. 功能简介

采用BGP PW和BGP自动发现LDP信令PW时,如果BGP配置发生变化,则可以通过软复位或复位BGP会话使新的配置生效。软复位BGP会话是指在不断开BGP邻居关系的情况下,更新BGP路由信息;复位BGP会话是指断开并重新建立BGP邻居关系的情况下,更新BGP路由信息。软复位需要BGP对等体具备路由刷新能力(支持ROUTE-REFRESH消息)。

本配置中各命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

2. 配置步骤

请在用户视图下选择一项进行配置。

·            手工对L2VPN地址族下的BGP会话进行软复位。

refresh bgp  [ instance instance-name ] { ip-address [ mask-length ] | all | external | group group-name | internal } { export | import } l2vpn

·            复位L2VPN地址族下的BGP会话。

reset bgp [ instance instance-name ] { as-number | ip-address [ mask-length ] | all | external | group group-name | internal } l2vpn

1.9  配置AC与VSI关联

1.9.1  功能简介

配置三层接口与VSI关联后,从接口接收到的报文将通过查找关联VSI的MAC地址表进行转发。

在某个接口的以太网服务实例视图下配置该以太网服务实例与VSI关联后,从该接口接收到的、符合以太网服务实例报文匹配规则的报文,将通过查找关联VSI的MAC地址表进行转发。以太网服务实例提供了多种报文匹配规则(包括接口接收到的所有报文、所有携带VLAN Tag的报文和所有不携带VLAN Tag的报文等),为报文关联VSI提供了更加灵活的方式。

配置AC与VSI关联时,可以指定AC与Track项联动。仅当关联的Track项中至少有一个状态为positive时,AC的状态才会up,否则,AC的状态为down。

在L2VPN接入L3VPN或IP骨干网组网中,由于VE-L2VPN接口为虚拟接口,链路故障时接口不会down。通过将AC与Track项关联,利用Track项监测PE-agg连接L3VPN或IP骨干网的链路状态,可以实现该链路故障时,将VE-L2VPN接口置为down状态,从而使得与AC关联的PW转变为down状态。如果在L2VPN网络中存在主备PW,则流量可以切换到备份PW。L2VPN接入L3VPN或IP骨干网的详细介绍,请参见“MPLS配置指导”中的“L2VPN接入L3VPN或IP骨干网”。

1.9.2  配置限制和指导

以太网服务实例关联VSI与以太网链路聚合功能互斥。二层以太网接口加入聚合组后,不能再将该接口上的以太网服务实例与VSI关联;反之亦然。

1.9.3  配置以太网服务实例与VSI关联

(1)       进入系统视图。

system-view

(2)       进入接口视图。

¡  进入二层以太网接口视图。

interface interface-type interface-number

¡  进入二层聚合接口视图。

interface bridge-aggregation interface-number

(3)       进入以太网服务实例视图。

service-instance instance-id

(4)       将以太网服务实例与VSI关联。

xconnect vsi vsi-name [ access-mode { ethernet | vlan } ] [ track track-entry-number&<1-3> ]

缺省情况下,以太网服务实例未关联VSI。

1.10  配置PW冗余保护

1.10.1  配置静态PW的冗余保护

(1)       进入系统视图。

system-view

(2)       进入VSI视图。

vsi vsi-name

(3)       指定VSI采用静态配置方式建立PW,并进入VSI静态配置视图。

pwsignaling static

缺省情况下,未指定VSI使用的PW信令协议。

(4)       (可选)配置PW冗余保护倒换的回切模式,以及回切等待时间。

revertive { wtr wtr-time | never }

缺省情况下,回切模式为可回切,回切等待时间为0。

(5)       配置VPLS的PW,并进入VSI静态PW视图。

peer ip-address [ pw-id pw-id ] [ in-label label-value out-label label-value ] [ no-split-horizon | pw-class class-name | tunnel-policy tunnel-policy-name ] *

(6)       配置VPLS的备份PW,并进入VSI静态备份PW视图。

backup-peer ip-address [ pw-id pw-id ] in-label label-value out-label label-value [ pw-class class-name | tunnel-policy tunnel-policy-name ] *

如果在VSI视图下通过default-pw-id命令配置了缺省PW ID,则执行本命令时可以不指定pw-id pw-id参数,采用缺省的PW ID;否则,执行本命令时必须指定pw-id pw-id参数。

(7)       (可选)手工倒换流量。

a.   返回用户视图。

return

b.   将PW的流量手工倒换到它的冗余备份PW上。

l2vpn switchover peer ip-address pw-id pw-id

1.10.2  配置LDP PW的冗余保护

(1)       进入系统视图。

system-view

(2)       进入VSI视图。

vsi vsi-name

(3)       指定VSI使用LDP信令建立PW,并进入VSI LDP信令视图。

pwsignaling ldp

缺省情况下,未指定VSI使用的PW信令协议。

(4)       (可选)配置PW冗余保护模式为主从操作模式,且本地PE作为主节点。

pw-redundancy master

缺省情况下,PW冗余保护模式为主从操作模式,且本地PE作为从节点。

当对端PE不支持PW冗余保护模式时,本地PE不能配置为主从模式的主节点。

(5)       (可选)配置PW冗余保护倒换的回切模式,以及回切等待时间。

revertive { wtr wtr-time | never }

缺省情况下,回切模式为可回切,回切等待时间为0。

(6)       配置VPLS的PW,并进入VSI LDP PW视图。

peer ip-address [ pw-id pw-id ] [ ignore-standby-state | no-split-horizon | pw-class class-name | tunnel-policy tunnel-policy-name ] *

ignore-standby-state用来指定忽略远端PE发送的Active/Standby状态,即不根据接收到的Active/Standby状态改变本端的主备状态。

(7)       配置VPLS的备份PW,并进入VSI LDP备份PW视图。

backup-peer ip-address [ pw-id pw-id ] [ pw-class class-name | tunnel-policy tunnel-policy-name ] *

缺省情况下,不存在VPLS的备份PW。

如果在VSI视图下通过default-pw-id命令配置了缺省PW ID,则执行本命令时可以不指定pw-id pw-id参数,采用缺省的PW ID;否则,执行本命令时必须指定该参数。

(8)       (可选)手工倒换流量。

a.   返回用户视图。

return

b.   将PW的流量手工倒换到它的冗余备份PW上。

l2vpn switchover peer ip-address pw-id pw-id

1.11  配置MAC地址学习功能

(1)       进入系统视图。

system-view

(2)       进入VSI视图。

vsi vsi-name [ hub-spoke ]

(3)       开启VSI的MAC地址学习功能。

mac-learning enable

缺省情况下,VSI的MAC地址学习功能处于开启状态。

1.12  开启L2VPN告警功能

1. 功能简介

开启L2VPN告警功能后,当PW的up-down状态发生变化、PW删除或主备PW切换时会产生告警信息。生成的告警信息将发送到设备的SNMP模块,通过设置SNMP中告警信息的发送参数,来决定告警信息输出的相关属性。

有关告警信息的详细介绍,请参见“网络管理和监控配置指导”中的“SNMP”。

2. 配置步骤

(1)       进入系统视图。

system-view

(2)       开启L2VPN告警功能。

snmp-agent trap enable l2vpn [ pw-delete | pw-switch | pw-up-down ] *

缺省情况下,L2VPN告警功能处于关闭状态。

1.13  VPLS显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后VPLS的运行情况,通过查看显示信息验证配置的效果。

在用户视图下执行reset命令可以清除VPLS的相关信息。

display bgp group l2vpndisplay bgp peer l2vpndisplay bgp update-group l2vpnreset bgp l2vpn命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

表1-1 VPLS显示和维护

操作

命令

显示BGP L2VPN对等体组的信息

display bgp  [ instance instance-name ] group l2vpn [ group-name group-name ]

显示通过BGP协议自动发现的VPLS PE信息

display bgp  [ instance instance-name ] l2vpn auto-discovery [ peer ip-address { advertised | received } [ statistics ] | route-distinguisher route-distinguisher [ pe-address ip-address [ advertise-info ] ] | statistics ]

显示BGP协议的VPLS标签块信息

display bgp  [ instance instance-name ] l2vpn signaling [ peer ip-address { advertised | received } [ statistics ] | route-distinguisher route-distinguisher [ site-id site-id [ label-offset label-offset [ advertise-info ] ] ] | statistics ]

显示BGP L2VPN对等体的信息

display bgp  [ instance instance-name ] peer l2vpn [ ip-address mask-length | group-name group-name log-info | ip-address { log-info | verbose } | verbose ]

显示BGP L2VPN地址族下打包组的相关信息

display bgp [ instance instance-name ] update-group l2vpn [ ip-address ]

显示VPLS的自动发现信息

display l2vpn auto-discovery [ peer ip-address ] [ vsi vsi-name ]

显示VPLS的标签块信息

display l2vpn bgp [ instance instance-name ] [ peer ip-address | local ] [ vsi vsi-name ] [ verbose ]

显示L2VPN转发信息

(独立运行模式)

display l2vpn forwarding { ac | pw } [ vsi vsi-name ] [ slot slot-number ] [ verbose ]

(IRF模式)

display l2vpn forwarding { ac | pw } [ vsi vsi-name ] [ chassis chassis-number slot slot-number ] [ verbose ]

显示LDP协议通告的PW标签相关信息

display l2vpn ldp [ peer ip-address [ pw-id pw-id | vpls-id vpls-id ] | vsi vsi-name ] [ verbose ]

显示VSI的MAC地址表信息

display l2vpn mac-address [ vsi vsi-name ] [ dynamic ] [ count | verbose ]

显示L2VPN的PW信息

display l2vpn pw [ vsi vsi-name ] [ protocol { bgp | ldp | static } ] [ verbose ]

显示PW模板的信息

display l2vpn pw-class [ class-name ] [ verbose ]

显示以太网服务实例的信息

display l2vpn service-instance [ interface interface-type interface-number [ service-instance instance-id ] ] [ verbose ]

显示VSI的信息

display l2vpn vsi [ name vsi-name ] [ verbose ]

复位L2VPN地址族下的BGP会话

reset bgp { as-number | ip-address [ mask-length ] | all | external | group group-name | internal } l2vpn

清除VSI的MAC地址表项

reset l2vpn mac-address [ vsi vsi-name ]

 

1.14  VPLS典型配置举例

1.14.1  静态PW配置举例

1. 组网需求

·            CE 1、CE 2和CE 3分属于3个站点,同属于VPN 1;

·            PE 1、PE 2和PE 3通过服务实例将报文与VSI实例关联,以便更为灵活地匹配从AC接收到的报文:服务实例10用来匹配接口HundredGigE1/0/1接收到的VLAN Tag为100的报文,并通过VSI实例svc转发;

·            在各个PE上配置VPLS,使得PE之间采用静态配置建立PW,通过PW连接各个CE。

2. 组网图

图1-7 静态PW配置组网图

3. 配置步骤

说明

进行下面配置之前,需要先全局关闭STP功能,或为每个VLAN映射一个MSTP实例,具体配置方法请参见“二层技术-以太网交换配置指导”中的“生成树”。

 

(1)       配置PE 1

# 配置LSR ID。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 1.1.1.9 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 1.1.1.9

# 开启L2VPN功能。

[PE1] l2vpn enable

# 全局使能LDP。

[PE1] mpls ldp

[PE1-ldp] quit

# 配置连接PE 2的接口Vlan-interface20,在此接口上使能LDP。

[PE1] interface vlan-interface 20

[PE1-Vlan-interface20] ip address 20.1.1.1 24

[PE1-Vlan-interface20] mpls enable

[PE1-Vlan-interface20] mpls ldp enable

[PE1-Vlan-interface20] quit

# 配置连接PE 3的接口Vlan-interface30,在此接口上使能LDP。

[PE1] interface vlan-interface 30

[PE1-Vlan-interface30] ip address 30.1.1.1 24

[PE1-Vlan-interface30] mpls enable

[PE1-Vlan-interface30] mpls ldp enable

[PE1-Vlan-interface30] quit

# 在PE 1上运行OSPF,用于建立LSP。

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 在PE 1上创建虚拟交换实例,并配置远端PE。

[PE1] vsi svc

[PE1-vsi-svc] pwsignaling static

[PE1-vsi-svc-static] peer 2.2.2.9 pw-id 3 in-label 100 out-label 100

[PE1-vsi-svc-static-2.2.2.9-3] quit

[PE1-vsi-svc-static] peer 3.3.3.9 pw-id 3 in-label 200 out-label 200

[PE1-vsi-svc-static-3.3.3.9-3] quit

[PE1-vsi-svc-static] quit

[PE1-vsi-svc] quit

# 在接口HundredGigE1/0/1上创建服务实例,并绑定VSI实例svc。

[PE1] interface hundredgige 1/0/1

[PE1-HundredGigE1/0/1] service-instance 10

[PE1-HundredGigE1/0/1-srv10] encapsulation s-vid 100

[PE1-HundredGigE1/0/1-srv10] xconnect vsi svc

(2)       配置PE 2

# 配置LSR ID。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 2.2.2.9 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 2.2.2.9

# 开启L2VPN功能。

[PE2] l2vpn enable

# 全局使能LDP。

[PE2] mpls ldp

[PE2-ldp] quit

# 配置连接PE 1的接口Vlan-interface20,在此接口上使能LDP。

[PE2] interface vlan-interface 20

[PE2-Vlan-interface20] ip address 20.1.1.2 24

[PE2-Vlan-interface20] mpls enable

[PE2-Vlan-interface20] mpls ldp enable

[PE2-Vlan-interface20] quit

# 配置连接PE 3的接口Vlan-interface40,在此接口上使能LDP。

[PE2] interface vlan-interface 40

[PE2-Vlan-interface40] ip address 40.1.1.2 24

[PE2-Vlan-interface40] mpls enable

[PE2-Vlan-interface40] mpls ldp enable

[PE2-Vlan-interface40] quit

# 在PE 2上运行OSPF,用于建立LSP。

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] network 40.1.1.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 在PE 2上创建虚拟交换实例,并配置远端PE。

[PE2] vsi svc

[PE2-vsi-svc] pwsignaling static

[PE2-vsi-svc-static] peer 1.1.1.9 pw-id 3 in-label 100 out-label 100

[PE2-vsi-svc-static-1.1.1.9-3] quit

[PE2-vsi-svc-static] peer 3.3.3.9 pw-id 3 in-label 300 out-label 300

[PE2-vsi-svc-static-3.3.3.9-3] quit

[PE2-vsi-svc-static] quit

[PE2-vsi-svc] quit

# 在接口HundredGigE1/0/1上创建服务实例,并绑定VSI实例svc。

[PE2] interface hundredgige 1/0/1

[PE2-HundredGigE1/0/1] service-instance 10

[PE2-HundredGigE1/0/1-srv10] encapsulation s-vid 100

[PE2-HundredGigE1/0/1-srv10] xconnect vsi svc

(3)       配置PE 3

# 配置LSR ID。

<PE3> system-view

[PE3] interface loopback 0

[PE3-LoopBack0] ip address 3.3.3.9 32

[PE3-LoopBack0] quit

[PE3] mpls lsr-id 3.3.3.9

# 开启L2VPN功能。

[PE3] l2vpn enable

# 全局使能LDP。

[PE3] mpls ldp

[PE3-ldp] quit

# 配置连接PE 1的接口Vlan-interface30,在此接口上使能LDP。

[PE3] interface vlan-interface 30

[PE3-Vlan-interface30] ip address 30.1.1.3 24

[PE3-Vlan-interface30] mpls enable

[PE3-Vlan-interface30] mpls ldp enable

[PE3-Vlan-interface30] quit

# 配置连接PE 2的接口Vlan-interface40,在此接口上使能LDP。

[PE3] interface vlan-interface 40

[PE3-Vlan-interface40] ip address 40.1.1.3 24

[PE3-Vlan-interface40] mpls enable

[PE3-Vlan-interface40] mpls ldp enable

[PE3-Vlan-interface40] quit

# 在PE 3上运行OSPF,用于建立LSP。

[PE3] ospf

[PE3-ospf-1] area 0

[PE3-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255

[PE3-ospf-1-area-0.0.0.0] network 40.1.1.0 0.0.0.255

[PE3-ospf-1-area-0.0.0.0] network 3.3.3.9 0.0.0.0

[PE3-ospf-1-area-0.0.0.0] quit

[PE3-ospf-1] quit

# 在PE 3上创建虚拟交换实例,并配置远端PE。

[PE3] vsi svc

[PE3-vsi-svc] pwsignaling static

[PE3-vsi-svc-static] peer 1.1.1.9 pw-id 3 in-label 200 out-label 200

[PE3-vsi-svc-static-1.1.1.9-3] quit

[PE3-vsi-svc-static] peer 2.2.2.9 pw-id 3 in-label 300 out-label 300

[PE3-vsi-svc-static-2.2.2.9-3] quit

[PE3-vsi-svc-static] quit

[PE3-vsi-svc] quit

# 在接口HundredGigE1/0/1上创建服务实例,并绑定VSI实例svc。

[PE3] interface hundredgige 1/0/1

[PE3-HundredGigE1/0/1] service-instance 10

[PE3-HundredGigE1/0/1-srv10] encapsulation s-vid 100

[PE3-HundredGigE1/0/1-srv10] xconnect vsi svc

4. 验证配置

# 在PE 1上查看SVC的L2VPN连接信息,可以看到建立了两条L2VPN连接。

[PE1] display l2vpn pw verbose

VSI Name: svc

  Peer: 2.2.2.9          PW ID: 3

    Signaling Protocol  : Static

    Link ID             : 8          PW State : Up

    In Label            : 100        Out Label: 100

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x160000001

    Tunnel NHLFE IDs    : 1027

  Peer: 3.3.3.9          PW ID: 3

    Signaling Protocol  : Static

    Link ID             : 9          PW State : Up

    In Label            : 200        Out Label: 200

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x260000002

    Tunnel NHLFE IDs    : 1028

1.14.2  LDP方式VPLS配置举例

1. 组网需求

·            CE 1、CE 2和CE 3分属于3个站点,同属于VPN 1;

·            PE 1、PE 2和PE 3通过服务实例将报文与VSI实例关联,以便更为灵活地匹配从AC接收到的报文:服务实例10用来匹配接口HundredGigE1/0/1接收到的VLAN Tag为100的报文,并通过VSI实例aaa转发;

·            在各个PE上配置VPLS,使得PE之间采用LDP信令协议建立PW,通过PW连接各个CE。

2. 组网图

图1-8 LDP方式VPLS配置组网图

3. 配置步骤

说明

进行下面配置之前,需要先全局关闭STP功能,或为每个VLAN映射一个MSTP实例,具体配置方法请参见“二层技术-以太网交换配置指导”中的“生成树”。

 

(1)       配置IGP协议、公网隧道,具体配置过程略。

(2)       配置PE 1

# 配置MPLS基本能力。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 1.1.1.9 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 1.1.1.9

[PE1] mpls ldp

[PE1-ldp] quit

# 开启L2VPN功能。

[PE1] l2vpn enable

# 配置VSI实例aaa采用LDP信令协议,并在PE 1和PE 2、PE 1和PE 3之间建立PW。

[PE1] vsi aaa

[PE1-vsi-aaa] pwsignaling ldp

[PE1-vsi-aaa-ldp] peer 2.2.2.9 pw-id 500

[PE1-vsi-aaa-ldp-2.2.2.9-500] quit

[PE1-vsi-aaa-ldp] peer 3.3.3.9 pw-id 500

[PE1-vsi-aaa-ldp-3.3.3.9-500] quit

[PE1-vsi-aaa-ldp] quit

[PE1-vsi-aaa] quit

# 在接口HundredGigE1/0/1上创建服务实例,并绑定VSI实例aaa。

[PE1] interface hundredgige 1/0/1

[PE1-HundredGigE1/0/1] service-instance 10

[PE1-HundredGigE1/0/1-srv10] encapsulation s-vid 100

[PE1-HundredGigE1/0/1-srv10] xconnect vsi aaa

(3)       配置PE 2

# 配置MPLS基本能力。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 2.2.2.9 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 2.2.2.9

[PE2] mpls ldp

[PE2-ldp] quit

# 开启L2VPN功能。

[PE2] l2vpn enable

# 配置VSI实例aaa采用LDP信令协议,并在PE 1和PE 2、PE 2和PE 3之间建立PW。

[PE2] vsi aaa

[PE2-vsi-aaa] pwsignaling ldp

[PE2-vsi-aaa-ldp] peer 1.1.1.9 pw-id 500

[PE2-vsi-aaa-ldp-1.1.1.9-500] quit

[PE2-vsi-aaa-ldp] peer 3.3.3.9 pw-id 500

[PE2-vsi-aaa-ldp-3.3.3.9-500] quit

[PE2-vsi-aaa-ldp] quit

[PE2-vsi-aaa] quit

# 在接口HundredGigE1/0/1上创建服务实例,并绑定VSI实例aaa。

[PE2] interface hundredgige 1/0/1

[PE2-HundredGigE1/0/1] service-instance 10

[PE2-HundredGigE1/0/1-srv10] encapsulation s-vid 100

[PE2-HundredGigE1/0/1-srv10] xconnect vsi aaa

(4)       配置PE 3

# 配置MPLS基本能力。

<PE3> system-view

[PE3] interface loopback 0

[PE3-LoopBack0] ip address 3.3.3.9 32

[PE3-LoopBack0] quit

[PE3] mpls lsr-id 3.3.3.9

[PE3] mpls ldp

[PE3-ldp] quit

# 开启L2VPN功能。

[PE3] l2vpn enable

# 配置VSI实例aaa采用LDP信令协议,并在PE 1和PE 3、PE 2和PE 3之间建立PW。

[PE3] vsi aaa

[PE3-vsi-aaa] pwsignaling ldp

[PE3-vsi-aaa-ldp] peer 1.1.1.9 pw-id 500

[PE3-vsi-aaa-ldp-1.1.1.9-500] quit

[PE3-vsi-aaa-ldp] peer 2.2.2.9 pw-id 500

[PE3-vsi-aaa-ldp-2.2.2.9-500] quit

[PE3-vsi-aaa-ldp] quit

[PE3-vsi-aaa] quit

# 在接口HundredGigE1/0/1上创建服务实例,并绑定VSI实例aaa。

[PE3] interface hundredgige 1/0/1

[PE3-HundredGigE1/0/1] service-instance 10

[PE3-HundredGigE1/0/1-srv10] encapsulation s-vid 100

[PE3-HundredGigE1/0/1-srv10] xconnect vsi aaa

4. 验证配置

完成上述配置后,在PE 1上执行display l2vpn pw verbose命令,可以看到建立了两条PW,状态为up。

[PE1] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1279       Out Label: 1279

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x260000000

    Tunnel NHLFE IDs    : 1028

  Peer: 3.3.3.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1278       Out Label: 1277

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x360000001

    Tunnel NHLFE IDs    : 1029

1.14.3  BGP方式VPLS配置举例

1. 组网需求

·            CE 1、CE 2和CE 3分属于3个站点,同属于VPN 1;

·            PE 1、PE 2和PE 3通过服务实例将报文与VSI实例关联,以便更为灵活地匹配从AC接收到的报文:服务实例10用来匹配接口HundredGigE1/0/1接收到的VLAN Tag为100的报文,并通过VSI实例aaa转发;

·            在各个PE上配置VPLS,使得PE之间采用BGP信令协议建立PW,通过PW连接各个CE。

2. 组网图

图1-9 BGP方式VPLS配置组网图

 

3. 配置步骤

说明

进行下面配置之前,需要先全局关闭STP功能,或为每个VLAN映射一个MSTP实例,具体配置方法请参见“二层技术-以太网交换配置指导”中的“生成树”。

 

(1)       配置IGP协议、公网隧道,具体配置过程略。

(2)       配置PE 1

# 配置MPLS基本能力。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 1.1.1.9 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 1.1.1.9

[PE1] mpls ldp

[PE1-ldp] quit

# 在PE 1和PE 2、PE 1和PE 3之间建立IBGP连接,并配置通过BGP发布VPLS标签块信息。

[PE1] bgp 100

[PE1-bgp-default] peer 2.2.2.9 as-number 100

[PE1-bgp-default] peer 2.2.2.9 connect-interface loopback 0

[PE1-bgp-default] peer 3.3.3.9 as-number 100

[PE1-bgp-default] peer 3.3.3.9 connect-interface loopback 0

[PE1-bgp-default] address-family l2vpn

[PE1-bgp-default-l2vpn] peer 2.2.2.9 enable

[PE1-bgp-default-l2vpn] peer 3.3.3.9 enable

[PE1-bgp-default-l2vpn] quit

[PE1-bgp-default] quit

# 开启L2VPN功能。

[PE1] l2vpn enable

# 配置VSI实例aaa采用BGP信令协议在PE 1和PE 2、PE 1和PE 3之间建立BGP PW。

[PE1] vsi aaa

[PE1-vsi-aaa] auto-discovery bgp

[PE1-vsi-aaa-auto] route-distinguisher 1:1

[PE1-vsi-aaa-auto] vpn-target 1:1

[PE1-vsi-aaa-auto] signaling-protocol bgp

[PE1-vsi-aaa-auto-bgp] site 1 range 10 default-offset 0

[PE1-vsi-aaa-auto-bgp] quit

[PE1-vsi-aaa-auto] quit

[PE1-vsi-aaa] quit

# 在接口HundredGigE1/0/1上创建服务实例,并绑定VSI实例aaa。

[PE1] interface hundredgige 1/0/1

[PE1-HundredGigE1/0/1] service-instance 10

[PE1-HundredGigE1/0/1-srv10] encapsulation s-vid 100

[PE1-HundredGigE1/0/1-srv10] xconnect vsi aaa

(3)       配置PE 2

# 配置MPLS基本能力。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 2.2.2.9 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 2.2.2.9

[PE2] mpls ldp

[PE2-ldp] quit

# 在PE 1和PE 2、PE 2和PE 3之间建立IBGP连接,并配置通过BGP发布VPLS标签块信息。

[PE2] bgp 100

[PE2-bgp-default] peer 1.1.1.9 as-number 100

[PE2-bgp-default] peer 1.1.1.9 connect-interface loopback 0

[PE2-bgp-default] peer 3.3.3.9 as-number 100

[PE2-bgp-default] peer 3.3.3.9 connect-interface loopback 0

[PE2-bgp-default] address-family l2vpn

[PE2-bgp-default-l2vpn] peer 1.1.1.9 enable

[PE2-bgp-default-l2vpn] peer 3.3.3.9 enable

[PE2-bgp-default-l2vpn] quit

[PE2-bgp-default] quit

# 开启L2VPN功能。

[PE2] l2vpn enable

# 配置VSI实例aaa采用BGP信令协议在PE 1和PE 2、PE 2和PE 3之间建立BGP PW。

[PE2] vsi aaa

[PE2-vsi-aaa] auto-discovery bgp

[PE2-vsi-aaa-auto] route-distinguisher 1:1

[PE2-vsi-aaa-auto] vpn-target 1:1

[PE2-vsi-aaa-auto] signaling-protocol bgp

[PE2-vsi-aaa-auto-bgp] site 2 range 10 default-offset 0

[PE2-vsi-aaa-auto-bgp] quit

[PE2-vsi-aaa-auto] quit

[PE2-vsi-aaa] quit

# 在接口HundredGigE1/0/1上创建服务实例,并绑定VSI实例aaa。

[PE2] interface hundredgige 1/0/1

[PE2-HundredGigE1/0/1] service-instance 10

[PE2-HundredGigE1/0/1-srv10] encapsulation s-vid 100

[PE2-HundredGigE1/0/1-srv10] xconnect vsi aaa

(4)       配置PE 3

# 配置MPLS基本能力。

<PE3> system-view

[PE3] interface loopback 0

[PE3-LoopBack0] ip address 3.3.3.9 32

[PE3-LoopBack0] quit

[PE3] mpls lsr-id 3.3.3.9

[PE3] mpls ldp

[PE3-ldp] quit

# 在PE 1和PE 3、PE 2和PE 3之间建立IBGP连接,并配置通过BGP发布VPLS标签块信息。

[PE3] bgp 100

[PE3-bgp-default] peer 1.1.1.9 as-number 100

[PE3-bgp-default] peer 1.1.1.9 connect-interface loopback 0

[PE3-bgp-default] peer 2.2.2.9 as-number 100

[PE3-bgp-default] peer 2.2.2.9 connect-interface loopback 0

[PE3-bgp-default] address-family l2vpn

[PE3-bgp-default-l2vpn] peer 1.1.1.9 enable

[PE3-bgp-default-l2vpn] peer 2.2.2.9 enable

[PE3-bgp-default-l2vpn] quit

[PE3-bgp-default] quit

# 开启L2VPN功能。

[PE3] l2vpn enable

# 配置VSI实例aaa采用BGP信令协议在PE 1和PE 3、PE 2和PE 3之间建立BGP PW。

[PE3] vsi aaa

[PE3-vsi-aaa] auto-discovery bgp

[PE3-vsi-aaa-auto] route-distinguisher 1:1

[PE3-vsi-aaa-auto] vpn-target 1:1

[PE3-vsi-aaa-auto] signaling-protocol bgp

[PE3-vsi-aaa-auto-bgp] site 3 range 10 default-offset 0

[PE3-vsi-aaa-auto-bgp] quit

[PE3-vsi-aaa-auto] quit

[PE3-vsi-aaa] quit

# 在接口HundredGigE1/0/1上创建服务实例,并绑定VSI实例aaa。

[PE3] interface hundredgige 1/0/1

[PE3-HundredGigE1/0/1] service-instance 10

[PE3-HundredGigE1/0/1-srv10] encapsulation s-vid 100

[PE3-HundredGigE1/0/1-srv10] xconnect vsi aaa

4. 验证配置

# 完成上述配置后,在PE 1上执行display l2vpn pw verbose命令,可以看到建立了两条BGP PW,状态为up。

[PE1] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.9          Remote Site: 2

    Signaling Protocol  : BGP

    Link ID             : 9          PW State : Up

    In Label            : 1295       Out Label: 1025

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x800000160000001

    Tunnel NHLFE IDs    : 1027

  Peer: 3.3.3.9          Remote Site: 3

    Signaling Protocol  : BGP

    Link ID             : 10         PW State : Up

    In Label            : 1296       Out Label: 1025

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x800000060000000

    Tunnel NHLFE IDs    : 1026

# 在PE 1上执行display l2vpn bgp verbose命令,可以看到从PE 2和PE 3接收到的VPLS标签块信息。

[PE1] display l2vpn bgp verbose

VSI Name: aaa

 Remote Site ID     : 2

 Offset             : 0

 RD                 : 1:1

 PW State           : Up

 Encapsulation      : BGP-VPLS

 MTU                : 1500

 Nexthop            : 2.2.2.9

 Local VC Label     : 1295

 Remote VC Label    : 1025

 Link ID            : 9

 Local Label Block  : 1293/10/0

 Remote Label Block : 1024/10/0

 Export Route Target: 1:1

 

 Remote Site ID     : 3

 Offset             : 0

 RD                 : 1:1

 PW State           : Up

 Encapsulation      : BGP-VPLS

 MTU                : 1500

 Nexthop            : 3.3.3.9

 Local VC Label     : 1296

 Remote VC Label    : 1025

 Link ID            : 10

 Local Label Block  : 1293/10/0

 Remote Label Block : 1024/10/0

 Export Route Target: 1:1

1.14.4  BGP自动发现LDP信令方式VPLS配置举例

1. 组网需求

·            CE 1、CE 2和CE 3分属于3个站点,同属于VPN 1;

·            PE 1、PE 2和PE 3通过服务实例将报文与VSI实例关联,以便更为灵活地匹配从AC接收到的报文:服务实例10用来匹配接口HundredGigE1/0/1接收到的VLAN Tag为100的报文,并通过VSI实例aaa转发;

·            在各个PE上配置VPLS,使得PE之间采用BGP协议自动发现邻居、采用LDP信令协议建立PW,通过PW连接各个CE。

2. 组网图

图1-10 BGP自动发现LDP信令方式VPLS配置组网图

3. 配置步骤

说明

进行下面配置之前,需要先全局关闭STP功能,或为每个VLAN映射一个MSTP实例,具体配置方法请参见“二层技术-以太网交换配置指导”中的“生成树”。

 

(1)       配置IGP协议、公网隧道,具体配置过程略。

(2)       配置PE 1

# 配置MPLS基本能力。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 1.1.1.9 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 1.1.1.9

[PE1] mpls ldp

[PE1-ldp] quit

# 在PE 1和PE 2、PE 1和PE 3之间建立IBGP连接,并配置通过BGP发布VPLS PE信息。

[PE1] bgp 100

[PE1-bgp-default] peer 2.2.2.9 as-number 100

[PE1-bgp-default] peer 2.2.2.9 connect-interface loopback 0

[PE1-bgp-default] peer 3.3.3.9 as-number 100

[PE1-bgp-default] peer 3.3.3.9 connect-interface loopback 0

[PE1-bgp-default] address-family l2vpn

[PE1-bgp-default-l2vpn] peer 2.2.2.9 enable

[PE1-bgp-default-l2vpn] peer 3.3.3.9 enable

[PE1-bgp-default-l2vpn] quit

[PE1-bgp-default] quit

# 开启L2VPN功能。

[PE1] l2vpn enable

# 配置VSI实例aaa采用BGP协议自动发现邻居,并采用LDP信令协议在PE 1和PE 2、PE 1和PE 3之间建立PW。

[PE1] vsi aaa

[PE1-vsi-aaa] auto-discovery bgp

[PE1-vsi-aaa-auto] route-distinguisher 1:1

[PE1-vsi-aaa-auto] vpn-target 1:1

[PE1-vsi-aaa-auto] signaling-protocol ldp

[PE1-vsi-aaa-auto-ldp] vpls-id 100:100

[PE1-vsi-aaa-auto-ldp] quit

[PE1-vsi-aaa-auto] quit

[PE1-vsi-aaa] quit

# 在接口HundredGigE1/0/1上创建服务实例,并绑定VSI实例aaa。

[PE1] interface hundredgige 1/0/1

[PE1-HundredGigE1/0/1] service-instance 10

[PE1-HundredGigE1/0/1-srv10] encapsulation s-vid 100

[PE1-HundredGigE1/0/1-srv10] xconnect vsi aaa

(3)       配置PE 2

# 配置MPLS基本能力。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 2.2.2.9 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 2.2.2.9

[PE2] mpls ldp

[PE2-ldp] quit

# 在PE 1和PE 2、PE 2和PE 3之间建立IBGP连接,并配置通过BGP发布VPLS PE信息。

[PE2] bgp 100

[PE2-bgp-default] peer 1.1.1.9 as-number 100

[PE2-bgp-default] peer 1.1.1.9 connect-interface loopback 0

[PE2-bgp-default] peer 3.3.3.9 as-number 100

[PE2-bgp-default] peer 3.3.3.9 connect-interface loopback 0

[PE2-bgp-default] address-family l2vpn

[PE2-bgp-default-l2vpn] peer 1.1.1.9 enable

[PE2-bgp-default-l2vpn] peer 3.3.3.9 enable

[PE2-bgp-default-l2vpn] quit

[PE2-bgp-default] quit

# 开启L2VPN功能。

[PE2] l2vpn enable

# 配置VSI实例aaa采用BGP协议自动发现邻居,并采用LDP信令协议在PE 1和PE 2、PE 2和PE 3之间建立PW。

[PE2] vsi aaa

[PE2-vsi-aaa] auto-discovery bgp

[PE2-vsi-aaa-auto] route-distinguisher 1:1

[PE2-vsi-aaa-auto] vpn-target 1:1

[PE2-vsi-aaa-auto] signaling-protocol ldp

[PE2-vsi-aaa-auto-ldp] vpls-id 100:100

[PE2-vsi-aaa-auto-ldp] quit

[PE2-vsi-aaa-auto] quit

[PE2-vsi-aaa] quit

# 在接口HundredGigE1/0/1上创建服务实例,并绑定VSI实例aaa。

[PE2] interface hundredgige 1/0/1

[PE2-HundredGigE1/0/1] service-instance 10

[PE2-HundredGigE1/0/1-srv10] encapsulation s-vid 100

[PE2-HundredGigE1/0/1-srv10] xconnect vsi aaa

(4)       配置PE 3

# 配置MPLS基本能力。

<PE3> system-view

[PE3] interface loopback 0

[PE3-LoopBack0] ip address 3.3.3.9 32

[PE3-LoopBack0] quit

[PE3] mpls lsr-id 3.3.3.9

[PE3] mpls ldp

[PE3-ldp] quit

# 在PE 1和PE 3、PE 2和PE 3之间建立IBGP连接,并配置通过BGP发布VPLS PE信息。

[PE3] bgp 100

[PE3-bgp-default] peer 1.1.1.9 as-number 100

[PE3-bgp-default] peer 1.1.1.9 connect-interface loopback 0

[PE3-bgp-default] peer 2.2.2.9 as-number 100

[PE3-bgp-default] peer 2.2.2.9 connect-interface loopback 0

[PE3-bgp-default] address-family l2vpn

[PE3-bgp-default-l2vpn] peer 1.1.1.9 enable

[PE3-bgp-default-l2vpn] peer 2.2.2.9 enable

[PE3-bgp-default-l2vpn] quit

[PE3-bgp-default] quit

# 开启L2VPN功能。

[PE3] l2vpn enable

# 配置VSI实例aaa采用BGP协议自动发现邻居,并采用LDP信令协议在PE 1和PE 3、PE 2和PE 3之间建立PW。

[PE3] vsi aaa

[PE3-vsi-aaa] auto-discovery bgp

[PE3-vsi-aaa-auto] route-distinguisher 1:1

[PE3-vsi-aaa-auto] vpn-target 1:1

[PE3-vsi-aaa-auto] signaling-protocol ldp

[PE3-vsi-aaa-auto-ldp] vpls-id 100:100

[PE3-vsi-aaa-auto-ldp] quit

[PE3-vsi-aaa-auto] quit

[PE3-vsi-aaa] quit

# 在接口HundredGigE1/0/1上创建服务实例,并绑定VSI实例aaa。

[PE3] interface hundredgige 1/0/1

[PE3-HundredGigE1/0/1] service-instance 10

[PE3-HundredGigE1/0/1-srv10] encapsulation s-vid 100

[PE3-HundredGigE1/0/1-srv10] xconnect vsi aaa

4. 验证配置

# 完成上述配置后,在PE 1上执行display l2vpn pw verbose命令,可以看到建立了两条PW,状态为up。

[PE1] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.9          VPLS ID: 100:100

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1555       Out Label: 1555

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x800000060000000

    Tunnel NHLFE IDs    : 1029

  Peer: 3.3.3.9          VPLS ID: 100:100

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1554       Out Label: 1416

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x800000160000001

    Tunnel NHLFE IDs    : 1030

# 在PE 1上执行display l2vpn ldp verbose命令,可以看到LDP协议通告的PW标签相关信息。

[PE1] display l2vpn ldp verbose

Peer: 2.2.2.9          VPLS ID: 100:100

  VSI Name: aaa

  PW State: Up

  PW Status Communication: Notification method

  PW ID FEC (Local/Remote):

    Local AII   : (1.1.1.9, 2.2.2.9)

    Remote AII  : (2.2.2.9, 1.1.1.9)

    PW Type     : VLAN/VLAN

    Group ID    : 0/0

    Label       : 1555/1555

    Control Word: Disabled/Disabled

    VCCV CV Type: -/-

    VCCV CC Type: -/-

    MTU         : 1500/1500

    PW Status   : PW forwarding/PW forwarding

 

Peer: 3.3.3.9          VPLS ID: 100:100

  VSI Name: aaa

  PW State: Up

  PW Status Communication: Notification method

  PW ID FEC (Local/Remote):

    Local AII   : (1.1.1.9, 3.3.3.9)

    Remote AII  : (3.3.3.9, 1.1.1.9)

    PW Type     : VLAN/VLAN

    Group ID    : 0/0

    Label       : 1554/1416

    Control Word: Disabled/Disabled

    VCCV CV Type: -/-

    VCCV CC Type: -/-

    MTU         : 1500/1500

    PW Status   : PW forwarding/PW forwarding

1.14.5  MPLS接入方式的H-VPLS配置举例

1. 组网需求

通过MPLS接入方式的H-VPLS来避免PE全连接,简化网络管理。H-VPLS采用的信令协议为LDP。

2. 组网图

图1-11 MPLS接入方式的H-VPLS配置组网图

3. 配置步骤

说明

进行下面配置之前,需要先全局关闭STP功能,或为每个VLAN映射一个MSTP实例,具体配置方法请参见“二层技术-以太网交换配置指导”中的“生成树”。

 

(1)       配置IGP协议、公网隧道,具体配置过程略。

(2)       配置UPE

# 配置MPLS基本能力。

<UPE> system-view

[UPE] interface loopback 0

[UPE-LoopBack0] ip address 1.1.1.9 32

[UPE-LoopBack0] quit

[UPE] mpls lsr-id 1.1.1.9

[UPE] mpls ldp

[UPE-ldp] quit

# 开启L2VPN功能。

[UPE] l2vpn enable

# 配置VSI实例aaa采用LDP信令协议,并在UPE和NPE 1之间建立U-PW。

[UPE] vsi aaa

[UPE-vsi-aaa] pwsignaling ldp

[UPE-vsi-aaa-ldp] peer 2.2.2.9 pw-id 500

[UPE-vsi-aaa-ldp-2.2.2.9-500] quit

[UPE-vsi-aaa-ldp] quit

[UPE-vsi-aaa] quit

# 在接口HundredGigE1/0/1上创建服务实例10,并绑定VSI实例aaa。

[UPE] interface hundredgige 1/0/1

[UPE-HundredGigE1/0/1] service-instance 10

[UPE-HundredGigE1/0/1-srv10] encapsulation s-vid 100

[UPE-HundredGigE1/0/1-srv10] xconnect vsi aaa

(3)       配置NPE 1

# 配置MPLS基本能力。

<NPE1> system-view

[NPE1] interface loopback 0

[NPE1-LoopBack0] ip address 2.2.2.9 32

[NPE1-LoopBack0] quit

[NPE1] mpls lsr-id 2.2.2.9

[NPE1] mpls ldp

[NPE1–ldp] quit

# 开启L2VPN功能。

[NPE1] l2vpn enable

# 配置VSI实例aaa采用LDP信令协议,并在UPE和NPE 1之间建立U-PW,在NPE 1和NPE 2、NPE 1和NPE 3之间建立N-PW。

[NPE1] vsi aaa

[NPE1-vsi-aaa] pwsignaling ldp

[NPE1-vsi-aaa-ldp] peer 1.1.1.9 pw-id 500 no-split-horizon

[NPE1-vsi-aaa-ldp-1.1.1.9-500] quit

[NPE1-vsi-aaa-ldp] peer 3.3.3.9 pw-id 500

[NPE1-vsi-aaa-ldp-3.3.3.9-500] quit

[NPE1-vsi-aaa-ldp] peer 4.4.4.9 pw-id 500

[NPE1-vsi-aaa-ldp-4.4.4.9-500] quit

[NPE1-vsi-aaa-ldp] quit

[NPE1-vsi-aaa] quit

(4)       配置NPE 2

# 配置MPLS基本能力。

<NPE2> system-view

[NPE2] interface loopback 0

[NPE2-LoopBack0] ip address 3.3.3.9 32

[NPE2-LoopBack0] quit

[NPE2] mpls lsr-id 3.3.3.9

[NPE2] mpls ldp

[NPE2–ldp] quit

# 开启L2VPN功能。

[NPE2] l2vpn enable

# 配置VSI实例aaa采用LDP信令协议,并在NPE 2和NPE 1、NPE 2和NPE 3之间建立N-PW。

[NPE2] vsi aaa

[NPE2-vsi-aaa] pwsignal ldp

[NPE2-vsi-aaa-ldp] peer 2.2.2.9 pw-id 500

[NPE2-vsi-aaa-ldp-2.2.2.9-500] quit

[NPE2-vsi-aaa-ldp] peer 4.4.4.9 pw-id 500

[NPE2-vsi-aaa-ldp-4.4.4.9-500] quit

[NPE2-vsi-aaa-ldp] quit

[NPE2-vsi-aaa] quit

# 在接口HundredGigE1/0/1上创建服务实例10,并绑定VSI实例aaa。

[NPE2] interface hundredgige 1/0/1

[NPE2-HundredGigE1/0/1] service-instance 10

[NPE2-HundredGigE1/0/1-srv10] encapsulation s-vid 100

[NPE2-HundredGigE1/0/1-srv10] xconnect vsi aaa

[NPE2-HundredGigE1/0/1-srv10] quit

[NPE2-HundredGigE1/0/1] quit

(5)       配置NPE 3

# 配置MPLS基本能力。

<NPE3> system-view

[NPE3] interface loopback 0

[NPE3-LoopBack0] ip address 4.4.4.9 32

[NPE3-LoopBack0] quit

[NPE3] mpls lsr-id 4.4.4.9

[NPE3] mpls ldp

[NPE3–ldp] quit

# 开启L2VPN功能。

[NPE3] l2vpn enable

# 配置VSI实例aaa采用LDP信令协议,并在NPE 3和NPE 1、NPE 3和NPE 2之间建立N-PW。

[NPE3] vsi aaa

[NPE3-vsi-aaa] pwsignal ldp

[NPE3-vsi-aaa-ldp] peer 2.2.2.9 pw-id 500

[NPE3-vsi-aaa-ldp-2.2.2.9-500] quit

[NPE3-vsi-aaa-ldp] peer 3.3.3.9 pw-id 500

[NPE3-vsi-aaa-ldp-3.3.3.9-500] quit

[NPE3-vsi-aaa-ldp] quit

[NPE3-vsi-aaa] quit

# 在接口HundredGigE1/0/1上创建服务实例10,并绑定VSI实例aaa。

[NPE3] interface hundredgige 1/0/1

[NPE3-HundredGigE1/0/1] service-instance 10

[NPE3-HundredGigE1/0/1-srv10] encapsulation s-vid 100

[NPE3-HundredGigE1/0/1-srv10] xconnect vsi aaa

[NPE3-HundredGigE1/0/1-srv10] quit

[NPE3-HundredGigE1/0/1] quit

4. 验证配置

完成上述配置后,在各个PE上执行display l2vpn pw verbose命令,可以看到建立了PW连接,状态为up。

[UPE] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1277       Out Label: 1277

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x460000000

    Tunnel NHLFE IDs    : 1030

[NPE1] display l2vpn pw verbose

VSI Name: aaa

  Peer: 1.1.1.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1277       Out Label: 1277

    MTU                 : 1500

    PW Attributes       : Main, No-split-horizon

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x460000000

    Tunnel NHLFE IDs    : 1030

  Peer: 3.3.3.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1276       Out Label: 1275

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x560000001

    Tunnel NHLFE IDs    : 1031

  Peer: 4.4.4.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 10          PW State : Up

    In Label            : 1278       Out Label: 1279

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x570000001

    Tunnel NHLFE IDs    : 1032

[NPE2] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1275       Out Label: 1276

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x660000000

    Tunnel NHLFE IDs    : 1031

  Peer: 4.4.4.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1277       Out Label: 1277

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x670000000

    Tunnel NHLFE IDs    : 1032

[NPE3] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1279       Out Label: 1278

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x660000000

    Tunnel NHLFE IDs    : 1031

  Peer: 3.3.3.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1277       Out Label: 1277

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x670000000

    Tunnel NHLFE IDs    : 1032

1.14.6  H-VPLS的UPE双归属配置举例

1. 组网需求

为了提高H-VPLS网络的可靠性,UPE与NPE 1和NPE 2同时建立U-PW。UPE与NPE 1之间的U-PW为主链路;UPE与NPE 2之间的U-PW为备份链路。当UPE与NPE 1之间的U-PW正常工作时,通过该U-PW转发用户报文;当UPE与NPE 1之间的U-PW出现故障时,通过UPE与NPE 2之间的U-PW转发用户报文。

VPLS采用的信令协议为LDP。

2. 组网图

图1-12 配置H-VPLS的UPE双归属组网图

3. 配置步骤

说明

进行下面配置之前,需要先全局关闭STP功能,或为每个VLAN映射一个MSTP实例,具体配置方法请参见“二层技术-以太网交换配置指导”中的“生成树”。

 

(1)       配置IGP协议、公网隧道,具体配置过程略。

(2)       配置UPE

# 配置MPLS基本能力。

<UPE> system-view

[UPE] interface loopback 0

[UPE-LoopBack0] ip address 1.1.1.1 32

[UPE-LoopBack0] quit

[UPE] mpls lsr-id 1.1.1.1

[UPE] mpls ldp

[UPE-ldp] quit

# 开启L2VPN功能。

[UPE] l2vpn enable

# 配置VSI实例aaa采用LDP信令协议,并在UPE和NPE 1之间建立主PW、在UPE和NPE 2之间建立备份PW。

[UPE] vsi aaa

[UPE-vsi-aaa] pwsignaling ldp

[UPE-vsi-aaa-ldp] peer 2.2.2.2 pw-id 500

[UPE-vsi-aaa-ldp-2.2.2.2-500] backup-peer 3.3.3.3 pw-id 500

[UPE-vsi-aaa-ldp-2.2.2.2-500-backup] quit

[UPE-vsi-aaa-ldp-2.2.2.2-500] quit

[UPE-vsi-aaa-ldp] quit

[UPE-vsi-aaa] quit

# 在接入CE 1的接口HundredGigE1/0/1上创建服务实例,并绑定VSI实例aaa。

[UPE] interface hundredgige 1/0/1

[UPE-HundredGigE1/0/1] service-instance 1000

[UPE-HundredGigE1/0/1-srv1000] encapsulation s-vid 10

[UPE-HundredGigE1/0/1-srv1000] xconnect vsi aaa

[UPE-HundredGigE1/0/1-srv1000] quit

# 在接入CE 2的接口HundredGigE1/0/2上创建服务实例,并绑定VSI实例aaa。

[UPE] interface hundredgige 1/0/2

[UPE-HundredGigE1/0/2] service-instance 1000

[UPE-HundredGigE1/0/2-srv1000] encapsulation s-vid 11

[UPE-HundredGigE1/0/2-srv1000] xconnect vsi aaa

[UPE-HundredGigE1/0/2-srv1000] quit

(3)       配置NPE 1

# 配置MPLS基本能力。

<NPE1> system-view

[NPE1] interface loopback 0

[NPE1-LoopBack0] ip address 2.2.2.2 32

[NPE1-LoopBack0] quit

[NPE1] mpls lsr-id 2.2.2.2

[NPE1] mpls ldp

[NPE1–ldp] quit

# 开启L2VPN功能。

[NPE1] l2vpn enable

# 配置VSI实例aaa采用LDP信令协议,并在UPE和NPE 1、NPE 1和NPE 2、NPE 1和NPE 3之间建立PW。

[NPE1] vsi aaa

[NPE1-vsi-aaa] pwsignaling ldp

[NPE1-vsi-aaa-ldp] peer 1.1.1.1 pw-id 500 no-split-horizon

[NPE1-vsi-aaa-ldp-1.1.1.1-500] quit

[NPE1-vsi-aaa-ldp] peer 3.3.3.3 pw-id 500

[NPE1-vsi-aaa-ldp-3.3.3.3-500] quit

[NPE1-vsi-aaa-ldp] peer 4.4.4.4 pw-id 500

[NPE1-vsi-aaa-ldp-4.4.4.4-500] quit

[NPE1-vsi-aaa-ldp] quit

[NPE1-vsi-aaa] quit

(4)       配置NPE 2

# 配置MPLS基本能力。

<NPE2> system-view

[NPE2] interface loopback 0

[NPE2-LoopBack0] ip address 3.3.3.3 32

[NPE2-LoopBack0] quit

[NPE2] mpls lsr-id 3.3.3.3

[NPE2] mpls ldp

[NPE2–ldp] quit

# 开启L2VPN功能。

[NPE2] l2vpn enable

# 配置VSI实例aaa采用LDP信令协议,并在UPE和NPE 2、NPE 1和NPE 2、NPE 2和NPE 3之间建立PW。

[NPE2] vsi aaa

[NPE2-vsi-aaa] pwsignaling ldp

[NPE2-vsi-aaa-ldp] peer 1.1.1.1 pw-id 500 no-split-horizon

[NPE2-vsi-aaa-ldp-1.1.1.1-500] quit

[NPE2-vsi-aaa-ldp] peer 2.2.2.2 pw-id 500

[NPE2-vsi-aaa-ldp-2.2.2.2-500] quit

[NPE2-vsi-aaa-ldp] peer 4.4.4.4 pw-id 500

[NPE2-vsi-aaa-ldp-4.4.4.4-500] quit

[NPE2-vsi-aaa-ldp] quit

[NPE2-vsi-aaa] quit

(5)       配置NPE 3

# 配置MPLS基本能力。

<NPE3> system-view

[NPE3] interface loopback 0

[NPE3-LoopBack0] ip address 4.4.4.4 32

[NPE3-LoopBack0] quit

[NPE3] mpls lsr-id 4.4.4.4

[NPE3] mpls ldp

[NPE3–ldp] quit

# 开启L2VPN功能。

[NPE3] l2vpn enable

# 配置VSI实例aaa采用LDP信令协议,并在NPE 1和NPE 3、NPE 2和NPE 3之间建立PW。

[NPE3] vsi aaa

[NPE3-vsi-aaa] pwsignaling ldp

[NPE3-vsi-aaa-ldp] peer 2.2.2.2 pw-id 500

[NPE3-vsi-aaa-ldp-2.2.2.2-500] quit

[NPE3-vsi-aaa-ldp] peer 3.3.3.3 pw-id 500

[NPE3-vsi-aaa-ldp-3.3.3.3-500] quit

[NPE3-vsi-aaa-ldp] quit

[NPE3-vsi-aaa] quit

# 在接入CE 3的接口HundredGigE1/0/1上创建服务实例,并绑定VSI实例aaa。

[NPE3] interface hundredgige 1/0/1

[NPE3-HundredGigE1/0/1] service-instance 1000

[NPE3-HundredGigE1/0/1-srv1000] encapsulation s-vid 10

[NPE3-HundredGigE1/0/1-srv1000] xconnect vsi aaa

[NPE3-HundredGigE1/0/1-srv1000] quit

4. 验证配置

完成上述配置后,在各个PE上执行display l2vpn pw verbose命令,可以看到PW连接,状态为up。

[UPE] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.2          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1151       Out Label: 1279

    Wait to Restore Time: 0 sec

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x260000002

    Tunnel NHLFE IDs    : 1027

  Peer: 3.3.3.3          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Blocked

    In Label            : 1150       Out Label: 1279

    MTU                 : 1500

    PW Attributes       : Backup

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x360000003

    Tunnel NHLFE IDs    : 1025

[NPE1] display l2vpn pw verbose

VSI Name: aaa

  Peer: 1.1.1.1          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1279       Out Label: 1151

    MTU                 : 1500

    PW Attributes       : Main, No-split-horizon

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x60000000

    Tunnel NHLFE IDs    : 1026

  Peer: 3.3.3.3          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1280       Out Label: 1290

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x160000005

    Tunnel NHLFE IDs    : 1027

  Peer: 4.4.4.4          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 10         PW State : Up

    In Label            : 1278       Out Label: 1279

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x160000001

    Tunnel NHLFE IDs    : 1028

[NPE2] display l2vpn pw verbose

VSI Name: aaa

  Peer: 1.1.1.1          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1279       Out Label: 1150

    MTU                 : 1500

    PW Attributes       : Main, No-split-horizon

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x60000000

    Tunnel NHLFE IDs    : 1026

  Peer: 2.2.2.2          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1290       Out Label: 1280

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x160000008

    Tunnel NHLFE IDs    : 1027

  Peer: 4.4.4.4          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 10         PW State : Up

    In Label            : 1278       Out Label: 1278

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x160000001

    Tunnel NHLFE IDs    : 1028

[NPE3] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.2          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1279       Out Label: 1278

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x60000000

    Tunnel NHLFE IDs    : 1026

  Peer: 3.3.3.3          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1278       Out Label: 1278

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x160000001

    Tunnel NHLFE IDs    : 1027

 

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!