选择区域语言: EN CN HK

07-MPLS配置指导

09-MPLS L2VPN配置

本章节下载  (469.94 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500X-AF/Configure/Operation_Manual/H3C_S12500X-AF_CG(R320x)-6W100/07/201905/1181941_30005_0.htm

09-MPLS L2VPN配置


1 MPLS L2VPN

MPLS L2VPN既可以提供点到点的连接,也可以提供多点间的连接。本章只介绍提供点到点连接的MPLS L2VPN技术。提供多点间连接的MPLS L2VPN技术,请参见“MPLS配置指导”中的“VPLS”。

1.1  MPLS L2VPN简介

MPLS L2VPN是基于MPLS的二层VPN(Virtual Private Network,虚拟专用网络)技术,是PWE3(Pseudo Wire Emulation Edge-to-Edge,边缘到边缘的伪线仿真)的一种实现方式。MPLS L2VPN将用户的二层数据(如以太网数据帧、ATM信元等)封装成可以在IP或MPLS网络中传送的分组,通过IP路径或MPLS隧道转发,接收端解封装分组后恢复原来的二层数据,从而实现用户二层数据跨越MPLS或IP网络在不同站点间透明地传送。

1.1.1  基本概念

1. CE

CE(Customer Edge,用户网络边缘)设备是直接与服务提供商网络相连的用户网络侧设备。

2. PE

PE(Provider Edge,服务提供商网络边缘)设备是与CE相连的服务提供商网络侧设备。PE主要负责VPN业务的接入,完成报文从用户网络到公网隧道、从公网隧道到用户网络的映射与转发。

3. AC

AC(Attachment Circuit,接入电路)是连接CE和PE的物理电路或虚拟电路,例如Frame Relay的DLCI、ATM的VPI/VCI、Ethernet接口、VLAN、物理接口上的PPP连接。

4. PW

PW(Pseudowire,伪线)是两个PE之间的虚拟双向连接。MPLS PW由一对方向相反的单向LSP构成。

5. 公网隧道

公网隧道(Tunnel)是穿越IP或MPLS骨干网、用来承载PW的隧道。一条公网隧道可以承载多条PW,公网隧道可以是LSP、MPLS TE、GRE隧道等。

6. 交叉连接

交叉连接(Cross connect)是由两条物理电路或虚拟电路串连而成的一条连接,从一条物理、虚拟电路收到的报文直接交换到另一条物理、虚拟电路转发。交叉连接包括三种方式:AC到AC交叉连接、AC到PW交叉连接、PW到PW交叉连接。

7. Site ID

Site ID是用户网络站点在VPN内的唯一标识。不同VPN内站点的Site ID可以相同。

8. RD

RD(Route Distinguisher,路由标识符)用来区分不同VPN内Site ID相同的站点。在Site ID前增加RD,通过RD+Site ID可以唯一标识网络中的一个站点。

9. 标签块

标签块是一组标签的集合,包含以下参数:

·            LB(Label Base,初始标签):标签块的标签初始值。该值为PE设备自动选取,不可手动修改。

·            LR(Label Range,标签范围):标签块包含的标签数目。LB和LR确定了标签块中包含哪些标签。例如,LB为1000、LR为5,则该标签块包含的标签为1000~1004。

·            LO(Label-block Offset,标签块偏移):VPN网络中站点的数量增加,原有的标签块大小无法满足要求时,PE无需撤销原有的标签块,只要在原有标签块的基础上再分配一个新的标签块就可以扩大标签范围,满足扩展需要。在这种情况下,PE通过LO来标识某个标签块在所有为站点分配的标签块中的位置,并根据LO来判断从哪个标签块中分配标签。LO的取值为之前分配的所有标签块大小的总合。例如,PE为站点分配的第一个标签块的LR为10、LO为0,则第二个标签块的LO为10;如果第二个标签块的LR为20,则第三个标签块的LO为30。

标签块通过LB/LO/LR来表示,即LB为1000、LO为10、LR为5的标签块可以表示为1000/10/5。

假设,某个VPN网络中原有站点数量为10,PE为其分配第一个标签块LB1/0/10。站点数量增加到25时,PE可以保留分配的第一个标签块,并补充分配第二个标签块LB2/10/15,从而满足VPN网络扩展的要求。其中,LB1和LB2为PE随机选取的初始标签值。

10. VPN target

MPLS L2VPN使用BGP扩展团体属性——VPN Target(也称为Route Target)来控制BGP L2VPN信息的发布。

PE上的VPN target属性分为以下两种,每一种都可以包括多个属性值:

·            Export target属性:本地PE在通过BGP的Update消息将L2VPN信息(如本地Site ID、RD、标签块等)发送给远端PE时,将Update消息中携带的VPN target属性设置为Export target。

·            Import target属性:PE收到其它PE发布的Update消息时,将消息中携带的VPN target属性与本地配置的Import target属性进行比较,只有二者中存在相同的属性值时,才会接收该消息中的L2VPN信息。

也就是说,VPN target属性定义了本地发送的L2VPN信息可以为哪些PE所接收,PE可以接收哪些远端PE发送来的L2VPN信息。

1.1.2  基本网络架构

MPLS L2VPN的组网架构分为远程连接和本地交换两种。

图1-1所示,MPLS L2VPN的远程连接组网是指通过穿越IP或MPLS骨干网络的PW连接两端的用户网络。

图1-1 远程连接组网

 

图1-2所示,本地交换是MPLS L2VPN提供的一种比较特殊的连接,它将同一个用户网络两个站点的CE连接到同一个PE上,两个CE直接通过PE进行用户报文的交换。

图1-2 本地交换组网图

 

当前设备不支持本地交换组网方式。

1.1.3  远程连接的配置方法

要想通过MPLS L2VPN的远程连接转发报文,需要完成以下工作:

(1)       建立公网隧道,公网隧道用来承载PE之间的一条或多条PW。

(2)       建立用来传送特定用户网络报文的PW,PW标签标识了报文所属的用户网络。

(3)       建立用来连接CE和PE的AC,AC的报文匹配规则(显式配置或隐含的规则)决定了从CE接收到的哪些报文属于一个特定的用户网络。

(4)       将AC和PW关联,以便PE确定从AC接收到的报文向哪条PW转发,从PW接收到的报文向哪条AC转发。

完成上述配置后,PE从AC接收到用户网络的报文后,根据AC关联的PW为报文封装PW标签,并通过公网隧道将报文转发给远端PE;远端PE从公网隧道接收到报文后,根据PW标签判断报文所属的PW,并将还原后的原始报文转发给与该PW关联的AC。

1. 建立公网隧道

公网隧道用来承载PW,可以是LSP隧道、MPLS TE隧道和GRE隧道等。不同隧道的建立方式不同,详细介绍请参见相关手册。

当两个PE之间存在多条公网隧道时,可以通过配置隧道策略,确定如何选择隧道。隧道策略的详细介绍,请参见“MPLS配置指导”中的“隧道策略”。

说明

如果PW建立在LSP或MPLS TE隧道之上,则PW上传送的报文将包括两层标签:内层标签为PW标签,用来决定报文所属的PW,从而将报文转发给正确的CE;外层标签为公网LSP或MPLS TE隧道标签,用来保证报文在MPLS网络正确传送。

 

2. 建立PW

建立PW是指两端的PE设备分别为对方分配PW标签,以便建立方向相反的一对单向LSP。

PW的建立方式有以下几种:

·            静态方式

静态方式建立PW是指在两端的PE上分别手工指定远端PE地址、PW的入标签、出标签等信息,以便建立PW。采用静态方式建立的PW,称为静态PW。

采用此方式时,不需要使用PW信令协议传递PW标签等信息,消耗的网络资源比较少,但是需要手工在两端PE上配置入标签和出标签,配置比较复杂。

·            LDP方式

LDP方式建立PW是指在两端的PE上分别手工指定远端PE地址后,通过LDP协议向该远端PE通告本端PE为PW分配的PW标签等信息,以便建立PW。采用LDP方式建立的PW,称为LDP PW。

为了在PE之间交换PW和PW标签的绑定关系,LDP定义了一种新的FEC类型——PW ID FEC。该FEC通过PW ID和PW type来标识一条PW。其中,PW ID为PW在两个PE之间的标识;PW type表明PW上传送数据的封装类型,如ATM、帧中继、Ethernet、VLAN等。

PE发送标签映射消息时,在消息中携带PW ID FEC及相应的PW标签,就可以将PE为该PW分配的PW标签通告给远端PE。两端PE均收到对端通告的PW标签后,便成功在这两个PE之间建立起一条PW。

与静态方式相比,LDP方式配置比较简单,但是消耗的网络资源比较多。

·            BGP方式

BGP方式建立PW是指通过BGP协议通告本端PE分配的PW标签块等信息,以便远端PE自动发现该PE,并与其建立PW。采用BGP方式建立的PW,称为BGP PW。

采用BGP方式建立PW的过程为:PE将自己分配的标签块通过扩展的BGP Update消息通告给同一个VPN内的所有PE,每个PE都根据其他PE通告的标签块计算PW出标签、根据自己分配的标签块计算PW入标签。两端PE分别计算出PW入标签和PW出标签后,便在二者之间建立了BGP PW。

BGP方式具有如下特点:

¡  无需手工指定远端PE的地址,在通过BGP发布标签块信息的同时可以自动发现远端PE,简化了配置。

¡  通过发布标签块信息可以实现一次为多个PW分配标签,减少了VPN部署和扩容时的配置工作量,但是耗费的标签资源较多。

·            CCC方式

CCC(Circuit Cross Connect,电路交叉连接)方式建立PW是指通过在PE设备上手工指定入标签和出标签而建立一条静态连接。CCC方式建立的PW称为CCC PW,或CCC远程连接。

CCC远程连接不需要公网隧道来承载,它通过在PE之间的P设备上配置两条方向相反的静态LSP,来实现报文跨越公网传送。通过CCC远程连接转发二层用户报文时,只需为用户报文封装一层标签。

CCC远程连接对P设备上LSP的使用是独占性的。P设备上的LSP只用于传递这个CCC远程连接的数据,不能用于其他连接,也不能用于MPLS L3VPN。

3. 建立AC

AC是CE与PE之间的虚拟电路。建立AC就是在PE和CE上配置链路层协议,以便在PE和CE之间建立链路层连接。

AC在PE上的表现形式为二层以太网接口或二层聚合接口下的以太网服务实例,将一个二层以太网接口或二层聚合接口上接收到的、符合以太网服务实例匹配规则的报文关联到同一条PW。这种方式为以太网帧关联PW提供了更加灵活的匹配方法。如果服务实例匹配的是VLAN tag,则该VLAN在接口范围内唯一,而不是整设备范围内唯一。

说明

VLAN整设备范围内唯一是指不区分接口,无论从哪个接口接收到的报文,只要Tag相同就关联到同一条PW;VLAN接口范围内唯一是指从不同接口接收到的带有相同Tag的报文,可以关联到不同的PW。

 

4. 将AC和PW关联

通过命令行将AC连接对应的以太网服务实例与PW关联,即可实现从该AC接收到的报文通过关联的PW转发,从关联的PW上接收到的报文通过该AC转发。

1.1.4  PW数据封装类型

MPLS L2VPN可以在PW上传递不同数据链路层协议的二层用户报文。为二层报文封装PW标签前,PE对不同链路层协议的二层报文的处理方式有所不同。PW数据封装类型(PW type)用来标识PE对二层报文的处理方式。

1. PW数据封装类型与AC链路类型的对应关系

PW数据封装类型与AC的链路类型(PE—CE之间的链路类型)密切相关,其对应关系如表1-1所示。

表1-1 AC链路类型及PW数据封装类型对应关系表

AC链路类型

PW数据封装类型

以太网

Ethernet

VLAN

2. Ethernet over MPLS

Ethernet over MPLS是指利用MPLS L2VPN连接以太网,通过PW在MPLS骨干网上传送Ethernet报文。

Ethernet over MPLS对应的PW数据封装类型有两种:

·            Ethernet数据封装类型下,PW上传输的帧不能带服务提供商网络为了区分用户而要求用户添加的P-Tag,该Tag又称为服务定界符。对于CE侧的报文,如果PE从CE收到带有P-Tag的报文,则将其去除后再添加PW标签和公网隧道标签转发;如果从CE收到不带P-Tag的报文,则直接添加PW标签和公网隧道标签后转发。对于PE发送给CE的报文,如果ac interface命令配置的接入模式为VLAN,则添加P-Tag后转发给CE;如果配置的接入模式为Ethernet,则不添加P-Tag,直接转发给CE;不允许重写或去除已经存在的任何Tag。

·            VLAN数据封装类型下,PW上传输的帧必须带P-Tag。对于CE侧的报文,PE从CE收到带有P-Tag的报文后,如果远端PE不要求Ingress改写P-Tag,则保留P-Tag,如果远端PE要求Ingress改写P-Tag,则将P-Tag改写为远端PE期望的VLAN Tag(Tag可能是值为0的空Tag),再添加PW标签和公网隧道标签后转发;从CE收到不带P-Tag的报文后,如果远端PE不要求Ingress改写P-Tag,则添加值为0的空P-Tag,如果远端PE要求Ingress改写P-Tag,则添加一个远端PE期望的VLAN Tag(Tag可能是值为0的空Tag)后,再添加PW标签和公网隧道标签后转发。对于PE发送给CE的报文,如果ac interface命令配置的接入模式为VLAN,转发给CE时重写或保留P-Tag;如果配置的接入模式为Ethernet,则去除P-Tag后转发给CE。

Ethernet over MPLS有如下几种方式:

·            VLAN模式

通过命令行将三层以太网子接口与PW关联。这样,接收到的所有属于特定VLAN的报文都通过关联的PW传送到远端PE,远端PE可以根据连接的用户网络的需要修改VLAN tag。缺省情况下,VLAN模式中PW的数据封装类型为VLAN。

·            灵活匹配模式

通过命令行将以太网服务实例与PW关联,通过以太网服务实例的报文匹配规则(如接口接收到的所有报文、所有携带VLAN Tag的报文和所有不携带VLAN Tag的报文等),灵活匹配来自用户网络的报文。从接口接收到的、符合报文匹配规则的报文,将通过关联的PW传送到远端PE。缺省情况下,灵活匹配模式中PW的数据封装类型为VLAN。

在灵活匹配模式下,通过配置匹配规则也可以实现上述的端口模式和VLAN模式。

1.1.5  控制字功能

控制字字段位于MPLS标签栈和二层数据之间,用来携带额外的二层数据帧的控制信息,如序列号等。控制字具有如下功能:

·            避免报文乱序:在多路径转发的情况下,报文有可能产生乱序,此时可以通过控制字的序列号字段对报文进行排序重组。

·            指示净载荷长度:如果PW上传送报文的净载荷长度小于64字节,则需要对报文进行填充,以避免报文发送失败。此时,通过控制字的载荷长度字段可以确定原始载荷的长度,以便从填充后的报文中正确获取原始的报文载荷。

对于某些PW数据封装类型(如Ethernet、VLAN),控制字字段是可选的,由两端的配置共同决定是否携带控制字:如果两端PE上都使能了控制字功能,则报文中携带控制字字段;否则,报文中不携带控制字字段。

1.1.6  PW冗余保护

如果两个CE之间只存在一条PW,则当PE节点、PE与CE之间的链路、或PE之间的PW出现故障时,CE之间将无法通信。PW冗余保护功能通过部署主备两条PW,实现当主PW出现故障后,将流量立即切换到备份PW,使得流量转发得以继续。目前,只有静态PW和LDP PW支持PW冗余保护功能。

图1-3所示,在两个CE之间建立两条PW链路,正常情况下,CE使用主PW与远端CE通信;当PE 1检测出到PE 2的PW不可用(可能是PE 2节点故障,也可能是PW故障,或PE 2与CE 2之间的链路故障),PE 1将启用备份PW,通过备份PW将CE 1的报文转发给PE 3,再由PE 3转发给CE 2。CE 2接收到报文后,通过更新MAC地址表项等方式将发送给CE 1的报文切换到备份PW转发,从而保证通信不会中断。

图1-3 MPLS L2VPN的PW冗余保护

 

MPLS L2VPN根据控制平面的LDP会话状态,或者数据平面连通性检测结果等来判断当前使用的PW是否可以继续使用。在当前使用的PW不可用的情况下,将流量切换到备用的另一条PW上。在以下情况下,将启用备份PW:

·            承载主PW的公网隧道被拆除或通过BFD等检测机制检测到公网隧道出现故障,导致主PW的状态变为down;

·            控制平面拆除主PW(如主PW两端PE之间的LDP会话down导致主PW被删除),或利用BFD等链路检测机制检测到主PW故障;

·            执行命令手工切换主备PW。

主备PW的状态分为Active和Standby。PE根据上述条件确定本地主备PW的状态。

·            Active:表示该PW可以用于业务传送。

·            Standby:表示该PW处于备份状态,不能用于业务传送。

对于LDP PW,PW两端的PE通过LDP通告消息协商主备PW的状态。在主从操作模式下,其中一个PE作为主节点,另一个PE作为从节点。主节点决定了本地PW的Active状态、Standby状态后,通过LDP通知消息将该状态通告给从节点。从节点接收到主节点的LDP通知消息后,保持本地的PW状态与主节点一致,从而保证主、从节点均在相同的、处于Active状态的PW上传送客户业务。

1.2  MPLS L2VPN配置任务简介

1.2.1  远程连接配置任务简介

建立远程连接的配置任务如下:

(1)       开启L2VPN功能

(2)       配置AC

配置以太网服务实例

(3)       配置交叉连接

(4)       配置PW

请在静态PW、LDP PW、BGP PW和CCC远程连接中至少选择一项进行配置:

¡  (可选)配置PW模板

¡  配置静态PW

¡  配置LDP PW

¡  配置BGP PW

¡  配置CCC远程连接

(5)       配置AC与交叉连接关联

(6)       (可选)提高MPLS L2VPN网络可靠性

配置PW冗余保护

(7)       (可选)开启L2VPN告警功能

1.3  MPLS L2VPN配置准备

在配置MPLS L2VPN前,需要完成以下任务:

·            配置IGP(Interior Gateway Protocol,内部网关协议),实现骨干网的IP连通性。

·            配置MPLS基本功能、LDP、GRE或MPLS TE等,在骨干网上建立公网隧道。

1.4  开启L2VPN功能

1. 配置准备

执行本配置前,需要先通过mpls lsr-id命令配置本节点的LSR ID,并在PE连接公网的接口上通过mpls enable命令使能该接口的MPLS能力。mpls lsr-id命令和mpls enable命令的详细介绍,请参见“MPLS命令参考”中的“MPLS基础”。

2. 配置步骤

(1)       进入系统视图。

system-view

(2)       开启L2VPN功能。

l2vpn enable

缺省情况下,L2VPN功能处于关闭状态。

1.5  配置以太网服务实例

1. 功能简介

PE通过二层以太网接口或二层聚合接口连接CE时,可以配置以太网服务实例,以便精确地匹配属于AC的报文。

2. 配置限制和指导

配置以太网服务实例的报文匹配规则时需要注意的事项请参见“MPLS命令参考”中的“MPLS L2VPN”。

3. 配置步骤

(1)       进入系统视图。

system-view

(2)       进入接口视图。

¡  进入二层以太网接口视图。

interface interface-type interface-number

¡  进入二层聚合接口视图。

interface bridge-aggregation interface-number

(3)       创建以太网服务实例,并进入以太网服务实例视图。

service-instance instance-id

(4)       配置以太网服务实例的报文匹配规则。

¡  匹配报文的外层VLAN tag。

encapsulation s-vid vlan-id-list [ only-tagged ]

¡  同时匹配报文的外层和内层VLAN tag。

encapsulation s-vid vlan-id-list c-vid vlan-id

¡  匹配携带VLAN tag的所有报文。

encapsulation tagged

¡  匹配未匹配到接口上其他以太网服务实例的所有报文。

encapsulation default

同一个接口上最多只能有一个服务实例采用缺省的报文匹配规则。

如果接口上只存在一个配置了encapsulation default规则的以太网服务实例,则该接口上的所有报文都匹配该以太网服务实例。

缺省情况下,未配置报文匹配规则。

1.6  配置交叉连接

(1)       进入系统视图。

system-view

(2)       创建一个交叉连接组,并进入交叉连接组视图。

xconnect-group group-name

(3)       (可选)配置交叉连接组的描述信息。

description text

缺省情况下,未配置交叉连接组的描述信息。

(4)       (可选)开启交叉连接组。

undo shutdown

缺省情况下,交叉连接组处于开启状态。

(5)       创建一个交叉连接,并进入交叉连接视图。

connection connection-name

(6)       (可选)配置PW的MTU值。

mtu size

缺省情况下,PW的MTU值为1500字节。

如果采用LDP信令协议建立PW,则要求PW两端的PE上为PW配置相同的MTU值。否则,PW无法up。

1.7  配置PW

1.7.1  配置PW模板

1. 功能简介

在PW模板中可以指定PW的属性,如PW的数据封装类型、是否使用控制字等。具有相同属性的PW可以通过引用相同的PW模板,实现对PW属性的配置,从而简化配置。

2. 配置步骤

(1)       进入系统视图。

system-view

(2)       创建PW模板,并进入PW模板视图。

pw-class class-name

(3)       开启控制字功能。

control-word enable

缺省情况下,控制字功能处于关闭状态。

(4)       PW数据封装类型。

pw-type { ethernet | vlan }

缺省情况下,PW数据封装类型为VLAN。

1.7.2  配置静态PW

(1)       进入系统视图。

system-view

(2)       进入交叉连接组视图。

xconnect-group group-name

(3)       进入交叉连接视图。

connection connection-name

(4)       配置静态PW,并进入交叉连接PW视图。

peer ip-address pw-id pw-id in-label label-value out-label label-value [ pw-class class-name | tunnel-policy tunnel-policy-name ] *

1.7.3  配置LDP PW

1. 功能简介

创建LDP PW后,本端PE会自动使用Targeted hello来发现远端PE,以建立LDP会话,并在这个会话上交换PW ID FEC与PW标签的映射。

2. 配置准备

在配置LDP PW之前,需要在PE上使能全局和接口的MPLS LDP能力,详细配置方法请参见“MPLS配置指导”中的“LDP”。

3. 配置步骤

(1)       进入系统视图。

system-view

(2)       进入交叉连接组视图。

xconnect-group group-name

(3)       进入交叉连接视图。

connection connection-name

(4)       配置LDP PW,并进入交叉连接PW视图。

peer ip-address pw-id pw-id [ pw-class class-name | tunnel-policy tunnel-policy-name ] *

1.7.4  配置BGP PW

1. 配置BGP发布MPLS L2VPN标签块信息

(1)       进入系统视图。

system-view

(2)       启动BGP实例,并进入BGP实例视图。

bgp as-number [ instance instance-name ]

缺省情况下,系统没有运行BGP。

(3)       将远端PE配置为对等体。

peer { group-name | ip-address [ mask-length ] } as-number as-number

本命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

(4)       创建BGP L2VPN地址族,并进入BGP L2VPN地址族视图。

address-family l2vpn

(5)       使能本地路由器与指定对等体/对等体组交换BGP L2VPN信息的能力。

peer { group-name | ip-address [ mask-length ] } enable

缺省情况下,本地路由器不能与对等体/对等体组交换BGP L2VPN信息。

本命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

(6)       开启本地路由器与指定对等体/对等体组交换MPLS L2VPN标签块信息的能力。

peer { group-name | ip-address [ mask-length ] } signaling [ non-standard ]

缺省情况下,本地路由器具有与BGP L2VPN对等体/对等体组交换标签块信息的能力,并且采用RFC 4761中定义的MP_REACH_NLRI格式交换标签块信息。

(7)       配置BGP L2VPN地址族。

本配置的详细介绍请参见“3. 配置BGP L2VPN地址族”。

(8)       维护BGP L2VPN会话。

本配置的详细介绍请参见“4. 维护BGP L2VPN会话”。

2. 建立BGP PW

(1)       进入系统视图。

system-view

(2)       进入交叉连接组视图。

xconnect-group group-name

(3)       指定交叉连接组采用BGP方式自动发现邻居、建立PW,并进入交叉连接组自动发现视图。

auto-discovery bgp

缺省情况下,交叉连接组不会采用BGP方式自动发现邻居并建立PW。

(4)       为交叉连接组的BGP方式配置RD。

route-distinguisher route-distinguisher

缺省情况下,未指定交叉连接组BGP方式的RD。

(5)       为交叉连接组的BGP方式配置Route Target属性。

vpn-target vpn-target&<1-8> [ both | export-extcommunity | import-extcommunity ]

缺省情况下,未指定交叉连接组BGP方式的Route Target属性。

(6)       (可选)指定引用的PW模板。

pw-class class-name

缺省情况下,未引用PW模板。

(7)       (可选)配置PW的MTU值。

mtu size

缺省情况下,PW的MTU值为1500字节。

(8)       创建本地站点,并进入站点视图。

site site-id [ range range-value ] [ default-offset defalut-offset ]

(9)       创建交叉连接,并进入自动发现交叉连接视图。

connection remote-site-id remote-site-id

执行本命令创建交叉连接后,将同时创建连接当前站点和指定远端站点的一条PW,该PW与该交叉连接关联。

(10)    (可选)指定引用的隧道策略。

tunnel-policy tunnel-policy-name

缺省情况下,未引用隧道策略。

3. 配置BGP L2VPN地址族

(1)       进入系统视图。

system-view

(2)       进入BGP实例视图。

bgp as-number [ instance instance-name ]

(3)       进入BGP L2VPN地址族视图。

address-family l2vpn

(4)       配置对于从对等体/对等体组接收的BGP消息,允许本地AS号在该消息的AS_PATH属性中出现,并配置允许出现的次数。

peer { group-name | ip-address [ mask-length ] } allow-as-loop [ number ]

缺省情况下,不允许本地AS号在接收消息的AS_PATH属性中出现。

本命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

(5)       开启BGP L2VPN信息的VPN-Target过滤功能。

policy vpn-target

缺省情况下,BGP L2VPN信息的VPN-Target过滤功能处于开启状态。

(6)       配置BGP路由反射功能。

a.   配置本机作为路由反射器,对等体/对等体组作为路由反射器的客户机。

peer { group-name | ip-address [ mask-length ] } reflect-client

缺省情况下,没有配置路由反射器及其客户机。

b.   允许路由反射器在客户机之间反射L2VPN信息。

reflect between-clients

缺省情况下,允许路由反射器在客户机之间反射L2VPN信息。

c.   配置路由反射器的集群ID。

reflector cluster-id { cluster-id | ip-address }

缺省情况下,每个路由反射器都使用自己的Router ID作为集群ID。

d.   创建路由反射器的反射策略。

rr-filter ext-comm-list-number

缺省情况下,路由反射器不会对反射的L2VPN信息进行过滤。

本配置中各命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

(7)       配置BGP路由延迟优选

route-select delay delay-value

缺省情况下,延迟时间为0秒,即路由优选不延迟。

本命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

4. 维护BGP L2VPN会话

请在用户视图下选择一项进行配置。

·            手工对L2VPN地址族下的BGP会话进行软复位。

refresh bgp [ instance instance-name ] { ip-address [ mask-length ] | all | external | group group-name | internal } { export | import } l2vpn

·            复位L2VPN地址族下的BGP会话。

reset bgp [ instance instance-name ] { as-number | ip-address [ mask-length ] | all | external | group group-name | internal } l2vpn

本配置中各命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

1.7.5  配置CCC远程连接

1. 配置限制和指导

创建CCC远程连接时,需要确保:

·            为某一台设备指定的出标签必须与为其下一跳指定的入标签相同。

·            两端PE上CCC远程连接的封装类型、控制字功能等配置保持一致,否则可能会导致报文转发失败。

2. 配置步骤

(1)       配置两端的PE设备。

a.   进入系统视图。

system-view

b.   进入交叉连接组视图。

xconnect-group group-name

c.   进入交叉连接视图。

connection connection-name

d.   创建一条CCC远程连接。

ccc in-label in-label-value out-label out-label-value { nexthop nexthop | out-interface interface-type interface-number } [ pw-class class-name ]

只有出接口连接的链路是点到点链路,才能指定out-interface参数。该链路不是点到点链路时,如出接口为三层以太网接口、VLAN接口,则必须指定nexthop参数。

(2)       配置PE之间的所有P设备。

a.   进入系统视图。

system-view

b.   配置静态LSP的Transit节点,需要为两个数据传输方向分别配置一条静态LSP。

static-lsp transit lsp-name in-label in-label { nexthop next-hop-ip-address | outgoing-interface interface-type interface-number } out-label out-label

本命令的详细介绍,请参见“MPLS命令参考”中的“静态LSP”。

1.8  配置AC与交叉连接关联

1.8.1  功能简介

配置某个接口的以太网服务实例与交叉连接关联后,从该接口接收到的、符合以太网服务实例报文匹配规则的报文,将通过关联该交叉连接的PW或另一条AC转发。以太网服务实例提供了多种报文匹配规则(包括接口接收到的所有报文、所有携带VLAN Tag的报文和所有不携带VLAN Tag的报文等),为报文关联PW或AC提供了更加灵活的匹配方式。

配置AC与交叉连接关联时,可以指定AC与Track项联动。仅当关联的Track项中至少有一个状态为positive时,AC的状态才会up,否则,AC的状态为down。

在L2VPN接入L3VPN或IP骨干网组网中,由于VE-L2VPN接口为虚拟接口,链路故障时接口不会down。通过将AC与Track项关联,利用Track项监测PE-agg连接L3VPN或IP骨干网的链路状态,可以实现该链路故障时,将VE-L2VPN接口置为down状态,从而使得与AC关联的PW转变为down状态。如果在L2VPN网络中存在主备PW,则流量可以切换到备份PW。L2VPN接入L3VPN或IP骨干网的详细介绍,请参见“MPLS配置指导”中的“L2VPN接入L3VPN或IP骨干网”。

1.8.2  配置限制和指导

以太网服务实例关联交叉连接与以太网链路聚合功能互斥。二层以太网接口加入聚合组后,不能再将该接口上的以太网服务实例与交叉连接关联;反之亦然。

1.8.3  配置以太网服务实例与非BGP方式交叉连接关联

(1)       进入系统视图。

system-view

(2)       进入交叉连接组视图。

xconnect-group group-name

(3)       进入交叉连接视图。

connection connection-name

(4)       将以太网服务实例与交叉连接关联。

ac interface interface-type interface-number service-instance instance-id ] [ access-mode { ethernet | vlan } [ track track-entry-number&<1-3> ]

缺省情况下,以太网服务实例未与交叉连接关联。

1.8.4  配置以太网服务实例与BGP方式交叉连接关联

(1)       进入系统视图。

system-view

(2)       进入交叉连接组视图。

xconnect-group group-name

(3)       进入交叉连接组自动发现视图。

auto-discovery bgp

(4)       进入站点视图。

site site-id [ range range-value ] [ default-offset defalut-offset-value ]

(5)       进入自动发现交叉连接视图。

connection remote-site-id remote-site-id

(6)       将以太网服务实例与交叉连接关联。

ac interface interface-type interface-number service-instance instance-id ] [ access-mode { ethernet | vlan } [ track track-entry-number&<1-3> ]

缺省情况下,以太网服务实例未与交叉连接关联。

1.9  配置PW冗余保护

1.9.1  配置静态PW的冗余保护

(1)       进入系统视图。

system-view

(2)       进入交叉连接组视图。

xconnect-group group-name

(3)       进入交叉连接视图。

connection connection-name

(4)       (可选)配置PW冗余保护倒换的回切模式,以及回切等待时间。

revertive { wtr wtr-time | never }

缺省情况下,回切模式为可回切,回切等待时间为0。

(5)       进入交叉连接PW视图。

peer ip-address pw-id pw-id [ in-label label-value out-label label-value ] [ pw-class class-name | tunnel-policy tunnel-policy-name ] *

(6)       配置备份的静态PW,并进入交叉连接备份PW视图。

backup-peer ip-address pw-id pw-id in-label label-value out-label label-value [ pw-class class-name | tunnel-policy tunnel-policy-name ] *

1.9.2  配置LDP PW的冗余保护

(1)       进入系统视图。

system-view

(2)       进入交叉连接组视图。

xconnect-group group-name

(3)       进入交叉连接视图。

connection connection-name

(4)       (可选)配置PW冗余保护模式为主从操作模式,且本地PE作为主节点。

pw-redundancy master

缺省情况下,PW冗余保护模式为主从操作模式,且本地PE作为从节点。

当对端PE不支持PW冗余保护模式时,本地PE不能配置为主从模式的主节点。

(5)       (可选)配置PW冗余保护倒换的回切模式,以及回切等待时间。

revertive { wtr wtr-time | never }

缺省情况下,回切模式为可回切,回切等待时间为0。

(6)       进入交叉连接PW视图。

peer ip-address pw-id pw-id [ ignore-standby-state | pw-class class-name | tunnel-policy tunnel-policy-name ] *

ignore-standby-state用来指定忽略远端PE发送的Active/Standby状态,即不根据接收到的Active/Standby状态改变本端的主备状态。

(7)       配置备份的LDP PW,并进入交叉连接备份PW视图。

backup-peer ip-address pw-id pw-id [ pw-class class-name | tunnel-policy tunnel-policy-name ] *

1.9.3  手工倒换流量

1. 功能简介

执行本配置后,如果指定的PW存在对应的可用主PW或备份PW,则通过该PW转发的流量将倒换到另一条可用的主PW或备份PW上转发;如果不存在对应的可用主PW和备份PW,则不进行流量倒换。

2. 配置步骤

请在用户视图下执行本命令,将PW的流量手工倒换到它的冗余备份PW上。

l2vpn switchover peer ip-address pw-id pw-id

1.10  开启L2VPN告警功能

1. 功能简介

开启L2VPN告警功能后,当PW的up-down状态发生变化、PW删除或主备PW切换时会产生告警信息。生成的告警信息将发送到设备的SNMP模块,通过设置SNMP中告警信息的发送参数,来决定告警信息输出的相关属性。

有关告警信息的详细介绍,请参见“网络管理和监控配置指导”中的“SNMP”。

2. 配置步骤

(1)       进入系统视图。

system-view

(2)       开启L2VPN告警功能。

snmp-agent trap enable l2vpn [ pw-delete | pw-switch | pw-up-down ] *

缺省情况下,L2VPN告警功能处于关闭状态。

1.11  MPLS L2VPN显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后MPLS L2VPN的运行情况,通过查看显示信息验证配置的效果。

在用户视图下,执行reset命令可以复位BGP会话。

display bgp group l2vpndisplay bgp peer l2vpndisplay bgp update-group l2vpnreset bgp l2vpn命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

表1-2 MPLS L2VPN显示和维护

操作

命令

显示BGP L2VPN对等体组的信息

display bgp [ instance instance-name ] group l2vpn [ group-name group-name ]

显示BGP协议的MPLS L2VPN标签块信息

display bgp [ instance instance-name ] l2vpn signaling [ peer ip-address { advertised | received } [ statistics ] | route-distinguisher route-distinguisher [ site-id site-id [ label-offset label-offset [ advertise-info ] ] ] | statistics ]

显示BGP L2VPN对等体的信息

display bgp [ instance instance-name ] peer l2vpn [ ip-address mask-length | group-name group-name log-info | ip-address { log-info | verbose } | verbose ]

显示BGP L2VPN地址族下打包组的相关信息

display bgp [ instance instance-name ] update-group l2vpn [ ip-address ]

显示MPLS L2VPN的标签块信息

display l2vpn bgp [ peer ip-address | local ] [ xconnect-group group-name ] [ verbose ]

显示交叉连接的转发信息

(独立运行模式)

display l2vpn forwarding { ac | pw } [ xconnect-group group-name ] [ slot slot-number ] [ verbose ]

(IRF模式)

display l2vpn forwarding { ac | pw } [ xconnect-group group-name ] [ chassis chassis-number slot slot-number ] [ verbose ]

显示LDP协议通告的PW标签相关信息

display l2vpn ldp [ peer ip-address [ pw-id pw-id ] | xconnect-group group-name ] [ verbose ]

显示L2VPN的PW信息

display l2vpn pw [ xconnect-group group-name ] [ protocol { bgp | ldp | static } ] [ verbose ]

显示PW模板的信息

display l2vpn pw-class [ class-name ]

显示以太网服务实例的信息

display l2vpn service-instance [ interface interface-type interface-number [ service-instance instance-id ] ] [ verbose ]

显示交叉连接组的信息

display l2vpn xconnect-group [ name group-name ] [ verbose ]

复位L2VPN地址族下的BGP会话

reset bgp [ instance instance-name ] { as-number | ip-address [ mask-length ] | all | external | group group-name | internal } l2vpn

 

1.12  MPLS L2VPN典型配置举例

1.12.1  静态PW配置举例

1. 组网需求

用户网络有若干个站点,希望通过在骨干网上建立静态PW,实现站点1的VLAN 10与站点2的VLAN 10互联。

在PE 1和PE 2分别创建以太网服务实例10,匹配接口HundredGigE1/0/1接收到的VLAN Tag为10的报文。

2. 组网图

图1-4 静态PW配置组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

Vlan-int10

100.1.1.1/24

P

Loop0

192.4.4.4/32

PE 1

Loop0

192.2.2.2/32

 

Vlan-int30

10.2.2.2/24

 

Vlan-int20

10.1.1.1/24

 

Vlan-int20

10.1.1.2/24

CE 2

Vlan-int10

100.1.1.2/24

PE 2

Loop0

192.3.3.3/32

 

 

 

 

Vlan-int30

10.2.2.1/24

 

3. 配置步骤

说明

进行下面的配置之前,请先在各台交换机上创建VLAN,并将相应端口加入VLAN。

 

(1)       配置CE 1

<CE1> system-view

[CE1] interface vlan-interface 10

[CE1-Vlan-interface10] ip address 100.1.1.1 24

[CE1-Vlan-interface10] quit

(2)       配置PE 1

# 配置LSR ID。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.2.2.2 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 192.2.2.2

# 开启L2VPN功能。

[PE1] l2vpn enable

# 全局使能LDP。

[PE1] mpls ldp

[PE1-ldp] quit

# 配置连接P的接口Vlan-interface20,在此接口上使能LDP。

[PE1] interface vlan-interface 20

[PE1-Vlan-interface20] ip address 10.1.1.1 24

[PE1-Vlan-interface20] mpls enable

[PE1-Vlan-interface20] mpls ldp enable

[PE1-Vlan-interface20] quit

# 在PE 1上运行OSPF,用于建立LSP。

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 创建VLAN 10并将接口HundredGigE1/0/1加入VLAN 10。

[PE1] vlan 10

[PE1-vlan10] port hundredgige 1/0/1

[PE1-vlan10] quit

# 在接口HundredGigE1/0/1上创建服务实例。

[PE1] interface hundredgige 1/0/1

[PE1-HundredGigE1/0/1] service-instance 10

[PE1-HundredGigE1/0/1-srv10] encapsulation s-vid 10

[PE1-HundredGigE1/0/1-srv10] quit

[PE1-HundredGigE1/0/1] quit

# 创建交叉连接组vpna,在该交叉连接组内创建名称为svc的交叉连接,将HundredGigE1/0/1接口上的服务实例10与此交叉连接关联,并在交叉连接内创建静态PW,以便将AC和PW关联。

[PE1] xconnect-group vpna

[PE1-xcg-vpna] connection svc

[PE1-xcg-vpna-svc] ac interface hundredgige 1/0/1 service-instance 10

[PE1-xcg-vpna-svc] peer 192.3.3.3 pw-id 3 in-label 100 out-label 200

[PE1-xcg-vpna-svc-192.3.3.3-3] quit

[PE1-xcg-vpna-svc] quit

[PE1-xcg-vpna] quit

(3)       配置P

# 配置LSR ID。

<P> system-view

[P] interface loopback 0

[P-LoopBack0] ip address 192.4.4.4 32

[P-LoopBack0] quit

[P] mpls lsr-id 192.4.4.4

# 全局使能LDP。

[P] mpls ldp

[P-ldp] quit

# 配置连接PE 1的接口Vlan-interface20,在此接口上使能LDP。

[P] interface vlan-interface 20

[P-Vlan-interface20] ip address 10.1.1.2 24

[P-Vlan-interface20] mpls enable

[P-Vlan-interface20] mpls ldp enable

[P-Vlan-interface20] quit

# 配置连接PE 2的接口Vlan-interface30,在此接口上使能LDP。

[P] interface vlan-interface 30

[P-Vlan-interface30] ip address 10.2.2.2 24

[P-Vlan-interface30] mpls enable

[P-Vlan-interface30] mpls ldp enable

[P-Vlan-interface30] quit

# 在P上运行OSPF,用于建立LSP。

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

(4)       配置PE 2

# 配置LSR ID。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.3.3.3 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 192.3.3.3

# 开启L2VPN功能。

[PE2] l2vpn enable

# 全局使能LDP。

[PE2] mpls ldp

[PE2-ldp] quit

# 配置连接P的接口Vlan-interface30,在此接口上使能LDP。

[PE2] interface vlan-interface 30

[PE2-Vlan-interface30] ip address 10.2.2.1 24

[PE2-Vlan-interface30] mpls enable

[PE2-Vlan-interface30] mpls ldp enable

[PE2-Vlan-interface30] quit

# 在PE 2上运行OSPF,用于建立LSP。

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 10.2.2.1 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 创建VLAN 10并将接口HundredGigE1/0/1加入VLAN 10。

[PE2] vlan 10

[PE2-vlan10] port hundredgige 1/0/1

[PE2-vlan10] quit

# 在接口HundredGigE1/0/1上创建服务实例。

[PE2] interface hundredgige 1/0/1

[PE2-HundredGigE1/0/1] service-instance 10

[PE2-HundredGigE1/0/1-srv10]encapsulation s-vid 10

[PE2-HundredGigE1/0/1-srv10] quit

[PE2-HundredGigE1/0/1] quit

# 创建交叉连接组vpna,在该交叉连接组内创建名称为svc的交叉连接,将HundredGigE1/0/1接口上的服务实例10与此交叉连接关联,并在交叉连接内创建静态PW,以便将AC和PW关联。

[PE2] xconnect-group vpna

[PE2-xcg-vpna] connection svc

[PE2-xcg-vpna-svc] ac interface hundredgige 1/0/1 service-instance 10

[PE2-xcg-vpna-svc] peer 192.2.2.2 pw-id 3 in-label 200 out-label 100

[PE2-xcg-vpna-svc-192.2.2.2-3] quit

[PE2-xcg-vpna-svc] quit

[PE2-xcg-vpna] quit

(5)       配置CE 2

<CE2> system-view

[CE2] interface vlan-interface 10

[CE2-Vlan-interface10] ip address 100.1.1.2 24

[CE2-Vlan-interface10] quit

4. 验证配置

# 在PE 1上查看PW信息,可以看到建立了一条静态PW。

[PE1] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpna

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.3.3.3       3                 100/200         Static M     0          Up

# 在PE 2上也可以看到静态PW的信息。

[PE2] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpna

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.2.2.2       3                 200/100         Static M     0          Up

# CE 1与CE 2之间能够ping通。

1.12.2  LDP PW配置举例

1. 组网需求

用户网络有两个站点,站点CE分别为CE 1和CE 2。站点1有一个用户VLAN(VLAN 10),站点2有一个用户VLAN(VLAN 10)。

通过在PE 1和PE 2上创建以太网服务实例,采用灵活匹配模式关联AC和PW,实现站点1与站点2之间的VLAN 10互联,但不消耗PE设备上的VLAN资源。

2. 组网图

图1-5 LDP PW配置组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

Vlan-int10

100.1.1.1/24

P

Loop0

192.4.4.4/32

PE 1

Loop0

192.2.2.2/32

 

Vlan-int23

23.1.1.2/24

 

Vlan-int23

23.1.1.1/24

 

Vlan-int26

26.2.2.2/24

CE 2

Vlan-int10

100.1.1.2/24

PE 2

Loop0

192.3.3.3/32

 

 

 

 

Vlan-int26

26.2.2.1/24

 

3. 配置步骤

说明

进行下面的配置之前,请先在各台CE上创建VLAN,并将相应端口加入VLAN。

 

(1)       配置CE 1

<CE1> system-view

[CE1] interface vlan-interface 10

[CE1-Vlan-interface10] ip address 100.1.1.1 24

[CE1-Vlan-interface10] quit

(2)       配置PE 1

# 配置LSR ID。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.2.2.2 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 192.2.2.2

# 开启L2VPN功能。

[PE1] l2vpn enable

# 全局使能LDP。

[PE1] mpls ldp

[PE1-ldp] quit

# 配置连接P的接口Vlan-interface23,在此接口上使能LDP。

[PE1] interface vlan-interface 23

[PE1-Vlan-interface23] ip address 23.1.1.1 24

[PE1-Vlan-interface23] mpls enable

[PE1-Vlan-interface23] mpls ldp enable

[PE1-Vlan-interface23] quit

# 在PE 1上运行OSPF,用于建立LSP。

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 23.1.1.1 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 在接入CE 1的接口HundredGigE1/0/1上创建服务实例。

[PE1] interface hundredgige 1/0/1

[PE1-HundredGigE1/0/1] service-instance 1000

[PE1-HundredGigE1/0/1-srv1000] encapsulation s-vid 10

[PE1-HundredGigE1/0/1-srv1000] quit

[PE1-HundredGigE1/0/1] quit

# 创建交叉连接组vpn1,在该交叉连接组内创建名称为ldp的交叉连接,将接口HundredGigE1/0/1的服务实例1000与此交叉连接关联,并在交叉连接内创建LDP PW,以实现AC和PW关联。

[PE1] xconnect-group vpn1

[PE1-xcg-vpn1] connection ldp

[PE1-xcg-vpn1-ldp] ac interface hundredgige 1/0/1 service-instance 1000

[PE1-xcg-vpn1-ldp] peer 192.3.3.3 pw-id 1000

[PE1-xcg-vpn1-ldp-192.3.3.3-1000] quit

[PE1-xcg-vpn1-ldp] quit

[PE1-xcg-vpn1] quit

(3)       配置P

# 配置LSR ID。

<P> system-view

[P] interface loopback 0

[P-LoopBack0] ip address 192.4.4.4 32

[P-LoopBack0] quit

[P] mpls lsr-id 192.4.4.4

# 全局使能LDP。

[P] mpls ldp

[P-ldp] quit

# 配置连接PE 1的接口Vlan-interface23,在此接口上使能LDP。

[P] interface vlan-interface 23

[P-Vlan-interface23] ip address 23.1.1.2 24

[P-Vlan-interface23] mpls enable

[P-Vlan-interface23] mpls ldp enable

[P-Vlan-interface23] quit

# 配置连接PE 2的接口Vlan-interface26,在此接口上使能LDP。

[P] interface vlan-interface 26

[P-Vlan-interface26] ip address 26.2.2.2 24

[P-Vlan-interface26] mpls enable

[P-Vlan-interface26] mpls ldp enable

[P-Vlan-interface26] quit

# 在P上运行OSPF,用于建立LSP。

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 23.1.1.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 26.2.2.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

(4)       配置PE 2

# 配置LSR ID。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.3.3.3 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 192.3.3.3

# 开启L2VPN功能。

[PE2] l2vpn enable

# 全局使能LDP。

[PE2] mpls ldp

[PE2-ldp] quit

# 配置连接P的接口Vlan-interface26,在此接口上使能LDP。

[PE2] interface vlan-interface 26

[PE2-Vlan-interface26] ip address 26.2.2.1 24

[PE2-Vlan-interface26] mpls enable

[PE2-Vlan-interface26] mpls ldp enable

[PE2-Vlan-interface26] quit

# 在PE 2上运行OSPF,用于建立LSP。

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] network 26.2.2.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 在接入CE 2的接口HundredGigE1/0/1上创建服务实例。

[PE2] interface hundredgige 1/0/1

[PE2-HundredGigE1/0/1] service-instance 1000

[PE2-HundredGigE1/0/1-srv1000] encapsulation s-vid 10

[PE2-HundredGigE1/0/1-srv1000] quit

[PE2-HundredGigE1/0/1] quit

# 创建交叉连接组vpn1,在该交叉连接组内创建名称为ldp的交叉连接,将接口HundredGigE1/0/1的服务实例1000与此交叉连接关联,并在交叉连接内创建LDP PW,以实现AC和PW关联。

[PE2] xconnect-group vpn1

[PE2-xcg-vpn1] connection ldp

[PE2-xcg-vpn1-ldp] ac interface hundredgige 1/0/1 service-instance 1000

[PE2-xcg-vpn1-ldp] peer 192.2.2.2 pw-id 1000

[PE2-xcg-vpn1-ldp-192.2.2.2-1000] quit

[PE2-xcg-vpn1-ldp] quit

[PE2-xcg-vpn1] quit

(5)       配置CE 2

<CE2> system-view

[CE2] interface vlan-interface 10

[CE2-Vlan-interface10] ip address 100.1.1.2 24

[CE2-Vlan-interface10] quit

4. 验证配置

# 在PE 1上查看PW信息,可以看到建立了一条LDP PW。

[PE1] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpn1

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.3.3.3       1000              1151/1279       LDP    M     1          Up

# 在PE 2上也可以看到LDP PW信息。

[PE2] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpn1

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.2.2.2       1000              1279/1151       LDP    M     1          Up

# CE 1与CE 2之间能够ping通。

1.12.3  BGP PW配置举例

1. 组网需求

用户网络有若干个站点,希望通过在骨干网上建立BGP PW,实现站点1的VLAN 10与站点2的VLAN 10互联。

在PE 1和PE 2分别创建以太网服务实例10,匹配接口HundredGigE1/0/1接收到的VLAN Tag为10的报文。

2. 组网图

图1-6 BGP PW配置组网图

 

设备

接口

IP地址

设备

接口

IP地址

CE 1

Vlan-int10

100.1.1.1/24

P

Loop0

192.4.4.4/32

PE 1

Loop0

192.2.2.2/32

 

Vlan-int20

10.1.1.2/24

 

Vlan-int20

10.1.1.1/24

 

Vlan-int30

10.2.2.2/24

CE 2

Vlan-int10

100.1.1.2/24

PE 2

Loop0

192.3.3.3/32

 

 

 

 

Vlan-int30

10.2.2.1/24

 

3. 配置步骤

说明

进行下面的配置之前,请先在各台交换机上创建VLAN,并将相应端口加入VLAN。

 

(1)       配置CE 1

<CE1> system-view

[CE1] interface vlan-interface 10

[CE1-Vlan-interface10] ip address 100.1.1.1 24

[CE1-Vlan-interface10] quit

(2)       配置PE 1

# 配置LSR ID。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.2.2.2 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 192.2.2.2

# 开启L2VPN功能。

[PE1] l2vpn enable

# 全局使能LDP。

[PE1] mpls ldp

[PE1-ldp] quit

# 配置连接P的接口Vlan-interface20,在此接口上使能LDP。

[PE1] interface vlan-interface 20

[PE1-Vlan-interface20] ip address 10.1.1.1 24

[PE1-Vlan-interface20] mpls enable

[PE1-Vlan-interface20] mpls ldp enable

[PE1-Vlan-interface20] quit

# 在PE 1上运行OSPF,用于建立LSP。

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 在PE 1和PE 2之间建立IBGP连接,并配置在二者之间通过BGP发布L2VPN信息。

[PE1] bgp 100

[PE1-bgp-default] peer 192.3.3.3 as-number 100

[PE1-bgp-default] peer 192.3.3.3 connect-interface loopback 0

[PE1-bgp-default] address-family l2vpn

[PE1-bgp-default-l2vpn] peer 192.3.3.3 enable

[PE1-bgp-default-l2vpn] quit

[PE1-bgp-default] quit

# 创建VLAN 10并将接口HundredGigE1/0/1加入VLAN 10。

[PE1] vlan 10

[PE1-vlan10] port hundredgige 1/0/1

[PE1-vlan10] quit

# 在接口HundredGigE1/0/1上创建服务实例10。

[PE1] interface hundredgige 1/0/1

[PE1-HundredGigE1/0/1] service-instance 10

[PE1-HundredGigE1/0/1-srv10]encapsulation s-vid 10

[PE1-HundredGigE1/0/1-srv10] quit

[PE1-HundredGigE1/0/1] quit

# 创建交叉连接组vpnb,在该交叉连接组内创建本地站点1,在本地站点1和远端站点2之间建立BGP PW,并将HundredGigE1/0/1接口上的服务实例10与此PW关联。

[PE1] xconnect-group vpnb

[PE1-xcg-vpnb] auto-discovery bgp

[PE1-xcg-vpnb-auto] route-distinguisher 2:2

[PE1-xcg-vpnb-auto] vpn-target 2:2 export-extcommunity

[PE1-xcg-vpnb-auto] vpn-target 2:2 import-extcommunity

[PE1-xcg-vpnb-auto] site 1 range 10 default-offset 0

[PE1-xcg-vpnb-auto-1] connection remote-site-id 2

[PE1-xcg-vpnb-auto-1-2] ac interface hundredgige 1/0/1 service-instance 10

[PE1-xcg-vpnb-auto-1-2] return

(3)       配置P

# 配置LSR ID。

<P> system-view

[P] interface loopback 0

[P-LoopBack0] ip address 192.4.4.4 32

[P-LoopBack0] quit

[P] mpls lsr-id 192.4.4.4

# 全局使能LDP。

[P] mpls ldp

[P-ldp] quit

# 配置连接PE 1的接口Vlan-interface20,在此接口上使能LDP。

[P] interface vlan-interface 20

[P-Vlan-interface20] ip address 10.1.1.2 24

[P-Vlan-interface20] mpls enable

[P-Vlan-interface20] mpls ldp enable

[P-Vlan-interface20] quit

# 配置连接PE 2的接口Vlan-interface30,在此接口上使能LDP。

[P] interface vlan-interface 30

[P-Vlan-interface30] ip address 10.2.2.2 24

[P-Vlan-interface30] mpls enable

[P-Vlan-interface30] mpls ldp enable

[P-Vlan-interface30] quit

# 在P上运行OSPF,用于建立LSP。

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

(4)       配置PE 2

# 配置LSR ID。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.3.3.3 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 192.3.3.3

# 开启L2VPN功能。

[PE2] l2vpn enable

# 全局使能LDP。

[PE2] mpls ldp

[PE2-ldp] quit

# 配置连接P的接口Vlan-interface30,在此接口上使能LDP。

[PE2] interface vlan-interface 30

[PE2-Vlan-interface30] ip address 10.2.2.1 24

[PE2-Vlan-interface30] mpls enable

[PE2-Vlan-interface30] mpls ldp enable

[PE2-Vlan-interface30] quit

# 在PE 2上运行OSPF,用于建立LSP。

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 在PE 1和PE 2之间建立IBGP连接,并配置在二者之间通过BGP发布L2VPN信息。

[PE2] bgp 100

[PE2-bgp-default] peer 192.2.2.2 as-number 100

[PE2-bgp-default] peer 192.2.2.2 connect-interface loopback 0

[PE2-bgp-default] address-family l2vpn

[PE2-bgp-default-l2vpn] peer 192.2.2.2 enable

[PE2-bgp-default-l2vpn] quit

[PE2-bgp-default] quit

# 创建VLAN 10并将接口HundredGigE1/0/1加入VLAN 10。

[PE2] vlan 10

[PE2-vlan10] port hundredgige 1/0/1

[PE2-vlan10] quit

# 在接口HundredGigE1/0/1上创建服务实例10。

[PE2] interface hundredgige 1/0/1

[PE2-HundredGigE1/0/1] service-instance 10

[PE2-HundredGigE1/0/1-srv10]encapsulation s-vid 10

[PE2-HundredGigE1/0/1-srv10] quit

[PE2-HundredGigE1/0/1] quit

# 创建交叉连接组vpnb,在该交叉连接组内创建本地站点2,在本地站点2和远端站点1之间建立BGP PW,并将HundredGigE1/0/1接口上的服务实例10与此PW关联。

[PE2] xconnect-group vpnb

[PE2-xcg-vpnb] auto-discovery bgp

[PE2-xcg-vpnb-auto] route-distinguisher 2:2

[PE2-xcg-vpnb-auto] vpn-target 2:2 export-extcommunity

[PE2-xcg-vpnb-auto] vpn-target 2:2 import-extcommunity

[PE2-xcg-vpnb-auto] site 2 range 10 default-offset 0

[PE2-xcg-vpnb-auto-2] connection remote-site-id 1

[PE2-xcg-vpnb-auto-2-1] ac interface hundredgige 1/0/1 service-instance 10

[PE2-xcg-vpnb-auto-2-1] return

(5)       配置CE 2

<CE2> system-view

[CE2] interface vlan-interface 10

[CE2-Vlan-interface10] ip address 100.1.1.2 24

[CE2-Vlan-interface10] quit

4. 验证配置

# 在PE 1上查看PW信息,可以看到建立了一条BGP PW。

<PE1> display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpnb

Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State

192.3.3.3       2                 1036/1025       BGP     M     1        Up

# 在PE 2上也可以看到PW信息。

<PE2> display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpnb

Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State

192.2.2.2       1                 1025/1036       BGP     M     1        Up

# CE 1与CE 2之间能够ping通。

1.12.4  CCC远程连接配置举例

1. 组网需求

用户网络有若干个站点,希望通过在骨干网上建立CCC远程连接,实现站点1的VLAN 10与站点2的VLAN 10互联。

在PE 1和PE 2分别创建以太网服务实例10,匹配接口HundredGigE1/0/1接收到的VLAN Tag为10的报文。

2. 组网图

图1-7 CCC远程连接配置组网图

 

设备

接口

IP地址

设备

接口

IP地址

CE 1

Vlan-int10

100.1.1.1/24

P

Loop0

192.4.4.4/32

PE 1

Loop0

192.2.2.2/32

 

Vlan-int20

10.1.1.2/24

 

Vlan-int20

10.1.1.1/24

 

Vlan-int30

10.2.2.2/24

CE 2

Vlan-int10

100.1.1.2/24

PE 2

Loop0

192.3.3.3/32

 

 

 

 

Vlan-int30

10.2.2.1/24

 

3. 配置步骤

说明

进行下面的配置之前,请先在各台交换机上创建VLAN,并将相应端口加入VLAN。

 

(1)       配置CE 1

<CE1> system-view

[CE1] interface vlan-interface 10

[CE1-Vlan-interface10] ip address 100.1.1.1 24

[CE1-Vlan-interface10] quit

(2)       配置PE 1

# 配置LSR ID。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.2.2.2 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 192.2.2.2

# 开启L2VPN功能。

[PE1] l2vpn enable

# 配置连接P的接口Vlan-interface20,在此接口上使能MPLS。

[PE1] interface vlan-interface 20

[PE1-Vlan-interface20] ip address 10.1.1.1 24

[PE1-Vlan-interface20] mpls enable

[PE1-Vlan-interface20] quit

# 创建VLAN 10并将接口HundredGigE1/0/1加入VLAN 10。

[PE1] vlan 10

[PE1-vlan10] port hundredgige 1/0/1

[PE1-vlan10] quit

# 在接口HundredGigE1/0/1上创建服务实例。

[PE1] interface hundredgige 1/0/1

[PE1-HundredGigE1/0/1] service-instance 10

[PE1-HundredGigE1/0/1-srv10]encapsulation s-vid 10

[PE1-HundredGigE1/0/1-srv10] quit

[PE1-HundredGigE1/0/1] quit

# 创建交叉连接组ccc,在该交叉连接组内创建CCC远程连接(入标签为101、出标签为201、下一跳地址为10.1.1.2),并将HundredGigE1/0/1接口上的服务实例10与此CCC远程连接关联。

[PE1] xconnect-group ccc

[PE1-xcg-ccc] connection ccc

[PE1-xcg-ccc-ccc] ccc in-label 101 out-label 201 nexthop 10.1.1.2

[PE1-xcg-ccc-ccc] ac interface hundredgige 1/0/1 service-instance 10

[PE1-xcg-ccc-ccc] quit

[PE1-xcg-ccc] quit

(3)       配置P

# 配置LSR ID。

<P> system-view

[P] interface loopback 0

[P-LoopBack0] ip address 192.4.4.4 32

[P-LoopBack0] quit

[P] mpls lsr-id 192.4.4.4

# 配置连接PE 1的接口Vlan-interface20,在此接口上使能MPLS。

[P] interface vlan-interface 20

[P-Vlan-interface20] ip address 10.1.1.2 24

[P-Vlan-interface20] mpls enable

[P-Vlan-interface20] quit

# 配置连接PE 2的接口Vlan-interface30,在此接口上使能MPLS。

[P] interface vlan-interface 30

[P-Vlan-interface30] ip address 10.2.2.2 24

[P-Vlan-interface30] mpls enable

[P-Vlan-interface30] quit

# 配置一条静态LSP用于转发由PE 1去往PE 2的报文。

[P] static-lsp transit pe1-pe2 in-label 201 nexthop 10.2.2.1 out-label 202

# 配置另一条静态LSP用于转发由PE 2去往PE 1的报文。

[P] static-lsp transit pe2-pe1 in-label 102 nexthop 10.1.1.1 out-label 101

(4)       配置PE 2

# 配置LSR ID。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.3.3.3 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 192.3.3.3

# 开启L2VPN功能。

[PE2] l2vpn enable

# 配置连接P的接口Vlan-interface30,在此接口上使能MPLS。

[PE2] interface vlan-interface 30

[PE2-Vlan-interface30] ip address 10.2.2.1 24

[PE2-Vlan-interface30] mpls enable

[PE2-Vlan-interface30] quit

# 创建VLAN 10并将接口HundredGigE1/0/1加入VLAN 10。

[PE2] vlan 10

[PE2-vlan10] port hundredgige 1/0/1

[PE2-vlan10] quit

# 在接口HundredGigE1/0/1上创建服务实例。

[PE2] interface hundredgige 1/0/1

[PE2-HundredGigE1/0/1] service-instance 10

[PE2-HundredGigE1/0/1-srv10]encapsulation s-vid 10

[PE2-HundredGigE1/0/1-srv10] quit

[PE2-HundredGigE1/0/1] quit

# 创建交叉连接组ccc,在该交叉连接组内创建CCC远程连接(入标签为202、出标签为102、下一跳地址为10.2.2.2),并将HundredGigE1/0/1接口上的服务实例10与此CCC远程连接关联。

[PE2] xconnect-group ccc

[PE2-xcg-ccc] connection ccc

[PE2-xcg-ccc-ccc] ccc in-label 202 out-label 102 nexthop 10.2.2.2

[PE2-xcg-ccc-ccc] ac interface hundredgige 1/0/1 service-instance 10

[PE2-xcg-ccc-ccc] quit

[PE2-xcg-ccc] quit

(5)       配置CE 2

<CE2> system-view

[CE2] interface vlan-interface 10

[CE2-Vlan-interface10] ip address 100.1.1.2 24

[CE2-Vlan-interface10] quit

4. 验证配置

# 在PE 1上查看PW信息,可以看到建立了一条PW连接。PW ID/Rmt Site字段为“-”,Proto字段为“Static”,表示该PW连接为CCC远程连接。

[PE1] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: ccc

Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State

10.1.1.2        -                 101/201         Static  M     0        Up

# 在PE 2上也可以看到PW信息。

[PE2] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: ccc                                                       

Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State 

10.2.2.2        -                 202/102         Static  M     0        Up    

# CE 1与CE 2之间能够ping通。

1.12.5  LDP PW冗余保护配置举例

1. 组网需求

用户网络有两个站点,站点的CE设备分别为CE 1和CE 2。CE 1和CE 2之间建立两条LDP方式的MPLS L2VPN连接,以提供PW冗余保护功能。其中:

·            CE 1-PE 1-PE 2-CE 2的连接为主链路,该链路正常工作时,CE 1和CE 2通过该链路通信。

·            CE 1-PE 1-PE 3-CE 2的连接为备份链路,当PE 1检测到主链路出现故障时,启用备份链路,CE 1和CE 2通过备份链路通信。

2. 组网图

图1-8 LDP PW冗余保护配置组网图

 

设备

接口

IP地址

设备

接口

IP地址

CE 1

Vlan-int10

100.1.1.1/24

PE 2

Loop0

2.2.2.2/32

PE 1

Loop0

1.1.1.1/32

 

Vlan-int12

12.1.1.2/24

 

Vlan-int12

12.1.1.1/24

PE 3

Loop0

3.3.3.3/32

 

Vlan-int13

13.1.1.1/24

 

Vlan-int13

13.1.1.3/24

CE 2

Vlan-int10

100.1.1.2/24

 

 

 

 

3. 配置步骤

说明

进行下面的配置之前,请先进行如下操作:

·         在各台交换机上创建VLAN,并将相应端口加入VLAN

·         全局关闭STP功能,或为每个VLAN映射一个MSTP实例,具体配置方法请参见“二层技术-以太网交换配置指导”中的“生成树”

 

(1)       配置CE 1

<CE1> system-view

[CE1] interface vlan-interface 10

[CE1-Vlan-interface10] ip address 100.1.1.1 24

[CE1-Vlan-interface10] quit

(2)       配置PE 1

# 配置LSR ID。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 1.1.1.1 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 1.1.1.1

# 全局使能MPLS LDP。

[PE1] mpls ldp

[PE1-ldp] quit

# 配置连接PE 2、PE 3的接口Vlan-interface12和Vlan-interface13,在接口上使能LDP。

[PE1] interface vlan-interface 12

[PE1-Vlan-interface12] ip address 12.1.1.1 24

[PE1-Vlan-interface12] mpls enable

[PE1-Vlan-interface12] mpls ldp enable

[PE1-Vlan-interface12] quit

[PE1] interface vlan-interface 13

[PE1-Vlan-interface13] ip address 13.1.1.1 24

[PE1-Vlan-interface13] mpls enable

[PE1-Vlan-interface13] mpls ldp enable

[PE1-Vlan-interface13] quit

# 在PE 1上运行OSPF,用于建立LSP。

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] network 12.1.1.0 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 13.1.1.0 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 开启L2VPN功能。

[PE1] l2vpn enable

# 在接口HundredGigE1/0/1上创建服务实例10,报文匹配规则为VLAN标签10。

[PE1] interface hundredgige 1/0/1

[PE1-HundredGigE1/0/1] port link-type trunk

[PE1-HundredGigE1/0/1] port trunk permit vlan 10

[PE1-HundredGigE1/0/1] service-instance 10

[PE1-HundredGigE1/0/1-srv10] encapsulation s-vid 10

[PE1-HundredGigE1/0/1-srv10] quit

[PE1-HundredGigE1/0/1] quit

# 创建交叉连接组vpna,在该交叉连接组内创建名称为ldp的交叉连接,将接口HundredGigE1/0/1上的服务实例10与此交叉连接关联,并在交叉连接内创建主备两条LDP PW,以便将AC和PW关联、实现PW的冗余保护。

[PE1] xconnect-group vpna

[PE1-xcg-vpna] connection ldp

[PE1-xcg-vpna-ldp] ac interface hundredgige 1/0/1 service-instance 10

[PE1-xcg-vpna-ldp] peer 2.2.2.2 pw-id 20

[PE1-xcg-vpna-ldp-2.2.2.2-20] backup-peer 3.3.3.3 pw-id 30

[PE1-xcg-vpna-ldp-3.3.3.3-30-backup] quit

[PE1-xcg-vpna-ldp-2.2.2.2-20] quit

[PE1-xcg-vpna-ldp] quit

[PE1-xcg-vpna] quit

[PE1] quit

(3)       配置PE 2

# 配置LSR ID。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 2.2.2.2 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 2.2.2.2

# 全局使能MPLS LDP。

[PE2] mpls ldp

[PE2-ldp] quit

# 配置连接PE 1的接口Vlan-interface12,在接口上使能LDP。

[PE2] interface vlan-interface 12

[PE2-Vlan-interface12] ip address 12.1.1.2 24

[PE2-Vlan-interface12] mpls enable

[PE2-Vlan-interface12] mpls ldp enable

[PE2-Vlan-interface12] quit

# 在PE 2上运行OSPF,用于建立LSP。

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 12.1.1.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 开启L2VPN功能。

[PE2] l2vpn enable

# 在接口HundredGigE1/0/1上创建服务实例10,报文匹配规则为VLAN标签10。

[PE2] interface hundredgige 1/0/1

[PE2-HundredGigE1/0/1] port link-type trunk

[PE2-HundredGigE1/0/1] port trunk permit vlan 10

[PE2-HundredGigE1/0/1] service-instance 10

[PE2-HundredGigE1/0/1-srv10] encapsulation s-vid 10

[PE2-HundredGigE1/0/1-srv10] quit

[PE2-HundredGigE1/0/1] quit

# 创建交叉连接组vpna,在该交叉连接组内创建名称为ldp的交叉连接,将接口HundredGigE1/0/1上的服务实例10与此交叉连接关联,并在交叉连接内创建LDP PW,以便将AC和PW关联。

[PE2] xconnect-group vpna

[PE2-xcg-vpna] connection ldp

[PE2-xcg-vpna-ldp] ac interface hundredgige 1/0/1 service-instance 10

[PE2-xcg-vpna-ldp] peer 1.1.1.1 pw-id 20

[PE2-xcg-vpna-ldp-1.1.1.1-20] quit

[PE2-xcg-vpna-ldp] quit

[PE2-xcg-vpna] quit

(4)       配置PE 3

# 配置LSR ID。

<PE3> system-view

[PE3] interface loopback 0

[PE3-LoopBack0] ip address 3.3.3.3 32

[PE3-LoopBack0] quit

[PE3] mpls lsr-id 3.3.3.3

# 全局使能MPLS LDP。

[PE3] mpls ldp

[PE3-ldp] quit

# 配置连接PE 1的接口Vlan-interface13,在接口上使能LDP。

[PE3] interface vlan-interface 13

[PE3-Vlan-interface13] ip address 13.1.1.3 24

[PE3-Vlan-interface13] mpls enable

[PE3-Vlan-interface13] mpls ldp enable

[PE3-Vlan-interface13] quit

# 在PE 3上运行OSPF,用于建立LSP。

[PE3] ospf

[PE3-ospf-1] area 0

[PE3-ospf-1-area-0.0.0.0] network 13.1.1.0 0.0.0.255

[PE3-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0

[PE3-ospf-1-area-0.0.0.0] quit

[PE3-ospf-1] quit

# 开启L2VPN功能。

[PE3] l2vpn enable

# 在接口HundredGigE1/0/1上创建服务实例10,报文匹配规则为VLAN标签10。

[PE3] interface hundredgige 1/0/1

[PE3-HundredGigE1/0/1] port link-type trunk

[PE3-HundredGigE1/0/1] port trunk permit vlan 10

[PE3-HundredGigE1/0/1] service-instance 10

[PE3-HundredGigE1/0/1-srv10] encapsulation s-vid 10

[PE3-HundredGigE1/0/1-srv10] quit

[PE3-HundredGigE1/0/1] quit

# 创建交叉连接组vpna,在该交叉连接组内创建名称为ldp的交叉连接,将接口HundredGigE1/0/1上的服务实例10与此交叉连接关联,并在交叉连接内创建LDP PW,以便将AC和PW关联。

[PE3] xconnect-group vpna

[PE3-xcg-vpna] connection ldp

[PE3-xcg-vpna-ldp] ac interface hundredgige 1/0/1 service-instance 10

[PE3-xcg-vpna-ldp] peer 1.1.1.1 pw-id 30

[PE3-xcg-vpna-ldp-1.1.1.1-30] quit

[PE3-xcg-vpna-ldp] quit

[PE3-xcg-vpna] quit

(5)       配置CE 2

<CE2> system-view

[CE2] interface vlan-interface 10

[CE2-Vlan-interface10] ip address 100.1.1.2 24

[CE2-Vlan-interface10] quit

4. 验证配置

# 在PE 1上查看PW信息,可以看到建立了主备两条LDP PW。

<PE1> display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 2

1 up, 1 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpna

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

2.2.2.2         20                1151/1279       LDP    M     1          Up

3.3.3.3         30                1150/1279       LDP    B     1          Blocked

# 在PE 1上查看PW详细信息,可以看到主备两条LDP PW的详细信息。

<PE1> display l2vpn pw verbose

Xconnect-group Name: vpna

 Connection Name: ldp

  Peer: 2.2.2.2          PW ID: 20

    Signaling Protocol  : LDP

    Link ID             : 1          PW State : Up

    In Label            : 1151       Out Label: 1279

    Wait to Restore Time: 0 sec

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x260000002

    Tunnel NHLFE IDs    : 1025

  Peer: 3.3.3.3          PW ID: 30

    Signaling Protocol  : LDP

    Link ID             : 1          PW State : Blocked

    In Label            : 1150       Out Label: 1279

    MTU                 : 1500

    PW Attributes       : Backup

    VCCV CC             : -

    VCCV BFD            : -

    Tunnel Group ID     : 0x360000003

    Tunnel NHLFE IDs    : 1027

# 在PE 2上也可以看到LDP PW信息。

[PE2] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpna

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

1.1.1.1         20                1279/1151       LDP    M     1          Up

# 在PE 3上也可以看到LDP PW信息。

[PE3] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpna

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

1.1.1.1         30                1279/1150       LDP    M     1          Up

# CE 1与CE 2之间能够ping通。

# 在PE 1上使用l2vpn switchover命令手工切换工作链路。

<PE1> l2vpn switchover peer 2.2.2.2 pw-id 20

# 在PE 1上查看PW信息,可以看到工作链路发生了切换。

<PE1> display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 2

1 up, 1 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpna

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

2.2.2.2         20                1151/1279       LDP    M     1          Blocked

3.3.3.3         30                1150/1279       LDP    B     1          Up

# CE 1与CE 2之间仍然能够ping通。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!