国家 / 地区

11-可靠性配置指导

06-Monitor Link配置

本章节下载  (190.13 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500/Configure/Operation_Manual/H3C_S12500_CG-R7374-6W732/11/201505/868953_30005_0.htm

06-Monitor Link配置


1 Monitor Link

1.1  Monitor Link简介

Monitor Link是一种接口联动方案,通过监控设备的上行接口,根据其up/down状态的变化来触发下行接口up/down状态的变化,从而触发下游设备上的拓扑协议进行链路的切换,如图1-1所示。

图1-1 Monitor Link应用场景示意图

 

每个Monitor Link组都由上行接口和下行接口这两种成员接口组成,一个Monitor Link组可以有多个上行接口或下行接口,但一个接口只能属于一个Monitor Link组。

·     上行接口是被监控的接口,其所在链路被称为上行链路。Monitor Link组的状态与该接口的状态保持联动,当Monitor Link组中没有上行接口或所有上行接口都down时,Monitor Link组就处于down状态;而只要有一个上行接口up,Monitor Link组就处于up状态。

·     下行接口是监控接口,其所在链路被称为下行链路。该接口的状态与Monitor Link组的状态保持联动,当Monitor Link组的up/down状态发生改变时,下行接口的状态就会发生相应的改变,从而与Monitor Link组的状态保持一致。

图1-1所示,Device B的接口Port 1和Port 2组成了一个Monitor Link组,其中Port 1为上行接口,该接口所在的链路为上行链路;Port 2为下行接口,该接口所在的链路为下行链路。Device D上的情形也与Device B类似。

Monitor Link在运行中遵循以下机制:

1. 端口联动机制

每个Monitor Link组独立进行上行接口的监控和下行接口的联动。当Monitor Link组中没有上行接口或所有上行接口都down时,Monitor Link组就处于down状态,并将强制使其所有下行接口的状态都变为down;而只要有一个上行接口由down变为up,Monitor Link组的状态就恢复为up,并使其所有下行接口的状态都恢复为up。

提示

请勿通过接口开关命令来干预Monitor Link组中下行接口的状态。

 

2. 延时回切机制

通过延时回切机制可以避免由于上行链路震荡而导致Monitor Link组频繁地up/down。当Monitor Link组的上行接口恢复为up状态之后,下行接口先等待一段时间,若此时间过后上行接口仍然up,下行接口才恢复为up状态,这段时间就称为Monitor Link组的回切延时。

1.2  配置Monitor Link

1.2.1  创建Monitor Link组

表1-1 创建Monitor Link组

操作

命令

说明

进入系统视图

system-view

-

创建Monitor Link组,并进入Monitor Link组视图

monitor-link group group-id

缺省情况下,不存在任何Monitor Link组

 

1.2.2  配置Monitor Link组的成员接口

可在Monitor Link组视图或接口视图下配置Monitor Link组的成员接口,各视图下的配置效果相同。可配置为Monitor Link组成员接口的接口包括二层以太网接口、三层以太网接口、三层以太网子接口、二层聚合接口、三层聚合接口和三层聚合子接口。

配置时需要注意的是:

·     如果已将一个接口的主接口配置为Monitor Link组的下行接口,请勿再将该接口的子接口配置为任何Monitor Link组的上行接口,否则将影响Monitor Link协议的正常运行。

·     由于同一接口的主接口和子接口的up/down状态本身是联动的,因此请勿将它们配置为同一Monitor Link组的成员接口,否则将影响该Monitor Link组的性能。

·     一个接口只能属于一个Monitor Link组。

·     建议先配置Monitor Link的上行接口,以避免下行接口出现不必要的down/up状态变化。

1. Monitor Link组视图下的配置

表1-2 在Monitor Link组视图下配置Monitor Link组的成员接口

操作

命令

说明

进入系统视图

system-view

-

进入Monitor Link组视图

monitor-link group group-id

-

配置Monitor Link组的成员接口

port interface-type { interface-number | interface-number.subnumber } { downlink | uplink }

缺省情况下,Monitor Link组中没有成员接口

 

2. 接口视图下的配置

表1-3 在接口视图下配置Monitor Link组的成员接口

操作

命令

说明

进入系统视图

system-view

-

进入接口或子接口视图

interface interface-type { interface-number | interface-number.subnumber }

-

配置Monitor Link组的成员接口

port monitor-link group group-id { downlink | uplink }

缺省情况下,接口/子接口不是Monitor Link组的成员接口

 

1.2.3  配置Monitor Link组的回切延时

表1-4 配置Monitor Link组的回切延时

操作

命令

说明

进入系统视图

system-view

-

进入Monitor Link组视图

monitor-link group group-id

-

配置Monitor Link组的回切延时

downlink up-delay delay

缺省情况下,Monitor Link组的回切延时为0秒,即上行接口up后,下行接口立刻恢复为up状态

 

1.3  Monitor Link显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后Monitor Link组的运行情况。

表1-5 Monitor Link显示和维护

操作

命令

显示Monitor Link组的信息

display monitor-link group { group-id | all }

 

1.4  Monitor Link典型配置举例

说明

缺省情况下,以太网接口、VLAN接口及聚合接口处于DOWN状态。如果要使这些接口能够正常工作,请先使用undo shutdown命令使接口状态处于UP。

 

1. 组网需求

·     在图1-2所示的组网中,Device C为Smart Link设备,Device A、Device B和Device D为相关设备。Device C上VLAN 1~30的流量通过Smart Link组双上行到Device A。

·     通过配置,在Device C上实现双上行链路的灵活备份,并且当Device A与Device B(或Device D)之间出现链路故障时,Device C能够感知到这个故障并完成其上行链路的切换。

说明

有关Smart Link的详细介绍和配置,请参见“可靠性配置指导”中的“Smart Link”。

 

2. 组网图

图1-2 Monitor Link典型配置组网图

 

3. 配置步骤

(1)     配置Device C

# 创建VLAN 1~30,将这些VLAN都映射到MSTI 1上,并激活MST域的配置。

<DeviceC> system-view

[DeviceC] vlan 1 to 30

[DeviceC] stp region-configuration

[DeviceC-mst-region] instance 1 vlan 1 to 30

[DeviceC-mst-region] active region-configuration

[DeviceC-mst-region] quit

# 分别关闭端口GigabitEthernet3/0/1GigabitEthernet3/0/2,在这两个端口上分别关闭生成树协议,并将端口配置为Trunk端口且允许VLAN 130通过。

[DeviceC] interface GigabitEthernet 3/0/1

[DeviceC-GigabitEthernet3/0/1] shutdown

[DeviceC-GigabitEthernet3/0/1] undo stp enable

[DeviceC-GigabitEthernet3/0/1] port link-type trunk

[DeviceC-GigabitEthernet3/0/1] port trunk permit vlan 1 to 30

[DeviceC-GigabitEthernet3/0/1] quit

[DeviceC] interface GigabitEthernet 3/0/2

[DeviceC-GigabitEthernet3/0/2] shutdown

[DeviceC-GigabitEthernet3/0/2] undo stp enable

[DeviceC-GigabitEthernet3/0/2] port link-type trunk

[DeviceC-GigabitEthernet3/0/2] port trunk permit vlan 1 to 30

[DeviceC-GigabitEthernet3/0/2] quit

# 创建Smart Link1,并配置其保护VLANMSTI 1所映射的VLAN

[DeviceC] smart-link group 1

[DeviceC-smlk-group1] protected-vlan reference-instance 1

# 配置Smart Link组1的主端口为GigabitEthernet3/0/1,从端口为GigabitEthernet3/0/2。

[DeviceC-smlk-group1] port GigabitEthernet 3/0/1 primary

[DeviceC-smlk-group1] port GigabitEthernet 3/0/2 secondary

# 在Smart Link组1中使能发送Flush报文的功能。

[DeviceC-smlk-group1] flush enable

[DeviceC-smlk-group1] quit

# 重新开启端口GigabitEthernet3/0/1和GigabitEthernet3/0/2。

[DeviceC] interface GigabitEthernet 3/0/1

[DeviceC-GigabitEthernet3/0/1] undo shutdown

[DeviceC-GigabitEthernet3/0/1] quit

[DeviceC] interface GigabitEthernet 3/0/2

[DeviceC-GigabitEthernet3/0/2] undo shutdown

[DeviceC-GigabitEthernet3/0/2] quit

(2)     配置Device A

# 创建VLAN 1~30。

<DeviceA> system-view

[DeviceA] vlan 1 to 30

# 分别将端口GigabitEthernet3/0/1和GigabitEthernet3/0/2配置为Trunk端口且允许VLAN 1~30通过,并在这些端口上都使能接收Flush报文的功能。

[DeviceA] interface GigabitEthernet 3/0/1

[DeviceA-GigabitEthernet3/0/1] port link-type trunk

[DeviceA-GigabitEthernet3/0/1] port trunk permit vlan 1 to 30

[DeviceA-GigabitEthernet3/0/1] smart-link flush enable

[DeviceA-GigabitEthernet3/0/1] quit

[DeviceA] interface GigabitEthernet 3/0/2

[DeviceA-GigabitEthernet3/0/2] port link-type trunk

[DeviceA-GigabitEthernet3/0/2] port trunk permit vlan 1 to 30

[DeviceA-GigabitEthernet3/0/2] smart-link flush enable

[DeviceA-GigabitEthernet3/0/2] quit

(3)     配置Device B

# 创建VLAN 1~30。

<DeviceB> system-view

[DeviceB] vlan 1 to 30

# 分别将端口GigabitEthernet3/0/1和GigabitEthernet3/0/2配置为Trunk端口且允许VLAN 1~30通过,在端口GigabitEthernet3/0/2上关闭生成树协议,并在这些端口上都使能接收Flush报文的功能。

[DeviceB] interface GigabitEthernet 3/0/1

[DeviceB-GigabitEthernet3/0/1] port link-type trunk

[DeviceB-GigabitEthernet3/0/1] port trunk permit vlan 1 to 30

[DeviceB-GigabitEthernet3/0/1] smart-link flush enable

[DeviceB-GigabitEthernet3/0/1] quit

[DeviceB] interface GigabitEthernet 3/0/2

[DeviceB-GigabitEthernet3/0/2] undo stp enable

[DeviceB-GigabitEthernet3/0/2] port link-type trunk

[DeviceB-GigabitEthernet3/0/2] port trunk permit vlan 1 to 30

[DeviceB-GigabitEthernet3/0/2] smart-link flush enable

[DeviceB-GigabitEthernet3/0/2] quit

# 创建Monitor Link组1,并配置该组的上行接口为GigabitEthernet3/0/1,下行接口为GigabitEthernet3/0/2。

[DeviceB] monitor-link group 1

[DeviceB-mtlk-group1] port GigabitEthernet 3/0/1 uplink

[DeviceB-mtlk-group1] port GigabitEthernet 3/0/2 downlink

[DeviceB-mtlk-group1] quit

(4)     配置Device D

# 创建VLAN 1~30。

<DeviceD> system-view

[DeviceD] vlan 1 to 30

# 分别将端口GigabitEthernet3/0/1和GigabitEthernet3/0/2配置为Trunk端口且允许VLAN 1~30通过,在端口GigabitEthernet3/0/2上关闭生成树协议,并在这些端口上都使能接收Flush报文的功能。

[DeviceD] interface GigabitEthernet 3/0/1

[DeviceD-GigabitEthernet3/0/1] port link-type trunk

[DeviceD-GigabitEthernet3/0/1] port trunk permit vlan 1 to 30

[DeviceD-GigabitEthernet3/0/1] smart-link flush enable

[DeviceD-GigabitEthernet3/0/1] quit

[DeviceD] interface GigabitEthernet 3/0/2

[DeviceD-GigabitEthernet3/0/2] undo stp enable

[DeviceD-GigabitEthernet3/0/2] port link-type trunk

[DeviceD-GigabitEthernet3/0/2] port trunk permit vlan 1 to 30

[DeviceD-GigabitEthernet3/0/2] smart-link flush enable

[DeviceD-GigabitEthernet3/0/2] quit

# 创建Monitor Link组1,并配置该组的上行接口为GigabitEthernet3/0/1,下行接口为GigabitEthernet3/0/2。

[DeviceD] monitor-link group 1

[DeviceD-mtlk-group1] port GigabitEthernet 3/0/1 uplink

[DeviceD-mtlk-group1] port GigabitEthernet 3/0/2 downlink

[DeviceD-mtlk-group1] quit

4. 验证配置

通过使用display monitor-link group命令可以查看各设备上Monitor Link组的信息。例如当Device A的端口GigabitEthernet3/0/2由于链路故障而down掉时:

# 显示Device B上Monitor Link组1的信息。

[DeviceB] display monitor-link group 1

Monitor link group 1 information:

  Group status     : UP

  Downlink up-delay: 0(s)

  Last-up-time     : 16:38:26 2012/4/21

  Last-down-time   : 16:37:20 2012/4/21

 

  Member                    Role       Status

  ------------------------------------------

  GE3/0/1                   UPLINK     UP

  GE3/0/2                   DOWNLINK   UP

# 显示Device D上Monitor Link组1的信息。

[DeviceD] display monitor-link group 1

Monitor link group 1 information:

  Group status     : DOWN

  Downlink up-delay: 0(s)

  Last-up-time     : 16:37:20 2012/4/21

  Last-down-time   : 16:38:26 2012/4/21

 

  Member                    Role       Status

  ------------------------------------------

  GE3/0/1                   UPLINK     DOWN

  GE3/0/2                   DOWNLINK   DOWN

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部