国家 / 地区

07-IP组播配置指导

12-IPv6组播VLAN配置

本章节下载  (220.16 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500/Configure/Operation_Manual/H3C_S12500_CG-R7374-6W732/07/201505/868905_30005_0.htm

12-IPv6组播VLAN配置


1 IPv6组播VLAN

说明

设备支持两种运行模式:独立运行模式和IRF模式,缺省情况下为独立运行模式。有关IRF模式的介绍,请参见“虚拟化技术配置指导”中的“IRF”。

 

1.1  IPv6组播VLAN简介

图1-1所示,在传统的IPv6组播点播方式下,当属于不同VLAN的主机Host A、Host B和Host C同时点播同一IPv6组播组时,三层设备(Switch A)需要将IPv6组播数据为每个用户VLAN(即主机所属的VLAN)都复制一份后发送给二层设备(Switch B)。这样既造成了带宽的浪费,也给三层设备增加了额外的负担。

图1-1 未运行IPv6组播VLAN时的IPv6组播数据传输

 

可以使用IPv6组播VLAN功能解决这个问题。在二层设备上配置了IPv6组播VLAN后,三层设备只需将IPv6组播数据通过IPv6组播VLAN向二层设备发送一份即可,而不必为每个用户VLAN内都复制一份,从而节省了网络带宽,也减轻了三层设备的负担。

IPv6组播VLAN有以下两种实现和配置方式:

1. 基于子VLAN的IPv6组播VLAN

图1-2所示,接收者主机Host A、Host B和Host C分属不同的用户VLAN。在Switch B上配置VLAN 10为IPv6组播VLAN,将所有的用户VLAN都配置为该IPv6组播VLAN的子VLAN,并在IPv6组播VLAN及其子VLAN内都使能MLD Snooping。

图1-2 基于子VLAN的IPv6组播VLAN示意图

 

配置完成后,MLD Snooping将在IPv6组播VLAN中对路由器端口进行维护,而在各子VLAN中对成员端口进行维护。这样,Switch A只需将IPv6组播数据通过IPv6组播VLAN向Switch B发送一份即可,Switch B会将其复制分发给该IPv6组播VLAN内那些有接收者的子VLAN。

2. 基于端口的IPv6组播VLAN

说明

设备不支持基于端口的IPv6组播VLAN,此节仅供学习参考。

 

图1-3所示,接收者主机Host A、Host B和Host C分属不同的用户VLAN,Switch B上的所有用户端口(即连接主机的端口)均为Hybrid类型。在Switch A上配置VLAN 10为IPv6组播VLAN,将所有用户端口都添加到该IPv6组播VLAN内,并在IPv6组播VLAN和所有用户VLAN内都使能MLD Snooping。

图1-3 基于端口的IPv6组播VLAN示意图

 

配置完成后,当Switch B上的用户端口收到来自主机的MLD报文时,会为其打上IPv6组播VLAN的Tag并上送给MLD查询器,于是MLD Snooping就可以在IPv6组播VLAN中对路由器端口和成员端口进行统一的维护。这样,Switch A只需将IPv6组播数据通过IPv6组播VLAN向Switch B发送一份即可,Switch B会将其复制分发给该IPv6组播VLAN内的所有成员端口。

1.2  IPv6组播VLAN配置任务简介

表1-1 IPv6组播VLAN配置任务简介

配置任务

说明

详细配置

配置基于子VLAN的IPv6组播VLAN

必选

1.3 

配置IPv6组播VLAN转发表项的最大数量

可选

1.4 

 

说明

·     在已使能了IPv6组播路由的设备上不允许再配置IPv6组播VLAN。

·     IPv6组播VLAN功能在Secondary VLAN中不会生效,因此不建议在Secondary VLAN中配置此功能。有关Secondary VLAN的详细介绍,请参见“二层技术-以太网交换配置指导”中的“VLAN”。

 

1.3  配置基于子VLAN的IPv6组播VLAN

1.3.1  配置准备

在配置基于子VLAN的IPv6组播VLAN之前,需完成以下任务:

·     创建相应的VLAN

·     在欲配置为IPv6组播VLAN及其子VLAN的所有VLAN内使能MLD Snooping

1.3.2  配置基于子VLAN的IPv6组播VLAN

首先需要把某个VLAN配置为IPv6组播VLAN,再将用户VLAN添加到该IPv6组播VLAN内,使其成为IPv6组播VLAN的子VLAN。

提示

·     要配置为IPv6组播VLAN的指定VLAN必须存在,设备仅支持配置1个IPv6组播VLAN。

·     要添加到IPv6组播VLAN内的子VLAN必须存在。

 

表1-2 配置基于子VLAN的IPv6组播VLAN

操作

命令

说明

进入系统视图

system-view

-

配置指定VLAN为IPv6组播VLAN,并进入IPv6组播VLAN视图

ipv6 multicast-vlan vlan-id

缺省情况下,VLAN不是IPv6组播VLAN

向IPv6组播VLAN内添加子VLAN

subvlan vlan-list

缺省情况下,IPv6组播VLAN内没有子VLAN

 

1.4  配置IPv6组播VLAN转发表项的最大数量

用户可以调整IPv6组播VLAN转发表项的最大数量,当所有IPv6组播VLAN内维护的表项总数达到最大数量后,将不再创建新的表项,直至有表项被老化或被手工删除。

提示

在对IPv6组播VLAN转发表项的最大数量进行配置时,如果所有IPv6组播VLAN内的表项总数已超过了配置值,系统不会自动删除任何已存在的表项,也不再继续创建新的表项。在这种情况下,建议用户手工删除多余表项。

 

表1-3 配置IPv6组播VLAN转发表项的最大数量

操作

命令

说明

进入系统视图

system-view

-

配置IPv6组播VLAN转发表项的最大数量

ipv6 multicast-vlan entry-limit limit

缺省情况下 ,没有配置IPv6组播VLAN转发表项的最大数量

 

1.5  IPv6组播VLAN显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后IPv6组播VLAN的运行情况,通过查看显示信息验证配置的效果。

在用户视图下执行reset命令可以清除IPv6组播VLAN的统计信息。

表1-4 IPv6组播VLAN显示和维护

操作

命令

显示IPv6组播VLAN的信息

display ipv6 multicast-vlan [ vlan-id ]

显示IPv6组播VLAN的组播组表项信息(独立运行模式)

display ipv6 multicast-vlan group [ ipv6-source-address | ipv6-group-address | slot slot-number | verbose | vlan vlan-id ] *

显示IPv6组播VLAN的组播组表项信息(IRF模式)

display ipv6 multicast-vlan group [ ipv6-source-address | ipv6-group-address | chassis chassis-number slot slot-number | verbose | vlan vlan-id ] *

显示IPv6组播VLAN转发表的信息(独立运行模式)

display ipv6 multicast-vlan forwarding-table [ ipv6-source-address [ prefix-length ] | ipv6-group-address [ prefix-length ] | slot slot-number | subvlan vlan-id | vlan vlan-id ] *

显示IPv6组播VLAN转发表的信息(IRF模式)

display ipv6 multicast-vlan forwarding-table [ ipv6-source-address [ prefix-length ] | ipv6-group-address [ prefix-length ] | chassis chassis-number slot slot-number | subvlan vlan-id | vlan vlan-id ] *

清除IPv6组播VLAN的组播组表项

reset ipv6 multicast-vlan group [ ipv6-group-address [ prefix-length ] | ipv6-source-address [ prefix-length ] | vlan vlan-id ] *

 

1.6  基于子VLAN的IPv6组播VLAN典型配置举例

说明

缺省情况下,以太网接口、VLAN接口及聚合接口处于DOWN状态。如果要使这些接口能够正常工作,请先使用undo shutdown命令使接口状态处于UP。

 

1. 组网需求

·     如图1-4所示,三层交换机Switch A通过接口VLAN-interface20连接IPv6组播源(Source),通过接口VLAN-interface10连接二层交换机Switch B;Switch A上运行MLDv1,Switch B上运行版本1的MLD Snooping,并由Switch A充当MLD查询器。

·     IPv6组播源向IPv6组播组FF1E::101发送IPv6组播数据,Host A~Host C都是该IPv6组播组的接收者(Receiver),且分别属于VLAN 2~VLAN 4。

·     通过在Switch B上配置基于子VLAN的IPv6组播VLAN,Switch A通过IPv6组播VLAN向Switch B下分属不同用户VLAN的主机分发IPv6组播数据。

2. 组网图

图1-4 基于子VLAN的IPv6组播VLAN配置组网图

 

3. 配置步骤

(1)     配置Switch A

# 使能IPv6组播路由。

<SwitchA> system-view

[SwitchA] ipv6 multicast routing

[SwitchA-mrib6] quit

# 创建VLAN 20,并将端口GigabitEthernet3/0/2加入该VLAN

[SwitchA] vlan 20

[SwitchA-vlan20] port GigabitEthernet 3/0/2

[SwitchA-vlan20] quit

# 在接口VLAN-interface20上配置IPv6地址,并使能IPv6 PIM-DM

[SwitchA] interface vlan-interface 20

[SwitchA-Vlan-interface20] ipv6 address 1::2 64

[SwitchA-Vlan-interface20] ipv6 pim dm

[SwitchA-Vlan-interface20] quit

# 创建VLAN 10,配置端口GigabitEthernet3/0/1Hybrid端口,并允许VLAN 10的报文带Tag通过。

[SwitchA] vlan 10

[SwitchA-vlan10] quit

[SwitchA] interface GigabitEthernet 3/0/1

[SwitchA-GigabitEthernet3/0/1] port link-type hybrid

[SwitchA-GigabitEthernet3/0/1] port hybrid vlan 10 tagged

[SwitchA-GigabitEthernet3/0/1] quit

# 在接口VLAN-interface10上配置IPv6地址,并使能MLDIPv6 PIM-DM

[SwitchA] interface vlan-interface 10

[SwitchA-Vlan-interface10] ipv6 address 2001::1 64

[SwitchA-Vlan-interface10] mld enable

[SwitchA-Vlan-interface10] ipv6 pim dm

[SwitchA-Vlan-interface10] quit

(2)     配置Switch B

# 全局使能MLD Snooping。

<SwitchB> system-view

[SwitchB] mld-snooping

[SwitchB-mld-snooping] quit

# 创建VLAN 2,将端口GigabitEthernet3/0/2加入该VLAN,并在该VLAN内使能MLD Snooping

[SwitchB] vlan 2

[SwitchB-vlan2] port GigabitEthernet 3/0/2

[SwitchB-vlan2] mld-snooping enable

[SwitchB-vlan2] quit

# 创建VLAN 3,将端口GigabitEthernet3/0/3加入该VLAN,并在该VLAN内使能MLD Snooping

[SwitchB] vlan 3

[SwitchB-vlan3] port GigabitEthernet 3/0/3

[SwitchB-vlan3] mld-snooping enable

[SwitchB-vlan3] quit

# 创建VLAN 4,将端口GigabitEthernet3/0/4加入该VLAN,并在该VLAN内使能MLD Snooping

[SwitchB] vlan 4

[SwitchB-vlan4] port GigabitEthernet 3/0/4

[SwitchB-vlan4] mld-snooping enable

[SwitchB-vlan4] quit

# 创建VLAN 10,在该VLAN内使能MLD Snooping

[SwitchB] vlan 10

[SwitchB-vlan10] mld-snooping enable

[SwitchB-vlan10] quit

# 配置端口GigabitEthernet3/0/1Hybrid端口,并允许VLAN 10的报文带Tag通过。

[SwitchB] interface GigabitEthernet 3/0/1

[SwitchB-GigabitEthernet3/0/1] port link-type hybrid

[SwitchB-GigabitEthernet3/0/1] port hybrid vlan 10 tagged

[SwitchB-GigabitEthernet3/0/1] quit

# 配置VLAN 10IPv6组播VLAN,并把VLAN 2VLAN 4都配置为该IPv6组播VLAN的子VLAN

[SwitchB] ipv6 multicast-vlan 10

[SwitchB-ipv6-mvlan-10] subvlan 2 to 4

[SwitchB-ipv6-mvlan-10] quit

4. 验证配置

# 显示Switch B上所有IPv6组播VLAN的信息。

[SwitchB] display ipv6 multicast-vlan

Total 1 IPv6 multicast VLANs.

 

IPv6 multicast VLAN 10:

  Sub-VLAN list(3 in total):

     2-4

  Port list(0 in total):

# 显示Switch B上IPv6组播VLAN的所有组播组表项信息。

[SwitchB] display ipv6 multicast-vlan group

Total 1 entries.

 

IPv6 multicast VLAN 10: Total 1 entries.

  (::, FF1E::101)

    Sub-VLANs (3 in total):

      VLAN 2

      VLAN 3

      VLAN 4

由此可见,IPv6组播VLAN(VLAN 10)在各子VLAN(VLAN 2~VLAN 4)内维护表项。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!