选择区域语言: EN CN HK

05-三层技术-IP路由配置举例

04-H3C_S12500-S_IS-IS配置举例

本章节下载  (178.49 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500-S/Configure/Typical_Configuration_Example/H3C_S12500-S_Example-R7150P02-6W100/05/201505/867814_30005_0.htm

04-H3C_S12500-S_IS-IS配置举例

H3C S12500-S IS-IS典型配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2015杭州华三通信技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,

并不得以任何形式传播。本文档中的信息可能变动,恕不另行通知。

H3C_彩色.emf

 



1  简介

本文档介绍IS-IS配置举例。

2  配置前提

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解IS-IS特性。

3  配置举例

3.1  组网需求

图1所示,某公司总部和分部使用IS-IS路由协议进行互联。公司总部内为市场部(Mkt dept.)和财务部(F&A dept.)设置了独立的网络。该公司的合作伙伴使用的是OSPF路由协议。现要求:

·     公司总部内市场部和财务部可以通信;并通过配置路由渗透功能,实现总部与分部间,市场部与分部可以正常通信,财务部与分部无法通信,且分部无法查看到财务部的路由信息。

·     将合作伙伴的OSPF路由引入公司分部的网络中,并保证市场部与合作伙伴可以通信。

·     当总部的网关设备Switch C IS-IS协议进程重启时,原有的通信不中断。

图1 IS-IS配置组网图

 

3.2  配置思路

·     为了实现公司总部内市场部和财务部的相互通信,在area 10区域部署Level-1路由器。

·     为了使公司总部内财务部和公司分部不能相互通信,且公司分部无法查看财务部的路由,需要通过在Switch C上配置IS-IS路由渗透并引用地址前缀列表来实现Level-1区域只将10.100.1.0/24网段的路由信息向Level-2发布。

·     为了实现公司总部内市场部与合作伙伴的网络互通,需要在Switch D的IS-IS进程中引入OSPF进程的路由,并在OSPF进程中引入IS-IS进程的路由。

·     为了保证Switch C IS-IS协议进程重启时,原有的通信不中断,需要在Switch C上使能IS-IS协议的GR(Graceful Restart,平滑重启)能力。

3.3  使用版本

本举例是在S12500-S-CMW710-R7150P02版本上进行配置和验证的。

3.4  配置注意事项

在设备平滑重启过程中,请勿变更拓扑,否则可能导致路由黑洞。

3.5  配置步骤

3.5.1  Switch A的配置

# 配置接口Vlan-interface 11地址。

<SwitchA> system-view

[SwitchA] interface vlan-interface 11

[SwitchA-Vlan-interface11] ip address 192.168.1.1 24

[SwitchA-Vlan-interface11] quit

# 请参考以上方法配置图1中Switch A的其它接口的IP地址,具体配置过程略。

# 配置IS-IS基本功能。

[SwitchA] isis 1

[SwitchA-isis-1] is-level level-1

[SwitchA-isis-1] network-entity 10.1921.6800.1001.00

[SwitchA-isis-1] quit

[SwitchA] interface vlan-interface 11

[SwitchA–Vlan-interface11] isis enable 1

[SwitchA–Vlan-interface11] quit

[SwitchA] interface vlan-interface 100

[SwitchA–Vlan-interface100] isis enable 1

[SwitchA–Vlan-interface100] quit

3.5.2  Switch B的配置

# 配置接口Vlan-interface 12的IP地址。

<SwitchB> system-view

[SwitchB] interface vlan-interface 12

[SwitchB-Vlan-interface12] ip address 192.168.2.1 24

[SwitchB-Vlan-interface12] quit

# 请参考以上方法配置图1中Switch B的其它接口的IP地址,具体配置过程略。

# 配置IS-IS基本功能。

[SwitchB] isis 1

[SwitchB-isis-1] is-level level-1

[SwitchB-isis-1] network-entity 10.1921.6800.2001.00

[SwitchB-isis-1] quit

[SwitchB] interface vlan-interface 12

[SwitchB–Vlan-interface12] isis enable 1

[SwitchB–Vlan-interface12] quit

[SwitchB] interface vlan-interface 200

[SwitchB–Vlan-interface 200] isis enable 1

[SwitchB–Vlan-interface 200] quit

3.5.3  Switch C的配置

# 配置接口Vlan-interface11的IP地址。

<SwitchC> system-view

[SwitchC] interface vlan-interface 11

[SwitchC-Vlan-interface11] ip address 192.168.1.2 24

[SwitchC-Vlan-interface11] quit

# 请参考以上方法配置图1中Switch C的其它接口的IP地址,具体配置过程略。

# 配置IS-IS基本功能。

[SwitchC] isis 1

[SwitchC-isis-1] network-entity 10.1921.6801.0001.00

[SwitchC-isis-1] quit

[SwitchC] interface vlan-interface 10

[SwitchC–Vlan-interface10] isis enable 1

[SwitchC–Vlan-interface10] quit

[SwitchC] interface vlan-interface 11

[SwitchC–Vlan-interface11] isis enable 1

[SwitchC–Vlan-interface11] quit

[SwitchC] interface vlan-interface 12

[SwitchC–Vlan-interface12] isis enable 1

[SwitchC–Vlan-interface12] quit

# 配置IS-IS路由渗透,并引用名为1的地址前缀列表,实现Level-1区域只将10.100.1.0/24网段的路由信息向Level-2发布。

[SwitchC] ip prefix-list 1 permit 10.100.1.0 24

[SwitchC] isis 1

[SwitchC-isis-1] address-family ipv4

[SwitchC-isis-1-ipv4] import-route isis level-1 into level-2 filter-policy prefix-list 1

[SwitchC-isis-1-ipv4] quit

[SwitchC-isis-1] import-route isis level-1 into level-2 filter-policy prefix-list 1

# 使能IS-IS协议的GR能力。

[SwitchC-isis-1] graceful-restart

[SwitchC-isis-1] quit

3.5.4  Switch D的配置

# 配置接口Vlan-interface10的IP地址。

<SwitchD> system-view

[SwitchD] interface vlan-interface 10

[SwitchD- Vlan-interface10] ip address 192.168.10.2 24

[SwitchD- Vlan-interface10] quit

# 请参考以上方法配置图1中Switch D的其它接口的IP地址,具体配置过程略。

# 配置IS-IS基本功能。

[SwitchD] isis 1

[SwitchD-isis-1] is-level level-2

[SwitchD-isis-1] network-entity 10.1921.6802.0001.00

[SwitchD-isis-1] quit

[SwitchD] interface vlan-interface 10

[SwitchD–Vlan-interface10] isis enable 1

[SwitchD–Vlan-interface10] quit

[SwitchD] interface vlan-interface 20

[SwitchD–Vlan-interface20] isis enable 1

[SwitchD–Vlan-interface20] quit

# 配置OSPF基本功能。

[SwitchD] ospf

[SwitchD-ospf-1] area 0

[SwitchD-ospf-1-area-0.0.0.0] network 192.168.20.0 0.0.0.255

[SwitchD-ospf-1-area-0.0.0.0] quit

[SwitchD-ospf-1] quit

# 配置IS-IS进程引入OSPF进程的路由和直连路由。

[SwitchD] isis 1

[SwitchD-isis-1] address-family ipv4

[SwitchD-isis-1-ipv4] import-route ospf

[SwitchD-isis-1-ipv4] import-route direct

[SwitchD-isis-1-ipv4] quit

[SwitchD-isis-1] import-route ospf

[SwitchD-isis-1] import-route direct

[SwitchD-isis-1] quit

# 配置OSPF进程引入IS-IS进程的路由和直连路由。

[SwitchD] ospf 1

[SwitchD-ospf-1] import-route isis 1

[SwitchD-ospf-1] import-route direct

3.5.5  Switch E的配置

# 配置接口Vlan-interface20的IP地址。

<SwitchE> system-view

[SwitchE] interface Vlan-interface20

[SwitchE-Vlan-interface12] ip address 192.168.20.2 24

[SwitchE-Vlan-interface12] quit

# 请参考以上方法配置图1中Switch E的其它接口的IP地址,具体配置过程略。

# 配置OSPF基本功能。

[SwitchE] ospf

[SwitchE-ospf-1] area 0

[SwitchE-ospf-1-area-0.0.0.0] network 192.168.20.0 0.0.0.255

[SwitchE-ospf-1-area-0.0.0.0] network 10.200.1.0 0.0.0.255

[SwitchE-ospf-1-area-0.0.0.0] quit

[SwitchE-ospf-1] quit

3.6  验证配置

(1)     在Switch D上查看IS-IS路由表,可以查看到市场部(10.100.1.0/24)的路由,无法查看到财务部(10.100.2.0/24)的路由,说明公司分部只能与市场部通信。

[SwitchD] display isis route

 

                         Route information for IS-IS(1)

                         ------------------------------

 

                         Level-2 IPv4 Forwarding Table

                         -----------------------------

 

 IPv4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags

-------------------------------------------------------------------------------

 192.168.10.0/24      10         NULL    Vlan10          Direct          D/L/-

 192.168.1.0/24       20         NULL    Vlan10          192.168.10.1    R/-/-

 10.100.1.0/24        30         NULL    Vlan10          192.168.10.1    R/-/-

 192.168.2.0/24       20         NULL    Vlan10          192.168.10.1    R/-/-

 

      Flags: D-Direct, R-Added to Rib, L-Advertised in LSPs, U-Up/Down Bit Set

(2)     在Switch C上查看IS-IS路由表,可以看到10.200.1.0/24的路由,并且可以ping通10.200.1.1,说明本公司与合作伙伴可以正常通信。

# 查看Switch C上的IS-IS路由表。

[SwitchC] display isis route

 

                         Route information for IS-IS(1)

                         ------------------------------

 

                         Level-1 IPv4 Forwarding Table

                         -----------------------------

 

 IPv4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags

-------------------------------------------------------------------------------

 192.168.10.0/24      10         NULL    Vlan10          Direct          D/L/-

 192.168.1.0/24       10         NULL    Vlan11          Direct          D/L/-

 10.100.1.0/24        20         NULL    Vlan11          192.168.1.1     R/L/-

 10.100.2.0/24        20         NULL    Vlan12          192.168.2.1     R/-/-

 192.168.2.0/24       10         NULL    Vlan12          Direct          D/L/-

 

      Flags: D-Direct, R-Added to Rib, L-Advertised in LSPs, U-Up/Down Bit Set

 

                         Level-2 IPv4 Forwarding Table

                         -----------------------------

 

 IPv4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags

-------------------------------------------------------------------------------

 192.168.10.0/24      10         NULL    Vlan10          Direct          D/L/-

 10.200.1.0/24        10         0       Vlan10          192.168.10.2    R/-/-

 192.168.20.0/24      10         0       Vlan10          192.168.10.2    R/-/-

 192.168.1.0/24       10         NULL    Vlan11          Direct          D/L/-

 192.168.2.0/24       10         NULL    Vlan12          Direct          D/L/-

 

      Flags: D-Direct, R-Added to Rib, L-Advertised in LSPs, U-Up/Down Bit Set

# 从Switch C ping 10.200.1.1。

[SwitchC] ping 10.200.1.1

Ping 10.200.1.1 (10.200.1.1): 56 data bytes, press CTRL_C to break

56 bytes from 10.200.1.1: icmp_seq=0 ttl=254 time=1.862 ms

56 bytes from 10.200.1.1: icmp_seq=1 ttl=254 time=2.969 ms

56 bytes from 10.200.1.1: icmp_seq=2 ttl=254 time=1.402 ms

56 bytes from 10.200.1.1: icmp_seq=3 ttl=254 time=1.324 ms

56 bytes from 10.200.1.1: icmp_seq=4 ttl=254 time=1.510 ms

 

--- Ping statistics for 10.200.1.1 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 1.324/1.813/2.969/0.606 ms

(3)     在Switch A上持续ping Switch B,期间在Switch C上重启IS-IS进程,查看Switch C的IS-IS协议重启时,通信是否中断。并使用display isis graceful-restart status命令,可查看Switch C上IS-IS协议的GR状态。

# 在Switch A上持续ping Switch B。

[SwitchA] ping -c 10000 10.100.2.1

Ping 10.100.2.1 (10.100.2.1): 56 data bytes, press CTRL_C to break

56 bytes from 10.100.2.1: icmp_seq=0 ttl=254 time=1.185 ms

56 bytes from 10.100.2.1: icmp_seq=1 ttl=254 time=1.087 ms

……

# 重启Switch C的IS-IS进程。

<SwitchC> reset isis all graceful-restart

Reset IS-IS process? [Y/N] :y

# 在Switch A上查看到IS-IS协议重启时通信未发生中断。

[SwitchA] ping -c 10000 10.100.2.1

Ping 10.100.2.1 (10.100.2.1): 56 data bytes, press CTRL_C to break

56 bytes from 10.100.2.1: icmp_seq=0 ttl=254 time=1.185 ms

56 bytes from 10.100.2.1: icmp_seq=1 ttl=254 time=1.087 ms

56 bytes from 13.13.13.3: icmp_seq=2 ttl=254 time=1.672 ms

56 bytes from 13.13.13.3: icmp_seq=3 ttl=254 time=1.751 ms

56 bytes from 13.13.13.3: icmp_seq=4 ttl=254 time=1.816 ms

56 bytes from 13.13.13.3: icmp_seq=5 ttl=254 time=1.814 ms

# 查看Switch C上IS-IS协议的GR状态。

[SwitchC] display isis graceful-restart status

 

                        Restart information for IS-IS(1)

                        --------------------------------

Restart status: COMPLETE

Restart phase: Finish

Restart t1: 3, count 10; Restart t2: 60; Restart t3: 300

SA Bit: supported

 

                          Level-1 restart information

                          ---------------------------

Total number of interfaces: 3

Number of waiting LSPs: 0

 

                          Level-2 restart information

                          ---------------------------

Total number of interfaces: 3

Number of waiting LSPs: 0

3.7  配置文件

·     Switch A:

#

isis 1

 is-level level-1

 network-entity 10.1921.6800.1001.00

#

vlan 11

#

vlan 100

#

interface Vlan-interface11

 ip address 192.168.1.1 255.255.255.0

 isis enable 1

#

interface Vlan-interface100

 ip address 10.100.1.1 255.255.255.0

 isis enable 1

#

·     Switch B:

#

isis 1

 is-level level-1

 network-entity 10.1921.6800.2001.00

#

vlan 12

#

vlan 200

#

interface Vlan-interface12

 ip address 192.168.2.1 255.255.255.0

 isis enable 1

#

interface Vlan-interface200

 ip address 10.100.2.1 255.255.255.0

 isis enable 1

#

·     Switch C:

#

isis 1

 graceful-restart

 network-entity 10.1921.6801.0001.00

 import-route isis level-1 into level-2 filter-policy prefix-list 1

#

isis 1

 graceful-restart

 network-entity 10.1921.6801.0001.00

 #

 address-family ipv4 unicast

  import-route isis level-1 into level-2 filter-policy prefix-list 1

#

vlan 11 to 13

#

interface Vlan-interface11

 ip address 192.168.1.2 255.255.255.0

 isis enable 1

#

interface Vlan-interface12

 ip address 192.168.2.2 255.255.255.0

 isis enable 1

#

interface Vlan-interface13

 ip address 192.168.10.1 255.255.255.0

 isis enable 1

#

 ip prefix-list 1 index 10 permit 10.100.1.0 24

#

·     Switch D:

#

isis 1

 is-level level-2

 network-entity 10.1921.6802.0001.00

 import-route direct

 import-route ospf 1

 #

 address-family ipv4 unicast

  import-route direct

  import-route ospf 1

#

ospf 1

 import-route direct

 import-route isis 1

 area 0.0.0.0

  network 192.168.20.0 0.0.0.255

#

vlan 10

#

vlan 20

#

interface Vlan-interface10

 ip address 192.168.10.2 255.255.255.0

 isis enable 1

#

interface Vlan-interface20

 ip address 192.168.20.1 255.255.255.0

#

·     Switch E:

#

ospf 1

 area 0.0.0.0

  network 10.200.1.0 0.0.0.255

  network 192.168.20.0 0.0.0.255

#

vlan 20

#

vlan 300

#

interface Vlan-interface20

 ip address 192.168.20.2 255.255.255.0

#

interface Vlan-interface300

 ip address 10.200.1.1 255.255.255.0

#

4  相关资料

·     H3C S12500-S系列交换机 三层技术-IP路由配置指导-Release 7150P02

·     H3C S12500-S系列交换机 三层技术-IP路由命令参考-Release 7150P02

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!