选择区域语言: EN CN HK

04-二层技术-以太网交换配置指导

11-VLAN终结配置

本章节下载  (416.85 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500/Configure/Operation_Manual/H3C_S12500_CG-R1828P04-6W182/04/201407/834572_30005_0.htm

11-VLAN终结配置


1 VLAN终结

说明

当系统工作模式为标准模式时,设备不支持QinQ终结功能。有关系统工作模式命令的介绍,请参见“基础配置命令参考”中的“设备管理”。

 

1.1  VLAN终结简介

VLAN终结是指对接收到的报文,按照报文携带的VLAN Tag信息匹配对应的接口后,去除报文VLAN Tag,再将报文进行三层转发或交由其他业务处理;对从配置了VLAN终结的接口发送的报文,按照该接口上的终结配置,将相应的VLAN Tag添加到报文中后发送该报文。

1.1.1  VLAN终结分类

根据对所终结的报文的不同处理方式,VLAN终结分为以下两种:

·     Dot1q终结:用来终结带有一层及以上VLAN Tag的报文的最外一层VLAN Tag(要求最外层VLAN ID必须匹配当前VLAN接口的编号),设备上每个VLAN接口缺省支持Dot1q终结,无须配置。从VLAN接口发送的报文,都添加一层本VLAN的Tag。

·     QinQ终结:用来终结带有两层及以上VLAN Tag的报文的最外两层VLAN Tag(要求最外层VLAN ID必须匹配当前VLAN接口的编号),从配置了QinQ终结的接口发送的报文,都添加两层VLAN Tag。

1.1.2  VLAN终结应用场景

1. 指定VLAN间的互通

划分VLAN后,不同VLAN间的主机不能直接通信,使用三层路由技术可以实现所有VLAN间报文的互通。此时如果要对互通的VLAN范围做限制,即要求只有指定的部分VLAN间可以互通,可以借助VLAN终结功能来实现。目前可以通过VLAN接口实现指定VLAN间的互通。

图1-1所示,Host A属于VLAN 2,Host B属于VLAN 3,Host C属于VLAN 4,Device上创建了VLAN接口Vlan-interface2和Vlan-interface3。将Host A的网关地址指定为1.1.1.1/24,Host B的网关地址指定为1.1.2.1/24,就可以实现Host A和Host B的三层报文互通了:当Vlan-interface2收到Host A的报文时,去掉VLAN Tag,再转发给Vlan-interface3,Vlan-interface3在发送该报文时添加本VLAN的 Tag(VLAN 3),使该报文到达Host B;反之亦然。

Host C由于没有对应的VLAN接口终结VLAN 4的报文,不能与Host A或Host B互通。

图1-1 VLAN终结用于指定VLAN之间三层互通(VLAN接口)

 

2. 局域网和广域网的互联

局域网内的报文大多数都带有VLAN Tag,但一些广域网协议并不能识别VLAN报文,比如ATM、FR和PPP等,这种情况下,如果局域网的VLAN报文要转发到广域网,需要在本地记录并去掉报文的VLAN信息后再转发,可以借助VLAN终结功能来实现。目前可以通过VLAN接口实现局域网和广域网的互联。

图1-2所示,用户网络的私网VLAN为Customer VLAN。运营商为用户网络分配的公网VLAN为Service VLAN。当用户网内Customer VLAN的报文进入运营商网络时,报文外面就会被封装上Service VLAN的VLAN Tag。在运营商网基于Service VLAN进行转发。如果报文要发往外部WAN,则需要在出口网关(Device)上对该报文进行VLAN终结处理,去掉两层VLAN Tag,再发送到WAN。

图1-2 VLAN终结用于LAN和WAN的互联

 

 

1.1.3  VLAN终结组网方案

对于QinQ终结,有以下两种组网方案:

1. 传统方案

图1-3所示,在汇聚层设备上配置QinQ功能,在核心层设备上配置QinQ终结功能。

图1-3 QinQ终结组网-传统方案

 

说明

在配置举例中,除非在标题中注明“精简方案”,否则均为传统方案。

 

2. 精简方案

图1-4所示,在核心层设备上同时配置QinQ功能和QinQ终结功能,不需要部署汇聚层设备。

配置本方案时需要注意:在核心层设备上创建VLAN接口进行QinQ终结时,要确保终结的内层VLAN ID(Customer VLAN)不包含当前VLAN接口编号。

图1-4 QinQ终结组网-精简方案

 

1.2  VLAN终结配置任务简介

表1-1 VLAN终结配置任务简介

配置任务

说明

详细配置

配置QinQ终结

配置明确的QinQ终结

两者至少选其一

1.3.1 

配置模糊的QinQ终结

1.3.2 

配置VLAN终结支持广播/组播

可选

1.4 

配置VLAN Tag的TPID值

可选

1.5 

 

1.3  配置QinQ终结

根据每个接口所能终结的VLAN报文的内层VLAN ID范围的不同,QinQ终结分为:

·     明确的QinQ终结:发送VLAN报文时可以添加的内层VLAN ID只有一个。

·     模糊的QinQ终结:发送VLAN报文时可以添加的内层VLAN ID为多个。

配置了QinQ终结的VLAN接口只允许接收最外层VLAN ID等于当前VLAN接口编号的报文,其他VLAN报文则不允许通过该VLAN接口。收到报文后,将报文最外两层VLAN Tag剥离。发送报文时,会给报文添加两层VLAN Tag。添加VLAN Tag时,报文的外层VLAN ID为当前VLAN接口的编号,内层VLAN ID必须在配置的范围内,否则丢弃该报文。内层VLAN ID取值为:对于DHCP中继转发的DHCP服务器端报文,通过查找DHCP中继用户地址表项获取相应的VLAN ID;对于MPLS和其他IPv4报文,根据目标IP地址查找ARP表项获取相应的VLAN ID。

当VLAN接口下的QinQ终结配置发生改变时,需要在用户视图下使用reset arp interface命令来更新该VLAN接口绑定的二层物理接口的ARP。关于reset arp命令请参见“IP业务配置指导”中的“ARP”。

 

1.3.1  配置明确的QinQ终结

表1-2 配置明确的QinQ终结

操作

命令

说明

进入系统视图

system-view

-

进入VLAN接口视图

interface vlan-interface interface-number

-

使能当前接口的QinQ终结功能,并指定当前接口发送VLAN报文时可以添加的内层VLAN ID(外层VLAN ID等于当前VLAN接口的编号,不能配置)

second-dot1q vlan-id

必选

缺省情况下,QinQ终结功能未使能,VLAN接口只终结外层VLAN Tag

 

1.3.2  配置模糊的QinQ终结

表1-3 配置模糊的QinQ终结

操作

命令

说明

进入系统视图

system-view

-

进入VLAN接口视图

interface vlan-interface interface-number

-

使能当前接口的QinQ终结功能,并指定当前接口发送VLAN报文时可以添加的内层VLAN ID范围(外层VLAN ID等于当前VLAN接口的编号,不能配置)

second-dot1q { vlan-list | any }

必选

缺省情况下,QinQ终结功能未使能,VLAN接口只终结外层VLAN Tag

 

1.4  配置VLAN终结支持广播/组播

当接口下配置了模糊的QinQ终结功能后,不允许发送广播、组播报文。只有配置了VLAN终结支持广播/组播功能,这些接口才能发送广播/组播报文。

表1-4 配置VLAN终结支持广播/组播

操作

命令

说明

进入系统视图

system-view

-

进入VLAN接口视图

interface vlan-interface interface-number

-

配置允许当前接口发送广播和组播报文

vlan-termination broadcast enable

必选

缺省情况下,当前接口配置了模糊的QinQ终结功能后,不允许发送广播、组播报文

 

1.5  配置VLAN Tag的TPID值

说明

对于QinQ终结组网,只有“精简方案“支持配置TPID值为非缺省值。

 

如果要在VLAN接口上使用VLAN终结功能,可以指定VLAN接口绑定的二层物理接口接收和发送报文的VLAN Tag的TPID(Tag Protocol Identifier,标签协议标识符)值。在配置TPID值后,当接收报文时,只有报文最外层VLAN Tag的TPID值为配置值的报文才会作为VLAN报文来处理。

如果不指定TPID值的话,将使用缺省值0x8100。二层物理接口TPID值配置的相关内容请参见“二层技术-以太网交换配置指导”中的“QinQ”。

1.6  VLAN终结配置举例

说明

缺省情况下,以太网接口、VLAN接口及聚合接口处于DOWN状态。如果要对这些接口进行配置,请先使用undo shutdown命令使接口状态处于UP。

 

1.6.1  明确的QinQ终结配置举例

1. 组网需求

如下图所示,Host A和L2 Switch A相连,属于VLAN 11;Host B和L2 Switch D相连,L2 Switch D只支持一层VLAN标签;L2 Switch B上使能了QinQ功能,它会给收到的内层VLAN ID为11的报文外面添加一层VLAN ID为100的VLAN Tag后再转发出去。现需要实现Host A与Host B之间能够互相通信。

2. 组网图

图1-5 明确的QinQ终结配置组网图

 

说明

·     报文从L2 Switch B发往L3 Switch C时带有两层VLAN Tag,外层VLAN为100,内层VLAN为11;报文到达L3 Switch C的VLAN接口100时,需要终结两层Tag再进行三层转发。

·     报文从Host B发到L3 Switch C上时进行三层转发,需要通过VLAN接口100给报文封装两层VLAN Tag并发出去。报文外层VLAN为100,内层VLAN为11(由second-dot1q命令配置和设备学习到的ARP表项决定)。该报文到达L2 Switch B后,由于GE4/0/2是一个PVID为100的Trunk端口,该端口会将报文的外层VLAN Tag 100去掉后再发送给L2 Switch A。

 

3. 配置步骤

(1)     Host A、Host B的配置

将Host A的IP地址指定为1.1.1.1/24,网关地址指定为1.1.1.11/24;Host B的IP地址为1.1.2.1/24,网关地址指定为1.1.2.11/24。

(2)     L2 Switch A的配置

# 向VLAN 11中加入端口GigabitEthernet3/0/2。

<L2_SwitchA> system-view

[L2_SwitchA] vlan 11

[L2_SwitchA-vlan11] port GigabitEthernet 3/0/2

[L2_SwitchA-vlan11] quit

# 配置端口GigabitEthernet3/0/1的链路类型为Hybrid类型,且允许VLAN 11的报文带Tag通过。

[L2_SwitchA] interface GigabitEthernet 3/0/1

[L2_SwitchA-GigabitEthernet3/0/1] port link-type hybrid

[L2_SwitchA-GigabitEthernet3/0/1] port hybrid vlan 11 tagged

(3)     L2 Switch B的配置

# 配置端口GigabitEthernet4/0/2的链路类型为Trunk类型,并允许VLAN 100通过。

<L2_SwitchB> system-view

[L2_SwitchB] interface GigabitEthernet 4/0/2

[L2_SwitchB-GigabitEthernet4/0/2] port link-type trunk

[L2_SwitchB-GigabitEthernet4/0/2] port trunk permit vlan 100

# 配置端口GigabitEthernet4/0/2的缺省VLANVLAN 100,并使能QinQ功能,使该端口为收到的报文添加VLAN ID为100的外层VLAN Tag。

[L2_SwitchB-GigabitEthernet4/0/2] port trunk pvid vlan 100

[L2_SwitchB-GigabitEthernet4/0/2] qinq enable

[L2_SwitchB-GigabitEthernet4/0/2] quit

# 配置端口GigabitEthernet4/0/1的链路类型为Trunk类型,并允许VLAN 100通过。

[L2_SwitchB] interface GigabitEthernet 4/0/1

[L2_SwitchB-GigabitEthernet4/0/1] port link-type trunk

[L2_SwitchB-GigabitEthernet4/0/1] port trunk permit vlan 100

(4)     L3 Switch C的配置

# 创建并进入VLAN接口Vlan-interface 100,为其配置IP地址,使能QinQ终结功能(收到外层VLAN ID为100的报文时,终结该报文最外两层VLAN Tag),并指定发送VLAN报文时可以添加的内层VLAN ID为11。

<L3_SwitchC> system-view

[L3_SwitchC] vlan 100

[L3_SwitchC-vlan100] quit

[L3_SwitchC] interface vlan-interface 100

[L3_SwitchC-Vlan-interface100] ip address 1.1.1.11 255.255.255.0

[L3_SwitchC-Vlan-interface100] second-dot1q 11

[L3_SwitchC-Vlan-interface100] quit

# 配置端口GigabitEthernet3/0/1的链路类型为Trunk类型,并允许VLAN 100通过。

[L3_SwitchC] interface GigabitEthernet 3/0/1

[L3_SwitchC-GigabitEthernet3/0/1] port link-type trunk

[L3_SwitchC-GigabitEthernet3/0/1] port trunk permit vlan 100

[L3_SwitchC-GigabitEthernet3/0/1] quit

# 创建并进入VLAN接口Vlan-interface 2,为其配置IP地址。

[L3_SwitchC] vlan 2

[L3_SwitchC-vlan2] quit

[L3_SwitchC] interface vlan-interface 2

[L3_SwitchC-Vlan-interface2] ip address 1.1.2.11 255.255.255.0

[L3_SwitchC-Vlan-interface2] quit

# 配置端口GigabitEthernet3/0/2加入VLAN 2。

[L3_SwitchC] interface GigabitEthernet 3/0/2

[L3_SwitchC-GigabitEthernet3/0/2] port access vlan 2

(5)     L2 Switch D的配置

L2 Switch D用出厂配置即可。

1.6.2  模糊的QinQ终结配置举例

1. 组网需求

如下图所示,Host A、Host B、Host C和Switch A相连,分别属于VLAN 11、VLAN 12和VLAN 13;Server群和Switch C相连;Switch B上使能了QinQ功能。Host A、Host B、Host C需要与Server群互相通信。

2. 组网图

图1-6 模糊的QinQ终结配置组网图

 

3. 配置步骤

(1)     Host A、Host B、Host C的配置

将Host A的IP地址指定为1.1.1.1/24, Host B的IP地址为1.1.1.2/24,Host C的IP地址为1.1.1.3/24,网关地址均指定为1.1.1.11/24。

(2)     L2 Switch A的配置

# 向VLAN 11中加入端口GigabitEthernet3/0/1。

<L2_SwitchA> system-view

[L2_SwitchA] vlan 11

[L2_SwitchA-vlan11] port GigabitEthernet 3/0/1

[L2_SwitchA-vlan11] quit

# 向VLAN 12中加入端口GigabitEthernet3/0/2。

[L2_SwitchA] vlan 12

[L2_SwitchA-vlan12] port GigabitEthernet 3/0/2

[L2_SwitchA-vlan12] quit

# 向VLAN 13中加入端口GigabitEthernet3/0/3。

[L2_SwitchA] vlan 13

[L2_SwitchA-vlan13] port GigabitEthernet 3/0/3

[L2_SwitchA-vlan13] quit

# 配置端口GigabitEthernet3/0/7的链路类型为Hybrid类型,且允许VLAN 11~13的报文带Tag通过。

[L2_SwitchA] interface GigabitEthernet 3/0/7

[L2_SwitchA-GigabitEthernet3/0/7] port link-type hybrid

[L2_SwitchA-GigabitEthernet3/0/7] port hybrid vlan 11 to 13 tagged

(3)     L2 Switch B的配置

# 配置端口GigabitEthernet4/0/2的链路类型为Trunk类型,并允许VLAN 100通过。

<L2_SwitchB> system-view

[L2_SwitchB] interface GigabitEthernet 4/0/2

[L2_SwitchB-GigabitEthernet4/0/2] port link-type trunk

[L2_SwitchB-GigabitEthernet4/0/2] port trunk permit vlan 100

# 配置端口GigabitEthernet4/0/2的缺省VLANVLAN 100,并使能QinQ功能,使该端口为收到的报文添加VLAN ID为100的外层VLAN Tag。

[L2_SwitchB-GigabitEthernet4/0/2] port trunk pvid vlan 100

[L2_SwitchB-GigabitEthernet4/0/2] qinq enable

[L2_SwitchB-GigabitEthernet4/0/2] quit

# 配置端口GigabitEthernet4/0/1的链路类型为Trunk类型,并允许VLAN 100通过。

[L2_SwitchB] interface GigabitEthernet 4/0/1

[L2_SwitchB-GigabitEthernet4/0/1] port link-type trunk

[L2_SwitchB-GigabitEthernet4/0/1] port trunk permit vlan 100

(4)     L3 Switch C的配置

# 创建VLAN接口Vlan-interface100,为其配置IP地址,使能QinQ终结功能(收到外层VLAN ID为100的报文时,终结该报文最外两层VLAN Tag),并指定发送VLAN报文时可以添加的内层VLAN ID为11、12或13。

<L3_SwitchC> system-view

[L3_SwitchC] vlan 100

[L3_SwitchC-vlan100] quit

[L3_SwitchC] interface vlan-interface 100

[L3_SwitchC-Vlan-interface100] ip address 1.1.1.11 255.255.255.0

[L3_SwitchC-Vlan-interface100] second-dot1q 11 to 13

[L3_SwitchC-Vlan-interface100] quit

# 配置端口GigabitEthernet3/0/1的链路类型为Trunk类型,并允许VLAN 100通过。

[L3_SwitchC] interface GigabitEthernet 3/0/1

[L3_SwitchC-GigabitEthernet3/0/1] port link-type trunk

[L3_SwitchC-GigabitEthernet3/0/1] port trunk permit vlan 100

[L3_SwitchC-GigabitEthernet3/0/1] quit

# 创建VLAN接口Vlan-interface2,为其配置IP地址。

[L3_SwitchC] vlan 2

[L3_SwitchC-vlan2] quit

[L3_SwitchC] interface vlan-interface 2

[L3_SwitchC-Vlan-interface2] ip address 1.1.2.11 255.255.255.0

[L3_SwitchC-Vlan-interface2] quit

# 配置端口GigabitEthernet3/0/2加入VLAN 2。

[L3_SwitchC] interface GigabitEthernet 3/0/2

[L3_SwitchC-GigabitEthernet3/0/2] port access vlan 2

(5)     L2 Switch D的配置

L2 Switch D采用出厂配置即可。

(6)     Server group的配置

将Server group里所有设备的IP地址配置在1.1.2.0/24网段,网关地址指定为1.1.2.11/24即可。

1.6.3  模糊的QinQ终结配置举例-精简方案

配置本方案时请确保内层VLAN ID范围不和当前VLAN接口编号冲突,例如在Vlan-interface 100上配置second-dot1q { vlan-list | any }命令时,vlan-list不应包含100,且不要配置any参数。

 

1. 组网需求

·     L3 Switch C为运营商核心网络设备,通过端口GE3/0/1、GE3/0/2分别与L2 Switch A、L2 Switch B相连。端口GE3/0/1、GE3/0/2的链路类型均为Access。

·     L3 Switch C通过L2 Switch D和Server群相连。L2 Switch D只支持一层VLAN Tag。

·     用户网络A和B的私网VLAN都为VLAN 11~13,其中Host A1和Host A2属于VLAN 11,Host B1和Host B2属于VLAN 12,Host C1和Host C2属于VLAN 13。

希望配置后达到下列要求:

·     L3 Switch C的端口GE3/0/1、GE3/0/2上使能QinQ功能,当用户网络A和B中VLAN ID为11~13的报文在进入L3 Switch C时,报文外面被分别封装上VLAN 100和VLAN 200的公网VLAN Tag,实现用户网络A和B之间二层报文隔离。

·     L3 Switch C在VLAN接口上进行QinQ终结,实现Host A1、Host B1、Host C1、Host A2、Host B2、Host C2都能够与Server群互相通信;并且Host A1、Host B1、Host C1能与Host A2、Host B2、Host C2进行三层报文互通。

2. 组网图

图1-7 模糊的QinQ终结配置组网图

说明

以Host A1与Host B2为例,它们实现三层报文互通的过程如下:

Host A1的报文经过L2 Switch A时被添加VLAN ID为11的Tag;到达L3 Switch C的端口GE3/0/1时,报文外面被添加一层VLAN ID为100的Tag;到达Host A1的网关(Vlan-interface100)时被去掉两层Tag,再转发给Host B2的网关(Vlan-interface200);Vlan-interface200通过查找ARP表项获取Host B2的VLAN ID为12,在发送该报文时添加外层VLAN ID为200、内层VLAN ID为12的双层Tag;该报文经过Access端口GE3/0/2发往L2 Switch B时,去掉端口缺省VLAN的Tag(VLAN 200),剩下一层VLAN ID为12的Tag;该报文经过L2 Switch B,到达同属于VLAN 12的Host B2。

 

3. 配置步骤

(1)     Host A1、Host B1、Host C1、Host A2、Host B2、Host C2的配置

将Host A1的IP地址指定为1.1.1.1/24,Host B1的IP地址为1.1.1.2/24,Host C1的IP地址为1.1.1.3/24,网关地址均指定为1.1.1.11/24。

将Host A2的IP地址指定为2.1.1.1/24,Host B2的IP地址为2.1.1.2/24,Host C2的IP地址为2.1.1.3/24,网关地址均指定为2.1.1.11/24。

(2)     L2 Switch A的配置

# 向VLAN 11中加入端口GigabitEthernet1/0/1。

<L2_SwitchA> system-view

[L2_SwitchA] vlan 11

[L2_SwitchA-vlan11] port GigabitEthernet 1/0/1

[L2_SwitchA-vlan11] quit

# 向VLAN 12中加入端口GigabitEthernet1/0/2。

[L2_SwitchA] vlan 12

[L2_SwitchA-vlan12] port GigabitEthernet 1/0/2

[L2_SwitchA-vlan12] quit

# 向VLAN 13中加入端口GigabitEthernet1/0/3。

[L2_SwitchA] vlan 13

[L2_SwitchA-vlan13] port GigabitEthernet 1/0/3

[L2_SwitchA-vlan13] quit

# 配置端口GigabitEthernet1/0/7的链路类型为Trunk类型,且允许VLAN 11~13的报文通过。

[L2_SwitchA] interface GigabitEthernet 1/0/7

[L2_SwitchA-GigabitEthernet1/0/7] port link-type trunk

[L2_SwitchA-GigabitEthernet1/0/7] port trunk permit vlan 11 to 13

(3)     L2 Switch B的配置

L2 Switch B的配置与L2 Switch A相同。

(4)     L3 Switch C的配置

# 配置端口GigabitEthernet3/0/1加入VLAN 100,并使能QinQ功能,为该端口收到的报文打上本端口缺省VLAN Tag。

[L3_SwitchC] vlan 100

[L3_SwitchC-vlan100] quit

[L3_SwitchC] interface GigabitEthernet 3/0/1

[L3_SwitchC-GigabitEthernet3/0/1] port access vlan 100

[L3_SwitchC-GigabitEthernet3/0/1] qinq enable

[L3_SwitchC-GigabitEthernet3/0/1] quit

# 创建VLAN接口Vlan-interface100,为其配置IP地址,当收到外层VLAN ID为100的报文时,终结该报文最外两层VLAN Tag,并指定发送VLAN报文时可以添加的内层VLAN ID为11、12或13。

<L3_SwitchC> system-view

[L3_SwitchC] interface vlan-interface 100

[L3_SwitchC-Vlan-interface100] ip address 1.1.1.11 255.255.255.0

[L3_SwitchC-Vlan-interface100] second-dot1q 11 to 13

[L3_SwitchC-Vlan-interface100] quit

# 配置端口GigabitEthernet3/0/2加入VLAN 200,并使能QinQ功能,为该端口收到的报文打上本端口缺省VLAN Tag。

[L3_SwitchC] vlan 200

[L3_SwitchC-vlan200] quit

[L3_SwitchC] interface GigabitEthernet 3/0/2

[L3_SwitchC-GigabitEthernet3/0/2] port access vlan 200

[L3_SwitchC-GigabitEthernet3/0/2] qinq enable

[L3_SwitchC-GigabitEthernet3/0/2] quit

# 创建VLAN接口Vlan-interface200,为其配置IP地址,当收到外层VLAN ID为200的报文时,终结该报文最外两层VLAN Tag,并指定发送VLAN报文时可以添加的内层VLAN ID为11、12或13。

<L3_SwitchC> system-view

[L3_SwitchC] interface vlan-interface 200

[L3_SwitchC-Vlan-interface200] ip address 2.1.1.11 255.255.255.0

[L3_SwitchC-Vlan-interface200] second-dot1q 11 to 13

[L3_SwitchC-Vlan-interface200] quit

# 配置端口GigabitEthernet3/0/3加入VLAN 300。

[L3 SwitchC] vlan 300

[L3 SwitchC-vlan100] port GigabitEthernet 3/0/3

[L3 SwitchC-vlan100] quit

# 创建VLAN接口Vlan-interface300,为其配置IP地址。

[L3_SwitchC] interface vlan-interface 300

[L3_SwitchC-Vlan-interface300] ip address 3.1.1.11 255.255.255.0

[L3_SwitchC-Vlan-interface300] quit

(5)     L2 Switch D的配置

L2 Switch D采用出厂配置即可。

(6)     Server group的配置

将Server group里所有设备的IP地址配置在3.1.1.0/24网段,网关地址指定为3.1.1.11/24即可。

1.6.4  QinQ终结支持DHCP中继配置举例

1. 组网需求

·     Provider A、Provider B作为运营商网络设备。

·     DHCP client A和DHCP client B作为用户网络设备。

·     Provider A作为DHCP中继,Provider B作为DHCP server。

·     Provider A和Provider B之间通过三层接口连接。

希望配置完成后达到下列要求:

·     DHCP中继接收到的客户端发送的报文包括两层Tag,在DHCP中继上实现QinQ终结,即去掉报文中的两层Tag后,通过运营商网络将报文转发给DHCP server。

·     DHCP client A和DHCP client B可以经过运营商网络从DHCP server申请到IP地址和网络配置参数。

2. 组网图

图1-8 QinQ终结支持DHCP中继配置组网图

 

 

3. 配置步骤

(1)     Provider A(DHCP relay agent)的配置

# 使能DHCP 服务。

<ProviderA> system-view

[ProviderA] dhcp enable

# 创建DHCP服务器组。

[ProviderA] dhcp relay server-group 1 ip 10.2.1.1

# 创建VLAN接口。

[ProviderA] vlan 100

[ProviderA-vlan100] quit

[ProviderA] interface vlan-interface 100

# 配置VLAN接口在收到外层VLAN ID为100的报文时,终结该报文最外两层VLAN Tag,并指定发送VLAN报文时可以添加的内层VLAN ID为10或20。

[ProviderA-Vlan-interface100] second-dot1q 10 20

# 配置允许VLAN接口发送广播、组播报文。

[ProviderA-Vlan-interface100] vlan-termination broadcast enable

# 配置接口使能DHCP中继,选择服务器组,并使能DHCP中继的地址匹配检查功能。

[ProviderA-Vlan-interface100] dhcp select relay

[ProviderA-Vlan-interface100] dhcp relay server-select 1

[ProviderA-Vlan-interface100] dhcp relay address-check enable

# 配置VLAN接口的IP地址。

[ProviderA-Vlan-interface100] ip address 192.168.1.1 24

[ProviderA-Vlan-interface100] quit

# 配置连接Switch A的端口GigabitEthernet3/0/1的链路类型为Trunk类型,并允许VLAN 100通过。

[ProviderA] interface GigabitEthernet 3/0/1

[ProviderA-GigabitEthernet3/0/1] port link-type trunk

[ProviderA-GigabitEthernet3/0/1] port trunk permit vlan 100

[ProviderA-GigabitEthernet3/0/1] quit

# 配置与DHCP服务器连接接口的IP地址。

[ProviderA] interface vlan-interface 10

[ProviderA-Vlan-interface10] ip address 10.1.1.1 24

[ProviderA-Vlan-interface10] quit

# 配置到DHCP服务器的静态路由。

[ProviderA] ip route-static 10.2.1.1 24 10.1.1.1

(2)     Provider B(DHCP server)的配置

# 配置DHCP服务器的IP地址。

<ProviderB> system-view

[ProviderB] interface vlan-interface 20

[ProviderB-Vlan-interface20] ip address 10.2.1.1 24

[ProviderB-Vlan-interface20] quit

# 使能DHCP服务。

[ProviderB] dhcp enable

# 配置DHCP服务器地址池。

[ProviderB] dhcp server ip-pool 1

[ProviderB-dhcp-pool-1] network 192.168.1.0 24

[ProviderB-dhcp-pool-1] gateway-list 192.168.1.1

[ProviderB-dhcp-pool-1] quit

# 配置到DHCP中继VLAN接口的静态路由。

[ProviderB] ip route-static 192.168.1.1 24 10.1.1.1

(3)     Switch A的配置

# 配置QinQ上行口。

<SwitchA> system-view

[SwitchA] interface GigabitEthernet 2/0/1

[SwitchA-GigabitEthernet2/0/1] port link-type trunk

# 配置Trunk口,允许VLAN 100的报文通过。

[SwitchA-GigabitEthernet2/0/1] port trunk permit vlan 100

[SwitchA-GigabitEthernet2/0/1] quit

# 配置QinQ下行口GigabitEthernet2/0/2,使能QinQ功能。

[SwitchA] interface GigabitEthernet 2/0/2

[SwitchA-GigabitEthernet2/0/2] qinq enable

[SwitchA-GigabitEthernet2/0/2] quit

# 配置QinQ下行口GigabitEthernet2/0/3,使能QinQ功能。

[SwitchA] interface GigabitEthernet 2/0/3

[SwitchA-GigabitEthernet2/0/3] qinq enable

[SwitchA-GigabitEthernet2/0/3] quit

# 下行端口GigabitEthernet2/0/2和GigabitEthernet2/0/3加入VLAN 100。

[SwitchA] vlan 100

[SwitchA-vlan100] port GigabitEthernet 2/0/2

[SwitchA-vlan100] port GigabitEthernet 2/0/3

(4)     Switch B的配置

# 端口GigabitEthernet2/0/2加入VLAN 10。

<SwitchB> system-view

[SwitchB] vlan 10

[SwitchB-vlan10] port GigabitEthernet 2/0/2

[SwitchB-vlan10] quit

# 配置端口GigabitEthernet2/0/1为Trunk口,且允许VLAN 10的报文通过。

[SwitchB] interface GigabitEthernet 2/0/1

[SwitchB-GigabitEthernet2/0/1] port link-type trunk

[SwitchB-GigabitEthernet2/0/1] port trunk permit vlan 10

(5)     Switch C的配置

# 端口GigabitEthernet2/0/2加入VLAN 20。

<SwitchC> system-view

[SwitchC] vlan 20

[SwitchC-vlan20] port GigabitEthernet 2/0/2

[SwitchC-vlan20] quit

# 配置端口GigabitEthernet2/0/1为Trunk口,且允许VLAN 20的报文通过。

[SwitchC] interface GigabitEthernet 2/0/1

[SwitchC-GigabitEthernet2/0/1] port link-type trunk

[SwitchC-GigabitEthernet2/0/1] port trunk permit vlan 20

4. 验证配置

配置完成后,DHCP client A和DHCP client B可以从DHCP server申请到IP地址,在Provider A上通过display dhcp relay security命令可以查看到生成的DHCP中继用户地址表项信息。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!