选择区域语言: EN CN HK

04-二层技术-以太网交换配置指导

04-以太网链路聚合配置

本章节下载  (436.74 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500/Configure/Operation_Manual/H3C_S12500_CG-R1828P04-6W182/04/201407/834565_30005_0.htm

04-以太网链路聚合配置


1 以太网链路聚合

说明

·     设备支持两种运行模式:独立运行模式和IRF模式,缺省情况为独立运行模式。有关IRF模式的介绍,请参见“IRF配置指导”中的“IRF”。

·     当设备处于IRF模式且配置了IRF增强功能时,不能再创建三层以太网接口/子接口、三层聚合接口/子接口。

·     设备整机最多支持240个聚合组。一个聚合组最多支持单台设备上的选中端口数为12个,且当设备处于IRF模式时,一个聚合组最多支持的选中端口数=12×成员设备数量。

 

1.1  以太网链路聚合简介

以太网链路聚合简称链路聚合,它通过将多条以太网物理链路捆绑在一起成为一条逻辑链路,从而实现增加链路带宽的目的。同时,这些捆绑在一起的链路通过相互间的动态备份,可以有效地提高链路的可靠性。

图1-1所示,Device A与Device B之间通过三条以太网物理链路相连,将这三条链路捆绑在一起,就成为了一条逻辑链路Link aggregation 1,这条逻辑链路的带宽等于原先三条以太网物理链路的带宽总和,从而达到了增加链路带宽的目的;同时,这三条以太网物理链路相互备份,有效地提高了链路的可靠性。

图1-1 链路聚合示意图

1.1.1  基本概念

1. 聚合组、成员端口和聚合接口

将多个以太网接口捆绑在一起所形成的组合称为聚合组,而这些被捆绑在一起的以太网接口就称为该聚合组的成员端口。每个聚合组唯一对应着一个逻辑接口,我们称之为聚合接口。聚合组/聚合接口可以分为以下两种类型:

·     二层聚合组/二层聚合接口:二层聚合组的成员端口全部为二层以太网接口,其对应的聚合接口称为二层聚合接口(Bridge-aggregation Interface,BAGG)。

·     三层聚合组/三层聚合接口:三层聚合组的成员端口全部为三层以太网接口,其对应的聚合接口称为三层聚合接口(Route-aggregation Interface,RAGG)。

说明

·     聚合组与聚合接口的编号是一一对应的,譬如聚合组1对应于聚合接口1。

·     在创建了三层聚合接口之后,还可以继续创建该三层聚合接口的子接口(简称三层聚合子接口)。三层聚合子接口也是一种逻辑接口,工作在网络层,主要用来在三层聚合接口上支持收发携带VLAN Tag的报文。

·     聚合接口的速率和双工模式取决于对应聚合组内的选中端口(请参见“1.1  2. 成员端口的状态”):聚合接口的速率等于所有选中端口的速率之和,聚合接口的双工模式则与选中端口的双工模式相同。

 

2. 成员端口的状态

聚合组内的成员端口具有以下两种状态:

·     选中(Selected)状态:此状态下的成员端口可以参与用户数据的转发,处于此状态的成员端口简称为“选中端口”。

·     非选中(Unselected)状态:此状态下的成员端口不能参与用户数据的转发,处于此状态的成员端口简称为“非选中端口”。

3. 操作Key

在进行链路聚合时,系统会根据成员端口上的一些信息(包括该端口的速率、双工模式等)的组合自动计算生成一个数值,该数值就称为操作Key。这个信息组合中任何一项的变化都会引起操作Key的重新计算。在同一聚合组中,所有的选中端口都必须具有相同的操作Key。

4. 配置分类

根据对成员端口状态的影响不同,我们可以将成员端口上的配置分为以下三类:

(1)     端口属性类配置:包含速率、双工模式和链路状态(up/down)这三项配置内容,是成员端口上最基础的配置内容。

(2)     第二类配置:包含的配置内容如表1-1所示。在聚合组中,只有与对应聚合接口的第二类配置完全相同的成员端口才能够成为选中端口。

表1-1 第二类配置的内容

配置项

内容

端口隔离

端口是否加入隔离组、端口所属的端口隔离组

QinQ配置

端口的QinQ功能开启/关闭状态、VLAN Tag的TPID值、添加的外层VLAN Tag、内外层VLAN优先级映射关系、不同内层VLAN ID添加外层VLAN Tag的策略、内层VLAN ID替换关系

VLAN配置

端口上允许通过的VLAN、端口缺省VLAN ID、端口的链路类型(即Trunk、Hybrid、Access类型)、基于IP子网的VLAN配置、基于协议的VLAN配置、VLAN报文是否带Tag配置

MAC地址学习配置

是否具有MAC地址学习功能、端口是否具有最大学习MAC地址个数的限制、MAC地址表满后是否继续转发

 

说明

·     在聚合接口上所作的第二类配置,将被自动同步到对应聚合组内的所有成员端口上。当聚合接口被删除后,这些配置仍将保留在这些成员端口上。

·     由于成员端口上第二类配置的改变可能导致其选中/非选中状态发生变化,进而对业务产生影响,因此当在成员端口上进行此类配置时,系统将给出提示信息,由用户来决定是否继续执行该配置。

 

(3)     第一类配置:是相对于第二类配置而言的,包含的配置内容有GVRP、MSTP等。在聚合组中,即使某成员端口与对应聚合接口的第一类配置存在不同,也不会影响该成员端口成为选中端口。

5. 参考端口

参考端口从成员端口中选出,其端口属性类配置和第二类配置将作为同一聚合组内的其它成员端口的参照,以确定这些成员端口的状态。

6. LACP协议

基于IEEE802.3ad标准的LACP(Link Aggregation Control Protocol,链路聚合控制协议)协议是一种实现链路动态聚合的协议,运行该协议的设备之间通过互发LACPDU(Link Aggregation Control Protocol Data Unit,链路聚合控制协议数据单元)来交互链路聚合的相关信息。

(1)     LACP协议的功能

根据所使用的LACPDU字段的不同,可将LACP协议的功能分为基本功能和扩展功能两大类,如表1-2所示。

表1-2 LACP协议的功能分类

类别

说明

基本功能

利用LACPDU的基本字段可以实现LACP协议的基本功能,基本字段包含以下信息:系统LACP优先级、系统MAC地址、端口LACP优先级、端口编号和操作Key

动态聚合组内的成员端口会自动使能LACP协议,并通过发送LACPDU向对端通告本端的上述信息。当对端收到该LACPDU后,将其中的信息与本端其它成员端口收到的信息进行比较,以选择能够处于选中状态的成员端口,使双方可以对各自接口的选中/非选中状态达成一致,从而决定哪些链路可以加入聚合组以及某链路何时可以加入聚合组

扩展功能

通过对LACPDU的字段进行扩展,可以实现对LACP协议的扩展。譬如,通过在扩展字段中定义一个新的TLV(Type/Length/Value,类型/长度/值)数据域,可以实现IRF(Intelligent Resilient Framework,智能弹性架构)中的LACP MAD(Multi-Active Detection,多Active检测)机制。对于支持LACP协议扩展功能的设备来说:

·     如果同时支持IRF,则该设备可以作为成员设备或中间设备来参与LACP MAD

·     如果不支持IRF,则该设备只能作为中间设备来参与LACP MAD

 

说明

有关IRF、成员设备、中间设备和LACP MAD机制的详细介绍,请参见“IRF配置指导”中的“IRF”。

 

(2)     LACP优先级

根据作用的不同,可以将LACP优先级分为系统LACP优先级和端口LACP优先级两类,如表1-3所示。

表1-3 LACP优先级的分类

类别

说明

比较标准

系统LACP优先级

系统LACP优先级用于区分两端设备优先级的高低。要想使两端设备的选中端口一致,可以使一端具有较高的优先级,另一端则根据优先级较高的一端来选择本端的选中端口

优先级数值越小,优先级越高

端口LACP优先级

端口LACP优先级用于区分各成员端口成为选中端口的优先程度

 

(3)     LACP超时时间

LACP超时时间是指成员端口等待接收LACPDU的超时时间。在三倍LACP超时时间之后,如果本端成员端口仍未收到来自对端的LACPDU,则认为对端成员端口已失效。LACP超时时间只有短超时(1秒)和长超时(30秒)两种取值。

7. 聚合模式

根据成员端口上是否启用了LACP协议,可以将链路聚合分为静态聚合和动态聚合两种模式,它们各自的特点如表1-4所示。

表1-4 不同聚合模式的特点

聚合模式

成员端口是否开启LACP协议

优点

缺点

静态聚合模式

一旦配置好后,端口的选中/非选中状态就不会受网络环境的影响,比较稳定

不能根据对端的状态调整端口的选中/非选中状态,不够灵活

动态聚合模式

能够根据对端和本端的信息调整端口的选中/非选中状态,比较灵活

端口的选中/非选中状态容易受网络环境的影响,不够稳定

 

处于静态聚合模式和动态聚合模式下的聚合组分别称为静态聚合组和动态聚合组,动态聚合组内的选中端口以及处于up状态、与对应聚合接口的第二类配置相同的非选中端口均可以收发LACPDU。

1.1.2  静态聚合模式

在静态聚合模式下,聚合组内的成员端口上不启用LACP协议,其端口状态通过手工进行维护。静态聚合模式的工作机制如下:

1. 选择参考端口

当聚合组内有处于up状态的端口时,先比较端口的聚合优先级,优先级数值最小的端口作为参考端口;如果优先级相同,再按照端口全双工/高速率->全双工/低速率->半双工/高速率->半双工/低速率的优先次序,选择优先次序最高、且第二类配置与对应聚合接口相同的端口作为该组的参考端口;如果优先次序相同,则选择端口号最小的端口作为参考端口。

2. 确定成员端口的状态

静态聚合组内成员端口状态的确定流程如图1-2所示。

图1-2 静态聚合组内成员端口状态的确定流程

 

 

说明

·     当一个成员端口的端口属性类配置或第二类配置改变时,其所在聚合组内各成员端口的选中/非选中状态可能会发生改变。

·     当聚合组内选中端口的数量已达到上限时,后加入的成员端口即使满足成为选中端口的其它条件,也会成为非选中端口。这样能够尽量维持当前选中端口上的流量不中断,但是由于设备重启时会重新计算选中端口,因此可能导致设备重启前、后各成员端口的选中/非选中状态不一致。

 

1.1.3  动态聚合模式

在动态聚合模式下,聚合组内的成员端口上均启用LACP协议,其端口状态通过该协议自动进行维护。动态聚合模式的工作机制如下:

1. 选择参考端口

(1)     首先,从聚合链路的两端选出设备ID(由系统的LACP优先级和系统的MAC地址共同构成)较小的一端:先比较两端的系统LACP优先级,优先级越小其设备ID越小;若优先级相同再比较其系统MAC地址,MAC地址越小其设备ID越小。

(2)     其次,对于设备ID较小的一端,再比较其聚合组内各成员端口的端口ID(由端口的LACP优先级和端口的编号共同构成):先比较端口的端口LACP优先级,优先级越小其端口ID越小;若优先级相同再比较其端口号,端口号越小其端口ID越小。端口ID最小的端口作为参考端口。

2. 确定成员端口的状态

在设备ID较小的一端,动态聚合组内成员端口状态的确定流程如图1-3所示。

图1-3 动态聚合组内成员端口状态的确定流程

与此同时,设备ID较大的一端也会随着对端成员端口状态的变化,随时调整本端各成员端口的状态,以确保聚合链路两端成员端口状态的一致。

 

说明

·     当动态聚合组内同时存在全双工端口和半双工端口时,全双工端口将优先成为选中端口;只有当所有全双工端口都无法成为选中端口,或动态聚合组内只有半双工端口时,才允许从半双工端口中选出一个成为选中端口,且只有一个半双工端口可成为选中端口。

·     当一个成员端口的端口属性类配置或第二类配置改变时,其所在聚合组内各成员端口的选中/非选中状态可能会发生改变。

·     当本端端口的选中/非选中状态发生改变时,其对端端口的选中/非选中状态也将随之改变。

·     当动态聚合组内选中端口的数量已达到上限时,后加入的成员端口一旦满足成为选中端口的所有条件,就会立刻取代已不满足条件的端口成为选中端口。

 

1.1.4  聚合负载分担类型

通过采用不同的聚合负载分担类型,可以实现灵活地对聚合组内流量进行负载分担。聚合负载分担的类型可以归为以下几类:

·     逐流负载分担:按照报文的源/目的MAC地址、源/目的服务端口、入端口、源/目的IP地址或MPLS标签中的一种或某几种的组合区分流,使属于同一数据流的报文从同一条成员链路上通过。

·     逐包负载分担:不区分数据流,而是以报文为单位,将报文逐次逐个分担到不同的成员链路上进行传输。

1.2  以太网链路聚合配置任务简介

表1-5 链路聚合配置任务简介

配置任务

说明

详细配置

配置聚合组

配置静态聚合组

二者必选其一

1.3.1 

配置动态聚合组

1.3.2 

聚合接口相关配置

配置聚合接口的描述信息

可选

1.4.1 

配置三层聚合接口MTU

可选

1.4.2 

开启聚合接口链路状态变化Trap功能

可选

1.4.3 

限制聚合组内选中端口的数量

可选

1.4.4 

关闭聚合接口

可选

1.4.5 

恢复聚合接口的缺省配置

可选

1.4.6 

配置聚合负载分担类型

可选

1.5 

配置聚合流量重定向功能

可选

1.6 

配置IRF模式下聚合选中能力增强功能

可选

1.7 

 

1.3  配置聚合组

请根据需要聚合的以太网接口类型来配置相应类型的聚合组:当需要聚合的是二层以太网接口时,请配置二层聚合组;当需要聚合的是三层以太网接口时,请配置三层聚合组。聚合链路的两端应配置相同的聚合模式。

注意

·     用户删除聚合接口时,系统将自动删除对应的聚合组,且该聚合组内的所有成员端口将全部离开该聚合组。

·     成员接口加入三层聚合组前,请不要在该接口上配置三层业务(如MPLS、VPN等),如果成员接口上已有三层业务配置,请先取消该接口上所有的三层业务配置,再加入三层聚合组;加入三层聚合组后,相关业务也只能在三层聚合接口上进行配置,如果在成员接口上误操作配置了三层业务,请先取消该成员接口上的所有三层业务配置,并在三层聚合接口上执行shutdownundo shutdown命令即可恢复。

 

说明

·     建议不要将镜像反射口加入聚合组,关于反射口的介绍请参见“网络管理和监控配置指导”中的“镜像”。

·     配置或使能了下列功能的端口将不能加入二层聚合组:RRPP(请参见“可靠性配置指导”中的“RRPP”)、MAC地址认证(请参见“安全配置指导”中的“MAC地址认证”)、IP Source Guard功能(请参见“安全配置指导”中的“IP Source Guard”)、802.1X功能(请参见“安全配置指导”中的“802.1X”)以及Portal免认证规则源接口(请参见“安全配置指导”中的“Portal”)。

·     配置或使能了下列功能的接口将不能加入三层聚合组:IP地址(请参见“三层技术-IP业务配置指导”中的“IP地址”)、VRRP功能(请参见“可靠性配置指导”中的“VRRP”)和Portal功能(请参见“安全配置指导”中的“Portal”)。

 

1.3.1  配置静态聚合组

说明

对于静态聚合模式,用户需要保证在同一链路两端端口的选中/非选中状态的一致性,否则聚合功能无法正常使用。

 

1. 配置二层静态聚合组

表1-6 配置二层静态聚合组

操作

命令

说明

进入系统视图

system-view

-

创建二层聚合接口,并进入二层聚合接口视图

interface bridge-aggregation interface-number

必选

创建二层聚合接口后,系统将自动生成同编号的二层聚合组,且该聚合组缺省工作在静态聚合模式下

退回系统视图

quit

-

进入二层以太网接口视图

interface interface-type interface-number

必选

用户可通过此方法在聚合组中加入多个以太网接口

将二层以太网接口加入聚合组

port link-aggregation group number

配置端口的聚合优先级

link-aggregation port-priority port-priority

可选

缺省情况下,端口的聚合优先级为32768

改变端口的聚合优先级,将会影响到静态聚合组成员端口的选中/非选中状态

 

2. 配置三层静态聚合组

表1-7 配置三层静态聚合组

操作

命令

说明

进入系统视图

system-view

-

创建三层聚合接口,并进入三层聚合接口视图

interface route-aggregation interface-number

必选

创建三层聚合接口后,系统将自动生成同编号的三层聚合组,且该聚合组缺省工作在静态聚合模式下

退回系统视图

quit

-

进入三层以太网接口视图

interface interface-type interface-number

必选

多次执行此步骤可将多个三层以太网接口加入聚合组

将三层以太网接口加入聚合组

port link-aggregation group number

配置端口的聚合优先级

link-aggregation port-priority port-priority

可选

缺省情况下,端口的聚合优先级为32768

改变端口的聚合优先级,将会影响到静态聚合组成员端口的选中/非选中状态

 

1.3.2  配置动态聚合组

说明

对于动态聚合模式,聚合链路两端的设备会自动协商同一链路两端的端口在各自聚合组内的选中/非选中状态,用户只需保证本端聚合在一起的端口的对端也同样聚合在一起,聚合功能即可正常使用。

 

1. 配置二层动态聚合组

表1-8 配置二层动态聚合组

操作

命令

说明

进入系统视图

system-view

-

配置系统的LACP优先级

lacp system-priority system-priority

可选

缺省情况下,系统的LACP优先级为32768

改变系统的LACP优先级将会影响到动态聚合组成员的Selected和Unselected状态

创建二层聚合接口,并进入二层聚合接口视图

interface bridge-aggregation interface-number

必选

创建二层聚合接口后,系统将自动生成同编号的二层聚合组,且该聚合组缺省工作在静态聚合模式下

配置聚合组工作在动态聚合模式下

link-aggregation mode dynamic

必选

缺省情况下,聚合组工作在静态聚合模式下

退回系统视图

quit

-

进入二层以太网接口视图

interface interface-type interface-number

必选

用户可通过此方法在聚合组中加入多个二层以太网接口

将二层以太网接口加入聚合组

port link-aggregation group number

配置端口的聚合优先级

link-aggregation port-priority port-priority

可选

缺省情况下,端口的聚合优先级为32768

改变端口的聚合优先级,将会影响到动态聚合组成员的Selected和Unselected状态

配置端口的LACP超时时间为短超时(即1秒)

lacp period short

可选

缺省情况下,端口的LACP超时时间为长超时(即30秒)

 

2. 配置三层动态聚合组

表1-9 配置三层动态聚合组

操作

命令

说明

进入系统视图

system-view

-

配置系统的LACP优先级

lacp system-priority system-priority

可选

缺省情况下,系统的LACP优先级为32768

改变系统的LACP优先级,将会影响到动态聚合模式聚合组成员的选中/非选中状态

创建三层聚合接口,并进入三层聚合接口视图

interface route-aggregation interface-number

必选

创建三层聚合接口后,系统将自动生成同编号的三层聚合组,且该聚合组缺省工作在静态聚合模式下

配置聚合组工作在动态聚合模式下

link-aggregation mode dynamic

必选

缺省情况下,聚合组工作在静态聚合模式下

退回系统视图

quit

-

进入三层以太网接口视图

interface interface-type interface-number

必选

多次执行此步骤可将多个三层以太网接口加入聚合组

将三层以太网接口加入聚合组

port link-aggregation group number

配置端口的聚合优先级

link-aggregation port-priority port-priority

可选

缺省情况下,端口的聚合优先级为32768

改变端口的聚合优先级,将会影响到动态聚合模式聚合组成员的选中/非选中状态

配置端口的LACP超时时间为短超时(即1秒)

lacp period short

可选

缺省情况下,端口的LACP超时时间为长超时(即30秒)

 

1.4  聚合接口相关配置

本节对能够在聚合接口上进行的部分配置进行介绍。除本节所介绍的以外,能够在二层/三层以太网接口上进行的配置大多数也能在二层/三层聚合接口上进行,具体配置请参见相关的配置指导。

1.4.1  配置聚合接口的描述信息

通过在接口上配置描述信息,可以方便网络管理员根据这些信息来区分各接口的作用。

表1-10 配置聚合接口的描述信息

操作

命令

说明

进入系统视图

system-view

-

进入聚合接口视图

进入二层聚合接口视图

interface bridge-aggregation interface-number

二者必选其一

进入三层聚合接口/子接口视图

interface route-aggregation { interface-number | interface-number.subnumber }

配置当前接口的描述信息

description text

可选

缺省情况下,接口的描述信息为“接口名 Interface”

 

1.4.2  配置三层聚合接口MTU

MTU(Maximum Transmission Unit,最大传输单元)参数会影响IP报文的分片与重组,可以通过下面的配置来改变MTU值。

表1-11 配置三层聚合接口MTU

操作

命令

说明

进入系统视图

system-view

-

进入三层聚合接口/子接口视图

interface route-aggregation { interface-number | interface-number.subnumber }

-

配置当前接口的MTU

mtu size

可选

缺省情况下,三层聚合接口/子接口的MTU值为1500字节

 

1.4.3  开启聚合接口链路状态变化Trap功能

在聚合接口上开启了接口链路状态变化Trap功能后,可以使聚合接口在链路状态发生改变时生成并发送端口Link up和Link down的Trap报文。有关Trap的详细介绍,请参见“网络管理和监控配置指导”中的“SNMP”。

表1-12 开启聚合接口状态变化Trap功能

操作

命令

说明

进入系统视图

system-view

-

开启全局接口链路状态变化Trap功能

snmp-agent trap enable [ standard [ linkdown | linkup ] * ]

可选

缺省情况下,全局接口链路状态变化Trap功能处于开启状态

进入聚合接口视图

进入二层聚合接口视图

interface bridge-aggregation interface-number

二者必选其一

进入三层聚合接口/子接口视图

interface route-aggregation { interface-number | interface-number.subnumber }

开启聚合接口链路状态变化Trap功能

enable snmp trap updown

可选

缺省情况下,聚合接口链路状态变化Trap功能处于开启状态

 

1.4.4  限制聚合组内选中端口的数量

聚合链路的带宽取决于聚合组内选中端口的数量,用户通过配置聚合组中的最小选中端口数,可以避免由于选中端口太少而造成聚合链路上的流量拥塞。当聚合组内选中端口的数量达不到配置值时,对应的聚合接口将不会up,从而使流量可以切换到备份链路上。具体实现如下:

·     如果聚合组内能够被选中的成员端口数小于配置值,这些成员端口都将变为非选中状态,对应聚合接口的链路状态也将变为down。

·     当聚合组内能够被选中的成员端口数增加至不小于配置值时,这些成员端口都将变为选中状态,对应聚合接口的链路状态也将变为up。

缺省情况下,聚合组内选中端口的最大数量仅受端口硬件能力的限制;在配置了聚合组中的最大选中端口数之后,聚合组内选中端口的最大数量将同时受配置值和端口硬件能力的限制,即取二者中较低的值作为限制值。用户利用此特性可实现两端口间的冗余备份:在一个聚合组中只添加两个成员端口,并配置该聚合组中的最大选中端口数为1,那么在同一时刻这两个成员端口中只能有一个成为选中端口,另一个将作为备份端口。

表1-13 限制聚合组内选中端口的数量

操作

命令

说明

进入系统视图

system-view

-

进入聚合接口视图

进入二层聚合接口视图

interface bridge-aggregation interface-number

二者必选其一

进入三层聚合接口

interface route-aggregation interface-number

配置聚合组中的最小选中端口数

link-aggregation selected-port minimum number

必选

缺省情况下,聚合组中的最小选中端口数不受限制

配置聚合组中的最大选中端口数

link-aggregation selected-port maximum number

必选

缺省情况下,聚合组中的最大选中端口数仅受端口硬件能力的限制

 

注意

·     针对静态聚合组进行本配置时,必须在聚合链路两端进行相同的配置,并保证两端聚合组的配置一致。

·     配置聚合组中的最小选中端口数可能导致聚合组内的所有成员端口都变为非选中状态。

·     要求本端和对端配置的聚合组中的最小选中端口数必须一致。

·     配置聚合组中的最大选中端口数可能导致聚合组内的部分成员端口变为非选中状态。

·     如果在聚合组中同时配置最大选中端口数和最小选中端口数,那么最大选中端口数应该大于或等于最小选中端口数。

 

1.4.5  关闭聚合接口

对聚合接口的开启/关闭操作,将会影响聚合接口对应的聚合组内成员端口的选中/非选中状态和链路状态:

·     关闭聚合接口时,将使对应聚合组内所有处于选中状态的成员端口都变为非选中端口,且所有成员端口的链路状态都将变为down。

·     开启聚合接口时,系统将重新计算对应聚合组内成员端口的选中/非选中状态,且所有成员端口的链路状态都将变为up。

表1-14 打开聚合接口

操作

命令

说明

进入系统视图

system-view

-

进入聚合接口视图

进入二层聚合接口视图

interface bridge-aggregation interface-number

二者必选其一

进入三层聚合接口/子接口视图

interface route-aggregation { interface-number | interface-number.subnumber }

关闭当前接口

shutdown

必选

缺省情况下,聚合接口处于开启状态

 

说明

由于三层聚合子接口不存在对应的聚合组,所以关闭三层聚合子接口对聚合组没有影响。

 

1.4.6  恢复聚合接口的缺省配置

通过执行本操作可以将接口下的所有配置都恢复为缺省配置。

表1-15 恢复聚合接口的缺省配置

操作

命令

说明

进入系统视图

system-view

-

进入聚合接口视图

进入二层聚合接口视图

interface bridge-aggregation interface-number

二者必选其一

进入三层聚合接口/子接口视图

interface route-aggregation { interface-number | interface-number.subnumber }

恢复当前接口的缺省配置

default

必选

 

1.5  配置聚合负载分担类型

通过改变负载分担的类型,可以灵活地实现聚合组流量的负载分担,系统利用Hash算法来计算负载分担的类型,该算法可依据报文中携带的MPLS标签、服务端口号、IP地址、MAC地址、报文入端口等信息及其组合进行计算。用户也可以指定系统对每个报文逐包进行聚合负载分担。

表1-16 配置聚合负载分担类型

操作

命令

说明

进入系统视图

system-view

-

配置聚合负载分担类型

link-aggregation load-sharing mode { { destination-ip | destination-mac | destination-port | ingress-port | mpls-label1 | mpls-label2 | mpls-label3 | source-ip | source-mac | source-port } * | per-packet }

可选

缺省情况下,设备支持除ingress-portper-packet之外的所有其他聚合负载分担类型

配置本命令后,所有负载分担聚合组的负载分担类型都会随之改变

 

说明

·     ingress-port分担类型不能和其他分担类型结合使用。

·     per-packet分担类型不支持在IRF模式下配置;使用per-packet分担类型可能造成报文乱序。当OAP单板的内联接口属于某个聚合组时,请不要配置per-packet分担类型。关于OAP单板请参见“OAA配置指导”中的“OAP单板”。

·     配置的聚合负载分担类型中,除mpls-label1mpls-label2mpls-label3per-packet之外的所有其他分担类型对单播流量的等价路由负载分担也会生效,即等价路由流量会按照这些分担类型进行负载分担;配置per-packet分担类型时,等价路由流量按照缺省情况下设备支持的分担类型进行负载分担。关于等价路由请参见“三层技术-IP路由配置指导”。

 

1.6  配置聚合流量重定向功能

在使能了聚合流量重定向功能后,当重启设备上的某块单板或IRF中的某台成员设备时,系统可以将待重启单板/设备上的聚合成员端口的流量重定向到其它单板/设备上,从而实现聚合链路上流量的不中断。有关IRF的详细介绍,请参见“IRF配置指导”中的“IRF”。

表1-17 配置聚合流量重定向功能

操作

命令

说明

进入系统视图

system-view

-

使能聚合流量重定向功能

link-aggregation lacp traffic-redirect-notification enable

可选

缺省情况下,聚合流量重定向功能处于关闭状态

 

注意

·     聚合流量重定向功能只支持动态聚合组。

·     必须在聚合链路两端都使能聚合流量重定向功能才能实现聚合链路上流量的不中断。

·     如果同时使能聚合流量重定向功能和MSTP功能,在重启单板/设备时会出现少量的丢包,因此不建议同时使能上述两个功能。

 

1.7  配置IRF模式下聚合选中能力增强功能

聚合选中能力即每个聚合组内的最大选中端口数。通常情况下,IRF模式和非IRF模式下的聚合选中能力相同。使能IRF模式下聚合选中能力增强功能后,每个成员设备的聚合选中能力与非IRF模式下的相同,但整个IRF的聚合选中能力则成倍增长(整个IRF上每个聚合组内的最大选中端口数=非IRF模式下每个聚合组内的最大选中端口数×成员设备个数)。

配置IRF模式下聚合选中能力增强功能时,需要注意:设备配置本功能后,用户需要保证该设备的对端设备同时也配置了本功能,否则聚合功能可能无法正常使用。

表1-18 配置IRF模式下聚合选中能力增强功能

操作

命令

说明

进入系统视图

system-view

-

使能IRF模式下聚合选中能力增强功能

link-aggregation irf-enhanced

缺省情况下,IRF模式下聚合选中能力增强功能处于关闭状态

 

1.8  以太网链路聚合显示与维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后链路聚合的运行情况,通过查看显示信息验证配置的效果。

在用户视图下执行reset命令可以清除端口和聚合接口上的LACP统计信息。

表1-19 链路聚合显示与维护

操作

命令

显示聚合接口的相关信息

display interface [ bridge-aggregation | route-aggregation ] [ brief [ down ] ] [ | { begin | exclude | include } regular-expression ]

display interface [ { bridge-aggregation | route-aggregation } [ interface-number ] ] [ brief [ description ] ] [ | { begin | exclude | include } regular-expression ]

显示本端系统的设备ID

display lacp system-id [ | { begin | exclude | include } regular-expression ]

显示成员端口上链路聚合的详细信息

display link-aggregation member-port [ interface-list ] [ | { begin | exclude | include } regular-expression ]

显示所有聚合组的摘要信息

display link-aggregation summary [ | { begin | exclude | include } regular-expression ]

显示指定聚合组的详细信息

display link-aggregation verbose [ { bridge-aggregation | route-aggregation } [ interface-number ] ] [ | { begin | exclude | include } regular-expression ]

显示聚合负载分担类型

display link-aggregation load-sharing mode [ | { begin | exclude | include } regular-expression ]

清除端口的LACP统计信息

reset lacp statistics [ interface interface-list ]

清除聚合接口上的统计信息

reset counters interface [ { bridge-aggregation | route-aggregation } [ interface-number ] ]

 

1.9  以太网链路聚合典型配置举例

说明

·     在聚合组中,只有端口属性配置(请参见“1.1  4. 配置分类”)和第二类配置(请参见“1.1  4. 配置分类”)与参考端口(请参见“1.1  5. 参考端口”)都相同的成员端口才可以成为Selected端口。因此,用户需保证各成员端口的上述配置都与参考端口保持一致,而除此以外的其它配置则只需在聚合接口上进行,不必在成员端口上进行重复配置。

·     缺省情况下,以太网接口、VLAN接口及聚合接口处于DOWN状态。如果要对这些接口进行配置,请先使用undo shutdown命令使接口状态处于UP。

 

1.9.1  二层静态聚合配置举例

1. 组网需求

·     Device A与Device B通过各自的二层以太网端口GigabitEthernet4/0/1~GigabitEthernet4/0/3相互连接。

·     在Device A和Device B上分别配置二层静态链路聚合组,并使两端的VLAN 10和VLAN 20之间分别互通。

·     通过配置源MAC地址与目的MAC地址相结合的聚合负载分担类型,实现数据流量在各成员端口间的负载分担。

2. 组网图

图1-4 二层静态聚合配置组网图

 

3. 配置步骤

(1)     配置Device A

# 创建VLAN 10,并将端口GigabitEthernet4/0/4加入到该VLAN中。

<DeviceA> system-view

[DeviceA] vlan 10

[DeviceA-vlan10] port GigabitEthernet 4/0/4

[DeviceA-vlan10] quit

# 创建VLAN 20,并将端口GigabitEthernet4/0/5加入到该VLAN中。

[DeviceA] vlan 20

[DeviceA-vlan20] port GigabitEthernet 4/0/5

[DeviceA-vlan20] quit

# 创建二层聚合接口1。

[DeviceA] interface Bridge-Aggregation 1

[DeviceA-Bridge-Aggregation1] quit

# 分别将端口GigabitEthernet 4/0/1至GigabitEthernet 4/0/3加入到聚合组1中。

[DeviceA] interface GigabitEthernet 4/0/1

[DeviceA-GigabitEthernet4/0/1] port link-aggregation group 1

[DeviceA-GigabitEthernet4/0/1] quit

[DeviceA] interface GigabitEthernet 4/0/2

[DeviceA-GigabitEthernet4/0/2] port link-aggregation group 1

[DeviceA-GigabitEthernet4/0/2] quit

[DeviceA] interface GigabitEthernet 4/0/3

[DeviceA-GigabitEthernet4/0/3] port link-aggregation group 1

[DeviceA-GigabitEthernet4/0/3] quit

# 配置二层聚合接口1为Trunk端口,并允许VLAN 10和20的报文通过。

[DeviceA] interface Bridge-Aggregation 1

[DeviceA-Bridge-Aggregation1] port link-type trunk

[DeviceA-Bridge-Aggregation1] port trunk permit vlan 10 20

 Please wait... Done.

[DeviceA-Bridge-Aggregation1] quit

# 配置全局聚合负载分担类型为源MAC地址与目的MAC地址相结合的方式。

[DeviceA] link-aggregation load-sharing mode source-mac destination-mac

(2)     配置Device B

Device B的配置与Device A相似,配置过程略。

(3)     检验配置效果

# 查看Device A上所有聚合组的摘要信息。

[DeviceA] display link-aggregation summary

 

Aggregation Interface Type:

BAGG -- Bridge-Aggregation, RAGG -- Route-Aggregation

Aggregation Mode: S -- Static, D -- Dynamic

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Actor System ID: 0x8000, 000f-e2ff-0001

 

AGG         AGG       Partner ID               Select Unselect   Share

Interface   Mode                               Ports  Ports      Type

-------------------------------------------------------------------------------

BAGG1       S         none                     3      0          Shar

以上信息表明,聚合组1为负载分担类型的二层静态聚合组,包含有三个选中端口。

# 查看Device A上全局采用的聚合负载分担类型。

[DeviceA] display link-aggregation load-sharing mode

 

Link-Aggregation Load-Sharing Mode:

  destination-mac address, source-mac address

以上信息表明,所有聚合组都按照报文的源MAC地址和目的MAC地址进行聚合负载分担。

1.9.2  二层动态聚合配置举例

1. 组网需求

·     Device A与Device B通过各自的二层以太网端口GigabitEthernet4/0/1~GigabitEthernet4/0/3相互连接。

·     在Device A和Device B上分别配置二层动态链路聚合组,并使两端的VLAN 10和VLAN 20之间分别互通。

·     通过配置源MAC地址与目的MAC地址相结合的聚合负载分担类型,实现数据流量在各成员端口间的负载分担。

2. 组网图

图1-5 二层动态聚合配置组网图

 

3. 配置步骤

(1)     配置Device A

# 创建VLAN 10,并将端口GigabitEthernet4/0/4加入到该VLAN中。

<DeviceA> system-view

[DeviceA] vlan 10

[DeviceA-vlan10] port GigabitEthernet 4/0/4

[DeviceA-vlan10] quit

# 创建VLAN 20,并将端口GigabitEthernet4/0/5加入到该VLAN中。

[DeviceA] vlan 20

[DeviceA-vlan20] port GigabitEthernet 4/0/5

[DeviceA-vlan20] quit

# 创建二层聚合接口1,并配置该接口为动态聚合模式。

[DeviceA] interface Bridge-Aggregation 1

[DeviceA-Bridge-Aggregation1] link-aggregation mode dynamic

# 分别将端口GigabitEthernet4/0/1至GigabitEthernet4/0/3加入到聚合组1中。

[DeviceA] interface GigabitEthernet 4/0/1

[DeviceA-GigabitEthernet4/0/1] port link-aggregation group 1

[DeviceA-GigabitEthernet4/0/1] quit

[DeviceA] interface GigabitEthernet 4/0/2

[DeviceA-GigabitEthernet4/0/2] port link-aggregation group 1

[DeviceA-GigabitEthernet4/0/2] quit

[DeviceA] interface GigabitEthernet 4/0/3

[DeviceA-GigabitEthernet4/0/3] port link-aggregation group 1

[DeviceA-GigabitEthernet4/0/3] quit

# 配置二层聚合接口1为Trunk端口,并允许VLAN 10和20的报文通过。

[DeviceA] interface Bridge-Aggregation 1

[DeviceA-Bridge-Aggregation1] port link-type trunk

[DeviceA-Bridge-Aggregation1] port trunk permit vlan 10 20

 Please wait... Done.

# 配置全局聚合负载分担类型为源MAC地址与目的MAC地址相结合的方式。

[DeviceA] link-aggregation load-sharing mode source-mac destination-mac

(2)     配置Device B

Device B的配置与Device A相似,配置过程略。

(3)     检验配置效果

# 查看Device A上所有聚合组的摘要信息。

[DeviceA] display link-aggregation summary

 

Aggregation Interface Type:

BAGG -- Bridge-Aggregation, RAGG -- Route-Aggregation

Aggregation Mode: S -- Static, D -- Dynamic

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Actor System ID: 0x8000, 000f-e2ff-0001

 

AGG         AGG       Partner ID               Select Unselect   Share

Interface   Mode                               Ports  Ports      Type

-------------------------------------------------------------------------------

BAGG1       D         0x8000, 000f-e2ff-0002   3      0          Shar

以上信息表明,聚合组1为负载分担类型的二层动态聚合组,包含有三个选中端口。

# 查看Device A上全局采用的聚合负载分担类型。

[DeviceA] display link-aggregation load-sharing mode

 

Link-Aggregation Load-Sharing Mode:

  destination-mac address, source-mac address

以上信息表明,所有聚合组都按照报文的源MAC地址和目的MAC地址进行聚合负载分担。

1.9.3  三层静态聚合配置举例

1. 组网需求

·     Device A与Device B通过各自的三层以太网接口GigabitEthernet3/0/1~GigabitEthernet3/0/3相互连接。

·     在Device A和Device B上分别配置三层静态链路聚合组,并为对应的三层聚合接口配置IP地址和子网掩码。

·     通过按照报文的源IP地址和目的IP地址进行聚合负载分担的方式,来实现数据流量在各成员端口间的分担。

2. 组网图

图1-6 三层静态聚合配置组网图

 

3. 配置步骤

(1)     配置Device A

# 创建三层聚合接口1,并为该接口配置IP地址和子网掩码。

<DeviceA> system-view

[DeviceA] interface Route-Aggregation 1

[DeviceA-Route-Aggregation1] ip address 192.168.1.1 24

[DeviceA-Route-Aggregation1] quit

# 分别将接口GigabitEthernet3/0/1GigabitEthernet3/0/3加入到聚合组1中。

[DeviceA] interface GigabitEthernet3/0/1

[DeviceA-GigabitEthernet3/0/1] port link-aggregation group 1

[DeviceA-GigabitEthernet3/0/1] quit

[DeviceA] interface GigabitEthernet3/0/2

[DeviceA-GigabitEthernet3/0/2] port link-aggregation group 1

[DeviceA-GigabitEthernet3/0/2] quit

[DeviceA] interface GigabitEthernet3/0/3

[DeviceA-GigabitEthernet3/0/3] port link-aggregation group 1

[DeviceA-GigabitEthernet3/0/3] quit

# 配置全局按照报文的源IP地址和目的IP地址进行聚合负载分担。

[DeviceA] link-aggregation load-sharing mode source-ip destination-ip

(2)     配置Device B

Device B的配置与Device A相似,配置过程略。

(3)     检验配置效果

# 查看Device A上所有聚合组的摘要信息。

[DeviceA] display link-aggregation summary

 

Aggregation Interface Type:

BAGG -- Bridge-Aggregation, RAGG -- Route-Aggregation

Aggregation Mode: S -- Static, D -- Dynamic

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Actor System ID: 0x8000, 000f-e2ff-0001

 

AGG         AGG       Partner ID               Select Unselect   Share

Interface   Mode                               Ports  Ports      Type

-------------------------------------------------------------------------------

RAGG1       S         none                     3      0          Shar

以上信息表明由此可见,聚合组1为负载分担类型的三层静态聚合组,包含有三个选中端口。

# 查看Device A上全局采用的聚合负载分担类型。

[DeviceA] display link-aggregation load-sharing mode

 

Link-Aggregation Load-Sharing Mode:

  destination-ip address,  source-ip address

以上信息表明由此可见,所有聚合组都按照报文的源IP地址和目的IP地址进行聚合负载分担。

1.9.4  三层动态聚合配置举例

1. 组网需求

·     Device A与Device B通过各自的三层以太网接口GigabitEthernet3/0/1~GigabitEthernet3/0/3相互连接。

·     在Device A和Device B上分别配置三层动态链路聚合组,并为对应的三层聚合接口配置IP地址和子网掩码。

·     通过按照报文的源IP地址和目的IP地址进行聚合负载分担的方式,来实现数据流量在各成员端口间的分担。

2. 组网图

图1-7 三层动态聚合配置组网图

 

3. 配置步骤

(1)     配置Device A

# 创建三层聚合接口1,配置该接口为动态聚合模式,并为其配置IP地址和子网掩码。

<DeviceA> system-view

[DeviceA] interface Route-Aggregation 1

[DeviceA-Route-Aggregation1] link-aggregation mode dynamic

[DeviceA-Route-Aggregation1] ip address 192.168.1.1 24

[DeviceA-Route-Aggregation1] quit

# 分别将接口GigabitEthernet3/0/1至GigabitEthernet3/0/3加入到聚合组1中。

[DeviceA] interface GigabitEthernet3/0/1

[DeviceA-GigabitEthernet3/0/1] port link-aggregation group 1

[DeviceA-GigabitEthernet3/0/1] quit

[DeviceA] interface GigabitEthernet3/0/2

[DeviceA-GigabitEthernet3/0/2] port link-aggregation group 1

[DeviceA-GigabitEthernet3/0/2] quit

[DeviceA] interface GigabitEthernet3/0/3

[DeviceA-GigabitEthernet3/0/3] port link-aggregation group 1

[DeviceA-GigabitEthernet3/0/3] quit

# 配置全局按照报文的源IP地址和目的IP地址进行聚合负载分担。

[DeviceA] link-aggregation load-sharing mode source-ip destination-ip

(2)     配置Device B

Device B的配置与Device A相似,配置过程略。

(3)     检验配置效果

# 查看Device A上所有聚合组的摘要信息。

[DeviceA] display link-aggregation summary

 

Aggregation Interface Type:

BAGG -- Bridge-Aggregation, RAGG -- Route-Aggregation

Aggregation Mode: S -- Static, D -- Dynamic

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Actor System ID: 0x8000, 000f-e2ff-0001

 

AGG         AGG       Partner ID               Select Unselect   Share

Interface   Mode                               Ports  Ports      Type

-------------------------------------------------------------------------------

RAGG1       D         0x8000, 000f-e2ff-0002   3      0          Shar

以上信息表明由此可见,聚合组1为负载分担类型的三层动态聚合组,包含有三个选中端口。

# 查看Device A上全局采用的聚合负载分担类型。

[DeviceA] display link-aggregation load-sharing mode

 

Link-Aggregation Load-Sharing Mode:

  destination-ip address,  source-ip address

以上信息表明由此可见,所有聚合组都按照报文的源IP地址和目的IP地址进行聚合负载分担。

 

 

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!