国家 / 地区

07 MPLS配置指导

05-MPLS L2VPN配置

本章节下载  (627.29 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/CE3000/CE3000-EI/Configure/Operation_Manual/H3C_CE3000-32F-EI_CG-Release_18xx-6W100/07/201403/822410_30005_0.htm

05-MPLS L2VPN配置

 

1 MPLS L2VPN·· 1-1

1.1 MPLS L2VPN简介·· 1-1

1.1.1 MPLS L2VPN概述·· 1-1

1.1.2 MPLS L2VPN的基本概念·· 1-1

1.1.3 MPLS L2VPN基本网络架构·· 1-2

1.1.4 MPLS L2VPN远程连接的工作机制·· 1-3

1.1.5 MPLS L2VPN的实现方式·· 1-4

1.1.6 VC封装类型·· 1-9

1.2 MPLS L2VPN配置任务简介·· 1-10

1.3 配置MPLS L2VPN基本功能·· 1-11

1.4 配置连接CE的接口·· 1-11

1.4.1 配置CE侧接口的封装类型为Ethernet 1-11

1.4.2 配置CE侧接口的封装类型为VLAN· 1-11

1.5 配置CCC方式MPLS L2VPN· 1-12

1.6 配置SVC方式MPLS L2VPN· 1-12

1.6.1 在三层接口上配置SVC方式的MPLS L2VPN(方式一)·· 1-13

1.6.2 在三层接口上配置SVC方式的MPLS L2VPN(方式二)·· 1-13

1.6.3 在服务实例上配置SVC方式的MPLS L2VPN· 1-14

1.7 配置Martini方式MPLS L2VPN· 1-15

1.7.1 配置远端对等体·· 1-16

1.7.2 在三层接口上创建Martini方式的VC连接·· 1-16

1.7.3 配置在服务实例上创建Martini方式的VC连接·· 1-17

1.7.4 检测VC· 1-18

1.8 配置Kompella方式MPLS L2VPN· 1-18

1.8.1 配置BGPL2VPN能力·· 1-19

1.8.2 创建并配置MPLS L2VPN· 1-19

1.8.3 配置CE连接·· 1-20

1.9 配置对AC上的流量进行监管·· 1-22

1.9.1 配置准备·· 1-22

1.9.2 配置对AC上的流量进行监管·· 1-22

1.10 配置对AC上的流量进行统计·· 1-22

1.11 MPLS L2VPN显示和维护·· 1-23

1.12 MPLS L2VPN典型配置举例·· 1-24

1.12.1 配置CCC远程连接示例·· 1-24

1.12.2 配置SVC方式MPLS L2VPN示例·· 1-27

1.12.3 配置Martini方式MPLS L2VPN示例·· 1-31

1.12.4 配置Kompella方式MPLS L2VPN示例·· 1-35

1.12.5 配置在服务实例上创建VC连接示例·· 1-37

1.13 常见配置错误举例·· 1-42

1.13.1 配置后不能Ping·· 1-42

 


1 MPLS L2VPN

说明

MPLS L2VPN既可以提供点到点的连接,也可以提供多点间的连接。本章只介绍提供点到点连接的MPLS L2VPN技术。提供多点间连接的MPLS L2VPN技术,请参见“MPLS配置指导”中的“VPLS”。

 

1.1  MPLS L2VPN简介

1.1.1  MPLS L2VPN概述

MPLS L2VPN是基于MPLSMultiprotocol Label Switching,多协议标签交换)的二层VPNVirtual Private Network,虚拟专用网络)技术,它利用MPLS技术在不同用户节点间建立二层连接。

采用MPLS L2VPN技术,运营商可以在统一的MPLSIP骨干网上透明传输不同数据链路层(包括VLANEthernet等)的二层数据,使得数据链路层业务可以跨越MPLSIP骨干网传递。

从用户的角度来看,MPLSIP骨干网是一个二层交换网络,用户感知不到MPLSIP骨干网的存在。以Ethernet类型的用户网络为例,通过MPLS L2VPN连接的Ethernet节点感知不到MPLSIP骨干网的存在,就好像节点之间直接通过以太网链路相连。

MPLS L2VPN具有以下优势:

·     可扩展性强:MPLS L2VPN只建立二层连接关系,不引入和管理用户的路由信息。这大大减轻了服务提供商网络边缘设备甚至整个服务提供商网络的负担,使服务提供商能支持更多的VPN和接入更多的用户。

·     可靠性和私网路由的安全性得到保证:由于不引入用户的路由信息,MPLS L2VPN不能获得和处理用户路由,保证了用户VPN路由的安全。

·     支持多种网络层协议:包括IPIPXSNA等。

1.1.2  MPLS L2VPN的基本概念

·     CECustomer Edge,用户网络边缘)设备

直接与服务提供商网络相连的用户网络侧设备。CE可以是网络设备(如路由器、交换机),也可以是一台主机。CE“感知”不到VPN的存在,不需要支持MPLS

·     PEProvider Edge,服务提供商网络边缘)设备

CE相连的服务提供商网络侧设备。PE主要负责VPN业务的接入。它完成报文从用户网络到公网隧道、从公网隧道到用户网络的映射与转发。

MPLS网络中,VPN相关的所有处理都发生在PE上。

·     ACAttachment Circuit,接入电路)

连接CEPE的链路。

·     VCVirtual Circuit,虚电路)

VC又称为PWPseudowire,伪线),是将两个PE上的AC连接起来的一条虚拟的双向连接。MPLS VC由一对方向相反的单向LSP构成。

·     隧道(Tunnel

又称为公网隧道,是穿越MPLSIP骨干网、用来承载VC的连接。隧道可以是LSPMPLS TEGRE隧道等。

·     PProvider,服务提供商网络)设备

不与CE直接相连。P设备只需沿着隧道将用户报文从一端PE转发到另一端PE

1.1.3  MPLS L2VPN基本网络架构

MPLS L2VPN的网络架构分为远程连接和本地连接两种。

1. 远程连接网络架构

图1-1所示,MPLS L2VPN的远程连接组网是指跨越MPLSIP骨干网络连接两端的用户二层网络。

图1-1 远程连接组网

 

2. 本地连接网络架构

图1-2所示,本地连接是指两个用户二层网络通过两个CE连接到同一个PE上,用户网络直接通过PE进行用户报文的交换。PE的作用类似于二层交换机。

图1-2 本地连接组网图

 

说明

CE3000-32F-EI交换机不支持本地连接架构。

 

1.1.4  MPLS L2VPN远程连接的工作机制

1. 远程连接建立过程

为了在CE之间建立MPLS L2VPN的远程连接,实现通过MPLS L2VPN技术跨越骨干网传递二层用户报文,需要完成以下工作:

·     建立公网隧道,以便将用户网络报文从本地PE转发到对端PE

公网隧道可以是LSPMPLS TEGRE隧道等。LSP隧道的详细介绍,请参见“MPLS配置指导”中的“MPLS基础”;MPLS TE隧道的详细介绍,请参见“MPLS配置指导”中的“MPLS TE”;GRE隧道的详细介绍,请参见“三层技术-IP业务”中的“GRE”。

如果在两端PE之间存在多条公网隧道,可以配置隧道策略,根据该隧道策略选择承载VC的公网隧道。隧道策略的详细介绍,请参见“MPLS配置指导”中的“MPLS L3VPN”。

·     建立VC,以便通过VC标签标识报文所属的用户网络。

建立VC,是指两端的PE设备分别为对方分配VC标签,建立方向相反的一对单向LSP

根据VC建立方式的不同,MPLS L2VPN的实现方式分为CCCCircuit Cross Connect,电路交叉连接)、SVCStatic Virtual Circuit,静态虚拟电路)、MartiniKompella四种,详细介绍请参见“1.1.5  MPLS L2VPN的实现方式”。

·     建立AC,并将ACVC绑定,以便确定接收到的用户网络报文通过哪条VC转发。

¡     建立AC:即在PECE上配置链路层协议,以便在PECE之间建立链路层连接。

¡     ACVC绑定:ACVC绑定后,从该AC接收到的报文将通过绑定的VC转发,从绑定的VC上接收到的报文将转发给该AC。在CE3000-32F-EI交换机上,可以通过将接口上的服务实例与VC绑定的方式,来实现ACVC的绑定。

2. 远程连接的报文转发过程

MPLS L2VPN通过在二层用户报文外封装Tunnel标记和VC标签,实现用户报文在MPLSIP骨干网中的透明传送。

·     Tunnel标记用于将报文从一个PE传递到另一个PE。如果采用LSPMPLS TE隧道,则Tunnel标记为MPLS标签;如果采用GRE隧道,则Tunnel标记为GRE头和传输协议的报文头。

·     VC标签用于区分连接不同CE的二层连接。接收方PE根据VC标签决定将报文转发给哪个CE

图1-3 远程连接的报文转发过程

(1) L2PDU是链路层报文,PDUProtocol Data Unit,协议数据单元

(2) TTunnel标记;VVC标签

 

图1-3所示,远程连接建立后,MPLS L2VPN的报文转发过程为:

(1)     PE 1接收到CE 1发送的二层用户报文后,根据PE 1CE 1之间的AC所绑定的VC为报文封装VC标签,并查找对应的公网隧道,为其封装Tunnel标记后将封装后的报文转发给P设备。

(2)     P设备根据外层的Tunnel标记将报文转发给PE 2

(3)     PE 2从公网隧道接收到报文后,根据VC标签判断报文所属的VCPE 2删除Tunnel标记和VC标签,还原二层用户报文后,将其转发给与该VC绑定的AC,即转发给CE 2

说明

上文描述的连接建立和报文转发过程不适用于CCC方式MPLS L2VPNCCC方式MPLS L2VPN的详细介绍,请参见“1.1.5  1. CCC方式MPLS L2VPN”。

 

1.1.5  MPLS L2VPN的实现方式

1. CCC方式MPLS L2VPN

CCC方式通过建立方向相反的两条静态LSP,并通过配置将静态LSPAC绑定的方法来建立VC连接。采用CCC方式建立的VC连接称为CCC连接。

图1-4 CCC方式示意图

 

图1-4所示,完成图中所示的各项配置后,将建立从PE 1PE 2和从PE 2PE 1的两条静态LSP,在PE 1上这两条静态LSPInterface A绑定,在PE 2上与Interface B绑定,至此,一条CCC远程连接成功建立。

CE 1发送报文给CE 2为例,CCC方式的报文转发过程为:

(1)     PE 1接收到CE 1发送的报文后,由于Interface A与静态LSP绑定,因此PE 1为其添加从PE 1PE 2的静态LSP的标签300

(2)     P接收到报文后,查找标签转发表,将入标签300替换为静态LSP的出标签310

(3)     由于静态LSPInterface B绑定,因此,PE 2接收到报文后,删除标签,将原始报文通过Interface B转发给CE 2

与其他方式的MPLS L2VPN不同,CCC采用一层标签传送用户报文,只有与该静态LSP绑定的AC才能通过该静态LSP转发报文。因此,CCCLSP的使用是独占性的。LSP只用于传递这个CCC连接的数据,不能用于其他连接,也不能用于MPLS L3VPN

2. SVC方式MPLS L2VPN

SVC是一种静态的MPLS L2VPN实现方式。SVC方式采用两层标签传递用户报文,内层的VC标签是在两端的PE上静态配置的,不需要使用信令协议传递。

3. Martini方式MPLS L2VPN

Martini方式采用两层标签传递用户报文,以LDPLabel Distribution Protocol,标签分发协议)为信令协议分发内层的VC标签。

为了在PE之间交换VC标签,Martini方式对LDP进行了扩展,增加了VC FECForwarding Equivalence Class,转发等价类)的FEC类型。该类型的FEC包含以下信息:

·     VC typeVC的封装类型。详细介绍请参见“1.1.6  VC封装类型”。

·     VC IDPE上为VC指定的连接标识。

VC type+VC ID唯一标识了一个VC。在一台PE上,相同VC type的所有VC,其VC ID必须唯一。

图1-5所示,两端PE分别发送标签映射消息,通过VC FEC(包含VC typeVC ID)和VC label将用于标识VC的信息和对应的VC标签发送给对端,即可实现VC标签的发布,从而在PE之间建立VC连接。

图1-5 Martini方式标签分发过程

 

4. Kompella方式MPLS L2VPN

Kompella方式采用两层标签传递用户报文,以扩展的BGP为信令协议分发内层的VC标签。

与其他方式不同,Kompella方式引入了VPN的概念,属于同一个VPNCE之间可以建立连接,属于不同VPNCE之间不能建立连接。

(1)     基本概念

·     CE ID

Kompella方式在VPN内部对CE进行编号,通过CE ID唯一标识VPN内的一个CE。不同VPNCE编号可以相同。

·     RDRoute Distinguisher,路由标识符)

为了区分不同VPN内编号相同的CEKompella方式定义了RD。在CE ID前增加RD,通过RD+CE ID可以唯一标识网络中的一个CE

·     VPN target

Kompella方式使用BGPVPN target(也称为Route target)属性来区分不同的VPN,确保属于同一个VPNCE之间可以建立连接,属于不同VPNCE之间不能建立连接。

PE上的VPN target属性分为以下两种:

¡     Export target属性:本地PE在通过BGPUpdate消息将L2VPN信息(如本地CE IDRD等)发送给对端PE时,将Update消息中携带的VPN target属性设置为Export target

¡     Import target属性:PE收到其它PE发布的Update消息时,检查消息中携带的VPN target属性,只有当此属性与PE上设置的Import target匹配时,才会接收该消息中的L2VPN信息。

也就是说,VPN target属性定义了本地发送的L2VPN信息可以为哪些PE所接收,PE可以接收哪些对端PE发送来的L2VPN信息。

(2)     标签块

Martini方式不同,Kompella方式并不是将本地PE分配的VC标签通过消息直接发送给对端PE,而是采用标签块的方式,一次为多个连接分配标签。PE将自己分配的标签块通告给同一个VPN内的所有PE,每个PE都根据其他PE通告的标签块计算出VC标签。

标签块包含以下参数:

·     LBLabel Base,初始标签):标签块的标签初始值。该值为PE设备自动选取,不可手动修改。

·     LRLabel Range,标签范围):标签块包含的标签数目。LBLR确定了标签块中包含哪些标签。例如,LB1000LR5,则该标签块包含的标签为10001004

·     LOLabel-block Offset,标签块偏移):VPN网络中CE的数量增加,原有的标签块大小无法满足要求时,PE无需撤销原有的标签块,只要在原有标签块的基础上再分配一个新的标签块就可以扩大标签范围,满足扩展需要。在这种情况下,PE通过LO来标识某个标签块在所有为CE分配的标签块中的位置,并根据LO来判断从哪个标签块中分配标签。LO的取值为之前分配的所有标签块大小的总合。例如,PECE分配的第一个标签块的LR10LO0,则第二个标签块的LO10;如果第二个标签块的LR20,则第三个标签块的LO30

为了方便描述,下文利用LB/LO/LR来描述一个标签块,即LB1000LO10LR5的标签块可以表示为1000/10/5

采用标签块的方式允许用户为VPN分配一些额外的标签,留待以后使用。这样短期来看会造成标签资源的浪费,但是却带来一个很大的好处,即可以减少VPN部署和扩容时的配置工作量。假设一个企业的VPN包括10CE,但是考虑到企业会扩展业务,将来可能会有20CE。这样可以把LR设置为20,系统会预先为未来的10CE分配标签。以后VPN添加CE节点时,配置的修改仅限于与新CE直接相连的PE,其他PE不需要作任何修改。这使得VPN的扩容变得非常简单。

(3)     VC标签的计算方法

图1-6 VC标签计算方式

 

图1-6所示,以计算连接CE 1CE 12VCVC标签为例,Kompella方式中VC标签的计算方法为:

·     PE 1计算本地为该VC分配的VC标签:

a.     将对端CECE 12)的ID12)与PE 1分配的两个标签块进行比较,如果存在满足LO<=CE ID<LO+LR的标签块,则从该标签块中分配标签。在本例中,标签块21055/5/10)满足LO<=CE ID<LO+LR(即5<=12<5+10),故从该标签块中为此VC分配标签。

b.     本地为此VC分配的标签值为:LB+CE ID-LO,即1055+12-5=1062

·     PE 1计算对端PEPE 2)为该VC分配的VC标签:

c.     将本地CECE 1)的ID1)与PE 2分配的标签块进行比较,如果存在满足LO<=CE ID<LO+LR的标签块,则从该标签块中分配标签。在本例中,标签块(2000/0/15)满足LO<=CE ID<LO+LR(即0<=1<0+15),故从该标签块中为此VC分配标签。

d.     对端PE为此VC分配的标签值为:LB+CE ID-LO,即2000+1-0=2001

·     PE 2上也进行类似地计算,可以得到相同的结果:本地PEPE 2)分配的VC标签为2001、对端PEPE 1)分配的VC标签为1062

说明

PE为来自CE的二层用户报文封装VC标签时,封装的是对端PE为该VC分配的标签。例如,PE 1将来自CE 1的报文转发给CE 2时,封装的VC标签为2001

 

(4)     VC建立过程

图1-7 Kompella方式标签分发过程

 

图1-7所示,CE 1CE 2属于VPN 1CE 3CE 4属于VPN 2。通过为两个VPN分别配置VPN target属性,实现VPN 1内的两个CEVPN 2内的两个CE分别可以建立VC连接,但VPN 1内的CEVPN 2内的CE不能建立VC连接。

VC建立过程为:

a.     PE 1通过BGPUpdate消息将RDCE IDVPN targetPE 1上为VPN配置的Export target)、标签块等信息发送给PE 2

b.     PE 2接收到Update消息后,比较该消息中的VPN target是否与本地为各VPN配置的Import target匹配。如果与某个VPNImport target匹配,则为该VPN学习Update消息中的L2VPN信息;否则,不会学习该Update消息中的信息,不进行后续的处理。在本例中,传递CE 1信息的Update消息的VPN target100:1,与VPN 1Import target相同,则将CE 1的信息学习到VPN 1L2VPN信息中;传递CE 2信息的Update消息的VPN target200:1,与VPN 2Import target相同,则将CE 2的信息学习到VPN 2L2VPN信息中。属于不同VPNCE信息学习到不同的VPN中,从而实现不同VPNCE的隔离。

c.     同样地,PE 2也向PE 1发送Update消息,PE 1也进行类似地处理。

d.     PE 1PE 2根据学习到的L2VPN信息,按照上文描述的方法为每个VPN内的CE分别计算VC标签。PE 1PE 2均计算出VC标签后,就成功建立了VC连接。

5. 四种实现方式的比较

四种实现方式的对比如表1-1所示。

表1-1 四种实现方式对比

实现方式

封装层数

VC标签分发方式

优点

缺点

适用场景

CCC

一层

静态配置

·     不需要任何信令协议传递标签,占用网络资源少

·     网络设备只要能支持MPLS转发即可

·     由于LSP是专用的,采用CCC方式,可以为业务流量提供QoS保证

·     配置维护复杂。每台P设备上都需要为每条CCC连接配置两条方向相反的静态LSP

·     不能自动适应网络的变化

拓扑简单、且其中的设备都支持MPLS的小型网络

SVC

两层

静态配置

不需要任何信令协议传递VC标签,占用网络资源少

·     不能自动适应网络的变化

·     只支持远程连接

拓扑简单的小型网络

Martini

两层

LDP

·     在运营商网络中,只有PE设备需要保存少量的VC标签与LSP的映射关系等信息,P设备不包含任何二层VPN信息

·     当需要新增一条VC时,只在相关的两端PE上进行配置即可,不影响网络的运行

只支持远程连接

稀疏的二层连接,例如星型连接

Kompella

两层

BGP

·     引入VPN的概念,限制属于不同VPNCE之间的通信

·     采用标签块的方式允许用户为VPN分配一些额外的标签,留待以后使用,减少VPN部署和扩容时的配置工作量

·     网络中新增一台CE时,只需在与其连接的PE上进行配置,维护工作量小,且不影响网络的运行

实现相对复杂,不易于理解

全连接的网络

 

1.1.6  VC封装类型

为二层报文封装VC标签前,PE对不同链路层协议的二层报文的处理方式有所不同。VC封装类型(VC type)用来标识PE对二层报文的处理方式。VC封装类型与AC的链路类型(PECE之间的链路类型)密切相关,对于以太网类型的AC链路,VC封装类型可以为EthernetVLAN两种。

·     Ethernet:采用该封装类型时,PW上传输的报文不能携带P-Tag。对于从CE侧接收到的报文,如果带有P-Tag,则删除P-tag后对报文进行封装;如果不带P-Tag,则直接对报文进行封装。对于PE转发给CE的下行报文,如果用户接入方式为VLAN,则PE添加P-Tag后转发给CE;如果用户接入方式为Ethernet,则PE不添加P-Tag,直接将报文转发给CEPE不允许重写或去除报文中已经存在的任何Tag

·     VLAN:采用该封装类型时,PW上传输的报文必须带P-Tag。对于从CE侧接收的报文,如果带有P-Tag,则对端PE不要求Ingress改写P-Tag时,保留P-Tag;对端PE要求Ingress改写P-Tag时,将P-Tag改写为对端PE期望的VLAN TagTag可能是值为0的空Tag),再对报文进行封装。如果不带P-Tag,则对端PE不要求Ingress改写P-Tag时,添加值为0的空P-Tag;对端PE要求Ingress改写P-Tag时,添加一个对端PE期望的VLAN TagTag可能是值为0的空Tag)后,再对报文进行封装。对于PE转发给CE的下行报文,如果用户接入方式为VLAN,则转发给CE时需要重写或保留P-Tag;如果用户接入方式为Ethernet,则去除P-Tag后转发给CE

1.2  MPLS L2VPN配置任务简介

MPLS L2VPN远程连接组网中,需要进行以下配置:

·     PEP上配置IGP,实现骨干网的IP连通性

·     PEP配置MPLSGREMPLS TE,在骨干网上建立公网隧道

·     在两端的PE上配置隧道策略,以便PE根据该隧道策略选择承载VC的公网隧道

·     在两端的PE上配置MPLS L2VPN,建立VC,并将ACVC绑定

MPLS L2VPN本地连接组网中,只需在PE上将两个AC绑定。

本文只介绍PE设备上的MPLS L2VPN相关配置,其余配置请参考相关手册。

说明

MPLS L2VPN对于用户网络来说是透明的,因此CE上无需进行特殊配置。

 

表1-2 MPLS L2VPN配置任务简介

操作

说明

详细配置

配置MPLS L2VPN基本功能

必选

本配置用来使能MPLS L2VPN功能,以便进行MPLS L2VPN的其他配置

1.3 

配置连接CE的接口

必选

本配置用来在PECE之间建立AC

1.4 

配置CCC方式MPLS L2VPN

选择其一

根据实际需求选择合适的实现方式

本配置用来在PE之间建立VC,并将ACVC绑定

1.5 

配置SVC方式MPLS L2VPN

1.6 

配置Martini方式MPLS L2VPN

1.7 

配置Kompella方式MPLS L2VPN

1.8 

配置对AC上的流量进行监管

可选

1.9 

配置对AC上的流量进行统计

可选

1.10 

 

1.3  配置MPLS L2VPN基本功能

表1-3 配置MPLS L2VPN基本功能

操作

命令

说明

进入系统视图

system-view

-

配置LSR-ID

mpls lsr-id lsr-id

必选

配置MPLS基本能力,并进入MPLS视图

mpls

必选

退回系统视图

quit

-

使能L2VPN,并进入L2VPN视图

l2vpn

必选

缺省情况下,L2VPN功能处于关闭状态

使能MPLS L2VPN

mpls l2vpn

必选

缺省情况下,MPLS L2VPN功能处于关闭状态

 

1.4  配置连接CE的接口

CE侧接口为PE设备上与CE相连的接口。

表1-4所示,CE侧接口的封装类型有两种,请查看相应章节了解各种封装类型的配置方法。

表1-4 CE侧接口的封装类型

CE侧接口的封装类型

详细配置

Ethernet

1.4.1 

VLAN

1.4.2 

 

1.4.1  配置CE侧接口的封装类型为Ethernet

在服务实例上配置Martini方式的MPLS L2VPN时,用户可以修改CE侧接口的封装类型;在配置其它类型的MPLS L2VPN时,均只能使用缺省的封装类型。

缺省情况下,当接口类型为三层以太网接口时,封装类型为Ethernet。有关三层以太网接口的配置请参见“二层技术-以太网交换配置指导”中的“以太网接口”;

1.4.2  配置CE侧接口的封装类型为VLAN

在服务实例上配置Martini方式的MPLS L2VPN时,用户可以修改CE侧接口的封装类型;在配置其它类型的MPLS L2VPN时,均只能使用缺省的封装类型。

缺省情况下,当接口类型为VLAN接口时,封装类型为VLAN,其中该接口所属的VLAN IDCEVLAN ID一致。有关VLAN接口的配置请参见“二层技术-以太网交换配置指导”中的“VLAN”。

1.5  配置CCC方式MPLS L2VPN

配置CCC远程连接时,需要在PEP上分别进行如下配置:

·     在两端PE上分别通过ccc interface in-label out-label命令指定入标签和出标签等。PE上不需要执行static-lsp命令为每个CCC远程连接配置静态LSP

·     PE之间的所有P设备上执行static-lsp命令为两个数据传输方向分别配置一条静态LSP,用于专门传输CCC连接的数据。

·     static-lsp命令的详细介绍,请参见“MPLS命令参考”中的“MPLS基础”。

表1-5 配置PE

操作

命令

说明

进入系统视图

system-view

-

PE上创建一条连接两个CE的远程CCC连接

ccc ccc-connection-name interface interface-type interface-number in-label in-label-value out-label out-label-value nexthop ip-address

必选

interface interface-type interface-number参数指定的接口为PE上连接CE的接口,通过指定该接口可以实现将该接口所在的AC链路与此CCC远程连接绑定

 

注意

·     CCC使用的标签范围是161023,即保留给静态LSP使用的标签。

·     CCC方式下,如果PE上连接CE的接口为VLAN接口、以太网子接口,则PE发送给CE的报文都会携带VLAN Tag。因此,在这种情况下,需要配置CE上连接PE的接口可以接收携带VLAN Tag的报文。

 

表1-6 配置P

操作

命令

说明

进入系统视图

system-view

-

Transit节点配置静态LSP

static-lsp transit lsp-name incoming-interface interface-type interface-number in-label in-label nexthop next-hop-addr  out-label out-label

必选

 

1.6  配置SVC方式MPLS L2VPN

SVC方式MPLS L2VPN不使用信令协议传输L2VPN信息,数据是通过隧道在PE之间传递。

SVC支持的隧道类型包括LDP LSPCR-LSP,缺省情况下使用LDP LSP隧道。

SVC具有以下几种配置方法:

·     在三层接口上配置SVC,包括三层以太网端口和VLAN接口。

·     在服务实例上配置SVC,只能在二层以太网端口或二层聚合接口上创建。

三层接口上和服务实例上配置的SVC有以下区别:

·     在三层接口上配置SVC后,从该接口接收到的报文将通过创建的VC连接转发。如果在VLAN接口上配置SVC,则不同二层以太网端口接收的带有该VLAN接口对应VLAN Tag的报文均通过创建的VC连接转发,即只能根据接收报文中的VLAN Tag匹配绑定的VC连接,无法区分不同二层以太网端口连接的不同用户和业务。因此,当三层接口连接的用户都通过同一个VC连接转发报文时,可以使用SVC方式。

·     在服务实例上配置SVC后,设备根据二层以太网接口或二层聚合接口上创建的服务实例对该接口接收到的报文进行匹配,与服务实例匹配的报文将通过创建的VC连接转发。服务实例提供了多种报文匹配规则(包括接口接收到的所有报文、所有携带VLAN Tag的报文和所有不携带VLAN Tag的报文等),为报文接入VC连接提供了更加灵活的方式。因此,当不同物理端口连接的用户需要通过不同的VC连接转发报文时,建议采用此方式。

1.6.1  在三层接口上配置SVC方式的MPLS L2VPN(方式一)

表1-7 在三层接口上配置SVC方式的MPLS L2VPN(方式一)

操作

命令

说明

进入系统视图

system-view

-

进入连接CE的接口视图

interface interface-type interface-number

-

创建普通方式SVCVC连接

mpls static-l2vc destination destination-router-id transmit-vpn-label transmit-label-value receive-vpn-label receive-label-value [ { ethernet | vlan } | tunnel-policy tunnel-policy-name ] *

必选

 

说明

·     SVC使用的标签范围是161023,即保留给静态LSP使用的标签。

·     本地PE上配置的transmit-vpn-label与对端PE上配置的receive-vpn-label应该相同;本地PE上配置的receive-vpn-label与对端PE上配置的transmit-vpn-label应该相同。

 

1.6.2  在三层接口上配置SVC方式的MPLS L2VPN(方式二)

表1-8 在三层接口上配置SVC方式的MPLS L2VPN(方式二)

操作

命令

说明

进入系统视图

system-view

-

进入连接CE的接口视图

interface interface-type interface-number

-

创建SVC方式的VC连接,并进入Static-L2VC视图

mpls static-l2vc destination vcid [ { ethernet | vlan } | [ tunnel-policy tunnel-policy-name ] ] *

必选

缺省情况下,没有创建SVC方式的VC连接

配置VC的标签

static label local local-vc remote remote-vc

必选

缺省情况下,没有指定VC的标签

 

1.6.3  在服务实例上配置SVC方式的MPLS L2VPN

完成本配置任务,需要在PE上执行以下操作:

·     在二层以太网接口或二层聚合接口上创建服务实例

·     为服务实例配置报文匹配规则

·     在服务实例上创建SVC方式的VC连接

配置完成后,如果接口接收到的报文符合服务实例的报文匹配规则,则该报文将通过该服务实例下创建的VC连接进行转发。

为了简化VC属性(如VC封装类型、VC隧道选用策略)的配置,可以先创建PW模板,在PW模板下配置VC属性,具有相同属性的VC通过引用相同的PW模板实现对VC属性的配置,无需逐个配置每个属性。

表1-9 在服务实例上配置SVC方式的MPLS L2VPN

操作

命令

说明

进入系统视图

system-view

-

创建PW模板,并进入PW模板视图

pw-class pw-class-name

可选

缺省情况下,不存在任何PW模板

设置VC封装类型

trans-mode { ethernet | vlan }

可选

缺省情况下,VC封装类型为VLAN

设置隧道选用策略

pw-tunnel-policy policy-name

可选

缺省情况下,采用缺省策略,即按照LSP隧道->GRE隧道->CR-LSP隧道的优先级顺序选择隧道,并指定负载分担个数为1

隧道策略的配置方法,请参见“MPLS配置指导”中的“MPLS L3VPN

退回系统视图

quit

-

进入连接CE的二层以太网接口或二层聚合接口视图

进去二层以太网接口视图

interface interface-type interface-number

-

进去二层聚合接口视图

interface bridge-aggregation interface-number

创建服务实例,并进入服务实例视图

service-instance instance-id

必选

缺省情况下,不存在任何服务实例

配置报文匹配规则

encapsulation { s-vid vlan-id [ only-tagged ] | port-based | tagged | untagged }

必选

缺省情况下,不存在任何报文匹配规则

在服务实例上创建SVC方式的VC连接,并进入Static-xpeer视图

xconnect static-peer peer-ip-address pw-id pw-id [ access-mode { ethernet | vlan } | mtu mtu-value | pw-class class-name ] *

必选

此命令执行后,服务实例下匹配的VLAN ID、接入模式和MTU值均不可更改,只有执行undo xconnect static-peer命令删除VC连接后,才可以修改这些参数

配置VC的标签

static label local local-vc remote remote-vc

必选

缺省情况下,没有指定VC的标签

显示接口上服务实例的信息

display service-instance interface interface-type interface-number [ service-instance instance-id ] [ | { begin | exclude | include } regular-expression ]

display命令可以在任意视图执行

 

说明

·     xconnect static-peer命令只能在编号为14094的服务实例视图下进行配置,否则系统会提示出错。

·     有关service-instanceencapsulationdisplay service-instance interface命令的详细介绍,请参见“MPLS命令参考”中的“VPLS”。

 

1.7  配置Martini方式MPLS L2VPN

配置Martini方式的MPLS L2VPN时需要:

(1)     配置远端对等体

Martini方式的MPLS L2VPN中,需要在PE之间交换VC标签。由于交换VC标签的两个PE可能不是直接相连的,所以需要在两个PE上分别将对端PE配置为远端对等体,以便在PE之间建立LDP远端会话,并在这个会话上传递VC FECVC标签。

(2)     创建Martini方式VC连接

用户可以通过以下两种方式创建Martini方式的VC连接:

·     三层接口上创建:在三层接口上创建Martini方式的VC连接后,从该接口接收到的报文将通过创建的VC连接转发。如果三层接口为VLAN接口,则不同二层以太网接口接收的相同VLAN Tag的报文均通过创建的VC连接转发,即只能根据接收报文中的VLAN Tag匹配绑定的VC连接,无法区分不同二层以太网接口连接的不同用户和业务。三层接口连接的用户都通过同一个VC连接转发报文时,可以采用此方式。

·     服务实例(Service Instance)上创建:在服务实例上创建Martini方式的VC连接后,设备根据二层以太网接口或二层聚合接口上创建的服务实例对该接口接收到的报文进行匹配,与服务实例匹配的报文将通过创建的VC连接转发。服务实例提供了多种报文匹配规则(包括接口接收到的所有报文、所有携带VLAN Tag的报文和所有不携带VLAN Tag的报文等),为报文接入VC连接提供了更加灵活的方式。VLAN接口连接的用户需要通过不同的VC连接转发报文时,可以采用此方式。服务实例的详细介绍请参见“MPLS配置指导”中的“VPLS”。

说明

服务实例只能在二层以太网端口或二层聚合接口上创建。

 

1.7.1  配置远端对等体

下述配置需要在PE上进行。

表1-10 配置远端对等体

操作

命令

说明

进入系统视图

system-view

-

创建远端对等体实体并进入MPLS-LDP远端对等体视图

mpls ldp remote-peer remote-peer-name

必选

将对端PE的地址指定为LDP远端对等体的IP地址

remote-ip ip-address

必选

 

说明

有关远端对等体的配置请参见“MPLS配置指导”中的“MPLS基础”。

 

1.7.2  在三层接口上创建Martini方式的VC连接

表1-11 在三层接口上创建Martini方式的VC连接

操作

命令

说明

进入系统视图

system-view

-

进入连接CE的接口视图

interface interface-type interface-number

-

创建Martini方式VC连接

mpls l2vc destination vcid [ { ethernet | vlan } | [ tunnel-policy tunnel-policy-name ] ] *

必选

 

注意

创建Martini方式VC连接的命令主要参数有两个:一个是对端PEIP地址,一个是VC ID。其中,VC ID与封装类型的组合必须在PE上唯一,修改封装类型有可能会造成VC ID的冲突。

 

1.7.3  配置在服务实例上创建Martini方式的VC连接

完成本配置任务,需要在PE上执行以下操作:

·     在二层以太网接口或二层聚合接口上创建服务实例

·     为服务实例配置报文匹配规则

·     在服务实例上创建Martini方式的VC连接

配置完成后,如果接口接收到的报文符合服务实例的报文匹配规则,则该报文将通过该服务实例下创建的VC连接进行转发。

为了简化VC属性(如VC封装类型、VC隧道选用策略)的配置,可以先创建PW模板,在PW模板下配置VC属性,具有相同属性的VC通过引用相同的PW模板实现对VC属性的配置,无需逐个配置每个属性。

表1-12 在服务实例上创建Martini方式的VC连接

操作

命令

说明

进入系统视图

system-view

-

创建PW模板,并进入PW模板视图

pw-class pw-class-name

可选

缺省情况下,不存在任何PW模板

设置VC封装类型

trans-mode { ethernet | vlan }

可选

缺省情况下,VC封装类型为VLAN

设置隧道选用策略

pw-tunnel-policy policy-name

可选

缺省情况下,采用缺省策略,即按照LSP隧道-> CR-LSP隧道的优先级顺序选择隧道,并指定负载分担个数为1

隧道策略的配置方法,请参见“MPLS配置指导”中的“MPLS L3VPN

退回系统视图

quit

-

进入连接CE的二层以太网接口或二层聚合接口视图

进去二层以太网接口视图

interface interface-type interface-number

-

进去二层聚合接口视图

interface bridge-aggregation interface-number

创建服务实例,并进入服务实例视图

service-instance instance-id

必选

缺省情况下,不存在任何服务实例

配置报文匹配规则

encapsulation { s-vid { vlan-id | vlan-list } [ only-tagged ] | port-based | tagged | untagged }

必选

缺省情况下,不存在任何报文匹配规则

在服务实例上创建Martini方式的VC连接

xconnect peer peer-ip-address pw-id pw-id [ access-mode { ethernet | vlan } | mtu mtu-value | [ pw-class class-name ] ] *

必选

此命令执行后服务实例下匹配的VLAN ID、接入模式和MTU值均不可更改只有执行undo xconnect peer命令删除VC连接后才可以修改这些参数

显示接口上服务实例的信息

display service-instance interface interface-type interface-number [ service-instance instance-id ] [ | { begin | exclude | include } regular-expression ]

display命令可以在任意视图执行

 

说明

·     目前,MPLS L2VPN不支持多条隧道的负载分担。

·     xconnect peer命令只能在编号为14094的服务实例视图下进行配置,否则系统会提示出错。

 

1.7.4  检测VC

说明

MPLS LSP Ping只能用来检测Martini方式VC的可达性。

 

MPLS L2VPN网络中,通过MPLS LSP Ping功能,可以对VC的可达性进行检测,并提供必要的诊断信息,以便对VC的故障进行定位。

MPLS LSP Ping功能采取的方法是:在本地PE设备上为MPLS Echo Request报文压入待检测的VC对应的标签,使得MPLS Echo Request报文沿着VC转发,本地PE设备根据收到的对端PE设备的应答报文,判断VC的可达性。

表1-13 利用MPLS LSP Ping功能检测VC

操作

命令

说明

通过MPLS LSP Ping检测VC的可达性

ping lsp [ -a source-ip | -c count | -exp exp-value | -h ttl-value | -m wait-time | -r reply-mode | -s packet-size | -t time-out | -v ] * pw ip-address pw-id pw-id

必选

可在任意视图下执行本命令

 

1.8  配置Kompella方式MPLS L2VPN

配置Kompella方式远程连接时,需要在PE上进行以下配置:

·     配置BGPL2VPN能力

·     创建并配置MPLS L2VPN

·     配置CE连接

·     配置Kompella方式本地连接时,不需要配置BGPL2VPN能力,只需在PE上创建并配置MPLS L2VPN、配置CE连接。

1.8.1  配置BGPL2VPN能力

表1-14 配置BGPL2VPN能力

操作

命令

说明

进入系统视图

system-view

-

进入BGP视图

bgp as-number

-

与对端PE建立对等体

peer { group-name | ip-address } as-number as-number

必选

指定建立TCP连接的接口

peer { group-name | ip-address } connect-interface interface-type interface-number

必选

进入BGP-L2VPN地址族视图

l2vpn-family

必选

对接收到的VPNv4路由使能VPN-Target过滤功能

policy vpn-target

可选

缺省情况下,对接收的路由信息进行VPN-target扩展团体属性的过滤

使能对等体,并使能交换BGP-L2VPN地址族的BGP路由信息的能力

peer { group-name | ip-address } enable

必选

 

说明

BGP-L2VPN地址族下的详细配置,请参见“MPLS配置指导”中的“MPLS L3VPN”。

 

1.8.2  创建并配置MPLS L2VPN

表1-15 配置VPN

操作

命令

说明

进入系统视图

system-view

-

创建MPLS L2VPN,并进入MPLS-L2VPN视图

mpls l2vpn vpn-name [ encapsulation { ethernet | vlan } ]

必选

MPLS L2VPN配置RD

route-distinguisher route-distinguisher

必选

将指定MPLS L2VPN和一个或多个VPN Target相关联

vpn-target vpn-target&<1-16> [ both | export-extcommunity | import-extcommunity ]

必选

配置MPLS L2VPNMTU

mtu mtu

可选

缺省情况下,MPLS L2VPNMTU值为1500

 

注意

·     mtu命令只进行有可能存在的协议上的参数协商,并不指导转发,因此不建议使用此命令。

·     Kompella方式MPLS L2VPN必须在PE上为每个直接相连的CE所在的VPN创建L2VPN。创建L2VPN时指定的封装类型应与AC链路类型对应。

·     对于Kompella L2VPN,必须配置RDRD配置后不能修改,除非先删除创建的VPN,然后重新创建。

 

1.8.3  配置CE连接

1. 简介

配置CE连接时的主要参数解释如下:

(1)     id ce-id

PE连接的本地CECE ID

(2)     range ce-range

当前CE在一个VPN内最多可以连接的CE数——CE范围(CE range)。

建议根据对VPN规模发展的预计,把CE range设置得比实际需要大一些。这样当以后对VPN进行扩容,增加VPN中的CE数目时,就可以尽量少的修改配置。

(3)     default-offset default-offset

VPNCE的起始编号,取值为01。取值为0时,表示VPN内的CE0开始编号;取值为1时,表示VPN内的CE1开始编号。

本参数和CE range决定了PECE分配的标签块:

·     第一次执行ce命令时指定CE rangece-range1,则分配第一个标签块,其LRCE range相同,为ce-range1。如果default-offset0,则LO0;否则,LO1

·     再次执行ce命令时将CE range增加为ce-range2(大于ce-range1),则分配第二个标签块,LRce-range2ce-range1。如果default-offset0,则LOce-range1;否则,LOce-range11。以此类推。

例如,在PE上先后执行如下命令,则PE分配三个标签块,分别为:LB1/0/10LB2/10/12LB3/22/14。其中,LB1LB2LB3PE自动选取的标签值。

ce ce1 id 1 range 10 default-offset 0

ce ce1 id 1 range 22

ce ce1 id 1 range 36

(4)     ce-offset ce-id

与本地CE建立远程连接或本地连接的对端CECE ID

如果执行connection命令时没有指定本参数,则:

·     第一次执行connection命令时,为本地CEIDdefault-offset的对端CE建立连接。如果default-offset的值与本地CE ID相同,则为本地CEIDdefault-offset1的对端CE建立连接。

·     再次执行connection命令时,为本地CEID<上一个连接的CE ID1>的对端CE建立连接。如果<上一个连接的CE ID1>与本地CE ID相同,则为本地CEID<上一个连接的CE ID2>的对端CE建立连接。以此类推。

在规划VPN时,建议CE ID编号顺序递增,在配置连接时按CE ID顺序配置,这样,大多数连接都可以省略ce-offset参数,使用缺省值,从而简化配置。

2. 配置过程

表1-16 配置CE连接

操作

命令

说明

进入系统视图

system-view

-

进入MPLS-L2VPN视图

mpls l2vpn vpn-name

-

创建CE,指定CE名称、CE IDCE rangeCE起始编号,并进入MPLS-L2VPN-CE视图

ce ce-name [ id ce-id [ range ce-range ] [ default-offset default-offset ] ]

必选

创建Kompella方式连接

connection [ ce-offset ce-id ] interface interface-type interface-number [ tunnel-policy tunnel-policy-name ]

必选

ce-offset ce-id参数指定的CE ID值决定了此连接是本地连接还是远程连接。如果该CE ID标识的CE与本CE连接在同一个PE上,则建立的为本地连接;否则,为远程连接

本配置中指定的接口为PE上连接CE的接口,通过指定该接口可以实现将该接口所在的AC链路与此连接绑定

 

说明

·     通过重复执行ce命令的方式修改CE range时,只能CE range改得更大,不能改小。例如:原来的CE range10,则可以把它改为20;如果改为5,则会失败。要想将CE range改小,则需要删除这个CE,并重新创建。

·     通过重复执行ce命令的方式将CE range改得更大时,不会导致原有业务的中断。

 

3. 复位L2VPNBGP会话

当影响BGP路由选择的配置发生变化后,如果需要通过复位BGP会话使新的配置生效,请在用户视图下进行以下配置。

表1-17 复位L2VPNBGP会话

操作

命令

复位L2VPNBGP会话

reset bgp l2vpn { as-number | ip-address | all | external | internal }

 

1.9  配置对AC上的流量进行监管

流量监管是指通过限定报文的接收和发送速率,来避免网络拥塞。ACAttachment Circuit,接入电路)原指CEPE之间的物理链路,用来传输用户向公网发送的数据。在MPLS L2VPN环境中,该链路上的流量被PE通过服务实例区分为不同的VPN用户流量,因此,这里的AC实际对应的是PE上的每一个服务实例。

1.9.1  配置准备

配置对AC上的流量进行监管之前,需要先通过系统视图下的qos car命令配置全局CARCommitted Access Rate,承诺访问速率)的参数。全局CAR的详细介绍,请参见“ACLQoS配置指导”中的“全局CAR”。

1.9.2  配置对AC上的流量进行监管

在服务实例视图下应用全局CAR后,当端口发送或接收符合该服务实例匹配规则的报文时,设备将根据应用的全局CARAC入方向或出方向的流量进行监管。

表1-18 配置对AC上的流量进行监管

操作

命令

说明

进入系统视图

system-view

-

进入连接CE的二层以太网接口或二层聚合接口视图

进去二层以太网接口视图

interface interface-type interface-number

-

进去二层聚合接口视图

interface bridge-aggregation interface-number

进入服务实例视图

service-instance instance-id

-

配置在AC入方向或出方向上应用全局CAR

car { inbound | outbound } name car-name

必选

缺省情况下,没有对AC上的流量进行监管

 

说明

car命令的详细介绍,请参见“MPLS命令参考”中的“VPLS”。

 

1.10  配置AC上的流量进行统计

在服务实例下创建VC连接后,通过执行以下配置,在服务实例视图下使能流量统计功能,可以实现对AC入方向或出方向的流量进行统计。

表1-19 配置服务实例的流量统计功能

操作

命令

说明

进入系统视图

system-view

-

进入连接CE的二层以太网接口或二层聚合接口视图

进去二层以太网接口视图

interface interface-type interface-number

-

进去二层聚合接口视图

interface bridge-aggregation interface-number

进入服务实例视图

service-instance instance-id

-

使能AC入方向或出方向流量的统计功能

statistics { inbound | outbound }

必选

缺省情况下,AC的流量统计功能处于关闭状态

 

说明

·     statistics命令的详细介绍,请参见“MPLS命令参考”中的“VPLS”。

·     AC的流量统计信息可以通过display mpls l2vpn fib ac vpws命令查看,详细介绍请参见“MPLS命令参考”中的“VPLS”。

 

1.11  MPLS L2VPN显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后MPLS L2VPN的运行情况,通过查看显示信息验证配置的效果。

表1-20 MPLS L2VPN显示和维护

操作

命令

显示CCC连接信息

display ccc [ ccc-name ccc-name | type { local | remote } ] [ | { begin | exclude | include } regular-expression ]

显示L2VPN VC使用的接口信息

display l2vpn ccc-interface vc-type { all | bgp-vc | ccc | ldp-vc | static-vc } [ up | down ] [ | { begin | exclude | include } regular-expression ]

显示设备上创建的SVC的相关信息

display mpls static-l2vc [ interface interface-type interface-number [ service-instance instance-id ] ] [ | { begin | exclude | include } regular-expression ]

显示设备上Martini方式VC的相关信息

display mpls l2vc[ interface interface-type interface-number [ service-instance instance-id ] | remote-info] [ | { begin | exclude | include } regular-expression ]

显示Kompella方式的VC连接信息

display mpls l2vpn connection [ vpn-name vpn-name [ remote-ce ce-id | down | up | verbose ] | summary | interface interface-type interface-number ] [ | { begin | exclude | include } regular-expression ]

显示BGP路由表中的L2VPN信息

display bgp l2vpn { all | group [ group-name ] | peer [ [ ip-address ] verbose ] | route-distinguisher rd [ ce-id ce-id [ label-offset label-offset ] ] } [ | { begin | exclude | include } regular-expression ]

显示PE上的L2VPN信息

display mpls l2vpn [ export-route-target-list | import-route-target-list | vpn-name vpn-name [ local-ce | remote-ce ] ] [ | { begin | exclude | include } regular-expression ]

显示MPLS L2VPNAC表项信息

display mpls l2vpn fib ac vpws [ interface interface-type interface-number [ service-instance service-instanceid ] ] [ slot slot-number ] [ | { begin | exclude | include } regular-expression ]

显示MPLS L2VPNPW表项信息

display mpls l2vpn fib pw vpws [ interface interface-type interface-number [ service-instance service-instanceid ] ] [ slot slot-number ] [ verbose ] [ | { begin | exclude | include } regular-expression ]

显示PW模板的信息

display pw-class [ pw-class-name ] [ | { begin | exclude | include } regular-expression ]

清除服务实例的流量统计信息

reset service-instance statistics [ interface interface-type interface-number [ service-instance instance-id [ inbound | outbound ] ] ]

 

1.12  MPLS L2VPN典型配置举例

1.12.1  配置CCC远程连接示例

1. 组网需求

·     PE通过VLAN接口连接CE

·     通过建立CCC远程连接,实现CE 1CE 2之间的二层报文跨越骨干网络传递。

2. 配置思路

配置CCC远程连接的关键步骤包括:

·     PE上创建CCC远程连接(不需要配置静态LSP)。

·     P上配置两条静态LSP,用于双向传递报文。

3. 组网图

图1-8 配置CCC远程连接组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

Vlan-int10

100.1.1.1/24

CE 2

Vlan-int10

100.1.1.2/24

PE 1

Loop0

10.0.0.1/32

P

Loop0

10.0.0.2/32

 

Vlan-int30

10.1.1.1/24

 

Vlan-int20

10.2.2.2/24

PE 2

Loop0

10.0.0.3/32

 

Vlan-int30

10.1.1.2/24

 

Vlan-int20

10.2.2.1/24

 

 

 

 

4. 配置步骤

(1)     配置CE 1

# 为连接PE 1的接口Vlan-interface10配置IP地址。

<Sysname> system-view

[Sysname] sysname CE1

[CE1] interface vlan-interface 10

[CE1-Vlan-interface10] ip address 100.1.1.1 24

(2)     配置PE 1

# 配置LSR ID,全局使能MPLS

<Sysname> system-view

[Sysname] sysname PE1

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 10.0.0.1 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 10.0.0.1

[PE1] mpls

[PE1-mpls] quit

# 使能L2VPNMPLS L2VPN

[PE1] l2vpn

[PE1-l2vpn] mpls l2vpn

[PE1-l2vpn] quit

# 配置接口Vlan-interface10

[PE1] interface vlan-interface 10

[PE1-Vlan-interface10] quit

# 配置接口Vlan-interface30使能MPLS

[PE1] interface vlan-interface 30

[PE1-Vlan-interface30] ip address 10.1.1.1 24

[PE1-Vlan-interface30] mpls

[PE1-Vlan-interface30] quit

# 创建CE 1CE 2的远程连接入接口为连接CE 1的接口出接口为连接P的接口入标签为100出标签为200

[PE1] ccc ce1-ce2 interface vlan-interface 10 in-label 100 out-label 200 nexthop 10.1.1.2

(3)     配置P

# 配置LSR ID,全局使能MPLS

<Sysname> system-view

[Sysname] sysname P

[P] interface loopback 0

[P-LoopBack0] ip address 10.0.0.2 32

[P-LoopBack0] quit

[P] mpls lsr-id 10.0.0.2

[P] mpls

[P-mpls] quit

# 配置接口Vlan-interface30,使能MPLS

[P] interface vlan-interface 30

[P-Vlan-interface30] ip address 10.1.1.2 24

[P-Vlan-interface30] mpls

[P-Vlan-interface30] quit

# 配置接口Vlan-interface20使能MPLS

[P] interface vlan-interface 20

[P-Vlan-interface20] ip address 10.2.2.2 24

[P-Vlan-interface20] mpls

[P-Vlan-interface20] quit

# 配置一条静态LSP用于转发由PE 1去往PE 2的报文。

[P] static-lsp transit pe1_pe2 incoming-interface vlan-interface 30 in-label 200 nexthop 10.2.2.1 out-label 201

# 配置另一条静态LSP用于转发由PE 2去往PE 1的报文。

[P] static-lsp transit pe2_pe1 incoming-interface vlan-interface 20 in-label 101 nexthop 10.1.1.1 out-label 100

(4)     配置PE 2

# 配置LSR ID,全局使能MPLS

<Sysname> system-view

[Sysname] sysname PE2

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 10.0.0.3 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 10.0.0.3

[PE2] mpls

[PE2-mpls] quit

# 使能L2VPNMPLS L2VPN

[PE2] l2vpn

[PE2-l2vpn] mpls l2vpn

[PE2-l2vpn] quit

# 配置接口Vlan-interface10

[PE2] interface vlan-interface 10

[PE2-Vlan-interface10] quit

# 配置接口Vlan-interface20使能MPLS

[PE2] interface vlan-interface 20

[PE2-Vlan-interface20] ip address 10.2.2.1 24

[PE2-Vlan-interface20] mpls

[PE2-Vlan-interface20] quit

# 创建CE 2CE 1的远程连接入接口为连接CE 2的接口出接口为连接P的接口入标签为201出标签为101

[PE2] ccc ce2-ce1 interface vlan-interface 10 in-label 201 out-label 101  nexthop 10.2.2.2

(5)     配置CE 2

# 为连接PE 2的接口Vlan-interface10配置IP地址。

<Sysname> system-view

[Sysname] sysname CE2

[CE2] interface vlan-interface 10

[CE2-Vlan-interface10] ip address 100.1.1.2 24

5. 验证配置

# 配置完成后,在PE 1上查看CCC连接信息,可以看到建立了一条CCC远程连接。

[PE1] display ccc

    Total  ccc vc          : 1

    Local  ccc vc          : 0,  0 up

    Remote ccc vc          : 1,  1 up

 ***Name                   : ce1-ce2

    Type                   : remote

    State                  : up

    Intf                   : Vlan-interface10 (up)

    In-label               : 100

    Out-label              : 200

    Nexthop                : 10.1.1.2

# CE 1CE 2之间能够ping通。

[CE1] ping 100.1.1.2

  PING 100.1.1.2: 56  data bytes, press CTRL_C to break

    Reply from 100.1.1.2: bytes=56 Sequence=1 ttl=255 time=180 ms

    Reply from 100.1.1.2: bytes=56 Sequence=2 ttl=255 time=60 ms

    Reply from 100.1.1.2: bytes=56 Sequence=3 ttl=255 time=10 ms

    Reply from 100.1.1.2: bytes=56 Sequence=4 ttl=255 time=70 ms

    Reply from 100.1.1.2: bytes=56 Sequence=5 ttl=255 time=60 ms

  --- 100.1.1.2 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 10/76/180 ms

1.12.2  配置SVC方式MPLS L2VPN示例

1. 组网需求

·     PE通过VLAN口连接CE

·     通过建立SVC方式的VC连接,实现CE 1CE 2之间的二层报文跨越骨干网络传递。

2. 配置思路

主要的配置步骤可分为两部分:

·     PEP上配置MPLS基本转发能力:包括配置LSR ID、使能MPLSLDP、在PE 1PPE 2之间运行IGP(本配置例中使用OSPF)以建立LSP

·     建立SVC方式的VC连接:包括在PE 1PE 2上使能MPLS L2VPN、创建SVC连接并指定VC标签。

3. 组网图

图1-9 配置SVC方式MPLS L2VPN组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

Vlan-int10

100.1.1.1/24

CE 2

Vlan-int10

100.1.1.2/24

PE 1

Loop0

192.2.2.2/32

P

Loop0

192.4.4.4/32

 

Vlan-int20

10.1.1.1/24

 

Vlan-int30

10.2.2.2/24

PE 2

Loop0

192.3.3.3/32

 

Vlan-int20

10.1.1.2/24

 

Vlan-int30

10.2.2.1/24

 

 

 

 

4. 配置步骤

(1)     配置CE 1

# 为连接PE 1的接口Vlan-interface10配置IP地址。

<Sysname> system-view

[Sysname] sysname CE1

[CE1] interface vlan-interface 10

[CE1-Vlan-interface10] ip address 100.1.1.1 24

(2)     配置PE 1

# 配置LSR ID,全局使能MPLS

<Sysname> system-view

[Sysname] sysname PE1

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.2.2.2 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 192.2.2.2

[PE1] mpls

[PE1-mpls] quit

# 使能L2VPNMPLS L2VPN

[PE1] l2vpn

[PE1-l2vpn] mpls l2vpn

[PE1-l2vpn] quit

# 全局使能LDP

[PE1] mpls ldp

[PE1-mpls-ldp] quit

# 配置连接P的接口Vlan-interface20在此接口上使能LDP

[PE1] interface vlan-interface 20

[PE1-Vlan-interface20] ip address 10.1.1.1 24

[PE1-Vlan-interface20] mpls

[PE1-Vlan-interface20] mpls ldp

[PE1-Vlan-interface20] quit

# PE 1上运行OSPF用于建立LSP

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 在接入CE 1的接口Vlan-interface10上创建一条SVC方式VC连接。此接口不需配置IP地址。

[PE1] interface vlan-interface 10

[PE1-Vlan-interface10] mpls static-l2vc destination 192.3.3.3 transmit-vpn-label 100 receive-vpn-label 200

[PE1-Vlan-interface10] quit

(3)     配置P

# 配置LSR ID,全局使能MPLS

<Sysname> system-view

[Sysname] sysname P

[P] interface loopback 0

[P-LoopBack0] ip address 192.4.4.4 32

[P-LoopBack0] quit

[P] mpls lsr-id 192.4.4.4

[P] mpls

[P-mpls] quit

# 全局使能LDP

[P] mpls ldp

[P-mpls-ldp] quit

# 配置连接PE 1的接口Vlan-interface20在此接口上使能LDP

[P] interface vlan-interface 20

[P-Vlan-interface20] ip address 10.1.1.2 24

[P-Vlan-interface20] mpls

[P-Vlan-interface20] mpls ldp

[P-Vlan-interface20] quit

# 配置连接PE 2的接口Vlan-interface30在此接口上使能LDP

[P] interface vlan-interface 30

[P-Vlan-interface30] ip address 10.2.2.2 24

[P-Vlan-interface30] mpls

[P-Vlan-interface30] mpls ldp

[P-Vlan-interface30] quit

# P上运行OSPF用于建立LSP

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

(4)     配置PE 2

# 配置LSR ID,全局使能MPLS

<Sysname> system-view

[Sysname] sysname PE2

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.3.3.3 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 192.3.3.3

[PE2] mpls

[PE2-mpls] quit

# 使能L2VPNMPLS L2VPN

[PE2] l2vpn

[PE2-l2vpn] mpls l2vpn

[PE2-l2vpn] quit

# 全局使能LDP

[PE2] mpls ldp

[PE2-mpls-ldp] quit

# 配置连接P的接口Vlan-interface30在此接口上使能LDP

[PE2] interface vlan-interface 30

[PE2-Vlan-interface30] ip address 10.2.2.1 24

[PE2-Vlan-interface30] mpls

[PE2-Vlan-interface30] mpls ldp

[PE2-Vlan-interface30] quit

# PE 2上运行OSPF用于建立LSP

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 10.2.2.1 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 在接入CE 2的接口Vlan-interface10上创建一条SVC方式VC连接。此接口不需配置IP地址。

[PE2] interface vlan-interface 10

[PE2-Vlan-interface10] mpls static-l2vc destination 192.2.2.2 transmit-vpn-label 200 receive-vpn-label 100

[PE2-Vlan-interface10] quit

(5)     配置CE 2

# 为连接PE 2的接口Vlan-interface10配置IP地址。

<Sysname> system-view

[Sysname] sysname CE2

[CE2] interface vlan-interface 10

[CE2-Vlan-interface10] ip address 100.1.1.2 24

5. 验证配置

# PE 1上查看SVCVC连接信息,可以看到建立了一条VC连接。

[PE1] display mpls static-l2vc

Total connections:  1,  1 up,  0 down

ce-intf             state destination     tr-label  rcv-label tnl-policy

Vlan10              up    192.3.3.3       100       200       -  

# PE 2上也可以看到SVCVC连接。

[PE2] display mpls static-l2vc

Total connections:  1,  1 up,  0 down

ce-intf             state destination     tr-label  rcv-label tnl-policy

Vlan20              up    192.2.2.2       200       100       -

# CE 1CE 2之间能够ping通。

[CE1] ping 100.1.1.2

  PING 100.1.1.2: 56  data bytes, press CTRL_C to break

    Reply from 100.1.1.2: bytes=56 Sequence=1 ttl=255 time=150 ms

    Reply from 100.1.1.2: bytes=56 Sequence=2 ttl=255 time=130 ms

    Reply from 100.1.1.2: bytes=56 Sequence=3 ttl=255 time=130 ms

    Reply from 100.1.1.2: bytes=56 Sequence=4 ttl=255 time=140 ms

    Reply from 100.1.1.2: bytes=56 Sequence=5 ttl=255 time=80 ms

  --- 100.1.1.2 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 80/126/150 ms

1.12.3  配置Martini方式MPLS L2VPN示例

1. 组网需求

·     PE通过VLAN接口连接CE

·     通过建立Martini方式的VC连接,实现CE 1CE 2之间的二层报文跨越骨干网络传递。

2. 组网图

图1-10 配置Martini方式MPLS L2VPN组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

Vlan-int10

100.1.1.1/24

CE 2

Vlan-int10

100.1.1.2/24

PE 1

Loop0

192.2.2.2/32

P

Loop0

192.4.4.4/32

 

Vlan-int20

10.1.1.1/24

 

Vlan-int20

10.1.1.2/24

PE 2

Loop0

192.3.3.3/32

 

Vlan-int30

10.2.2.2/24

 

Vlan-int30

10.2.2.1/24

 

 

 

 

3. 配置步骤

(1)     配置CE 1

# 为连接PE 1的接口Vlan-interface10配置IP地址。

<Sysname> system-view

[Sysname] sysname CE1

[CE1] interface vlan-interface 10

[CE1-Vlan-interface10] ip address 100.1.1.1 24

(2)     配置PE 1

# 配置LSR ID,全局使能MPLS

<Sysname> system-view

[Sysname] sysname PE1

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.2.2.2 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 192.2.2.2

[PE1] mpls

[PE1-mpls] quit

# 使能L2VPNMPLS L2VPN

[PE1] l2vpn

[PE1-l2vpn] mpls l2vpn

[PE1-l2vpn] quit

# 全局使能LDP

[PE1] mpls ldp

[PE1-mpls-ldp] quit

# 配置PE 1PE 2建立LDP远程会话。

[PE1] mpls ldp remote-peer 1

[PE1-mpls-ldp-remote-1] remote-ip 192.3.3.3

[PE1-mpls-ldp-remote-1] quit

# 配置连接P的接口Vlan-interface20在此接口上使能LDP

[PE1] interface vlan-interface 20

[PE1-Vlan-interface20] ip address 10.1.1.1 24

[PE1-Vlan-interface20] mpls

[PE1-Vlan-interface20] mpls ldp

[PE1-Vlan-interface20] quit

# PE 1上运行OSPF用于建立LSP

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 在接入CE 1的接口Vlan-interface10上创建VC连接。此接口不需配置IP地址。

[PE1] interface vlan-interface 10

[PE1-Vlan-interface10] mpls l2vc 192.3.3.3 101

[PE1-Vlan-interface10] quit

(3)     配置P

# 配置LSR ID,全局使能MPLS

<Sysname> system-view

[Sysname] sysname P

[P] interface loopback 0

[P-LoopBack0] ip address 192.4.4.4 32

[P-LoopBack0] quit

[P] mpls lsr-id 192.4.4.4

[P] mpls

[P-mpls] quit

# 全局使能LDP

[P] mpls ldp

[P-mpls-ldp] quit

# 配置连接PE 1的接口Vlan-interface20在此接口上使能LDP

[P] interface vlan-interface 20

[P-Vlan-interface20] ip address 10.1.1.2 24

[P-Vlan-interface20] mpls

[P-Vlan-interface20] mpls ldp

[P-Vlan-interface20] quit

# 配置连接PE 2的接口Vlan-interface30在此接口上使能LDP

[P] interface vlan-interface 30

[P-Vlan-interface30] ip address 10.2.2.2 24

[P-Vlan-interface30] mpls

[P-Vlan-interface30] mpls ldp

[P-Vlan-interface30] quit

# P上运行OSPF用于建立LSP

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

(4)     配置PE 2

# 配置LSR ID,全局使能MPLS

<Sysname> system-view

[Sysname] sysname PE2

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.3.3.3 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 192.3.3.3

[PE2] mpls

[PE2-mpls] quit

# 使能L2VPNMPLS L2VPN

[PE2] l2vpn

[PE2-l2vpn] mpls l2vpn

[PE2-l2vpn] quit

# 全局使能LDP

[PE2] mpls ldp

[PE2-mpls-ldp] quit

# 配置PE 2PE 1建立LDP远程会话。

[PE2] mpls ldp remote-peer 2

[PE2-mpls-ldp-remote-2] remote-ip 192.2.2.2

[PE2-mpls-ldp-remote-2] quit

# 配置连接P的接口Vlan-interface30,在此接口上使能LDP

[PE2] interface vlan-interface 30

[PE2-Vlan-interface30] ip address 10.2.2.1 24

[PE2-Vlan-interface30] mpls

[PE2-Vlan-interface30] mpls ldp

[PE2-Vlan-interface30] quit

# PE 2上运行OSPF,用于建立LSP

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 在接入CE 2的接口Vlan-interface10上创建VC连接。此接口不需配置IP地址。

[PE2] interface vlan-interface 10

[PE2-Vlan-interface10] mpls l2vc 192.2.2.2 101

[PE2-Vlan-interface10] quit

(5)     配置CE 2

# 为连接PE 2的接口Vlan-interface10配置IP地址。

<Sysname> system-view

[Sysname] sysname CE2

[CE2] interface vlan-interface 10

[CE2-Vlan-interface10] ip address 100.1.1.2 24

4. 验证配置

# PE 1上查看VC连接信息,可以看到建立了一条VC连接。

[PE1] display mpls l2vc

Total ldp vc : 1     1 up       0 down      0 blocked

 

Transport   Client               Service  VC       Local     Remote

VC ID       Intf                 ID       State    VC Label  VC Label

101         Vlan10               --       up       8193      8192

# PE 2上也可以看到VC连接。

[PE2] display mpls l2vc

Total ldp vc : 1     1 up       0 down      0 blocked

 

Transport   Client               Service  VC       Local     Remote

VC ID       Intf                 ID       State    VC Label  VC Label

101         Vlan10               --       up       8192      8193

# CE 1CE 2之间能够ping通。

[CE1] ping 100.1.1.2

  PING 100.1.1.2: 56  data bytes, press CTRL_C to break

    Reply from 100.1.1.2: bytes=56 Sequence=1 ttl=255 time=30 ms

    Reply from 100.1.1.2: bytes=56 Sequence=2 ttl=255 time=60 ms

    Reply from 100.1.1.2: bytes=56 Sequence=3 ttl=255 time=50 ms

    Reply from 100.1.1.2: bytes=56 Sequence=4 ttl=255 time=40 ms

    Reply from 100.1.1.2: bytes=56 Sequence=5 ttl=255 time=70 ms

  --- 100.1.1.2 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 30/50/70 ms

1.12.4  配置Kompella方式MPLS L2VPN示例

1. 组网需求

·     PE通过VLAN接口连接CE

·     通过建立Kompella方式的VC连接,实现CE 1CE 2之间的二层报文跨越骨干网络传递。

2. 组网图

图1-11 配置Kompella方式MPLS L2VPN组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

Vlan-int10

100.1.1.1/24

CE 2

Vlan-int10

100.1.1.2/24

PE 1

Loop0

2.2.2.2/32

P

Loop0

3.3.3.3/32

 

Vlan-int20

10.1.1.1/24

 

Vlan-int20

10.1.1.2/24

PE 2

Loop0

4.4.4.4/32

 

Vlan-int30

10.2.2.2/24

 

Vlan-int30

10.2.2.1/24

 

 

 

 

3. 配置步骤

(1)     MPLS骨干网上配置IGP

本例中使用OSPF,具体配置步骤略。

配置完成后,在各LSR上执行display ip routing-table命令可以看到都已学到彼此LSR ID的路由;执行display ospf peer命令可以建立了OSPF邻居关系,状态为FULL

(2)     配置MPLS基本能力和LDP,建立LDP LSP

具体配置步骤略。

配置完成后,在各LSR上执行display mpls ldp sessiondisplay mpls ldp peer命令可以看到LDP会话和对等体的建立情况,执行display mpls lsp命令可以看到LSP的建立情况。

(3)     配置BGPL2VPN能力

# 配置PE 1

<Sysname> system-view

[Sysname] sysname PE1

[PE1] l2vpn

[PE1-l2vpn] mpls l2vpn

[PE1-l2vpn] quit

[PE1] bgp 100

[PE1-bgp] peer 4.4.4.4 as-number 100

[PE1-bgp] peer 4.4.4.4 connect-interface loopback 0

[PE1-bgp] l2vpn-family

[PE1-bgp-af-l2vpn] policy vpn-target

[PE1-bgp-af-l2vpn] peer 4.4.4.4 enable

[PE1-bgp-af-l2vpn] quit

[PE1-bgp] quit

# 配置PE 2

<Sysname> system-view

[Sysname] sysname PE2

[PE2] l2vpn

[PE2-l2vpn] mpls l2vpn

[PE2-l2vpn] quit

[PE2] bgp 100

[PE2-bgp] peer 2.2.2.2 as-number 100

[PE2-bgp] peer 2.2.2.2 connect-interface loopback 0

[PE2-bgp] l2vpn-family

[PE2-bgp-af-l2vpn] policy vpn-target

[PE2-bgp-af-l2vpn] peer 2.2.2.2 enable

[PE2-bgp-af-l2vpn] quit

[PE2-bgp] quit

# 配置完成后,在PE 1PE 2上执行display bgp l2vpn peer命令可以看到PE之间建立了对等体关系,状态为Established

PE 1为例:

[PE1] display bgp l2vpn peer

BGP local router ID : 2.2.2.2

 Local AS number : 100

 Total number of peers : 1                 Peers in established state : 1

  Peer      V   AS   MsgRcvd   MsgSent  OutQ PrefRcv Up/Down  State

  4.4.4.4   4   100        2        5     0       0  00:01:07 Established

(4)     配置L2VPNCE连接

# 配置PE 1

[PE1] mpls l2vpn vpn1 encapsulation vlan

[PE1-mpls-l2vpn-vpn1] route-distinguisher 100:1

[PE1-mpls-l2vpn-vpn1] vpn-target 1:1

[PE1-mpls-l2vpn-vpn1] ce ce1 id 1 range 10

[PE1-mpls-l2vpn-ce-vpn1-ce1] connection ce-offset 2 interface Vlan-interface10

[PE1-mpls-l2vpn-ce-vpn1-ce1] quit

[PE1-mpls-l2vpn-vpn1] quit

# 配置PE 2

[PE2] mpls l2vpn vpn1 encapsulation vlan

[PE2-mpls-l2vpn-vpn1] route-distinguisher 100:1

[PE2-mpls-l2vpn-vpn1] vpn-target 1:1

[PE2-mpls-l2vpn-vpn1] ce ce2 id 2 range 10

[PE2-mpls-l2vpn-ce-vpn1-ce2] connection ce-offset 1 interface vlan-interface 10

[PE2-mpls-l2vpn-ce-vpn1-ce2] quit

[PE2-mpls-l2vpn-vpn1] quit

4. 验证配置

# 完成上述配置后,在PE上执行display mpls l2vpn connection命令,可以看到建立了一条VC连接,状态为up

PE 1为例:

[PE1] display mpls l2vpn connection

1 total connections,

connections: 1 up, 0 down, 0 local, 1 remote, 0 unknown

VPN name: vpn1,

1 total connections,

connections: 1 up, 0 down, 0 local, 1 remote, 0 unknown

  CE name: ce1, id: 1,

  Rid type status peer-id         route-distinguisher   intf

  2   rmt  up     4.4.4.4         100:1                 Vlan10

# CE 1CE 2之间能够ping通。

[CE1] ping 100.1.1.2

  PING 100.1.1.2: 56  data bytes, press CTRL_C to break

    Reply from 100.1.1.2: bytes=56 Sequence=1 ttl=255 time=90 ms

    Reply from 100.1.1.2: bytes=56 Sequence=2 ttl=255 time=77 ms

    Reply from 100.1.1.2: bytes=56 Sequence=3 ttl=255 time=34 ms

    Reply from 100.1.1.2: bytes=56 Sequence=4 ttl=255 time=46 ms

    Reply from 100.1.1.2: bytes=56 Sequence=5 ttl=255 time=94 ms

  --- 100.1.1.2 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 34/68/94 ms

1.12.5  配置在服务实例上创建VC连接示例

1. 组网需求

·     CE 1CE 2分别通过VLAN方式接入PE 1PE 2

·     PE 1PE 2在服务实例上为CE 1CE 2创建VC连接,实现CE 1CE 2之间的二层报文跨越骨干网络传递。

2. 组网图

图1-12 配置在服务实例上创建VC连接组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

Vlan-int10

100.1.1.1/24

CE 2

Vlan-int10

100.1.1.2/24

PE 1

Loop0

192.2.2.2/32

P

Loop0

192.4.4.4/32

 

Vlan-int23

23.1.1.1/24

 

Vlan-int23

23.1.1.2/24

PE 2

Loop0

192.3.3.3/32

 

Vlan-int26

26.2.2.2/24

 

Vlan-int26

26.2.2.1/24

 

 

 

 

3. 配置步骤

(1)     配置CE 1

# 为连接PE 1的接口Vlan-interface10配置IP地址。

<Sysname> system-view

[Sysname] sysname CE1

[CE1] interface vlan-interface 10

[CE1-Vlan-interface10] ip address 100.1.1.1 24

(2)     配置PE 1

<Sysname> system-view

[Sysname] sysname PE1

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.2.2.2 32

[PE1-LoopBack0] quit

# 配置LSR ID,全局使能MPLS

[PE1] mpls lsr-id 192.2.2.2

[PE1] mpls

[PE1-mpls] quit

# 使能L2VPNMPLS L2VPN

[PE1] l2vpn

[PE1-l2vpn] mpls l2vpn

[PE1-l2vpn] quit

# 全局使能LDP

[PE1] mpls ldp

[PE1-mpls-ldp] quit

# 配置PE 1PE 2建立LDP远程会话。

[PE1] mpls ldp remote-peer 1

[PE1-mpls-ldp-remote-1] remote-ip 192.3.3.3

[PE1-mpls-ldp-remote-1] quit

# 配置连接P的接口Vlan-interface23,在此接口上使能LDP

[PE1] interface vlan-interface 23

[PE1-Vlan-interface23] ip address 23.1.1.1 24

[PE1-Vlan-interface23] mpls

[PE1-Vlan-interface23] mpls ldp

[PE1-Vlan-interface23] quit

# PE 1上运行OSPF用于建立LSP

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 23.1.1.1 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 在接入CE 1的接口GigabitEthernet1/0/1上创建服务实例,并创建VC连接。

[PE1] interface gigabitethernet1/0/1

[PE1-GigabitEthernet1/0/1] port access vlan 10

[PE1-GigabitEthernet1/0/1] service-instance 1000

[PE1-GigabitEthernet1/0/1-srv1000] encapsulation s-vid 10

[PE1-GigabitEthernet1/0/1-srv1000] xconnect peer 192.3.3.3 pw-id 1000

[PE1-GigabitEthernet1/0/1-srv1000] quit

[PE1-GigabitEthernet1/0/1] quit

(3)     配置P

<Sysname> system-view

[Sysname] sysname P

[P] interface loopback 0

[P-LoopBack0] ip address 192.4.4.4 32

[P-LoopBack0] quit

# 配置LSR ID,全局使能MPLS

[P] mpls lsr-id 192.4.4.4

[P] mpls

[P-mpls] quit

# 全局使能LDP

[P] mpls ldp

[P-mpls-ldp] quit

# 配置连接PE 1的接口Vlan-interface23在此接口上使能LDP

[P] interface vlan-interface 23

[P-Vlan-interface23] ip address 23.1.1.2 24

[P-Vlan-interface23] mpls

[P-Vlan-interface23] mpls ldp

[P-Vlan-interface23] quit

# 配置连接PE 2的接口Vlan-interface26在此接口上使能LDP

[P] interface vlan-interface 26

[P-Vlan-interface26] ip address 26.2.2.2 24

[P-Vlan-interface26] mpls

[P-Vlan-interface26] mpls ldp

[P-Vlan-interface26] quit

# P上运行OSPF用于建立LSP

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 23.1.1.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 26.2.2.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

(4)     配置PE 2

<Sysname> system-view

[Sysname] sysname PE2

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.3.3.3 32

[PE2-LoopBack0] quit

# 配置LSR ID,全局使能MPLS

[PE2] mpls lsr-id 192.3.3.3

[PE2] mpls

[PE2-mpls] quit

# 使能L2VPNMPLS L2VPN

[PE2] l2vpn

[PE2-l2vpn] mpls l2vpn

[PE2-l2vpn] quit

# 全局使能LDP

[PE2] mpls ldp

[PE2-mpls-ldp] quit

# 配置PE 2PE 1建立LDP远程会话。

[PE2] mpls ldp remote-peer 2

[PE2-mpls-ldp-remote-2] remote-ip 192.2.2.2

[PE2-mpls-ldp-remote-2] quit

# 配置连接P的接口Vlan-interface26,在此接口上使能LDP

[PE2] interface vlan-interface 26

[PE2-Vlan-interface26] ip address 26.2.2.1 24

[PE2-Vlan-interface26] mpls

[PE2-Vlan-interface26] mpls ldp

[PE2-Vlan-interface26] quit

# PE 2上运行OSPF,用于建立LSP

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] network 26.2.2.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 在接入CE 2的接口GigabitEthernet1/0/1上创建服务实例,并创建VC连接。

[PE2] interface GigabitEthernet1/0/1

[PE2-GigabitEthernet1/0/1] port access vlan 10

[PE2-GigabitEthernet1/0/1] service-instance 1000

[PE2-GigabitEthernet1/0/1-srv1000] encapsulation s-vid 10

[PE2-GigabitEthernet1/0/1-srv1000] xconnect peer 192.2.2.2 pw-id 1000

[PE2-GigabitEthernet1/0/1-srv1000] quit

[PE2-GigabitEthernet1/0/1] quit

(5)     配置CE 2

# 为连接PE 2的接口Vlan-interface10配置IP地址。

<Sysname> system-view

[Sysname] sysname CE2

[CE2] interface vlan-interface 10

[CE2-Vlan-interface10] ip address 100.1.1.2 24

4. 验证配置

# PE 1上查看VC连接信息,可以看到建立了一条L2VC

[PE1] display mpls l2vc

Total ldp vc : 1     1 up       0 down      0 blocked

 

 

Transport   Client               Service  VC       Local     Remote

VC ID       Intf                 ID       State    VC Label  VC Label

1000        GE1/0/1               1000     up       8193      8192

# PE 2上也可以看到VC连接。

[PE2] display mpls l2vc

Total ldp vc : 1     1 up       0 down      0 blocked

 

 

Transport   Client               Service  VC       Local     Remote

VC ID       Intf                 ID       State    VC Label  VC Label

1000        GE1/0/1               1000     up       8192      8193

# CE 1CE 2之间能够ping通。

[CE1] ping 100.1.1.2

  PING 100.1.1.2: 56  data bytes, press CTRL_C to break

    Reply from 100.1.1.2: bytes=56 Sequence=1 ttl=255 time=90 ms

    Reply from 100.1.1.2: bytes=56 Sequence=2 ttl=255 time=77 ms

    Reply from 100.1.1.2: bytes=56 Sequence=3 ttl=255 time=34 ms

    Reply from 100.1.1.2: bytes=56 Sequence=4 ttl=255 time=46 ms

    Reply from 100.1.1.2: bytes=56 Sequence=5 ttl=255 time=94 ms

  --- 100.1.1.2 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 34/68/94 ms

1.13  常见配置错误举例

1.13.1  配置后不能Ping

1. 错误现象

L2VPN配置后,Ping对端失败。查看VC状态,发现VC状态为downRemote值为无效值。

2. 分析

VC状态为down可能是因为两端封装类型不一致。

3. 处理过程

(1)     查看本端和对端PE设备配置的封装类型是否一致,如果配置的封装类型不一样,请修改两端的封装类型。

(2)     检查两端是否已配置了远端对等体,并正确地将对端PE地址设置为远端对等体的地址。如果没有配置远端对等体或地址配置错误,请在两端均配置正确的远端对等体地址。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!