国家 / 地区

07 MPLS配置指导

04-VPLS配置

本章节下载  (523.07 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/CE3000/CE3000-EI/Configure/Operation_Manual/H3C_CE3000-32F-EI_CG-Release_18xx-6W100/07/201403/822409_30005_0.htm

04-VPLS配置


1 VPLS

1.1  VPLS简介

VPLS(Virtual Private LAN Service,虚拟专用局域网服务)是在公用网络中提供的一种点到多点的L2VPN业务。VPLS使地域上隔离的用户站点能通过MAN(Metropolitan Area Network,城域网)或WAN(Wide Area Network,广域网)相连,并且使各个站点间的连接效果像在一个LAN中一样。

VPLS也称TLS(Transparent LAN Service,透明局域网服务)或Virtual Private Switched Network Service(虚拟专有交换网络服务)。

VPLS提供二层VPN服务。在VPLS中,用户是由多点网络连接起来,不同于传统VPN提供的P2P(Point-to-Point,点到点)的连接服务。VPLS实际上就是在PE上创建一系列的虚拟交换机租借给用户,虚拟交换机的组网和传统交换机完全相同,这样,用户就可以通过MAN(Metropolitan Area Network,城域网)或WAN(Wide Area Network,广域网)来实现自己的LAN(Local Area Network,局域网)。

1.1.1  VPLS的工作机制

1. VPLS的基本概念

·     CE(Custom Edge)

直接与服务提供商相连的用户边缘设备。

·     PE(Provider Edge)

服务提供商网络上的边缘设备,与CE相连,主要负责VPN业务的接入。它完成报文从私网到公网隧道,并从公网隧道到私网的映射与转发。PE可以细分为UPE和NPE。

·     UPE(User facing-Provider Edge)

靠近用户侧的PE设备,主要作为用户接入VPN的汇聚设备。

·     NPE(Network Provider Edge)

网络核心PE设备,处于VPLS网络的核心域边缘,提供在核心网之间的VPLS透明传输服务。

·     VSI(Virtual Switch Instance)

虚拟交换实例,下文中简称为VPLS实例。通过VSI,可以将实际接入链路映射到各条虚链接上。

·     PW(Pseudo Wire)

虚链路,在两个VSI之间的一条双向的虚拟连接,它由一对单向的MPLS VC(Virtual Circuit,虚电路)构成。

·     服务实例(Service Instance)

服务实例在端口下创建,用来对通过该端口的报文进行识别和处理。PE设备通过服务实例对从CE收到的流量进行分类匹配,从而将具备不同特征的流量通过不同的PW进行转发。服务实例提供了多种报文匹配规则,为报文接入VPLS实例提供了更加灵活的方式。

·     AC(Attachment Circuit)

接入电路,原指连接CE与PE的链路,对应的接口可以是实际的物理接口,也可以是虚拟接口。AC上的所有用户报文一般都要求原封不动的转发到对端Site(站点)去,包括用户的二、三层协议报文。在VPLS环境中,CE与PE之间物理链路上的流量被PE通过服务实例区分为不同的VPN用户流量,因此,本文中的AC实际对应的是PE上的每一个服务实例。

·     QinQ(802.1Q in 802.1Q)

一种基于802.1Q封装的隧道协议,能够提供点到多点的L2VPN服务机制。它将用户私网VLAN Tag封装在公网VLAN Tag中,最终报文带着两层Tag穿越服务提供商的骨干网络,从而为用户提供一种较为简单的二层VPN隧道。

·     Forwarders

转发器,PE的一种。PE收到AC上送的数据帧,由转发器选定转发报文使用的PW,转发器事实上就是VPLS的转发表。

·     Tunnel

隧道,用于承载PW,一条隧道上可以承载多条PW,一般情况下为MPLS隧道。隧道是一条本地PE与对端PE之间的直连通道,完成PE之间的数据透明传输。

·     Encapsulation

封装,PW上传输的报文使用标准的PW封装格式和技术。PW上的VPLS报文封装有两种模式:Ethernet和VLAN模式。

·     PW Signaling

PW信令协议,VPLS实现的基础,用于创建和维护PW。PW信令协议还可用于自动发现VSI的对端PE设备。目前,PW信令协议主要有LDP和BGP。

图1-1为VPLS典型组网示意图,图中简单显示出以上所涉及的各基本概念。

图1-1 VPLS典型组网示意图

 

2. PW的创建

PW是VPLS在公网上的通信隧道,它建立在MPLS(包括LSP和CR-LSP)隧道之上。创建PW需要:

(1)     在本端和对端PE之间建立MPLS隧道。

(2)     确定对端PE的地址。对于同一个VSI内的PE设备,可以通过手工配置来指定对端PE地址,也可以通过信令协议(如BGP)自动发现对端PE。

(3)     在两端的PE设备上分别为PW分配多路复用分离标记(VC标签),并将分配的VC标签通告给对端PE,建立单向的VC。一对单向的VC建立成功后,它们组合起来形成双向的PW。

根据PW建立方式的不同,VPLS分为:

·     静态方式的VPLS:采用手工配置方式在两端的PE设备上指定VC标签。

·     LDP方式的VPLS:采用LDP作为信令协议为PW分发VC标签,该方式也称为Martini方式。

·     BGP方式的VPLS:采用BGP扩展作为信令协议为PW分发VC标签,该方式也称为Kompella方式。

说明

有关Martini方式和Kompella方式的介绍请参见“MPLS配置指导”中的“MPLS L2VPN”。

 

3. MAC地址学习与泛洪

VPLS通过MAC地址学习来提供可达性。每个PE设备会维护一张MAC地址表。

(1)     源MAC地址学习

MAC地址学习过程包含两部分:

·     与PW关联的远程MAC地址学习

PW是由一对单向的VC LSP组成(只有两个方向的VC LSP都up才被认为PW是up的)。当在入方向的VC LSP上学习到一个原来未知的MAC地址后,需要PW将此MAC地址与出方向的VC LSP形成映射关系。

·     与用户直接相连端口的本地MAC地址学习

对于CE上传送的报文,需要将报文中的源MAC地址学习到VSI的对应端口上。

PE的MAC地址学习与泛洪过程如图1-2所示。

图1-2 PE的MAC地址学习与泛洪过程

 

(2)     MAC地址回收

动态学习到的MAC地址必须有刷新和重学习的机制。在VPLS相关草案中提供一种动态学习的方法,即使用地址回收消息。地址回收消息中携带MAC TLV,收到这个消息的设备根据TLV中指定的参数进行MAC地址的删除或者重新学习这些MAC地址。如果TLV中指定的MAC地址为NULL,则删除此VSI下所有MAC地址,但不删除收到这个消息的PW上学习到的MAC地址。

在拓扑结构改变时为了能快速移除MAC地址,可以使用地址回收消息。地址回收消息分为两类:带有MAC地址列表的和不带MAC地址列表的。

如果在一条备份链路变为活动状态后,收到带有重学习MAC表项的通知消息,PE将更新VPLS实例的FIB表中对应的MAC表项,并将此消息发送给其他相关的LDP会话直连的PE。如果通知消息中包含空的MAC地址TLV列表,表示告知PE移除指定VSI中的所有MAC地址(从发送此消息的PE处学习到的MAC地址除外)。

(3)     MAC地址老化

PE学习到的与VC标签相关但是不再使用的远程MAC地址需要有老化机制来移除。老化机制使用了MAC地址对应的老化定时器。在接收到报文并处理时,根据报文中的源MAC地址,如果这个源地址启动了相应的老化定时器,则PE重置该老化定时器。

4. VPLS的环路避免

为了避免环路,一般的二层网络都要求使能STP(Spanning Tree Protocol,生成树协议)。但是对使用VPLS的用户来说,不会感知到ISP的网络,因此在私网侧使能STP的时候,不能把ISP的网络考虑进来。VPLS中,使用全连接和水平分割转发来避免在ISP上使用VPLS私网侧的STP协议。

VPLS环路避免的方法如下:

·     PE之间逻辑上全连接(PW全连接),也就是每个PE必须为每一个VPLS转发实例创建一棵到该实例下的所有其他PE的树。

·     每个PE设备必须支持水平分割策略来避免环路,即PE不能在具有相同VSI的PW之间转发报文(由于在同一个VSI中每个PE直连),也就是说,从公网侧PW收到的数据包不再转发到其他PW上,只能转发到私网侧。

1.1.2  VPLS报文封装

1. AC上的报文封装

AC上的报文封装方式由用户的VSI接入方式决定。用户接入方式可以分为两种:VLAN接入和Ethernet接入。其含义如下:

·     VLAN接入:CE发送给PE或PE发送给CE的以太网帧头带有一个VLAN Tag,该Tag是一个服务提供商网络为了区分用户而要求用户压入的“服务定界符”。我们把这个作为服务定界符的Tag称为P-Tag。

·     Ethernet接入:CE发送给PE或PE发送给CE的以太网帧头中没有服务定界符,如果此时帧头中有VLAN Tag,则说明它只是用户报文的内部VLAN Tag,对于PE设备没有意义。这种用户内部VLAN的Tag称为U-Tag。

至于用户的VSI接入方式,可以使用配置的方式来指定。

2. PW上的报文封装

PW上的报文封装方式也可以分为两种:Ethernet模式和VLAN模式。

·     Ethernet模式下,P-Tag不在PW上传输:对于CE侧的报文,如果收到带有服务定界符的报文,则将其去除后再压入PW标签和隧道标签后转发;如果收到不带服务定界符的报文,则直接压入PW标签和隧道标签后转发。对于PE侧的下行报文,根据实际配置选择添加或不添加服务定界符后转发给CE,但是它不允许重写或移除已经存在的任何Tag。

·     VLAN模式下,PW上传输的帧必须带P-Tag:对于CE侧的报文,如果收到带有服务界定符的报文,保留P-Tag,或者将P-Tag改写为对端PE期望的VLAN Tag或者空Tag(Tag值为0),再压入PW标签和隧道标签后转发;如果收到不带服务界定符的报文,则添加一个对端PE期望的VLAN Tag或空Tag后,再压入PW标签和隧道标签后转发。对于PE侧的下行报文,根据实际配置选择重写、去除或保留服务界定符后转发给CE。

根据协议规定,缺省情况下PW使用VLAN模式对报文进行封装。

1.1.3  H-VPLS实现方式

H-VPLS(Hierarchy of VPLS,分层VPLS),延伸服务提供商的VPLS接入范围和降低成本。

1. H-VPLS接入的优点

·     H-VPLS对MTU-s((Multi-Tenant Unit switch,汇聚设备)的要求比较低,层次鲜明,分工明确。

·     H-VPLS能够减少PE全连接带来的逻辑复杂度和配置管理的复杂度。

2. H-VPLS的两种接入方式

·     H-VPLSLSP方式接入

图1-3 H-VPLSLSP方式接入

 

图1-3所示,UPE作为汇聚设备MTU-s,它只跟NPE1建立一条虚链接接入链路U-PW,跟其他所有的对端都不建立虚链接。

数据转发流程如下:

(1)     UPE负责将CE上送的报文发给NPE1,同时打上U-PW对应的多路复用分离标记(MPLS标签);

(2)     NPE1收到报文后,先根据多路复用分离标记判断报文所属的VSI,再根据该报文的目的MAC压入N-PW对应的多路复用分离标记,然后转发该报文;

(3)     NPE1从N-PW侧收到报文后,打上U-PW对应的多路复用分离标记将报文发送给UPE,UPE再将报文转发给CE。

如果CE1与CE2之间的数据交换为本地CE之间交换,由于UPE本身具有桥接功能,UPE将直接完成两者间的报文转发,而无需将报文上送给NPE1。不过对于目的MAC未知的第一个数据报文或广播报文,UPE在将数据通过桥广播到CE2的同时,仍然会通过U-PW转发给NPE1,由NPE1来完成报文的复制并转发到各个对端CE。

·     H-VPLSQinQ方式接入

图1-4 H-VPLSQinQ方式接入

 

图1-4所示,MTU为标准的桥接设备,数据转发流程如下:

(1)     在CE接入端口使能QinQ,为收到的报文添加压入VLAN Tag作为多路复用分离标记,在MTU与PE1之间通过QinQ隧道将报文透明传输到PE1上;

(2)     PE1先根据报文携带MTU压入的VLAN Tag判断所属的VSI,再根据该报文的目的MAC为其压入PW对应的多路复用分离标记(MPLS标签),然后将其转发;

(3)     PE1从PW侧收到报文后,根据多路复用分离标记(MPLS标签)判断报文所属的VSI,再根据用户报文的目的MAC打上VLAN Tag通过QinQ隧道将报文转发给MTU,由MTU将报文转发给CE。

如果CE1与CE2之间的数据交换为本地CE之间交换,由于MTU本身具有桥接功能,MTU将直接完成两者间的报文转发,而无需将报文上送给PE1。不过对于目的MAC未知的第一个数据报文或广播报文,MTU在通过桥广播到CE2的同时,仍然会通过QinQ隧道转发给PE1,由PE1来完成报文的复制并转发到各个对端CE。

3. 主备PW切换

UPE与NPE之间只有单条链路连接的方案具有明显的弱点:一旦该接入链路出现故障,汇聚设备连接的所有VPN都将丧失连通性。如图1-5所示,LSP接入方式的H-VPLS提供了链路冗余备份方案。在正常情况下,设备只使用一条链路(主链路)接入。当主链路出现故障时,将启用备用链路继续提供VPN业务。

图1-5 LSP接入方式的冗余保护

 

LSP接入方式的H-VPLS根据LDP会话状态和BFD检测结果等判断主链路是否失效。在以下情况下,将启用备份链路:

·     主PW经过的隧道被删除,导致此PW的状态变为down

·     利用BFD协议等链路检测机制,检测到主链路故障;

·     主PW对应的对等体间LDP会话down导致该PW删除。

1.1.4  Hub-Spoke实现方式

Hub-Spoke是VPLS的一种组网应用方式。在这种组网方式下,存在一个中心节点(Hub站点)和多个接入节点(Spoke站点)。VPLS的Hub-Spoke组网中,Spoke-CE站点之间的数据必须通过Hub-CE站点进行交换,而不允许各个Spoke-CE站点之间直接进行数据交换。与中心站点或者接入站点相连的PE设备相应称作Hub-PE或者Spoke-PE。

1. Hub-Spoke组网接入的优点

Hub-Spoke组网方式下所有接入站点之间的数据流量都需要通过中心站点,便于中心站点对数据流量的统一管理。

2. Hub-Spoke组网方式

图1-6 Hub-Spoke组网图

 

典型的Hub-Spoke组网如图1-6所示。Hub-Spoke组网中MAC地址学习过程与普通组网相同,此处不再赘述。MAC地址学习完成后,数据转发流程如下:

(1)     Spoke-PE 1接收到接入站点Spoke-CE 1发送的数据报文后,根据所属的VSI,为报文压入多路复用分离标记(MPLS标签)然后转发给指定的Hub-PE;

(2)     Hub-PE从PW侧收到报文后,根据多路复用分离标记(MPLS标签)判断报文所属的VSI,将报文直接转发给Hub-CE;

(3)     Hub-CE具有二层转发功能,将报文处理后重新转发给Hub-PE;

(4)     Hub-PE从AC侧收到报文后,根据VLAN Tag判断所属的VSI,再根据该报文的目的MAC为其压入PW对应的多路复用分离标记(MPLS标签),然后将其转发给Spoke-PE 2;

(5)     Spoke-PE从PW侧收到报文后,根据多路复用分离标记(MPLS标签)判断报文所属的VSI,将报文转发给对应的Spoke-CE 2。

1.2  VPLS配置任务简介

表1-1 VPLS配置任务简介

配置任务

说明

详细配置

使能L2VPN和MPLS L2VPN

必选

1.3 

配置静态方式的VPLS

根据实际组网情况,选择一种方式的VPLS

1.4 

配置LDP方式的VPLS

1.5 

配置BGP方式的VPLS

1.6 

绑定VPLS实例

必选

1.7 

配置VPLS的流量监管功能

可选

1.8 

配置VPLS统计功能

可选

1.9 

配置MAC地址学习功能

可选

1.10 

配置VPLS实例的属性

可选

1.11 

检测PW

可选

1.12 

 

1.3  使能L2VPN和MPLS L2VPN

只有使能了L2VPN和MPLS L2VPN,才允许进行VPLS相关配置。

表1-2 使能L2VPN和MPLS L2VPN

操作

命令

说明

进入系统视图

system-view

-

使能L2VPN,并进入L2VPN视图

l2vpn

必选

使能MPLS L2VPN

mpls l2vpn

必选

 

说明

l2vpnmpls l2vpn命令的详细介绍请参见“MPLS命令参考”中的“MPLS L2VPN”。

 

1.4  配置静态方式的VPLS

1.4.1  配置准备

·     在MPLS骨干网设备(PE、P)上配置IGP,实现骨干网的IP连通性。具体配置方法请参见“三层技术-IP路由配置指导”。

·     在MPLS骨干网设备(PE、P)上配置MPLS基本能力,用于创建公网的LSP隧道。具体配置方法请参见“MPLS配置指导”中的“MPLS基础”。

1.4.2  配置静态方式的VPLS实例

在创建静态方式的VPLS实例时,需要进行以下配置:

(1)     指定全局唯一的VPLS实例名,并指明对端发现机制是静态手工配置。

(2)     指明所使用的PW信令协议为static

(3)     通过peer命令创建一个实例中包含的VPLS对端PE,并指定:

·     对端PE的IP地址。

·     到对端PE的PW的ID,该PW ID必须与对端PE上的配置保持一致。

·     对等体类型。如果指定对等体类型为upe,则表示该对等体为分层VPLS模型中的用户汇聚节点UPE;如果创建对等体时指定了backup-peer参数,则表示在UPE上创建了一对主备NPE。汇聚节点UPE上只允许用户配置一对主备NPE。指定的多个远程对等体NPE间需要全连接,UPE与NPE之间无需全连接。

·     引用的PW模板。通过引用PW模板,可以指定PW传输模式和到达对端的隧道使用的隧道选用策略。

(4)     指定本端VC标签和远端VC标签。

表1-3 配置静态方式的VPLS实例

操作

命令

说明

进入系统视图

system-view

-

创建PW模板,并进入PW模板视图

pw-class pw-class-name

可选

缺省情况下,不存在任何PW模板

配置PW传输模式

trans-mode { ethernet | vlan }

可选

缺省情况下,PW传输模式为VLAN

配置隧道选用策略

pw-tunnel-policy policy-name

可选

缺省情况下,采用VSI视图下,通过tnl-policy命令指定的隧道策略

隧道策略的配置方法,请参见“MPLS配置指导”中的“MPLS L3VPN”

退回系统视图

quit

-

创建静态方式的VPLS实例,并进入VSI视图

vsi vsi-name static [ hub-spoke ]

必选

缺省情况下,设备上不存在任何VPLS实例

指定使用的PW信令协议为static,并进入VSI-Static视图

pwsignal static

必选

创建一个实例中包含的VPLS对端PE,并进入L2VPN peer视图

peer ip-address [ { hub | spoke } | pw-class class-name | [ pw-id pw-id ] [ upe | backup-peer ip-address [ backup-pw-id pw-id ] ] ] *

必选

如果没有通过vsi-id命令指定VPLS实例的ID号,则执行peer命令时,必须通过pw-id参数指定PW ID

配置主VC的VC标签

static label local local-vc remote remote-vc

必选

缺省情况下,没有指定主VC的VC标签

配置备份VC的VC标签

static backup-label local local-vc remote remote-vc

可选

缺省情况下,没有指定备份VC的VC标签

退回VSI-Static视图

quit

-

开启主备PW的回切功能,并指定回切时间

dual-npe revertive [ wtr-time wtr-time ]

可选

缺省情况下,主备切换后不进行回切

 

1.5  配置LDP方式的VPLS

1.5.1  配置准备

·     在MPLS骨干网设备(PE、P)上配置IGP,实现骨干网的IP连通性。具体配置方法请参见“三层技术-IP路由配置指导”。

·     在MPLS骨干网设备(PE、P)上配置MPLS基本能力,用于创建公网的LSP隧道。具体配置方法请参见“MPLS配置指导”中的“MPLS基础”。

·     在PE设备上配置LDP远端对等体,用于建立远端LDP会话。具体配置方法请参见“MPLS配置指导”中的“MPLS基础”。

1.5.2  配置LDP方式的VPLS实例

在创建LDP方式的VPLS实例时,需要进行以下配置:

(1)     指定全局唯一的VPLS实例名,并指明对端发现机制是静态手工配置。

(2)     指明所使用的PW信令协议为LDP。

(3)     指定VPLS实例的ID号。

(4)     通过peer命令创建一个实例中包含的VPLS对端PE,并指定:

·     对端PE的IP地址。

·     到对端PE的PW的ID,该PW ID必须与对端PE上的配置保持一致。

·     对等体类型。如果指定对等体类型为UPE,则表示该对等体为分层VPLS模型中的用户汇聚节点UPE;如果创建对等体时指定了backup-peer参数,则表示在UPE上创建了一对主备NPE。汇聚节点UPE上只允许用户配置一对主备NPE。指定的多个远程对等体NPE间需要全连接,UPE与NPE之间无需全连接。

·     引用的PW模板。通过引用PW模板,可以指定PW传输模式和到达对端的隧道使用的隧道选用策略。

表1-4 配置LDP方式的VPLS实例

操作

命令

说明

进入系统视图

system-view

-

创建PW模板,并进入PW模板视图

pw-class pw-class-name

可选

缺省情况下,不存在任何PW模板

配置PW传输模式

trans-mode { ethernet | vlan }

可选

缺省情况下,PW传输模式为VLAN

配置隧道选用策略

pw-tunnel-policy policy-name

可选

缺省情况下,采用VSI视图下,通过tnl-policy命令指定的隧道策略

隧道策略的配置方法,请参见“MPLS配置指导”中的“MPLS L3VPN”

退回系统视图

quit

-

创建LDP方式的VPLS实例,并进入VSI视图

vsi vsi-name static [ hub-spoke ]

必选

配置使用的PW信令协议为LDP,并进入VSI-LDP视图

pwsignal ldp

必选

指定VPLS实例的ID号

vsi-id vsi-id

必选

创建一个实例中包含的VPLS对端PE,并进入L2VPN peer视图

peer ip-address [ { hub | spoke } | pw-class class-name | [ pw-id pw-id ] [ upe | backup-peer ip-address [ backup-pw-id pw-id ] ] ] *

必选

退回VSI-LDP视图

quit

-

配置VPLS实例的主备PW回切时间

dual-npe revertive [ wtr-time wtr-time ]

可选

缺省情况下,主备切换后不进行回切

 

1.6  配置BGP方式的VPLS

1.6.1  配置准备

·     在MPLS骨干网设备(PE、P)上配置IGP,实现骨干网的IP连通性。具体配置方法请参见“三层技术-IP路由配置指导”。

·     在MPLS骨干网设备(PE、P)上配置MPLS基本能力,用于创建公网的LSP隧道。具体配置方法请参见“MPLS配置指导”中的“MPLS基础”。

1.6.2  配置BGP扩展

配置BGP方式的VPLS之前,需要在PE上配置BGP参数。具体配置方法请参见“三层技术-IP路由配置指导”中的“BGP”。

表1-5 配置BGP扩展

操作

命令

说明

进入系统视图

system-view

-

进入BGP视图

bgp as-number

-

进入BGP-VPLS地址族视图

vpls-family

必选

激活指定对等体

peer peer-address enable

必选

缺省情况下,无激活的对等体

 

说明

有关BGP-VPLS地址族下的配置请参见“MPLS配置指导”中的“MPLS L3VPN”。

 

1.6.3  配置BGP方式的VPLS实例

在创建BGP方式的VPLS实例时,必须指定全局唯一VPLS实例名,并指明对端发现机制是自动配置。

在配置BGP方式的VPLS实例时,需要指明所使用的PW信令协议为BGP。

表1-6 配置BGP方式的VPLS实例

操作

命令

说明

进入系统视图

system-view

-

创建BGP方式的VPLS实例,并进入VSI视图

vsi vsi-name auto

必选

配置使用的PW信令协议为BGP,并进入VSI-BGP视图

pwsignal bgp

必选

配置VPLS实例的RD

route-distinguisher route-distinguisher

必选

将一个指定VPLS实例和一个或多个VPN Target相关联

vpn-target vpn-target&<1-16> [ both | import-extcommunity | export-extcommunity ]

必选

创建VPLS实例的站点

site site-id [ range site-range ] [ default-offset { 0 | 1 } ]

必选

 

1.6.4  复位VPLS的BGP连接

当BGP路由策略或协议发生变化后,如果需要通过复位VPLS的BGP连接,使新的配置生效,请在用户视图下进行以下配置。

表1-7 复位VPLS的BGP连接

字段

描述

复位VPLS的BGP连接

reset bgp vpls { as-number | ip-address | all | external | internal }

 

1.7  绑定VPLS实例

配置服务实例与VPLS实例绑定后,设备根据二层以太网接口或二层聚合接口上创建的服务实例对该接口接收到的报文进行匹配,与服务实例匹配的报文将通过绑定的VPLS实例转发。服务实例提供了多种报文匹配规则(包括接口接收到的所有报文、所有携带VLAN Tag的报文和所有不携带VLAN Tag的报文等),为报文接入VPLS实例提供了更加灵活的方式。VLAN接口连接的用户属于不同的VPN时,可以采用此方式。

1.7.1  配置服务实例与VPLS实例绑定

配置服务实例与VPLS实例绑定,需要在二层以太网接口或二层聚合接口上创建服务实例,为服务实例配置报文匹配规则,并与一个VPLS实例建立绑定关系。这样,接口收到的符合匹配规则的报文,将进入绑定好的VPLS实例进行转发。

表1-8 配置服务实例与VPLS实例绑定

操作

命令

说明

进入系统视图

system-view

-

进入连接CE的二层以太网接口或二层聚合接口视图

进入二层以太网接口视图

interface interface-type interface-number

-

进入二层聚合接口视图

interface bridge-aggregation interface-number

创建服务实例,并进入服务实例视图

service-instance service-instance-id

必选

缺省情况下,不存在任何服务实例

配置报文匹配规则

encapsulation { s-vid vlan-id [ only-tagged ] | port-based | tagged | untagged }

必选

缺省情况下,不存在任何报文匹配规则

将指定接口下的服务实例与VPLS实例进行关联

xconnect vsi vsi-name [ access-mode { ethernet | vlan } | { hub | spoke } ] *

必选

缺省情况下,服务实例没有与VPLS实例关联

 

说明

只有使能了VPLS实例的Hub-Spoke能力(执行vsi static命令时携带了hub-spoke关键字)后,才可以进一步指定接入方式为Hub方式或者Spoke方式,缺省的接入方式为Spoke。如果没有使能VPLS实例的Hub-Spoke能力(执行vsi static命令时没有携带hub-spoke关键字),则不能指定接入方式。

 

1.8  配置VPLS的流量监管功能

1.8.1  配置准备

流量监管是指通过限定报文的接收或发送速率,来避免网络拥塞。在配置VPLS的流量监管功能之前,需要先通过系统视图下的qos car命令配置全局CAR(Committed Access Rate,承诺访问速率)的参数。关于流量监管功能和全局CAR的详细介绍,请参见“ACL和QoS配置指导”中的“流量监管、流量整形和端口限速”和“全局CAR”部分。

1.8.2  配置对PW上的流量进行监管

说明

目前,只有静态方式和LDP方式的VPLS支持对PW上的流量进行监管。

 

对PW上的流量进行监管是通过在L2VPN peer视图下应用全局CAR的方式实现的。在应用全局CAR后,当本地PE与指定对端PE之间的PW上存在流量时,设备将根据应用的全局CAR对PW上入方向的流量进行监管,限定报文的接收速率,从而避免网络拥塞。

表1-9 配置对PW上的流量进行监管

操作

命令

说明

进入系统视图

system-view

-

进入VSI视图

vsi vsi-name

-

进入VSI-LDP视图

pwsignal ldp

-

进入L2VPN peer视图

peer ip-address

-

配置在PW入方向上应用全局CAR

qos car inbound  name car-name

必选

缺省情况下,没有在PW上应用全局CAR进行

 

1.8.3  配置对AC上的流量进行监管

在将服务实例与VPLS实例进行绑定后,可以通过执行以下配置,在服务实例视图下应用全局CAR,以实现对AC上的流量进行监管。

在服务实例视图下应用全局CAR后,当接口接收到符合该服务实例匹配规则的报文时,设备将根据应用的全局CAR对AC入方向的流量进行监管。

表1-10 配置对AC上的流量进行监管

操作

命令

说明

进入系统视图

system-view

-

进入连接CE的二层以太网接口或二层聚合接口视图

进入二层以太网接口视图

interface interface-type interface-number

-

进入二层聚合接口视图

interface bridge-aggregation interface-number

进入服务实例视图

service-instance instance-id

-

配置在AC入方向上应用全局CAR

car inbound  name car-name

必选

缺省情况下,没有在AC上应用全局CAR

 

1.9  配置VPLS的流量统计功能

1.9.1  配置对PW上的流量进行统计

说明

目前,只有静态方式和LDP方式的VPLS支持对PW上的流量进行统计。

 

在L2VPN peer视图下使能PW的统计功能后,设备将对本地PE和指定对端PE之间的PW进行流量统计。

在使能PW统计功能后,还需要在MPLS视图下通过statistics interval命令配置获取统计数据的时间间隔,才能够通过display mpls statistics pw命令查看统计信息。statistics interval命令的详细介绍,请参见“MPLS命令参考”中的“MPLS基础”。

表1-11 配置对PW上的流量进行统计

操作

命令

说明

进入系统视图

system-view

-

进入VSI视图

vsi vsi-name

-

进入VSI-LDP视图

pwsignal ldp

-

进入L2VPN peer视图

peer ip-address

-

使能PW的统计功能

statistics enable

必选

缺省情况下,本端与对端PE之间PW的统计功能处于关闭状态

 

1.9.2  配置对AC上的流量进行统计

在将服务实例与VPLS实例进行绑定后,可以通过执行以下配置,在服务实例视图下使能AC的流量统计功能,以实现对AC入方向或出方向的流量进行统计。

AC上的流量统计信息可以通过display mpls l2vpn fib ac vpls命令查看。

表1-12 配置对AC上的流量进行统计

操作

命令

说明

进入系统视图

system-view

-

进入连接CE的二层以太网接口或二层聚合接口视图

进入二层以太网接口视图

interface interface-type interface-number

-

进入二层聚合接口视图

interface bridge-aggregation interface-number

进入服务实例视图

service-instance instance-id

-

使能AC入方向或出方向流量的统计功能

statistics { inbound | outbound }

必选

缺省情况下,AC的流量统计功能处于关闭状态

 

1.10  配置MAC地址学习功能

操作

命令

说明

进入系统视图

system-view

-

进入VSI视图

vsi vsi-name

-

开启或关闭MAC地址学习功能

mac-learning { enable | disable }

可选

缺省情况下,MAC地址学习功能是开启状态

配置VPLS实例可以学习的最大MAC地址数

mac-table limit mac-limit-number

可选

缺省情况下,VPLS实例可以学习到的最大MAC地址数目为524288

使能MAC地址迁移功能,即允许随着报文入接口的变化而改变MAC地址表项中的入接口

mac-move enable

可选

缺省情况下,MAC地址迁移功能处于使能状态

 

1.11  配置VPLS实例的属性

表1-13 配置VPLS实例的属性

操作

命令

说明

进入系统视图

system-view

-

进入VSI视图

vsi vsi-name

-

设置指定VPLS实例的封装类型

encapsulation { bgp-vpls | ethernet | vlan }

可选

缺省情况下,VPLS实例的封装类型为vlan,对应VSI的PW封装类型为Tagged模式

设置指定VPLS实例的MTU(最大传输单元)值

mtu mtu

可选

缺省情况下,VPLS实例的MTU值为1500字节

配置VPLS实例的MTU值仅用于VPLS两端PE间的链路协商,在数据转发过程中,本设备不会将数据按用户配置的MTU进行分片

设置指定VPLS实例的描述信息

description text

可选

缺省情况下,不设置VPLS实例的描述信息

关闭指定VPLS实例的VPLS服务

shutdown

可选

缺省情况下,VPLS实例的VPLS服务是开启状态

配置指定VPLS实例的隧道策略

tnl-policy tunnel-policy-name

可选

缺省情况下,未指定VPLS实例选用的隧道策略,采用缺省的隧道策略,即按照LSP隧道-> CR-LSP隧道的优先级顺序选择隧道,负载分担条数为1

隧道策略的配置方法,请参见“MPLS配置指导”中的“MPLS L3VPN”

 

1.12  检测PW

在VPLS网络中,通过MPLS LSP Ping功能,可以对PW的可达性进行检测,并提供必要的诊断信息,以便对PW的故障进行定位。

MPLS LSP Ping功能采取的方法是:在本地PE设备上为MPLS Echo Request报文压入待检测的PW对应的标签,使得MPLS Echo Request报文沿着PW转发,本地PE设备根据收到的对端PE设备的应答报文,判断PW的可达性。

表1-14 利用MPLS LSP Ping功能检测PW

操作

命令

说明

通过MPLS LSP Ping检测PW的可达性

ping lsp [ -a source-ip | -c count | -exp exp-value | -h ttl-value | -m wait-time | -r reply-mode | -s packet-size | -t time-out | -v ] * pw ip-address pw-id pw-id

必选

可在任意视图下执行本命令

 

说明

MPLS LSP Ping只能用来检测LDP方式建立的PW的可达性。

 

1.13  VPLS显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后VPLS的运行情况,通过查看显示信息验证配置的效果。

在用户视图下执行reset命令可以清除VPLS实例的MAC地址表信息。

表1-15 VPLS显示和维护

字段

描述

显示BGP路由表中的VPLS信息

display bgp vpls { all | group [ group-name ] | peer [ [ ip-address ] verbose ] | route-distinguisher route-distinguisher [ site-id site-id [ label-offset label-offset ] ] } [ | { begin | exclude | include } regular-expression ]

显示VPLS实例的MAC地址表信息

display mac-address vsi [ vsi-name ] [ blackhole | dynamic | static ] [ count ] [ | { begin | exclude | include } regular-expression ]

显示VPLS连接信息

display vpls connection [ bgp | ldp | static | vsi vsi-name ] [ block | down | up ] [ verbose ] [ | { begin | exclude | include } regular-expression ]

显示VPLS实例的AC表项信息

display mpls l2vpn fib ac vpls [ vsi vsi-name | interface interface-type interface-number [ service-instance service-instanceid ] ] [ slot slot-number ] [ verbose ] [ | { begin | exclude | include } regular-expression ]

显示VPLS实例的PW表项信息

display mpls l2vpn fib pw vpls [ vsi vsi-name [ link link-id ] ] [ slot slot-number ] [ verbose ] [ | { begin | exclude | include } regular-expression ]

显示端口上指定服务实例的信息

display service-instance interface interface-type interface-number [ service-instance instance-id ] [ | { begin | exclude | include } regular-expression ]

显示VPLS实例的PW统计信息

display mpls statistics pw [ vsi vsi-name [ link link-id ] ] [ | { begin | exclude | include } regular-expression ]

显示VPLS实例的信息

display vsi [ vsi-name ] [ verbose ] [ | { begin | exclude | include } regular-expression ]

显示VPLS远程连接信息

display vsi remote { bgp | ldp } [ | { begin | exclude | include } regular-expression ]

显示PW模板的信息

display pw-class [ pw-class-name ] [ | { begin | exclude | include } regular-expression ]

清除指定VSI的MAC地址转发表

reset mac-address vsi [ vsi-name ]

清除VPLS实例的PW统计信息

reset mpls statistics pw [ vsi vsi-name [ link link-id ] ]

清除VPLS实例的AC统计信息

reset service-instance statistics [ interface interface-type interface-number [ service-instance instance-id [ inbound | outbound ] ] ]

 

1.14  VPLS典型配置举例

1.14.1  服务实例与VPLS实例绑定配置举例

1. 组网需求

·     CE 1、CE 2分别通过VLAN方式接入PE 1和PE 2。

·     配置VPLS实例aaa为LDP方式(Martini方式),bbb为BGP方式(Kompella方式),AS号为100。

·     PE 1和PE 2通过服务实例将报文与VPLS实例绑定:服务实例1000用来匹配接口GigabitEthernet1/0/1接收到的VLAN Tag为100的报文,并通过VPLS实例aaa转发;服务实例2000用来匹配接口GigabitEthernet1/0/1接收到的VLAN Tag为200的报文,并通过VPLS实例bbb转发。

2. 组网图

图1-7 服务实例与VPLS实例绑定配置举例组网图

 

3. 配置步骤

(1)     PE 1的配置

<Sysname> system-view

[Sysname] sysname PE1

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 1.1.1.9 32

[PE1-LoopBack0] quit

# 配置LSR ID,全局使能MPLS。

[PE1] mpls lsr-id 1.1.1.9

[PE1] mpls

[PE1-mpls] quit

# 使能L2VPNMPLS L2VPN

[PE1] l2vpn

[PE1-l2vpn] mpls l2vpn

[PE1-l2vpn] quit

# 全局使能LDP

[PE1] mpls ldp

[PE1-mpls-ldp] quit

# 配置PE 1PE 2建立LDP远程会话。

[PE1] mpls ldp remote-peer 1

[PE1-mpls-ldp-remote-1] remote-ip 3.3.3.9

[PE1-mpls-ldp-remote-1] quit

# 配置连接P的接口Vlan-interface2,在此接口上使能LDP。

[PE1] interface vlan-interface 2

[PE1-Vlan-interface2] ip address 23.1.1.1 24

[PE1-Vlan-interface2] mpls

[PE1-Vlan-interface2] mpls ldp

[PE1-Vlan-interface2] quit

# PE 1上运行OSPF,用于建立LSP

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 23.1.1.1 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 配置BGP扩展。

[PE1] bgp 100

[PE1-bgp] peer 3.3.3.9 as-number 100

[PE1-bgp] peer 3.3.3.9 connect-interface loopback 0

[PE1-bgp] vpls-family

[PE1-bgp-af-vpls] peer 3.3.3.9 enable

[PE1-bgp-af-vpls] quit

[PE1-bgp] quit

# 配置LDP方式下的VPLS实例aaa基本属性。

[PE1] vsi aaa static

[PE1-vsi-aaa] pwsignal ldp

[PE1-vsi-aaa-ldp] vsi-id 500

[PE1-vsi-aaa-ldp] peer 3.3.3.9

[PE1-vsi-aaa-ldp] quit

[PE1-vsi-aaa] quit

# 配置BGP方式下的VPLS实例bbb基本属性。

[PE1] vsi bbb auto

[PE1-vsi-bbb] pwsignal bgp

[PE1-vsi-bbb-bgp] route-distinguisher 100:1

[PE1-vsi-bbb-bgp] vpn-target 111:1

[PE1-vsi-bbb-bgp] site 10

[PE1-vsi-bbb-bgp] quit

[PE1-vsi-bbb] quit

# 在接入CE 1的接口GigabitEthernet1/0/1上创建服务实例,并绑定L2VPN

[PE1] interface GigabitEthernet 1/0/1

[PE1-GigabitEthernet1/0/1] service-instance 1000

[PE1-GigabitEthernet1/0/1-srv1000] encapsulation s-vid 100

[PE1-GigabitEthernet1/0/1-srv1000] xconnect vsi aaa

[PE1-GigabitEthernet1/0/1-srv1000] quit

[PE1-GigabitEthernet1/0/1] service-instance 2000

[PE1-GigabitEthernet1/0/1-srv2000] encapsulation s-vid 200

[PE1-GigabitEthernet1/0/1-srv2000] xconnect vsi bbb

[PE1-GigabitEthernet1/0/1-srv2000] quit

[PE1-GigabitEthernet1/0/1] quit

(2)     配置P

<Sysname> system-view

[Sysname] sysname P

[P] interface loopback 0

[P-LoopBack0] ip address 2.2.2.9 32

[P-LoopBack0] quit

# 配置LSR ID,全局使能MPLS。

[P] mpls lsr-id 2.2.2.9

[P] mpls

[P-mpls] quit

# 全局使能LDP

[P] mpls ldp

[P-mpls-ldp] quit

# 配置连接PE 1的接口Vlan-interface2,在此接口上使能LDP

[P] interface vlan-interface 2

[P-Vlan-interface2] ip address 23.1.1.2 24

[P-Vlan-interface2] mpls

[P-Vlan-interface2] mpls ldp

[P-Vlan-interface2] quit

# 配置连接PE 2的接口Vlan-interface3,在此接口上使能LDP

[P] interface vlan-interface 3

[P-Vlan-interface3] ip address 26.2.2.2 24

[P-Vlan-interface3] mpls

[P-Vlan-interface3] mpls ldp

[P-Vlan-interface3] quit

# P上运行OSPF,用于建立LSP

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 23.1.1.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 26.2.2.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

(3)     PE 2的配置

<Sysname> system-view

[Sysname] sysname PE2

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 3.3.3.9 32

[PE2-LoopBack0] quit

# 配置LSR ID,全局使能MPLS。

[PE2] mpls lsr-id 3.3.3.9

[PE2] mpls

[PE2-mpls] quit

# 使能L2VPNMPLS L2VPN

[PE2] l2vpn

[PE2-l2vpn] mpls l2vpn

[PE2-l2vpn] quit

# 全局使能LDP

[PE2] mpls ldp

[PE2-mpls-ldp] quit

# 配置PE 2PE 1建立LDP远程会话。

[PE2] mpls ldp remote-peer 2

[PE2-mpls-ldp-remote-2] remote-ip 1.1.1.9

[PE2-mpls-ldp-remote-2] quit

# 配置连接P的接口Vlan-interface3,在此接口上使能LDP。

[PE2] interface vlan-interface 3

[PE2-Vlan-interface3] ip address 26.2.2.1 24

[PE2-Vlan-interface3] mpls

[PE2-Vlan-interface3] mpls ldp

[PE2-Vlan-interface3] quit

# 在PE 2上运行OSPF,用于建立LSP。

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 3.3.3.9 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] network 26.2.2.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 配置BGP扩展。

[PE2] bgp 100

[PE2-bgp] peer 1.1.1.9 as-number 100

[PE2-bgp] peer 1.1.1.9 connect-interface loopback 0

[PE2-bgp] vpls-family

[PE2-bgp-af-vpls] peer 1.1.1.9 enable

[PE2-bgp-af-vpls] quit

[PE2-bgp] quit

# 配置LDP方式下的VPLS实例aaa基本属性。

[PE2] vsi aaa static

[PE2-vsi-aaa] pwsignal ldp

[PE2-vsi-aaa-ldp] vsi-id 500

[PE2-vsi-aaa-ldp] peer 1.1.1.9

[PE2-vsi-aaa-ldp] quit

[PE2-vsi-aaa] quit

# 配置BGP方式下的VPLS实例bbb基本属性。

[PE2] vsi bbb auto

[PE2-vsi-bbb] pwsignal bgp

[PE2-vsi-bbb-bgp] route-distinguisher 100:1

[PE2-vsi-bbb-bgp] vpn-target 111:1

[PE2-vsi-bbb-bgp] site 20

[PE2-vsi-bbb-bgp] quit

[PE2-vsi-bbb] quit

# 在接入CE 2的接口GigabitEthernet1/0/1上创建服务实例,并绑定L2VPN

[PE2] interface GigabitEthernet 1/0/1

[PE2-GigabitEthernet1/0/1] service-instance 1000

[PE2-GigabitEthernet1/0/1-srv1000] encapsulation s-vid 100

[PE2-GigabitEthernet1/0/1-srv1000] xconnect vsi aaa

[PE2-GigabitEthernet1/0/1-srv1000] quit

[PE2-GigabitEthernet1/0/1] service-instance 2000

[PE2-GigabitEthernet1/0/1-srv2000] encapsulation s-vid 200

[PE2-GigabitEthernet1/0/1-srv2000] xconnect vsi bbb

[PE2-GigabitEthernet1/0/1-srv2000] quit

[PE2-GigabitEthernet1/0/1] quit

(4)     配置完成后的检验

完成上述配置后,在各个PE上执行display vpls connection命令,可以看到建立了PW连接,且状态为up。

[PE2] display vpls connection vsi aaa verbose

VSI Name: aaa                             Signaling: ldp

  **Remote Vsi ID   : 500

    VC State        : up

    Encapsulation   : vlan

    Group ID        : 0

    MTU             : 1500

    Peer Ip Address : 1.1.1.9

    PW Type         : label

    Local VC Label  : 89766

    Remote VC Label : 81922

    Link ID         : 1

    Tunnel Policy   : --

    Tunnel ID       : 0x4600068

1.14.2  Hub-Spoke的VPLS配置举例

1. 组网需求

·     Spoke-PE 1与Hub-PE建立PW连接,Spoke-PE 2与Hub-PE之间建立PW连接;

·     Spoke-CE 1、Spoke-CE 2和Hub-CE分别连接到对应PE设备的GigabitEthernet1/0/1端口;Spoke-PE 1、Spoke-PE 2和Hub-PE通过服务实例将报文与VPLS实例绑定:服务实例1000用来匹配接收到的VLAN Tag为100的报文,并通过VPLS实例aaa转发

·     Spoke-PE 1与Hub-PE之间以接口Vlan-interface10连接;

·     Spoke-PE 2与Hub-PE之间以接口Vlan-interface20连接;

·     配置VPLS实例aaa支持Hub-Spoke组网方式。

2. 组网图

图1-8 Hub-Spoke的VPLS配置举例组网图

 

3. 配置步骤

(1)     在MPLS骨干网络上配置IGP协议,此例选择OSPF,具体配置略。

(2)     Spoke-PE 1的配置

# 配置MPLS基本能力。

<Sysname> system-view

[Sysname] sysname Spoke-PE1

[Spoke-PE1] interface loopback 0

[Spoke-PE1-LoopBack0] ip address 1.1.1.9 32

[Spoke-PE1-LoopBack0] quit

[Spoke-PE1] mpls lsr-id 1.1.1.9

[Spoke-PE1] mpls

[Spoke-PE1–mpls] quit

[Spoke-PE1] mpls ldp

[Spoke-PE1-mpls-ldp] quit

# 配置与Hub-PE相连接口的MPLS基本能力。

[Spoke-PE1] interface vlan-interface 10

[Spoke-PE1-Vlan-interface10] ip address 10.1.1.1 24

[Spoke-PE1-Vlan-interface10] mpls

[Spoke-PE1-Vlan-interface10] mpls ldp

[Spoke-PE1-Vlan-interface10] quit

# 配置与Hub-PE的远端LDP会话。

[Spoke-PE1] mpls ldp remote-peer 1

[Spoke-PE1-mpls-remote-1] remote-ip 3.3.3.9

[Spoke-PE1-mpls-remote-1] quit

# 使能L2VPN和MPLS L2VPN。

[Spoke-PE1] l2vpn

[Spoke-PE1-l2vpn] mpls l2vpn

[Spoke-PE1-l2vpn] quit

# 配置LDP方式下支持Hub-Spoke的VPLS实例aaa的基本属性,并指定对端设备的连接方式为Hub方式。

[Spoke-PE1] vsi aaa static hub-spoke

[Spoke-PE1-vsi-aaa] pwsignal ldp

[Spoke-PE1-vsi-aaa-ldp] vsi-id 500

[Spoke-PE1-vsi-aaa-ldp] peer 3.3.3.9 hub

[Spoke-PE1-vsi-aaa-ldp] quit

[Spoke-PE1-vsi-aaa] quit

# 在接入Spock-CE 1的接口GigabitEthernet1/0/1上创建服务实例,并绑定VPLS实例,同时指定接入的CE设备为Spoke-CE

[Spoke-PE1] interface GigabitEthernet 1/0/1

[Spoke-PE1-GigabitEthernet1/0/1] service-instance 1000

[Spoke-PE1-GigabitEthernet1/0/1-srv1000] encapsulation s-vid 100

[Spoke-PE1-GigabitEthernet1/0/1-srv1000] xconnect vsi aaa spoke

[Spoke-PE1-GigabitEthernet1/0/1-srv1000] quit

(3)     Spoke-PE 2的配置

# 配置MPLS基本能力。

<Sysname> system-view

[Sysname] sysname Spoke-PE2

[Spoke-PE2] interface loopback 0

[Spoke-PE2-LoopBack0] ip address 2.2.2.9 32

[Spoke-PE2-LoopBack0] quit

[Spoke-PE2] mpls lsr-id 2.2.2.9

[Spoke-PE2] mpls

[Spoke-PE2–mpls] quit

[Spoke-PE2] mpls ldp

[Spoke-PE2–mpls-ldp] quit

# 配置与Hub-PE相连接口的MPLS基本能力。

[Spoke-PE2] interface vlan-interface 20

[Spoke-PE2-Vlan-interface20] ip address 20.1.1.1 24

[Spoke-PE2-Vlan-interface20] mpls

[Spoke-PE2-Vlan-interface20] mpls ldp

[Spoke-PE2-Vlan-interface20] quit

# 配置与Hub-PE的远端LDP会话。

[Spoke-PE2] mpls ldp remote-peer 2

[Spoke-PE2-mpls-remote-2] remote-ip 3.3.3.9

[Spoke-PE2-mpls-remote-2] quit

# 使能L2VPN和MPLS L2VPN。

[Spoke-PE2] l2vpn

[Spoke-PE2-l2vpn] mpls l2vpn

[Spoke-PE2-l2vpn] quit

# 配置LDP方式下支持Hub-Spoke的VPLS实例aaa的基本属性,并指定对端设备的连接方式为Hub方式。

[Spoke-PE2] vsi aaa static hub-spoke

[Spoke-PE2-vsi-aaa] pwsignal ldp

[Spoke-PE2-vsi-aaa-ldp] vsi-id 500

[Spoke-PE2-vsi-aaa-ldp] peer 3.3.3.9 hub

[Spoke-PE2-vsi-aaa-ldp] quit

[Spoke-PE2-vsi-aaa] quit

# 在接入Spock-CE 1的接口GigabitEthernet1/0/1上创建服务实例,并绑定VPLS实例,同时指定接入的CE设备为Spoke-CE

[Spoke-PE2] interface GigabitEthernet 1/0/1

[Spoke-PE2-GigabitEthernet1/0/1] service-instance 1000

[Spoke-PE2-GigabitEthernet1/0/1-srv1000] encapsulation s-vid 100

[Spoke-PE2-GigabitEthernet1/0/1-srv1000] xconnect vsi aaa spoke

[Spoke-PE2-GigabitEthernet1/0/1-srv1000] quit

(4)     Hub-PE的配置

# 配置MPLS基本能力。

<Sysname> system-view

[Sysname] sysname Hub-PE

[Hub-PE] interface loopback 0

[Hub-PE-LoopBack0] ip address 3.3.3.9 32

[Hub-PE-LoopBack0] quit

[Hub-PE] mpls lsr-id 3.3.3.9

[Hub-PE] mpls

[Hub-PE–mpls] quit

[Hub-PE] mpls ldp

[Hub-PE–mpls-ldp] quit

# 配置与Spoke-PE 1相连接口的MPLS基本能力。

[Hub-PE] interface vlan-interface 10

[Hub-PE-Vlan-interface10] ip address 10.1.1.2 24

[Hub-PE-Vlan-interface10] mpls

[Hub-PE-Vlan-interface10] mpls ldp

[Hub-PE-Vlan-interface10] quit

# 配置与Spoke-PE 2相连接口的MPLS基本能力。

[Hub-PE] interface vlan-interface 20

[Hub-PE-Vlan-interface20] ip address 20.1.1.2 24

[Hub-PE-Vlan-interface20] mpls

[Hub-PE-Vlan-interface20] mpls ldp

[Hub-PE-Vlan-interface20] quit

# 配置远端LDP会话。

[Hub-PE] mpls ldp remote-peer 1

[Hub-PE-mpls-remote-1] remote-ip 1.1.1.9

[Hub-PE-mpls-remote-1] quit

[Hub-PE] mpls ldp remote-peer 2

[Hub-PE-mpls-remote-2] remote-ip 2.2.2.9

[Hub-PE-mpls-remote-2] quit

# 使能L2VPN和MPLS L2VPN。

[Hub-PE] l2vpn

[Hub-PE-l2vpn] mpls l2vpn

[Hub-PE-l2vpn] quit

# 配置LDP方式下支持Hub-Spoke的VPLS实例aaa的基本属性,并指定对端设备的连接方式为Spoke方式。

[Hub-PE] vsi aaa static hub-spoke

[Hub-PE-vsi-aaa] pwsignal ldp

[Hub-PE-vsi-aaa-ldp] vsi-id 500

[Hub-PE-vsi-aaa-ldp] peer 1.1.1.9 spoke

[Hub-PE-vsi-aaa-ldp] peer 2.2.2.9 spoke

[Hub-PE-vsi-aaa-ldp] quit

[Hub-PE-vsi-aaa] quit

# 在接入Hub-CE的接口GigabitEthernet1/0/1上创建服务实例,并绑定VPLS实例,同时指定接入的CE设备为Hub-CE

[Hub-PE] interface GigabitEthernet 1/0/1

[Hub-PE-GigabitEthernet1/0/1] service-instance 1000

[Hub-PE-GigabitEthernet1/0/1-srv1000] encapsulation s-vid 100

[Hub-PE-GigabitEthernet1/0/1-srv1000] xconnect vsi aaa hub

[Hub-PE-GigabitEthernet1/0/1-srv1000] quit

(5)     配置完成后的检验

完成上述配置后,在各个PE上执行display vpls connection命令,可以看到建立了PW连接,且状态为up。

1.14.3  H-VPLS备份链路配置举例

1. 组网需求

·     CE 1、CE 2分别通过VLAN方式接入UPE;

·     UPE与NPE1和NPE2建立PW连接——U-PW,NPE2作为备份链路;

·     NPE1、NPE2与NPE3之间建立PW连接——N-PW,CE3通过NPE3连接到网络;

·     UPE与NPE1和NPE2设备之间以接口Vlan-interface12和Vlan-interface13连接;

·     NPE1与NPE3之间以接口Vlan-interface15连接;NPE2与NPE3之间以接口Vlan-interface16连接;

·     配置VPLS实例支持H-VPLS组网方式。

2. 组网图

图1-9 配置H-VPLS备份链路组网图

 

3. 配置步骤

(1)     在MPLS骨干网络上配置IGP协议,此例选择OSPF,具体配置略。

(2)     UPE的配置

# 配置MPLS基本能力。

<Sysname> system-view

[Sysname] sysname UPE

[UPE] interface loopback 0

[UPE-LoopBack0] ip address 1.1.1.1 32

[UPE-LoopBack0] quit

[UPE] mpls lsr-id 1.1.1.1

[UPE] mpls

[UPE-mpls] quit

[UPE] mpls ldp

[UPE-mpls-ldp] quit

# 配置与NPE1相连接口的IP地址,并使能MPLSMPLS LDP

[UPE] interface vlan-interface 12

[UPE-Vlan-interface12] ip address 12.1.1.1 24

[UPE-Vlan-interface12] mpls

[UPE-Vlan-interface12] mpls ldp

[UPE-Vlan-interface12] quit

# 配置与NPE2相连接口的IP地址,并使能MPLS和MPLS LDP。

[UPE] interface vlan-interface 13

[UPE-Vlan-interface13] ip address 13.1.1.1 255.255.255.0

[UPE-Vlan-interface13] mpls

[UPE-Vlan-interface13] mpls ldp

[UPE-Vlan-interface13] quit

# 配置与NPE1的远端LDP会话。

[UPE] mpls ldp remote-peer 1

[UPE-mpls-remote-1] remote-ip 2.2.2.2

[UPE-mpls-remote-1] quit

# 配置与NPE2的远端LDP会话。

[UPE] mpls ldp remote-peer 2

[UPE-mpls-remote-1] remote-ip 3.3.3.3

[UPE-mpls-remote-1] quit

# 使能L2VPN和MPLS L2VPN。

[UPE] l2vpn

[UPE-l2vpn] mpls l2vpn

[UPE-l2vpn] quit

# 配置LDP方式下VPLS实例aaa的基本属性。

[UPE] vsi aaa static

[UPE-vsi-aaa] pwsignal ldp

[UPE-vsi-aaa-ldp] vsi-id 500

[UPE-vsi-aaa-ldp] peer 2.2.2.2 backup-peer 3.3.3.3

[UPE-vsi-aaa-ldp] dual-npe revertive wtr-time 1

[UPE-vsi-aaa-ldp] quit

[UPE-vsi-aaa] quit

# 在接入CE 1的接口GigabitEthernet1/0/1上创建服务实例,并绑定VSI。

[UPE] interface GigabitEthernet 1/0/1

[UPE-GigabitEthernet1/0/1] service-instance 1000

[UPE-GigabitEthernet1/0/1-srv1000] encapsulation s-vid 10

[UPE-GigabitEthernet1/0/1-srv1000] xconnect vsi aaa

[UPE-GigabitEthernet1/0/1-srv1000] quit

# 在接入CE 2的接口GigabitEthernet1/0/2上创建服务实例,并绑定VSI。

[UPE] interface GigabitEthernet 1/0/2

[UPE-GigabitEthernet1/0/2] service-instance 1000

[UPE-GigabitEthernet1/0/2-srv1000] encapsulation s-vid 11

[UPE-GigabitEthernet1/0/2-srv1000] xconnect vsi aaa

[UPE-GigabitEthernet1/0/2-srv1000] quit

(3)     NPE1的配置

# 配置MPLS基本能力。

<Sysname> system-view

[Sysname] sysname NPE1

[NPE1] interface loopback 0

[NPE1-LoopBack0] ip address 2.2.2.2 32

[NPE1-LoopBack0] quit

[NPE1] mpls lsr-id 2.2.2.2

[NPE1] mpls

[NPE1–mpls] quit

[NPE1] mpls ldp

[NPE1–mpls-ldp] quit

# 配置与UPE相连接口的IP地址,并使能MPLS和MPLS LDP。

[NPE1] interface vlan-interface 12

[NPE1-Vlan-interface12] ip address 12.1.1.2 24

[NPE1-Vlan-interface12] mpls

[NPE1-Vlan-interface12] mpls ldp

[NPE1-Vlan-interface12] quit

# 配置与NPE2相连接口的IP地址,并使能MPLS和MPLS LDP。

[NPE1] interface vlan-interface 17

[NPE1-Vlan-interface17] ip address 17.1.1.1 24

[NPE1-Vlan-interface17] mpls

[NPE1-Vlan-interface17] mpls ldp

[NPE1-Vlan-interface17] quit

# 配置与NPE3相连接口的IP地址,并使能MPLS和MPLS LDP。

[NPE1] interface vlan-interface 15

[NPE1-Vlan-interface15] ip address 15.1.1.1 24

[NPE1-Vlan-interface15] mpls

[NPE1-Vlan-interface15] mpls ldp

[NPE1-Vlan-interface15] quit

# 配置与UPE的远端LDP会话。

[NPE1] mpls ldp remote-peer 2

[NPE1-mpls-remote-2] remote-ip 1.1.1.1

[NPE1-mpls-remote-2] quit

# 配置与NPE2的远端LDP会话。

[NPE1] mpls ldp remote-peer 3

[NPE1-mpls-remote-3] remote-ip 3.3.3.3

[NPE1-mpls-remote-3] quit

# 配置与NPE3的远端LDP会话。

[NPE1] mpls ldp remote-peer 4

[NPE1-mpls-remote-4] remote-ip 4.4.4.4

[NPE1-mpls-remote-4] quit

# 使能L2VPN和MPLS L2VPN。

[NPE1] l2vpn

[NPE1-l2vpn] mpls l2vpn

[NPE1-l2vpn] quit

# 配置LDP方式下VPLS实例aaa的基本属性。

[NPE1] vsi aaa static

[NPE1-vsi-aaa] pwsignal ldp

[NPE1-vsi-aaa-ldp] vsi-id 500

[NPE1-vsi-aaa-ldp] peer 1.1.1.1 upe

[NPE1-vsi-aaa-ldp] peer 3.3.3.3

[NPE1-vsi-aaa-ldp] peer 4.4.4.4

[NPE1-vsi-aaa-ldp] quit

[NPE1-vsi-aaa] quit

NPE2和NPE1的配置相似,配置过程略。

(4)     NPE3的配置

# 配置MPLS基本能力。

<Sysname> system-view

[Sysname] sysname NPE3

[NPE3] interface loopback 0

[NPE3-LoopBack0] ip address 4.4.4.4 32

[NPE3-LoopBack0] quit

[NPE3] mpls lsr-id 4.4.4.4

[NPE3] mpls

[NPE3–mpls] quit

[NPE3] mpls ldp

[NPE3–mpls-ldp] quit

# 配置与NPE1相连接口的IP地址,并使能MPLS和MPLS LDP。

[NPE3] interface vlan-interface 15

[NPE3-Vlan-interface15] ip address 15.1.1.2 24

[NPE3-Vlan-interface15] mpls

[NPE3-Vlan-interface15] mpls ldp

[NPE3-Vlan-interface15] quit

# 配置与NPE2相连接口的IP地址,并使能MPLS和MPLS LDP。

[NPE3] interface vlan-interface 16

[NPE3-Vlan-interface16] ip address 16.1.1.2 255.255.255.0

[NPE3-Vlan-interface16] mpls

[NPE3-Vlan-interface16] mpls ldp

[NPE3-Vlan-interface16] quit

# 配置远端LDP会话。

[NPE3] mpls ldp remote-peer 1

[NPE3-mpls-remote-1] remote-ip 2.2.2.2

[NPE3-mpls-remote-1] quit

[NPE3] mpls ldp remote-peer 2

[NPE3-mpls-remote-2] remote-ip 3.3.3.3

[NPE3-mpls-remote-2] quit

# 使能L2VPN和MPLS L2VPN。

[NPE3] l2vpn

[NPE3-l2vpn] mpls l2vpn

[NPE3-l2vpn] quit

# 配置LDP方式下VPLS实例aaa的基本属性。

[NPE3] vsi aaa static

[NPE3-vsi-aaa] pwsignal ldp

[NPE3-vsi-aaa-ldp] vsi-id 500

[NPE3-vsi-aaa-ldp] peer 2.2.2.2

[NPE3-vsi-aaa-ldp] peer 3.3.3.3

[NPE3-vsi-aaa-ldp] quit

[NPE3-vsi-aaa] quit

# 在接入CE 3的接口GigabitEthernet1/0/1上创建服务实例,并绑定VSI。

[NPE3] interface GigabitEthernet 1/0/1

[NPE3-GigabitEthernet1/0/1] service-instance 1000

[NPE3-GigabitEthernet1/0/1-srv1000] encapsulation s-vid 10

[NPE3-GigabitEthernet1/0/1-srv1000] xconnect vsi aaa

[NPE3-GigabitEthernet1/0/1-srv1000] quit

(5)     配置完成后的检验

完成上述配置后,在各个PE上执行display vpls connection命令,可以看到PW连接,状态为up。

1.14.4  H-VPLS组网中通过BFD检测主链路故障配置举例

1. 组网需求

·     H-VPLS组网,Switch A作为UPE设备,Switch B作为主NPE设备、Switch C作为备份NPE设备,在双方直连口上使能MPLS应用,在设备上运行OSPF,网络层相互可达。

·     在断开Switch A和Switch B之间的链路后,BFD能够快速检测并通告MPLS LDP协议,从而快速进行主备PW间的切换。

2. 组网图

图1-10 H-VPLS组网中通过BFD检测主链路故障配置组网图

 

3. 配置步骤

(1)     配置MPLS基本功能

# 配置Switch A。

<SwitchA> system-view

[SwitchA] mpls lsr-id 1.1.1.9

[SwitchA] mpls

[SwitchA-mpls] quit

[SwitchA] mpls ldp

[SwitchA-mpls-ldp] quit

[SwitchA] mpls ldp remote-peer switchb

[SwitchA-mpls-ldp-remote-switchb] remote-ip 2.2.2.9

[SwitchA-mpls-ldp-remote-switchb] remote-ip bfd

[SwitchA-mpls-ldp-remote-switchb] quit

[SwitchA] mpls ldp remote-peer switchc

[SwitchA-mpls-ldp-remote-switchc] remote-ip 3.3.3.9

[SwitchA-mpls-ldp-remote-switchc] remote-ip bfd

[SwitchA-mpls-ldp-remote-switchc] quit

[SwitchA] vlan 12

[SwitchA-vlan12] port gigabitethernet 1/0/2

[SwitchA-vlan12] quit

[SwitchA] vlan 13

[SwitchA-vlan13] port gigabitethernet 1/0/1

[SwitchA-vlan13] quit

[SwitchA] interface vlan-interface 12

[SwitchA-Vlan-interface12] mpls

[SwitchA-Vlan-interface12] mpls ldp

[SwitchA-Vlan-interface12] quit

[SwitchA] interface vlan-interface 13

[SwitchA-Vlan-interface13] mpls

[SwitchA-Vlan-interface13] mpls ldp

[SwitchA-Vlan-interface13] quit

# 配置Switch B。

<SwitchB> system-view

[SwitchB] mpls lsr-id 2.2.2.9

[SwitchB] mpls

[SwitchB-mpls] quit

[SwitchB] mpls ldp

[SwitchB-mpls-ldp] quit

[SwitchB] mpls ldp remote-peer switcha

[SwitchB-mpls-ldp-remote-switcha] remote-ip 1.1.1.9

[SwitchB-mpls-ldp-remote-switcha] remote-ip bfd

[SwitchB-mpls-ldp-remote-switcha] quit

[SwitchB] vlan 12

[SwitchB-vlan12] port gigabitethernet 1/0/1

[SwitchB-vlan12] quit

[SwitchB] interface vlan-interface 12

[SwitchB-Vlan-interface12] mpls

[SwitchB-Vlan-interface12] mpls ldp

[SwitchB-Vlan-interface12] quit

# 配置Switch C。

<SwitchC> system-view

[SwitchC] mpls lsr-id 3.3.3.9

[SwitchC] mpls

[SwitchC-mpls] quit

[SwitchC] mpls ldp

[SwitchC-mpls-ldp] quit

[SwitchC] mpls ldp remote-peer switcha

[SwitchC-mpls-ldp-remote-switcha] remote-ip 1.1.1.9

[SwitchC-mpls-ldp-remote-switcha] remote-ip bfd

[SwitchC-mpls-ldp-remote-switcha] quit

[SwitchC] vlan 13

[SwitchC-vlan13] port gigabitethernet 1/0/1

[SwitchC-vlan13] quit

[SwitchC] interface vlan-interface 13

[SwitchC-Vlan-interface13] mpls

[SwitchC-Vlan-interface13] mpls ldp

[SwitchC-Vlan-interface13] quit

(2)     配置各交换机接口地址

# 配置Switch A。

[SwitchA] interface vlan-interface 12

[SwitchA-Vlan-interface12] ip address 12.1.1.1 24

[SwitchA-Vlan-interface12] quit

[SwitchA] interface vlan-interface 13

[SwitchA-Vlan-interface13] ip address 13.1.1.1 24

[SwitchA-Vlan-interface13] quit

[SwitchA] interface loopback 0

[SwitchA-LoopBack0] ip address 1.1.1.9 32

[SwitchA-LoopBack0] quit

# 配置Switch B。

[SwitchB] interface vlan-interface 12

[SwitchB-Vlan-interface12] ip address 12.1.1.2 24

[SwitchB-Vlan-interface12] quit

[SwitchB] interface loopback 0

[SwitchB-LoopBack0] ip address 2.2.2.9 32

[SwitchB-LoopBack0] quit

# 配置Switch C。

[SwitchC] interface vlan-interface 13

[SwitchC-Vlan-interface13] ip address 13.1.1.3 24

[SwitchC-Vlan-interface13] quit

[SwitchC] interface loopback 0

[SwitchC-LoopBack0] ip address 3.3.3.9 32

[SwitchC-LoopBack0] quit

(3)     配置OSPF基本功能

# 配置Switch A。

[SwitchA] ospf

[SwitchA-ospf-1] area 0

[SwitchA-ospf-1-area-0.0.0.0] network 12.1.1.1 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] network 13.1.1.1 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0

[SwitchA-ospf-1-area-0.0.0.0] quit

[SwitchA-ospf-1] quit

# 配置Switch B。

[SwitchB] ospf

[SwitchB-ospf-1] area 0

[SwitchB-ospf-1-area-0.0.0.0] network 12.1.1.2 0.0.0.255

[SwitchB-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0

[SwitchB-ospf-1-area-0.0.0.0] quit

[SwitchB-ospf-1] quit

# 配置Switch C。

[SwitchC] ospf

[SwitchC-ospf-1] area 0

[SwitchC-ospf-1-area-0.0.0.0] network 13.1.1.3 0.0.0.255

[SwitchC-ospf-1-area-0.0.0.0] network 3.3.3.9 0.0.0.0

[SwitchC-ospf-1-area-0.0.0.0] quit

[SwitchC-ospf-1] quit

(4)     配置各交换机VSI实例

# 配置Switch A。

[SwitchA] l2vpn

[SwitchA-l2vpn] mpls l2vpn

[SwitchA-l2vpn] quit

[SwitchA] vsi vpna static

[SwitchA-vsi-vpna] pwsignal ldp

[SwitchA-vsi-vpna-ldp] vsi-id 100

[SwitchA-vsi-vpna-ldp] peer 2.2.2.9 backup-peer 3.3.3.9

[SwitchA-vsi-vpna-ldp] quit

[SwitchA-vsi-vpna] quit

[SwitchA] vlan 100

[SwitchA-vlan100] port gigabitethernet 1/0/3

[SwitchA-vlan100] quit

[SwitchA] interface gigabitethernet 1/0/3

[SwitchA -GigabitEthernet1/0/3] service-instance 1000

[SwitchA -GigabitEthernet1/0/3-srv1000] encapsulation s-vid 100

[SwitchA -GigabitEthernet1/0/3-srv1000] xconnect vsi vpna

# 配置Switch B。

[SwitchB] l2vpn

[SwitchB-l2vpn] mpls l2vpn

[SwitchB-l2vpn] quit

[SwitchB] vsi vpna static

[SwitchB-vsi-vpna] pwsignal ldp

[SwitchB-vsi-vpna-ldp] vsi-id 100

[SwitchB-vsi-vpna-ldp] peer 1.1.1.9 upe

[SwitchB-vsi-vpna-ldp] quit

[SwitchB-vsi-vpna] quit

# 配置Switch C。

[SwitchC] l2vpn

[SwitchC-l2vpn] mpls l2vpn

[SwitchC-l2vpn] quit

[SwitchC] vsi vpna static

[SwitchC-vsi-vpna] pwsignal ldp

[SwitchC-vsi-vpna-ldp] vsi-id 100

[SwitchC-vsi-vpna-ldp] peer 1.1.1.9 upe

[SwitchC-vsi-vpna-ldp] quit

[SwitchC-vsi-vpna] quit

(5)     检查配置结果

# 通过display bfd session verbose显示Switch A的BFD邻居详细信息。

<SwitchA> display bfd session verbose

 

 Total Session Num: 2            Init Mode: Active

 

 Session Working Under Ctrl Mode:

 

     Local Discr: 21                  Remote Discr: 20

       Source IP: 1.1.1.9           Destination IP: 2.2.2.9

   Session State: Up                     Interface: LoopBack0

 Min Trans Inter: 400ms            Act Trans Inter: 400ms

  Min Recv Inter: 400ms           Act Detect Inter: 2000ms

  Running Up for: 00:00:01               Auth mode: None

    Connect Type: Indirect                 Board Num: 6

        Protocol: MFW/LDP

       Diag Info: No Diagnostic

 

     Local Discr: 4                   Remote Discr: 0

       Source IP: 1.1.1.9           Destination IP: 3.3.3.9

   Session State: Up                     Interface: LoopBack0

 Min Trans Inter: 400ms            Act Trans Inter: 1000ms

  Min Recv Inter: 400ms           Act Detect Inter: 3000ms

  Running Up for: 00:00:01               Auth mode: None

    Connect Type: Indirect               Board Num: 6

        Protocol: MFW/LDP

       Diag Info: No Diagnostic

# 通过display vpls connection vsi vpna显示Switch A连接Switch B的路径为up状态。

<SwitchA> display vpls connection vsi vpna

 

Total 2 connection(s),

connection(s): 1 up, 1 block, 0 down

 

VSI Name: vpna                             Signaling: ldp

VsiID      VsiType           PeerAddr      InLabel OutLabel LinkID  VCState

100        vlan              2.2.2.9       134312  138882   1       up

100        vlan              3.3.3.9       134216  140476   2       block

# 断开Switch ASwitch B之间的链路。使用display vpls connection vsi vpna可以看到3.3.3.9这条路径的状态为up

<SwitchA> display vpls connection vsi vpna

 

Total 1 connection(s),

connection(s): 1 up, 0 block, 0 down

 

VSI Name: vpna                             Signaling: ldp

VsiID       VsiType             PeerAddr        InLabel OutLabel LinkID  VCState

100         vlan                3.3.3.9         134216  140476   2       up

1.15  常见配置错误举例

1.15.1  PW状态不是up

1. 故障现象

VPLS的PW状态不是up。

2. 故障分析

·     公网LSP隧道没有建立(两端)。

·     扩展会话工作不正常。

·     连接私网的接口没有绑定对应的VPLS实例,或私网接口状态为down。

3. 处理过程

·     查看两端PE设备的路由表,判断PE之间是否存在可达的路由,ping对端环回端口是否可以ping通,LDP会话是否正常。

·     检查两端的扩展会话配置命令是否有遗漏,配置是否正确。

·     通过display interface命令查看私网接口的状态,确保私网接口up。

·     通过display current-configuration命令查看当前配置,确认对等体之间的PW-ID和传输模式是否一致。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!