选择区域语言: EN CN HK

11 网络管理和监控配置指导

10-镜像配置

本章节下载  (553.15 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/CE3000/CE3000-EI/Configure/Operation_Manual/H3C_CE3000-32F-EI_CG-Release_1211-6W100/11/201107/721467_30005_0.htm

10-镜像配置


1 端口镜像配置

本章中提到的端口同时表示二层以太网端口和三层以太网端口。三层以太网端口是指工作模式被配置成三层模式的以太网端口,有关以太网端口工作模式切换的操作,请参见“二层技术-以太网交换配置指导”中的“以太网端口配置”部分。

 

1.1  端口镜像简介

端口镜像是将指定端口(源端口)或CPU(源CPU)的报文复制一份到其它端口(目的端口),目的端口会与数据监测设备相连,用户利用这些数据监测设备来分析复制到目的端口的报文,进行网络监控和故障排除。

1.1.1  端口镜像的基本概念

为了更好地理解后面的内容,首先介绍一下端口镜像中涉及的基本概念。

1. 源端口

源端口是被监控的端口,用户可以对通过该端口的报文进行监控和分析。

2. 源CPU

源CPU是被监控设备上的CPU,用户可以对通过该CPU的报文进行监控和分析。

3. 目的端口

目的端口也可称为监控端口,该端口将接收到的报文转发到数据监测设备,以便对报文进行监控和分析。

4. 镜像的方向

端口镜像的方向分为三种:

l              入方向:仅对从源端口/源CPU收到的报文进行镜像。

l              出方向:仅对从源端口/源CPU发出的报文进行镜像。

l              双向:对从源端口/源CPU收到和发出的报文都进行镜像。

1.1.2  端口镜像的分类

根据使用范围的不同,端口镜像可分为以下三种类型:

l              本地端口镜像:可以将设备源端口/源CPU上的报文复制到本设备的目的端口,用于监控和分析这些报文。

l              二层远程端口镜像:可以将本设备源端口/源CPU上的报文通过二层网络复制到另一台设备的目的端口,用于监控和分析这些报文。

l              三层远程端口镜像:可以将本设备源端口/源CPU上的报文通过三层网络复制到另一台设备的目的端口,用于监控和分析这些报文。三层远程端口镜像可以实现不同网络甚至不同地域间的镜像功能,极大扩展了镜像功能监测的范围,并通过隧道方式保证了镜像报文的安全。适用于在通过隧道连接的不同站点间进行数据采集和分析。

l          由于一个目的端口可以同时监视多个源端口,在某些配置情况下,目的端口会收到同一个报文的多个复制报文。例如,目的端口Port 1同时监控源端口Port 2和Port 3接收和发送的所有报文(Port 2和Port 3在同一台设备上),如果一个报文从Port 2进入设备又从Port 3发送出去,那么这个报文将被复制两次送到目的端口Port 1。

l          对于H3C CE3000-32F-EI交换机,如果对端口入方向的报文进行镜像,则镜像后的报文携带VLAN Tag的情况与原始报文保持一致;如果对端口出方向的报文进行镜像,则镜像后的报文始终携带报文在从源端口发送前所属VLAN的VLAN Tag。

 

1.1.3  端口镜像的实现方式

端口镜像通过镜像组的方式实现,镜像组可以分为本地镜像组、远程源镜像组和远程目的镜像组三类。

1. 本地端口镜像实现方式

本地端口镜像通过本地镜像组的方式实现,即源端口/源CPU和目的端口在同一个本地镜像组中,设备将源端口/源CPU的报文复制一份并转发到目的端口。

图1-1 本地端口镜像示意图

 

图1-1所示,源端口的报文被镜像到目的端口,这样,连接目的端口的数据监测设备就可以对这些报文进行监控和分析。

2. 二层远程端口镜像实现方式

二层远程端口镜像通过远程源镜像组和远程目的镜像组互相配合的方式实现。

图1-2 二层远程端口镜像示意图

 

图1-2所示,用户在源设备上创建远程源镜像组,在目的设备上创建远程目的镜像组。源设备将源端口/源CPU的报文复制一份后,将其通过出端口在远程镜像VLAN中广播,经由中间设备发送至目的设备。目的设备收到该报文后,若其VLAN ID与远程目的镜像组的远程镜像VLAN的VLAN ID相同,就将其转发至目的端口。这样,连接在目的端口上的数据监测设备就可以对源设备上源端口/源CPU的报文进行监控和分析。

l          用户需要确保远程镜像VLAN内源设备到目的设备间二层网络的互通性。

l          在一个镜像组中对同一个端口收发的报文进行双向镜像时,需要在源设备、中间设备和目的设备上通过mac-address mac-learning disable命令用来关闭远程镜像VLAN的MAC地址学习功能,以保证镜像功能的正常进行。关于mac-address mac-learning disable命令的详细信息,请参见“二层技术-以太网交换命令参考”中的“MAC地址表配置命令”。

 

在镜像报文离开源设备到达远程目的设备过程中,用户应确保镜像报文中VLAN ID的正确性,如果该VLAN ID被修改或删除,二层远程镜像功能将失效。

 

3. 三层远程端口镜像实现方式

三层远程端口镜像通过远程源镜像组、远程目的镜像组和GRE隧道互相配合的方式实现。

图1-3 三层远程端口镜像示意图

 

图1-3所示,在源设备上,源端口/源CPU的报文被镜像到Tunnel接口(作为其目的端口),然后通过GRE隧道发送至目的设备,目的设备在通过Tunnel接口(作为其源端口)将报文转发至其目的端口。这样,目的设备上连接目的端口的数据监测设备就可以对源设备上源端口的报文进行监控和分析。

有关GRE隧道的详细介绍,请参见“三层技术-IP业务配置指导”中的“隧道配置”。

 

1.2  配置本地端口镜像

1.2.1  配置任务简介

本地端口镜像的配置需要在同一台设备上进行。

首先创建一个本地镜像组,然后为该镜像组配置源端口和目的端口。

表1-1 本地端口镜像配置任务简介

配置任务

说明

详细配置

创建本地镜像组

必选

1.2.2 

配置源端口

二者至少选其一

源端口和源CPU可以只配其一,也可以都配置

1.2.3 

配置源CPU

1.2.4 

配置目的端口

必选

1.2.5 

 

在H3C CE3000-32F-EI交换机上,可以通过将一个端口配置为多个镜像组的源端口,实现将通过该端口的数据镜像至多个目的端口。其中,对源端口的单向数据进行镜像需要占用一个镜像资源,对源端口的双向数据进行镜像需要占用两个镜像资源,CE3000-32F-EI交换机对一个源端口最多分配四个镜像资源。即一个端口作为单向源端口最多可以加入四个镜像组,作为双向源端口最多可以加入两个镜像组,或者以一个双向源端口和两个单向源端口的形式加入三个镜像组。

 

源端口不能再被用作本镜像组或其它镜像组的出端口或目的端口。

 

1.2.2  创建本地镜像组

表1-2 创建本地镜像组

操作

命令

说明

进入系统视图

system-view

-

创建本地镜像组

mirroring-group group-id local

必选

缺省情况下,不存在任何镜像组

 

配置源端口目的端口后,本地镜像组才能生效。

 

1.2.3  配置源端口

可以在系统视图下为指定镜像组配置一个或多个源端口,也可以在端口视图下将当前端口配置为指定镜像组的源端口,二者的配置效果相同。

1. 在系统视图下配置源端口

表1-3 在系统视图下配置源端口

操作

命令

说明

进入系统视图

system-view

-

为本地镜像组配置源端口

mirroring-group group-id mirroring-port mirroring-port-list { both | inbound | outbound }

必选

缺省情况下,镜像组没有源端口

 

2. 在端口视图下配置源端口

表1-4 在端口视图下配置源端口

操作

命令

说明

进入系统视图

system-view

-

进入端口视图

interface interface-type interface-number

-

配置本端口为本地镜像组的源端口

[ mirroring-group group-id ] mirroring-port { both | inbound | outbound }

必选

缺省情况下,端口不是任何镜像组的源端口

 

一个镜像组内可以配置多个源端口。

 

1.2.4  配置源CPU

表1-5 配置源CPU

操作

命令

说明

进入系统视图

system-view

-

为本地镜像组配置源CPU

mirroring-group group-id mirroring-cpu slot slot-number-list { both | inbound | outbound }

必选

缺省情况下,镜像组没有源CPU

 

一个镜像组内可以配置多个源CPU。

 

1.2.5  配置目的端口

可以在系统视图下为指定镜像组配置目的端口,也可以在端口视图下将当前端口配置为指定镜像组的目的端口,二者的配置效果相同。

1. 在系统视图下配置目的端口

表1-6 在系统视图下配置目的端口

操作

命令

说明

进入系统视图

system-view

-

为本地镜像组配置目的端口

mirroring-group group-id monitor-port monitor-port-id

必选

缺省情况下,镜像组没有目的端口

 

2. 在端口视图下配置目的端口

表1-7 在端口视图下配置目的端口

操作

命令

说明

进入系统视图

system-view

-

进入端口视图

interface interface-type interface-number

-

配置本端口为本地镜像组的目的端口

[ mirroring-group group-id ] monitor-port

必选

缺省情况下,端口不是任何镜像组的目的端口

 

l          一个镜像组内只能配置一个目的端口。

l          请不要在目的端口上使能STP、MSTP和RSTP,否则会影响镜像功能的正常使用。

l          目的端口收到的报文包括复制自源端口的报文和来自其它端口的正常转发报文。为了保证数据监测设备只对源端口的报文进行分析,请将目的端口只用于端口镜像,不作其它用途。

l          镜像组的目的端口不能配置为已经接入RRPP环的端口。

 

1.3  配置二层远程端口镜像

1.3.1  配置任务简介

二层远程端口镜像的配置需要分别在源设备和目的设备上进行。

在H3C CE3000-32F-EI交换机上,可以通过将一个端口配置为多个镜像组的源端口,实现将通过该端口的数据镜像至多个目的端口。其中,对源端口的单向数据进行镜像需要占用一个镜像资源,对源端口的双向数据进行镜像需要占用两个镜像资源,CE3000-32F-EI交换机对一个源端口最多分配四个镜像资源。即一个端口作为单向源端口最多可以加入四个镜像组,作为双向源端口最多可以加入两个镜像组,或者以一个双向源端口和两个单向源端口的形式加入三个镜像组。

 

l          源端口不能再被用作本镜像组或其它镜像组的出端口或目的端口。

l          如果用户在设备上启用了GVRP(GARP VLAN Registration Protocol,GARP VLAN注册协议)功能,GVRP可能将远程镜像VLAN注册到不希望的端口上,此时在目的端口就会收到很多不必要的报文。有关GVRP的详细介绍,请参见“二层技术-以太网交换配置指导”中的“GVRP配置”。

 

首先在源设备上为远程源镜像组配置源端口、出端口和远程镜像VLAN,然后在目的设备上为远程目的镜像组配置远程镜像VLAN和目的端口。

表1-8 二层远程端口镜像配置任务简介

配置任务

说明

详细配置

配置远程源镜像组

创建远程源镜像组

必选

1.3.3  1.

配置源端口

二者至少选其一

源端口和源CPU可以只配其一,也可以都配置

1.3.3  2.

配置源CPU

1.3.3  3.

配置出端口

必选

1.3.3  4.

配置远程镜像VLAN

必选

1.3.3  5.

配置远程目的镜像组

创建远程目的镜像组

必选

1.3.4  1.

配置目的端口

必选

1.3.4  2.

配置远程镜像VLAN

必选

1.3.4  3.

将目的端口加入远程镜像VLAN

必选

1.3.4  4.

利用远程镜像VLAN实现本地镜像支持多个目的端口

可选

1.3.5 

 

1.3.2  配置准备

在配置二层远程端口镜像之前,需完成以下任务:

l              配置远程镜像VLAN所使用的静态VLAN

源设备上的远程源镜像组和目的设备上的远程目的镜像组必须使用相同的远程镜像VLAN。

 

1.3.3  配置远程源镜像组

请在源设备上进行如下配置。

1. 创建远程源镜像组

表1-9 创建远程源镜像组

操作

命令

说明

进入系统视图

system-view

-

创建远程源镜像组

mirroring-group group-id remote-source

必选

缺省情况下,不存在任何镜像组

 

2. 配置源端口

可以在系统视图下为指定镜像组配置一个或多个源端口,也可以在端口视图下将当前端口配置为指定镜像组的源端口,二者的配置效果相同。

(1)        在系统视图下配置源端口

表1-10 在系统视图下配置源端口

操作

命令

说明

进入系统视图

system-view

-

为远程源镜像组配置源端口

mirroring-group group-id mirroring-port mirroring-port-list { both | inbound | outbound }

必选

缺省情况下,镜像组没有源端口

 

(2)        在端口视图下配置源端口

表1-11 在端口视图下配置源端口

操作

命令

说明

进入系统视图

system-view

-

进入端口视图

interface interface-type interface-number

-

配置本端口为远程源镜像组的源端口

[ mirroring-group group-id ] mirroring-port { both | inbound | outbound }

必选

缺省情况下,端口不是任何镜像组的源端口

 

l          一个镜像组内可以配置多个源端口。

l          请不要将源端口加入到远程镜像VLAN中,否则会影响镜像功能的正常使用。

 

3. 配置源CPU

表1-12 配置源CPU

操作

命令

说明

进入系统视图

system-view

-

为远程源镜像组配置源CPU

mirroring-group group-id mirroring-cpu slot slot-number-list { both | inbound | outbound }

必选

缺省情况下,镜像组没有源CPU

 

一个镜像组内可以配置多个源CPU。

 

4. 配置出端口

可以在系统视图下为指定镜像组配置出端口,也可以在端口视图下将当前端口配置为指定镜像组的出端口,二者的配置效果相同。

(1)        在系统视图下配置出端口

表1-13 在系统视图下配置出端口

操作

命令

说明

进入系统视图

system-view

-

为远程源镜像组配置出端口

mirroring-group group-id monitor-egress monitor-egress-port

必选

缺省情况下,镜像组没有出端口

 

(2)        在端口视图下配置出端口

表1-14 在端口视图下配置出端口

操作

命令

说明

进入系统视图

system-view

-

进入端口视图

interface interface-type interface-number

-

配置本端口为远程源镜像组的出端口

mirroring-group group-id monitor-egress

必选

缺省情况下,端口不是任何镜像组的出端口

 

l          一个镜像组内只能配置一个出端口。

l          出端口不能是现有镜像组的成员端口。

l          请不要在出端口上配置下列功能:STP、MSTP、RSTP、802.1X、IGMP Snooping、静态ARP和MAC地址学习,否则会影响镜像功能的正常使用。

 

5. 配置远程镜像VLAN

表1-15 配置远程镜像VLAN

操作

命令

说明

进入系统视图

system-view

-

为远程源镜像组配置远程镜像VLAN

mirroring-group group-id remote-probe vlan rprobe-vlan-id

必选

缺省情况下,镜像组没有远程镜像VLAN

 

l          一个VLAN只能被一个镜像组使用。

l          请将远程镜像VLAN只用于端口镜像,不作其它用途。

l          被配置成远程镜像VLAN后,该VLAN不能直接删除,必须先删除远程镜像VLAN的配置才能够删除这个VLAN。

l          如果镜像组生效后,远程镜像VLAN被取消,那么该镜像组将失效。

 

1.3.4  配置远程目的镜像组

请在目的设备上进行如下配置。

1. 创建远程目的镜像组

表1-16 创建远程目的镜像组

操作

命令

说明

进入系统视图

system-view

-

创建远程目的镜像组

mirroring-group group-id remote-destination

必选

缺省情况下,不存在任何镜像组

 

2. 配置目的端口

可以在系统视图下为指定镜像组配置目的端口,也可以在端口视图下将当前端口配置为指定镜像组的目的端口,二者的配置效果相同。

(1)        在系统视图下配置目的端口

表1-17 在系统视图下配置目的端口

操作

命令

说明

进入系统视图

system-view

-

为远程目的镜像组配置目的端口

mirroring-group group-id monitor-port monitor-port-id

必选

缺省情况下,镜像组没有目的端口

 

(2)        在端口视图下配置目的端口

表1-18 在端口视图下配置目的端口

操作

命令

说明

进入系统视图

system-view

-

进入端口视图

interface interface-type interface-number

-

配置本端口为远程目的镜像组的目的端口

[ mirroring-group group-id ] monitor-port

必选

缺省情况下,端口不是任何镜像组的目的端口

 

l          一个镜像组内只能配置一个目的端口。

l          请不要在目的端口上使能STP、MSTP和RSTP,否则会影响镜像功能的正常使用。

l          目的端口收到的报文包括复制自源端口的报文和来自其它端口的正常转发报文。为了保证数据监测设备只对源端口的报文进行分析,请将目的端口只用于端口镜像,不作其它用途。

l          镜像组的目的端口不能配置为已经接入RRPP环的端口。

 

3. 配置远程镜像VLAN

表1-19 配置远程镜像VLAN

操作

命令

说明

进入系统视图

system-view

-

为远程目的镜像组配置远程镜像VLAN

mirroring-group group-id remote-probe vlan rprobe-vlan-id

必选

缺省情况下,镜像组没有远程镜像VLAN

 

l          一个VLAN只能被一个镜像组使用。

l          请将远程镜像VLAN只用于端口镜像,不作其它用途。

l          被配置成远程镜像VLAN后,该VLAN不能直接删除,必须先删除远程镜像VLAN的配置才能够删除这个VLAN。

l          如果镜像组生效后,远程镜像VLAN被取消,那么该镜像组将失效。

 

4. 将目的端口加入远程镜像VLAN

表1-20 将目的端口加入远程镜像VLAN

操作

命令

说明

进入系统视图

system-view

-

进入目的端口视图

interface interface-type interface-number

-

将目的端口加入远程镜像VLAN

目的端口为Access端口

port access vlan vlan-id

三者必选其一

目的端口为Trunk端口

port trunk permit vlan vlan-id

目的端口为Hybrid端口

port hybrid vlan vlan-id { tagged | untagged }

 

有关port access vlanport trunk permit vlanport hybrid vlan命令的详细介绍,请参见“二层技术-以太网交换命令参考”中的“VLAN配置命令”。

 

1.3.5  利用远程镜像VLAN实现本地镜像支持多个目的端口

传统的本地镜像配置方式仅支持在一个镜像组中指定一个镜像目的端口,虽然可以通过在多个镜像组中指定同一个源端口的方式,实现将流经某端口的数据镜像至多个目的端口,但这种方式十分浪费镜像组资源,并且目的端口的数量仍然有限。此时可以利用远程镜像VLAN的原理来实现这种需求。

在二层远程端口镜像中,会使用到远程镜像VLAN,镜像报文在远程镜像VLAN中以广播的方式发送。因此,可以利用远程镜像VLAN的原理,在本地设备上创建远程源镜像组,并指定远程镜像VLAN,同时将本设备上连接数据检测设备的多个端口加入该VLAN。完成以上配置后,镜像报文在远程镜像VLAN中广播时便可以从这些端口中发送出去,实现将镜像报文输出至多个端口的需求。

表1-21 利用远程镜像VLAN实现本地镜像支持多个目的端口配置

操作

命令

说明

进入系统视图

system-view

-

创建远程源镜像组

mirroring-group group-id remote-source

必选

缺省情况下,不存在任何镜像组

为远程源镜像组配置源端口

在系统视图下配置

mirroring-group group-id mirroring-port mirroring-port-list { both | inbound | outbound }

两种方式必选其一

缺省情况下,镜像组没有源端口

在端口视图下配置

interface interface-type interface-number

[ mirroring-group group-id ] mirroring-port { both | inbound | outbound }

quit

 

为远程源镜像组配置反射端口

mirroring-group group-id reflector-port reflector-port

必选

缺省情况下,镜像组没有反射端口

创建远程镜像VLAN并进入VLAN视图

vlan vlan-id

必选

缺省情况下,镜像组没有远程镜像VLAN

将镜像目的端口加入远程镜像VLAN

port interface-list

必选

缺省情况下,新建VLAN中不包含任何端口

退出至系统视图

quit

-

为远程源镜像组配置远程镜像VLAN

mirroring-group group-id remote-probe vlan rprobe-vlan-id

必选

缺省情况下,镜像组没有远程镜像VLAN

 

l          镜像反射口必须是Access类型的端口,且必须属于缺省VLAN(VLAN1)。

l          建议选择设备上未使用的端口作为镜像反射口,且建议关闭反射口的STP功能。

l          一个镜像组内可以配置多个源端口。

l          请不要将源端口加入到远程镜像VLAN中,否则会影响镜像功能的正常使用。

l          在一个镜像组内,如果已经配置了镜像反射口,则无法再配置镜像出端口。

l          一个VLAN只能作为一个远程源镜像组的远程镜像VLAN,且建议该VLAN只用于端口镜像,不作其它用途。

l          远程镜像VLAN必须为静态VLAN,且在被配置成远程镜像VLAN后,该VLAN不能直接删除,必须先删除远程镜像VLAN的配置才能够删除这个VLAN。

l          如果镜像组生效后,远程镜像VLAN被取消,那么该镜像组将失效。

l          镜像目的端口必须是Access类型的端口。

 

1.4  配置三层远程端口镜像

1.4.1  配置任务简介

三层远程端口镜像的配置需要分别在源设备和目的设备上进行。

分别在源设备和目的设备上先创建一个本地镜像组,然后为该镜像组配置源端口/源CPU和目的端口,不同的是:

l              在源设备上,需要将源端口/源CPU指定为待监控的端口/CPU,目的端口指定为Tunnel接口;

l              在目的设备上,需要将源端口指定为Tunnel接口对应的物理端口,目的端口指定为连接数据监测设备的端口。

表1-22 三层远程端口镜像配置任务简介

配置任务

说明

详细配置

源设备上的配置

创建本地镜像组

必选

1.4.3 

配置源端口

二者至少选其一

源端口和源CPU可以只配其一,也可以都配置

1.4.4 

配置源CPU

1.4.5 

配置目的端口

必选

1.4.6 

目的设备上的配置

创建本地镜像组

必选

1.4.3 

配置源端口

必选

1.4.4 

配置目的端口

必选

1.4.6 

 

在H3C CE3000-32F-EI交换机上,可以通过将一个端口配置为多个镜像组的源端口,实现将通过该端口的数据镜像至多个目的端口。其中,对源端口的单向数据进行镜像需要占用一个镜像资源,对源端口的双向数据进行镜像需要占用两个镜像资源,CE3000-32F-EI交换机对一个源端口最多分配四个镜像资源。即一个端口作为单向源端口最多可以加入四个镜像组,作为双向源端口最多可以加入两个镜像组,或者以一个双向源端口和两个单向源端口的形式加入三个镜像组。

 

源端口不能再被用作本镜像组或其它镜像组的出端口或目的端口。

 

1.4.2  配置准备

在配置三层远程端口镜像之前,需要先完成GRE隧道的配置。

1.4.3  创建本地镜像组

请分别在源设备和目的设备上进行如下配置。

表1-23 创建本地镜像组

操作

命令

说明

进入系统视图

system-view

-

创建本地镜像组

mirroring-group group-id local

必选

缺省情况下,不存在任何镜像组

 

1.4.4  配置源端口

在源设备上,请将源端口指定为待监控的端口;而在目的设备上,请将源端口指定为Tunnel接口对应的物理端口。

可以在系统视图下为指定镜像组配置一个或多个源端口,也可以在端口视图下将当前端口配置为指定镜像组的源端口,二者的配置效果相同。

1. 在系统视图下配置源端口

表1-24 在系统视图下配置源端口

操作

命令

说明

进入系统视图

system-view

-

为本地镜像组配置源端口

mirroring-group group-id mirroring-port mirroring-port-list { both | inbound | outbound }

必选

缺省情况下,镜像组没有源端口

 

2. 在端口视图下配置源端口

表1-25 在端口视图下配置源端口

操作

命令

说明

进入系统视图

system-view

-

进入端口视图

interface interface-type interface-number

-

配置本端口为本地镜像组的源端口

[ mirroring-group group-id ] mirroring-port { both | inbound | outbound }

必选

缺省情况下,端口不是任何镜像组的源端口

 

一个镜像组内可以配置多个源端口。

 

1.4.5  配置源CPU

表1-26 配置源CPU

操作

命令

说明

进入系统视图

system-view

-

为本地镜像组配置源CPU

mirroring-group group-id mirroring-cpu slot slot-number-list { both | inbound | outbound }

必选

缺省情况下,镜像组没有源CPU

 

一个镜像组内可以配置多个源CPU。

 

1.4.6  配置目的端口

在源设备上,请将目的端口指定为Tunnel接口;而在目的设备上,请将目的端口指定为连接数据监测设备的端口。

可以在系统视图下为指定镜像组配置目的端口,也可以在端口/Tunnel接口视图下将当前端口/Tunnel接口配置为指定镜像组的目的端口,二者的配置效果相同。

1. 在系统视图下配置目的端口

表1-27 在系统视图下配置目的端口

操作

命令

说明

进入系统视图

system-view

-

为本地镜像组配置目的端口

mirroring-group group-id monitor-port monitor-port-id

必选

缺省情况下,镜像组没有目的端口

 

2. 在端口视图下配置目的端口

表1-28 在端口视图下配置目的端口

操作

命令

说明

进入系统视图

system-view

-

进入端口/Tunnel接口视图

interface interface-type interface-number

-

配置本端口/Tunnel接口为本地镜像组的目的端口

[ mirroring-group group-id ] monitor-port

必选

缺省情况下,端口/Tunnel接口不是任何镜像组的目的端口

 

l          一个镜像组内只能配置一个目的端口。

l          请不要在目的端口上使能STP、MSTP和RSTP,否则会影响镜像功能的正常使用。

l          目的端口收到的报文包括复制自源端口的报文和来自其它端口的正常转发报文。为了保证数据监测设备只对源端口的报文进行分析,请将目的端口只用于端口镜像,不作其它用途。

l          镜像组的目的端口不能配置为已经接入RRPP环的端口。

 

1.5  端口镜像显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后镜像组的运行情况,通过查看显示信息验证配置的效果。

表1-29 端口镜像显示和维护

操作

命令

显示镜像组的配置信息

display mirroring-group { group-id | all | local | remote-destination | remote-source } [ | { begin | exclude | include } regular-expression ]

 

1.6  端口镜像典型配置举例

1.6.1  本地端口镜像配置举例

1. 组网需求

l              Device A通过端口GigabitEthernet1/0/1和GigabitEthernet1/0/2分别连接市场部和技术部,并通过端口GigabitEthernet1/0/3连接Server。

l              通过配置源端口方式的本地端口镜像,使Server可以监控所有进、出市场部和技术部的报文。

2. 组网图

图1-4 本地端口镜像配置组网图

 

 

3. 配置步骤

(1)        配置本地镜像组

# 创建本地镜像组1。

<DeviceA> system-view

[DeviceA] mirroring-group 1 local

# 配置本地镜像组1的源端口为GigabitEthernet1/0/1和GigabitEthernet1/0/2,目的端口为GigabitEthernet1/0/3。

[DeviceA] mirroring-group 1 mirroring-port gigabitethernet 1/0/1 gigabitethernet 1/0/2 both

[DeviceA] mirroring-group 1 monitor-port gigabitethernet 1/0/3

# 在目的端口GigabitEthernet1/0/3上关闭生成树协议。

[DeviceA] interface gigabitethernet 1/0/3

[DeviceA-GigabitEthernet1/0/3] undo stp enable

[DeviceA-GigabitEthernet1/0/3] quit

(2)        检验配置效果

# 显示所有镜像组的配置信息。

[DeviceA] display mirroring-group all

mirroring-group 1:

    type: local

    status: active

    mirroring port:

        GigabitEthernet1/0/1  both

        GigabitEthernet1/0/2  both

    mirroring CPU:

    monitor port: GigabitEthernet1/0/3  

配置完成后,用户可以通过Server监控所有进、出市场部和技术部的报文。

1.6.2  二层远程端口镜像配置举例

1. 组网需求

l              在一个二层网络中,Device A通过端口GigabitEthernet1/0/1连接市场部,并通过Trunk端口GigabitEthernet1/0/2与Device B的Trunk端口GigabitEthernet1/0/1相连;Device C通过端口GigabitEthernet1/0/2连接Server,并通过Trunk端口GigabitEthernet1/0/1与Device B的Trunk端口GigabitEthernet1/0/2相连。

l              通过配置远程端口镜像,使Server可以穿越二层网络监控所有进、出市场部的报文。

2. 组网图

图1-5 二层远程端口镜像配置组网图

 

 

3. 配置步骤

(1)        配置Device A

# 创建远程源镜像组1。

<DeviceA> system-view

[DeviceA] mirroring-group 1 remote-source

# 创建VLAN 2作为远程镜像VLAN。

[DeviceA] vlan 2

# 关闭远程镜像VLAN的MAC地址学习功能

[DeviceA-vlan2] mac-address mac-learning disable

[DeviceA-vlan2] quit

# 配置远程源镜像组1的远程镜像VLAN为VLAN 2,源端口为GigabitEthernet1/0/1,出端口为GigabitEthernet1/0/2。

[DeviceA] mirroring-group 1 remote-probe vlan 2

[DeviceA] mirroring-group 1 mirroring-port gigabitethernet 1/0/1 both

[DeviceA] mirroring-group 1 monitor-egress gigabitethernet 1/0/2

# 配置出端口GigabitEthernet1/0/2为Trunk口,允许VLAN 2的报文通过,并在该端口上关闭生成树协议。

[DeviceA] interface gigabitethernet 1/0/2

[DeviceA-GigabitEthernet1/0/2] port link-type trunk

[DeviceA-GigabitEthernet1/0/2] port trunk permit vlan 2

[DeviceA-GigabitEthernet1/0/2] undo stp enable

[DeviceA-GigabitEthernet1/0/2] quit

(2)        配置Device B

# 创建VLAN 2作为远程镜像VLAN。

<DeviceB> system-view

[DeviceB] vlan 2

# 关闭远程镜像VLAN的MAC地址学习功能

[DeviceB-vlan2] mac-address mac-learning disable

[DeviceB-vlan2] quit

# 配置端口GigabitEthernet1/0/1为Trunk口,并允许VLAN 2的报文通过。

<DeviceB> system-view

[DeviceB] interface gigabitethernet 1/0/1

[DeviceB-GigabitEthernet1/0/1] port link-type trunk

[DeviceB-GigabitEthernet1/0/1] port trunk permit vlan 2

[DeviceB-GigabitEthernet1/0/1] quit

# 配置端口GigabitEthernet1/0/2为Trunk口,并允许VLAN 2的报文通过。

[DeviceB-GigabitEthernet1/0/1] quit

[DeviceB] interface gigabitethernet 1/0/2

[DeviceB-GigabitEthernet1/0/2] port link-type trunk

[DeviceB-GigabitEthernet1/0/2] port trunk permit vlan 2

[DeviceB-GigabitEthernet1/0/2] quit

(3)        配置Device C

# 配置端口GigabitEthernet1/0/1为Trunk口,并允许VLAN 2的报文通过。

<DeviceC> system-view

[DeviceC] interface gigabitethernet 1/0/1

[DeviceC-GigabitEthernet1/0/1] port link-type trunk

[DeviceC-GigabitEthernet1/0/1] port trunk permit vlan 2

[DeviceC-GigabitEthernet1/0/1] quit

# 创建远程目的镜像组1。

[DeviceC] mirroring-group 1 remote-destination

# 创建VLAN 2作为远程镜像VLAN。

[DeviceC] vlan 2

# 关闭远程镜像VLAN的MAC地址学习功能

[DeviceA-vlan2] mac-address mac-learning disable

[DeviceA-vlan2] quit

# 配置远程目的镜像组1的远程镜像VLANVLAN 2,目的端口为GigabitEthernet1/0/2,在该端口上关闭生成树协议并将其加入VLAN 2

[DeviceC] mirroring-group 1 remote-probe vlan 2

[DeviceC] interface gigabitethernet 1/0/2

[DeviceC-GigabitEthernet1/0/2] mirroring-group 1 monitor-port

[DeviceC-GigabitEthernet1/0/2] undo stp enable

[DeviceC-GigabitEthernet1/0/2] port access vlan 2

[DeviceC-GigabitEthernet1/0/2] quit

(4)        检验配置效果

配置完成后,用户可以通过Server监控所有进、出市场部的报文。

1.6.3  利用远程镜像VLAN实现本地镜像支持多个目的端口典型配置举例

1. 组网需求

三个部门A、B、C分别使用GigabitEthernet1/0/1~GigabitEthernet1/0/3端口接入SwitchA,现要求通过镜像功能,使三台数据检测设备ServerA、ServerB、ServerC都能够对三个部门发送和接收的报文进行镜像。

2. 组网图

图1-6 利用远程镜像VLAN实现本地镜像支持多个目的端口配置组网图

3. 配置步骤

# 创建远程源镜像组1。

<SwitchA> system-view

[SwitchA] mirroring-group 1 remote-source

# 将接入部门A、B、C的三个端口配置为远程源镜像组1的源端口。

[SwitchA] mirroring-group 1 mirroring-port gigabitethernet 1/0/1 to gigabitethernet 1/0/3 both

# 将设备上任意未使用的端口(此处以GigabitEthernet1/0/5为例)配置为镜像组1的反射口,关闭该端口上的STP功能。

[SwitchA] mirroring-group 1 reflector-port GigabitEthernet 1/0/5

[SwitchA] interface GigabitEthernet 1/0/5

[SwitchA-GigabitEthernet1/0/5] undo stp enable

# 创建VLAN10作为镜像组1的远程镜像VLAN,并将接入三台数据检测设备的端口加入VLAN10。

[SwitchA] vlan 10

[SwitchA-vlan10] port gigabitethernet 1/0/11 to gigabitethernet 1/0/13

[SwitchA-vlan10] quit

# 配置VLAN10作为镜像组1的远程镜像VLAN。

[SwitchA] mirroring-group 1 remote-probe vlan 10

1.6.4  三层远程端口镜像配置举例

1. 组网需求

l              在一个三层网络中,Device A通过端口GigabitEthernet1/0/1连接市场部,并通过端口GigabitEthernet1/0/2与Device B的端口GigabitEthernet1/0/1相连;Device C通过端口GigabitEthernet1/0/2连接Server,并通过端口GigabitEthernet1/0/1与Device B的端口GigabitEthernet1/0/2相连。

l              通过配置远程端口镜像,使Server可以通过GRE隧道穿越三层网络监控所有进、出市场部的报文。

2. 组网图

图1-7 三层远程端口镜像配置组网图

 

 

3. 配置步骤

(1)        配置IP地址

请按照图1-7配置VLAN,并将相应端口加入VLAN,配置各接口的IP地址和子网掩码,具体配置过程略。

(2)        配置Device A

# 创建接口Tunnel0,并为其配置IP地址和掩码。

<DeviceA> system-view

[DeviceA] interface tunnel 0

[DeviceA-Tunnel0] ip address 50.1.1.1 24

# 配置Tunnel0接口采用GRE隧道模式,并为该接口指定源地址和目的地址。

[DeviceA-Tunnel0] tunnel-protocol gre

[DeviceA-Tunnel0] source 20.1.1.1

[DeviceA-Tunnel0] destination 30.1.1.2

[DeviceA-Tunnel0] quit

# 创建并配置业务环回组1,服务类型为tunnel

[DeviceA] service-loopback group 1 type tunnel

# 将设备上的任意端口(此处以GigabitEthernet1/0/3为例)加入业务环回组1。

[DeviceA] interface GigabitEthernet 1/0/3

[DeviceA-GigabitEthernet1/0/3] undo stp enable

[DeviceA-GigabitEthernet1/0/3] port service-loopback group 1

# 在Tunnel接口视图下指定隧道引用的业务环回组1。

[DeviceA-GigabitEthernet1/0/3] quit

[DeviceA] interface tunnel 0

[DeviceA-Tunnel0] service-loopback-group 1

[DeviceA-Tunnel0] quit

# 配置OSPF协议。

[DeviceA] ospf 1

[DeviceA-ospf-1] area 0

[DeviceA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255

[DeviceA-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255

[DeviceA-ospf-1-area-0.0.0.0] network 50.1.1.0 0.0.0.255

[DeviceA-ospf-1-area-0.0.0.0] quit

[DeviceA-ospf-1] quit

# 创建本地镜像组1。

[DeviceA] mirroring-group 1 local

# 配置本地镜像组1的源端口为GigabitEthernet1/0/1,目的端口为Tunnel0。

[DeviceA] mirroring-group 1 mirroring-port gigabitethernet 1/0/1 both

[DeviceA] mirroring-group 1 monitor-port tunnel 0

(3)        配置Device B

# 配置OSPF协议。

<DeviceB> system-view

[DeviceB] ospf 1

[DeviceB-ospf-1] area 0

[DeviceB-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255

[DeviceB-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255

[DeviceB-ospf-1-area-0.0.0.0] quit

[DeviceB-ospf-1] quit

(4)        配置Device C

# 创建接口Tunnel0,并为其配置IP地址和掩码。

<DeviceC> system-view

[DeviceC] interface tunnel 0

[DeviceC-Tunnel0] ip address 50.1.1.2 24

# 配置Tunnel0接口采用GRE隧道模式,并为该接口指定源地址和目的地址。

[DeviceC-Tunnel0] tunnel-protocol gre

[DeviceC-Tunnel0] source 30.1.1.2

[DeviceC-Tunnel0] destination 20.1.1.1

[DeviceC-Tunnel0] quit

# 创建并配置业务环回组1,服务类型为tunnel

[DeviceC] service-loopback group 1 type tunnel

# 将设备上的任意端口(此处以GigabitEthernet1/0/3为例)加入业务环回组1。

[DeviceC] interface GigabitEthernet 1/0/3

[DeviceC-GigabitEthernet1/0/3] undo stp enable

[DeviceC-GigabitEthernet1/0/3] port service-loopback group 1

# 在Tunnel接口视图下指定隧道引用的业务环回组1。

[DeviceC-GigabitEthernet1/0/3] quit

[DeviceC] interface tunnel 0

[DeviceC-Tunnel0] service-loopback-group 1

[DeviceC-Tunnel0] quit

# 配置OSPF协议。

[DeviceC] ospf 1

[DeviceC-ospf-1] area 0

[DeviceC-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255

[DeviceC-ospf-1-area-0.0.0.0] network 40.1.1.0 0.0.0.255

[DeviceC-ospf-1-area-0.0.0.0] network 50.1.1.0 0.0.0.255

[DeviceC-ospf-1-area-0.0.0.0] quit

[DeviceC-ospf-1] quit

# 创建本地镜像组1

[DeviceC] mirroring-group 1 local

# 配置本地镜像组1的源端口为GigabitEthernet1/0/1,目的端口为GigabitEthernet1/0/2,关闭目的端口上的STP功能。

[DeviceC] mirroring-group 1 mirroring-port gigabitethernet 1/0/1 inbound

[DeviceC] mirroring-group 1 monitor-port gigabitethernet 1/0/2

[DeviceC] interface gigabitethernet 1/0/2

[DeviceC-GigabitEthernet1/0/2] undo stp enable

(5)        检验配置效果

配置完成后,用户可以通过Server监控所有进、出市场部的报文。


2 流镜像配置

本章中提到的三层以太网端口是指工作模式被配置成三层模式的以太网端口,有关以太网端口工作模式切换的操作,请参见“二层技术-以太网交换配置指导”中的“以太网端口配置”部分。

 

2.1  流镜像简介

流镜像,即将指定的报文复制到用户指定的目的地,用于报文的分析和监视。

流镜像分为两种:流镜像到端口、流镜像到CPU。

l              流镜像到端口:将端口接收或发送的符合要求的报文复制一份并转发到目的端口。

l              流镜像到CPU:将端口接收或发送的符合要求的报文复制一份并转发到CPU,这里的CPU指的是配置了流镜像的源端口所在设备上的CPU。

2.2  配置流镜像

配置流镜像时,用户首先要有一个已经存在的流行为,然后进入流行为视图进行流镜像的相关配置。

在配置流镜像动作时,同一个流行为中流镜像类型只能为流镜像到端口和流镜像到CPU中的一种。

 

2.2.1  配置流镜像到端口

表2-1 配置流镜像到端口

操作

命令

说明

进入系统视图

system-view

-

定义类并进入类视图

traffic classifier tcl-name [ operator { and | or } ]

必选

缺省情况下,不存在任何流分类

定义匹配数据包的规则

if-match match-criteria

必选

缺省情况下,流分类中不存在任何报文匹配规则

退出类视图

quit

-

进入流行为视图

traffic behavior behavior-name

必选

缺省情况下,不存在任何流行为

为流行为配置流镜像目的端口

mirror-to interface interface-type interface-number

必选

缺省情况下,流行为中未配置任何流镜像

目的端口既可以是二层以太网端口,也可以是三层以太网端口

通过重复执行该命令,在一个流行为中可以配置多个流镜像目的端口,镜像报文将同时从这些端口中发送出去

CE3000-32F-EI交换机最多支持配置4个目的端口

退出流行为视图

quit

-

定义策略并进入策略视图

qos policy policy-name

必选

缺省情况下,不存在任何策略

在策略中为类指定采用的流行为

classifier tcl-name behavior behavior-name

必选

缺省情况下,没有为流分类指定采用的流行为

退出策略视图

quit

-

应用QoS策略

请参见2.2.3  应用QoS策略

必选

 

2.2.2  配置流镜像到CPU

表2-2 配置流镜像到CPU

操作

命令

说明

进入系统视图

system-view

-

定义类并进入类视图

traffic classifier tcl-name [ operator { and | or } ]

必选

缺省情况下,不存在任何流分类

定义匹配数据包的规则

if-match match-criteria

必选

缺省情况下,流分类中不存在任何报文匹配规则

退出类视图

quit

-

进入流行为视图

traffic behavior behavior-name

必选

缺省情况下,不存在任何流行为

为流行为配置流镜像到CPU

mirror-to cpu

必选

缺省情况下,流行为中未配置任何流镜像

退出流行为视图

quit

-

定义策略并进入策略视图

qos policy policy-name

必选

缺省情况下,不存在任何策略

在策略中为类指定采用的流行为

classifier tcl-name behavior behavior-name

必选

缺省情况下,没有为流分类指定采用的流行为

退出策略视图

quit

-

应用QoS策略

请参见2.2.3  应用QoS策略

必选

 

2.2.3  应用QoS策略

有关应用QoS策略的详细介绍,请参见“ACL和QoS配置指导”中的“QoS配置方式”。

 

1. 基于端口应用

将QoS策略应用到某端口,可以方便对该端口上的流量进行管理。一个QoS策略可以应用于多个端口,而端口在出/入的每个方向上只能应用一个QoS策略。

表2-3 基于端口应用

操作

命令

说明

进入系统视图

system-view

-

进入二层以太网端口、三层以太网端口或端口组视图视图

进入二层以太网端口视图或三层以太网端口视图

interface interface-type interface-number

二者必选其一

端口视图下的配置只对当前端口生效;端口组视图下的配置将对端口组中的所有端口生效

进入端口组视图

port-group manual port-group-name

应用QoS策略到端口

qos apply policy policy-name { inbound | outbound }

必选

 

有关qos apply policy命令的详细介绍,请参见“ACL和QoS命令参考”中的“QoS策略配置命令”。

 

2. 基于VLAN应用

将QoS策略应用到某VLAN,可以方便对该VLAN内的所有流量进行管理。

表2-4 基于VLAN应用

操作

命令

说明

进入系统视图

system-view

-

应用QoS策略到指定VLAN

qos vlan-policy policy-name vlan vlan-id-list { inbound | outbound }

必选

 

有关qos vlan-policy命令的详细介绍,请参见“ACL和QoS命令参考”中的“QoS策略配置命令”。

 

3. 基于全局应用

将QoS策略应用到全局,可以方便对设备上的所有流量进行管理。

表2-5 基于全局应用

操作

命令

说明

进入系统视图

system-view

-

应用QoS策略到全局

qos apply policy policy-name global { inbound | outbound }

必选

 

有关qos apply policy命令的详细介绍,请参见“ACL和QoS命令参考”中的“QoS策略配置命令”。

 

2.3  流镜像显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后流镜像的运行情况,通过查看显示信息验证配置的效果。

表2-6 流镜像显示和维护

操作

命令

显示用户自定义流行为的配置内容

display traffic behavior user-defined [ behavior-name ] [ | { begin | exclude | include } regular-expression ]

显示用户自定义策略的配置内容

display qos policy user-defined [ policy-name [ classifier tcl-name ] ] [ | { begin | exclude | include } regular-expression ]

 

2.4  流镜像典型配置举例

2.4.1  流镜像到端口配置举例

1. 组网需求

用户网络描述如下:

l              Host A(IP地址为192.168.0.1)和Host B通过端口GigabitEthernet 1/0/1接入交换机Switch。

l              Server接在Switch的GigabitEthernet1/0/2端口上。

需求为:通过Server对Host A发出的所有报文进行分析监控。

2. 组网图

图2-1 配置流镜像到端口组网图

 

3. 配置步骤

# 进入系统视图。

<Sysname> system-view

# 配置基本IPv4 ACL 2000,匹配源IP地址为192.168.0.1的报文。

[Sysname] acl number 2000

[Sysname-acl-basic-2000] rule permit source 192.168.0.1 0

[Sysname-acl-basic-2000] quit

# 配置流分类规则,使用基本IPv4 ACL 2000进行流分类。

[Sysname] traffic classfier 1

[Sysname-classifier-1] if-match acl 2000

[Sysname-classifier-1] quit

# 配置流行为,定义流镜像到GigabitEthernet 1/0/2的动作。

[Sysname] traffic behavior 1

[Sysname-behavior-1] mirror-to interface GigabitEthernet 1/0/2

[Sysname-behavior-1] quit

# 配置QoS策略1,为流分类1指定流行为1。

[Sysname] qos policy 1

[Sysname-policy-1] classifier 1 behavior 1

[Sysname-policy-1] quit

# 将QoS策略应用到端口GigabitEthernet 1/0/1上。

[Sysname] interface GigabitEthernet 1/0/1

[Sysname-GigabitEthernet1/0/1] qos apply policy 1 inbound

完成上述配置后,用户可以在数据监测设备上对Host A发出的所有报文进行分析监控。

 

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!