选择区域语言: EN CN HK

03 二层技术-以太网交换配置指导

10-QinQ配置

本章节下载  (356.64 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/CE3000/CE3000-EI/Configure/Operation_Manual/H3C_CE3000-32F-EI_CG-Release_1211-6W100/03/201107/721360_30005_0.htm

10-QinQ配置


1 QinQ配置

1.1  QinQ简介

QinQ是802.1Q in 802.1Q的简称,它是基于IEEE 802.1Q技术的一种二层隧道协议,通过将用户的私网报文封装上外层VLAN Tag,使其携带两层VLAN Tag穿越运营商的骨干网络(又称公网),从而为用户提供了一种比较简单的二层VPN隧道技术,也使运营商能够利用一个VLAN为包含多个VLAN的用户网络提供服务成为了可能。

1.1.1  QinQ的产生背景和优点

在IEEE 802.1Q定义的VLAN Tag域只有12个比特,最多可以表示4094个VLAN。但在实际应用中,尤其是在城域网中,需要大量的VLAN来隔离用户,4094个VLAN远远不能满足需求。

QinQ使整个网络最多可提供4094×4094个VLAN,从而满足了城域网对VLAN数量的需求。它具备以下优点:

l              缓解公网VLAN ID资源日益紧缺的问题。

l              用户可以规划自己的私网VLAN ID,不会导致与公网VLAN ID冲突。

l              为小型城域网和企业网提供了一种简单、灵活的二层VPN解决方案。

l              当运营商升级网络时,用户网络不必更改原有配置,使用户网络具有了较强的独立性。

1.1.2  QinQ的实现原理

在公网的传输过程中,设备只根据外层VLAN Tag转发报文,并将报文的源MAC地址表项学习到外层VLAN Tag所在VLAN的MAC地址表中,而用户的私网VLAN Tag将被当作报文的数据部分进行传输。

图1-1 QinQ典型应用组网图

 

图1-1所示,用户网络A和B的私网VLAN分别为VLAN 1~10和VLAN 1~20。运营商为用户网络A和B分配的VLAN分别为VLAN 3和VLAN 4。当用户网络A和B中带VLAN Tag的报文进入运营商网络时,报文外面就会被分别封装上VLAN 3和VLAN 4的VLAN Tag。这样,来自不同用户网络的报文在运营商网络中传输时被完全分开,即使这些用户网络各自的VLAN范围存在重叠,在运营商网络中传输时也不会产生冲突。

1.1.3  QinQ的报文结构

图1-2所示,QinQ报文在运营商网络中传输时带有双层VLAN Tag:

l              内层VLAN Tag:为用户的私网VLAN Tag;

l              外层VLAN Tag:为运营商分配给用户的公网VLAN Tag。

图1-2 QinQ的报文结构

 

一般情况下,以太网帧的最大长度为1500字节。设备每为报文加上一层VLAN Tag,报文长度将增加4个字节,因此建议用户确认QinQ报文的传输路径上的所有设备均允许长度至少为1508字节的报文(带有双层VLAN Tag)通过。

 

1.1.4  QinQ的实现方式

QinQ的实现方式可分为以下两种:

1. 基本QinQ

基本QinQ是基于端口方式实现的。当端口上配置了基本QinQ功能后,不论从该端口收到报文是否带有VLAN Tag,设备都会为该报文打上本端口缺省VLAN的Tag:

l              如果收到的是带有VLAN Tag的报文,该报文就成为带双Tag的报文;

l              如果收到的是不带VLAN Tag的报文,该报文就成为带有本端口缺省VLAN Tag的报文。

2. 灵活QinQ

灵活QinQ是基于端口与VLAN相结合的方式实现的,它对QinQ的功能进行了扩展,是对QinQ的一种更灵活的实现。灵活QinQ除了能实现所有基本QinQ的功能外,对于从同一个端口收到的报文,还可以根据VLAN的不同进行不同的操作,包括:

l              为具有不同内层VLAN ID的报文添加不同的外层VLAN Tag。

l              根据报文内层VLAN的802.1p优先级标记外层VLAN的802.1p优先级。

l              在添加外层VLAN Tag的同时,还可修改内层的VLAN ID。

通过使用灵活QinQ技术,在能够隔离运营商网络和用户网络的同时,又能够提供丰富的业务特性和更加灵活的组网能力。

1.1.5  VLAN Tag的TPID值可调功能

图1-3所示,是IEEE802.1Q协议定义的以太网帧的VLAN Tag结构,TPID(Tag Protocol Identifier,标签协议标识)就是VLAN Tag中的一个字段,用于表示VLAN Tag的协议类型,其缺省取值为0x8100。

图1-3 以太网帧的VLAN Tag结构

 

TPID值可以用来判断报文中是否携带有VLAN Tag,例如:在设备上配置用户VLAN Tag和运营商VLAN Tag中携带的TPID值分别为0x8200和0x9100,而如果收到的报文实际携带的内、外层VLAN Tag的TPID值分别为0x8100和0x9100,设备就会认为该报文只携带运营商VLAN Tag,而没有携带用户VLAN Tag。

第三方厂商的设备可能将QinQ报文外层VLAN Tag的TPID字段设为不同的值。为了与这些第三方厂商的设备兼容,用户可以通过修改TPID值,使发送到公网中的QinQ报文携带的TPID值与第三方厂商的相同,从而实现与这些厂商的设备互通。

由于TPID字段在以太网报文中的位置与不带VLAN Tag的报文中协议类型字段的位置相同,因此为了避免给报文转发和接收造成混乱,不允许用户将TPID值配置为表1-1中列举的常用协议类型值。

表1-1 常用协议类型值

协议类型

协议类型值

ARP

0x0806

PUP

0x0200

RARP

0x8035

IP

0x0800

IPv6

0x86DD

PPPoE

0x8863/0x8864

MPLS

0x8847/0x8848

IPX/SPX

0x8137

IS-IS

0x8000

LACP

0x8809

802.1X

0x888E

集群

0x88A7

设备保留

0xFFFD/0xFFFE/0xFFFF

 

1.1.6  协议规范

与QinQ相关的协议规范有:

l              IEEE 802.1Q:IEEE standard for local and metropolitan area networks: Virtual Bridged Local Area Networks

1.2  QinQ配置任务简介

表1-2 QinQ配置任务简介

配置任务

说明

详细配置

配置基本QinQ功能

使能基本QinQ功能

必选

1.3.1 

配置VLAN透传功能

可选

1.3.2 

配置灵活QinQ功能

配置外层VLAN Tag的添加策略

可选

1.4.1 

配置内、外层VLAN Tag中802.1p优先级的映射关系

可选

1.4.2 

配置内层VLAN ID替换关系

可选

1.4.3 

配置VLAN Tag中携带的TPID值

可选

1.5 

 

l          QinQ功能只需在运营商网络进行配置,用户网络不需进行配置。

l          对于QinQ的相关配置来说,以太网端口视图下的配置只对当前端口有效;二层聚合接口视图下的配置对当前聚合接口及其所对应聚合组中的所有成员端口都有效;端口组视图下的配置对当前端口组中的所有端口有效。

l          基本QinQ和灵活QinQ功能都应在连接用户网络的二层以太网端口上进行配置。

 

1.3  配置基本QinQ功能

1.3.1  使能基本QinQ功能

使能了基本QinQ功能的端口将为其收到的报文添加新的VLAN Tag,该VLAN Tag即该端口缺省VLAN的Tag。

表1-3 使能基本QinQ功能

操作

命令

说明

进入系统视图

system-view

-

进入相应视图

进入二层以太网端口视图或二层聚合接口视图

interface interface-type interface-number

二者必选其一

进入端口组视图

port-group manual port-group-name

使能端口的基本QinQ功能

qinq enable

必选

缺省情况下,端口的基本QinQ功能处于关闭状态

 

1.3.2  配置VLAN透传功能

端口上使能了基本QinQ功能后,从该端口收到的报文就会被打上本端口缺省VLAN的Tag。而VLAN透传功能则可使端口在收到带有指定VLAN Tag的报文后,不为其添加外层VLAN Tag而直接在运营商网络中传输。

表1-4 配置VLAN透传功能

操作

命令

说明

进入系统视图

system-view

-

进入相应视图

进入二层以太网端口视图或二层聚合接口视图

interface interface-type interface-number

二者必选其一

进入端口组视图

port-group manual port-group-name

配置端口的VLAN透传功能

qinq transparent-vlan vlan-list

必选

缺省情况下,端口没有配置VLAN透传功能

 

l          配置VLAN透传功能时,还需在报文传输路径的所有设备上都配置允许透传的VLAN通过。

l          配置了端口对指定VLAN的报文进行透传后,请勿在该端口上对这些VLAN再进行VLAN映射的相关配置。有关VLAN映射的相关介绍,请参见“二层技术-以太网交换配置指导”中的“VLAN映射配置”。

 

1.4  配置灵活QinQ功能

1.4.1  配置外层VLAN Tag的添加策略

基本QinQ功能添加的外层VLAN Tag是端口缺省VLAN的Tag,灵活的QinQ功能则可以为不同的内层VLAN Tag添加不同的外层VLAN Tag。本交换机的灵活QinQ功能通过QoS策略的方式实现,通过配置匹配报文原有VLAN Tag的流分类和封装外层VLAN Tag的流行为,并将其在QoS策略中进行关联,然后应用到连接用户的端口,即可以实现根据报文内层VLAN封装外层VLAN Tag的功能。

表1-5 配置外层VLAN Tag的添加策略

操作

命令

说明

进入系统视图

system-view

-

创建类并进入类视图

traffic classifier classifier-name [ operator { and | or } ]

必选

缺省情况下,类视图下各规则之间的关系为and,即逻辑与

配置匹配报文的规则,即指定报文的内层VLAN ID

if-match customer-vlan-id vlan-id-list

必选

退出至系统视图

quit

-

创建流行为并进入流行为视图

traffic behavior behavior-name

必选

定义流行为,即指定为报文封装的外层VLAN ID

nest top-most vlan-id vlan-id

必选

定义流行为,统计QinQ报文的数量

accounting { byte | packet }

可选

通过报文统计的流行为动作,用户可以针对某些带有双层VLAN Tag的QinQ报文进行统计,以便了解特定报文的流量变化,从而更有针对性的优化网络传输策略。

byte表示报文基于字节为单位进行统计;packet表示报文基于包为单位进行统计

退出至系统视图

quit

-

创建QoS策略并进入QoS策略视图

qos policy policy-name

必选

将之前定义的流分类和指定的流行为进行绑定,组成QoS策略

classifier classifier-name  behavior behavior-name

必选

退出至系统视图

quit

-

进入连接用户的二层以太网端口视图或端口组视图

进入二层以太网端口视图

interface interface-type interface-number

二者必选其一

进入二层以太网端口后,下面进行的配置只在当前端口生效;进入端口组视图后,下面进行的配置将在端口组中的所有端口生效

进入端口组视图

port-group manual port-group-name

开启端口的基本QinQ功能

qinq enable

必选

在端口的入方向应用QoS策略

qos apply policy policy-name inbound

必选

 

l          当配置了灵活QinQ的端口接收到报文时,满足灵活QinQ配置的报文将按灵活QinQ处理,不满足灵活QinQ配置的报文将按基本QinQ处理。

l          关于QoS策略的更多详细信息,请参见“ACL和QoS配置指导”中的“QoS配置方式”部分。

 

1.4.2  配置内、外层VLAN Tag中802.1p优先级的映射关系

本交换机可以通过QoS策略来实现以下两种内、外层VLAN Tag的802.1p优先级映射功能:

l              根据内层802.1p优先级或内层VLAN ID来标记外层VLAN Tag中的802.1p优先级

l              将内层802.1p优先级复制到外层VLAN Tag中的802.1p优先级

如果在开启了QinQ或灵活QinQ的端口上配置了优先级信任模式为信任报文的802.1p优先级,则端口在为报文封装外层VLAN Tag时,会自动将内层VLAN Tag的802.1p优先级复制到外层VLAN Tag中。有关优先级信任模式的配置,请参见“ACL和QoS配置指导”中的“优先级映射配置”。

 

表1-6 根据内层802.1p优先级或内层VLAN ID来标记外层VLAN Tag中的802.1p优先级

操作

命令

说明

进入系统视图

system-view

-

创建类并进入类视图

traffic classifier classifier-name [ operator { and | or } ]

必选

缺省情况下,类视图下各规则之间的关系为and,即逻辑与

配置匹配报文的规则

配置内层VLAN作为匹配规则

if-match customer-vlan-id vlan-id-list

二者选其一

配置内层标签优先级作为匹配规则

if-match customer-dot1p 8021p-list

退出至系统视图

quit

-

创建流行为并进入流行为视图

traffic behavior behavior-name

必选

定义流行为,即指定报文外层标签的优先级

重标记外层VLAN Tag中的802.1p优先级

remark dot1p 8021p

二者必选其一

用户可以根据需要选择不同的动作,实现内外层802.1p优先级的映射或复制功能

将内层802.1p优先级复制到外层VLAN Tag中的802.1p优先级

remark dot1p customer-dot1p-trust

退出至系统视图

quit

-

创建QoS策略并进入QoS策略视图

qos policy policy-name

必选

将之前定义的流分类和指定的流行为进行绑定,组成QoS策略

classifier classifier-name  behavior behavior-name

必选

退出至系统视图

quit

-

进入连接用户网络的二层以太网端口视图或端口组视图

进入二层以太网端口视图

interface interface-type interface-number

二者必选其一

进入二层以太网端口后,下面进行的配置只在当前端口生效;进入端口组视图后,下面进行的配置将在端口组中的所有端口生效

进入端口组视图

port-group manual port-group-name

开启端口的基本QinQ功能

qinq enable

必选

在端口的入方向应用QoS策略

qos apply policy policy-name inbound

必选

 

1.4.3  配置内层VLAN ID替换关系

基本QinQ功能在对用户VLAN报文添加外层VLAN Tag时,默认情况下不会对用户报文的内层VLAN ID做修改。灵活QinQ功能可以配置内层VLAN ID替换功能,可以在添加外层Tag的同时对内层的VLAN ID进行修改。

表1-7 配置内层VLAN ID替换

操作

命令

说明

进入系统视图

system-view

-

创建类并进入类视图

traffic classifier classifier-name [ operator { and | or } ]

必选

缺省情况下,类视图下各规则之间的关系为and,即逻辑与

配置匹配报文的规则,即指定报文的原始内层VLAN ID

if-match customer-vlan-id vlan-id-list

必选

退出至系统视图

quit

-

创建流行为并进入流行为视图

traffic behavior behavior-name

必选

定义流行为,即修改报文内层VLAN ID

remark customer-vlan-id vlan-id

必选

退出至系统视图

quit

-

创建QoS策略并进入QoS策略视图

qos policy policy-name

必选

将之前定义的流分类和指定的流行为进行绑定,组成QoS策略

classifier classifier-name  behavior behavior-name

必选

退出至系统视图

quit

-

进入连接运营商网络的二层以太网端口视图或端口组视图

进入二层以太网端口视图

interface interface-type interface-number

二者必选其一

进入二层以太网端口后,下面进行的配置只在当前端口生效;进入端口组视图后,下面进行的配置将在端口组中的所有端口生效

进入端口组视图

port-group manual port-group-name

在端口的出方向应用QoS策略

qos apply policy policy-name outbound

必选

 

1.5  配置VLAN Tag中携带的TPID值

1.5.1  配置用户网络的TPID

表1-8 配置用户网络的TPID值

操作

命令

说明

进入系统视图

system-view

-

配置VLAN Tag中携带的TPID值

qinq ethernet-type customer-tag hex-value

可选

缺省情况下,用户网络的TPID值为0x8100

 

1.5.2  配置运营商网络的TPID

表1-9 配置运营商网络的TPID值

操作

命令

说明

进入系统视图

system-view

-

进入相应视图

进入二层以太网端口视图

interface interface-type interface-number

二者必选其一

进入端口组视图

port-group manual port-group-name

配置VLAN Tag中携带的TPID值

qinq ethernet-type service-tag hex-value

可选

缺省情况下,运营商网络的TPID值为0x8100

 

l          对于没有开启基本QinQ功能和用户侧QinQ功能的端口,交换机将根据端口上的运营商网络TPID值来判断接收到的报文是否携带VLAN Tag;对于开启了QinQ功能或用户侧QinQ功能的端口,交换机将根据全局配置的用户网络TPID值来判断接收到的报文是否携带VLAN Tag。

l          关于用户侧QinQ功能的介绍,请参见“二层技术-以太网交换配置指导”中的“VLAN映射配置”。

l          运营商网络中的TPID值和QinQ功能不能在端口上同时配置。

 

1.6  QinQ典型配置举例

1.6.1  基本QinQ配置举例

1. 组网需求

l              Provider A和Provider B为运营商网络的边缘设备,二者通过Trunk口相连,且都属于运营商网络的VLAN 10和VLAN 50;Customer A1、Customer A2、Customer B1和Customer B2分别为CustomerA和CustomerB的用户网络边缘设备。

l              Provider A和Provider B之间采用了第三方厂商的设备,TPID值为0x8200。

希望配置完成后达到下列要求:

l              Customer A1与Customer A2之间传输的VLAN 200~299内的报文可以通过运营商网络的VLAN 10实现互通。

l              Customer B1与Customer B2之间传输的VLAN 250~350内的报文可以通过运营商网络的VLAN 50实现互通。

2. 组网图

图1-4 基本QinQ配置组网图

3. 配置步骤

用户必须通过配置保证运营商网络中的设备之间允许QinQ报文通过。

 

(1)        配置Provider A

l              配置端口GigabitEthernet1/0/1

# 配置端口的缺省VLAN为VLAN10,这里以端口为Access端口为例。

<ProviderA> system-view

[ProviderA] interface gigabitethernet 1/0/1

[ProviderA-GigabitEthernet1/0/1] port access vlan 10

# 使能端口的基本QinQ功能。

[ProviderA-GigabitEthernet1/0/1] qinq enable

[ProviderA-GigabitEthernet1/0/1] quit

l              配置端口GigabitEthernet1/0/2

# 配置端口的缺省VLAN为VLAN50,这里以端口为Hybrid端口为例。

[ProviderA] interface gigabitethernet 1/0/2

[ProviderA-GigabitEthernet1/0/2] port link-type hybrid

[ProviderA-GigabitEthernet1/0/2] port hybrid pvid vlan 50

[ProviderA-GigabitEthernet1/0/2] port hybrid vlan 50 untagged

# 使能端口的基本QinQ功能。

[ProviderA-GigabitEthernet1/0/2] qinq enable

[ProviderA-GigabitEthernet1/0/2] quit

l              配置端口GigabitEthernet1/0/3

# 配置端口为Trunk端口,且允许VLAN 10和VLAN50的报文通过。

[ProviderA] interface gigabitethernet 1/0/3

[ProviderA-GigabitEthernet1/0/3] port link-type trunk

[ProviderA-GigabitEthernet1/0/3] port trunk permit vlan 10 50

# 配置端口添加的外层Tag中携带的TPID值为0x8200。

[ProviderA-GigabitEthernet1/0/3] qinq ethernet-type service-tag 8200

[ProviderA-GigabitEthernet1/0/3] quit

(2)        配置Provider B

l              配置端口GigabitEthernet1/0/1

# 配置端口的缺省VLAN为VLAN50,这里以端口为Access端口为例。

<ProviderB> system-view

[ProviderB] interface gigabitethernet 1/0/1

[ProviderB-GigabitEthernet1/0/1] port access vlan 50

# 使能端口的基本QinQ功能。

[ProviderB-GigabitEthernet1/0/1] qinq enable

[ProviderB-GigabitEthernet1/0/1] quit

l              配置端口GigabitEthernet1/0/2

# 配置端口的缺省VLAN为VLAN10,这里以端口为Hybrid端口为例。

[ProviderB] interface gigabitethernet 1/0/2

[ProviderB-GigabitEthernet1/0/2] port link-type hybrid

[ProviderB-GigabitEthernet1/0/2] port hybrid pvid vlan 10

[ProviderB-GigabitEthernet1/0/2] port hybrid vlan 10 untagged

# 使能端口的基本QinQ功能。

[ProviderB-GigabitEthernet1/0/2] qinq enable

[ProviderB-GigabitEthernet1/0/2] quit

l              配置端口GigabitEthernet1/0/3

# 配置端口为Trunk端口,且允许VLAN 10和VLAN50的报文通过。

[ProviderB] interface gigabitethernet 1/0/3

[ProviderB-GigabitEthernet1/0/3] port link-type trunk

[ProviderB-GigabitEthernet1/0/3] port trunk permit vlan 10 50

# 配置端口添加的外层Tag中携带的TPID值为0x8200。

[ProviderB-GigabitEthernet1/0/3] qinq ethernet-type service-tag 8200

[ProviderB-GigabitEthernet1/0/3] quit

(3)        配置第三方厂商设备

对于Provider A与Provider B之间的第三方厂商设备,其关键配置如下:在与Provider A的端口GigabitEthernet1/0/3以及与Provider B的端口GigabitEthernet1/0/3相连接的端口上,配置其允许VLAN 10和VLAN50的报文携带VLAN Tag通过。

1.6.2  灵活QinQ配置举例

1. 组网需求

l              Provider A、Provider B作为运营商网络接入设备。

l              Customer A、Customer B、Customer C、CustomerD为用户网络接入设备。

l              Provider A、Provider B之间通过Trunk端口连接,允许运营商网络的VLAN1000、VLAN2000和VLAN3000通过。

l              Provider A和Provider B之间,运营商采用其他厂商的设备,TPID值为0x8200。

希望配置完成后达到下列要求:

l              Customer A的VLAN10的报文可以和Customer B的VLAN10的报文经过运营商网络的VLAN1000转发后互通;

l              Customer A的VLAN20的报文可以和Customer C的VLAN20的报文经过运营商网络的VLAN2000转发后互通。

l              Customer A的其余VLAN的报文可以通过运营商网络的VLAN3000转发至Customer D。

2. 组网图

图1-5 配置QinQ功能组网图

 

 

3. 配置步骤

用户必须通过配置保证运营商网络中的设备之间允许QinQ报文通过。

 

(1)        Provider A的配置

# 进入系统视图。

<ProviderA> system-view

l              GigabitEthernet1/0/1端口的配置

# 配置端口为Hybrid端口,且允许VLAN1000、VLAN2000和VLAN3000的报文通过,并且在发送时去掉外层Tag。

[ProviderA] interface gigabitethernet 1/0/1

[ProviderA-GigabitEthernet1/0/1] port link-type hybrid

[ProviderA-GigabitEthernet1/0/1] port hybrid vlan 1000 2000 3000 untagged

# 将VLAN3000配置为该端口的缺省VLAN,并配置基本QinQ功能,为接收的报文封装VLAN3000的Tag。

[ProviderA-GigabitEthernet1/0/1] port hybrid pvid vlan 3000

[ProviderA-GigabitEthernet1/0/1] qinq enable

[ProviderA-GigabitEthernet1/0/1] quit

# 创建流分类规则,将Customer A的VLAN10的报文定义为“A10”类。

[ProviderA] traffic classifier A10

[ProviderA-classifier-A10] if-match customer-vlan-id 10

[ProviderA-classifier-A10] quit

# 定义流行为,为报文封装VLAN1000的外层VLAN Tag,流行为命名为“P1000”。

[ProviderA] traffic behavior P1000

[ProviderA-behavior-P1000] nest top-most vlan-id 1000

[ProviderA-behavior-P1000] quit

# 与以上配置类似,创建流分类“A20”匹配用户VLAN ID为20的报文,并创建流行为,为此类报文封装外层VLAN2000的Tag。

[ProviderA] traffic classifier A20

[ProviderA-classifier-A20] if-match customer-vlan-id 20

[ProviderA-classifier-A20] quit

[ProviderA] traffic behavior P2000

[ProviderA-behavior-P2000] nest top-most vlan-id 2000

[ProviderA-behavior-P2000] quit

# 创建QoS策略,将流分类“A10”和流行为“P1000”进行关联,将流分类“A20”和流行为“P2000”关联,策略命名为“qinq”。

[ProviderA] qos policy qinq

[ProviderA-qospolicy-qinq] classifier A10 behavior P1000

[ProviderA-qospolicy-qinq] classifier A20 behavior P2000

[ProviderA-qospolicy-qinq] quit

# 在GigabitEthernet1/0/1端口的接收方向应用“qinq”规则。

[ProviderA] interface Gigabitethernet1/0/1

[ProviderA-GigabitEthernet1/0/1] qos apply  policy qinq inbound

l              GigabitEthernet1/0/2端口的配置

# 配置端口的缺省VLAN为VLAN1000。

[ProviderA] interface gigabitethernet 1/0/2

[ProviderA-GigabitEthernet1/0/2] port access vlan 1000

# 配置端口的基本QinQ功能,将来自VLAN10的报文封装VLAN ID为1000的外层Tag。

[ProviderA-GigabitEthernet1/0/2] qinq enable

[ProviderA-GigabitEthernet1/0/2] quit

l              GigabitEthernet1/0/3端口的配置

# 配置端口为Trunk端口,且允许VLAN1000、VLAN2000和VLAN3000的报文通过。

[ProviderA] interface gigabitethernet 1/0/3

[ProviderA-GigabitEthernet1/0/3] port link-type trunk

[ProviderA-GigabitEthernet1/0/3] port trunk permit vlan 1000 2000 3000

# 为与公共网络中的设备进行互通,配置运营商网络的TPID为0x8200,即配置端口在添加外层Tag时使用的TPID值为0x8200。

[ProviderA-GigabitEthernet1/0/3] qinq ethernet-type service-tag 8200

(2)        Provider B的配置

l              GigabitEthernet1/0/1端口的配置

# 配置端口为Trunk端口,且允许VLAN1000、VLAN2000和VLAN3000的报文通过。

<ProviderB> system-view

[ProviderB] interface gigabitethernet 1/0/1

[ProviderB-GigabitEthernet1/0/1] port link-type trunk

[ProviderB-GigabitEthernet1/0/1] port trunk permit vlan 1000 2000 3000

# 为与公共网络中的设备进行互通,配置运营商网络的TPID为0x8200,即配置端口添加外层Tag时使用的TPID值为0x8200。

[ProviderB-GigabitEthernet1/0/1] qinq ethernet-type service-tag 8200

[ProviderB-GigabitEthernet1/0/1] quit

l              GigabitEthernet1/0/2端口的配置

# 配置端口的缺省VLAN为VLAN2000。

[ProviderB] interface gigabitethernet 1/0/2

[ProviderB-GigabitEthernet1/0/2] port access vlan 2000

# 配置端口的基本QinQ功能,将来自VLAN20的报文封装VLAN ID为2000的外层Tag。

[ProviderB-GigabitEthernet1/0/2] qinq enable

[ProviderB-GigabitEthernet1/0/2] quit

l              GigabitEthernet1/0/3端口的配置

# 配置端口的缺省VLAN为VLAN3000。

[ProviderB] interface gigabitethernet 1/0/3

[ProviderB-GigabitEthernet1/0/3] port access vlan 3000

# 配置端口的基本QinQ功能,为来自所有用户VLAN的报文封装VLAN ID为3000的外层Tag。

[ProviderB-GigabitEthernet1/0/3] qinq enable

(3)        公共网络设备的配置

由于Provider A和Provider B之间使用的公共网络设备可能来自于其他厂商,这里只介绍基本原理:配置公共网络中与Provider A的GigabitEthernet1/0/3端口和Provider B的GigabitEthernet1/0/1端口连接的设备,使其相应的端口允许VLAN1000、VLAN2000和VLAN3000的报文携带VLAN Tag进行发送即可。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!