- Table of Contents
-
- 01-Fundamentals Configuration Guide
- 00-Preface
- 01-CLI configuration
- 02-RBAC configuration
- 03-Login management configuration
- 04-License management
- 05-Device management configuration
- 06-FTP and TFTP configuration
- 07-File system management configuration
- 08-RAID management configuration (security devices)
- 09-Configuration file management configuration
- 10-Software upgrade configuration
- 11-ISSU configuration
- 12-Automatic configuration
- 13-Tcl configuration
- 14-Python configuration
- Related Documents
-
Title | Size | Download |
---|---|---|
12-Automatic configuration | 139.39 KB |
Contents
Using URL-based automatic configuration
About URL-based automatic configuration
Hardware compatibility with URL-based automatic configuration
How URL-based automatic configuration works
Using USB-based automatic configuration
About USB-based automatic configuration
Preparing the USB disk for automatic configuration
Configuring and using USB-based automatic configuration
Using automatic configuration
About automatic configuration
With the automatic configuration feature, the device can automatically obtain a set of configuration settings at startup. This feature simplifies network configuration and maintenance.
Automatic configuration can be implemented by using the implementation methods in Table 1.
Table 1 Automatic configuration implementation methods
Implementation method |
Configuration file location |
Application scenarios |
URL-based automatic configuration |
Saved on the device before the device is shipped |
Devices are geographically distributed. |
USB-based automatic configuration |
USB disk |
· On a small network, the devices reside near to each other, and no host can be used as a file server. · On a large network, only a few devices require automatic configuration or configuration update. |
About automatic configuration
With the automatic configuration feature, the device can automatically obtain a set of configuration settings at startup. This feature simplifies network configuration and maintenance.
Automatic configuration can be implemented by using the implementation methods in Table 2.
Table 2 Automatic configuration implementation methods
Implementation method |
Configuration file location |
Application scenarios |
Server-based automatic configuration |
File server |
A number of geographically distributed devices need to be configured. |
URL-based automatic configuration |
Saved on the device before the device is shipped |
Devices are geographically distributed. |
USB-based automatic configuration |
USB disk |
· On a small network, the devices reside near to each other, and no host can be used as a file server. · On a large network, only a few devices require automatic configuration or configuration update. |
If both server-based automatic configuration and USB-based automatic configuration are available, the device prefers USB-based automatic configuration.
As a best practice, use SMS-based automatic configuration only if you do not have any other choices. SMS-based automatic configuration has the following disadvantages:
· High cost.
· Low reliability. Short messages depend on 3G or 4G networks. Wireless signals might be unstable.
Using URL-based automatic configuration
About URL-based automatic configuration
URL-based automatic configuration uses a customizable configuration file saved on the device by default to implement basic device configuration after the device starts up. The configuration file contains the basic network configuration command lines. This feature requires you to construct a URL to indicate the values for the parameters in the command lines. The URL can be in either of the following forms:
· Plaintext form—The user directly configures the plaintext URL. Parameters in the URL are configured and transmitted in plaintext form.
· Encrypted form—The administrator generates the encrypted URL and an authentication password for the URL by using the controller. Within the validity of the URL, a user can enter the authentication password as prompted to use the URL to perform URL-based automatic configuration.
Hardware compatibility with URL-based automatic configuration
Series |
Models |
URL-based automatic configuration compatibility |
F5000 series |
F5000-AI360, F5000-AI160, F5000-AI120, F5000-AI-40, F5000-AI-20, F5000-AI-15 |
Yes |
F5000-CN60, F5000-CN30 |
Yes |
|
F5000-CN160, F5000-CN-G85, F5000-CN-G65, F5000-CN-G55 |
No |
|
F1000 series |
F1000-AI-90, F1000-AI-80, F1000-AI-75, F1000-AI-70, F1000-AI-65, F1000-AI-60 , F1000-AI-25 |
Yes |
F1000-CN-G35 |
No |
How URL-based automatic configuration works
The basic device configuration defines how the device connects to the network. By default, the following connection modes are available: PPPoE mode, static IP address mode, and DHCP mode. The customizable configuration file contains the command lines for the connection modes. The required URL varies by connection mode.
PPPoE mode
Table 3 lists the parameters required or optional in the URL in PPPoE mode. The following is the format of the URL in PPPoE mode:
http://Device IP address/urlcfg?sys_name=Device name&link_mode=Link mode&dialer_if=Dialer interface name&ntp_server=NTP server (optional)&link_if=WAN interface&ac_host=Server IP address&ac_port=Server port&ac_password=Server password&pap_user=PPPoE PAP authentication password&pap_password=PPPoE PAP authentication password&chap_user=PPPoE CHAP authentication username&chap_password=PPPoE CHAP authentication password
Table 3 Parameters required for PPPoE mode
Item |
Parameter |
Value type |
Value range |
Corresponding command |
Required |
Device address |
Device IP address |
IP address |
N/A |
N/A |
Yes |
Device name |
sys_name |
String |
1 to 64 |
sysname sysname |
Yes |
Server address |
ac_host |
IP address |
N/A |
cloud-management server domain ip-address |
Yes |
Server port |
ac_port |
Integer |
1 to 65535 |
cloud-management server port port-number |
Yes |
Server password |
ac_password |
String |
1 to 63 |
cloud-management server password simple password |
Yes |
NTP server |
ntp_server |
IP address |
N/A |
ntp-service unicast-server ip-address |
No |
WAN interface |
link_if |
Interface type and number |
N/A |
interface interface-type interface-number |
Yes |
PPPoE connection mode |
link_mode |
String |
PPPoE |
N/A |
Yes |
PPPoE dialer interface |
dialer_if |
String |
N/A |
interface dialer number |
Yes |
PPPoE PAP authentication username |
pap_user |
String |
1 to 80 |
ppp pap local-user user-name password simple password |
Yes |
PPPoE PAP authentication password |
pap_password |
String |
1 to 255 |
ppp pap local-user user-name password simple password |
Yes |
PPPoE CHAP authentication username |
chap_user |
String |
1 to 80 |
ppp chap user user-name |
Yes |
PPPoE CHAP authentication password |
chap_password |
String |
1 to 255 |
ppp chap password simple password |
Yes |
Static IP address mode
Table 4 lists the parameters required or optional in static IP address mode. The following is the format of the URL in static IP address mode:
http://Device IP address/urlcfg?sys_name=Device name&link_mode=Link mode&ntp_server=NTP server (optional)&dest_ip=Destination IP address&dest_mask=Destination IP mask&next_hop=IP address of the next hop&link_if=WAN interface&static_ip=Static IP address&static_mask=Static IP mask&ac_host=Server address&ac_port=Server port&ac_password=Server password
Table 4 Parameters required for static IP address mode
Item |
Parameter |
Value type |
Value range |
Corresponding command |
Required |
Device address |
Device IP address |
IP address |
N/A |
N/A |
Yes |
Device name |
sys_name |
String |
1 to 64 |
sysname sysname |
Yes |
Server address |
ac_host |
IP address |
N/A |
cloud-management server domain ip-address |
Yes |
Server port |
ac_port |
Integer |
1 to 65535 |
cloud-management server port port-number |
Yes |
Server password |
ac_password |
String |
1 to 63 |
cloud-management server password simple password |
Yes |
NTP server |
ntp_server |
IP address |
N/A |
ntp-service unicast-server ip-address |
No |
Destination IP address |
dest_ip |
IP address |
N/A |
ip route-static dest-address mask next-hop-address |
Yes |
Destination IP mask |
dest_mask |
IP mask |
N/A |
ip route-static dest-address mask next-hop-address |
Yes |
IP address of the next hop |
next_hop |
IP address |
N/A |
ip route-static dest-address mask next-hop-address |
Yes |
WAN interface |
link_if |
Interface type and number |
N/A |
interface interface-type interface-number |
Yes |
Static IP address connection mode |
link_mode |
String |
STATIC |
N/A |
Yes |
Static IP address |
static_ip |
IP address |
N/A |
ip address ip-address mask |
Yes |
Static IP mask |
static_mask |
IP mask |
N/A |
ip address ip-address mask |
Yes |
Static default gateway |
gateway |
IP address |
N/A |
ip route-static 0.0.0.0 0.0.0.0 next-hop-address |
Yes |
DHCP mode
Table 5 lists the parameters required or optional in DHCP mode. The following is the format of the URL in DHCP mode:
http://Device IP address/urlcfg?sys_name=Device name&link_mode=Link mode&ntp_server=NTP server (optional)&link_if=WAN interface&ac_host=Server address&ac_port=Server port&ac_password=Server password
Table 5 Parameters required for DHCP mode
Item |
Parameter |
Value type |
Value range |
Corresponding command |
Required |
Device address |
Device IP address |
IP address |
N/A |
N/A |
Yes |
Device name |
sys_name |
String |
1 to 64 |
sysname sysname |
Yes |
Server address |
ac_host |
IP address |
N/A |
cloud-management server domain ip-address |
Yes |
Server port |
ac_port |
Integer |
1 to 65535 |
cloud-management server port port-number |
Yes |
Server password |
ac_password |
String |
1 to 63 |
cloud-management server password simple password |
Yes |
NTP server |
ntp_server |
IP address |
N/A |
ntp-service unicast-server ip-address |
No |
WAN interface |
link_if |
Interface type and number |
N/A |
interface interface-type interface-number |
Yes |
DHCP connection mode |
link_mode |
String |
DHCP |
N/A |
Yes |
Procedure
1. Power on the device.
2. Enable URL-based automatic configuration.
a. Enter system view.
system-view
b. Enable URL-based automatic configuration.
autodeploy url enable
By default, URL-based automatic configuration is enabled the state.
c. Save the current configuration.
save
If URL-based automatic configuration is disabled on a device, you must execute this command, save the configuration, and reboot the device to make this feature take effect.
3. On the configuration terminal, launch a Web browser and enter the default IP address of the device in the address bar. Then, enter the default username and password as prompted to log in to the device.
You can change the default IP address, username, and password on the device. The IP address and username are the device address and device name required in the URL.
4. Construct a URL as describe in "How URL-based automatic configuration works."
5. Enter the URL in the address bar and enter the username and password as prompted.
The device will use the parameters and values in the URL and the customizable configuration file to reconstruct a configuration file, and then execute the file to complete automatic configuration.
Configuration file
IMPORTANT: The contents of the configuration file might vary by device model. |
PPPoE mode section
{link_mode = PPPoE}
#
system-view
#
sysname [sys_name]
#
dialer-group 1 rule ip permit
#
interface Dialer1
1:ppp chap password simple [chap_password]
1:ppp chap user [chap_user]
ppp ipcp dns admit-any
ppp ipcp dns request
1:ppp pap local-user [pap_user] password simple [pap_password]
dialer bundle enable
dialer-group 1
dialer timer idle 0
dialer timer autodial 5
ip address ppp-negotiate
tcp mss 1024
nat outbound
#
quit
#
interface [link_if]
port link-mode route
pppoe-client dial-bundle-number 1
#
quit
#
1:ntp-service unicast-server [ntp_server]
#
cloud-management server domain [ac_host]
cloud-management server port [ac_port]
cloud-management server password simple [ac_password]
#
ip route-static 0.0.0.0 0 Dialer1
#
Static IP address mode section
{link_mode = STATIC}
#
system-view
#
sysname [sys_name]
#
interface [link_if]
port link-mode route
ip address [static_ip] [static_mask]
nat outbound
#
qu
#
1:ntp-service unicast-server [ntp_server]
#
cloud-management server domain [ac_host]
cloud-management server port [ac_port]
cloud-management server password simple [ac_password]
#
ip route-static 0.0.0.0 0.0.0.0 [gateway]
#
DHCP mode section
{link_mode = DHCP}
#
system-view
#
sysname [sys_name]
#
interface [link_if]
port link-mode route
ip address dhcp-alloc
nat outbound
#
qu
#
1:ntp-service unicast-server [ntp_server]
#
cloud-management server domain [ac_host]
cloud-management server port [ac_port]
cloud-management server password simple [ac_password]
#
Using USB-based automatic configuration
About USB-based automatic configuration
USB-based automatic configuration enables the device to obtain a configuration file from a connected USB disk at startup. The configuration file can be in either of the following forms:
· Plaintext form—The configuration file is saved in plaintext form.
· Encrypted form—The configuration file is generated by the administrator in encrypted form by using the controller. When being transmitted to a USB disk, the configuration data in the file is transmitted in encrypted form. When being used to perform automatic configuration, the configuration data is automatically decrypted by the device.
After obtaining a configuration file, the device compares the file with its main startup configuration file. If the two files have the same settings, the device loads its main startup configuration file. If the two files have different settings, the device performs the following operations:
1. Identifies whether its main startup configuration file is using the same name as the obtained configuration file.
¡ If yes, the device renames its main startup configuration file by adding _bak to the base name of the file, and copies the obtained configuration file.
¡ If not, the system uses the obtained configuration file to overwrite its main startup configuration file.
2. Loads the obtained configuration file.
¡ If all commands in the obtained configuration file are successfully loaded, the device sets the obtained configuration file as the main startup configuration file.
¡ If a command in the obtained configuration file fails, the device removes all loaded settings
and searches for a local configuration file.
- If a configuration file is found, the device loads the configuration file.
- If no configuration file is found, the device finishes the automatic configuration process without loading any configurations.
Preparing the USB disk for automatic configuration
1. Prepare a USB disk that has only one partition.
2. Display the serial number of the device.
display device manuinfo
For more information about this command, see Fundamentals Command Reference.
3. Create a configuration file named Device serial number.cfg or autodeploy.cfg, and save the file to the root directory of the file system on the USB disk.
If a configuration file named Device serial number.cfg coexists with configuration file autodeploy.cfg, configuration file Device serial number.cfg is used.
Configuring and using USB-based automatic configuration
1. Enable USB-based automatic configuration on the device:
a. Enter system view.
system-view
b. Enable USB-based automatic configuration.
autodeploy udisk enable
By default, USB-based automatic configuration is enabled.
c. Save the running configuration.
save
A device reboot is required for USB-based automatic configuration. Save the running configuration to ensure that the USB-based automatic configuration feature takes effect after a reboot.
2. The device supports USB-based automatic configuration only if it has only one member device. When multiple member devices exist, use the shutdown command to shut down all IRF physical ports, and then perform USB-based automatic configuration for the master device.
3. Connect the USB disk to the USB1 interface on the device.
The USB disk will be identified as usba0.
4. Reboot the device and observe the LEDs of the device.
If the device finds no configuration files to load at startup, it performs the following operations:
a. Copies the configuration file on the USB disk.
b. Specifies the file as the startup configuration file.
c. Reboots to load the configuration file.
¡ If the SYS LED flashes green quickly for 5 seconds, the automatic configuration succeeded. Proceed to step 5.
¡ If the SYS LED flashes yellow quickly for 10 seconds, the automatic configuration failed. Display the log file named Fully qualified configuration file name.log in the USB disk root directory to locate and resolve the problem.
For more information about the LEDs, see the installation guide.
5. If the automatic configuration succeeded, use the display current-configuration command to verify that the configuration file has been loaded correctly.
6. Rebuild the IRF fabric.
The subordinate members automatically synchronize their configurations with the master at startup.