国家 / 地区

04-二层技术-以太网交换命令参考

04-VLAN命令

本章节下载  (221.02 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/SR_Router/SR8800-F/Command/Command_Manual/H3C_SR8800-F_CR-R7655PXX-6W761/04/201809/1111401_30005_0.htm

04-VLAN命令


1 VLAN

1.1  VLAN配置命令

1.1.1  default

default命令用来恢复VLAN接口的缺省配置。

【命令】

default

【视图】

VLAN接口视图

【缺省用户角色】

network-admin

【使用指导】

注意

接口下的某些配置取消后,会对现有功能产生影响,建议您在执行该命令前,完全了解其对网络产生的影响。

 

您可以在执行default命令后通过display this命令确认执行效果。对于未能成功恢复缺省的配置,建议您查阅相关功能的命令手册,手工执行恢复该配置缺省情况的命令。如果操作仍然不能成功,您可以通过设备的提示信息定位原因。

【举例】

# 将VLAN接口1恢复为缺省配置。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] default

1.1.2  description

description命令用来配置VLAN或VLAN接口的描述信息。

undo description命令用来恢复缺省情况。

【命令】

description text

undo description

【缺省情况】

VLAN的描述信息为“VLAN vlan-id”,其中vlan-id为该VLAN的四位数编号,如果该VLAN的编号不足四位,则会在编号前增加0,补齐四位。例如,VLAN 100的描述信息为“VLAN 0100”;VLAN接口的描述信息为该VLAN接口的接口名,如“Vlan-interface1 Interface”。

【视图】

VLAN视图

VLAN接口视图

【缺省用户角色】

network-admin

【参数】

text:VLAN或VLAN接口的描述信息,为1~255个字符的字符串,区分大小写。

【使用指导】

用户可以根据功能或者连接情况为VLAN或VLAN接口配置特定的描述信息,以便记忆和管理VLAN或VLAN接口。

【举例】

# 将VLAN 2的描述信息配置为sales-private。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] description sales-private

# 将VLAN接口2的描述信息配置为linktoPC56。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] description linktoPC56

【相关命令】

·              display interface vlan-interface

·              display vlan

1.1.3  display interface vlan-interface

display interface vlan-interface命令用来显示VLAN接口的相关信息。

【命令】

display interface vlan-interface [ interface-number ] [ brief [ description | down ] ]

【视图】

任意视图

【缺省用户角色】

network-admin

network-operator

【参数】

vlan-interface interface-number:VLAN接口的编号,显示指定VLAN接口的信息。不指定interface-number时,将显示已创建的所有VLAN接口的信息。

brief:显示接口的概要信息。不指定该参数时,将显示接口的详细信息。

description:用来显示用户配置的接口的全部描述信息。如果不指定该description参数,只显示描述信息中的前27个字符。

down:显示当前物理状态为down的接口的信息以及down的原因。不指定该参数时,将不会根据接口物理状态来过滤显示信息。

【举例】

# 显示VLAN-interface 10的相关信息。

<Sysname> display interface vlan-interface 10

Vlan-interface10

Current state: UP

Line protocol state: UP

Description: Vlan-interface10 Interface

Bandwidth: 100000 kbps

Maximum transmission unit: 1500

Internet Address is 192.168.1.54/24 Primary

IP packet frame type: Ethernet II, hardware address: 0023-89b6-d613

IPv6 packet frame type: Ethernet II, hardware address: 0023-89b6-d613

Last clearing of counters: Never

# 显示VLAN-interface 2的概要信息。

<Sysname> display interface vlan-interface 2 brief

Brief information on interfaces in route mode:

Link: ADM - administratively down; Stby - standby

Protocol: (s) - spoofing

Interface            Link Protocol Primary IP         Description

Vlan2                DOWN DOWN     --

表1-1 display interface vlan-interface命令显示信息描述表

字段

描述

Vlan-interface2

VLAN接口名

Current state

VLAN接口的物理状态,状态可能为:

·          Administratively DOWN:表示该VLAN接口已经通过shutdown命令被关闭,即管理状态为关闭

·          DOWN:表示该VLAN接口的管理状态为开启,但物理状态为关闭,即该接口对应的VLAN内没有处于UP状态的物理端口(可能因为没有物理连线或者线路故障)

·          UP:该端口的管理状态和物理状态均为开启

Line protocol state

VLAN接口的链路层协议状态,状态可能为:

·          DOWN:该VLAN接口的协议状态为关闭

·          UP:该VLAN接口的协议状态为开启

Description

VLAN接口的描述信息

Bandwidth

VLAN接口的期望带宽

Maximum transmission unit

VLAN接口允许通过的MTU

Internet protocol processing : Disabled

该接口还不具有处理IP报文的能力,当没有为该接口配置IP地址时会显示该信息

Internet Address

该接口的主IP地址

IP packet frame type

IPv4发送帧格式

hardware address

VLAN接口对应的MAC地址

IPv6 packet frame type

IPv6发送帧格式

Output queue - Urgent queuing: Size/Length/Discards 0/100/0

Output queue - Protocol queuing: Size/Length/Discards 0/500/0

Output queue - FIFO queuing: Size/Length/Discards 0/75/0

接口输出队列的类型:

·          紧急发送队列的报文统计

·          协议发送队列的报文统计

·          先入先出发送队列的报文统计

Last clearing of counters

最近一次使用reset counters interface vlan-interface命令清除接口下的统计信息的时间。如果从设备启动一直没有执行reset counters interface vlan-interface命令清除过该接口下的统计信息,则显示Never

Brief information on interfaces in route mode

三层模式下(route)的接口的概要信息,即三层接口的概要信息

Link: ADM - administratively down; Stby - standby

·          如果某接口的Link属性值为“ADM”,则表示该接口被管理员通过shutdown命令关闭,需要在该接口下执行undo shutdown命令才能恢复端口本身的物理状态

·          如果某接口的Link属性值为“Stby”,则表示该接口是一个处于Standby状态的备份接口

Protocol: (s) - spoofing

如果某接口的Protocol属性值中带有“(s)”字符串,则表示该接口的数据链路层协议状态显示为UP,但实际可能没有对应的链路,或者对应的链路不是永久存在而是按需建立的

Interface

接口名称缩写

Link

接口物理连接状态,取值为:

·          UP:表示接口物理上是连通的

·          DOWN:表示接口物理上是不通的

·          ADM:表示接口被管理员通过shutdown命令关闭,需要执行undo shutdown命令才能恢复接口本身的物理状态

·          Stby:表示该接口是一个处于Standby状态的备份接口

Protocol

接口数据链路层协议状态,取值为:

·          UP:表示接口的数据链路层协议状态为开启

·          DOWN:表示接口的数据链路层协议状态为关闭

·          UP(s):表示接口的数据链路层协议状态显示为UP,但实际可能没有对应的链路,或者对应的链路不是永久存在而是按需建立的

Primary IP

接口主IP地址

 

【相关命令】

·              reset counters interface vlan-interface

1.1.4  display system-vlan-mode

display system-vlan-mode命令用来显示系统当前运行的VLAN模式和下次启动后运行的VLAN模式。

【命令】

display system-vlan-mode

【视图】

系统视图

【缺省用户角色】

network-admin

【举例】

# 显示系统当前运行的VLAN模式和下次启动后运行的VLAN模式。

<Sysname> system-view

[Sysname] display system-vlan-mode

The current system vlan mode: standard.

The system vlan mode for next startup: advance.

【相关命令】

·              system-vlan-mode

1.1.5  display vlan

display vlan命令用来显示VLAN的相关信息。

【命令】

display vlan [ vlan-id1 [ to vlan-id2 ] | all | dynamic | reserved | static ]

【视图】

任意视图

【缺省用户角色】

network-admin

network-operator

【参数】

vlan-id1:显示指定VLAN的信息。vlan-id1为VLAN的编号,取值范围为1~4093。

vlan-id1 to vlan-id2:显示ID在指定范围内的VLAN的信息。vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4093。vlan-id2的值要大于或等于vlan-id1的值。

all:显示除保留VLAN外的其他VLAN的信息。

dynamic:显示系统动态创建的VLAN的数量和编号。动态VLAN是指通过MVRP协议生成或通过RADIUS服务器下发的VLAN。

reserved:显示系统保留VLAN的信息。保留VLAN是设备根据功能实现的需要预留的VLAN。保留VLAN由协议模块来指定,为协议模块服务,用户不能对保留VLAN进行任何操作。

static:显示系统静态创建的VLAN的数量和VLAN编号。静态VLAN是指通过命令行手工创建的VLAN。

【举例】

# 显示VLAN 2的信息。

<Sysname> display vlan 2

 VLAN ID: 2

 VLAN type: Static

 Route interface: Not configured

 Description: VLAN 0002

 Name: VLAN 0002

 Tagged ports:   None

 Untagged ports:

    GigabitEthernet1/0/1  GigabitEthernet1/0/2  GigabitEthernet1/0/3

# 显示VLAN 3的信息。

<Sysname> display vlan 3

 VLAN ID: 3

 VLAN type: static

 Route interface: Configured

 IPv4 address: 1.1.1.1

 IPv4 subnet mask: 255.255.255.0

 Description: VLAN 0003

 Name: VLAN 0003

 Tagged ports:   None

 Untagged ports: None

表1-2 display vlan命令显示信息描述表

字段

解释

VLAN ID

VLAN的编号

VLAN type

VLAN的类型:

·          Static:静态VLAN

·          Dynamic:动态VLAN

Route interface

设备上是否创建了对应的VLAN接口:

·          Not configured:未创建

·          Configured:已创建

Description

VLAN的描述信息

Name

VLAN的名称

IP address

VLAN接口的主用IP地址,如果VLAN接口没有配置IP地址,则不显示该字段,如果VLAN接口上还配置了从IP地址,可以使用display interface vlan-interface或者在VLAN接口视图下使用display this命令查看

Subnet mask

VLAN接口的主用IP地址的子网掩码,如果VLAN接口没有配置IP地址,则不显示该字段

Tagged ports

该VLAN报文从哪些端口发送时需要携带Tag标记

Untagged ports

该VLAN报文从哪些端口发送时不需要携带Tag标记

 

【相关命令】

·              vlan

1.1.6  display vlan brief

display vlan brief命令用来显示设备上所有已创建VLAN的概要信息。

【命令】

display vlan brief

【视图】

任意视图

【缺省用户角色】

network-admin

network-operator

【举例】

# 显示设备上所有已创建VLAN的概要信息。

<Sysname> display vlan brief

Brief information about all VLANs:

Supported Minimum VLAN ID: 1

Supported Maximum VLAN ID: 4093

Default VLAN ID: 1

VLAN ID   Name                             Port

1         VLAN 0001                        GE1/0/1  GE1/0/2  GE1/0/3  GE1/0/4

                                           GE1/0/5  GE1/0/6  GE1/0/7  GE1/0/8

                                           GE1/0/9  GE1/0/10  GE1/0/11

                                           GE1/0/12  GE1/0/13  GE1/0/14

                                           GE1/0/15  GE1/0/16  GE1/0/17

                                           GE1/0/18  GE1/0/19  GE1/0/20

                                           GE1/0/21  GE1/0/22  GE1/0/23

                                           GE1/0/24  GE1/0/25  GE1/0/26

                                           GE1/0/27  GE1/0/28  GE1/0/29

                                           GE1/0/30  GE1/0/31  GE1/0/32

                                           GE1/0/33  GE1/0/34  GE1/0/35

                                           GE1/0/36  GE1/0/37  GE1/0/38

                                           GE1/0/39  GE1/0/40  GE1/0/41

                                           GE1/0/42  GE1/0/43  GE1/0/44

                                           GE1/0/45  GE1/0/46  GE1/0/47

                                           GE1/0/48

2         VLAN 0002

3         VLAN 0003

表1-3 display vlan brief命令显示信息描述表

字段

描述

Brief information about all VLANs:

所有VLAN的概要信息

Supported Minimum VLAN ID

系统支持的最小VLAN ID

Supported Maximum VLAN ID

系统支持的最大VLAN ID

Default VLAN ID

缺省VLAN ID

VLAN ID

VLAN的编号

Name

VLAN的名称

Port

允许该VLAN报文通过的端口

 

1.1.7  egress interface resource check

egress interface resource check命令用来开启出接口资源检查功能。

undo egress interface resource check命令用来关闭出接口资源检查功能。

【命令】

egress interface resource check

undo egress interface resource check

【缺省情况】

出接口资源检查功能处于开启状态。

【视图】

系统视图

【缺省用户角色】

network-admin

【使用指导】

当设备上存在SPC类单板、CSPC类单板、CMPE-1104单板时,建议保持出接口资源检查功能的开启状态,以便在系统资源不足时阻止创建接口(例如三层聚合子接口/VLAN接口),从而避免接口功能不正常的情况。

当设备上的单板均属于CSPEX单板时,建议关闭出接口资源检查功能。

【举例】

# 关闭出接口资源检查功能。

<Sysname> system-view

[Sysname] undo egress interface resource check

1.1.8  interface vlan-interface

interface vlan-interface命令用来创建VLAN接口并进入VLAN接口视图。如果该VLAN接口已经存在,则直接进入VLAN接口视图。

undo interface vlan-interface命令用来删除指定的VLAN接口。

【命令】

interface vlan-interface interface-number

undo interface vlan-interface interface-number

【缺省情况】

不存在VLAN接口。

【视图】

系统视图

【缺省用户角色】

network-admin

【参数】

interface-number:VLAN接口的编号,取值范围为1~4093。

【使用指导】

在创建VLAN接口之前,对应的VLAN必须已经存在,否则将不能创建指定的VLAN接口。

Sub VLAN不能创建对应的VLAN接口。

【举例】

# 创建VLAN接口2并进入视图。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2]

【相关命令】

·              display interface vlan-interface

1.1.9  mtu

mtu命令用来配置VLAN接口的MTU值。

undo mtu命令用来恢复缺省情况。

【命令】

mtu size

undo mtu

【缺省情况】

VLAN接口的MTU值为1500。

【视图】

VLAN接口视图

【缺省用户角色】

network-admin

【参数】

size:表示接口允许通过的MTU(Maximum Transmission Unit,最大传输单元)值的大小,单位为字节。不同单板的接口MTU取值范围可能存在不同,请以实际情况为准。

【使用指导】

如果当前接口同时配置mtuip mtu命令,则设备会以ip mtu命令配置的接口MTU值对报文进行分片,不会再按照mtu命令配置的MTU值对报文进行分片。有关ip mtu命令的详细介绍,请参见“三层技术-IP业务命令参考”中的“IP性能优化”。

配置VLAN接口的MTU值时,需要注意:

·              如果SPC类单板、CSPC类单板、CMPE-1104单板的接口作为流量的入接口,则该流量的IP报文不支持根据出接口配置的MTU值进行分片。

·              如果CSPEX单板的接口作为流量的入接口且流量出接口的MTU配置值小于1280时,该流量的IP报文会根据MTU值1280来进行分片。建议当设备上有这些单板在位时,出接口的MTU值配置成1280以上。

·              对于CSPEX-1204单板上MIC子卡的接口,其所属VLAN对应的VLAN接口的MTU配置值不能超过2980;否则会导致流量不通,需要用undo mtu命令恢复缺省情况,再重新配置MTU值。

【举例】

# 配置VLAN接口1的MTU值为1492字节。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] mtu 1492

【相关命令】

·              display interface vlan-interface

1.1.10  name

name命令用来指定当前VLAN的名称。

undo name命令用来恢复缺省情况。

【命令】

name text

undo name

【缺省情况】

VLAN的名称为“VLAN vlan-id”,其中vlan-id为该VLAN的四位数编号,如果该VLAN的编号不足四位,则会在编号前增加0,补齐四位。例如,VLAN 100的名称为“VLAN 0100”。

【视图】

VLAN视图

【缺省用户角色】

network-admin

【参数】

text:VLAN名称,为1~32个字符的描述信息,区分大小写。

【举例】

# 指定VLAN 2的名称为“test vlan”。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] name test vlan

【相关命令】

·              display vlan

1.1.11  reset counters interface vlan-interface

reset counters interface vlan-interface命令用来清除VLAN接口的统计信息。

【命令】

reset counters interface vlan-interface [ interface-number ]

【视图】

用户视图

【缺省用户角色】

network-admin

【参数】

vlan-interface interface-number:VLAN接口的编号,清除指定VLAN接口的统计信息。不指定interface-number时,则清除所有VLAN接口的统计信息。

【使用指导】

在某些情况下,需要统计一定时间内某接口的流量,这就需要在统计开始前清除该接口原有的统计信息,重新进行统计。

【举例】

# 清除VLAN接口2的统计信息。

<Sysname> reset counters interface vlan-interface 2

【相关命令】

·              display interface vlan-interface

1.1.12  shutdown

shutdown命令用来手工关闭VLAN接口。

undo shutdown命令用来手工开启VLAN接口。

【命令】

shutdown

undo shutdown

【缺省情况】

VLAN接口处于开启状态。

【视图】

VLAN接口视图

【缺省用户角色】

network-admin

【使用指导】

如果未手工关闭VLAN接口,此时VLAN接口状态受VLAN中端口状态的影响,即:

·              当VLAN中所有以太网端口状态均为down时,VLAN接口为down状态,即关闭状态。

·              当VLAN中有一个或一个以上的以太网端口处于up状态时,则VLAN接口处于up状态。

如果手工关闭VLAN接口,则VLAN接口的状态始终为down(Administratively),不受VLAN中端口状态的影响。

配置VLAN接口参数前,为了避免配置过程中对网络造成影响,建议先使用shutdown命令手工关闭接口,之后再配置参数。配置完成后,使用undo shutdown命令取消手工关闭接口,使配置的参数生效。

当VLAN接口出现故障时,可以使用shutdown命令手工关闭接口,然后再使用undo shutdown命令取消手工关闭接口,这样有可能使接口恢复正常。

关闭和打开VLAN接口对于属于这个VLAN的任何一个以太网端口本身都不起作用,以太网端口的状态不随VLAN接口状态的改变而改变。

【举例】

# 将VLAN接口2关闭后再重新打开。

<Sysname> system-view

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] shutdown

[Sysname-Vlan-interface2] undo shutdown

1.1.13  system-vlan-mode

system-vlan-mode命令用来配置系统下次启动后运行的VLAN模式。

undo system-vlan-mode命令用来恢复缺省情况。

【命令】

system-vlan-mode { standard | advance }

undo system-vlan-mode

【缺省情况】

系统下次启动后运行在标准VLAN模式下。

【视图】

系统视图

【缺省用户角色】

network-admin

【参数】

standard:指定系统下次启动后运行的VLAN模式为标准VLAN模式,该模式下系统支持的VLAN接口数量上限为450。

advance:指定系统下次启动后运行的VLAN模式为增强VLAN模式,该模式下系统支持的VLAN接口数量上限为4090。

【举例】

# 配置系统下次启动后运行的VLAN模式为增强VLAN模式。

<Sysname> system-view

[Sysname] system-vlan-mode advance

Do you want to change the system vlan mode? [Y/N] :y

System vlan mode changed. For the change to take effect, save the running configuration and reboot the device.

【相关命令】

·              display system-vlan-mode

1.1.14  vlan

vlan vlan-id命令用来创建VLAN,并进入VLAN视图。如果指定的VLAN已存在,则直接进入该VLAN的视图。

vlan vlan-id1 to vlan-id2命令用来批量创建vlan-id1vlan-id2之间的所有VLAN,保留VLAN除外。

vlan all命令用来批量创建VLAN 1~4093。

undo vlan命令用来删除VLAN。

【命令】

vlan { vlan-id1 [ to vlan-id2 ] | all }

undo vlan { vlan-id1 [ to vlan-id2 ] | all }

【缺省情况】

系统只有一个缺省VLAN(VLAN 1)。

【视图】

系统视图

【缺省用户角色】

network-admin

【参数】

vlan-id1:VLAN的编号,取值范围为1~4093。

vlan-id1 to vlan-id2:指定VLAN的编号范围。vlan-id1vlan-id2为VLAN的编号,取值范围为1~4093。vlan-id2的值要大于或等于vlan-id1的值。

all:除保留VLAN外的其他VLAN。

【使用指导】

用户不能创建和删除缺省VLAN(VLAN 1)和保留VLAN。

动态学习到的VLAN,以及被其他应用锁定不让删除的VLAN,都不能使用undo vlan命令直接删除。只有将相关配置删除之后,才能删除相应的VLAN。

【举例】

# 创建VLAN 2,并进入该VLAN视图。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2]

# 批量创建VLAN 4~100。

<Sysname> system-view

[Sysname] vlan 4 to 100

【相关命令】

·              display vlan

1.2  基于端口的VLAN配置命令

1.2.1  display port

display port命令用来显示设备上存在的Hybrid或Trunk端口。

【命令】

display port { hybrid | trunk }

【视图】

任意视图

【缺省用户角色】

network-admin

network-operator

【参数】

hybrid:显示设备当前存在的Hybrid端口。

trunk:显示设备当前存在的Trunk端口。

【举例】

# 显示当前设备存在的Hybrid端口。

<Sysname> display port hybrid

Interface            PVID  VLAN Passing

GE1/0/1              100   Tagged:  1000, 1002, 1500, 1600-1611, 2000,

                                    2555-2558, 3000, 4000

                           Untagged:1, 10, 15, 18, 20-30, 44, 55, 67, 100,

                                    150-160, 200, 255, 286, 300-302

# 显示当前设备存在的Trunk端口。

<Sysname> display port trunk

Interface            PVID  VLAN Passing

GE1/0/2              2     1-4, 6-100, 145, 177, 189-200, 244, 289, 400,

                           555, 600-611, 1000, 2006-2008

表1-4 display port命令显示信息描述表

字段

描述

Interface

接口名称

PVID

该端口的缺省VLAN ID

VLAN Passing

表示该端口实际通过的VLAN(该VLAN已经创建,并且接口允许其通过)

Tagged

表示哪些VLAN的报文通过该端口时必须携带VLAN Tag

Untagged

表示哪些VLAN的报文通过该端口时必须去掉VLAN Tag

 

1.2.2  port

port命令用来向VLAN中添加一个或一组Access端口。

undo port命令用来从VLAN中删除一个或一组Access端口。

【命令】

port interface-list

undo port interface-list

【缺省情况】

系统将所有端口都加入到VLAN 1。

【视图】

VLAN视图

【缺省用户角色】

network-admin

【参数】

interface-list:以太网接口列表。表示方式为interface-list = { interface-type interface-number1 [ to interface-type interface-number2 ] }&<1-10>,其中interface-type interface-number为端口类型和端口编号,interface-number2的值要大于或等于interface-number1的值,&<1-10>表示前面的参数最多可以输入10次。

【使用指导】

通过本命令只能将Access端口加入到VLAN中,不能将Trunk和Hybrid端口加入到VLAN中。

设备上的所有端口的缺省链路类型都是Access类型,但用户可以自行切换端口类型,具体配置可参考命令port link-type

【举例】

# 向VLAN2中添加端口GigabitEthernet1/0/1~GigabitEthernet1/0/3。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] port gigabitethernet 1/0/1 to gigabitethernet 1/0/3

【相关命令】

·              display vlan

1.2.3  port access vlan

port access vlan命令用来将Access端口加入到指定的VLAN中。

undo port access vlan命令用来恢复缺省情况。

【命令】

port access vlan vlan-id

undo port access vlan

【缺省情况】

所有Access端口都属于VLAN 1。

【视图】

二层以太网接口视图

二层聚合接口视图

【缺省用户角色】

network-admin

【参数】

vlan-id:指定的VLAN编号,取值范围为1~4093。

【使用指导】

在将Access端口加入到指定VLAN之前,该VLAN必须已经存在。

【举例】

# 将GigabitEthernet1/0/1端口加入到VLAN 3中。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] quit

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port access vlan 3

1.2.4  port hybrid pvid

port hybrid pvid命令用来配置Hybrid端口的缺省VLAN。

undo port hybrid pvid命令用来配置Hybrid端口的缺省VLAN为1。

【命令】

port hybrid pvid vlan vlan-id

undo port hybrid pvid

【缺省情况】

Hybrid端口的缺省VLAN为该端口在链路类型为Access时的所属VLAN。

【视图】

二层以太网接口视图

二层聚合接口视图

【缺省用户角色】

network-admin

【参数】

vlan-id:指定接口的缺省的VLAN ID,取值范围为1~4093。

【使用指导】

对Hybrid端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即可以使用已经不存在的VLAN作为缺省VLAN。

建议本机Hybrid端口的缺省VLAN和相连的对端交换机的Hybrid端口的缺省VLAN保持一致。

配置缺省VLAN后,必须使用port hybrid vlan命令配置端口允许缺省VLAN的报文通过,该端口才能转发缺省VLAN的报文。

【举例】

# 配置端口GigabitEthernet1/0/1(Hybrid类型)的缺省VLAN为100,并允许VLAN 100通过。

<Sysname> system-view

[Sysname] vlan 100

[Sysname-vlan100] quit

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type hybrid

[Sysname-GigabitEthernet1/0/1] port hybrid pvid vlan 100

[Sysname-GigabitEthernet1/0/1] port hybrid vlan 100 untagged

【相关命令】

·              port hybrid vlan

·              port link-type

1.2.5  port hybrid vlan

port hybrid vlan命令用来允许指定的VLAN通过当前Hybrid端口。

undo port hybrid vlan命令用来禁止指定的VLAN通过当前Hybrid端口。

【命令】

port hybrid vlan vlan-id-list { tagged | untagged }

undo port hybrid vlan vlan-id-list

【缺省情况】

Hybrid端口只允许该端口在链路类型为Access时的所属VLAN的报文以Untagged方式通过。

【视图】

二层以太网接口视图

二层聚合接口视图

【缺省用户角色】

network-admin

【参数】

vlan-id-list:VLAN列表,Hybrid端口允许通过的VLAN范围。表示方式为vlan-id-list = { vlan-id1 [ to vlan-id2 ] }&<1-10>vlan-id取值范围为1~4093,vlan-id2的值要大于或等于vlan-id1的值,&<1-10>表示前面的参数最多可以重复输入10次。该VLAN必须是设备上已创建的VLAN,否则,该命令执行失败。

tagged:该端口在转发指定的VLAN报文时将携带VLAN Tag。

untagged:该端口在转发指定的VLAN报文时将去掉VLAN Tag。

【使用指导】

Hybrid端口允许多个VLAN通过。如果多次使用port hybrid vlan命令,那么Hybrid端口上允许通过的VLAN是这些vlan-id-list的合集。

【举例】

# 配置端口GigabitEthernet1/0/1为Hybrid端口,允许VLAN 2、4、50~VLAN 100通过,并且发送这些VLAN的报文时携带VLAN Tag。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type hybrid

[Sysname-GigabitEthernet1/0/1] port hybrid vlan 2 4 50 to 100 tagged

【相关命令】

·              port link-type

1.2.6  port link-type

port link-type命令用来配置端口的链路类型。

undo port link-type命令用来恢复缺省情况。

【命令】

port link-type { access | hybrid | trunk }

undo port link-type

【缺省情况】

所有端口的链路类型均为Access类型。

【视图】

二层以太网接口视图

二层聚合接口视图

【缺省用户角色】

network-admin

【参数】

access:配置端口的链路类型为Access类型。

hybrid:配置端口的链路类型为Hybrid类型。

trunk:配置端口的链路类型为Trunk类型。

【使用指导】

Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再配置为其他类型端口。

【举例】

# 配置端口GigabitEthernet1/0/1配置为Trunk端口。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type trunk

1.2.7  port trunk permit vlan

port trunk permit vlan命令用来允许指定的VLAN通过当前Trunk端口。

undo port trunk permit vlan命令用来禁止指定的VLAN通过当前Trunk端口。

【命令】

port trunk permit vlan { vlan-id-list | all }

undo port trunk permit vlan { vlan-id-list | all }

【缺省情况】

Trunk端口只允许VLAN 1的报文通过。

【视图】

二层以太网接口视图

二层聚合接口视图

【缺省用户角色】

network-admin

【参数】

vlan-id-list:VLAN列表,Trunk端口允许通过的VLAN范围。表示方式为vlan-id-list = { vlan-id1 [ to vlan-id2 ] }&<1-10>vlan-id取值范围为1~4093,vlan-id2的值要大于或等于vlan-id1的值,&<1-10>表示前面的参数最多可以重复输入10次。

all:表示允许所有VLAN通过该Trunk端口。建议用户谨慎使用port trunk permit vlan all命令,以防止未授权VLAN的用户通过该端口访问受限资源。

【使用指导】

Trunk端口可以允许多个VLAN通过。如果多次执行port trunk permit vlan命令,那么Trunk端口上允许通过的VLAN是这些vlan-id-list的集合。

Trunk端口发送出去的报文,只有缺省VLAN的报文不带VLAN Tag,其他VLAN的报文均会保留VLAN Tag。

【举例】

# 配置端口GigabitEthernet1/0/1为Trunk端口,允许VLAN 2、4、50~100通过。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type trunk

[Sysname-GigabitEthernet1/0/1] port trunk permit vlan 2 4 50 to 100

【相关命令】

·              port link-type

1.2.8  port trunk pvid

port trunk pvid命令用来配置Trunk端口的缺省VLAN。

undo port trunk pvid命令用来恢复缺省情况。

【命令】

port trunk pvid vlan vlan-id

undo port trunk pvid

【缺省情况】

Trunk端口的缺省VLAN为VLAN 1。

【视图】

二层以太网接口视图

二层聚合接口视图

【缺省用户角色】

network-admin

【参数】

vlan-id:指定接口的缺省VLAN ID,取值范围为1~4093。

【使用指导】

对Trunk端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即使用已经不存在的VLAN作为缺省VLAN。

本端设备Trunk端口的缺省VLAN ID和相连的对端设备的Trunk端口的缺省VLAN ID必须一致,否则报文将不能正确传输。

配置缺省VLAN后,必须使用port trunk permit vlan命令配置端口允许缺省VLAN的报文通过,该端口才能转发缺省VLAN的报文。

【举例】

# 配置端口GigabitEthernet1/0/1(Trunk类型)的缺省VLAN为VLAN 100,并允许VLAN 100通过。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type trunk

[Sysname-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Sysname-GigabitEthernet1/0/1] port trunk permit vlan 100

【相关命令】

·              port link-type

·              port trunk permit vlan


2 Super VLAN

2.1  Super VLAN配置命令

2.1.1  display supervlan

display supervlan命令用来显示Super VLAN及其关联的Sub VLAN的信息。

【命令】

display supervlan [ supervlan-id ]

【视图】

任意视图

【缺省用户角色】

network-admin

network-operator

【参数】

supervlan-id:Super VLAN的编号,取值范围为1~4093。如果未指定该参数,则显示设备上所有的Super VLAN及其关联的Sub VLAN的信息。

【举例】

# 显示Super VLAN 2及其关联的Sub VLAN的信息。

<Sysname> display supervlan 2

 Super VLAN ID: 2

 Sub-VLAN ID: 3-5

 

 VLAN ID: 2

 VLAN type: Static

 It is a super VLAN.

 Route interface: Configured

 IPv4 address: 10.153.17.41

 IPv4 subnet mask: 255.255.252.0

 IPv6 global unicast addresses:

   2001::1, subnet is 2001::/64 [TENTATIVE]

 Description: VLAN 0002

 Name: VLAN 0002

 Tagged ports:   None

 Untagged ports: None

 

 VLAN ID: 3

 VLAN type: Static

 It is a sub-VLAN.

 Route interface: Configured

 IPv4 address: 10.153.17.41

 IPv4 subnet mask: 255.255.252.0

 IPv6 global unicast addresses:

   2001::1, subnet is 2001::/64 [TENTATIVE]

 Description: VLAN 0003

 Name: VLAN 0003

 Tagged ports:   None

 Untagged ports:

    GigabitEthernet1/0/3

 

 VLAN ID: 4

 VLAN type: Static

 It is a sub-VLAN.

 Route interface: Configured

 IPv4 address: 10.153.17.41

 IPv4 subnet mask: 255.255.252.0

 IPv6 global unicast addresses:

   2001::1, subnet is 2001::/64 [TENTATIVE]

 Description: VLAN 0004

 Name: VLAN 0004

 Tagged ports:   None

 Untagged ports:

    GigabitEthernet1/0/4

表2-1 display supervlan命令显示信息描述表

字段

描述

Super VLAN ID

Super VLAN的编号

Sub-VLAN ID

Sub VLAN的编号

VLAN ID

VLAN编号

VLAN type

VLAN类型:

·          Dynamic:动态VLAN

·          Static:静态VLAN

It is a super VLAN

当前VLAN是Super VLAN

It is a sub-VLAN

当前VLAN是Sub VLAN

Route interface

设备上是否创建了对应的VLAN接口:

·          Configured:已创建

·          Not configured:未创建

IPv4 address

VLAN接口的主用IPv4地址,如果VLAN接口没有配置IPv4地址,则不显示该字段,如果VLAN接口上还配置了从IPv4地址,可以使用display interface vlan-interface或者在VLAN接口视图下使用display this命令查看

IPv4 subnet mask

VLAN接口的主用IPv4地址的子网掩码,如果VLAN接口没有配置IPv4地址,则不显示该字段

IPv6 global unicast addresses

VLAN接口上配置的全球单播IPv6地址,如果VLAN接口没有配置IPv6地址,则不显示该字段

可能的IPv6地址状态及含义如下:

·          [TENTATIVE]:该状态为地址初始化状态,此时该地址可能正在进行DAD检测或准备进行DAD检测,处于该状态的地址不能作为报文的源地址或者目的地址

·          [DUPLICATE]:该状态表明地址DAD检测已经结束,由于该地址在链路上不唯一,因此不能使用

·          [PREFERRED]:该状态表明地址处于首选生命期以内。该状态的地址可以作为报文的源地址或者目的地址。为该状态时,不显示地址的状态标识

·          [DEPRECATED]:该状态表明地址超过首选生命期,但是在有效生命期以内。该状态地址有效,但不应作为新建连接报文的源地址,目的地址是该地址的报文还可以被正常处理

Description

VLAN的描述信息

Name

VLAN的名称

Tagged ports

该VLAN报文从哪些端口发送需要携带VLAN Tag

Untagged ports

该VLAN报文从哪些端口发送时不需要携带VLAN Tag

 

【相关命令】

·              subvlan

·              supervlan

2.1.2  subvlan

subvlan命令用来建立Super VLAN和Sub VLAN的映射关系。

undo subvlan命令用来解除Super VLAN和Sub VLAN的映射关系。

【命令】

subvlan vlan-id-list

undo subvlan [ vlan-id-list ]

【缺省情况】

不存在Super VLAN和Sub VLAN的映射关系。

【视图】

VLAN视图

【缺省用户角色】

network-admin

【参数】

vlan-id-list:Sub VLAN列表,表示方式为vlan-id-list = { vlan-id1 [ to vlan-id2 ] }&<1-10>。其中,vlan-id表示Sub VLAN的VLAN ID,取值范围为1~4093。&<1-10>表示前面的参数最多可以重复输入10次。

【使用指导】

建立Super VLAN和Sub VLAN的映射关系前,指定的Sub VLAN必须已经创建。

在建立了Super VLAN和Sub VLAN的映射关系后,仍可以向Sub VLAN中添加和删除接口。

使用undo subvlan命令时:

·              如果不指定vlan-id-list,则解除当前Super VLAN与所有Sub VLAN的映射关系。

·              如果指定vlan-id-list,则解除当前Super VLAN与指定Sub VLAN的映射关系。

【举例】

# 建立Super VLAN 10和Sub VLAN 3、4、5的映射关系。

<Sysname> system-view

[Sysname] vlan 3 to 5

[Sysname] vlan 10

[Sysname-vlan10] supervlan

[Sysname-vlan10] subvlan 3 to 5

【相关命令】

·              display supervlan

·              supervlan

2.1.3  supervlan

supervlan命令用来配置VLAN的类型为Super VLAN。

undo supervlan命令用来恢复缺省情况。

【命令】

supervlan

undo supervlan

【缺省情况】

VLAN类型不为Super VLAN。

【视图】

VLAN视图

【缺省用户角色】

network-admin

【使用指导】

在Super VLAN对应的VLAN接口下配置VRRP功能后,会对网络性能造成影响,建议不要这样配置。

在Super VLAN下可以配置二层组播功能,但是由于Super VLAN中没有物理端口,该配置将不会生效。

【举例】

# 配置VLAN 2为Super VLAN。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] supervlan

【相关命令】

·              display supervlan

·              subvlan

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部