选择区域语言: EN CN HK

10-网络管理和监控配置指导

07-镜像配置

本章节下载  (277.86 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/E/E528[E552]/Configure/Operation_Manual/H3C_E528[E552]_CG-Release_1513-6W100/10/201305/784779_30005_0.htm

07-镜像配置


1 端口镜像配置

1.1  端口镜像简介

端口镜像是将指定端口(源端口)的报文复制一份到其它端口(目的端口),目的端口会与数据监测设备相连,用户利用这些数据监测设备来分析复制到目的端口的报文,进行网络监控和故障排除。

1.1.1  端口镜像的基本概念

为了更好地理解后面的内容,首先介绍一下端口镜像中涉及的基本概念。

1. 源端口

源端口是被监控的端口,用户可以对通过该端口的报文进行监控和分析。

1. 目的端口

目的端口也可称为监控端口,该端口将接收到的报文转发到数据监测设备,以便对报文进行监控和分析。

2. 镜像方向

端口镜像的方向分为三种:

·              入方向:仅对从源端口收到的报文进行镜像。

·              出方向:仅对从源端口发出的报文进行镜像。

·              双向:对从源端口收到和发出的报文都进行镜像。

1.1.2  端口镜像的分类

根据使用范围的不同,端口镜像可分为以下三种类型:

·              本地端口镜像:可以将设备源端口上的报文复制到本设备的目的端口,用于监控和分析这些报文。

·              二层远程端口镜像:可以将本设备源端口上的报文通过二层网络复制到另一台设备的目的端口,用于监控和分析这些报文。

·              三层远程端口镜像:可以将本设备源端口上的报文通过三层网络复制到另一台设备的目的端口,用于监控和分析源这些报文。

说明

·       本系列交换机支持本地端口镜像和二层远程端口镜像。

·       由于一个目的端口可以同时监视多个源端口,在某些配置情况下,目的端口会收到同一个报文的多个复制报文。例如,目的端口Port 1同时监控源端口Port 2和Port 3接收和发送的所有报文(Port 2和Port 3在同一台设备上),如果一个报文从Port 2进入设备又从Port 3发送出去,那么这个报文将被复制两次送到目的端口Port 1。

 

1.1.3  端口镜像的实现方式

端口镜像通过镜像组的方式实现,镜像组可分为以下三类:

·              本地镜像组:如果一台设备的一个镜像组中既有源端口,又有目的端口,那么该镜像组就称为本地镜像组。

·              远程源镜像组:如果一台设备的一个镜像组中只有源端口,那么该镜像组就称为远程源镜像组,该设备也称为源设备。

·              远程目的镜像组:如果一台设备的一个镜像组中只有目的端口,那么该镜像组就称为远程目的镜像组,该设备也称为目的设备。

说明

本系列交换机最多支持配置5个镜像组。

 

1. 本地端口镜像实现方式

本地端口镜像通过本地镜像组的方式实现,即源端口和目的端口在同一个本地镜像组中,设备将源端口的报文复制一份并转发到目的端口。

图1-1 本地端口镜像示意图

 

图1-1所示,源端口的报文被镜像到目的端口,这样,连接在目的端口上的数据监测设备就可以对这些报文进行监控和分析。

2. 二层远程端口镜像实现方式

二层远程端口镜像通过远程源镜像组和远程目的镜像组互相配合的方式实现。

图1-2 二层远程端口镜像示意图

 

图1-2所示,用户在源设备上创建远程源镜像组,在目的设备上创建远程目的镜像组。源设备将源端口的报文复制一份后,将其通过出端口转发给中间设备,再由中间设备在远程镜像VLAN中广播,最终到达目的设备。目的设备收到该报文后,若其VLAN ID与远程目的镜像组的远程镜像VLAN的VLAN ID相同,就将其转发至目的端口。这样,连接在目的端口上的数据监测设备就可以对源设备上源端口的报文进行监控和分析。

说明

用户需要确保远程镜像VLAN内源设备到目的设备间二层网络的互通性。

 

注意

在镜像报文离开源设备到达远程目的设备过程中,用户应确保镜像报文中VLAN ID的正确性,如果该VLAN ID被修改或删除,二层远程镜像功能将失效。

 

1.2  配置本地端口镜像

1.2.1  配置任务简介

本地端口镜像的配置需要在同一台设备上进行。

首先创建一个本地镜像组,然后为该镜像组配置源端口和目的端口。

表1-1 本地端口镜像配置任务简介

配置任务

说明

详细配置

创建本地镜像组

必选

1.2.2 

配置源端口

必选

1.2.3 

配置目的端口

必选

1.2.4 

 

说明

一个端口只能被一个镜像组使用。

 

1.2.2  创建本地镜像组

表1-2 创建本地镜像组

操作

命令

说明

进入系统视图

system-view

-

创建本地镜像组

mirroring-group group-id local

必选

缺省情况下,不存在任何镜像组

 

说明

配置好源端口和目的端口后,本地镜像组才能生效。

 

1.2.3  配置源端口

可以在系统视图下为指定镜像组配置一个或多个源端口,也可以在端口视图下将当前接口配置为指定镜像组的源端口,二者的配置效果相同。

1. 在系统视图下配置源端口

表1-3 在系统视图下配置源端口

操作

命令

说明

进入系统视图

system-view

-

为本地镜像组配置源端口

mirroring-group group-id mirroring-port mirroring-port-list { both | inbound | outbound }

必选

缺省情况下,镜像组没有源端口

 

2. 在端口视图下配置源端口

表1-4 在端口视图下配置源端口

操作

命令

说明

进入系统视图

system-view

-

进入以太网端口视图

interface interface-type interface-number

-

配置本端口为本地镜像组的源端口

[ mirroring-group group-id ] mirroring-port { both | inbound | outbound }

必选

缺省情况下,端口不是任何镜像组的源端口

 

说明

一个镜像组内可以配置多个源端口。

 

1.2.4  配置目的端口

可以在系统视图下为指定镜像组配置目的端口,也可以在端口视图下将当前端口配置为指定镜像组的目的端口,二者的配置效果相同。

1. 在系统视图下配置目的端口

表1-5 在系统视图下配置目的端口

操作

命令

说明

进入系统视图

system-view

-

为本地镜像组配置目的端口

mirroring-group group-id monitor-port monitor-port-id

必选

缺省情况下,镜像组没有目的端口

 

2. 在端口视图下配置目的端口

表1-6 在端口视图下配置目的端口

操作

命令

说明

进入系统视图

system-view

-

进入端口视图

interface interface-type interface-number

-

配置本端口为本地镜像组的目的端口

[ mirroring-group group-id ] monitor-port

必选

缺省情况下,端口不是任何镜像组的目的端口

 

说明

·       一个镜像组内只能配置一个目的端口。

·       请不要在目的端口上使能STP、MSTP和RSTP,否则会影响镜像功能的正常使用。

·       目的端口发送的报文包括复制自源端口的报文和来自其它端口的正常转发报文。为了保证数据监测设备只对源端口的报文进行分析,请将目的端口只用于端口镜像,不作其它用途。

 

1.3  配置二层远程端口镜像

1.3.1  配置任务简介

二层远程端口镜像的配置需要分别在源设备和目的设备上进行。

说明

·       一个端口只能被一个镜像组使用。

·       如果用户在设备上启用了GVRP(GARP VLAN Registration Protocol,GARP VLAN注册协议)功能,GVRP可能将远程镜像VLAN注册到不希望的端口上,此时在目的端口就会收到很多不必要的报文。有关GVRP的详细介绍,请参见“二层技术-以太网交换配置指导”中的“GVRP配置”。

 

首先在目的设备上为远程目的镜像组配置远程镜像VLAN和目的端口,然后在源设备上为远程源镜像组配置源端口、出端口和远程镜像VLAN。

表1-7 二层远程端口镜像配置任务简介

配置任务

说明

详细配置

配置远程目的镜像组

创建远程目的镜像组

必选

1.3.3  1.

配置目的端口

必选

1.3.3  2.

配置远程镜像VLAN

必选

1.3.3  3.

将目的端口加入远程镜像VLAN

必选

1.3.3  4.

配置远程源镜像组

创建远程源镜像组

必选

1.3.4  1.

配置源端口

必选

1.3.4  2.

配置出端口

必选

1.3.4  3.

配置远程镜像VLAN

必选

1.3.4  4.

 

1.3.2  配置准备

在配置二层远程端口镜像之前,需首先配置远程镜像VLAN所使用的静态VLAN。

注意

源设备上的远程源镜像组和目的设备上的远程目的镜像组必须使用相同的远程镜像VLAN。

 

1.3.3  配置远程目的镜像组

请在目的设备上进行如下配置。

1. 创建远程目的镜像组

表1-8 创建远程目的镜像组

操作

命令

说明

进入系统视图

system-view

-

创建远程目的镜像组

mirroring-group group-id remote-destination

必选

缺省情况下,不存在任何镜像组

 

2. 配置目的端口

可以在系统视图下为指定镜像组配置目的端口,也可以在端口视图下将当前接口配置为指定镜像组的目的端口,二者的配置效果相同。

(1)      在系统视图下配置目的端口

表1-9 在系统视图下配置目的端口

操作

命令

说明

进入系统视图

system-view

-

为远程目的镜像组配置目的端口

mirroring-group group-id monitor-port monitor-port-id

必选

缺省情况下,镜像组没有目的端口

 

(2)      在端口视图下配置目的端口

表1-10 在端口视图下配置目的端口

操作

命令

说明

进入系统视图

system-view

-

进入端口视图

interface interface-type interface-number

-

配置本端口为远程目的镜像组的目的端口

[ mirroring-group group-id ] monitor-port

必选

缺省情况下,端口不是任何镜像组的目的端口

 

说明

·       一个镜像组内只能配置一个目的端口。

·       请不要在目的端口上使能STP、MSTP和RSTP,否则会影响镜像功能的正常使用。

·       目的端口发送的报文包括复制自源端口的报文和来自其它端口的正常转发报文。为了保证数据监测设备只对源端口的报文进行分析,请将目的端口只用于端口镜像,不作其它用途。

 

3. 配置远程镜像VLAN

表1-11 配置远程镜像VLAN

操作

命令

说明

进入系统视图

system-view

-

为远程目的镜像组配置远程镜像VLAN

mirroring-group group-id remote-probe vlan rprobe-vlan-id

必选

缺省情况下,镜像组没有远程镜像VLAN

 

说明

请将远程镜像VLAN只用于端口镜像,不作其它用途。

 

4. 将目的端口加入远程镜像VLAN

表1-12 将目的端口加入远程镜像VLAN

操作

命令

说明

进入系统视图

system-view

-

进入目的端口视图

interface interface-type interface-number

-

将目的端口加入远程镜像VLAN

目的端口为Access端口

port access vlan vlan-id

三者必选其一

目的端口为Trunk端口

port trunk permit vlan vlan-id

目的端口为Hybrid端口

port hybrid vlan vlan-id { tagged | untagged }

 

说明

有关port access vlanport trunk permit vlanport hybrid vlan命令的详细介绍,请参见“二层技术-以太网交换命令参考”中的“VLAN配置命令”。

 

1.3.4  配置远程源镜像组

请在源设备上进行如下配置。

1. 创建远程源镜像组

表1-13 创建远程源镜像组

操作

命令

说明

进入系统视图

system-view

-

创建远程源镜像组

mirroring-group group-id remote-source

必选

缺省情况下,不存在任何镜像组

 

2. 配置源端口

可以在系统视图下为指定镜像组配置一个或多个源端口,也可以在端口视图下将当前接口配置为指定镜像组的源端口,二者的配置效果相同。

(1)      在系统视图下配置源端口

表1-14 在系统视图下配置源端口

操作

命令

说明

进入系统视图

system-view

-

为远程源镜像组配置源端口

mirroring-group group-id mirroring-port mirroring-port-list { both | inbound | outbound }

必选

缺省情况下,镜像组没有源端口

 

(2)      在端口视图下配置源端口

表1-15 在端口视图下配置源端口

操作

命令

说明

进入系统视图

system-view

-

进入端口视图

interface interface-type interface-number

-

配置本端口为远程源镜像组的源端口

[ mirroring-group group-id ] mirroring-port { both | inbound | outbound }

必选

缺省情况下,端口不是任何镜像组的源端口

 

说明

·       一个镜像组内可以配置多个源端口。

·       请不要将源端口加入到远程镜像VLAN中,否则会影响镜像功能的正常使用。

 

3. 配置出端口

可以在系统视图下为指定镜像组配置出端口,也可以在端口视图下将当前接口配置为指定镜像组的出端口,二者的配置效果相同。

(1)      在系统视图下配置出端口

表1-16 在系统视图下配置出端口

操作

命令

说明

进入系统视图

system-view

-

为远程源镜像组配置出端口

mirroring-group group-id monitor-egress monitor-egress-port

必选

缺省情况下,镜像组没有出端口

 

(2)      在端口视图下配置出端口

表1-17 在端口视图下配置出端口

操作

命令

说明

进入系统视图

system-view

-

进入端口视图

interface interface-type interface-number

-

配置本端口为远程源镜像组的出端口

mirroring-group group-id monitor-egress

必选

缺省情况下,端口不是任何镜像组的出端口

 

说明

·       一个镜像组内只能配置一个出端口。

·       请不要将出端口加入到源VLAN中,否则会影响镜像功能的正常使用。

·       出端口不能是现有镜像组的成员端口。

·       请不要在出端口上配置下列功能:STP、MSTP、RSTP、802.1X、IGMP Snooping、静态ARP和MAC地址学习,否则会影响镜像功能的正常使用。

 

4. 配置远程镜像VLAN

表1-18 配置远程镜像VLAN

操作

命令

说明

进入系统视图

system-view

-

为远程源镜像组配置远程镜像VLAN

mirroring-group group-id remote-probe vlan rprobe-vlan-id

必选

缺省情况下,镜像组没有远程镜像VLAN

 

说明

请将远程镜像VLAN只用于端口镜像,不作其它用途。

 

1.4  端口镜像显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后镜像组的运行情况,通过查看显示信息验证配置的效果。

表1-19 端口镜像显示和维护

操作

命令

显示镜像组的配置信息

display mirroring-group { group-id | all | local | remote-destination | remote-source } [ | { begin | exclude | include } regular-expression ]

 

1.5  端口镜像典型配置举例

1.5.1  本地端口镜像配置举例

1. 组网需求

·              Device A通过端口GigabitEthernet1/0/1和GigabitEthernet1/0/2分别连接市场部和技术部,并通过端口GigabitEthernet1/0/3连接Server。

·              通过配置源端口方式的本地端口镜像,使Server可以监控所有进、出市场部和技术部的报文。

2. 组网图

图1-3 本地端口镜像配置组网图

 

3. 配置步骤

(1)      配置本地镜像组

# 创建本地镜像组1。

<DeviceA> system-view

[DeviceA] mirroring-group 1 local

# 配置本地镜像组1的源端口为GigabitEthernet1/0/1和GigabitEthernet1/0/2,目的端口为GigabitEthernet1/0/3。

[DeviceA] mirroring-group 1 mirroring-port gigabitethernet 1/0/1 gigabitethernet 1/0/2 both

[DeviceA] mirroring-group 1 monitor-port gigabitethernet 1/0/3

(2)      检验配置效果

# 显示所有镜像组的配置信息。

[DeviceA] display mirroring-group all

mirroring-group 1:

    type: local

    status: active

    mirroring port:

        GigabitEthernet1/0/1  both

        GigabitEthernet1/0/2  both

    mirroring CPU:

    monitor port: GigabitEthernet1/0/3  

配置完成后,用户可以通过Server监控所有进、出市场部和技术部的报文。

1.5.2  二层远程端口镜像配置举例

1. 组网需求

·              在一个二层网络中,Device A通过端口GigabitEthernet1/0/1连接市场部,并通过Trunk端口GigabitEthernet1/0/2与Device B的Trunk端口GigabitEthernet1/0/1相连;Device C通过端口GigabitEthernet1/0/2连接Server,并通过Trunk端口GigabitEthernet1/0/1与Device B的Trunk端口GigabitEthernet1/0/2相连。

·              通过配置远程端口镜像,使Server可以穿越二层网络监控所有进、出市场部的报文。

2. 组网图

图1-4 二层远程端口镜像配置组网图

3. 配置步骤

(1)      配置Device C

# 配置端口GigabitEthernet1/0/1为Trunk口,并允许VLAN 2的报文通过。

<DeviceC> system-view

[DeviceC] interface gigabitethernet 1/0/1

[DeviceC-GigabitEthernet1/0/1] port link-type trunk

[DeviceC-GigabitEthernet1/0/1] port trunk permit vlan 2

[DeviceC-GigabitEthernet1/0/1] quit

# 创建远程目的镜像组1

[DeviceC] mirroring-group 1 remote-destination

# 创建VLAN 2

[DeviceC] vlan 2

[DeviceC-vlan2] quit

# 配置远程目的镜像组1的远程镜像VLANVLAN 2,目的端口为GigabitEthernet1/0/2,并将端口GigabitEthernet1/0/2加入VLAN 2

[DeviceC] mirroring-group 1 remote-probe vlan 2

[DeviceC] interface gigabitethernet 1/0/2

[DeviceC-GigabitEthernet1/0/2] mirroring-group 1 monitor-port

[DeviceC-GigabitEthernet1/0/2] port access vlan 2

[DeviceC-GigabitEthernet1/0/2] quit

(2)      配置Device B

# 配置端口GigabitEthernet1/0/1为Trunk口,并允许VLAN 2的报文通过。

<DeviceB> system-view

[DeviceB] interface gigabitethernet 1/0/1

[DeviceB-GigabitEthernet1/0/1] port link-type trunk

[DeviceB-GigabitEthernet1/0/1] port trunk permit vlan 2

[DeviceB-GigabitEthernet1/0/1] quit

# 配置端口GigabitEthernet1/0/2为Trunk口,并允许VLAN 2的报文通过。

[DeviceB-GigabitEthernet1/0/1] quit

[DeviceB] interface gigabitethernet 1/0/2

[DeviceB-GigabitEthernet1/0/2] port link-type trunk

[DeviceB-GigabitEthernet1/0/2] port trunk permit vlan 2

[DeviceB-GigabitEthernet1/0/2] quit

(3)      配置Device A

# 创建远程源镜像组1。

<DeviceA> system-view

[DeviceA] mirroring-group 1 remote-source

# 创建VLAN 2。

[DeviceA] vlan 2

[DeviceA-vlan2] quit

# 配置远程源镜像组1的远程镜像VLAN为VLAN 2,源端口为GigabitEthernet1/0/1,出端口为GigabitEthernet1/0/2。

[DeviceA] mirroring-group 1 remote-probe vlan 2

[DeviceA] mirroring-group 1 mirroring-port gigabitethernet 1/0/1 both

[DeviceA] mirroring-group 1 monitor-egress gigabitethernet 1/0/2

# 配置端口GigabitEthernet1/0/2为Trunk口,并允许VLAN 2的报文通过。

[DeviceA] interface gigabitethernet 1/0/2

[DeviceA-GigabitEthernet1/0/2] port link-type trunk

[DeviceA-GigabitEthernet1/0/2] port trunk permit vlan 2

[DeviceA-GigabitEthernet1/0/2] quit

(4)      检验配置效果

配置完成后,用户可以通过Server监控所有进、出市场部的报文。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!