选择区域语言: EN CN HK

H3C 中低端以太网交换机 可靠性典型配置指导-6W100

05-Smart Link-Monitor Link典型配置指导

本章节下载  (233.61 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/CE3000/CE3000-EI/Configure/Typical_Configuration_Example/H3C_KKX_CG-6W100/201111/733146_30005_0.htm

05-Smart Link-Monitor Link典型配置指导


1 Smart Link典型配置指导

1.1  Smart Link简介

当下游设备连接到上游设备时,使用单上行方式容易出现单点故障,造成业务中断。因此通常采用双上行方式,即将一台下游设备同时连接到两台上游设备,以最大限度地避免单点故障,提高网络可靠性,如图1-1所示。

图1-1 Smart Link应用场景示意图

 

双上行组网虽然能提高网络可靠性,但又引入了环路问题。通常可通过STP(Spanning Tree Protocol,生成树协议)或RRPP(Rapid Ring Protection Protocol,快速环网保护协议)来消除环路,但STP在收敛速度上只能达到秒级,不适用于对收敛时间有很高要求的用户,而RRPP尽管在收敛速度上能达到要求,但组网配置的复杂度较高,主要适用于较复杂的环形组网。

为了在满足用户对链路快速收敛要求的同时又能简化配置,我们针对双上行组网提出了Smart Link解决方案,实现了主备链路的冗余备份,并在主用链路发生故障后使流量能够迅速切换到备用链路上,因此具备较高的收敛速度。Smart Link的主要特点如下:

l              专用于双上行组网;

l              收敛速度快(达到亚秒级);

l              配置简单,便于用户操作。

1.2  单Smart Link组典型配置指导

1.2.1  组网图

图1-2 配置单Smart Link组组网图

 

1.2.2  应用要求

l              Device C和Device D均连接VLAN1~20的用户网络,且Device C和Device D均采用双上行链路连接到Device A。

l              通过配置,在Device C和Device D上分别实现双上行链路的灵活备份,且Device C上的流量优先选择经Device B向Device A转发;Device D上的流量优先选择经Device E向Device A转发。

1.2.3  适用产品、版本

表1-1 配置适用的产品与软件版本关系

产品

软件版本

S7500E系列以太网交换机

Release 6300系列,Release 6600系列,Release 6610系列

S7600系列以太网交换机

Release 6600系列,Release 6610系列

S5800&S5820X系列以太网交换机

Release 1110,Release 1211

CE3000-32F以太网交换机

Release 1211

S5810系列以太网交换机

Release 1102

S5500-EI系列以太网交换机

Release 2202,Release 2208

S5500-EI-D系列以太网交换机

Release 2208

S5500-SI系列以太网交换机

Release 2202 ,Release 2208

S5120-EI系列以太网交换机

Release 2202,Release 2208

S5120-EI-D系列以太网交换机

Release 1505

S5120-SI系列以太网交换机

Release 1505

S3610&S5510系列以太网交换机

Release 5306,Release 5309

S3500-EA系列以太网交换机

Release 5309

S3100V2-EI系列以太网交换机

Release 5103

E126B以太网交换机

Release 5103

 

1.2.4  配置过程和解释

(1)        配置Device C

# 创建VLAN 1~20,将这些VLAN都映射到MSTI 1上,并激活MST域的配置。

<DeviceC> system-view

[DeviceC] vlan 1 to 20

[DeviceC] stp region-configuration

[DeviceC-mst-region] instance 1 vlan 1 to 20

[DeviceC-mst-region] active region-configuration

[DeviceC-mst-region] quit

# 分别关闭端口GigabitEthernet1/0/1GigabitEthernet1/0/2,在这两个端口上分别关闭生成树协议,并将端口配置为Trunk端口且允许VLAN 120通过。

[DeviceC] interface gigabitethernet 1/0/1

[DeviceC-GigabitEthernet1/0/1] shutdown

[DeviceC-GigabitEthernet1/0/1] undo stp enable

[DeviceC-GigabitEthernet1/0/1] port link-type trunk

[DeviceC-GigabitEthernet1/0/1] port trunk permit vlan 1 to 20

[DeviceC-GigabitEthernet1/0/1] quit

[DeviceC] interface gigabitethernet 1/0/2

[DeviceC-GigabitEthernet1/0/2] shutdown

[DeviceC-GigabitEthernet1/0/2] undo stp enable

[DeviceC-GigabitEthernet1/0/2] port link-type trunk

[DeviceC-GigabitEthernet1/0/2] port trunk permit vlan 1 to 20

[DeviceC-GigabitEthernet1/0/2] quit

# 创建Smart Link1,并配置其保护VLANMSTI 1所映射的VLAN

[DeviceC] smart-link group 1

[DeviceC-smlk-group1] protected-vlan reference-instance 1

# 配置Smart Link1的主端口为GigabitEthernet1/0/1,从端口为GigabitEthernet1/0/2

[DeviceC-smlk-group1] port gigabitethernet 1/0/1 master

[DeviceC-smlk-group1] port gigabitethernet 1/0/2 slave

# Smart Link1中使能发送Flush报文的功能,并指定发送Flush报文的控制VLANVLAN 10

[DeviceC-smlk-group1] flush enable control-vlan 10

[DeviceC-smlk-group1] quit

# 重新开启端口GigabitEthernet1/0/1GigabitEthernet1/0/2

[DeviceC] interface gigabitethernet 1/0/1

[DeviceC-GigabitEthernet1/0/1] undo shutdown

[DeviceC-GigabitEthernet1/0/1] quit

[DeviceC] interface gigabitethernet 1/0/2

[DeviceC-GigabitEthernet1/0/2] undo shutdown

[DeviceC-GigabitEthernet1/0/2] quit

(2)        配置Device D

# 创建VLAN 1~20,将这些VLAN都映射到MSTI 1上,并激活MST域的配置。

<DeviceD> system-view

[DeviceD] vlan 1 to 20

[DeviceD] stp region-configuration

[DeviceD-mst-region] instance 1 vlan 1 to 20

[DeviceD-mst-region] active region-configuration

[DeviceD-mst-region] quit

# 分别关闭端口GigabitEthernet1/0/1GigabitEthernet1/0/2,在这两个端口上分别关闭生成树协议,并将端口配置为Trunk端口且允许VLAN 120通过。

[DeviceD] interface gigabitethernet 1/0/1

[DeviceD-GigabitEthernet1/0/1] shutdown

[DeviceD-GigabitEthernet1/0/1] undo stp enable

[DeviceD-GigabitEthernet1/0/1] port link-type trunk

[DeviceD-GigabitEthernet1/0/1] port trunk permit vlan 1 to 20

[DeviceD-GigabitEthernet1/0/1] quit

[DeviceD] interface gigabitethernet 1/0/2

[DeviceD-GigabitEthernet1/0/2] shutdown

[DeviceD-GigabitEthernet1/0/2] undo stp enable

[DeviceD-GigabitEthernet1/0/2] port link-type trunk

[DeviceD-GigabitEthernet1/0/2] port trunk permit vlan 1 to 20

[DeviceD-GigabitEthernet1/0/2] quit

# 创建Smart Link1,并配置其保护VLANMSTI 1所映射的VLAN

[DeviceD] smart-link group 1

[DeviceD-smlk-group1] protected-vlan reference-instance 1

# 配置Smart Link1的主端口为GigabitEthernet1/0/1,从端口为GigabitEthernet1/0/2

[DeviceD-smlk-group1] port gigabitethernet 1/0/1 master

[DeviceD-smlk-group1] port gigabitethernet 1/0/2 slave

# Smart Link1中使能发送Flush报文的功能,并指定发送Flush报文的控制VLANVLAN 20

[DeviceD-smlk-group1] flush enable control-vlan 20

[DeviceD-smlk-group1] quit

# 重新开启端口GigabitEthernet1/0/1GigabitEthernet1/0/2

[DeviceD] interface gigabitethernet 1/0/1

[DeviceD-GigabitEthernet1/0/1] undo shutdown

[DeviceD-GigabitEthernet1/0/1] quit

[DeviceD] interface gigabitethernet 1/0/2

[DeviceD-GigabitEthernet1/0/2] undo shutdown

[DeviceD-GigabitEthernet1/0/2] quit

(3)        配置Device B

# 创建VLAN 1~20。

<DeviceB> system-view

[DeviceB] vlan 1 to 20

# 将端口GigabitEthernet1/0/1配置为Trunk端口且允许VLAN 120通过,在该端口上使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 1020

[DeviceB] interface gigabitethernet 1/0/1

[DeviceB-GigabitEthernet1/0/1] port link-type trunk

[DeviceB-GigabitEthernet1/0/1] port trunk permit vlan 1 to 20

[DeviceB-GigabitEthernet1/0/1] smart-link flush enable control-vlan 10 20

[DeviceB-GigabitEthernet1/0/1] quit

# 将端口GigabitEthernet1/0/2配置为Trunk端口且允许VLAN 120通过,在该端口上关闭生成树协议,使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 20

[DeviceB] interface gigabitethernet 1/0/2

[DeviceB-GigabitEthernet1/0/2] port link-type trunk

[DeviceB-GigabitEthernet1/0/2] port trunk permit vlan 1 to 20

[DeviceB-GigabitEthernet1/0/2] undo stp enable

[DeviceB-GigabitEthernet1/0/2] smart-link flush enable control-vlan 20

[DeviceB-GigabitEthernet1/0/2] quit

# 将端口GigabitEthernet1/0/3配置为Trunk端口且允许VLAN 120通过,在该端口上关闭生成树协议,使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 10

[DeviceB] interface gigabitethernet 1/0/3

[DeviceB-GigabitEthernet1/0/3] port link-type trunk

[DeviceB-GigabitEthernet1/0/3] port trunk permit vlan 1 to 20

[DeviceB-GigabitEthernet1/0/3] undo stp enable

[DeviceB-GigabitEthernet1/0/3] smart-link flush enable control-vlan 10

[DeviceB-GigabitEthernet1/0/3] quit

(4)        配置Device E

# 创建VLAN 1~20。

<DeviceE> system-view

[DeviceE] vlan 1 to 20

# 将端口GigabitEthernet1/0/1配置为Trunk端口且允许VLAN 120通过,在该端口上使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 1020

[DeviceE] interface gigabitethernet 1/0/1

[DeviceE-GigabitEthernet1/0/1] port link-type trunk

[DeviceE-GigabitEthernet1/0/1] port trunk permit vlan 1 to 20

[DeviceE-GigabitEthernet1/0/1] smart-link flush enable control-vlan 10 20

[DeviceE-GigabitEthernet1/0/1] quit

# 将端口GigabitEthernet1/0/2配置为Trunk端口且允许VLAN 120通过,在该端口上关闭生成树协议,使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 10

[DeviceE] interface gigabitethernet 1/0/2

[DeviceE-GigabitEthernet1/0/2] port link-type trunk

[DeviceE-GigabitEthernet1/0/2] port trunk permit vlan 1 to 20

[DeviceE-GigabitEthernet1/0/2] undo stp enable

[DeviceE-GigabitEthernet1/0/2] smart-link flush enable control-vlan 10

[DeviceE-GigabitEthernet1/0/2] quit

# 将端口GigabitEthernet1/0/3配置为Trunk端口且允许VLAN 120通过,在该端口上关闭生成树协议,使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 20

[DeviceE] interface gigabitethernet 1/0/3

[DeviceE-GigabitEthernet1/0/3] port link-type trunk

[DeviceE-GigabitEthernet1/0/3] port trunk permit vlan 1 to 20

[DeviceE-GigabitEthernet1/0/2] undo stp enable

[DeviceE-GigabitEthernet1/0/3] smart-link flush enable control-vlan 20

[DeviceE-GigabitEthernet1/0/3] quit

(5)        配置Device A

# 创建VLAN 1~20。

<DeviceA> system-view

[DeviceA] vlan 1 to 20

# 分别将端口GigabitEthernet1/0/1GigabitEthernet1/0/2配置为Trunk端口且允许VLAN 120通过,在这些端口上使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 1020

[DeviceA] interface gigabitethernet 1/0/1

[DeviceA-GigabitEthernet1/0/1] port link-type trunk

[DeviceA-GigabitEthernet1/0/1] port trunk permit vlan 1 to 20

[DeviceA-GigabitEthernet1/0/1] smart-link flush enable control-vlan 10 20

[DeviceA-GigabitEthernet1/0/1] quit

[DeviceA] interface gigabitethernet 1/0/2

[DeviceA-GigabitEthernet1/0/2] port link-type trunk

[DeviceA-GigabitEthernet1/0/2] port trunk permit vlan 1 to 20

[DeviceA-GigabitEthernet1/0/2] smart-link flush enable control-vlan 10 20

[DeviceA-GigabitEthernet1/0/2] quit

(6)        检验配置效果

通过使用display smart-link group命令可以查看设备上Smart Link组的信息:

# 查看Device C上Smart Link组的信息。

[DeviceC] display smart-link group 1

 Smart link group 1 information:

 Device ID: 000f-e23d-5af0

 Preemption mode: NONE

 Preemption delay: 1(s)

 Control VLAN: 10

 Protected VLAN: Reference Instance 1

 Member                     Role    State    Flush-count Last-flush-time

 -----------------------------------------------------------------------------

 GigabitEthernet1/0/1       MASTER  ACTVIE   5           16:37:20 2010/02/21

 

 GigabitEthernet1/0/2       SLAVE   STANDBY  1           17:45:20 2010/02/21

通过使用display smart-link flush命令可以查看设备上收到的Flush报文信息:

# 查看Device B上收到的Flush报文信息。

[DeviceB] display smart-link flush

 Received flush packets                             : 5

 Receiving interface of the last flush packet       : GigabitEthernet1/0/3

 Receiving time of the last flush packet            : 16:25:21 2010/02/21

 Device ID of the last flush packet                 : 000f-e23d-5af0

 Control VLAN of the last flush packet              : 10

1.2.5  完整配置

l              Device A上的配置

#

vlan 1

#

vlan 2 to 20

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 to 20

 smart-link flush enable control-vlan 10 20

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan 1 to 20

 smart-link flush enable control-vlan 10 20

#

l              Device B上的配置

#

vlan 1

#

vlan 2 to 20

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 to 20

 smart-link flush enable control-vlan 10 20

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan 1 to 20

 smart-link flush enable control-vlan 20

#

interface GigabitEthernet1/0/3

 port link-type trunk

 port trunk permit vlan 1 to 20

 smart-link flush enable control-vlan 10

#

l              Device C上的配置

#

vlan 1

#

vlan 2 to 20

#

stp region-configuration

 instance 1 vlan 1 to 20

 active region-configuration

#

smart-link group 1

 protected-vlan reference-instance 1

 flush enable control-vlan 10

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 to 20

 stp disable

 port smart-link group 1 master

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan 1 to 20

 stp disable

 port smart-link group 1 slave

#

l              Device D上的配置

#

vlan 1

#

vlan 2 to 20

#

stp region-configuration

 instance 1 vlan 1 to 20

 active region-configuration

#

smart-link group 1

 protected-vlan reference-instance 1

 flush enable control-vlan 20

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 to 20

 stp disable

 port smart-link group 1 master

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan 1 to 20

 stp disable

 port smart-link group 1 slave

#

l              Device E上的配置

#

vlan 1

#

vlan 2 to 20

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 to 20

 smart-link flush enable control-vlan 10 20

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan 1 to 20

 smart-link flush enable control-vlan 10

#

interface GigabitEthernet1/0/3

 port link-type trunk

 port trunk permit vlan 1 to 20

 smart-link flush enable control-vlan 20

#

1.2.6  配置注意事项

l              如果打算配置某端口为Smart Link组成员端口(即主端口和副端口),则需先手工关闭该端口,待Smart Link组配置完成后,再开启该端口,以避免形成环路,导致广播风暴。

l              如果打算配置某端口为Smart Link组成员端口,则需关闭该端口的STP功能和RRPP功能,并确保该端口不是聚合成员端口和业务环回组成员端口。

l              需要为不同的Smart Link组配置不同的控制VLAN。

l              用户需要配置保证控制VLAN存在,且Smart Link组的端口允许控制VLAN的报文通过。

l              某Smart Link组的控制VLAN应同时为该Smart Link组的保护VLAN,且不要将已配置为控制VLAN的VLAN删除,否则会影响Flush报文的发送。

l              配置相关设备时,建议在其与Smart Link组的成员端口直接相连的端口上关闭生成树协议,以免由于网络拓扑改变时端口状态尚未迁移到Forwarding而导致Flush报文被丢弃。

l              在相关设备上配置的接收处理Flush报文的控制VLAN和在Smart Link设备上配置的发送控制VLAN要相同,如果二者不相同,相关设备将对接收到的Flush报文不做处理直接转发。

1.3  多Smart Link组实现负载分担典型配置指导

在同一个环网中,可能同时存在多个VLAN的数据流量,Smart Link可以实现流量的负载分担,即不同VLAN的流量沿不同Smart Link组所确定的路径进行转发。

通过把一个端口配置为多个Smart Link组的成员端口(每个Smart Link组的保护VLAN不同),且该端口在不同组中的转发状态不同,这样就能实现不同VLAN的数据流量的转发路径不同,从而达到负载分担的目的。

1.3.1  组网图

图1-3 配置多Smart Link组负载分担组网图

 

1.3.2  应用需求

l              Device C上VLAN 1~20的流量通过Device B和Device D双上行到Device A。

l              通过配置,在Device C上实现双上行链路的灵活备份和负载分担:VLAN 1~10的流量经Device B向Device A转发,VLAN 11~20的流量经Device D向Device A转发。

1.3.3  适用产品、版本

表1-2 配置适用的产品与软件版本关系

产品

软件版本

S7500E系列以太网交换机

Release 6300系列,Release 6600系列,Release 6610系列

S7600系列以太网交换机

Release 6600系列,Release 6610系列

S5800&S5820X系列以太网交换机

Release 1110,Release 1211

CE3000-32F以太网交换机

Release 1211

S5810系列以太网交换机

Release 1102

S5500-EI系列以太网交换机

Release 2202,Release 2208

S5500-EI-D系列以太网交换机

Release 2208

S5500-SI系列以太网交换机

Release 2202 ,Release 2208

S5120-EI系列以太网交换机

Release 2202,Release 2208

S5120-EI-D系列以太网交换机

Release 1505

S5120-SI系列以太网交换机

Release 1505

S3610&S5510系列以太网交换机

Release 5306,Release 5309

S3500-EA系列以太网交换机

Release 5309

S3100V2-EI系列以太网交换机

Release 5103

E126B以太网交换机

Release 5103

 

1.3.4  配置过程和解释

(1)        配置Device C

# 创建VLAN 1~20,分别将VLAN 1~10映射到MSTI 1、VLAN 11~20映射到MSTI2上,并激活MST域的配置。

<DeviceC> system-view

[DeviceC] vlan 1 to 20

[DeviceC] stp region-configuration

[DeviceC-mst-region] instance 1 vlan 1 to 10

[DeviceC-mst-region] instance 2 vlan 11 to 20

[DeviceC-mst-region] active region-configuration

[DeviceC-mst-region] quit

# 分别关闭端口GigabitEthernet1/0/1GigabitEthernet1/0/2,在这两个端口上分别关闭生成树协议,并将端口配置为Trunk端口且允许VLAN 120通过。

[DeviceC] interface gigabitethernet 1/0/1

[DeviceC-GigabitEthernet1/0/1] shutdown

[DeviceC-GigabitEthernet1/0/1] undo stp enable

[DeviceC-GigabitEthernet1/0/1] port link-type trunk

[DeviceC-GigabitEthernet1/0/1] port trunk permit vlan 1 to 20

[DeviceC-GigabitEthernet1/0/1] quit

[DeviceC] interface gigabitethernet 1/0/2

[DeviceC-GigabitEthernet1/0/2] shutdown

[DeviceC-GigabitEthernet1/0/2] undo stp enable

[DeviceC-GigabitEthernet1/0/2] port link-type trunk

[DeviceC-GigabitEthernet1/0/2] port trunk permit vlan 1 to 20

[DeviceC-GigabitEthernet1/0/2] quit

# 创建Smart Link1,并配置其保护VLANMSTI 1所映射的VLAN

[DeviceC] smart-link group 1

[DeviceC-smlk-group1] protected-vlan reference-instance 1

# 配置Smart Link1的主端口为GigabitEthernet1/0/1,从端口为GigabitEthernet1/0/2

[DeviceC-smlk-group1] port gigabitethernet 1/0/1 master

[DeviceC-smlk-group1] port gigabitethernet 1/0/2 slave

# Smart Link1中配置抢占模式为角色抢占模式;使能发送Flush报文的功能,并指定发送Flush报文的控制VLANVLAN 10

[DeviceC-smlk-group1] preemption mode role

[DeviceC-smlk-group1] flush enable control-vlan 10

[DeviceC-smlk-group1] quit

# 创建Smart Link2,并配置其保护VLANMSTI 2所映射的VLAN

[DeviceC] smart-link group 2

[DeviceC-smlk-group2] protected-vlan reference-instance 2

# 配置Smart Link2的主端口为GigabitEthernet1/0/2,从端口为GigabitEthernet1/0/1

[DeviceC-smlk-group2] port gigabitethernet 1/0/2 master

[DeviceC-smlk-group2] port gigabitethernet 1/0/1 slave

# Smart Link2中配置抢占模式为角色抢占模式;使能发送Flush报文的功能,并指定发送Flush报文的控制VLANVLAN 20

[DeviceC-smlk-group2] preemption mode role

[DeviceC-smlk-group2] flush enable control-vlan 20

[DeviceC-smlk-group2] quit

# 重新开启端口GigabitEthernet1/0/1GigabitEthernet1/0/2

[DeviceC] interface gigabitethernet 1/0/1

[DeviceC-GigabitEthernet1/0/1] undo shutdown

[DeviceC-GigabitEthernet1/0/1] quit

[DeviceC] interface gigabitethernet 1/0/2

[DeviceC-GigabitEthernet1/0/2] undo shutdown

[DeviceC-GigabitEthernet1/0/2] quit

(2)        配置Device B

# 创建VLAN 1~20。

<DeviceB> system-view

[DeviceB] vlan 1 to 20

# 将端口GigabitEthernet1/0/1配置为Trunk端口且允许VLAN 120通过,在该端口上使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 1020

[DeviceB] interface gigabitethernet 1/0/1

[DeviceB-GigabitEthernet1/0/1] port link-type trunk

[DeviceB-GigabitEthernet1/0/1] port trunk permit vlan 1 to 20

[DeviceB-GigabitEthernet1/0/1] smart-link flush enable control-vlan 10 20

[DeviceB-GigabitEthernet1/0/1] quit

# 将端口GigabitEthernet1/0/2配置为Trunk端口且允许VLAN 120通过,在该端口上关闭生成树协议,使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 1020

[DeviceB] interface gigabitethernet 1/0/2

[DeviceB-GigabitEthernet1/0/2] port link-type trunk

[DeviceB-GigabitEthernet1/0/2] port trunk permit vlan 1 to 20

[DeviceB-GigabitEthernet1/0/2] undo stp enable

[DeviceB-GigabitEthernet1/0/2] smart-link flush enable control-vlan 10 20

[DeviceB-GigabitEthernet1/0/2] quit

(3)        配置Device D

# 创建VLAN 1~20。

<DeviceD> system-view

[DeviceD] vlan 1 to 20

# 将端口GigabitEthernet1/0/1配置为Trunk端口且允许VLAN 120通过,在该端口上使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 1020

[DeviceD] interface gigabitethernet 1/0/1

[DeviceD-GigabitEthernet1/0/1] port link-type trunk

[DeviceD-GigabitEthernet1/0/1] port trunk permit vlan 1 to 20

[DeviceD-GigabitEthernet1/0/1] smart-link flush enable control-vlan 10 20

[DeviceD-GigabitEthernet1/0/1] quit

# 将端口GigabitEthernet1/0/2配置为Trunk端口且允许VLAN 120通过,在该端口上关闭生成树协议,使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 1020

[DeviceD] interface gigabitethernet 1/0/2

[DeviceD-GigabitEthernet1/0/2] port link-type trunk

[DeviceD-GigabitEthernet1/0/2] port trunk permit vlan 1 to 20

[DeviceD-GigabitEthernet1/0/2] undo stp enable

[DeviceD-GigabitEthernet1/0/2] smart-link flush enable control-vlan 10 20

[DeviceD-GigabitEthernet1/0/2] quit

(4)        配置Device A

# 创建VLAN 1~20。

<DeviceA> system-view

[DeviceA] vlan 1 to 20

# 分别将端口GigabitEthernet1/0/1GigabitEthernet1/0/2配置为Trunk端口且允许VLAN 120通过,在这些端口上使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 1020

[DeviceA] interface gigabitethernet 1/0/1

[DeviceA-GigabitEthernet1/0/1] port link-type trunk

[DeviceA-GigabitEthernet1/0/1] port trunk permit vlan 1 to 20

[DeviceA-GigabitEthernet1/0/1] smart-link flush enable control-vlan 10 20

[DeviceA-GigabitEthernet1/0/1] quit

[DeviceA] interface gigabitethernet 1/0/2

[DeviceA-GigabitEthernet1/0/2] port link-type trunk

[DeviceA-GigabitEthernet1/0/2] port trunk permit vlan 1 to 20

[DeviceA-GigabitEthernet1/0/2] smart-link flush enable control-vlan 10 20

[DeviceA-GigabitEthernet1/0/2] quit

(5)        检验配置效果

通过使用display smart-link group命令可以查看设备上Smart Link组的信息:

# 查看Device C上Smart Link组的信息。

[DeviceC] display smart-link group all

 Smart link group 1 information:

 Device ID: 000f-e23d-5af0

 Preemption mode: ROLE

 Preemption delay: 1(s)

 Control VLAN: 10

 Protected VLAN: Reference Instance 1

 Member                     Role    State    Flush-count Last-flush-time

 -----------------------------------------------------------------------------

 GigabitEthernet1/0/1       MASTER  ACTVIE   5           16:37:20 2010/02/21

 

 GigabitEthernet1/0/2       SLAVE   STANDBY  1           17:45:20 2010/02/21

 

 

 Smart link group 2 information:

 Device ID: 000f-e23d-5af0

 Preemption mode: ROLE

 Preemption delay: 1(s)

 Control VLAN: 20

 Protected VLAN: Reference Instance 2

 Member                     Role    State    Flush-count Last-flush-time

 -----------------------------------------------------------------------------

 GigabitEthernet1/0/2       MASTER  ACTVIE   5           16:37:20 2010/02/21

 

 GigabitEthernet1/0/1       SLAVE   STANDBY  1           17:45:20 2010/02/21

通过使用display smart-link flush命令可以查看设备上收到的Flush报文信息:

# 查看Device B上收到的Flush报文信息。

[DeviceB] display smart-link flush

 Received flush packets                             : 5

 Receiving interface of the last flush packet       : GigabitEthernet1/0/2

 Receiving time of the last flush packet            : 16:25:21 2010/02/21

 Device ID of the last flush packet                 : 000f-e23d-5af0

 Control VLAN of the last flush packet              : 10

1.3.5  完整配置

l              Device A上的配置

#

vlan 1

#

vlan 2 to 20

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 to 20

 smart-link flush enable control-vlan 10 20

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan 1 to 20

 smart-link flush enable control-vlan 10 20

#

l              Device B上的配置

#

vlan 1

#

vlan 2 to 20

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 to 20

 smart-link flush enable control-vlan 10 20

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan 1 to 20

 smart-link flush enable control-vlan 10 20

#

l              Device C上的配置

#

vlan 1

#

vlan 2 to 20

#

stp region-configuration

 instance 1 vlan 1 to 10

 instance 2 vlan 11 to 20

 active region-configuration

#

smart-link group 1

 preemption mode role

 protected-vlan reference-instance 1

 flush enable control-vlan 10

smart-link group 2

 preemption mode role

 protected-vlan reference-instance 2

 flush enable control-vlan 20

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 to 20

 stp disable

 port smart-link group 1 master

 port smart-link group 2 slave

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan 1 to 20

 stp disable

 port smart-link group 1 slave

 port smart-link group 2 master

#

l              Device D上的配置

#

vlan 1

#

vlan 2 to 20

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 to 20

 smart-link flush enable control-vlan 10 20

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan 1 to 20

 smart-link flush enable control-vlan 10 20

#

1.3.6  配置注意事项

l              如果打算配置某端口为Smart Link组成员端口(即主端口和副端口),则需先手工关闭该端口,待Smart Link组配置完成后,再开启该端口,以避免形成环路,导致广播风暴。

l              如果打算配置某端口为Smart Link组成员端口,则需关闭该端口的STP功能和RRPP功能,并确保该端口不是聚合成员端口和业务环回组成员端口。

l              需要为不同的Smart Link组配置不同的控制VLAN。

l              用户需要配置保证控制VLAN存在,且Smart Link组的端口允许控制VLAN的报文通过。

l              某Smart Link组的控制VLAN应同时为该Smart Link组的保护VLAN,且不要将已配置为控制VLAN的VLAN删除,否则会影响Flush报文的发送。

l              配置相关设备时,建议在其与Smart Link组的成员端口直接相连的端口上关闭生成树协议,以免由于网络拓扑改变时端口状态尚未迁移到Forwarding而导致Flush报文被丢弃。

l              在相关设备上配置的接收处理Flush报文的控制VLAN和在Smart Link设备上配置的发送控制VLAN要相同,如果二者不相同,相关设备将对接收到的Flush报文不做处理直接转发。

 


2 Monitor Link典型配置指导

2.1  Monitor Link简介

Monitor Link是一种端口联动方案,主要用于配合二层拓扑协议的组网应用,监控设备上行链路,根据上行链路的up/down状态变化来触发下行链路的up/down变化,从而触发下游设备上拓扑协议所控制备份链路的切换。

2.2  使用Monitor Link监视Smart Link上行链路典型配置指导

2.2.1  组网图

图2-1 Monitor Link配合Smart Link应用组网图

 

2.2.2  应用需求

l              设备Device C通过多Smart Link组将VLAN 1~10和VLAN 11~20的流量分别沿不同的路径双上行到设备Device A,具体配置请参见1.3  多Smart Link组实现负载分担典型配置指导

l              当Device A与Device B(或Device D)之间出现链路故障时,Device C能够感知到这个故障并完成其上行链路的切换。

2.2.3  适用产品、版本

表2-1 配置适用的产品与软件版本关系

产品

软件版本

S7500E系列以太网交换机

Release 6600系列,Release 6610系列

S7600系列以太网交换机

Release 6600系列,Release 6610系列

S5800&S5820X系列以太网交换机

Release 1110,Release 1211

CE3000-32F以太网交换机

Release 1211

S5810系列以太网交换机

Release 1102

S5500-EI系列以太网交换机

Release 2202,Release 2208

S5500-EI-D系列以太网交换机

Release 2208

S5500-SI系列以太网交换机

Release 2202 ,Release 2208

S5120-EI系列以太网交换机

Release 2202,Release 2208

S5120-EI-D系列以太网交换机

Release 1505

S5120-SI系列以太网交换机

Release 1505

S3610&S5510系列以太网交换机

Release 5306,Release 5309

S3500-EA系列以太网交换机

Release 5309

S3100V2-EI系列以太网交换机

Release 5103

E126B以太网交换机

Release 5103

 

2.2.4  配置过程和解释

1. 配置Smart Link

Device A~Device D上已经完成Smart Link组的配置,具体请参见1.3  多Smart Link组实现负载分担典型配置指导

2. 配置Monitor Link

(1)        配置Device B

# 创建Monitor Link组1。

<DeviceB> system-view

[DeviceB] monitor-link group 1

# 配置Monitor Link组1的上行链路为端口GigabitEthernet1/0/1,下行链路为端口GigabitEthernet1/0/2。

[DeviceB-mtlk-group1] port gigabitethernet 1/0/1 uplink

[DeviceB-mtlk-group1] port gigabitethernet 1/0/2 downlink

[DeviceB-mtlk-group-1] quit

(2)        配置Device D

# 创建Monitor Link组1。

<DeviceD> system-view

[DeviceD] monitor-link group 1

# 配置Monitor Link组1的上行链路为端口GigabitEthernet1/0/1,下行链路为端口GigabitEthernet1/0/2。

[DeviceD-mtlk-group1] port gigabitethernet 1/0/1 uplink

[DeviceD-mtlk-group1] port gigabitethernet 1/0/2 downlink

[DeviceD-mtlk-group1] quit

(3)        检验配置效果

通过使用display monitor-link group命令可以查看各设备上Monitor Link组的信息。例如当Device A的端口GigabitEthernet1/0/2由于链路故障而down掉时:

# 查看Device B上Monitor Link组1的信息。

[DeviceB] display monitor-link group 1

 Monitor link group 1 information:

 Group status: UP

 Last-up-time: 16:37:20 2010/02/21

 Last-down-time: 16:35:26 2010/02/21

 Member                    Role     Status

 ------------------------------------------

 GigabitEthernet1/0/1      UPLINK   UP

 GigabitEthernet1/0/2      DOWNLINK UP

# 查看Device DMonitor Link1的信息。

[DeviceD] display monitor-link group 1

 Monitor link group 1 information:

 Group status: DOWN

 Last-up-time: 16:35:27 2010/02/21

 Last-down-time: 16:37:19 2010/02/21

 Member                    Role     Status

 ------------------------------------------

 GigabitEthernet1/0/1      UPLINK   DOWN

 GigabitEthernet1/0/2      DOWNLINK DOWN

2.2.5  完整配置

Device A~Device D上已经完成Smart Link组的配置,具体请参见1.3.5  完整配置

l              Device B上的配置

#

monitor-link group 1

#

interface GigabitEthernet1/0/1

 port monitor-link group 1 uplink

#

interface GigabitEthernet1/0/2

 port monitor-link group 1 downlink

#

l              Device D上的配置

#

monitor-link group 1

#

interface GigabitEthernet1/0/1

 port monitor-link group 1 uplink

#

interface GigabitEthernet1/0/2

 port monitor-link group 1 downlink

#

2.2.6  配置注意事项

l              如果欲配置某端口为Monitor Link组的成员端口(上行端口或下行端口),需确保该端口不是聚合成员端口或业务环回组成员端口。

l              Monitor Link组的成员端口可以是二层以太网端口或二层聚合接口。

l              一个端口只能属于一个Monitor Link组。

l              建议先配置Monitor Link的上行端口,以避免下行端口出现不必要的down/up状态变化。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!