选择区域语言: EN CN HK

H3C 中低端以太网交换机 IP组播典型配置指导-6W100

05-组播路由与转发配置指导

本章节下载  (253.12 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/CE3000/CE3000-EI/Configure/Typical_Configuration_Example/H3C_IP_CG-6W100/201111/733135_30005_0.htm

05-组播路由与转发配置指导


1 组播路由与转发典型配置指导

1.1  组播静态路由典型配置指导(改变RPF路由)

组播静态路由是RPF(Reverse Path Forwarding,逆向路径转发)检查的重要依据之一,可以通过配置组播静态路由以改变RPF路由,从而为组播数据创建一条与单播不同的传输路径(通常情况下,组播数据的传输路径与单播相同)。

1.1.1  适用产品、版本

表1-1 配置适用的产品与软件版本关系

产品

软件版本

S7500E系列以太网交换机

Release 6100系列,Release 6300系列,Release 6600系列,Release 6610系列

S7600系列以太网交换机

Release 6600系列,Release 6610系列

S5800&S5820X系列以太网交换机

Release 1110,Release 1211

CE3000-32F以太网交换机

Release 1211

S5500-EI系列以太网交换机

Release 2202,Release 2208

S5500-EI-D系列以太网交换机

Release 2208

S3610&S5510系列以太网交换机

Release 5301,Release 5303,Release 5306,Release 5309

S3500-EA系列以太网交换机

Release 5303,Release 5309

 

1.1.2  组网需求

图1-1所示网络:

l              Switch A、Switch B和Switch C之间运行OSPF协议,实现用户网络与服务器群网络间单播三层互通;

l              Switch A、Switch B和Switch C之间运行PIM-DM协议,实现位于服务器群网络中的组播源Source发送的组播信息能被用户网络中的接收者所接收。

要求通过配置,使用户网络中的接收者通过与单播路径不同的路径来接收组播源Source发来的组播信息,以减轻单播路径的负担。

图1-1 改变RPF路由配置指导

 

1.1.3  配置思路

使用PIM-DM协议在创建组播路由表项时,运用了RPF检查机制,而执行RPF检查的依据是组播静态路由、MBGP路由或单播路由,执行RPF检查时,会从这三条路由中选择一条作为RPF路由(组播路由表项建立的依据)。而上面网络中并未配置MBGP,也未配置组播静态路由,所以在进行RPF检查时仅使用OSPF协议建立起来的单播路由作为RPF路由,从而使用户网络中的接收者将通过与单播路径相同的路径(Switch A—Switch B)接收来自Source的组播信息。

为了实现上述组网需求,则需要在Switch B上配置组播静态路由,以改变RPF路由,使组播信息由Switch A—Switch C—Switch B路径到达接收者。

1.1.4  配置过程和解释

(1)        配置各交换机接口的IP地址和单播路由协议

请按照图1-1配置各接口的IP地址和掩码,具体配置过程略。

配置PIM-DM域内的各交换机之间采用OSPF协议进行互连,确保PIM-DM域内部在网络层互通,并且各交换机之间能够借助单播路由协议实现动态路由更新,具体配置过程略。

(2)        使能IP组播路由,并使能PIM-DM和IGMP

# 在Switch B上使能IP组播路由,在各接口上使能PIM-DM,并在主机侧接口Vlan-interface100上使能IGMP。

<SwitchB> system-view

[SwitchB] multicast routing-enable

[SwitchB] interface vlan-interface 100

[SwitchB-Vlan-interface100] igmp enable

[SwitchB-Vlan-interface100] pim dm

[SwitchB-Vlan-interface100] quit

[SwitchB] interface vlan-interface 101

[SwitchB-Vlan-interface101] pim dm

[SwitchB-Vlan-interface101] quit

[SwitchB] interface vlan-interface 102

[SwitchB-Vlan-interface102] pim dm

[SwitchB-Vlan-interface102] quit

# 在Switch A上使能IP组播路由,并在各接口上使能PIM-DM。

<SwitchA> system-view

[SwitchA] multicast routing-enable

[SwitchA] interface vlan-interface 200

[SwitchA-Vlan-interface200] pim dm

[SwitchA-Vlan-interface200] quit

[SwitchA] interface vlan-interface 102

[SwitchA-Vlan-interface102] pim dm

[SwitchA-Vlan-interface102] quit

[SwitchA] interface vlan-interface 103

[SwitchA-Vlan-interface103] pim dm

[SwitchA-Vlan-interface103] quit

Switch C上的配置与Switch A相似,配置过程略。

# 在Switch B上使用display multicast rpf-info命令查看到Source的RPF信息。

[SwitchB] display multicast rpf-info 50.1.1.100

 RPF information about source 50.1.1.100:

     RPF interface: Vlan-interface102, RPF neighbor: 30.1.1.2

     Referenced route/mask: 50.1.1.0/24

     Referenced route type: igp

     Route selection rule: preference-preferred

     Load splitting rule: disable

Switch B上当前的RPF路由来源于单播路由,RPF邻居是Switch A。

(3)        配置组播静态路由

# 在Switch B上配置组播静态路由,到Source的RPF邻居为Switch C

[SwitchB] ip rpf-route-static 50.1.1.100 24 20.1.1.2

(4)        检验配置效果

# 在Switch B上使用display multicast rpf-info命令查看到Source的RPF信息。

[SwitchB] display multicast rpf-info 50.1.1.100

 RPF information about source 50.1.1.100:

     RPF interface: Vlan-interface101, RPF neighbor: 20.1.1.2

     Referenced route/mask: 50.1.1.0/24

     Referenced route type: multicast static

     Route selection rule: preference-preferred

     Load splitting rule: disable

与配置组播静态路由前相比,Switch B上的RPF路由已经产生了变化,其来源变为组播静态路由,RPF邻居变为Switch C。

1.1.5  完整配置

(1)        Switch A配置信息

#

 multicast routing-enable

#

interface Vlan-interface102

 ip address 30.1.1.2 255.255.255.0.

 pim dm

#

interface Vlan-interface103

 ip address 40.1.1.2 255.255.255.0

 pim dm

#

interface Vlan-interface200

 ip address 50.1.1.1 255.255.255.0

 pim dm

#

(2)        Switch B配置信息

#

 multicast routing-enable

#

interface Vlan-interface100

 ip address 10.1.1.1 255.255.255.0.

 igmp enable

 pim dm

#

interface Vlan-interface101

 ip address 20.1.1.1 255.255.255.0.

 pim dm

#

interface Vlan-interface102

 ip address 30.1.1.1 255.255.255.0

 pim dm

#

ip rpf-route-static 50.1.1.0 24 20.1.1.2

#

(3)        Switch C配置信息

#

 multicast routing-enable

#

interface Vlan-interface101

 ip address 20.1.1.2 255.255.255.0.

 pim dm

#

interface Vlan-interface103

 ip address 40.1.1.1 255.255.255.0

 pim dm

#

1.1.6  配置注意事项

无。

1.2  组播静态路由典型配置指导(衔接RPF路由)

一般情况下,RPF路由的生成依赖于网络中的单播路由。当网络中的单播路由被阻断时,由于没有RPF路由而无法进行包括组播数据在内的数据转发。可以通过配置组播静态路由以生成RPF路由,从而创建组播路由表项以指导组播数据的转发。

1.2.1  适用产品、版本

表1-2 配置适用的产品与软件版本关系

产品

软件版本

S7500E系列以太网交换机

Release 6100系列,Release 6300系列,Release 6600系列,Release 6610系列

S7600系列以太网交换机

Release 6600系列,Release 6610系列

S5800&S5820X系列以太网交换机

Release 1110,Release 1211

CE3000-32F以太网交换机

Release 1211

S5500-EI系列以太网交换机

Release 2202,Release 2208

S5500-EI-D系列以太网交换机

Release 2208

S3610&S5510系列以太网交换机

Release 5301,Release 5303,Release 5306,Release 5309

S3500-EA系列以太网交换机

Release 5303,Release 5309

 

1.2.2  组网需求

图1-2所示网络:

l              三层交换机Switch A和Switch B之间运行OSPF协议,保证用户网络N2内的用户可以访问服务器群网络N1。

l              三层交换机Switch C和Switch D之间运行RIP协议,保证用户网络N3内的用户可以访问服务器群网络N4。

l              为了保证信息安全,Switch B与Switch C单播路由隔离,即OSPF域和RIP域均不引入外部路由,使得N1、N2网络不能和N3、N4网络之间互访。

l              目前整个网络中运行PIM-DM协议,N2内的Host A能通过加入组播组224.1.1.1来接收来自OSPF域内Source 1的组播信息,N3内的Host C能通过加入225.1.1.1来接收来自RIP域内Source 2的组播信息。

要求通过配置,使N2内的Host B也可以接收来自OSPF域外Source 2的组播信息,N3内的Host D也可以接收来自RIP域外Source 1的组播信息。

图1-2 衔接RPF路由配置组网图

 

1.2.3  配置思路

通常情况下,PIM协议以单播路由为基础,依赖RPF(Reverse Path Forwarding,逆向路径转发)机制实现PIM路由表的建立与组播数据的转发。

在上述网络中,当Source 1的组播报文到达Switch C时,由于Switch B上的OSPF和Switch C上的RIP均不引入外部路由,致使OSPF域与RIP域间单播路由隔离,Switch C对收到来自Source 1的组播报文所进行的RPF检查将会失败,从而无法在Switch C上建立来自组播源Source 1的组播路由表项。同理也不会在Switch B上建立自组播源Source 2的组播路由表项。

为了满足上述组网需求,需要进行如下配置:

l              在Switch B上配置组播静态路由,指定到Source 2的RPF邻居为Switch C。从而保证N2内的用户可以接收Source 2发送的组播报文。

l              在Switch C上配置组播静态路由,指定到Source 1的RPF邻居为Switch B。从而保证N3内的用户可以接收Source 1发送的组播报文

1.2.4  配置过程和解释

(1)        配置IP地址和单播路由协议

请按照图1-2配置各接口的IP地址和掩码,具体配置过程略。

配置Switch A和Switch B之间采用OSPF协议进行互连、Switch C和Switch D之间采用RIP协议进行互连,确保Switch A和Switch B之间在网络层互通、Switch C和Switch D之间在网络层互通,并且能够借助单播路由协议实现动态路由更新,具体配置过程略。

(2)        使能IP组播路由,并使能PIM-DM和IGMP

# 在Switch A上使能IP组播路由,并在各接口上使能PIM-DM。

<SwitchA> system-view

[SwitchA] multicast routing-enable

[SwitchC] interface vlan-interface 100

[SwitchC-Vlan-interface100] pim dm

[SwitchC-Vlan-interface100] quit

[SwitchC] interface vlan-interface 101

[SwitchC-Vlan-interface101] pim dm

[SwitchC-Vlan-interface101] quit

Switch D上的配置与Switch A相似,配置过程略。

# 在Switch B上使能IP组播路由,在各接口上使能PIM-DM,并在主机侧接口Vlan-interface200上使能IGMP。

<SwitchB> system-view

[SwitchB] multicast routing-enable

[SwitchB] interface vlan-interface 200

[SwitchB-Vlan-interface200] igmp enable

[SwitchB-Vlan-interface200] pim dm

[SwitchB-Vlan-interface200] quit

[SwitchB] interface vlan-interface 101

[SwitchB-Vlan-interface101] pim dm

[SwitchB-Vlan-interface101] quit

[SwitchB] interface vlan-interface 102

[SwitchB-Vlan-interface102] pim dm

[SwitchB-Vlan-interface102] quit

Switch C上的配置与Switch B相似,配置过程略

# 在Switch B上使用display multicast rpf-info命令查看到Source 2的RPF信息。

[SwitchB] display multicast rpf-info 70.1.1.100

没有显示信息输出,说明在Switch B上没有到Source 2的RPF路由。在Switch C上使用该命令查看到Source 1的RPF信息,Switch C上也没有到Source 1的RPF路由。

(3)        配置组播静态路由

# 在Switch B上配置组播静态路由,指定到Source 2的RPF邻居为Switch C。

[SwitchB] ip rpf-route-static 70.1.1.100 24 40.1.1.2

# 在Switch C上配置组播静态路由,指定到Source 1的RPF邻居为Switch B。

[SwitchC] ip rpf-route-static 10.1.1.100 24 40.1.1.1

(4)        检验配置效果

l              配置完成后,通过使用display multicast rpf-info命令可以查看RPF信息。例如:

# 在Switch B上使用display multicast rpf-info命令查看到Source 2的RPF信息。

[SwitchB] display multicast rpf-info 70.1.1.100

 RPF information about source 70.1.1.100:

     RPF interface: Vlan-interface102, RPF neighbor: 40.1.1.2

     Referenced route/mask: 70.1.1.0/24

     Referenced route type: multicast static

     Route selection rule: preference-preferred

     Load splitting rule: disable

与配置组播静态路由前相比,Switch B上有了到Source 2的RPF路由,且其均来源于组播静态路由。

l              通过Host A和Host B检验一下配置效果。用户网络N2内的用户Host A通过加入组播组224.1.1.1接收Source 1发来的组播信息,Host B通过加入组播组225.1.1.1接收Source 2发来的组播信息。通过使用display pim routing-table命令可以查看交换机的PIM路由表信息。例如:

# 查看Switch B上的PIM路由表信息。

[SwitchA] display pim routing-table

Total 2 (*, G) entry; 2 (S, G) entry

 

(*, 224.1.1.1)

     Protocol: pim-dm, Flag: WC

     UpTime: 00:04:23

     Upstream interface: NULL

         Upstream neighbor: NULL

         RPF prime neighbor: NULL

     Downstream interface(s) information:

       Total number of downstreams: 1

           1: Vlan-interface200

                  Protocol: igmp, UpTime: 00:04:23, Expires: never

 

 (*, 225.1.1.1)

     Protocol: pim-dm, Flag: WC

     UpTime: 00:04:25

     Upstream interface: NULL

         Upstream neighbor: NULL

         RPF prime neighbor: NULL

     Downstream interface(s) information:

       Total number of downstreams: 1

           1: Vlan-interface200

                  Protocol: igmp, UpTime: 00:04:25, Expires: never

 

 (10.1.1.100, 224.1.1.1)

     Protocol: pim-dm, Flag: ACT

     UpTime: 00:06:10

     Upstream interface: Vlan-interface101,

         Upstream neighbor: 20.1.1.1

         RPF prime neighbor: 20.1.1.1

     Downstream interface(s) information:

       Total number of downstreams: 1

           1: Vlan-interface200

                  Protocol: pim-dm, UpTime: 00:04:20, Expires: never

 

(70.1.1.100, 225.1.1.1)

     Protocol: pim-dm, Flag: ACT

     UpTime: 00:06:14

     Upstream interface: Vlan-interface102,

         Upstream neighbor: 40.1.1.2

         RPF prime neighbor: 40.1.1.2

     Downstream interface(s) information:

       Total number of downstreams: 1

           1: Vlan-interface200

                  Protocol: pim-dm, UpTime: 00:04:25, Expires: never

由上显示信息可知,通过配置组播静态路由,在Switch B上可以成功生成到Source 2PIM组播路由表项,从而保证Host B可以接收来自Source 2的组播报文。

1.2.5  完整配置

(1)        Switch A配置信息

#

 multicast routing-enable

#

interface Vlan-interface100

 ip address 10.1.1.1 255.255.255.0.

 pim dm

#

interface Vlan-interface101

 ip address 20.1.1.1 255.255.255.0

 pim dm

#

(2)        Switch B配置信息

#

 multicast routing-enable

#

interface Vlan-interface101

 ip address 20.1.1.2 255.255.255.0.

 pim dm

#

interface Vlan-interface102

 ip address 40.1.1.1 255.255.255.0.

 pim dm

#

interface Vlan-interface200

 ip address 30.1.1.1 255.255.255.0

 igmp enable

 pim dm

#

ip rpf-route-static 70.1.1.0 24 40.1.1.2

#

(3)        Switch C配置信息

#

 multicast routing-enable

#

interface Vlan-interface102

 ip address 40.1.1.2 255.255.255.0.

 pim dm

#

interface Vlan-interface103

 ip address 60.1.1.1 255.255.255.0.

 pim dm

#

interface Vlan-interface300

 ip address 50.1.1.1 255.255.255.0

 igmp enable

 pim dm

#

ip rpf-route-static 10.1.1.0 24 40.1.1.1

#

(4)        Switch D配置信息

#

 multicast routing-enable

#

interface Vlan-interface103

 ip address 60.1.1.2 255.255.255.0.

 pim dm

#

interface Vlan-interface400

 ip address 70.1.1.1 255.255.255.0

 pim dm

#

1.2.6  配置注意事项

1.3  利用GRE隧道实现组播转发配置举例

网络中可能存在不支持组播协议的路由器。从组播源(Source)发出的组播数据沿组播路由器逐跳转发,当下一跳路由器不支持组播协议时,组播转发路径将被阻断。此时,通过在处于单播网段两端的组播路由器之间建立GRE(Generic Routing Encapsulation,通用路由封装)隧道,可以实现跨越单播网段的组播数据交换。

1.3.1  适用产品、版本

表1-3 配置适用的产品与软件版本关系

产品

软件版本

S7500E系列以太网交换机

Release 6600系列,Release 6610系列

S7600系列以太网交换机

Release 6600系列,Release 6610系列

S5800&S5820X系列以太网交换机

Release 1110,Release 1211

CE3000-32F以太网交换机

Release 1211

 

1.3.2  组网需求

图1-3所示:

l              服务器群网络N1和用户网络N2分别通过Switch A和Switch B接入到由不支持组播功能的路由器组成的中间网络。

l              Switch A和Switch B支持组播功能并运行PIM-DM。

l              各设备间通过运行OSPF协议实现N1和N2网络间的单播通信。

要求通过配置,实现N2内的用户能通过组播方式接收位于N1内的组播源Source发来的视频点播信息。

图1-3 利用GRE隧道实现组播转发配置组网图

 

1.3.3  配置思路

由于中间网络内的路由器不支持组播功能,从组播源发出的数据将无法到达接收者。为了满足上述组网需求:

l              在Switch A和Switch B之间建立GRE隧道。

l              在隧道的两端配置单播静态路由,或在隧道两端配置组播静态路由,二者都可用于创建组播路由表项。本配置中选择在隧道两端只配置组播静态路由,使该GRE隧道仅用于组播报文包传输,单播数据包的传输不能使用此隧道。

建立GRE隧道后,Switch A会将组播数据包封装在单播IP报文中,经由单播路由器转发,传送到隧道另一端的Switch B。然后,Switch B将单播IP报文头剥掉,继续进行组播传输。

l          GRE协议是对某些网络层协议(如IP和IPX)的数据报文进行封装,使这些被封装的数据报文能够在另一个网络层协议(如IP)中传输。

l          Tunnel是一个虚拟的点对点的连接,提供了一条通路使封装的数据报文能够在这个通路上传输,并且在一个Tunnel的两端分别对数据报进行封装及解封装。

 

1.3.4  配置过程和解释

(1)        配置IP地址和单播路由协议

请按照图1-3配置各接口的IP地址和掩码,具体配置过程略。

配置各路由器之间采用OSPF协议进行互连,确保网络层互通,具体配置过程略。

(2)        配置GRE隧道

l              配置Switch A

# 在Switch A上创建接口Tunnel0,并为其配置IP地址和掩码。

<SwitchA> system-view

[SwitchA] interface tunnel 0

[SwitchA-Tunnel0] ip address 50.1.1.1 24

# 配置Tunnel0接口采用GRE隧道模式,并为该接口指定源地址和目的地址。

[SwitchA-Tunnel0] tunnel-protocol gre

[SwitchA-Tunnel0] source 20.1.1.1

[SwitchA-Tunnel0] destination 30.1.1.2

[SwitchA-Tunnel0] quit

# 创建服务类型为tunnel的业务环回组1,并将闲置的端口GigabitEthernet1/0/1(该端口不属于VLAN 100和101)加入到业务环回组1内。

[SwitchA] service-loopback group 1 type tunnel

[SwitchA] interface GigabitEthernet 1/0/1

[SwitchA-GigabitEthernet1/0/1] undo stp enable

[SwitchA-GigabitEthernet1/0/1] undo lldp enable

[SwitchA-GigabitEthernet1/0/1] undo ndp enable

[SwitchA-GigabitEthernet1/0/1] port service-loopback group 1

[SwitchA-GigabitEthernet1/0/1] quit

# Tunnel接口视图下指定隧道引用的业务环回组1

[SwitchA] interface tunnel 0

[SwitchA-Tunnel0] service-loopback-group 1

[SwitchA-Tunnel0] quit

l              配置Switch B

# 在Switch B上创建接口Tunnel0,并为其配置IP地址和掩码。

<SwitchB> system-view

[SwitchB] interface tunnel 0

[SwitchB-Tunnel0] ip address 50.1.1.2 24

# 配置Tunnel0接口采用GRE隧道模式,并为该接口指定源地址和目的地址。

[SwitchB-Tunnel0] tunnel-protocol gre

[SwitchB-Tunnel0] source 30.1.1.2

[SwitchB-Tunnel0] destination 20.1.1.1

[SwitchB-Tunnel0] quit

# 创建服务类型为tunnel的业务环回组1,并将闲置的端口GigabitEthernet1/0/1(该端口不属于VLAN 102200)加入到业务环回组1内。

[SwitchB] service-loopback group 1 type tunnel

[SwitchB] interface GigabitEthernet 1/0/1

[SwitchB-GigabitEthernet1/0/1] undo stp enable

[SwitchB-GigabitEthernet1/0/1] undo lldp enable

[SwitchB-GigabitEthernet1/0/1] undo ndp enable

[SwitchB-GigabitEthernet1/0/1] port service-loopback group 1

[SwitchB-GigabitEthernet1/0/1] quit

# Tunnel接口视图下指定隧道引用的业务环回组1

[SwitchB] interface tunnel 0

[SwitchB-Tunnel0] service-loopback-group 1

[SwitchB-Tunnel0] quit

(3)        配置OSPF协议

# 在Switch A上配置OSPF协议。

[SwitchA] ospf 1

[SwitchA-ospf-1] area 0

[SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] network 50.1.1.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] quit

[SwitchA-ospf-1] quit

# 在Switch B上配置OSPF协议。

[SwitchB] ospf 1

[SwitchB-ospf-1] area 0

[SwitchB-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255

[SwitchB-ospf-1-area-0.0.0.0] network 40.1.1.0 0.0.0.255

[SwitchB-ospf-1-area-0.0.0.0] network 50.1.1.0 0.0.0.255

[SwitchB-ospf-1-area-0.0.0.0] quit

[SwitchB-ospf-1] quit

(4)        使能IP组播路由,并使能PIM-DM和IGMP

l              配置Switch A

# 在Switch A上使能IP组播路由,并在各接口上使能PIM-DM。

[SwitchA] multicast routing-enable

[SwitchA] interface vlan-interface 100

[SwitchA-Vlan-interface100] pim dm

[SwitchA-Vlan-interface100] quit

[SwitchA] interface vlan-interface 101

[SwitchA-Vlan-interface101] pim dm

[SwitchA-Vlan-interface101] quit

[SwitchA] interface tunnel 0

[SwitchA-Tunnel0] pim dm

[SwitchA-Tunnel0] quit

l              配置Switch B

# 在Switch B上使能IP组播路由,在各接口上使能PIM-DM,并在用户侧接口Vlan-interface200上使能IGMP。

[SwitchB] multicast routing-enable

[SwitchB] interface vlan-interface 200

[SwitchB-Vlan-interface200] igmp enable

[SwitchB-Vlan-interface200] pim dm

[SwitchB-Vlan-interface200] quit

[SwitchB] interface vlan-interface 102

[SwitchB-Vlan-interface102] pim dm

[SwitchB-Vlan-interface102] quit

[SwitchB] interface tunnel 0

[SwitchB-Tunnel0] pim dm

[SwitchB-Tunnel0] quit

(5)        配置组播静态路由

# 在Switch B上配置组播静态路由,指定到Source的RPF邻居为Switch A的Tunnel0接口。

[SwitchB] ip rpf-route-static 10.1.1.0 24 50.1.1.1

(6)        检验配置效果

组播源Source向组播组225.1.1.1发送组播数据,接收者Host A加入该组播组接收组播数据。通过使用display pim routing-table命令可以查看交换机的PIM路由表信息。例如:

# 查看Switch B上的PIM路由表信息。

[SwitchB] display pim routing-table

 VPN-Instance: public net

 Total 1 (*, G) entry; 1 (S, G) entry

 

 (*, 225.1.1.1)

     Protocol: pim-dm, Flag: WC

     UpTime: 00:04:25

     Upstream interface: NULL

         Upstream neighbor: NULL

         RPF prime neighbor: NULL

     Downstream interface(s) information:

     Total number of downstreams: 1

         1: Vlan-interface200

             Protocol: igmp, UpTime: 00:04:25, Expires: never

 

 (10.1.1.100, 225.1.1.1)

     Protocol: pim-dm, Flag: ACT

     UpTime: 00:06:14

     Upstream interface: Tunnel0

         Upstream neighbor: 50.1.1.1

         RPF prime neighbor: 50.1.1.1

     Downstream interface(s) information:

     Total number of downstreams: 1

         1: Vlan-interface200

             Protocol: pim-dm, UpTime: 00:04:25, Expires: never

由上显示信息可知,Switch B的RPF邻居为Switch A,组播数据通过GRE隧道直接由Switch A发往Switch B。

1.3.5  完整配置

l              SwitchA上的配置

#

 multicast routing-enable

#

 service-loopback group 1 type tunnel

#

vlan 100 to 101

#

interface Vlan-interface100

 ip address 10.1.1.1 255.255.255.0

 pim dm

#

interface Vlan-interface101

 ip address 20.1.1.1 255.255.255.0

 pim dm

#

interface GigabitEthernet1/0/1

 stp disable

 undo ndp enable

 undo lldp enable

 port service-loopback group 1

#

interface Tunnel0

 ip address 50.1.1.1 255.255.255.0

 source 20.1.1.1

 destination 30.1.1.2

 service-loopback-group 1

 pim dm

#

l              SwitchB上的配置

#

 multicast routing-enable

#

 service-loopback group 1 type tunnel

#

vlan 102

#

vlan 200

#

interface Vlan-interface102

 ip address 30.1.1.2 255.255.255.0

 pim dm

#

interface Vlan-interface200

 ip address 40.1.1.1 255.255.255.0

 igmp enable

 pim dm

#

interface GigabitEthernet1/0/1

 stp disable

 undo ndp enable

 undo lldp enable

 port service-loopback group 1

#

interface Tunnel0

 ip address 50.1.1.2 255.255.255.0

 source 30.1.1.2

 destination 20.1.1.1

 service-loopback-group 1

 pim dm

#

ip rpf-route-static 10.1.1.0 24 50.1.1.1

#

1.3.6  配置注意事项

l              Tunnel的源端地址与目的端地址唯一标识了一个通道。这些配置在Tunnel两端必须配置,且两端地址互为源地址和目的地址。

l              对于隧道引用的业务环回组,其内成员端口必须是闲置的以太网端口。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!