- Table of Contents
-
- 01-Fundamentals Command Reference
- 00-Preface
- 01-CLI commands
- 02-RBAC commands
- 03-Login management commands
- 04-FTP and TFTP commands
- 05-File system management commands
- 06-Configuration file management commands
- 07-Multichassis configuration sync commands
- 08-Software upgrade commands
- 09-ISSU commands
- 10-GIR commands
- 11-Automatic configuration commands
- 12-Target configuration management commands
- 13-Device management commands
- 14-Tcl commands
- 15-Python commands
- 16-License management commands
- Related Documents
-
Title | Size | Download |
---|---|---|
07-Multichassis configuration sync commands | 97.24 KB |
Multichassis configuration sync commands
display mc-configure config-check
display mc-configure config-compare
display mc-configure unsync-info
mc-configure access-local enable
mc-configure batch-synchronize
Multichassis configuration sync commands
display mc-configure config-check
Use display mc-configure config-check to display the configuration check result for multichassis configuration synchronization (sync).
Syntax
display mc-configure config-check m-lag [ { evpn-border | evpn-leaf } [ single-homed ] ]
Views
Any view
Predefined user roles
network-admin
network-operator
mdc-admin
mdc-operator
Parameters
m-lag: Specifies the M-LAG system.
evpn-border: Specifies the M-LAG system that plays the EVPN border role.
evpn-leaf: Specifies the M-LAG system that plays the EVPN leaf role.
single-homed: Specifies single-homed devices in the EVPN M-LAG network.
Usage guidelines
This command displays commands that must be configured but are not configured, and solutions for service module configuration issues.
If you do not specify a parameter, this command displays the configuration check result for the M-LAG system.
Examples
# Display the configuration check result for the M-LAG system.
<Sysname> display mc-configure config-check m-lag
The following settings must be configured:
M-LAG:
m-lag system-mac
The following are module suggestions:
LAGG module suggestion:
Don't set the link-aggregation auto-aggregation enable command in the M-LAG networking environment.
display mc-configure config-compare
Use display mc-configure config-compare to display the configuration comparison result for multichassis configuration sync.
Syntax
display mc-configure config-compare [ different | [ interface | verbose ] [ by-table [ width width-length ] ] ]
Views
Any view
Predefined user roles
network-admin
network-operator
mdc-admin
mdc-operator
Parameters
different: Displays the settings that must be configured differently between the peer devices but are configured the same.
interface: Displays settings configured differently between the interfaces numbered the same on the peer devices.
verbose: Displays the detailed configuration comparison result between the peer devices (settings in all views). If you do not specify this keyword, this command displays the brief configuration comparison result (different settings in the same view).
by-table: Displays the configuration comparison result by table. If you do not specify this keyword, this command displays the settings in the order as they appear in the configuration file.
width width-length: Specifies the number of characters in a line in the command output. The value is in the range of 80 to 512. The default value is 80.
Examples
# Display the brief configuration comparison result (different settings in the same view) for multichassis configuration sync.
<Sysname> display mc-configure config-compare
- indicates the configuration on the local device.
+ indicates the configuration on the peer device.
#
- sysname DEV2
- mvrp global enable
+ sysname DEV1
+ stp global enable
#
interface Ten-GigabitEthernet3/0/1
- port link-mode route
+ port link-mode bridge
+ port link-type trunk
+ port trunk permit vlan all
+ mvrp enable
#
- m-lag system-number 2
- m-lag keepalive ip destination 10.1.1.1 source 10.1.1.2
+ m-lag system-number 1
+ m-lag keepalive ip destination 10.1.1.2 source 10.1.1.1
- aaa device-id 1
+ aaa device-id 2
#
# Display the detailed configuration comparison result (settings in all views) for multichassis configuration sync.
<Sysname> display mc-configure config-compare verbose
- indicates the configuration on the local device.
+ indicates the configuration on the peer device.
#
mdc Admin id 1
#
- sysname sysname
- mvrp global enable
+ sysname sysname1
system-working-mode standard
xbar load-single
password-recovery enable
lpu-type f-series
#
vlan 1
#
interface Bridge-Aggregation10
port link-type trunk
port trunk permit vlan all
link-aggregation mode dynamic
port m-lag peer-link 1 auto-negotiate
#
interface Bridge-Aggregation20
link-aggregation mode dynamic
# Display settings that must be configured differently but are configured the same between the peers.
<Sysname> display mc-configure config-compare different
* indicates the command must be different.
#
* vrrp isolate enable
* vrrp ipv6 isolate enable
#
bgp 100
* router-id 1.1.1.1
#
* aaa device-id 1
#
# Display settings configured differently between the interfaces numbered the same on the peers.
<Sysname> display mc-configure config-compare interface
- indicates the configuration on the local device.
+ indicates the configuration on the peer device.
#
interface Ten-GigabitEthernet3/0/1
- port link-mode route
+ port link-mode bridge
+ port link-type trunk
+ port trunk permit vlan all
+ mvrp enable
# Display the configuration comparison result by table.
<Sysname> display mc-configure config-compare by-table
# <
sysname Sysname <
mvrp global enable <
> sysname Sysname1
> stp global enable
# #
interface Ten-GigabitEthernet3/0/1 interface Ten-GigabitEthernet3/0/1
port link-mode route <
> port link-mode bridge
> port link-type trunk
> port trunk permit vlan all
> mvrp enable
# <
m-lag system-number 2 <
m-lag keepalive ip destination 10.1.1 <
> m-lag system-number 1
> m-lag keepalive ip destination 10.1.1
aaa device-id 1 <
> aaa device-id 2
# #
Table 1 Command output
Field |
Description |
< |
Indicates that the setting exists only on the local device. |
> |
Indicates that the setting exists only on the peer device. |
display mc-configure unsync-info
Use display mc-configure unsync-info to display settings not synchronized to the peer during bulk configuration sync.
Syntax
display mc-configure unsync-info
Views
Any view for multichassis configuration sync
Predefined user roles
network-admin
network-operator
mdc-admin
mdc-operator
Usage guidelines
Bulk configuration sync will not synchronize the settings that must be different between the peers. To know the configuration sync status and view commands that have not been synchronized to the peer, execute the display mc-configure unsync-info command.
Examples
# Display settings not synchronized to the peer during bulk configuration sync.
<Sysname> system-view mc-config
System View: return to User View with Ctrl+Z.
All commands in this view will be synchronized to the peer device.
+[Sysname] mc-configure batch-synchronize
7 commands were not synchronized. To view the detailed information, execute the display mc-configure unsync-info command.
+[Sysname] display mc-configure unsync-info
* indicates an unsynchronized command.
The following commands were not synchronized to the peer device in the last batch synchronization.
*gir snapshot add ipv4routes
*vrrp isolate enable
interface Vlan-interface100
* ip address 1.2.3.4 255.255.255.0
* m-lag system-number 1
Related commands
mc-configure batch-synchronize
mc-configure access-local enable
Use mc-configure access-local enable to permit access of the peer device to the local device via the sync channel.
Use undo mc-configure access-local enable to disallow access of the peer device to the local device via the sync channel.
Syntax
mc-configure access-local enable
undo mc-configure access-local enable
Default
The peer device is permitted to access the peer device via the sync channel.
Views
System view
Predefined user roles
network-admin
mdc-admin
Usage guidelines
After configuring this command on the local M-LAG member device, you can use the mc-configure switch-to-peer command on the M-LAG peer device to switch from any view for configuration sync to the same view on the local M-LAG member device and configure and manage the local device.
Examples
# Permit access of the peer device to the local device.
<Sysname> system-view
[Sysname] mc-configure access-local enable
Related commands
mc-configure switch-to-peer
mc-configure backup-to-peer
Use mc-configure backup-to-peer to back up the local configuration file to the peer device.
Syntax
mc-configure backup-to-peer local-filename
Views
User view
Predefined user roles
network-admin
mdc-admin
Parameters
local-filename: Specifies the local configuration file name. The file must be a .cfg file, and the file path cannot exceed 64 characters.
Usage guidelines
To update an M-LAG member device, for example, update the software version or replace the device, you can use the mc-configure backup-to-peer command to back up its configuration file to the M-LAG peer in advance. After the update is completed, you can use the mc-configure get-from-peer command to retrieve the previously saved configuration file from the peer device.
Examples
# Save local configuration file abc.cfg to the peer device.
<Sysname> mc-configure backup-to-peer abc.cfg
Transferring the configuration file. Please wait……
File successfully transferred.
Related commands
mc-configure get-from-peer
mc-configure batch-synchronize
Use mc-configure batch-synchronize to bulk synchronize configurations to the peer device.
Syntax
mc-configure batch-synchronize
Views
Any view for multichassis configuration sync
Predefined user roles
network-admin
mdc-admin
Usage guidelines
To fast deploy the services that are required to be consistent across the M-LAG member devices, configure the services on one of the M-LAG member device before M-LAG system setup. After the M-LAG system is set up and the peer link comes up, you can execute this command in configuration sync view to bulk synchronize the configurations to the M-LAG peer. For example, if you execute this command in +[Sysname] view, the device will bulk synchronize the configurations in [Sysname] view and its sub-views to the peer device. If you execute this command in [Sysname1-GigabitEthernet1/0/1] view, the device will bulk synchronize the configurations in [Sysname1-GigabitEthernet1/0/1] view and its sub-views to the peer device.
Bulk synchronization synchronizes only configurations that must be consistent between the peers.
Examples
# Bulk synchronize configurations to the peer device.
<Sysname> system-view mc-config
System View: return to User View with Ctrl+Z.
All commands in this view will be synchronized to the peer device.
+[Sysname] mc-configure batch-synchronize
7 commands were not synchronized. To view the detailed information, execute the display mc-configure unsync-info command.
Related commands
display mc-configure unsync-info
mc-configure get-from-peer
Use mc-configure get-from-peer to retrieve the configuration file from the peer device.
Syntax
mc-configure get-from-peer filename
Views
User view
Predefined user roles
network-admin
mdc-admin
Parameters
filename: Specifies the configuration file name. The file must be a .cfg file, and the file path cannot exceed 64 characters.
Usage guidelines
To update an M-LAG member device, for example, update the software version or replace the device, you can the mc-configure backup-to-peer command to back up its configuration file to the M-LAG peer in advance. After the update is completed, you can use the mc-configure get-from-peer command to retrieve the previously saved configuration file from the peer device.
Examples
# Retrieve configuration file test from the peer device.
<Sysname> mc-configure get-from-peer test.cfg
Retrieving the configuration file. Please wait……
File successfully getd.
Related commands
mc-configure backup-to-peer
mc-configure quit
Use mc-configure quit to return from a view of the local/peer device to the original view for multichassis configuration sync.
Syntax
mc-configure quit
Views
Any view
Predefined user roles
network-admin
mdc-admin
Usage guidelines
To return to the original view for multichassis configuration sync from any view of a local or peer device, execute the mc-configure quit command or press Ctrl+Q.
Before executing this command, make sure the M-LAG system is operating correctly and the peer link is up.
Examples
# Return to the original view for multichassis configuration sync from a view of the peer device.
<Sysname1> system-view mc-config
System View: return to User View with Ctrl+Z.
All commands in this view will be synchronized to the peer device.
+[Sysname1] interface ten-gigabitethernet 3/0/1
+[Sysname1-Ten-GigabitEthernet3/0/1] mc-configure switch-to-peer
Peer view: To return to previous view, press Ctrl+Q or execute the mc-configure quit command.
All commands in this view are only executed on the peer device. [@peer][Sysname2-Ten-GigabitEthernet3/0/1] mc-configure quit
close by login.
+[Sysname1-Ten-GigabitEthernet3/0/1]
Related commands
· mc-configure switch-to-local
· mc-configure switch-to-peer
mc-configure switch-to-local
Use mc-configure switch-to-local to switch from a view for multichassis configuration sync to the same view of the local device.
Syntax
mc-configure switch-to-local
Views
Any view for multichassis configuration sync
Predefined user roles
network-admin
mdc-admin
Usage guidelines
You can execute this command in any view for multichassis configuration sync to switch to the same view of the local device, and then configure and manage the local device.
Before executing this command, make sure the M-LAG system is operating correctly and the peer link is up.
Execute the mc-configure access-local enable command on both M-LAG member devices for them to access each another.
Examples
# Switch from a view for multichassis configuration sync to the same view of the local device.
<Sysname> system-view mc-config
System View: return to User View with Ctrl+Z.
All commands in this view will be synchronized to the peer device.
+[Sysname] mc-configure switch-to-local
Local view: To return to previous view, press Ctrl+Q or execute the mc-configure quit command.
All commands in this view are only executed on the local device.
[@Local][Sysname]
Related commands
mc-configure access-local enable
mc-configure switch-to-peer
Use mc-configure switch-to-peer to switch from a view for multichassis configuration sync to the same view of the peer device.
Syntax
mc-configure switch-to-peer
Views
Any view for multichassis configuration sync
Predefined user roles
network-admin
mdc-admin
Usage guidelines
You can execute this command in any view for multichassis configuration sync to switch to the same view of the peer device, and then configure and manage the peer device.
Before executing this command, make sure the M-LAG system is operating correctly and the peer link is up.
Execute the mc-configure access-local enable command on both M-LAG member devices for them to access each another.
Examples
# Switch from a view for multichassis configuration sync to the same view of the peer device.
<Sysname> system-view mc-config
System View: return to User View with Ctrl+Z.
All commands in this view will be synchronized to the peer device.
+[Sysname] mc-configure switch-to-peer
Peer view: To return to previous view, press Ctrl+Q or execute the mc-configure quit command.
All commands in this view are only executed on the peer device.
[@peer][Sysname]
Related commands
mc-configure access-local enable