04-Layer 3 - IP Services Configuration Examples

HomeSupportResource CenterSwitchesH3C S7500E Switch SeriesH3C S7500E Switch SeriesTechnical DocumentsConfigure & DeployConfiguration ExamplesH3C S7500E Switch Series Configuration Examples-R7577P04-6W10004-Layer 3 - IP Services Configuration Examples
02-H3C_GRE_Tunnel_Configuration_Examples
Title Size Download
02-H3C_GRE_Tunnel_Configuration_Examples 84.79 KB

 

H3C GRE Tunnel Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Software version: Release 7577P04

Document version: 6W100-20190330

 

Copyright © 2019 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

This document provides GRE tunnel configuration examples.

Prerequisites

The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

This document assumes that you have basic knowledge of GRE.

Example: Configuring a GRE tunnel

Network configuration

As shown in Figure 1, Device A, Device B, and Device C are all on an IPv4 network. Dual stack devices Device A and Device B each connect to an IPv6 host.

Configure a GRE tunnel between Device A and Device B, so PC A and PC B can communicate with each other over the IPv4 network.

Figure 1 Network diagram

 

Analysis

To meet the network requirements, you must perform the following tasks:

·          To enable the IPv6 hosts to communicate over the IPv4 network, specify the GRE tunnel mode as GRE/IPv4 and configure IPv6 addresses for the tunnel interfaces.

·          To transmit packets between PC A and PC B through the GRE tunnel, configure a route reaching the destination network through the tunnel interface on Device A and Device B. You can configure the routes by using either of the following methods:

¡  Configure static routes, using the peer tunnel interface as the next hop or using the local tunnel interface as the outgoing interface.

¡  Enable a dynamic routing protocol on both the tunnel interfaces and the Layer 3 interfaces connected to PC A and PC B.

·          For both ends of the GRE tunnel to reach each other, configure a static route reaching the remote end on Device A and Device B.

Restrictions and guidelines

When you configure the GRE tunnel, follow these restrictions and guidelines:

·          You must configure the tunnel source address and destination address at both ends of the tunnel. The tunnel source or destination address at one end must be the tunnel destination or source address at the other end.

·          Encapsulated packets cannot be forwarded on Layer 3 according to the destination IP addresses and routing tables. You must create a service loopback group of the tunnel service type to loop encapsulated packets back to the forwarding module for Layer 3 forwarding.

Procedures

Configuring Device A

# Configure an IPv6 address for VLAN-interface 10.

<DeviceA> system-view

[DeviceA] vlan 10

[DeviceA-vlan10] port ten-gigabitethernet 2/0/1

[DeviceA-vlan10] quit

[DeviceA] interface vlan-interface 10

[DeviceA-Vlan-interface10] ip address 192.13.2.2 24

[DeviceA-Vlan-interface10] quit

# Configure other interfaces in the same way VLAN-interface 10 is configured. (Details not shown.)

# Create tunnel interface Tunnel 1, and specify the tunnel mode as GRE/IPv4.

[DeviceA] interface tunnel 1 mode gre

# Configure an IPv6 address for tunnel interface Tunnel 1.

[DeviceA-Tunnel1] ipv6 address 3001::1 64

# Configure the source address of Tunnel 1 as the IP address of VLAN-interface 10.

[DeviceA-Tunnel1] source 192.13.2.2

# Configure the destination address of Tunnel 1 as the IP address of VLAN-interface 11 on Device B.

[DeviceA-Tunnel1] destination 131.108.5.2

[DeviceA-Tunnel1] quit

# Configure a static route reaching PC B through tunnel interface Tunnel 1.

[DeviceA] ipv6 route-static 2001:: 64 tunnel 1

# Configure a static route reaching the remote end of the GRE tunnel.

[DeviceA] ip route-static 131.108.5.2 255.255.255.0 192.13.2.1

# Create service loopback group 1, and specify its service type as tunnel.

[DeviceA] service-loopback group 1 type tunnel

# Add Ten-GigabitEthernet 3/0/2 to service loopback group 1.

[DeviceA] interface ten-gigabitethernet 3/0/2

[DeviceA-Ten-GigabitEthernet3/0/2] port service-loopback group 1

[DeviceA-Ten-GigabitEthernet3/0/2] quit

Configuring Device B

# Configure an IPv6 address for VLAN-interface 11.

<DeviceB> system-view

[DeviceB] vlan 11

[DeviceB-vlan 11] port ten-gigabitethernet 2/0/2

[DeviceB-vlan 11] quit

[DeviceB] interface vlan-interface 11

[DeviceB-Vlan-interface11] ip address 131.108.5.2 24

[DeviceB-Vlan-interface11] quit

# Configure other interfaces in the same way VLAN-interface 11 is configured. (Details not shown.)

# Create tunnel interface Tunnel 1, and specify the tunnel mode as GRE/IPv4.

[DeviceB] interface tunnel 1 mode gre

# Configure an IPv6 address for tunnel interface Tunnel 1.

[DeviceB-Tunnel1] ipv6 address 3001::2 64

# Configure the source address of Tunnel 1 as the IP address of VLAN-interface 11.

[DeviceB-Tunnel1] source 131.108.5.2

# Configure the destination address of Tunnel 1 as the IP address of VLAN-interface 10 on Device A.

[DeviceB-Tunnel1] destination 192.13.2.2

[DeviceB-Tunnel1] quit

# Configure a static route reaching PC A through tunnel interface Tunnel 1.

[DeviceB] ipv6 route-static 1001:: 64 Tunnel 1

# Configure a static route reaching the remote end of the GRE tunnel.

[DeviceB] ip route-static 192.13.2.2 255.255.255.0 131.108.5.1

# Create service loopback group 1, and specify its service type as tunnel.

[DeviceB] service-loopback group 1 type tunnel

# Add Ten-GigabitEthernet 3/0/2 to service loopback group 1.

[DeviceB] interface ten-gigabitethernet 3/0/2

[DeviceB-Ten-GigabitEthernet3/0/2] port service-loopback group 1

[DeviceA-Ten-GigabitEthernet3/0/2] quit

Configuring Device C

# Configure an IP address for VLAN-interface 10.

<DeviceC> system-view

[DeviceC] vlan 10

[DeviceC-vlan 10] port ten-gigabitethernet 2/0/1

[DeviceC-vlan 10] quit

[DeviceC] interface vlan-interface 10

[DeviceC-Vlan-interface10] ip address 192.13.2.1 24

[DeviceC-Vlan-interface10] quit

# Configure an IP address for VLAN-interface 11.

[DeviceC] vlan 11

[DeviceC-vlan 11] port ten-gigabitethernet 2/0/2

[DeviceC-vlan 11] quit

[DeviceC] interface vlan-interface 11

[DeviceC-Vlan-interface11] ip address 131.108.5.1 24

[DeviceC-Vlan-interface11] quit

Verifying the configuration

# Verify that PC A and PC B can ping each other successfully. This example uses PC A to ping PC B.

C:\>ping6 2001::2

 

Pinging 2001::2

from 1001::1 with 32 bytes of data:

 

Reply from 2001::2: bytes=32 time<1ms

Reply from 2001::2: bytes=32 time<1ms

Reply from 2001::2: bytes=32 time<1ms

Reply from 2001::2: bytes=32 time<1ms

 

Ping statistics for 2001::2:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum = 0ms, Average = 0ms

Configuration files

·          Device A:

#

 service-loopback group 1 type tunnel

#

vlan 10

#

vlan 20

#

interface Ten-GigabitEthernet2/0/1

 port link-mode bridge

 port access vlan 10

#

interface Ten-GigabitEthernet3/0/1

 port link-mode bridge

 port access vlan 20

#

interface Ten-GigabitEthernet3/0/2

 port link-mode bridge

 port service-loopback group 1

#

interface Vlan-interface10

 ip address 192.13.2.2 255.255.255.0

#

interface Vlan-interface20

 ipv6 address 1001::1/64

#

interface Tunnel1 mode gre

 ipv6 address 3001::1/64

 source 192.13.2.2

 destination 131.108.5.2

#

 ip route-static 131.108.5.2 255.255.255.0 192.13.2.1

#

 ipv6 route-static 2001:: 64 Tunnel 1

#

·          Device B:

#

 service-loopback group 1 type tunnel

#

vlan 11

#

vlan 20

#

interface Ten-GigabitEthernet2/0/2

 port link-mode bridge

 port access vlan 11

#

interface Ten-GigabitEthernet3/0/1

 port link-mode bridge

 port access vlan 20

#

interface Ten-GigabitEthernet3/0/2

 port link-mode bridge

 port service-loopback group 1

#

interface Vlan-interface11

 ip address 131.108.5.2 255.255.255.0

#

interface Vlan-interface20

 ipv6 address 2001::1/64

#

interface Tunnel1 mode gre

 ipv6 address 3001::2/64

 source 131.108.5.2

 destination 192.13.2.2

#

ip route-static 192.13.2.2 255.255.255.0 131.108.5.1

#

ipv6 route-static 1001:: 64 Tunnel 1

#

·          Device C:

#

vlan 10

#

vlan 11

#

interface Ten-GigabitEthernet2/0/1

 port link-mode bridge

 port access vlan 10

#

interface Ten-GigabitEthernet2/0/2

 port link-mode bridge

 port access vlan 11

#

interface Vlan-interface10

 ip address 192.13.2.1 255.255.255.0

#

interface Vlan-interface11

 ip address 131.108.5.1 255.255.255.0

#

Related documentation

·          H3C S7500E Switch Series Layer 3—IP Services Command Reference-R757X

·          H3C S7500E Switch Series Layer 3—IP Services Configuration Guide-R757X