选择区域语言: EN CN HK

05-三层技术-IP路由配置指导

03-RIP配置

本章节下载  (572.73 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500X-AF/Configure/Operation_Manual/H3C_S12500X-AF_CG(R26xx)-6W102/05/201907/1217802_30005_0.htm

03-RIP配置

  录

1 RIP

1.1 RIP简介

1.1.1 RIP的工作机制

1.1.2 RIP的版本

1.1.3 协议规范

1.2 RIP配置任务简介

1.3 配置RIP的基本功能

1.3.1 配置准备

1.3.2 启动RIP

1.3.3 配置接口的工作状态

1.3.4 配置RIP版本

1.4 配置RIP的路由信息控制

1.4.1 配置准备

1.4.2 配置接口附加度量值

1.4.3 配置RIP-2路由聚合

1.4.4 禁止RIP接收主机路由

1.4.5 配置RIP发布缺省路由

1.4.6 配置RIP对接收/发布的路由进行过滤

1.4.7 配置RIP协议优先级

1.4.8 配置RIP引入外部路由

1.5 调整和优化RIP网络

1.5.1 配置准备

1.5.2 配置RIP定时器

1.5.3 配置水平分割和毒性逆转

1.5.4 配置RIP最大等价路由条数

1.5.5 配置RIP-1报文的零域检查

1.5.6 配置源地址检查

1.5.7 配置RIP-2报文的认证方式

1.5.8 配置RIP触发更新的时间间隔

1.5.9 配置RIP邻居

1.5.10 配置RIP网管功能

1.5.11 配置RIP报文的发送速率

1.5.12 配置RIP报文的最大长度

1.5.13 配置RIP发送协议报文的DSCP优先级

1.6 配置RIP GR

1.7 配置RIP NSR

1.8 配置RIP与BFD联动

1.8.1 echo报文单跳检测

1.8.2 指定目的地址的echo报文单跳检测

1.8.3 control报文双向检测

1.9 配置RIP快速重路由功能

1.9.1 功能简介

1.9.2 配置限制和指

1.9.3 配置准备

1.9.4 配置步骤

1.10 RIP显示和维护

1.11 RIP典型配置举例

1.11.1 RIP基本功能配置举例

1.11.2 RIP引入外部路由配置举例

1.11.3 RIP接口附加度量值配置举例

1.11.4 RIP发布聚合路由配置举例

1.11.5 RIP GR配置举例

1.11.6 RIP NSR配置举例

1.11.7 RIP与BFD联动配置举例(echo报文单跳检测)

1.11.8 RIP与BFD联动配置举例(指定目的地址的echo报文单跳检测)

1.11.9 RIP与BFD联动配置举例(control报文双向检测)

1.11.10 RIP快速重路由配置举例


1 RIP

1.1  RIP简介

RIP(Routing Information Protocol,路由信息协议)是一种较为简单的内部网关协议(Interior Gateway Protocol,IGP),主要用于规模较小的网络中,比如校园网以及结构较简单的地区性网络。对于更为复杂的环境和大型网络,一般不使用RIP。

由于RIP的实现较为简单,在配置和维护管理方面也远比OSPF和IS-IS容易,因此在实际组网中仍有广泛的应用。

1.1.1  RIP的工作机制

1. RIP的基本概念

RIP是一种基于距离矢量(Distance-Vector)算法的协议,它通过UDP报文进行路由信息的交换,使用的端口号为520。

RIP使用跳数来衡量到达目的地址的距离,跳数称为度量值。在RIP中,路由器到与它直接相连网络的跳数为0,通过一个路由器可达的网络的跳数为1,其余依此类推。为限制收敛时间,RIP规定度量值取0~15之间的整数,大于或等于16的跳数被定义为无穷大,即目的网络或主机不可达。由于这个限制,使得RIP不适合应用于大型网络。

为提高性能,防止产生路由环路,RIP支持水平分割(Split Horizon)和毒性逆转(Poison Reverse)功能。

2. RIP的路由数据库

每个运行RIP的路由器管理一个路由数据库,该路由数据库包含了到所有可达目的地的路由项,这些路由项包含下列信息:

·              目的地址:主机或网络的地址。

·              下一跳地址:为到达目的地,需要经过的相邻路由器的接口IP地址。

·              出接口:本路由器转发报文的出接口。

·              度量值:本路由器到达目的地的开销。

·              路由时间:从路由项最后一次被更新到现在所经过的时间,路由项每次被更新时,路由时间重置为0。

·              路由标记(Route Tag):用于标识外部路由,在路由策略中可根据路由标记对路由信息进行灵活的控制。关于路由策略的详细信息,请参见“三层技术-IP路由配置指导”中的“路由策略”。

3. RIP防止路由环路的机制

RIP协议向邻居通告的是自己的路由表,有可能会发生路由环路,可以通过以下机制来避免:

·              计数到无穷(Counting to infinity):将度量值等于16的路由定义为不可达(infinity)。在路由环路发生时,某条路由的度量值将会增加到16,该路由被认为不可达。

·              触发更新(Triggered Updates):RIP通过触发更新来避免在多个路由器之间形成路由环路的可能,而且可以加速网络的收敛速度。一旦某条路由的度量值发生了变化,就立刻向邻居路由器发布更新报文,而不是等到更新周期的到来。

·              水平分割(Split Horizon):RIP从某个接口学到的路由,不会从该接口再发回给邻居路由器。这样不但减少了带宽消耗,还可以防止路由环路。

·              毒性逆转(Poison Reverse):RIP从某个接口学到路由后,将该路由的度量值设置为16(不可达),并从原接口发回邻居路由器。利用这种方式,可以清除对方路由表中的无用信息。

4. RIP的运行过程

RIP的运行过程如下:

(1)      路由器启动RIP后,便会向相邻的路由器发送请求报文(Request message),相邻的RIP路由器收到请求报文后,响应该请求,回送包含本地路由表信息的响应报文(Response message)。

(2)      路由器收到响应报文后,更新本地路由表,同时向相邻路由器发送触发更新报文,通告路由更新信息。相邻路由器收到触发更新报文后,又向其各自的相邻路由器发送触发更新报文。在一连串的触发更新广播后,各路由器都能得到并保持最新的路由信息。

(3)      路由器周期性向相邻路由器发送本地路由表,运行RIP协议的相邻路由器在收到报文后,对本地路由进行维护,选择一条最佳路由,再向其各自相邻网络发送更新信息,使更新的路由最终能达到全局有效。同时,RIP采用老化机制对超时的路由进行老化处理,以保证路由的实时性和有效性。

1.1.2  RIP的版本

RIP有两个版本:RIP-1和RIP-2。

RIP-1是有类别路由协议(Classful Routing Protocol),它只支持以广播方式发布协议报文。RIP-1的协议报文无法携带掩码信息,它只能识别A、B、C类这样的自然网段的路由,因此RIP-1不支持不连续子网(Discontiguous Subnet)。

RIP-2是一种无类别路由协议(Classless Routing Protocol),与RIP-1相比,它有以下优势:

·              支持路由标记,在路由策略中可根据路由标记对路由进行灵活的控制。

·              报文中携带掩码信息,支持路由聚合和CIDR(Classless Inter-Domain Routing,无类域间路由)。

·              支持指定下一跳,在广播网上可以选择到最优下一跳地址。

·              支持组播路由发送更新报文,只有RIP-2路由器才能收到更新报文,减少资源消耗。

·              支持对协议报文进行验证,并提供明文验证和MD5验证两种方式,增强安全性。

RIP-2有两种报文传送方式:广播方式和组播方式,缺省将采用组播方式发送报文,使用的组播地址为224.0.0.9。当接口运行RIP-2广播方式时,也可接收RIP-1的报文。

1.1.3  协议规范

与RIP相关的协议规范有:

·              RFC 1058:Routing Information Protocol

·              RFC 1723:RIP Version 2 - Carrying Additional Information

·              RFC 1721:RIP Version 2 Protocol Analysis

·              RFC 1722:RIP Version 2 Protocol Applicability Statement

·              RFC 1724:RIP Version 2 MIB Extension

·              RFC 2082:RIP-2 MD5 Authentication

·              RFC 2453:RIP Version 2

1.2  RIP配置任务简介

表1-1 RIP配置任务简介

配置任务

说明

详细配置

配置RIP的基本功能

启动RIP

必选

1.3.2 

配置接口的工作状态

可选

1.3.3 

配置RIP版本

可选

1.3.4 

配置RIP的路由信息控制

配置接口附加度量值

可选

1.4.2 

配置RIP-2路由聚合

可选

1.4.3 

禁止RIP接收主机路由

可选

1.4.4 

配置RIP发布缺省路由

可选

1.4.5 

配置RIP对接收/发布的路由进行过滤

可选

1.4.6 

配置RIP协议优先级

可选

1.4.7 

配置RIP引入外部路由

可选

1.4.8 

调整和优化RIP网络

配置RIP定时器

可选

1.5.2 

配置水平分割和毒性逆转

可选

1.5.3 

配置最大等价路由条数

可选

1.5.4 

配置RIP-1报文的零域检查

可选

1.5.5 

配置源地址检查

可选

1.5.6 

配置RIP-2报文的认证方式

可选

1.5.7 

配置RIP触发更新的时间间隔

可选

1.5.8 

配置RIP邻居

可选

1.5.9 

配置RIP和MIB绑定

可选

1.5.10 

配置RIP报文的发送速率

可选

1.5.11 

配置RIP报文的最大长度

可选

1.5.12 

配置RIP发送协议报文的DSCP优先级

可选

1.5.13 

配置RIP GR

可选

1.6 

配置RIP NSR

可选

1.7 

配置RIP与BFD联动

可选

1.8 

配置RIP快速重路由功能

可选

1.9 

 

1.3  配置RIP的基本功能

1.3.1  配置准备

在配置RIP的基本功能之前,需完成以下任务:

·              配置链路层协议

·              配置接口的网络层地址,使相邻节点的网络层可达

1.3.2  启动RIP

提示

·       如果在启动RIP前在接口视图下配置了RIP相关命令,这些配置只有在RIP启动后才会生效。

·       RIP不支持将同一物理接口下的不同网段使能到不同的RIP进程中。

·       RIP不支持在同一物理接口下使能多个RIP进程。

·       在指定接口上使能RIP的优先级高于在指定网段上使能RIP。

 

目前,系统支持RIP多进程。当在一台路由器上启动多个RIP进程时,需要指定不同的进程号。RIP进程号是本地概念,不影响与其它路由器之间的报文交换。因此,不同的路由器之间,即使进程号不同也可以进行报文交换。

1. 在指定网段上使能RIP

RIP只在指定网段的接口上运行,指定网段的同时可以配置反码;对于不在指定网段上的接口,RIP既不在它上面接收和发送路由,也不将它的接口路由发布出去。因此,RIP启动后必须指定其工作网段。

表1-2 在指定网段上使能RIP

操作

命令

说明

进入系统视图

system-view

-

启动RIP,并进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

缺省情况下,系统没有启动RIP

在指定网段上使能RIP

network network-address [ wildcard-mask ]

缺省情况下,没有网段使能RIP

在单进程情况下,可以使用network 0.0.0.0命令用来在所有接口上使能RIP;在多进程情况下,无法使用network 0.0.0.0命令

 

2. 在指定接口上使能RIP

RIP支持在接口下使能RIP进程。

表1-3 在指定接口上使能RIP

操作

命令

说明

进入系统视图

system-view

-

启动RIP,并进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

缺省情况下,系统没有启动RIP

退回系统视图

quit

-

进入接口视图

interface interface-type interface-number

-

在指定接口上使能RIP

rip process-id enable [ exclude-subip ]

缺省情况下,接口上没有使能RIP

 

1.3.3  配置接口的工作状态

用户可对接口的工作状态进行配置:

·              配置接口工作在抑制状态,即接口只接收RIP报文而不发送RIP报文

·              配置允许接口接收RIP报文

·              配置允许接口发送RIP报文

表1-4 配置RIP收发报文控制

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

配置抑制接口

silent-interface { interface-type interface-number | all }

缺省情况下,允许所有接口发送路由更新报文

若抑制接口收到非知名端口的单播请求,需要发送响应报文

退回系统视图

quit

-

进入接口视图

interface interface-type interface-number

-

配置允许接口接收RIP报文

rip input

缺省情况下,允许接口接收RIP报文

配置允许接口发送RIP报文

rip output

缺省情况下,允许接口发送RIP报文

 

1.3.4  配置RIP版本

用户可以在RIP视图下配置RIP版本,也可在接口上配置RIP版本:

·              当全局和接口都没有进行RIP版本配置时,接口发送RIP-1广播报文,可以接收RIP-1广播/单播报文、RIP-2广播/组播/单播报文。

·              如果接口上配置了RIP版本,以接口配置的为准;如果接口没有进行RIP版本配置,接口运行的RIP版本将以全局配置的版本为准。

表1-5 配置RIP版本号

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

配置全局RIP版本

version { 1 | 2 }

缺省情况下,未配置全局RIP版本。接口只能发送RIP-1广播报文,可以接收RIP-1广播/单播报文、RIP-2广播/组播/单播报文

退回系统视图

quit

-

进入接口视图

interface interface-type interface-number

-

配置接口运行的RIP版本

rip version { 1 | 2 [ broadcast | multicast ] }

缺省情况下,未配置接口运行的RIP版本。接口只能发送RIP-1广播报文,可以接收RIP-1广播/单播报文、RIP-2广播/组播/单播报文

 

1.4  配置RIP的路由信息控制

1.4.1  配置准备

在实际应用中,有时候需要对RIP路由信息进行更为精确的控制以满足复杂网络环境的需要。

在配置之前,需完成以下任务:

·              配置接口的网络层地址,使相邻节点网络层可达

·              配置RIP的基本功能

1.4.2  配置接口附加度量值

附加度量值是在RIP路由原来度量值的基础上所增加的度量值(跳数),包括发送附加度量值和接收附加度量值。

·              发送附加度量值:不会改变路由表中的路由度量值,仅当接口发送RIP路由信息时才会添加到发送路由上。

·              接收附加度量值:会影响接收到的路由度量值,接口接收到一条合法的RIP路由时,在将其加入路由表前会把度量值附加到该路由上,当附加度量值与原路由度量值之和大于16时,该条路由的度量值取16。

表1-6 配置接口附加度量值

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置接口接收RIP路由时的附加度量值

rip metricin [ route-policy route-policy-name ] value

缺省情况下,接口接收RIP路由时的附加路由度量值为0

配置接口发送RIP路由时的附加度量值

rip metricout [ route-policy route-policy-name ] value

缺省情况下,接口发送RIP路由时的附加路由度量值为1

 

1.4.3  配置RIP-2路由聚合

路由聚合是指路由器把同一自然网段内的连续子网的路由聚合成一条路由向外发送,如路由表里有10.1.1.0/24、10.1.2.0/24、10.1.3.0/24三条路由,可以通过配置把它们聚合成一条路由10.1.0.0/16向外发送,这样邻居路由器只接收到一条路由10.1.0.0/16,从而减少了路由表的规模,以及网络上的传输流量。

通过配置路由聚合,可以提高网络的可扩展性以及路由器的处理速度。

RIP-2将多条路由聚合成一条路由时,聚合路由的Metric值将取所有路由Metric的最小值。

在RIP-2中,有两种路由聚合方式:自动路由聚合和手工配置聚合路由。

1. 自动路由聚合

自动路由聚合是指RIP-2将同一自然网段内的不同子网的路由聚合成一条自然掩码的路由向外发送,例如,假设路由表里有10.1.1.0/24、10.1.2.0/24、10.1.3.0/24三条路由,使能RIP-2自动路由聚合功能后,这三条路由聚合成一条自然掩码的路由10.0.0.0/8向外发送。

表1-7 配置自动路由聚合

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

使能RIP-2自动路由聚合功能

summary

缺省情况下,RIP-2自动路由聚合功能处于使能状态

如果路由表里的路由子网不连续,则需要取消自动路由聚合功能,使得RIP-2能够向外发布子网路由和主机路由

 

2. 手工配置聚合路由

用户可在指定接口配置RIP-2发布一条聚合路由。

聚合路由的目的地址和掩码进行与运算到一个网络地址,RIP-2将对落入该网段内的路由进行聚合,接口只发布聚合后的路由。

例如,假设路由表里有10.1.1.0/24、10.1.2.0/24、10.1.3.0/24三条子网连续的路由,在接口HundredGigE1/0/1配置发布一条聚合路由10.1.0.0/16后,这三条路由聚合成一条路由10.1.0.0/16向外发送。

缺省情况下,RIP-2的路由将按照自然掩码自动聚合,如果用户在指定接口配置发布一条聚合路由,则必须先关闭自动聚合功能。

表1-8 手工配置聚合路由

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

关闭RIP-2自动路由聚合功能

undo summary

缺省情况下,RIP-2自动路由聚合功能处于使能状态

退至系统视图

quit

-

进入接口视图

interface interface-type interface-number

-

配置发布一条聚合路由

rip summary-address ip-address { mask-length | mask }

缺省情况下,未配置聚合路由

 

1.4.4  禁止RIP接收主机路由

提示

禁止接收主机路由仅对RIPv2报文携带的路由有效,对RIPv1报文携带的路由无效。

 

在某些特殊情况下,路由器会收到大量来自同一网段的主机路由。这些路由对于路由寻址没有多少作用,却占用了大量的资源,此时可配置RIP禁止接收主机路由,以节省网络资源。

表1-9 禁止RIP接收主机路由

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

禁止RIP接收主机路由

undo host-route

缺省情况下,允许RIP接收主机路由

 

1.4.5  配置RIP发布缺省路由

用户可以配置RIP以指定度量值向邻居发布一条缺省路由。

·              用户可以在RIP视图下配置RIP进程的所有接口向邻居发布缺省路由,也可以在接口下配置指定RIP接口向邻居发布缺省路由。

·              如果接口没有进行发布缺省路由的相关配置,则以RIP进程下的配置为准,否则将以接口配置为准。

·              如果RIP进程配置了发布缺省路由,但希望该进程下的某个接口不发送缺省路由(只发布普通路由),可以通过在接口下配置rip default-route no-originate命令实现。

表1-10 配置RIP发布缺省路由

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

配置RIP发布缺省路由

default-route { only | originate } [ cost cost-value | route-policy route-policy-name ] *

缺省情况下,RIP不向邻居发送缺省路由

退回系统视图

quit

-

进入接口视图

interface interface-type interface-number

-

配置RIP接口发布缺省路由

rip default-route { { only | originate } [ cost cost-value | route-policy route-policy-name ] * | no-originate }

缺省情况下,RIP接口是否发布缺省路由以RIP进程配置的为准

 

说明

配置发布缺省路由的RIP路由器不接收来自RIP邻居的缺省路由。

 

1.4.6  配置RIP对接收/发布的路由进行过滤

路由过滤就是通过指定访问控制列表或IP地址前缀列表,配置入口或出口过滤策略,对接收和发布的路由进行过滤。

表1-11 配置RIP对接收/发布的路由进行过滤

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

对接收的路由信息进行过滤

filter-policy { ipv4-acl-number | gateway prefix-list-name | prefix-list prefix-list-name [ gateway prefix-list-name ] } import [ interface-type interface-number ]

缺省情况下,RIP不对接收的路由信息进行过滤

本命令对从邻居收到的RIP路由进行过滤,没有通过过滤的路由将不被加入路由表,也不向邻居发布该路由

对发布的路由信息进行过滤

filter-policy { ipv4-acl-number | prefix-list prefix-list-name } export [ protocol [ process-id ] | interface-type interface-number ]

缺省情况下,RIP不对发布的路由信息进行过滤

本命令对本机所有路由的发布进行过滤,包括使用import-route引入的路由和从邻居学到的RIP路由

 

1.4.7  配置RIP协议优先级

在路由器中可能会运行多个IGP路由协议,如果想让RIP路由具有比从其它路由协议学来的路由更高的优先级,需要配置小的优先级值。优先级的高低将最后决定IP路由表中的路由是通过哪种路由算法获取的最佳路由。

表1-12 配置RIP协议优先级

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

配置RIP路由的优先级

preference { preference | route-policy route-policy-name } *

缺省情况下,RIP路由的优先级为100

 

1.4.8  配置RIP引入外部路由

如果在路由器上不仅运行RIP,还运行着其它路由协议,可以配置RIP引入其它协议生成的路由,如OSPF、IS-IS、BGP、静态路由或者直连路由。

表1-13 配置RIP引入外部路由

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

引入外部路由

import-route protocol [ as-number ] [ process-id | all-processes | allow-ibgp ] [ allow-direct | cost cost-value | route-policy route-policy-name | tag tag ] *

缺省情况下,RIP不引入其它路由

只能引入路由表中状态为active的路由,是否为active状态可以通过display ip routing-table protocol命令来查看

(可选)配置引入路由的缺省度量值

default cost cost-value

缺省情况下,引入路由的缺省度量值为0

 

1.5  调整和优化RIP网络

1.5.1  配置准备

在某些特殊的网络环境中,需要对RIP网络的性能进行调整和优化在调整和优化RIP网络之前,需完成以下任务:

·              配置接口的网络层地址,使相邻节点网络层可达

·              配置RIP的基本功能

1.5.2  配置RIP定时器

提示

定时器值的调整应考虑网络的性能,并在所有运行RIP的路由器上进行统一配置,以免增加不必要的网络流量或引起网络路由震荡。

 

通过调整RIP定时器可以改变RIP网络的收敛速度。

RIP受四个定时器的控制,分别是Update、Timeout、Suppress和Garbage-Collect。

·              Update定时器:定义了发送路由更新的时间间隔。

·              Timeout定时器:定义了路由老化时间。如果在老化时间内没有收到关于某条路由的更新报文,则该条路由在路由表中的度量值将会被设置为16。

·              Suppress定时器:定义了RIP路由处于抑制状态的时长。当一条路由的度量值变为16时,该路由将进入抑制状态。在被抑制状态,只有来自同一邻居且度量值小于16的路由更新才会被路由器接收,取代不可达路由。

·              Garbage-Collect定时器:定义了一条路由从度量值变为16开始,直到它从路由表里被删除所经过的时间。在Garbage-Collect时间内,RIP以16作为度量值向外发送这条路由的更新,如果Garbage-Collect超时,该路由仍没有得到更新,则该路由将从路由表中被彻底删除。

表1-14 配置RIP定时器

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

配置RIP定时器的值

timers { garbage-collect garbage-collect-value | suppress suppress-value | timeout timeout-value | update update-value } *

缺省情况下,Garbage-collect定时器的值为120秒,Suppress定时器的值为120秒,Timeout定时器的值为180秒,Update定时器的值为30秒

 

1.5.3  配置水平分割和毒性逆转

提示

如果同时配置了水平分割和毒性逆转,则只有毒性逆转功能生效。

 

通过配置水平分割或毒性逆转功能可以防止路由环路。

1. 配置水平分割

配置水平分割可以使得从一个接口学到的路由不能通过此接口向外发布,用于避免相邻路由器间的路由环路。

表1-15 配置水平分割

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

使能水平分割功能

rip split-horizon

缺省情况下,水平分割功能处于使能状态

 

2. 配置毒性逆转

配置毒性逆转后,从一个接口学到的路由还可以从这个接口向外发布,但这些路由的度量值会设置为16(即不可达),可以用于避免相邻路由器间的路由环路。

表1-16 配置毒性逆转

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

使能毒性逆转功能

rip poison-reverse

缺省情况下,毒性逆转功能处于关闭状态

 

1.5.4  配置RIP最大等价路由条数

通过配置RIP最大等价路由条数,可以使用多条等价路由对RIP网络进行负载分担。

表1-17 配置RIP最大等价路由条数

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

配置RIP最大等价路由条数

maximum load-balancing number

RIP支持的等价路由的最大条数与系统支持最大等价路由的条数相同

 

1.5.5  配置RIP-1报文的零域检查

RIP-1报文中的有些字段必须为零,称之为零域。用户可配置RIP-1在接收报文时对零域进行检查,零域值不为零的RIP-1报文将不被处理。如果用户能确保所有报文都是可信任的,则可以不进行该项检查,以节省CPU处理时间。

由于RIP-2的报文没有零域,此项配置对RIP-2无效。

表1-18 配置RIP-1报文的零域检查

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

使能RIP-1报文的零域检查功能

checkzero

缺省情况下,RIP-1报文的零域检查功能处于使能状态

 

1.5.6  配置源地址检查

通过配置对接收到的RIP路由更新报文进行源IP地址检查:

·              对于在接口上接收的报文,RIP将检查该报文源地址和接收接口的IP地址是否处于同一网段,如果不在同一网段则丢弃该报文。

·              对于PPP接口上接收的报文,RIP检查该报文的源地址是否是对端接口的IP地址,如果不是则丢弃该报文。

表1-19 配置源地址检查

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

使能对接收到的RIP路由更新报文进行源IP地址检查功能

validate-source-address

缺省情况下,对接收到的RIP路由更新报文进行源IP地址检查功能处于使能状态

 

1.5.7  配置RIP-2报文的认证方式

在安全性要求较高的网络环境中,可以通过配置报文的认证方式来对RIP-2报文进行有效性检查和验证。

RIP-2支持两种认证方式:简单认证和MD5认证。

表1-20 配置RIP-2报文的认证方式

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置RIP-2报文的验证方式

rip authentication-mode { md5 { rfc2082 { cipher | plain } string key-id | rfc2453 { cipher | plain } string } | simple { cipher | plain } string }

缺省情况下,未配置RIP-2的验证方式

当RIP的版本为RIP-1时,虽然在接口视图下仍然可以配置验证方式,但由于RIP-1不支持认证,因此该配置不会生效

 

1.5.8  配置RIP触发更新的时间间隔

RIP路由信息变化后将以触发更新的方式通知邻居设备,加速邻居设备的路由收敛。如果路由信息频繁变化,且每次变化都立即发送触发更新,将会占用大量系统资源,并影响路由器的效率。通过调节触发更新的时间间隔,可以抑制由于路由信息频繁变化带来的影响。本命令在路由信息变化不频繁的情况下将连续触发更新的时间间隔缩小到minimum-interval,而在路由信息变化频繁的情况下可以进行相应惩罚,增加incremental-interval×2n-2(n为连续触发更新的次数),将等待时间按照配置的惩罚增量延长,最大不超过maximum-interval

表1-21 配置RIP触发更新的时间间隔

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

配置RIP触发更新的时间间隔

timer triggered maximum-interval [ minimum-interval [ incremental-interval ] ]

缺省情况下,发送触发更新的最大时间间隔为5秒,最小间隔为50毫秒,增量惩罚间隔为200毫秒

 

1.5.9  配置RIP邻居

通常情况下,RIP使用广播或组播地址发送报文,如果在不支持广播或组播报文的链路上运行RIP,则必须手工指定RIP的邻居。

表1-22 配置RIP邻居

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

配置RIP邻居

peer ip-address

缺省情况下,RIP不向任何定点地址发送单播更新报文

当RIP邻居与当前设备直连时不推荐使用peer ip-address命令,因为这样可能会造成对端同时收到同一路由信息的组播(或广播)和单播两种形式的报文

关闭对接收到的RIP路由更新报文进行源IP地址检查的功能

undo validate-source-address

缺省情况下,对接收到的RIP路由更新报文进行源IP地址检查的功能处于使能状态

当指定的邻居和本地路由器非直接连接,则必须关闭对更新报文的源地址进行检查的功能

 

1.5.10  配置RIP网管功能

配置RIP进程绑定MIB功能后,可以通过网管软件对指定的RIP进程进行管理。

表1-23 配置RIP网管功能

操作

命令

说明

进入系统视图

system-view

-

配置RIP进程绑定MIB

rip mib-binding process-id

缺省情况下,MIB绑定在进程号最小的RIP进程上

 

1.5.11  配置RIP报文的发送速率

RIP周期性地将路由信息放在RIP报文中向邻居发送。

如果路由表里的路由条目数量很多,同时发送大量RIP协议报文有可能会对当前设备和网络带宽带来冲击;因此,路由器将RIP协议报文分为多个批次进行发送,并且对RIP接口每次允许发送的RIP协议报文最大个数做出限制。

用户可根据需要配置接口发送RIP报文的时间间隔以及接口一次发送RIP报文的最大个数。

表1-24 配置RIP报文的发送速率

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

配置RIP报文的发送速率

output-delay time count count

缺省情况下,接口发送RIP报文的时间间隔为20毫秒,一次最多发送3个RIP报文

退回系统视图

quit

-

进入接口视图

interface interface-type interface-number

-

配置RIP报文的发送速率

rip output-delay time count count

缺省情况下,接口发送RIP报文的速率以RIP进程配置的为准

 

1.5.12  配置RIP报文的最大长度

提示

由于不同厂商对RIP报文最大长度的支持情况不同,要谨慎使用本特性,以免出现不兼容的情况。

 

RIP周期性地将路由信息放在RIP报文中向邻居发送,根据RIP报文的最大长度来计算报文中发送的最大路由数。通过设置RIP报文的最大长度,可以合理利用链路带宽。

在配置认证的情况下,如果配置不当可能会造成报文无法发送,建议用户按照下面进行配置:

·              简单验证方式时,RIP报文的最大长度不小于52字节;

·              MD5验证方式(使用RFC 2453规定的报文格式)时,RIP报文的最大长度不小于56字节;

·              MD5验证方式(使用RFC 2082规定的报文格式)时,RIP报文的最大长度不小于72字节。

表1-25 配置RIP报文的最大长度

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置RIP报文的最大长度

rip max-packet-length value

缺省情况下,接口发送RIP报文的最大长度为512字节

 

1.5.13  配置RIP发送协议报文的DSCP优先级

DSCP优先级用来体现报文自身的优先等级,决定报文传输的优先程度。通过本配置可以指定RIP发送协议报文的DSCP优先级。

表1-26 配置RIP发送协议报文的DSCP优先级

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

配置RIP发送协议报文的DSCP优先级

dscp dscp-value

缺省情况下,RIP发送协议报文的DSCP优先级为48

 

1.6  配置RIP GR

提示

设备充当GR Restarter后不能再配置RIP NSR功能。

 

GR(Graceful Restart,平滑重启)是一种在协议重启或主备倒换时RIP进行平滑重启,保证转发业务不中断的机制。

GR有两个角色:

·              GR Restarter:发生协议重启或主备倒换事件且具有GR能力的设备。

·              GR Helper:和GR Restarter具有邻居关系,协助完成GR流程的设备。

在普通的路由协议重启的情况下,路由器需要重新学习RIP路由,并更新FIB表,此时会引起网络暂时的中断,基于RIP的GR可以解决这个问题。

应用了GR特性的设备向外发送RIP全部路由表请求报文,重新从邻居处学习RIP路由,在此期间FIB表不变化。在路由协议重启完毕后,设备将重新学到的RIP路由下刷给FIB表,使该设备的路由信息恢复到重启前的状态。

在作为GR Restarter的设备上进行以下配置。启动了RIP的设备缺省就是GR Helper。

表1-27 配置RIP GR

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

使能RIP协议的GR能力

graceful-restart

缺省情况下,RIP协议的GR能力处于关闭状态

(可选)配置RIP协议的GR重启间隔时间

graceful-restart interval interval

缺省情况下,RIP协议的GR重启间隔时间为60秒

 

1.7  配置RIP NSR

提示

设备配置了RIP NSR功能后不能再充当GR Restarter。

 

NSR(Nonstop Routing,不间断路由)通过将RIP路由信息从主进程备份到备进程,使设备在发生主备倒换时新主进程可以无缝完成路由的重新生成、下刷,邻接关系不会发生中断,从而避免了主备倒换对转发业务的影响。

GR特性需要周边设备配合才能完成路由信息的恢复,在网络应用中有一定的限制。NSR特性不需要周边设备的配合,网络应用更加广泛。

表1-28 配置RIP NSR

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

使能RIP NSR功能

non-stop-routing

缺省情况下,RIP NSR功能处于关闭状态

各个进程的NSR功能是相互独立的,只对本进程生效。如果存在多个RIP进程,建议在各个进程下使能RIP NSR功能

 

1.8  配置RIP与BFD联动

RIP协议依赖周期性发送路由更新请求作为检测机制,当在指定时间内没有收到路由更新回应时,认为此条路由不再生效,这种方式不能快速响应链路故障。使用BFD(Bidirectional Forwarding Detection,双向转发检测)检测到链路故障时,RIP能快速撤销失效路由,减少对其他业务的影响。关于BFD的介绍和基本功能配置,请参见“可靠性配置指导”中的“BFD”。

目前RIP支持BFD提供了下面几种检测方式:

·              echo报文单跳检测方式:直连邻居使用。在对端有RIP路由发送时才能建立BFD会话。

·              指定目的地址的echo报文单跳检测方式:直连邻居使用,并且在接口上直接指定RIP邻居的IP地址。当该接口使能了RIP功能,会建立到指定目的IP地址的BFD会话。

·              control报文双向检测方式:非直连邻居使用。当两端互有RIP路由发送时,且使能BFD的接口与接收接口为同一接口,邻居之间才能建立BFD会话。

1.8.1  echo报文单跳检测

表1-29 配置RIP与BFD联动(echo报文单跳检测)

操作

命令

说明

进入系统视图

system-view

-

配置echo报文源地址

bfd echo-source-ip ip-address

缺省情况下,未配置echo报文源地址

进入接口视图

interface interface-type interface-number

-

使能RIP的BFD功能

rip bfd enable

缺省情况下,RIP的BFD功能处于关闭状态

 

1.8.2  指定目的地址的echo报文单跳检测

提示

本特性只检测本端到RIP直连邻居的链路的连通状况。配置本特性时,指定的目的地址只能是RIP直连邻居的IP地址。

 

在链路出现单通故障时,为了加快路由收敛速度,可以在本端设备上配置本特性对链路进行检测。链路出现故障时,本端设备不再从该接口收发任何RIP报文;链路恢复后,接口将继续发送RIP报文。

表1-30 配置RIP与BFD联动(指定目的地址的echo报文单跳检测)

操作

命令

说明

进入系统视图

system-view

-

配置echo报文源地址

bfd echo-source-ip ip-address

缺省情况下,未配置echo报文源地址

进入接口视图

interface interface-type interface-number

-

使能RIP指定目的地址的BFD功能

rip bfd enable destination ip-address

缺省情况下,RIP的BFD功能处于关闭状态

 

1.8.3  control报文双向检测

表1-31 配置RIP与BFD联动(control报文双向检测)

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

配置RIP邻居

peer ip-address

缺省情况下,RIP不向任何定点地址发送更新报文

由于peer命令与邻居之间没有对应关系,undo peer操作并不能立刻删除邻居,因此不能立刻删除BFD会话

进入接口视图

interface interface-type interface-number

-

使能RIP的BFD功能

rip bfd enable

缺省情况下,RIP的BFD功能处于关闭状态

 

1.9  配置RIP快速重路由功能

提示

·       RIP快速重路由功能仅对非迭代RIP路由(即从直连邻居学到RIP路由)有效。

·       等价路由不支持快速重路由功能。

 

1.9.1  功能简介

当RIP网络中的链路或某台路由器发生故障时,数据流量将会被中断,直到RIP根据新的拓扑网络路由收敛完毕后,被中断的流量才能恢复正常的传输。

为了尽可能缩短网络故障导致的流量中断时间,网络管理员可以根据需要配置RIP快速重路由功能。

图1-1 RIP快速重路由功能示意图

 

图1-1所示,通过在Router B上配置快速重路由功能,RIP可以为路由指定备份下一跳,当Router B检测到网络故障时,RIP会使用事先获取好的备份下一跳替换失效下一跳,通过备份下一跳来指导报文的转发,从而大大缩短了流量中断时间。在使用备份下一跳指导报文转发的同时,RIP会根据变化后的网络拓扑重新计算路由,网络收敛完毕后,使用新计算出来的最优路由来指导报文转发。

1.9.2  配置限制和指导

本功能只适合在主链路三层接口up,主链路由双通变为单通或者不通的情况下使用。在主链路三层接口down的情况下,本功能不可用。

单通现象,即一条链路上的两端,有且只有一端可以收到另一端发来的报文,此链路称为单向链路。

1.9.3  配置准备

要配置快速重路由功能,网络管理员需要配置路由策略,通过apply fast-reroute backup-interface命令在路由策略中指定备份下一跳;关于apply fast-reroute backup-interface命令以及路由策略的相关配置,请参见“三层技术-IP路由配置指导”中的“路由策略”。

1.9.4  配置步骤

1. 配置RIP快速重路由功能

表1-32 配置RIP快速重路由功能

操作

命令

说明

进入系统视图

system-view

-

进入RIP视图

rip [ process-id ] [ vpn-instance vpn-instance-name ]

-

配置RIP快速重路由功能

fast-reroute route-policy route-policy-name

缺省情况下,RIP快速重路由功能处于关闭状态

 

2. 配置RIP快速重路由支持BFD检测功能

RIP协议的快速重路由特性中,主用链路缺省不使用BFD进行链路故障检测。配置本功能后,将使用BFD(Echo方式)进行检测,可以加快RIP协议的收敛速度。

表1-33 配置RIP快速重路由支持BFD检测功能

操作

命令

说明

进入系统视图

system-view

-

配置BFD Echo报文源地址

bfd echo-source-ip ip-address

缺省情况下,未配置BFD Echo报文源地址

echo报文的源IP地址用户可以任意指定。建议配置echo报文的源IP地址不属于该设备任何一个接口所在网段

本命令的详细情况请参见“可靠性命令参考”中的“BFD”

进入接口视图

interface interface-type interface-number

-

使能RIP协议中主用链路的BFD(Echo方式)检测功能

rip primary-path-detect bfd echo

缺省情况下,RIP协议中主用链路的BFD(Echo方式)检测功能处于关闭状态

 

1.10  RIP显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后RIP的运行情况,通过查看显示信息验证配置的效果。

在用户视图下执行reset命令可以重启RIP进程或清除指定RIP进程的统计信息。

表1-34 RIP显示和维护

操作

命令

显示RIP的当前运行状态及配置信息

display rip [ process-id ]

显示RIP数据库的激活路由

display rip process-id database [ ip-address { mask-length | mask } ]

显示RIP进程的GR状态信息

display rip [ process-id ] graceful-restart

显示RIP的接口信息

display rip process-id interface [ interface-type interface-number ]

显示RIP进程的邻居信息

display rip process-id neighbor [ interface-type interface-number ]

显示RIP进程的NSR状态信息

display rip [ process-id ] non-stop-routing

显示RIP的路由信息

display rip process-id route [ ip-address { mask-length | mask } [ verbose ] | peer ip-address | statistics ]

重启指定RIP进程

reset rip process-id process

清除RIP进程的统计信息

reset rip process-id statistics

 

1.11  RIP典型配置举例

1.11.1  RIP基本功能配置举例

1. 组网需求

·              在Switch A和Switch B的所有接口上使能RIP,并使用RIP-2进行网络互连。

·              在Switch B上配置路由出策略,向Switch A发布的路由中过滤掉10.2.1.0/24;Switch B上配置入策略,使得Switch B只接收路由2.1.1.0/24。

2. 组网图

图1-2 RIP基本功能配置组网图

 

3. 配置步骤

(1)      配置各接口的IP地址(略)

(2)      配置RIP基本功能

使能RIP功能在下面采用了两种不同配置方式,请根据实际情况进行选择。

# 配置Switch A,在指定网段上使能RIP。

<SwitchA> system-view

[SwitchA] rip

[SwitchA-rip-1] network 1.0.0.0

[SwitchA-rip-1] network 2.0.0.0

[SwitchA-rip-1] network 3.0.0.0

[SwitchA-rip-1] quit

# 配置Switch B,在指定接口上使能RIP。

<SwitchB> system-view

[SwitchB] rip

[SwitchB-rip-1] quit

[SwitchB] interface vlan-interface 100

[SwitchB-Vlan-interface100] rip 1 enable

[SwitchB-Vlan-interface100] quit

[SwitchB] interface vlan-interface 101

[SwitchB-Vlan-interface101] rip 1 enable

[SwitchB-Vlan-interface101] quit

[SwitchB] interface vlan-interface 102

[SwitchB-Vlan-interface102] rip 1 enable

[SwitchB-Vlan-interface102] quit

# 查看Switch A的RIP路由表。

[SwitchA] display rip 1 route

 Route Flags: R - RIP, T - TRIP

              P - Permanent, A - Aging, S - Suppressed, G - Garbage-collect

              D - Direct, O - Optimal, F - Flush to RIB

----------------------------------------------------------------------------

 Peer 1.1.1.2 on Vlan-interface100

      Destination/Mask        Nexthop           Cost    Tag     Flags   Sec

      10.0.0.0/8              1.1.1.2           1       0       RAOF    11

 Local route

      Destination/Mask        Nexthop           Cost    Tag     Flags   Sec

      1.1.1.0/24              0.0.0.0           0       0       RDOF    -

      2.1.1.0/24              0.0.0.0           0       0       RDOF    -

      3.1.1.0/24              0.0.0.0           0       0       RDOF    -

从路由表中可以看出,RIP-1发布的路由信息使用的是自然掩码。

(3)      配置RIP的版本

# 在Switch A上配置RIP-2。

[SwitchA] rip

[SwitchA-rip-1] version 2

[SwitchA-rip-1] undo summary

[SwitchA-rip-1] quit

# 在Switch B上配置RIP-2。

[SwitchB] rip

[SwitchB-rip-1] version 2

[SwitchB-rip-1] undo summary

[SwitchB-rip-1] quit

# 查看Switch A的RIP路由表。

[SwitchA] display rip 1 route

 Route Flags: R - RIP, T - TRIP

              P - Permanent, A - Aging, S - Suppressed, G - Garbage-collect

              D - Direct, O - Optimal, F - Flush to RIB

----------------------------------------------------------------------------

 

 Peer 1.1.1.2 on Vlan-interface100

      Destination/Mask        Nexthop           Cost    Tag     Flags   Sec

      10.0.0.0/8              1.1.1.2           1       0       RAOF    50

      10.2.1.0/24             1.1.1.2           1       0       RAOF    16

      10.1.1.0/24             1.1.1.2           1       0       RAOF    16

 Local route

      Destination/Mask        Nexthop           Cost    Tag     Flags   Sec

      1.1.1.0/24              0.0.0.0           0       0       RDOF    -

      2.1.1.0/24              0.0.0.0           0       0       RDOF    -

      3.1.1.0/24              0.0.0.0           0       0       RDOF    -

从路由表中可以看出,RIP-2发布的路由中带有更为精确的子网掩码信息。

说明

由于RIP路由信息的老化时间较长,所以在配置RIP-2版本后的一段时间里,路由表中可能还会存在RIP-1的路由信息。

 

# 查看Switch B的路由表信息。

[SwitchB] display rip 1 route

 Route Flags: R - RIP, T - TRIP

              P - Permanent, A - Aging, S - Suppressed, G - Garbage-collect

              D - Direct, O - Optimal, F - Flush to RIB

----------------------------------------------------------------------------

 Peer 1.1.1.1 on Vlan-interface100

      Destination/Mask        Nexthop           Cost    Tag     Flags   Sec

      2.1.1.0/24              192.168.1.3       1       0       RAOF    19

      3.1.1.0/24              192.168.1.3       1       0       RAOF    19

 Local route

      Destination/Mask        Nexthop           Cost    Tag     Flags   Sec

      1.1.1.0/24              0.0.0.0           0       0       RDOF    -

      10.1.1.0/24             0.0.0.0           0       0       RDOF    -

      10.2.1.0/24             0.0.0.0           0       0       RDOF    -

(4)      配置RIP路由过滤

# 在Switch B配置地址前缀列表。

[SwitchB] ip prefix-list aaa index 10 permit 2.1.1.0 24

[SwitchB] ip prefix-list bbb index 10 permit 10.1.1.0 24

[SwitchB] ip prefix-list bbb index 11 permit 0.0.0.0 0 less-equal 32

[SwitchB] rip 1

[SwitchB-rip-1] filter-policy prefix-list aaa import

[SwitchB-rip-1] filter-policy prefix-list bbb export

[SwitchB-rip-1] quit

# 查看路由过滤后Switch A的路由信息。

[SwitchA] display rip 1 route

 Route Flags: R - RIP, T - TRIP

              P - Permanent, A - Aging, S - Suppressed, G - Garbage-collect

----------------------------------------------------------------------------

 Peer 1.1.1.2 on Vlan-interface100

      Destination/Mask        Nexthop           Cost    Tag     Flags   Sec

      10.1.1.0/24             1.1.1.2           1       0       RAOF    19

 Local route

      Destination/Mask        Nexthop           Cost    Tag     Flags   Sec

      1.1.1.0/24              0.0.0.0           0       0       RDOF    -

      1.1.1.0/24              0.0.0.0           0       0       RDOF    -

      3.1.1.0/24              0.0.0.0           0       0       RDOF    -

# 查看Switch B的路由表信息。

[SwitchB] display rip 1 route

 Route Flags: R - RIP, T - TRIP

              P - Permanent, A - Aging, S - Suppressed, G - Garbage-collect

              D - Direct, O - Optimal, F - Flush to RIB

----------------------------------------------------------------------------

 Peer 1.1.1.1 on Vlan-interface100

      Destination/Mask        Nexthop           Cost    Tag     Flags   Sec

      2.1.1.0/24              1.1.1.3           1       0       RAOF    19

 Local route

      Destination/Mask        Nexthop           Cost    Tag     Flags   Sec

      1.1.1.0/24              0.0.0.0           0       0       RDOF    -

      10.1.1.0/24             0.0.0.0           0       0       RDOF    -

      10.2.1.0/24             0.0.0.0           0       0       RDOF    -

1.11.2  RIP引入外部路由配置举例

1. 组网需求

·              Switch B上运行两个RIP进程:RIP 100和RIP 200。Switch B通过RIP 100和Switch A交换路由信息,通过RIP 200和Switch C交换路由信息。

·              在Switch B上配置RIP进程200引入外部路由,引入直连路由和RIP进程100的路由,使得Switch C能够学习到达10.2.1.0/24和11.1.1.0/24的路由,但Switch A不能学习到达12.3.1.0/24和16.4.1.0/24的路由。

2. 组网图

图1-3 RIP引入外部路由配置组网图

 

3. 配置步骤

(1)      配置各接口的IP地址(略)

(2)      配置RIP基本功能

# 在Switch A上启动RIP进程100,并配置RIP版本号为2。

<SwitchA> system-view

[SwitchA] rip 100

[SwitchA-rip-100] network 10.0.0.0

[SwitchA-rip-100] network 11.0.0.0

[SwitchA-rip-100] version 2

[SwitchA-rip-100] undo summary

[SwitchA-rip-100] quit

# 在Switch B上启动两个RIP进程,进程号分别为100和200,并配置RIP版本号为2。

<SwitchB> system-view

[SwitchB] rip 100

[SwitchB-rip-100] network 11.0.0.0

[SwitchB-rip-100] version 2

[SwitchB-rip-100] undo summary

[SwitchB-rip-100] quit

[SwitchB] rip 200

[SwitchB-rip-200] network 12.0.0.0

[SwitchB-rip-200] version 2

[SwitchB-rip-200] undo summary

[SwitchB-rip-200] quit

# 在Switch C上启动RIP进程200,并配置RIP版本号为2。

<SwitchC> system-view

[SwitchC] rip 200

[SwitchC-rip-200] network 12.0.0.0

[SwitchC-rip-200] network 16.0.0.0

[SwitchC-rip-200] version 2

[SwitchC-rip-200] undo summary

[SwitchC-rip-200] quit

# 查看Switch C的路由表信息。

[SwitchC] display ip routing-table

 

Destinations : 13        Routes : 13

 

Destination/Mask    Proto  Pre  Cost         NextHop         Interface

0.0.0.0/32          Direct 0    0            127.0.0.1       InLoop0

12.3.1.0/24         Direct 0    0            12.3.1.2        Vlan200

12.3.1.0/32         Direct 0    0            12.3.1.2        Vlan200

12.3.1.2/32         Direct 0    0            127.0.0.1       InLoop0

12.3.1.255/32       Direct 0    0            12.3.1.2        Vlan200

16.4.1.0/24         Direct 0    0            16.4.1.1        Vlan400

16.4.1.0/32         Direct 0    0            16.4.1.1        Vlan400

16.4.1.1/32         Direct 0    0            127.0.0.1       InLoop0

16.4.1.255/32       Direct 0    0            16.4.1.1        Vlan400

127.0.0.0/8         Direct 0    0            127.0.0.1       InLoop0

127.0.0.0/32        Direct 0    0            127.0.0.1       InLoop0

127.0.0.1/32        Direct 0    0            127.0.0.1       InLoop0

127.255.255.255/32  Direct 0    0            127.0.0.1       InLoop0

(3)      配置RIP引入外部路由

# 在Switch B配置RIP进程200引入外部路由,引入直连路由和RIP进程100的路由。

[SwitchB] rip 200

[SwitchB-rip-200] import-route rip 100

[SwitchB-rip-200] import-route direct

[SwitchB-rip-200] quit

# 查看路由引入后Switch C的路由表信息。

[SwitchC] display ip routing-table

 

Destinations : 15        Routes : 15

 

Destination/Mask    Proto  Pre  Cost         NextHop         Interface

0.0.0.0/32          Direct 0    0            127.0.0.1       InLoop0

10.2.1.0/24         RIP    100  1            12.3.1.1        Vlan200

11.1.1.0/24         RIP    100  1            12.3.1.1        Vlan200

12.3.1.0/24         Direct 0    0            12.3.1.2        Vlan200

12.3.1.0/32         Direct 0    0            12.3.1.2        Vlan200

12.3.1.2/32         Direct 0    0            127.0.0.1       InLoop0

12.3.1.255/32       Direct 0    0            12.3.1.2        Vlan200

16.4.1.0/24         Direct 0    0            16.4.1.1        Vlan400

16.4.1.0/32         Direct 0    0            16.4.1.1        Vlan400

16.4.1.1/32         Direct 0    0            127.0.0.1       InLoop0

16.4.1.255/32       Direct 0    0            16.4.1.1        Vlan400

127.0.0.0/8         Direct 0    0            127.0.0.1       InLoop0

127.0.0.0/32        Direct 0    0            127.0.0.1       InLoop0

127.0.0.1/32        Direct 0    0            127.0.0.1       InLoop0

127.255.255.255/32  Direct 0    0            127.0.0.1       InLoop0

1.11.3  RIP接口附加度量值配置举例

1. 组网需求

·              在Switch A、Switch B、Switch C、Switch D和Switch E的所有接口上使能RIP,并使用RIP-2进行网络互连。

·              Switch A有两条链路可以到达Switch D,其中,通过Switch B到达Switch D的链路比通过Switch C到达Switch D的链路更加稳定。通过在Switch A的Vlan-interface200上配置接口接收RIP路由的附加度量值,使得Switch A优选从Switch B学到的1.1.5.0/24网段的路由。

2. 组网图

图1-4 RIP接口附加度量值配置组网图

 

3. 配置步骤

(1)      配置各接口的地址(略)

(2)      配置RIP基本功能

# 配置Switch A。

<SwitchA> system-view

[SwitchA] rip 1

[SwitchA-rip-1] network 1.0.0.0

[SwitchA-rip-1] version 2

[SwitchA-rip-1] undo summary

[SwitchA-rip-1] quit

# 配置Switch B。

<SwitchB> system-view

[SwitchB] rip 1

[SwitchB-rip-1] network 1.0.0.0

[SwitchB-rip-1] version 2

[SwitchB-rip-1] undo summary

# 配置Switch C。

<SwitchC> system-view

[SwitchB] rip 1

[SwitchC-rip-1] network 1.0.0.0

[SwitchC-rip-1] version 2

[SwitchC-rip-1] undo summary

# 配置Switch D。

<SwitchD> system-view

[SwitchD] rip 1

[SwitchD-rip-1] network 1.0.0.0

[SwitchD-rip-1] version 2

[SwitchD-rip-1] undo summary

# 配置Switch E。

<SwitchE> system-view

[SwitchE] rip 1

[SwitchE-rip-1] network 1.0.0.0

[SwitchE-rip-1] version 2

[SwitchE-rip-1] undo summary

# 在Switch A上查看RIP数据库的所有激活路由。

[SwitchA] display rip 1 database

   1.0.0.0/8, auto-summary

       1.1.1.0/24, cost 0, nexthop 1.1.1.1, RIP-interface

       1.1.2.0/24, cost 0, nexthop 1.1.2.1, RIP-interface

       1.1.3.0/24, cost 1, nexthop 1.1.1.2

       1.1.4.0/24, cost 1, nexthop 1.1.2.2

       1.1.5.0/24, cost 2, nexthop 1.1.1.2

       1.1.5.0/24, cost 2, nexthop 1.1.2.2

可以看到,到达网段1.1.5.0/24有两条RIP路由,下一跳分别是Switch B(IP地址为1.1.1.2)和Switch C(IP地址为1.1.2.2),cost值都是2。

(3)      配置RIP接口附加度量值

# 在Switch A上配置接口Vlan-interface200接收RIP路由时的附加度量值为3。

[SwitchA] interface vlan-interface 200

[SwitchA-Vlan-interface200] rip metricin 3

# 在Switch A上查看RIP数据库的所有激活路由。

[SwitchA-Vlan-interface200] display rip 1 database

   1.0.0.0/8, auto-summary

       1.1.1.0/24, cost 0, nexthop 1.1.1.1, RIP-interface

       1.1.2.0/24, cost 0, nexthop 1.1.2.1, RIP-interface

       1.1.3.0/24, cost 1, nexthop 1.1.1.2

       1.1.4.0/24, cost 2, nexthop 1.1.1.2

       1.1.5.0/24, cost 2, nexthop 1.1.1.2

可以看到,到达网段1.1.5.0/24的RIP路由仅有一条,下一跳是Switch B(IP地址为1.1.1.2),cost值为2。

1.11.4  RIP发布聚合路由配置举例

1. 组网需求

·              Switch A、Switch B运行OSPF,Switch D运行RIP,Switch C同时运行OSPF和RIP。

·              在Switch C上配置RIP进程引入OSPF路由,使Switch D有到达10.1.1.0/24、10.2.1.0/24、10.5.1.0/24和10.6.1.0/24网段的路由。

·              为了减小Switch D的路由表规模,在Switch C上配置路由聚合,只发布聚合后的路由10.0.0.0/8。

2. 组网图

图1-5 RIP发布聚合路由配置组网图

 

3. 配置步骤

(1)      配置各接口的地址(略)

(2)      配置OSPF基本功能

# 配置Switch A。

<SwitchA> system-view

[SwitchA] ospf

[SwitchA-ospf-1] area 0

[SwitchA-ospf-1-area-0.0.0.0] network 10.5.1.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] quit

# 配置Switch B。

<SwitchB> system-view

[SwitchB] ospf

[SwitchB-ospf-1] area 0

[SwitchB-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255

[SwitchB-ospf-1-area-0.0.0.0] network 10.6.1.0 0.0.0.255

[SwitchB-ospf-1-area-0.0.0.0] quit

# 配置Switch C。

<SwitchC> system-view

[SwitchC] ospf

[SwitchC-ospf-1] area 0

[SwitchC-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255

[SwitchC-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255

[SwitchC-ospf-1-area-0.0.0.0] quit

[SwitchC-ospf-1] quit

(3)      配置RIP基本功能

# 配置Switch C。

[SwitchC] rip 1

[SwitchC-rip-1] network 11.3.1.0

[SwitchC-rip-1] version 2

[SwitchC-rip-1] undo summary

# 配置Switch D。

<SwitchD> system-view

[SwitchD] rip 1

[SwitchD-rip-1] network 11.0.0.0

[SwitchD-rip-1] version 2

[SwitchD-rip-1] undo summary

[SwitchD-rip-1] quit

# 在Switch C上配置RIP引入外部路由,引入OSPF进程1的路由和直连路由。

[SwitchC-rip-1] import-route direct

[SwitchC-rip-1] import-route ospf 1

[SwitchC-rip-1] quit

# 查看Switch D的路由表信息。

[SwitchD] display ip routing-table

 

Destinations : 15        Routes : 15

 

Destination/Mask    Proto  Pre  Cost         NextHop         Interface

0.0.0.0/32          Direct 0    0            127.0.0.1       InLoop0

10.1.1.0/24         RIP    100  1            11.3.1.1        Vlan300

10.2.1.0/24         RIP    100  1            11.3.1.1        Vlan300

10.5.1.0/24         RIP    100  1            11.3.1.1        Vlan300

10.6.1.0/24         RIP    100  1            11.3.1.1        Vlan300

11.3.1.0/24         Direct 0    0            11.3.1.2        Vlan300

11.3.1.0/32         Direct 0    0            11.3.1.2        Vlan300

11.3.1.2/32         Direct 0    0            127.0.0.1       InLoop0

11.4.1.0/24         Direct 0    0            11.4.1.2        Vlan400

11.4.1.0/32         Direct 0    0            11.4.1.2        Vlan400

11.4.1.2/32         Direct 0    0            127.0.0.1       InLoop0

127.0.0.0/8         Direct 0    0            127.0.0.1       InLoop0

127.0.0.0/32        Direct 0    0            127.0.0.1       InLoop0

127.0.0.1/32        Direct 0    0            127.0.0.1       InLoop0

127.255.255.255/32  Direct 0    0            127.0.0.1       InLoop0

(4)      在Switch C上配置路由聚合,只发布聚合路由10.0.0.0/8。

[SwitchC] interface vlan-interface 300

[SwitchC-Vlan-interface300] rip summary-address 10.0.0.0 8

# 查看Switch D的路由表信息。

[SwitchD] display ip routing-table

 

Destinations : 12        Routes : 12

 

Destination/Mask    Proto  Pre  Cost         NextHop         Interface

0.0.0.0/32          Direct 0    0            127.0.0.1       InLoop0

10.0.0.0/8          RIP    100  1            11.3.1.1        Vlan300

11.3.1.0/24         Direct 0    0            11.3.1.2        Vlan300

11.3.1.0/32         Direct 0    0            11.3.1.2        Vlan300

11.3.1.2/32         Direct 0    0            127.0.0.1       InLoop0

11.4.1.0/24         Direct 0    0            11.4.1.2        Vlan400

11.4.1.0/32         Direct 0    0            11.4.1.2        Vlan400

11.4.1.2/32         Direct 0    0            127.0.0.1       InLoop0

127.0.0.0/8         Direct 0    0            127.0.0.1       InLoop0

127.0.0.0/32        Direct 0    0            127.0.0.1       InLoop0

127.0.0.1/32        Direct 0    0            127.0.0.1       InLoop0

127.255.255.255/32  Direct 0    0            127.0.0.1       InLoop0

1.11.5  RIP GR配置举例

1. 组网需求

·              Switch A、Switch B和Switch C通过RIPv2协议实现网络互连。

·              Switch A作为GR Restarter,Switch B和Switch C作为GR Helper并且通过GR机制与Switch A保持同步。

2. 组网图

图1-6 RIP GR配置组网图

 

3. 配置步骤

(1)      配置各路由器接口的IP地址和RIP协议

请按照上面组网图配置各接口的IP地址和子网掩码,具体配置过程略。

配置各路由器之间采用RIPv2协议进行互连,确保Switch A、Switch B和Switch C之间能够在网络层互通,并且各路由器之间能够借助RIPv2协议实现动态路由更新。

(2)      配置RIP GR

# 使能Switch A的RIP GR功能。

<SwitchA> system-view

[SwitchA] rip

[SwitchA-rip-1] graceful-restart

4. 验证配置

# 在Switch A上以GR方式重启RIP进程。

[SwitchA-rip-1] return

<SwitchA> reset rip 1 process

Reset RIP process? [Y/N]:y

# 查看Switch A上RIP的GR状态。

<SwitchA> display rip graceful-restart

 RIP process: 1

 Graceful Restart capability     : Enabled

 Current GR state                : Normal

 Graceful Restart period         : 60  seconds

 Graceful Restart remaining time : 0   seconds

1.11.6  RIP NSR配置举例

1. 组网需求

Switch S、Switch A、Switch B通过RIPv2协议实现网络互连。要求对Switch S进行主备倒换时,Switch A和Switch B到Switch S的邻居没有中断,Switch A到Switch B的流量没有中断。

2. 组网图

图1-7 RIP NSR配置组网图

 

3. 配置步骤

(1)      配置各接口的IP地址和RIP协议

请按照上面组网图配置各接口的IP地址和子网掩码,具体配置过程略。

配置各交换机之间采用RIPv2协议进行互连,确保Switch S、Switch A和Switch B之间能够在网络层互通,并且各路由器之间能够借助RIPv2协议实现动态路由更新。

(2)      配置RIP NSR

# 使能Switch S的RIP NSR功能。

<SwitchS> system-view

[SwitchS] rip 100

[SwitchS-rip-100] non-stop-routing

[SwitchS-rip-100] quit

4. 验证配置

# Switch S进行主备倒换。

[SwitchS] placement reoptimize

Predicted changes to the placement

Program                           Current location       New location

---------------------------------------------------------------------

lb                                0/0                    0/0

lsm                               0/0                    0/0

slsp                              0/0                    0/0

rib6                              0/0                    0/0

routepolicy                       0/0                    0/0

rib                               0/0                    0/0

staticroute6                      0/0                    0/0

staticroute                       0/0                    0/0

ospf                              0/0                    1/0

Continue? [y/n]:y

Re-optimization of the placement start. You will be notified on completion

Re-optimization of the placement complete. Use 'display placement' to view the new placement

# 查看Switch A上RIP协议的邻居和路由。

[SwitchA] display rip 1 neighbor

 Neighbor Address: 12.12.12.2

     Interface  : Vlan-interface200

     Version    : RIPv2     Last update: 00h00m13s

     Relay nbr  : No        BFD session: None

     Bad packets: 0         Bad routes : 0

[SwitchA] display rip 1 route

 Route Flags: R - RIP, T - TRIP

              P - Permanent, A - Aging, S - Suppressed, G - Garbage-collect

              D - Direct, O - Optimal, F - Flush to RIB

 ----------------------------------------------------------------------------

 Peer 12.12.12.2 on Vlan-interface200

      Destination/Mask        Nexthop           Cost    Tag     Flags   Sec

      14.0.0.0/8              12.12.12.2        1       0       RAOF    16

      44.0.0.0/8              12.12.12.2        2       0       RAOF    16

 Local route

      Destination/Mask        Nexthop           Cost    Tag     Flags   Sec

      12.12.12.0/24           0.0.0.0           0       0       RDOF    -

      22.22.22.22/32          0.0.0.0           0       0       RDOF    -

# 查看Switch B上RIP协议的邻居和路由。

[SwitchB] display rip 1 neighbor

 Neighbor Address: 14.14.14.2

     Interface  : Vlan-interface200

     Version    : RIPv2     Last update: 00h00m32s

     Relay nbr  : No        BFD session: None

     Bad packets: 0         Bad routes : 0

[SwitchB] display rip 1 route

 Route Flags: R - RIP, T - TRIP

              P - Permanent, A - Aging, S - Suppressed, G - Garbage-collect

              D - Direct, O - Optimal, F - Flush to RIB

 ----------------------------------------------------------------------------

 Peer 14.14.14.2 on Vlan-interface200

      Destination/Mask        Nexthop           Cost    Tag     Flags   Sec

      12.0.0.0/8              14.14.14.2        1       0       RAOF    1

      22.0.0.0/8              14.14.14.2        2       0       RAOF    1

 Local route

      Destination/Mask        Nexthop           Cost    Tag     Flags   Sec

      44.44.44.44/32          0.0.0.0           0       0       RDOF    -

      14.14.14.0/24           0.0.0.0           0       0       RDOF    -

通过上面信息可以看出在Switch S发生主备倒换的时候,Switch A和Switch B的邻居和路由信息保持不变,从Switch A到Switch B的流量转发没有受到主备倒换的影响。

1.11.7  RIP与BFD联动配置举例(echo报文单跳检测)

1. 组网需求

·              Switch A、Switch C通过二层交换机互连,它们的接口Vlan-interface100都运行RIP进程1。并且Switch A的接口Vlan-interface100上还使能了BFD检测功能。

·              Switch A通过Switch B与Switch C互连,Switch A的接口Vlan-interface200运行RIP进程2。Switch C的接口Vlan-interface300、Switch B的接口Vlan-interface200和Vlan-interface300上都运行RIP进程1。

·              Switch C上配置静态路由,并且将静态路由引入在RIP进程中,使Switch C有路由发送至Switch A。Switch A上学习到Switch C发送的静态路由,出接口为与二层交换机相连的接口。

·              在Switch C和二层交换机之间的链路发生故障后,BFD能够快速检测链路中断并通告RIP协议。RIP协议响应BFD会话down,删除与Switch C的邻居,并删除从Switch C学习的路由。Switch A上学习到Switch C上发送的静态路由,出接口为与Switch B相连的接口。

2. 组网图

图1-8 RIP与BFD联动配置组网图(echo报文单跳检测)

 

3. 配置步骤

(1)      配置各接口的IP地址(略)

(2)      配置RIP基本功能

# 配置Switch A。

<SwitchA> system-view

[SwitchA] rip 1

[SwitchA-rip-1] version 2

[SwitchA-rip-1] undo summary

[SwitchA-rip-1] network 192.168.1.0

[SwitchA-rip-1] quit

[SwitchA] interface vlan-interface 100

[SwitchA-Vlan-interface100] rip bfd enable

[SwitchA-Vlan-interface100] quit

[SwitchA] rip 2

[SwitchA-rip-2] version 2

[SwitchA-rip-2] undo summary

[SwitchA-rip-2] network 192.168.2.0

[SwitchA-rip-2] quit

# 配置Switch B。

<SwitchB> system-view

[SwitchB] rip 1

[SwitchB-rip-1] version 2

[SwitchB-rip-1] undo summary

[SwitchB-rip-1] network 192.168.2.0

[SwitchB-rip-1] network 192.168.3.0

[SwitchB-rip-1] quit

# 配置Switch C。

<SwitchC> system-view

[SwitchC] rip 1

[SwitchC-rip-1] version 2

[SwitchC-rip-1] undo summary

[SwitchC-rip-1] network 192.168.1.0

[SwitchC-rip-1] network 192.168.3.0

[SwitchC-rip-1] import-route static

[SwitchC-rip-1] quit

(3)      配置BFD参数

# 配置Switch A。

[SwitchA] bfd echo-source-ip 11.11.11.11

[SwitchA] interface vlan-interface 100

[SwitchA-Vlan-interface100] bfd min-transmit-interval 500

[SwitchA-Vlan-interface100] bfd min-receive-interval 500

[SwitchA-Vlan-interface100] bfd detect-multiplier 7

[SwitchA-Vlan-interface100] quit

[SwitchA] quit

(4)      Switch C配置静态路由

[SwitchC] ip route-static 120.1.1.1 24 null 0

4. 验证配置

# 查看Switch A的BFD信息。

<SwitchA> display bfd session

 

 Total Session Num: 1     Up Session Num: 1     Init Mode: Active

 

 IPv4 Session Working Under Echo Mode:

 

 LD             SourceAddr      DestAddr        State    Holdtime    Interface

 4              192.168.1.1     192.168.1.2     Up       2000ms      Vlan100

# 查看Switch A上学到的路由120.1.1.0/24,可以看到Switch A经过L2 Switch到达Switch C。

<SwitchA> display ip routing-table 120.1.1.0 24

 

Summary count : 1

 

Destination/Mask   Proto   Pre Cost        NextHop         Interface

120.1.1.0/24       RIP     100 1           192.168.1.2     Vlan-interface100

当Switch C和二层交换机之间的链路发生故障时:

# 查看Switch A上学到的路由120.1.1.0/24,可以看到Switch A经过Switch B到达Switch C。

<SwitchA> display ip routing-table 120.1.1.0 24

 

Summary count : 1

 

Destination/Mask   Proto   Pre Cost        NextHop         Interface

120.1.1.0/24       RIP     100 1           192.168.2.2     Vlan-interface200

1.11.8  RIP与BFD联动配置举例(指定目的地址的echo报文单跳检测)

1. 组网需求

·              Switch A和Switch B互连,Switch A的接口Vlan-interface100和Switch B的接口Vlan-interface100都运行RIP进程1。Switch A的接口Vlan-interface100上使能了BFD检测功能,指定目的地址为Switch B的接口Vlan-interface100的地址。

·              Switch B与Switch C互连,它们的接口Vlan-interface200都运行RIP进程1。

·              Switch A和Switch C上配置静态路由,并都将静态路由引入RIP进程中,其中Switch A引入路由的cost值比Switch C引入的cost值小,这样,当Switch B上学习到Switch A和Switch C发送的路由后,会优选Switch A的路由,出接口为与Switch A连接的接口。

·              在Switch A和Switch B之间的链路发生单通故障(从Switch A到Switch B方向报文是通的,但是从Switch B到Switch A方向的链路不通)后,Switch A上BFD能够快速检测链路故障并通告RIP协议。Switch A上的RIP协议响应BFD会话down,删除从接口Vlan-interface100学习到的邻居和路由,并不再从该接口接收和发送RIP报文。Switch B上在学自Switch A的路由老化后,会优选Switch C发送的静态路由,出接口为与Switch C连接的接口。

2. 组网图

图1-9 RIP与BFD联动配置组网图(指定目的地址的echo报文单跳检测)

 

3. 配置步骤

(1)      配置各接口的IP地址(略)

(2)      配置RIP基本功能并且在接口上使能BFD

# 配置Switch A。

<SwitchA> system-view

[SwitchA] rip 1

[SwitchA-rip-1] network 192.168.2.0

[SwitchA-rip-1] import-route static

[SwitchA-rip-1] quit

[SwitchA] interface vlan-interface 100

[SwitchA-Vlan-interface100] rip bfd enable destination 192.168.2.2

[SwitchA-Vlan-interface100] quit

# 配置Switch B。

<SwitchB> system-view

[SwitchB] rip 1

[SwitchB-rip-1] network 192.168.2.0

[SwitchB-rip-1] network 192.168.3.0

[SwitchB-rip-1] quit

# 配置Switch C。

<SwitchC> system-view

[SwitchC] rip 1

[SwitchC-rip-1] network 192.168.3.0

[SwitchC-rip-1] import-route static cost 3

[SwitchC-rip-1] quit

(3)      配置接口BFD参数

# 配置Switch A。

[SwitchA] bfd echo-source-ip 11.11.11.11

[SwitchA] interface vlan-interface 100

[SwitchA-Vlan-interface100] bfd min-echo-receive-interval 500

[SwitchA-Vlan-interface100] return

(4)      配置静态路由

# 配置Switch A。

[SwitchA] ip route-static 100.1.1.0 24 null 0

# 配置Switch C。

[SwitchC] ip route-static 100.1.1.0 24 null 0

4. 验证配置

# 显示Switch A的BFD信息。

<SwitchA> display bfd session

 

 Total Session Num: 1     Up Session Num: 1     Init Mode: Active

 

 IPv4 session working under Echo mode:

 

 LD             SourceAddr      DestAddr        State    Holdtime    Interface

 3              192.168.2.1     192.168.2.2     Up       2000ms      vlan100

# 显示Switch B上学到的路由100.1.1.0/24。

<SwitchB> display ip routing-table 100.1.1.0 24 verbose

 

Summary Count : 1

 

Destination: 100.1.1.0/24

   Protocol: RIP             

 Process ID: 1

  SubProtID: 0x1                     Age: 00h02m47s

       Cost: 1                Preference: 100

      IpPre: N/A              QosLocalID: N/A

        Tag: 0                     State: Active Adv

  OrigTblID: 0x0                 OrigVrf: default-vrf

    TableID: 0x2                  OrigAs: 0

      NibID: 0x12000002           LastAs: 0

     AttrID: 0xffffffff         Neighbor: 192.168.2.1

      Flags: 0x1008c         OrigNextHop: 192.168.2.1

      Label: NULL            RealNextHop: 192.168.2.1

    BkLabel: NULL              BkNextHop: N/A

  Tunnel ID: Invalid           Interface: vlan-interface 100

BkTunnel ID: Invalid         BkInterface: N/A

   FtnIndex: 0x0            TrafficIndex: N/A

  Connector: N/A

当 Switch A和Switch B之间的链路发生故障时:

# 显示Switch B上学到的路由100.1.1.0/24。

<SwitchB> display ip routing-table 100.1.1.0 24 verbose

 

Summary Count : 1

 

Destination: 100.1.1.0/24

   Protocol: RIP             

 Process ID: 1

  SubProtID: 0x1                     Age: 00h21m23s

       Cost: 4                Preference: 100

      IpPre: N/A              QosLocalID: N/A

        Tag: 0                     State: Active Adv

  OrigTblID: 0x0                 OrigVrf: default-vrf

    TableID: 0x2                  OrigAs: 0

      NibID: 0x12000002           LastAs: 0

     AttrID: 0xffffffff         Neighbor: 192.168.3.2

      Flags: 0x1008c         OrigNextHop: 192.168.3.2

      Label: NULL            RealNextHop: 192.168.3.2

    BkLabel: NULL              BkNextHop: N/A

  Tunnel ID: Invalid           Interface: vlan-interface 200

BkTunnel ID: Invalid         BkInterface: N/A

   FtnIndex: 0x0            TrafficIndex: N/A

  Connector: N/A

1.11.9  RIP与BFD联动配置举例(control报文双向检测)

1. 组网需求

·              Switch A通过Switch B与Switch C互连。Switch A的接口Vlan-interface100和Switch C的接口Vlan-interface200上都运行RIP进程1。分别在Switch A和Switch C上配置到达对端的静态路由,并在Switch A的接口Vlan-interface100和Switch C的接口Vlan-interface200上并使能BFD检测功能。

·              Switch A通过Switch D与Switch C互连。Switch A的接口Vlan-interface300运行RIP进程2。Switch C的接口Vlan-interface400、Switch D的接口Vlan-interface300和Vlan-interface400上运行RIP进程1。

·              为使Switch A与Switch C互有路由发送,在Switch A与Switch C上将到达对端的静态路由引入RIP协议中。Switch A与Switch C之间建立BFD会话。Switch A上学习到Switch C发送的静态路由,出接口为与Switch B连接的接口。

·              在Switch B与Switch C之间的链路发生故障后,BFD能够快速检测链路中断并通告RIP协议。RIP协议响应BFD会话down,删除与Switch C的邻居,并删除从Switch C学习的路由。Switch A上学习到Switch C发送的静态路由,出接口为与Switch D连接的接口。

2. 组网图

图1-10 RIP与BFD联动配置组网图(control报文双向检测)

 

设备

接口

IP地址

设备

接口

IP地址

Switch A

Vlan-int300

192.168.3.1/24

Switch B

Vlan-int100

192.168.1.2/24

 

Vlan-int100

192.168.1.1/24

 

Vlan-int200

192.168.2.1/24

Switch C

Vlan-int200

192.168.2.2/24

Switch D

Vlan-int300

192.168.3.2/24

 

Vlan-int400

192.168.4.2/24

 

Vlan-int400

192.168.4.1/24

 

3. 配置步骤

(1)      配置各接口的IP地址(略)

(2)      配置RIP基本功能,并引入静态路由,使Switch A与Switch C互有路由发送

# 配置Switch A。

<SwitchA> system-view

[SwitchA] rip 1

[SwitchA-rip-1] version 2

[SwitchA-rip-1] undo summary

[SwitchA-rip-1] network 192.168.1.0

[SwitchA-rip-1] network 101.1.1.0

[SwitchA-rip-1] peer 192.168.2.2

[SwitchA-rip-1] undo validate-source-address

[SwitchA-rip-1] import-route static

[SwitchA-rip-1] quit

[SwitchA] interface vlan-interface 100

[SwitchA-Vlan-interface100] rip bfd enable

[SwitchA-Vlan-interface100] quit

[SwitchA] rip 2

[SwitchA-rip-2] version 2

[SwitchA-rip-2] undo summary

[SwitchA-rip-2] network 192.168.3.0

[SwitchA-rip-2] quit

# 配置Switch C。

<SwitchC> system-view

[SwitchC] rip 1

[SwitchC-rip-1] version 2

[SwitchC-rip-1] undo summary

[SwitchC-rip-1] network 192.168.2.0

[SwitchC-rip-1] network 192.168.4.0

[SwitchC-rip-1] network 100.1.1.0

[SwitchC-rip-1] peer 192.168.1.1

[SwitchC-rip-1] undo validate-source-address

[SwitchC-rip-1] import-route static

[SwitchC-rip-1] quit

[SwitchC] interface vlan-interface 200

[SwitchC-Vlan-interface200] rip bfd enable

[SwitchC-Vlan-interface200] quit

# 配置Switch D。

<SwitchD> system-view

[SwitchD] rip 1

[SwitchD-rip-1] version 2

[SwitchD-rip-1] undo summary

[SwitchD-rip-1] network 192.168.3.0

[SwitchD-rip-1] network 192.168.4.0

(3)      配置BFD参数

# 配置Switch A。

[SwitchA] bfd session init-mode active

[SwitchA] interface vlan-interface 100

[SwitchA-Vlan-interface100] bfd min-transmit-interval 500

[SwitchA-Vlan-interface100] bfd min-receive-interval 500

[SwitchA-Vlan-interface100] bfd detect-multiplier 7

[SwitchA-Vlan-interface100] quit

# 配置Switch C。

[SwitchC] bfd session init-mode active

[SwitchC] interface vlan-interface 200

[SwitchC-Vlan-interface200] bfd min-transmit-interval 500

[SwitchC-Vlan-interface200] bfd min-receive-interval 500

[SwitchC-Vlan-interface200] bfd detect-multiplier 7

[SwitchC-Vlan-interface200] quit

(4)      配置静态路由

# 配置Switch A。

[SwitchA] ip route-static 192.168.2.0 24 vlan-interface 100 192.168.1.2

[SwitchA] quit

# 配置Switch C。

[SwitchC] ip route-static 192.168.1.0 24 vlan-interface 200 192.168.2.1

4. 验证配置

# 显示Switch A的BFD信息。

<SwitchA> display bfd session

 

 Total Session Num: 1     Up Session Num: 1     Init Mode: Active

 

 IPv4 session working under Ctrl mode:

 

 LD/RD             SourceAddr      DestAddr        State    Holdtime    Interface

 513/513           192.168.1.1     192.168.2.2     Up       1700ms      vlan100

# 显示Switch A上学到的路由100.1.1.0/24,可以看到Switch A经过Switch B到达Switch C。

<SwitchA> display ip routing-table 100.1.1.0 24

 

Summary count : 1

 

Destination/Mask   Proto   Pre Cost        NextHop         Interface

100.1.1.0/24       RIP     100 1           192.168.2.2     vlan-interface 100

Switch B和Switch C之间的链路发生故障后:

# 显示Switch A上学到的路由100.1.1.0/24,可以看到Switch A经过Switch D到达Switch C。

<SwitchA> display ip routing-table 100.1.1.0 24

 

Summary count : 1

 

Destination/Mask   Proto   Pre Cost        NextHop         Interface

100.1.1.0/24       RIP     100 2           192.168.3.2     vlan-interface 300

1.11.10  RIP快速重路由配置举例

1. 组网需求

Switch A、Switch B和Switch C通过RIPv2协议实现网络互连。要求当Switch A和Switch B之间的链路出现单通故障时,业务可以快速切换到链路B上。

2. 组网图

图1-11 RIP快速重路由配置组网图

 

设备

接口

IP地址

设备

接口

IP地址

Switch A

Vlan-int100

12.12.12.1/24

Switch B

Vlan-int101

24.24.24.4/24

 

Vlan-int200

13.13.13.1/24

 

Vlan-int200

13.13.13.2/24

 

Loop0

1.1.1.1/32

 

Loop0

4.4.4.4/32

Switch C

Vlan-int100

12.12.12.2/24

 

 

 

 

Vlan-int101

24.24.24.2/24

 

 

 

 

3. 配置步骤

(1)      配置各交换机接口的IP地址和RIPv2协议

请按照上面组网图配置各接口的IP地址和子网掩码,具体配置过程略。

配置各路由器之间采用RIPv2协议进行互连,确保Switch A、Switch B和Switch C之间能够在网络层互通,并且各路由器之间能够借助RIPv2协议实现动态路由更新。

具体配置过程略。

(2)      配置RIP 快速重路由

# 配置Switch A。

<SwitchA> system-view

[SwitchA] ip prefix-list abc index 10 permit 4.4.4.4 32

[SwitchA] route-policy frr permit node 10

[SwitchA-route-policy-frr-10] if-match ip address prefix-list abc

[SwitchA-route-policy-frr-10] apply fast-reroute backup-interface vlan-interface 100 backup-nexthop 12.12.12.2

[SwitchA-route-policy-frr-10] quit

[SwitchA] rip 1

[SwitchA-rip-1] fast-reroute route-policy frr

[SwitchA-rip-1] quit

# 配置Switch B。

<SwitchB> system-view

[SwitchB] ip prefix-list abc index 10 permit 1.1.1.1 32

[SwitchB] route-policy frr permit node 10

[SwitchB-route-policy-frr-10] if-match ip address prefix-list abc

[SwitchB-route-policy-frr-10] apply fast-reroute backup-interface vlan-interface 101 backup-nexthop 24.24.24.2

[SwitchB-route-policy-frr-10] quit

[SwitchB] rip 1

[SwitchB-rip-1] fast-reroute route-policy frr

[SwitchB-rip-1] quit

4. 验证配置

# 在Switch A上查看4.4.4.4/32路由,可以看到备份下一跳信息:

[SwitchA] display ip routing-table 4.4.4.4 verbose

 

Summary Count : 1

 

Destination: 4.4.4.4/32

   Protocol: RIP             

 Process ID: 1

  SubProtID: 0x1                     Age: 04h20m37s

       Cost: 1                Preference: 100

      IpPre: N/A              QosLocalID: N/A

        Tag: 0                     State: Active Adv

  OrigTblID: 0x0                 OrigVrf: default-vrf

    TableID: 0x2                  OrigAs: 0

      NibID: 0x26000002           LastAs: 0

     AttrID: 0xffffffff         Neighbor: 13.13.13.2

      Flags: 0x1008c         OrigNextHop: 13.13.13.2

      Label: NULL            RealNextHop: 13.13.13.2

    BkLabel: NULL              BkNextHop: 12.12.12.2

  Tunnel ID: Invalid           Interface: Vlan-interface200

BkTunnel ID: Invalid         BkInterface: Vlan-interface100

   FtnIndex: 0x0            TrafficIndex: N/A

  Connector: N/A

# 在Switch B上查看1.1.1.1/32路由,可以看到备份下一跳信息:

[SwitchB] display ip routing-table 1.1.1.1 verbose

 

Summary Count : 1

 

Destination: 1.1.1.1/32

   Protocol: RIP             

 Process ID: 1

  SubProtID: 0x1                     Age: 04h20m37s

       Cost: 1                Preference: 100

      IpPre: N/A              QosLocalID: N/A

        Tag: 0                     State: Active Adv

  OrigTblID: 0x0                 OrigVrf: default-vrf

    TableID: 0x2                  OrigAs: 0

      NibID: 0x26000002           LastAs: 0

     AttrID: 0xffffffff         Neighbor: 13.13.13.1

      Flags: 0x1008c         OrigNextHop: 13.13.13.1

      Label: NULL            RealNextHop: 13.13.13.1

    BkLabel: NULL              BkNextHop: 24.24.24.2

  Tunnel ID: Invalid           Interface: Vlan-interface200

BkTunnel ID: Invalid         BkInterface: Vlan-interface101

   FtnIndex: 0x0            TrafficIndex: N/A

  Connector: N/A

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!