选择区域语言: EN CN HK

03-二层技术-以太网交换命令参考

09-VLAN命令

本章节下载  (312.04 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S5830/S5830/Command/Command_Manual/H3C_S5830_CR-Release_(R1115[R1118])-6W102/03/201501/853339_30005_0.htm

09-VLAN命令


1 VLAN

1.1  VLAN配置命令

1.1.1  default

【命令】

default

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

【描述】

default命令用来恢复当前接口的缺省配置。

需要注意的是,执行default命令并不能保证接口下的所有命令都能恢复到缺省情况,某些命令可能会由于不满足必备条件而恢复失败。因此,执行default命令后建议通过display this命令确认执行效果。

【举例】

# 将VLAN接口1恢复为缺省配置。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] default

This command will restore the default settings. Continue? [Y/N]:y

1.1.2  description

【命令】

description text

undo description

【视图】

VLAN视图/VLAN接口视图

【缺省级别】

2:系统级

【参数】

text:VLAN或VLAN接口的描述字符串,可以包含字母(区分大小写)、数字、特殊字符(包括~ ! @ # $ % ^ & * ( ) - _ + = { } [ ] | \ : ; " ' < > , . /)、空格以及符合unicode编码规范的其它文字和符号。VLAN和VLAN接口的描述信息的取值范围分别为:

·     VLAN的描述信息为1~32个字符的字符串。

·     VLAN接口的描述信息为1~80个字符的字符串。

说明

·     一个英文字符占用一个字符长度,一个unicode编码的字符占用两个字符长度,用户可以在描述字符串中混合输入英文字符和unicode字符,但字符串总长度不能超过规定的长度范围。

·     如果用户在设置描述字符时需要使用unicode编码的某种文字或符号,则必须具有相应的输入法软件,并使用支持该字符的远程登录软件登录到设备上进行配置。

·     一个unicode编码的字符占用两个字符长度,所以当所配置的描述信息长度达到或超过终端软件最大列宽时,终端软件会进行自动换行,此时可能导致unicode字符被截断,终端软件会在换行处之后显示乱码。

 

【描述】

description命令用来配置当前VLAN或VLAN接口的描述信息。undo description命令用来恢复缺省情况。

缺省情况下,VLAN的描述信息为“VLAN vlan-id”,其中vlan-id为该VLAN的编号。例如,VLAN 100的描述信息为“VLAN 0100”;VLAN接口的描述信息为该VLAN接口的接口名,如“Vlan-interface1 Interface”。

需要注意的是,当设备上配置的VLAN较多时,用户可以根据功能或者连接情况为VLAN或VLAN接口设置特定的描述信息,以便记忆和管理VLAN或VLAN接口。

相关配置可参考命令display interface vlan-interfacedisplay vlan

【举例】

# 将VLAN 2的描述信息配置为sales-private。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] description sales-private

# 将VLAN接口2的描述信息配置为linktoPC56。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] description linktoPC56

1.1.3  display interface vlan-interface

【命令】

display interface [ vlan-interface ] [ brief [ down ] ] [ | { begin | exclude | include } regular-expression ]

display interface vlan-interface vlan-interface-id [ brief ] [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

vlan-interface-id:VLAN接口的编号。

brief:显示接口的概要信息。不指定该参数时,将显示接口的详细信息。

down:显示当前状态为down的接口的信息以及down的原因。不指定该参数时,将不会根据接口状态来过滤显示信息。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display interface vlan-interface命令用来显示VLAN接口的相关信息。

需要注意的是:

·     如果不指定vlan-interface参数,将显示设备支持的所有接口的相关信息。

·     如果指定vlan-interface参数,不指定vlan-interface-id参数,将显示所有已创建的VLAN接口的相关信息。

【举例】

# 显示VLAN接口2的相关信息。

<Sysname> display interface vlan-interface 2

Vlan-interface2 current state: DOWN

Line protocol current state: DOWN

Description: Vlan-interface2 Interface

The Maximum Transmit Unit is 1500

Internet protocol processing : disabled

IP Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 000f-e249-8050

IPv6 Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 000f-e249-8050

Last clearing of counters:  Never

     Last 300 seconds input:  0 bytes/sec 0 packets/sec

     Last 300 seconds output:  0 bytes/sec 0 packets/sec

     0 packets input, 0 bytes, 0 drops

     0 packets output, 0 bytes, 0 drops

# 显示VLAN接口2的概要信息。

<Sysname> display interface vlan-interface 2 brief

The brief information of interface(s) under route mode:

Link: ADM - administratively down; Stby - standby

Protocol: (s) - spoofing

Interface            Link Protocol Main IP         Description

Vlan2                DOWN DOWN     --

# 显示所有状态为down的VLAN接口的概要信息。

<Sysname> display interface vlan-interface brief down

The brief information of interface(s) under route mode:

Link: ADM - administratively down; Stby - standby

Interface            Link Cause

Vlan2                DOWN Not connected

表1-1 display interface vlan-interface命令显示信息描述表

字段

描述

Vlan-interface2 current state

VLAN接口的物理状态,状态可能为:

·     DOWN ( Administratively ):表示该VLAN接口已经通过shutdown命令被关闭,即管理状态为关闭

·     DOWN:表示该VLAN接口的管理状态为开启,但物理状态为关闭,即该接口对应的VLAN内没有处于up状态的物理端口(可能因为没有物理连线或者线路故障)

·     UP:该端口的管理状态和物理状态均为开启

Line protocol current state

VLAN接口的链路层协议状态,状态可能为:

·     DOWN:该VLAN接口的协议状态为关闭

·     UP:该VLAN接口的协议状态为开启

Description

VLAN接口的字符串描述

The Maximum Transmit Unit

VLAN接口允许通过的最大传输单元

Internet protocol processing : disabled

该接口还不具有处理IP报文的能力(当没有为该接口配置IP地址时会显示该信息)

Internet Address is 192.168.1.54/24 Primary

该接口的主IP地址为192.168.1.54/24(只有为该接口配置主IP地址后才会显示该信息)

Internet Address is 6.4.4.4/24 Sub

该接口的从IP地址为6.4.4.4/24(只有为该接口配置从IP地址后才会显示该信息)

IP Packet Frame Type

IPv4发送帧格式

Hardware address

VLAN接口对应的MAC地址

IPv6 Packet Frame Type

IPv6发送帧格式

Last 300 seconds input:  0 bytes/sec 0 packets/sec

当前接口最近300秒内输入报文的平均速率(单位为bps和pps)

Last 300 seconds output:  0 bytes/sec 0 packets/sec

当前接口最近300秒内输出报文的平均速率(单位为bps和pps)

0 packets input, 0 bytes, 0 drops

接口输入的报文总数(分别以包和字节为单位进行了统计),输入报文中丢弃的报文数

0 packets output, 0 bytes, 0 drops

接口输出的报文总数(分别以包和字节为单位进行了统计),输出报文中丢弃的报文数

The brief information of interface(s) under route mode:

三层模式下(route)的接口的概要信息,即三层接口的概要信息

Link: ADM - administratively down; Stby - standby

·     如果某接口的Link属性值为“ADM”,则表示该接口被管理员手工关闭了,需要在该接口下执行undo shutdown命令才能恢复端口本身的物理状态

·     如果某接口的Link属性值为“Stby”,则表示该接口是一个备份接口

Protocol: (s) - spoofing

如果某接口的Protocol属性值中带有“(s)”字符串,则表示该接口的网络层协议状态显示是UP的,但实际可能没有对应的链路,或者所对应的链路不是永久存在而是按需建立

Interface

接口名称缩写

Link

接口物理连接状态,取值可能为:

·     UP:表示本链路物理上是连通的

·     ADM:表示本链路被手工关闭了,需要执行undo shutdown命令才能恢复真实的物理状态

Protocol

接口协议连接状态,取值为UP(s)

Main IP

接口主IP地址

Description

接口的描述信息

Cause

接口物理连接状态为DOWN的原因

·     取值为Administratively时表示本链路被手工关闭了,需要执行undo shutdown命令才能恢复真实的物理状态

·     取值为Not connected时表示本链路没有物理连接

 

1.1.4  display vlan

【命令】

display vlan [ vlan-id1 [ to vlan-id2 ] | all | dynamic | reserved | static ] [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

vlan-id1:显示指定VLAN的信息。vlan-id1为指定VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:显示ID在指定范围内的VLAN的信息。vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4094。vlan-id2的值要大于或等于vlan-id1的值。

all:显示除保留VLAN外的其它VLAN的信息。

dynamic:显示系统动态创建的VLAN的数量和编号。动态VLAN是指通过GVRP协议生成或通过Radius服务器下发的VLAN。

reserved:显示系统保留VLAN的信息。保留VLAN是设备根据功能实现的需要预留的VLAN。保留VLAN由协议模块来指定,为协议模块服务,用户不能对保留VLAN进行任何操作。

static:显示系统静态创建的VLAN的数量和VLAN编号。静态VLAN是指通过命令行手工创建的VLAN。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display vlan命令用来显示VLAN的相关信息。

相关配置可参考命令vlan

【举例】

# 显示VLAN 2的信息。

<Sysname> display vlan 2

 VLAN ID: 2

 VLAN Type: static

 Route interface: not configured

 Description: VLAN 0002

 Name: VLAN 0002

 Tagged   Ports: none

 Untagged Ports: 

    GigabitEthernet1/0/1  GigabitEthernet1/0/2  GigabitEthernet1/0/3

# 显示VLAN 3的信息。

<Sysname> display vlan 3

 VLAN ID: 3

 VLAN Type: static

 Route Interface: configured

 IP Address: 1.1.1.1

 Subnet Mask: 255.255.255.0

 Description: VLAN 0003

 Name: VLAN 0003

 Tagged   Ports: none

 Untagged Ports: none

表1-2 display vlan命令显示信息描述表

字段

解释

VLAN ID

VLAN的编号

VLAN Type

VLAN的类型:static表示静态VLAN;dynamic表示动态VLAN

Route interface

设备上是否创建了对应的VLAN接口:not configured(没有创建)/configured(创建了)

Description

VLAN的描述信息

Name

VLAN的名称

IP Address

VLAN接口的主用IP地址(如果VLAN接口没有配置IP地址,则不显示该字段),如果VLAN接口上还配置了从IP地址,可以使用display interface vlan-interface或者在VLAN接口视图下使用display this命令查看

Subnet Mask

VLAN接口的主用IP地址的子网掩码(如果VLAN接口没有配置IP地址,则不显示该字段)

Tagged Ports

该VLAN报文从哪些端口发送时需要携带Tag标记

Untagged Ports

该VLAN报文从哪些端口发送时不需要携带Tag标记

 

1.1.5  interface vlan-interface

【命令】

interface vlan-interface vlan-interface-id

undo interface vlan-interface vlan-interface-id

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

vlan-interface-id:VLAN接口的编号,取值范围为1~4094。

【描述】

interface vlan-interface命令用来创建VLAN接口并进入VLAN接口视图。如果该VLAN接口已经存在,则直接进入VLAN接口视图。undo interface vlan-interface命令用来删除指定的VLAN接口。

空配置启动时,使用软件功能缺省值,设备上没有任何VLAN接口。

缺省配置启动时,使用软件功能出厂值,设备上已创建VLAN1接口。

关于空配置启动和缺省配置启动,请参见“基础配置指导”中的“配置文件管理”。

需要注意的是:

·     在创建VLAN接口之前,对应的VLAN必须已经存在,否则将不能创建指定的VLAN接口。

·     用户可以在VLAN接口视图下使用ip address命令配置IP地址,使得交换机具有三层路由功能。

·     Release 1115版本无出厂缺省配置文件,缺省情况下,设备上没有任何VLAN接口。

相关配置可参考命令display interface vlan-interface

【举例】

# 创建VLAN接口2并进入视图。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2]

1.1.6  ip address

【命令】

ip address ip-address { mask | mask-length } [ sub ]

undo ip address [ ip-address { mask | mask-length } [ sub ] ]

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

ip-address:VLAN接口的IP地址,为点分十进制格式。

mask:子网掩码,为点分十进制格式。

mask-length:子网掩码长度,即子网掩码中“1”的个数,取值范围为0~32。

sub:表示该地址为VLAN接口的从IP地址。

【描述】

ip address命令用来给VLAN接口指定IP地址和掩码。undo ip address命令用来删除VLAN接口的IP地址和掩码。

空配置启动时,使用软件功能缺省值,没有配置VLAN接口的IP地址。

缺省配置启动时,使用软件功能出厂值,VLAN1接口使用DHCP方式自动获取IP地址。

Release 1115版本无出厂缺省配置文件,缺省情况下,没有配置VLAN接口的IP地址。

一般情况下,一个接口配置一个IP地址即可,但为了使设备的一个VLAN可以与多个子网相连,VLAN接口可以配置多个IP地址,其中一个为主IP地址,其余为从IP地址。主从地址的配置关系为:

·     当配置主IP地址时,如果接口上已经有主IP地址,则原主IP地址被新配置的地址取代。

·     undo ip address命令不带任何参数表示删除该接口的所有IP地址。

·     undo ip address ip-address { mask | mask-length }表示删除主IP地址。

·     undo ip address ip-address { mask | mask-length } sub表示删除从IP地址。

·     在删除主IP地址之前必须先删除从IP地址。

相关配置可参考“三层技术-IP业务命令参考/IP地址”中的命令display ip interface

【举例】

# 指定VLAN接口1的IP地址为1.1.0.1,子网掩码为255.255.255.0。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] ip address 1.1.0.1 255.255.255.0

1.1.7  mtu

【命令】

mtu size

undo mtu

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

size:表示接口允许通过的MTU(Maximum Transmission Unit,最大传输单元)值的大小,单位为字节。取值范围为46~1500。

【描述】

mtu命令用来配置VLAN接口的MTU值。undo mtu命令用来恢复缺省情况。

缺省情况下,VLAN接口的MTU值为1500字节。

相关配置可参考命令display interface vlan-interface

【举例】

# 配置VLAN接口1的MTU值为1492字节。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] mtu 1492

1.1.8  name

【命令】

name text

undo name

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

text:VLAN名称,为1~32个字符的描述信息,可以包含字母(区分大小写)、数字、特殊字符(包括~ ! @ # $ % ^ & * ( ) - _ + = { } [ ] | \ : ; " ' < > , . /)、空格以及符合unicode编码规范的其它文字和符号。

【描述】

name命令用来指定当前VLAN的名称。当交换机上配置了802.1X或MAC地址认证功能后,可以通过Radius服务器来对认证通过的端口下发VLAN。某些服务器可以向交换机发送需要下发的VLAN编号或者VLAN名称,当VLAN数量很多的时候,使用名称可以更明确的定位VLAN。undo name命令用来恢复缺省情况。

缺省情况下,VLAN的名称为“VLAN vlan-id”,其中vlan-id为该VLAN的编号。例如,VLAN 100的名称为“VLAN 0100”。

需要注意的是,当设备上配置了802.1X或MAC地址认证功能后,可以通过RADIUS服务器来对认证通过的端口下发VLAN。某些服务器可以向设备发送需要下发的VLAN编号或者VLAN名称,当VLAN数量很多的时候,使用名称可以更明确的定位VLAN。

相关配置可参考命令display vlan

【举例】

# 指定VLAN 2的名称为Test VLAN。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] name Test VLAN

1.1.9  shutdown

【命令】

shutdown

undo shutdown

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

【描述】

shutdown命令用来手工关闭VLAN接口。undo shutdown命令用来取消手工关闭VLAN接口。

缺省情况下,未手工关闭VLAN接口。此时VLAN接口状态受VLAN中端口状态的影响,即:当VLAN中所有以太网端口状态均为down时,VLAN接口为down状态,即关闭状态;当VLAN中有一个或一个以上的以太网端口处于up状态时,则VLAN接口处于up状态。

需要注意的是:

·     如果手工关闭VLAN接口,则VLAN接口的状态始终为down(Administratively),不受VLAN中端口状态的影响。

·     配置VLAN接口参数前,为了避免配置过程中对网络造成影响,建议先使用shutdown命令手工关闭接口,之后再配置参数。配置完成后,使用undo shutdown命令取消手工关闭接口,使配置的参数生效。

·     当VLAN接口出现故障时,可以使用shutdown命令手工关闭接口,然后再使用undo shutdown命令取消手工关闭接口,这样有可能使接口恢复正常。

·     关闭和打开VLAN接口对于属于这个VLAN的任何一个以太网端口本身都不起作用,以太网端口的状态不随VLAN接口状态的改变而改变。

【举例】

# 将VLAN接口2关闭后再重新打开。

<Sysname> system-view

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] shutdown

[Sysname-Vlan-interface2] undo shutdown

1.1.10  vlan

【命令】

vlan { vlan-id1 [ to vlan-id2 ] | all }

undo vlan { vlan-id1 [ to vlan-id2 ] | all }

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

vlan-id1:VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:指定VLAN的编号范围。vlan-id1vlan-id2为VLAN的编号,取值范围为1~4094。vlan-id2的值要大于或等于vlan-id1的值。

all:除保留VLAN外的其它VLAN。

【描述】

vlan vlan-id命令用来创建VLAN并进入VLAN视图。如果指定的VLAN已创建,则该命令直接用来进入该VLAN的视图。vlan vlan-id1 to vlan-id2命令用来批量创建vlan-id1vlan-id2之间的所有VLAN,保留VLAN除外。vlan all命令用来批量创建VLAN 1~VLAN 4094。undo vlan命令用来删除VLAN。

缺省情况下,系统只有一个缺省VLAN(VLAN 1)。

需要注意的是:

·     VLAN 1为系统缺省VLAN,用户不能创建和删除。

·     保留VLAN是系统为实现特定功能预留的VLAN,用户也不能手工创建和删除。

·     对于协议保留的VLAN、管理VLAN、动态学习到的VLAN、配置有QoS策略的VLAN、Smart Link的控制VLAN、RRPP的控制VLAN以及远程镜像VLAN等,都不能使用undo vlan命令直接删除。只有将相关配置删除之后,才能删除相应的VLAN。

相关配置可参考命令display vlan

【举例】

# 创建VLAN 2,并进入该VLAN视图。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2]

# 批量创建VLAN 4~VLAN 100。

<Sysname> system-view

[Sysname] vlan 4 to 100

Please wait............. Done.

1.2  基于端口的VLAN配置命令

1.2.1  display port

【命令】

display port { hybrid | trunk } [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

hybrid:显示系统当前存在的Hybrid端口。

trunk:显示系统当前存在的Trunk端口。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display port命令用来显示设备上当前存在的Hybrid或Trunk端口。显示的信息包括端口对应的端口名、缺省VLAN ID和允许通过的VLAN ID。

【举例】

# 显示当前系统存在的Hybrid端口。

<Sysname> display port hybrid

Interface            PVID  VLAN passing

GE1/0/4               100   Tagged:  1000, 1002, 1500, 1600-1611, 2000,

                                    2555-2558, 3000, 4000

                           Untagged:1, 10, 15, 18, 20-30, 44, 55, 67, 100,

                                    150-160, 200, 255, 286, 300-302

# 显示当前系统存在的Trunk端口。

<Sysname> display port trunk

Interface            PVID  VLAN passing

GE1/0/8               2     1-4, 6-100, 145, 177, 189-200, 244, 289, 400,

                           555, 600-611, 1000, 2006-2008

表1-3 display port命令显示信息描述表

字段

描述

Interface

接口名称

PVID

该端口的缺省VLAN ID

VLAN passing

表示哪些VLAN的报文允许通过该端口

Tagged

表示哪些VLAN的报文通过该端口时必须携带VLAN Tag

Untagged

表示哪些VLAN的报文通过该端口时必须去掉VLAN Tag

 

1.2.2  port

【命令】

port interface-list

undo port interface-list

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

interface-list:接口列表,表示方式为interface-list = { interface-type interface-number1 [ to interface-type interface-number2 ] }&<1-10>。其中,interface-type interface-number为指定接口类型和接口编号。&<1-10>表示前面的参数最多可以输入10次。

【描述】

port命令用来向当前VLAN中添加一个或一组Access端口。undo port命令用来从当前VLAN中删除一个或一组Access端口。

缺省情况下,系统将所有端口都加入到VLAN 1。

需要注意的是:

·     通过本命令只能将Access端口加入到VLAN中,不能将Trunk和Hybrid端口加入到VLAN中。

·     设备上的所有端口的缺省链路类型都是Access类型,但用户可以自行切换端口类型,具体配置可参考命令port link-type

·     不支持二层聚合接口添加到当前VLAN。

相关配置可参考命令display vlan

【举例】

# 向VLAN 2中加入从GigabitEthernet1/0/1到GigabitEthernet1/0/3的以太网端口。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] port gigabitethernet 1/0/1 to gigabitethernet 1/0/3

1.2.3  port access vlan

【命令】

port access vlan vlan-id

undo port access vlan

【视图】

二层以太网端口视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定的VLAN编号,取值范围为1~4094。该VLAN必须是设备上已创建的VLAN,否则,该命令执行失败。

【描述】

port access vlan命令用来将当前Access端口加入到指定的VLAN中。undo port access vlan命令用来恢复缺省情况。

缺省情况下,所有Access端口都属于VLAN 1。

需要注意的是:

·     二层以太网端口视图下的配置只对当前端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

【举例】

# 将GigabitEthernet1/0/1端口加入到VLAN 3中。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] quit

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port access vlan 3

# 将二层聚合接口1以及其对应的成员端口加入到VLAN 3中。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] quit

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port access vlan 3

1.2.4  port hybrid pvid

【命令】

port hybrid pvid vlan vlan-id

undo port hybrid pvid

【视图】

二层以太网端口视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定接口的缺省的VLAN ID,取值范围为1~4094。

【描述】

port hybrid pvid命令用来设置Hybrid端口的缺省VLAN。undo port hybrid pvid命令用来恢复缺省情况。

缺省情况下,Hybrid端口的缺省VLAN为VLAN 1。

需要注意的是:

·     对Hybrid端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即可以使用已经不存在的VLAN作为缺省VLAN。

·     建议本机Hybrid端口的缺省VLAN和相连的对端交换机的Hybrid端口的缺省VLAN保持一致。

·     配置缺省VLAN后,必须使用port hybrid vlan命令配置允许缺省VLAN的报文通过,出接口才能转发缺省VLAN的报文。

·     二层以太网端口视图下的配置只对当前端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

相关配置可参考命令port link-typeport hybrid vlan

【举例】

# 配置端口GigabitEthernet1/0/1(Hybrid类型)的缺省VLAN为VLAN 100,并允许VLAN 100的报文不带VLAN Tag通过。

<Sysname> system-view

[Sysname] vlan 100

[Sysname-vlan100] quit

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type hybrid

[Sysname-GigabitEthernet1/0/1] port hybrid pvid vlan 100

[Sysname-GigabitEthernet1/0/1] port hybrid vlan 100 untagged

# 将二层聚合接口1(Hybrid类型)以及其对应的成员端口的缺省VLAN设置为VLAN 100,并允许VLAN 100的报文不带VLAN Tag通过。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type hybrid

[Sysname-Bridge-Aggregation1] port hybrid pvid vlan 100

[Sysname-Bridge-Aggregation1] port hybrid vlan 100 untagged

1.2.5  port hybrid vlan

【命令】

port hybrid vlan vlan-list { tagged | untagged }

undo port hybrid vlan vlan-list

【视图】

二层以太网端口视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-list:VLAN列表,Hybrid端口允许通过的VLAN范围。表示方式为vlan-list = { vlan-id1 [ to vlan-id2 ] }&<1-10>。其中,vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4094,vlan-id2的值要大于或等于vlan-id1的值。&<1-10>表示前面的参数最多可以重复输入10次。该VLAN必须是设备上已创建的VLAN,否则,该命令执行失败。

tagged:该端口在转发指定的VLAN报文时将保留VLAN Tag。

untagged:该端口在转发指定的VLAN报文时将去掉VLAN Tag。

【描述】

port hybrid vlan命令用来允许指定的VLAN通过当前Hybrid端口。undo port hybrid vlan命令用来禁止指定的VLAN通过当前Hybrid端口。

缺省情况下,Hybrid端口只允许VLAN 1的报文以Untagged方式通过,即VLAN 1的报文从该端口发送出去后不携带VLAN Tag。

需要注意的是:

·     Hybrid端口允许多个VLAN通过。如果多次使用port hybrid vlan命令,那么Hybrid端口上允许通过的VLAN是这些vlan-list的合集。

·     二层以太网端口视图下的配置只对当前端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

相关配置可参考命令port link-type

【举例】

# 配置端口GigabitEthernet1/0/1(Hybrid类型)允许VLAN 2、VLAN 4、VLAN 50~VLAN 100通过(假设指定的VLAN都已经创建),并且发送这些VLAN的报文时保留VLAN Tag。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type hybrid

[Sysname-GigabitEthernet1/0/1] port hybrid vlan 2 4 50 to 100 tagged

# 将二层聚合接口1(Hybrid类型)以及其对应的成员端口允许VLAN 2通过,并且发送VLAN 2的报文时不带VLAN Tag。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type hybrid

[Sysname-Bridge-Aggregation1] port hybrid vlan 2 untagged

 Please wait... Done.

 Configuring GigabitEthernet1/0/1... Done.

 Configuring GigabitEthernet1/0/2... Done.

 Configuring GigabitEthernet1/0/3... Done.

接口GigabitEthernet1/0/1、GigabitEthernet1/0/2和GigabitEthernet1/0/3是二层聚合接口1对应的成员端口。

1.2.6  port link-type

【命令】

port link-type { access | hybrid | trunk }

undo port link-type

【视图】

二层以太网端口视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

access:设置端口的链路类型为Access类型。

hybrid:设置端口的链路类型为Hybrid类型。

trunk:设置端口的链路类型为Trunk类型。

【描述】

port link-type命令用来设置当前端口的链路类型。undo port link-type命令用来恢复缺省情况。

缺省情况下,所有端口的链路类型均为Access类型。

需要注意的是:

·     Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其它类型端口。

·     当使用port link-type命令修改接口的链路类型后,该接口下的loopback-detection action配置会自动恢复到缺省情况。相关配置可参考“二层技术-以太网交换命令参考/以太网端口”中的命令loopback-detection action

·     二层以太网端口视图下的配置只对当前端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

【举例】

# 将以太网端口GigabitEthernet1/0/1设置为Trunk类型端口。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type trunk

# 将二层聚合接口1以及其对应的成员端口的链路类型设置为Hybrid。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type hybrid

1.2.7  port trunk permit vlan

【命令】

port trunk permit vlan { vlan-list | all }

undo port trunk permit vlan { vlan-list | all }

【视图】

二层以太网端口视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-list:VLAN列表,Trunk端口允许通过的VLAN范围。表示方式为vlan-list = { vlan-id1 [ to vlan-id2 ] }& <1-10>。其中,vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4094,vlan-id2的值要大于或等于vlan-id1的值。&<1-10>表示前面的参数最多可以重复输入10次。

all:表示允许所有VLAN通过该Trunk端口,建议用户谨慎使用port trunk permit vlan all命令,以防止未授权VLAN的用户通过该端口访问受限资源。

【描述】

port trunk permit vlan命令用来允许指定的VLAN通过当前Trunk端口。undo port trunk permit vlan命令用来禁止指定的VLAN通过当前Trunk端口。

缺省情况下,Trunk端口只允许VLAN 1的报文通过。

需要注意的是:

·     Trunk端口可以允许多个VLAN通过。如果多次执行port trunk permit vlan命令,那么Trunk端口上允许通过的VLAN是这些vlan-list的集合。

·     Trunk端口发送出去的报文,只有缺省VLAN的报文不带VLAN Tag,其它VLAN的报文均会保留VLAN Tag。

·     二层以太网端口视图下的配置只对当前端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

相关配置可参考命令port link-type

【举例】

# 配置端口GigabitEthernet1/0/1(Trunk类型)允许VLAN 2、4、50~100通过。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type trunk

[Sysname-GigabitEthernet1/0/1] port trunk permit vlan 2 4 50 to 100

Please wait........... Done.

# 将二层聚合接口1(Trunk类型)允许VLAN 2通过。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type trunk

[Sysname-Bridge-Aggregation1] port trunk permit vlan 2

 Please wait... Done.

 Configuring GigabitEthernet1/0/1... Done.

 Configuring GigabitEthernet1/0/2... Done.

 Configuring GigabitEthernet1/0/3... Done.

接口GigabitEthernet1/0/1、GigabitEthernet1/0/2和GigabitEthernet1/0/3是二层聚合接口1的成员端口。

1.2.8  port trunk pvid

【命令】

port trunk pvid vlan vlan-id

undo port trunk pvid

【视图】

二层以太网端口视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定接口的缺省VLAN ID,取值范围为1~4094。

【描述】

port trunk pvid命令用来设置Trunk端口的缺省VLAN。undo port trunk pvid命令用来恢复缺省情况。

缺省情况下,Trunk端口的缺省VLAN为VLAN 1。

需要注意的是:

·     对Trunk端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即使用已经不存在的VLAN作为缺省VLAN。

·     本端设备Trunk端口的缺省VLAN ID和相连的对端设备的Trunk端口的缺省VLAN ID必须一致,否则报文将不能正确传输。

·     配置缺省VLAN后,必须使用port trunk permit vlan命令配置允许缺省VLAN的报文通过,出接口才能转发缺省VLAN的报文。

·     二层以太网端口视图下的配置只对当前端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

相关配置可参考命令port link-typeport trunk permit vlan

【举例】

# 配置端口GigabitEthernet1/0/1(Trunk类型)的缺省VLAN设置为VLAN 100,并允许VLAN 100通过。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type trunk

[Sysname-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Sysname-GigabitEthernet1/0/1] port trunk permit vlan 100

# 将二层聚合接口1(Trunk类型)的缺省VLAN设置为VLAN 100,并允许VLAN 100通过。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type trunk

[Sysname-Bridge-Aggregation1] port trunk pvid vlan 100

[Sysname-Bridge-Aggregation1] port trunk permit vlan 100

1.3  基于MAC的VLAN配置命令

1.3.1  display mac-vlan

【命令】

display mac-vlan { all | dynamic | mac-address mac-address [ mask mac-mask ] | static | vlan vlan-id } [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

all:显示MAC-VLAN表的所有表项。

dynamic:显示动态配置的MAC-VLAN表项。

mac-address mac-address:按MAC显示MAC-VLAN表项。

mask mac-mask:显示指定范围的MAC-VLAN表项。

static:显示静态配置的MAC-VLAN表项。

vlan vlan-id:显示指定VLAN的MAC-VLAN表项。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display mac-vlan命令用来显示MAC-VLAN表项。

指定mac-address参数但不带mask参数,则显示单个MAC VLAN表项。

【举例】

# 显示MAC-VLAN表的所有表项。

<Sysname> display mac-vlan all

The following MAC-VLAN address exist:

S: Static   D: Dynamic

MAC ADDR           MASK                    VLAN ID   PRIO    STATE

-------------------------------------------------------------------

0008-0001-0000     FFFF-FF00-0000          5         3       S

0002-0001-0000     FFFF-FFFF-FFFF          5         3       S&D

 

Total MAC VLAN address count:2

表1-4 display mac-vlan命令显示信息描述表

字段

描述

The following MAC-VLAN address exist:

目前设备上存在以下MAC VLAN配置

S: Static

以下显示信息中,S表示静态配置的MAC VLAN

D: Dynamic

以下显示信息中,D表示动态配置的MAC VLAN

MAC ADDR

配置的MAC-VLAN的MAC地址

MASK

配置的MAC-VLAN的MAC地址对应的掩码

VLAN ID

用户配置的MAC地址所对应的VLAN

PRIO

用户配置的MAC地址所对应的802.1P优先级

STATE

该表项的属性,MAC-VLAN表中的表项有三种属性:

·     S表示该表项是通过用户静态配置生成的

·     D表示该表项是通过认证功能自动生成的

·     S&D表示该表项由静态和动态同时配置的

 

1.3.2  display mac-vlan interface

【命令】

display mac-vlan interface [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display mac-vlan interface命令用来显示所有使能了MAC-VLAN功能的接口。

相关配置可参考命令mac-vlan enable

【举例】

# 显示所有使能了MAC-VLAN功能的接口。

<Sysname> display mac-vlan interface

MAC VLAN is enabled on following ports:

---------------------------------------

 GigabitEthernet1/0/1  GigabitEthernet1/0/2  GigabitEthernet1/0/3

1.3.3  mac-vlan enable

【命令】

mac-vlan enable

undo mac-vlan enable

【视图】

二层以太网端口视图

【缺省级别】

2:系统级

【参数】

【描述】

mac-vlan enable命令用来使能端口基于MAC地址划分VLAN的功能。undo mac-vlan enable 命令用来恢复缺省情况。

缺省情况下,没有使能端口基于MAC地址划分VLAN的功能。

需要注意的是,该命令只能在Hybrid端口配置。

【举例】

# 使能端口GigabitEthernet1/0/1的MAC VLAN功能。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname] port link-type hybrid

[Sysname–GigabitEthernet1/0/1] mac-vlan enable

1.3.4  mac-vlan mac-address

【命令】

mac-vlan mac-address mac-address [ mask mac-mask ] vlan vlan-id [ priority pri ]

undo mac-vlan { all | mac-address mac-address [ mask mac-mask ] | vlan vlan-id }

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

mac-address mac-address:指定MAC地址。

mask mac-mask:指定MAC地址的掩码,二进制时高位必须为连续1。缺省值为全F。

vlan vlan-id:指定VLAN编号,取值为1~4094。

priority pri:指定MAC地址对应VLAN的802.1p优先级,取值为0~7,缺省值为0。

all:删除所有的静态MAC-VLAN表项。

【描述】

mac-vlan mac-address命令用来配置MAC地址所对应的VLAN以及其优先级。undo mac-vlan命令用来删除MAC地址与VLAN的关联。

设备维护两张MAC-VLAN表,一种是通过指定mask参数配置的MAC-VLAN表,该表里的表项描述的是一类MAC地址和VLAN、优先级之间的关系;一种是不指定mask参数直接配置的MAC-VLAN表,该表里的表项描述的是单个MAC地址和VLAN、优先级之间的关系。根据用户的配置,系统将自动往这两个表里添加/删除表项。

【举例】

# 配置单个MAC地址(0-1-1)与VLAN 100的关联,并指定优先级为7。

<Sysname> system-view

[Sysname] mac-vlan mac-address 0-1-1 vlan 100 priority 7

# 配置将MAC地址前6位为121122的用户与VLAN 100关联,优先级为4。

<Sysname> system-view

[Sysname] mac-vlan mac-address 1211-2222-3333 mask ffff-ff00-0000 vlan 100 priority 4

1.3.5  mac-vlan trigger enable

【命令】

mac-vlan trigger enable

undo mac-vlan trigger enable

【视图】

二层以太网端口视图

【缺省级别】

2:系统级

【参数】

【描述】

mac-vlan trigger enable命令用来使能MAC VLAN的动态触发功能。undo mac-vlan trigger enable命令用来恢复缺省情况。

缺省情况下,未使能MAC VLAN的动态触发功能。

端口根据收到的报文的源MAC地址查询MAC VLAN表项来控制是否允许报文进行转发,如果源MAC地址和系统中配置的Mask为全F的MAC VLAN表项匹配,则添加MAC地址并动态触发端口加入该VLAN,后续的报文可以进行转发。如果没有找到匹配表项或者只匹配了Mask不是全F的MAC VLAN表项,均不会动态触发端口加入该VLAN

【举例】

# 二层以太网端口GigabitEthernet1/0/1上配置MAC VLAN的动态触发功能。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] mac-vlan trigger enable

1.3.6  port pvid disable

【命令】

port pvid disable

undo port pvid disable

【视图】

二层以太网端口视图

【缺省级别】

2:系统级

【参数】

【描述】

port pvid disable命令用来配置当报文源MAC地址不匹配MAC-VLAN表项时,禁止该报文在缺省VLAN内转发。undo port pvid disable命令用来恢复缺省情况。

缺省情况下,对于没有匹配到MAC-VLAN表项的未知源MAC会在缺省VLAN内进行转发通过。

【举例】

# 在端口GigabitEthernet1/0/1上配置当报文源MAC地址不匹配MAC-VLAN表项时,禁止该报文在缺省VLAN内转发。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port pvid disable

1.3.7  vlan precedence

【命令】

vlan precedence { mac-vlan | ip-subnet-vlan }

undo vlan precedence

【视图】

二层以太网端口视图

【缺省级别】

2:系统级

【参数】

mac-vlan:表示优先根据单个MAC地址来匹配VLAN。

ip-subnet-vlan:表示优先根据IP子网来匹配VLAN。

【描述】

vlan precedence命令用来配置当前端口的VLAN匹配优先级。undo vlan precedence命令用来恢复缺省情况。

缺省情况下,对于基于单个MAC的VLAN表项和基于IP子网的VLAN,优先根据单个MAC地址来匹配VLAN。

需要注意的是,该配置只对基于单个MAC的VLAN表项和基于IP子网的VLAN有效。如果端口下同时使能了MAC VLAN和IP子网VLAN,则当端口收到报文后,会根据vlan precedence命令的配置情况来决定是优先匹配单个MAC-VLAN表还是优先匹配IP子网-VLAN表。

【举例】

# 配置优先根据单个MAC地址来匹配VLAN。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] vlan precedence mac-vlan

1.4  基于协议的VLAN配置命令

1.4.1  display protocol-vlan interface

【命令】

display protocol-vlan interface { interface-type interface-number1 [ to interface-type interface-number2 ] | all } [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

2:系统级

【参数】

interface-type interface-number1:需要显示的接口的类型和编号。

interface-type interface-number1 to interface-type interface-number2:需要显示的接口的类型和范围。

all:显示所有端口的协议VLAN的相关信息。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display protocol-vlan interface命令用于显示端口上已配置的协议VLAN的相关信息。

【举例】

# 显示端口GigabitEthernet1/0/1上已配置的协议VLAN的相关信息。

<Sysname> display protocol-vlan interface gigabitethernet 1/0/1

 Interface: GigabitEthernet1/0/1

   VLAN ID   Protocol Index      Protocol Type

 ======================================================

       2          0               ipv6

       3          0               ipv4

表1-5 display protocol-vlan interface命令显示信息描述表

字段

描述

Interface

当前查看的端口

VLAN ID

与该端口绑定的协议VLAN的编号

Protocol Index

协议模板索引号

Protocol Type

该协议模板所指定的协议类型

 

1.4.2  display protocol-vlan vlan

【命令】

display protocol-vlan vlan { vlan-id1 [ to vlan-id2 ] | all } [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

2:系统级

【参数】

vlan-id1:显示指定协议VLAN的相关信息,vlan-id1表示VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:显示指定VLAN范围内协议VLAN的相关信息。vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4094,vlan-id2的值要大于或等于vlan-id1的值。

all:显示所有协议VLAN的相关信息。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display protocol-vlan vlan命令用于显示VLAN上所配置的协议及协议的索引。

相关配置可参考命令display vlan

【举例】

# 显示系统当前所有协议VLAN的协议信息及协议的索引。

<Sysname> display protocol-vlan vlan all

 VLAN ID:2

    Protocol Index      Protocol Type

 ======================================================

          0              ipv4

          3              ipv6

 VLAN ID:3

    Protocol Index      Protocol Type

 ======================================================

          0              ipv4

          1              ipv6

表1-6 display protocol-vlan vlan命令显示信息描述表

字段

描述

VLAN ID

与该端口绑定的协议VLAN的编号

Protocol Index

协议模板索引号

Protocol Type

该协议模板所指定的协议类型

 

1.4.3  port hybrid protocol-vlan

【命令】

port hybrid protocol-vlan vlan vlan-id { protocol-index [ to protocol-end ] | all }

undo port hybrid protocol-vlan { vlan vlan-id { protocol-index [ to protocol-end ] | all } | all }

【视图】

二层以太网端口视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan vlan-id:VLAN的编号,取值范围为1~4094。

protocol-index:已创建的协议VLAN的协议索引,取值范围为0~15。创建协议VLAN时由用户手工指定或者系统自动分配。可以通过display protocol-vlan vlan all命令来查看协议索引。

to protocol-end:协议索引终止值,取值范围为0~15,必须大于等于协议索引初始值。

all:与vlan-id绑定的所有协议。

【描述】

port hybrid protocol-vlan命令用来配置Hybrid端口与基于协议的VLAN关联。undo port hybrid protocol-vlan命令用于取消Hybrid端口与基于协议的VLAN关联。

需要注意的是:

·     二层以太网端口视图下的配置只对当前端口生效;二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

·     执行该命令前必须先进行以下配置,否则将执行失败:创建VLAN,并与协议关联;将端口类型配置为Hybrid类型;配置端口允许协议VLAN的报文通过。

相关配置可参考命令display protocol-vlan interface

【举例】

# 把端口GigabitEthernet1/0/1(Hybrid类型)与协议VLAN 2中的协议0(IPv4协议)相关联。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] protocol-vlan ipv4

[Sysname-vlan2] quit

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type hybrid

[Sysname-GigabitEthernet1/0/1] port hybrid vlan 2 untagged

 Please wait... Done

[Sysname-GigabitEthernet1/0/1] port hybrid protocol-vlan vlan 2 0

# 把二层聚合接口1(Hybrid类型)与协议VLAN 2中的协议0相关联。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] protocol-vlan ipv4

[Sysname-vlan2] quit

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type hybrid

[Sysname-Bridge-Aggregation1] port hybrid vlan 2 untagged

 Please wait... Done

 Configuring GigabitEthernet1/0/1... Done.

 Configuring GigabitEthernet1/0/2... Done.

 Configuring GigabitEthernet1/0/3... Done.

[Sysname-Bridge-Aggregation1] port hybrid protocol-vlan vlan 2 0

接口GigabitEthernet1/0/1、GigabitEthernet1/0/2和GigabitEthernet1/0/3是二层聚合接口1的成员端口。

1.4.4  protocol-vlan

【命令】

protocol-vlan [ protocol-index ] { at | ipv4 | ipv6 | ipx { ethernetii | llc | raw | snap } | mode { ethernetii etype etype-id | llc { dsap dsap-id [ ssap ssap-id ] | ssap ssap-id } | snap etype etype-id } }

undo protocol-vlan { protocol-index [ to protocol-end ] | all }

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

at:表示基于AT(AppleTalk,Apple计算机网络协议)协议的VLAN。

ipv4:表示基于IPv4协议的VLAN。

ipv6:表示基于IPv6协议的VLAN。

ipx:表示基于IPX协议的VLAN,可包括ethernetiillcrawsnap四种封装类型。

mode:表示自定义协议模板,可包括ethernetiillcsnap三种封装类型。

ethernetii etype etype-id:表示匹配Ethernet II封装格式的报文。其中,etype-id表示入报文的协议类型值,取值范围为0x0600~0xFFFF(不包括0x0800、0x809B、0x8137和0x86DD)。

llc:匹配LLC封装格式的报文。

dsap dsap-id:目的服务接入点,取值范围为0x00~0xFF。

ssap ssap-id:源服务接入点,取值范围为0x00~0xFF。

snap etype etype-id:表示匹配SNAP封装格式的报文。其中,etype-id表示入报文的以太网类型,取值范围为0x0600~0xFFFF(不包括0x8137)。

protocol-index:协议索引,用来标志与当前VLAN绑定的协议模版。取值范围为0~15。如果不指定该参数,则系统会自动分配一个索引值。

to protocol-end:协议索引终止值,取值范围为0~15,必须大于等于协议索引初始值。

all:表示与当前VLAN绑定的所有协议。

【描述】

protocol-vlan命令用来配置基于协议的VLAN,并指定协议模板。undo protocol-vlan命令用于取消配置的协议模板。

缺省情况下,没有配置任何协议模板。

需要注意的是:

·     使用mode ethernetii etype关键字进行配置时,不允许将etype-id的值配置为0x0800、0x809B、0x8137或0x86DD,因为上述取值分别与IPv4、AppleTalk、IPX和IPv6协议模板相同。

·     使用mode llc关键字进行配置时,dsap-idssap-id的值不能同时为0xE0(代表IPX报文的LLC封装格式)或者同时为0xFF(代表IPX报文的raw封装格式),否则系统将提示出错;如果只配置了dsap-idssap-id中的一个,系统会将另一参数的值自动设置为0xAA。

·     使用mode snap etype关键字进行配置时,不允许将etype-id的值配置为0x8137,因为该值与IPX协议协议模板相同。当etype-id的值取0x0800、0x809B或0x86DD时,其对应的三层协议分别为IPv4、AppleTalk和IPv6。

相关配置可参考命令display protocol-vlan vlan

【举例】

# 配置VLAN 3为协议VLAN,将IPv4协议报文划分到VLAN 3中传输。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] protocol-vlan ipv4

注意

由于IP协议与ARP协议关系密切,建议用户将IPv4协议和ARP协议绑定到同一VLAN,并且关联到相同的端口,避免因ARP报文与IP报文未划分到同一VLAN,而造成无法正常通信的情况。

 

# 为VLAN 3配置ARP协议模板(ARP协议的协议代码为0x0806),将ARP协议报文划分到VLAN 3中传输。

·     当使用以太网封装时,请按下面的命令进行配置。

[Sysname-vlan3] protocol-vlan mode ethernetii etype 0806

·     当使用802.3封装格式时,请按下面的命令进行配置

[Sysname-vlan3] protocol-vlan mode snap etype 0806

1.5  基于IP子网的VLAN配置命令

1.5.1  display ip-subnet-vlan interface

【命令】

display ip-subnet-vlan interface { interface-type interface-number1 [ to interface-type interface-number2 ] | all } [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

2:系统级

【参数】

interface-type interface-number1:需要显示的接口的类型和编号。

interface-type interface-number1 to interface-type interface-number2:需要显示的接口的类型和范围。

all:显示所有配置了基于子网VLAN的端口的IP子网信息。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display ip-subnet-vlan interface命令用于显示指定端口上所配置的IP子网VLAN信息以及IP子网的索引。

【举例】

# 显示端口GigabitEthernet1/0/1上所配置的IP子网VLAN信息及IP子网的索引。

<Sysname> system-view

[Sysname] display ip-subnet-vlan interface ethernet1/1

Interface: GigabitEthernet1/0/1

  VLAN ID   Subnet-Index    IP ADDRESS        NET MASK

  =======================================================

     3           0         192.168.1.0    255.255.255.0

表1-7 display ip-subnet-vlan interface命令显示信息描述表

字段

描述

Interface

当前查看的端口

VLAN ID

子网VLAN的编号

Subnet-Index

IP子网的索引

IP ADDRESS

IP子网的地址(可以是IP地址或网络地址)

NET MASK

IP子网的掩码

 

1.5.2  display ip-subnet-vlan vlan

【命令】

display ip-subnet-vlan vlan { vlan-id1 [ to vlan-id2 ] | all } [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

2:系统级

【参数】

vlan-id1:VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:指定VLAN的编号范围。vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4094,vlan-id2的值要大于或等于vlan-id1的值。

all:显示所有VLAN的IP子网信息。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display ip-subnet-vlan vlan命令用于显示指定VLAN上配置的IP子网VLAN信息及IP子网的索引。

相关配置可参考命令display vlan

【举例】

# 显示当前系统中所有IP子网VLAN信息以及IP子网的索引。

<Sysname> display ip-subnet-vlan vlan all

VLAN ID:  3

 Subnet Index      IP Address      Subnet Mask

 ====================================================

       0          192.168.1.0    255.255.255.0

表1-8 display ip-subnet-vlan vlan命令显示信息描述表

字段

描述

VLAN ID

子网VLAN的编号

Subnet Index

IP子网的索引

IP Address

IP子网的地址(可以是IP地址或网络地址)

Subnet Mask

IP子网的掩码

 

1.5.3  ip-subnet-vlan

【命令】

ip-subnet-vlan [ ip-subnet-index ] ip ip-address [ mask ]

undo ip-subnet-vlan { ip-subnet-index [ to ip-subnet-end ] | all }

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

ip-subnet-index:IP子网索引值,取值范围为0~11。子网索引可以由用户指定,也可由系统根据IP子网或IP地址与VLAN关联的先后顺序自动编号产生。

ip ip-address [ mask ]:作为子网VLAN划分依据的源IP地址或网络地址,ip-address表示源IP地址或网络地址,采用点分十进制格式;mask表示子网掩码,采用点分十进制格式,缺省值为255.255.255.0。

to:IP子网索引的范围。

ip-subnet-end:IP子网索引的终止值,取值范围为0~11,其值必须大于等于ip-subnet-index的值。

all:取消所有VLAN与指定的IP子网或IP地址的关联。

【描述】

ip-subnet-vlan命令用来配置当前VLAN与指定的IP子网或IP地址关联。undo ip-subnet-vlan命令用于取消该关联。

需要注意的是,配置的IP网段或IP地址不能是组播网段或组播地址。

相关配置可参考命令display ip-subnet-vlan vlan

【举例】

# 将VLAN 3配置为基于IP子网的VLAN,与192.168.1.0/24网段进行关联,使得源地址为该网段的报文可以分发到VLAN 3中传输。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] ip-subnet-vlan ip 192.168.1.0 255.255.255.0

1.5.4  port hybrid ip-subnet-vlan

【命令】

port hybrid ip-subnet-vlan vlan vlan-id

undo port hybrid ip-subnet-vlan { vlan vlan-id | all }

【视图】

二层以太网端口视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan vlan-id:VLAN的编号,取值范围为1~4094。

all:所有VLAN。

【描述】

port hybrid ip-subnet-vlan命令用来设置当前以太网端口和指定的基于IP子网的VLAN相关联。undo port hybrid ip-subnet-vlan命令用于取消端口与基于IP子网VLAN的关联。

端口和基于IP子网的VLAN关联后,端口收到untagged报文后会跟据报文的源IP地址去判断该地址是否属于某个子网的地址,如果属于,则将相应的VLAN标签添加到报文头中。

需要注意的是:

·     二层以太网端口视图下的配置只对当前端口生效;二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

·     端口必须是Hybrid类型。端口在与基于IP子网的VLAN进行关联之前,必须已经允许该VLAN通过,否则不允许进行关联。

相关配置可参考命令display ip-subnet-vlan interface

【举例】

# 将端口GigabitEthernet1/0/1与IP子网VLAN 3相关联。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] ip-subnet-vlan ip 192.168.1.0 255.255.255.0

[Sysname-vlan3] quit

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type hybrid

[Sysname-GigabitEthernet1/0/1] port hybrid vlan 3 untagged

 Please wait... Done.

[Sysname-GigabitEthernet1/0/1] port hybrid ip-subnet-vlan vlan 3

# 把二层聚合接口1(Hybrid类型)与协议VLAN 2中的协议0相关联。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] ip-subnet-vlan ip 192.168.1.0 255.255.255.0

[Sysname-vlan3] quit

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type hybrid

[Sysname-Bridge-Aggregation1] port hybrid vlan 3 untagged

 Please wait... Done

 Configuring GigabitEthernet1/0/1... Done.

 Configuring GigabitEthernet1/0/2... Done.

 Configuring GigabitEthernet1/0/3... Done.

[Sysname-Bridge-Aggregation1] port hybrid ip-subnet-vlan vlan 3

接口GigabitEthernet1/0/1、GigabitEthernet1/0/2和GigabitEthernet1/0/3是二层聚合接口1的成员端口。


2 Isolate-user-VLAN

2.1  Isolate-user-VLAN配置命令

2.1.1  display isolate-user-vlan

【命令】

display isolate-user-vlan [ isolate-user-vlan-id ] [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

isolate-user-vlan-id:Isolate-user-VLAN的编号,取值范围为1~4094。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display isolate-user-vlan命令用来显示Isolate-user-VLAN和Secondary VLAN的映射信息。

相关配置可参考命令isolate-user-vlan enableisolate-user-vlan

【举例】

# 显示isolate-user-vlan和Secondary VLAN的映射关系。

<Sysname> display isolate-user-vlan

 Isolate-user-VLAN VLAN ID : 2

 Secondary VLAN ID : 3 4

 

 VLAN ID: 2

 VLAN Type: static

 Isolate-user-VLAN type : isolate-user-VLAN

 Route Interface: configured

 IP Address: 1.1.1.1

 Subnet Mask: 255.255.255.0

 Description: VLAN 0002

 Name: VLAN 0002

 Tagged   Ports: none

 Untagged Ports:

    GigabitEthernet1/0/2            GigabitEthernet1/0/3            GigabitEthernet1/0/4

 

 VLAN ID: 3

 VLAN Type: static

 Isolate-user-VLAN type : secondary

Route Interface: not configured

 Description: VLAN 0003

 Name: VLAN 0003

 Tagged   Ports: none

 Untagged Ports:

    GigabitEthernet1/0/2            GigabitEthernet1/0/3

 

 VLAN ID: 4

 VLAN Type: static

 Isolate-user-VLAN type : secondary

 Route Interface: not configured

 Description: VLAN 0004

 Name: VLAN 0004

 Tagged   Ports: none

 Untagged Ports:

   GigabitEthernet1/0/2            GigabitEthernet1/0/4

表2-1 display isolate-user-vlan命令显示信息描述表

字段

描述

Isolate-user-VLAN VLAN ID

Isolate-user-VLAN的编号

Secondary VLAN ID

Secondary VLAN的编号

VLAN ID

VLAN编号

VLAN Type

VLAN类型(静态VLAN、动态VLAN等)

Isolate-user-VLAN type

当前VLAN类型(Isolate-user-VLAN或者Secondary VLAN)

Route Interface

VLAN是否配置了VLAN接口:not configured(没有配置)/configured(配置了)

IP Address

VLAN接口的IP地址(如果VLAN接口没有配置IP地址,则不显示该字段)

Subnet Mask

VLAN接口的子网掩码(如果VLAN接口没有配置IP地址,则不显示该字段)

Description

VLAN的描述

Name

VLAN的名称

Tagged   Ports

标识该VLAN报文在哪些端口上需要打Tag标记

Untagged Ports

标识该VLAN报文在哪些端口上不需要打Tag标记

 

2.1.2  isolate-user-vlan

【命令】

isolate-user-vlan isolate-user-vlan-id secondary secondary-vlan-id [ to secondary-vlan-id ]

undo isolate-user-vlan isolate-user-vlan-id [ secondary secondary-vlan-id [ to secondary-vlan-id ] ]

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

isolate-user-vlan-id:Isolate-user-VLAN的编号,取值范围为1~4094。其中,VLAN 1虽然在取值范围中,但不能配置。

secondary secondary-vlan-id [ to secondary-vlan-id ]:指定Secondary VLAN的编号或编号范围,secondary-vlan-id表示Secondary VLAN的编号,取值范围为1~4094。其中,VLAN 1虽然在取值范围中,但不能配置。

【描述】

isolate-user-vlan命令用来建立Isolate-user-VLAN和Secondary VLAN间的映射关系。undo isolate-user-vlan用来取消Isolate-user-VLAN和Secondary VLAN间的映射关系。

缺省情况下,用户创建的Isolate-user-VLAN和Secondary VLAN没有任何映射关系。

需要注意的是, undo isolate-user-vlan命令如果不带参数secondary secondary-vlan-id,就解除所有Secondary VLAN和指定Isolate-user-VLAN的映射关系;如果带有该参数,就解除参数指定的Secondary VLAN和指定Isolate-user-VLAN的映射关系。

相关配置可参考命令display isolate-user-vlan

【举例】

# 将Isolate-user-VLAN 2和Secondary VLAN 3、4关联。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] isolate-user-vlan enable

[Sysname-vlan2] port gigabitethernet 1/0/2

[Sysname-vlan2] vlan 3

[Sysname-vlan3] port gigabitethernet 1/0/3

[Sysname-vlan3] vlan 4

[Sysname-vlan4] port gigabitethernet 1/0/4

[Sysname-vlan4] quit

[Sysname] isolate-user-vlan 2 secondary 3 to 4

2.1.3  isolate-user-vlan enable

【命令】

isolate-user-vlan enable

undo isolate-user-vlan enable

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

【描述】

isolate-user-vlan enable命令用来设置一个VLAN的类型为Isolate-user-VLAN。undo isolate-user-vlan enable命令用来取消一个VLAN为Isolate-user-VLAN类型的设置。

缺省情况下,用户创建的VLAN不是Isolate-user-VLAN类型的VLAN。

需要注意的是,Isolate-user-VLAN中可以包含多个端口,包括与上行设备相连的端口。

相关配置可参考命令display isolate-user-vlan

【举例】

# 将VLAN 5配置为Isolate-user-VLAN。

<Sysname> system-view

[Sysname] vlan 5

[Sysname-vlan5] isolate-user-vlan enable

2.1.4  isolated-vlan enable

【命令】

isolated-vlan enable

undo isolated-vlan enable

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

【描述】

isolated-vlan enable命令用来设置同一Secondary VLAN内各端口二层隔离。undo isolated-vlan enable命令用来恢复缺省情况。

缺省情况下,同一Secondary VLAN内的端口能够二层互通。

需要注意的是:

·     在VLAN的视图下配置isolated-vlan enable命令后,该VLAN的所有成员端口都不能加入隔离组。

·     当同一Secondary VLAN内各端口的工作模式均为host模式,且Isolate-user-VLAN与Secondary VLAN之间建立映射关系后,isolated-vlan enable命令才生效。

相关配置可参考命令isolate-user-vlan

【举例】

# 设置Secondary VLAN 4内各端口二层互相隔离(GigabitEthernet 1/0/1为上行端口,GigabitEthernet 1/0/2、GigabitEthernet 1/0/3为下行端口)。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] isolate-user-vlan enable

[Sysname-vlan2] quit

[Sysname] vlan 4

[Sysname-vlan4] quit

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port isolate-user-vlan 2 promiscuous

[Sysname-GigabitEthernet1/0/1] quit

[Sysname] interface gigabitethernet 1/0/2

[Sysname-GigabitEthernet1/0/2] port access vlan 4

[Sysname-GigabitEthernet1/0/2] port isolate-user-vlan host

[Sysname-GigabitEthernet1/0/2] quit

[Sysname] interface gigabitethernet 1/0/3

[Sysname-GigabitEthernet1/0/3] port access vlan 4

[Sysname-GigabitEthernet1/0/3] port isolate-user-vlan host

[Sysname-GigabitEthernet1/0/3] quit

[Sysname] isolate-user-vlan 2 secondary 4

[Sysname] vlan 4

[Sysname-vlan4] isolated-vlan enable

2.1.5  port isolate-user-vlan promiscuous

【命令】

port isolate-user-vlan vlan-id promiscuous

undo port isolate-user-vlan

【视图】

二层以太网端口视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:VLAN的编号,取值范围为2~4094。

【描述】

port isolate-user-vlan vlan-id promiscuous命令用来配置在指定VLAN中,端口工作在promiscuous模式。undo port isolate-user-vlan命令用来配置在指定VLAN中,端口工作在缺省状态。

缺省情况下,端口既不工作在promiscuous模式也不工作在host模式。

(1)     配置port isolate-user-vlan vlan-id promiscuous命令时,需要注意的是:

在配置指定VLAN中端口采用promiscuous模式的同时,端口会自动加入指定VLAN:

·     此时若指定VLAN的类型已经配置为Isolate-user-VLAN,且存在与之有映射关系的Secondary VLAN,则该端口也会同步加入这些Secondary VLAN。

·     此时若指定VLAN的类型还未配置为Isolate-user-VLAN,则等指定VLAN的类型配置为Isolate-user-VLAN且配置了与其对应的Secondary VLAN后,该端口将自动加入这些Secondary VLAN。

在端口自动加入指定VLAN或与指定VLAN关联的Secondary VLAN时:

·     若当前端口的链路类型为Access类型,指定VLAN的类型已经配置为Isolate-user-VLAN,且存在与之有映射关系的Secondary VLAN,则系统会自动将当前端口的链路类型改为Hybrid类型,并将端口的缺省VLAN改为指定VLAN。

·     若当前端口的链路类型为Access类型,指定VLAN的类型还未配置为Isolate-user-VLAN,则等指定VLAN的类型配置为Isolate-user-VLAN且配置了与其对应的Secondary VLAN后,系统会自动将该端口的链路类型改为Hybrid类型,并将该端口的缺省VLAN改为指定VLAN。

·     若当前端口的链路类型为Trunk/Hybrid类型,则该端口的链路类型及缺省VLAN均保持不变。

在端口自动加入指定VLAN或与指定VLAN关联的Secondary VLAN时,当端口的链路类型为Hybrid后,若当前端口曾以Tagged方式加入其中某些VLAN中:

·     则这些VLAN中该端口将仍以Tagged方式加入。

·     其余VLAN中端口将以Untagged方式加入。

(2)     配置undo port isolate-user-vlan命令时,需要注意的是:

·     在配置指定VLAN中端口退出promiscuous模式的同时,若端口的链路类型为Access类型,则端口加入指定VLAN的配置不做改变;若端口的链路类型为Trunk/Hybrid类型,则取消端口加入指定VLAN的配置。

·     此时若指定VLAN的类型已经配置为Isolate-user-VLAN,且存在与之有映射关系的Secondary VLAN,则该端口依旧存在于这些Secondary VLAN中。

注意

·     建议将加入isolate-user-vlan的端口的链路类型配置为Access类型或Hybrid类型。

·     在执行port isolate-user-vlan vlan-id promiscuous命令时,若端口已配置在某指定VLAN中工作在promiscuous模式,则系统会自动先执行undo port isolate-user-vlan命令,再执行port isolate-user-vlan vlan-id promiscuous命令。

 

【举例】

# VLAN 2的类型为Isolate-user-VLAN,且VLAN 2和Secondary VLAN 20关联,配置链路类型为Access的端口GigabitEthernet1/0/1在VLAN 2中工作在promiscuous模式,然后取消该配置。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] display this

#

interface GigabitEthernet1/0/1

 port link-mode bridge

#

return

[Sysname-GigabitEthernet1/0/1] port isolate-user-vlan 2 promiscuous

[Sysname-GigabitEthernet1/0/1] display this

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port isolate-user-vlan 2 promiscuous

 port link-type hybrid

 undo port hybrid vlan 1

 port hybrid vlan 2 20 untagged

 port hybrid pvid vlan 2

#

return

[Sysname-GigabitEthernet1/0/1] undo port isolate-user-vlan

[Sysname-GigabitEthernet1/0/1] display this

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port link-type hybrid

 undo port hybrid vlan 1

 port hybrid vlan 20 untagged

 port hybrid pvid vlan 2

#

return

# VLAN 10的类型不为Isolate-user-VLAN。配置链路类型为Access的端口GigabitEthernet1/0/1VLAN 10中工作在promiscuous模式,然后取消该配置。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] display this

#

interface GigabitEthernet1/0/1

 port link-mode bridge

#

return

[Sysname-GigabitEthernet1/0/1] port isolate-user-vlan 10 promiscuous

[Sysname-GigabitEthernet1/0/1] display this

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port isolate-user-vlan 10 promiscuous

 port access vlan 10

#

return

[Sysname-GigabitEthernet1/0/1] undo port isolate-user-vlan

[Sysname-GigabitEthernet1/0/1] display this

#

interface GigabitEthernet1/0/1

port link-mode bridge

port access vlan 10

#

Return

2.1.6  port isolate-user-vlan host

【命令】

port isolate-user-vlan host

undo port isolate-user-vlan

【视图】

二层以太网端口视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

【描述】

port isolate-user-vlan host命令用来配置端口工作在host模式。undo port isolate-user-vlan命令用来配置端口工作在缺省状态。

缺省情况下,端口既不工作在promiscuous模式也不工作在host模式。

(1)     配置port isolate-user-vlan host命令时,需要注意的是:

配置Isolate-user-VLAN和Secondary VLAN间的映射关系后,在配置端口采用host模式的同时:

·     此时若已配置端口加入Secondary VLAN,则该端口也会同步加入Secondary VLAN对应的Isolate-user-VLAN。

·     此时若还未配置端口加入Secondary VLAN,则等配置端口加入Secondary VLAN后,该端口将自动加入Secondary VLAN对应的Isolate-user-VLAN。

在端口自动加入Secondary VLAN对应的Isolate-user-VLAN时:

·     若当前端口的链路类型为Access类型,则系统会自动将端口的链路类型改为Hybrid类型,缺省VLAN改为端口加入的Secondary VLAN。

·     若当前端口的链路类型为Trunk/Hybrid类型,则端口的链路类型及缺省VLAN均保持不变。

在端口自动加入Secondary VLAN对应的Isolate-user-VLAN时,当端口的链路类型为Hybrid后:

·     若当前端口曾以Tagged方式加入Secondary VLAN对应的Isolate-user-VLAN中,则端口仍以Tagged方式加入Isolate-user-VLAN。

·     否则端口以Untagged方式加入Isolate-user-VLAN。

(2)     配置undo port isolate-user-vlan命令时,需要注意的是:

端口退出host模式时,端口同步加入对应的Isolate-user-VLAN的配置保持不变。

注意

加入Secondary VLAN的端口的链路类型不能为Trunk类型。

 

【举例】

# VLAN 20的类型为Secondary VLAN,且VLAN 20和Isolate-user-VLAN 2关联。配置链路类型为Access的端口 GigabitEthernet1/0/1工作在host模式,将端口GigabitEthernet1/0/1加入VLAN 20。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port isolate-user-vlan host

[Sysname-GigabitEthernet1/0/1] display this

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port isolate-user-vlan host

#

return

[Sysname-GigabitEthernet1/0/1] port access vlan 20

[Sysname-GigabitEthernet1/0/1] display this

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port isolate-user-vlan host

 port link-type hybrid

 undo port hybrid vlan 1

 port hybrid vlan 2 20 untagged

 port hybrid pvid vlan 20

#

return

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!