选择区域语言: EN CN HK

二层技术-以太网交换命令参考

04-VLAN命令

本章节下载  (198.38 KB)

docurl=/cn/Service/Document_Software/Document_Center/Wlan/WA/WA1208E/Command/Command_Manual/H3C_WA_CR-6W101/03/201205/745607_30005_0.htm

04-VLAN命令


l          不同型号产品的特性功能支持情况略有不同,详细请参见“特性差异化列表” 部分的介绍。

l          设备支持的接口类型和编号与设备的实际情况相关,本手册涉及以太网接口的配置举例统一使用Eth口举例说明。实际使用中请根据具体设备的接口类型和编号进行配置。

 

1 VLAN配置命令

1.1  VLAN配置命令

1.1.1  description

【命令】

description text

undo description

【视图】

VLAN视图/VLAN接口视图

【缺省级别】

2:系统级

【参数】

text:描述VLAN或VLAN接口的描述字符串,可支持的描述字符包括英文可以包含标准字符(区分大小写的字母、数字)、英文特殊字符、空格、以及符合unicode编码规范的其他文字和符号。VLAN和VLAN接口的描述字符串的取值范围分别为:

l              VLAN的描述信息为1~32个字符的字符串。

l              VLAN接口的描述信息为1~80个字符的字符串。

l          一个英文字符占用一个字符长度,一个unicode编码的字符占用两个字符长度,用户可以在描述字符串中混合输入英文字符和unicode字符,但字符串总长度不能超过规定的长度范围。

l          如果用户在设置描述字符时需要使用unicode编码的某种文字或符号,则必须具有相应的输入法软件,并使用支持该字符的远程登录软件登录到设备上进行配置。

l          一个unicode编码的字符占用两个字符长度,所以当所配置的描述信息长度达到或超过终端软件最大列宽时,终端软件会进行自动换行,此时可能导致unicode字符被截断,终端软件会在换行处之后显示乱码。

 

【描述】

description命令用来设定当前VLAN或VLAN接口的描述信息。undo description命令用来恢复缺省情况。

缺省情况下,VLAN的描述信息为该VLAN的VLAN ID,如“VLAN 0001”,VLAN接口的描述信息为该VLAN接口的接口名,如“Vlan-interface1 Interface”。

当设备上配置的VLAN较多时,用户可以根据功能或者连接情况为VLAN或VLAN接口设置特定的描述信息,以便记忆和管理VLAN或VLAN接口。

【举例】

# 将VLAN2的描述信息配置为sales-private。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] description sales-private

# 将VLAN接口2的描述信息配置为linktoPC56。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] description linktoPC56

1.1.2  display interface vlan-interface

【命令】

display interface vlan-interface [ vlan-interface-id ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

vlan-interface-id:VLAN接口的编号。

【描述】

display interface vlan-interface命令用来显示VLAN接口的相关信息。

如果指定了vlan-interface-id,则显示指定VLAN接口的信息;如果不指定,将显示已创建的所有VLAN接口的信息。

相关配置可参考命令interface vlan-interface

【举例】

# 显示VLAN-interface 2的相关信息。

<Sysname> display interface vlan-interface 2

Vlan-interface2 current state: DOWN

Line protocol current state: DOWN

Description: Vlan-interface2 Interface

The Maximum Transmit Unit is 1500

Internet protocol processing : disabled

IP Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 000f-e249-8050

Last clearing of counters:  Never

表1-1 display interface vlan-interface命令显示信息描述表

字段

描述

Vlan-interface2 current state

VLAN接口的物理状态,状态可能为:

l      Administratively DOWN:表示该VLAN接口已经通过shutdown命令被关闭,即管理状态为关闭

l      DOWN:该VLAN接口的管理状态为开启,但物理状态为关闭,即该接口对应的VLAN内没有处于UP状态的端口(可能因为没有连接好或者线路故障)

l      UP:该端口的管理状态和物理状态均为开启

Line protocol current state

VLAN接口的链路层协议状态,状态可能为:

l      DOWN:该VLAN接口的协议状态为关闭,通常是因为没有配置IP地址

l      UP:该VLAN接口的协议状态为开启

Description

VLAN接口的字符串描述

The Maximum Transmit Unit

VLAN接口允许通过的最大传输单元(MTU)

Internet protocol processing :

对IP报文的处理能力,disabled表示没有为该接口配置IP地址

IP Packet Frame Type

IPv4发送帧格式

Hardware address

VLAN接口对应的MAC地址

Last clearing of counters

最后一次清除计数器的时间

 

1.1.3  display vlan

【命令】

display vlan [ vlan-id1 [ to vlan-id2 ] | all | dynamic | static ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

vlan-id1:显示指定VLAN的信息。vlan-id1为指定VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:显示ID在指定范围内的VLAN的信息。vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4094。

all:显示所有VLAN的信息。

dynamic:显示系统动态创建的VLAN的数量和编号。动态VLAN是指通过GVRP协议生成或通过Radius服务器下发的VLAN。

static:显示系统静态创建的VLAN的数量和VLAN编号。静态VLAN是指通过命令行手工创建的VLAN。

【描述】

display vlan命令用来显示VLAN的相关信息。

相关配置可参考命令vlan

【举例】

# 显示VLAN2的信息。

<Sysname> display vlan 2

 VLAN ID: 2

 VLAN Type: static

 Route Interface: configured

 IP Address: 10.1.0.5

 Subnet Mask: 255.255.255.0

 Description: VLAN 0002

 Name: V2

 Tagged   Ports: none

 Untagged Ports: none

表1-2 display vlan命令显示信息描述表

字段

解释

VLAN ID

VLAN的编号

VLAN Type

VLAN的类型:static表示静态VLAN;dynamic表示动态VLAN

Route interface

设备上是否创建了对应的VLAN接口:not configured(没有创建)/configured(创建了)

IP Address

VLAN接口的主用IP地址(如果VLAN接口没有配置IP地址,则不显示该字段),如果VLAN接口上还配置了从IP地址,可以使用display interface vlan-interface或者在VLAN接口视图下使用display this命令查看

Subnet Mask

VLAN接口的主用IP地址的子网掩码(如果VLAN接口没有配置IP地址,则不显示该字段)

Description

VLAN的描述信息

Name

VLAN的名称

Tagged Ports

标识该VLAN报文从哪些端口发送时需要携带Tag标记

Untagged Ports

标识该VLAN报文从哪些端口发送时不需要携带Tag标记

 

1.1.4  name

【命令】

name text

undo name

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

text:VLAN名称,为1~32个字符的描述信息(可以包含特殊字符及空格)。

【描述】

name命令用来指定当前VLAN的名称。当交换机上配置了802.1X或MAC地址认证功能后,可以通过Radius服务器来对认证通过的端口下发VLAN。某些服务器可以向交换机发送需要下发的VLAN编号或者VLAN名称,当VLAN数量很多的时候,使用名称可以更明确的定位VLAN。undo name命令用来恢复当前VLAN名称的缺省值。

缺省情况下,VLAN的名称为该VLAN的VLAN ID,如“VLAN 0001”。

【举例】

# 指定VLAN 2的名称为“test vlan”。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] name test vlan

1.1.5  interface vlan-interface

【命令】

interface vlan-interface vlan-interface-id

undo interface vlan-interface vlan-interface-id

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

vlan-interface-id:VLAN接口的编号,取值范围为1~4094。

【描述】

interface vlan-interface命令用来进入指定的VLAN接口视图。如果该VLAN接口不存在,则先创建该接口,再进入该VLAN接口视图。undo interface vlan-interface命令用来删除指定的VLAN接口。

需要注意的是:在创建VLAN接口之前,对应的VLAN必须已经创建。否则,将不能创建指定的VLAN接口。

用户可以在VLAN接口视图下使用ip address命令配置IP地址,使得设备具有三层路由功能。

相关配置可参考命令display interface vlan-interface

【举例】

# 创建VLAN接口2。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2]

1.1.6  ip address

【命令】

ip address ip-address { mask | mask-length } [ sub ]

undo ip address [ ip-address { mask | mask-length } [ sub ] ]

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

ip-address:VLAN接口的IP地址,为点分十进制格式。

mask:子网掩码,为点分十进制格式。

mask-length:子网掩码长度,即子网掩码中“1”的个数,取值范围为0~32。

sub:表示该地址为VLAN接口的从IP地址。

【描述】

ip address命令用来给VLAN接口指定IP地址和掩码。undo ip address命令用来删除VLAN接口的IP地址和掩码。

缺省情况下,没有配置VLAN接口的IP地址。

一般情况下,一个接口配置一个IP地址即可,但为了使设备的一个VLAN可以与多个子网相连,VLAN接口可以配置多个IP地址,其中一个为主IP地址,其余为从IP地址,目前设备支持的可配置的IP地址总数为2。主从地址的配置关系为:

l              当配置主IP地址时,如果接口上已经有主IP地址,则原主IP地址被新配置的地址取代。

l              undo ip address命令不带任何参数表示删除该接口的所有IP地址。

l              undo ip address ip-address { mask | mask-length }表示删除主IP地址。

l              undo ip address ip-address { mask | mask-length } sub表示删除从IP地址。

l              在删除主IP地址之前必须先删除从IP地址。

相关配置可参考“三层技术-IP业务命令参考/IP地址”中的命令display ip interface

【举例】

# 指定VLAN接口1的IP地址为1.1.0.1,子网掩码为255.255.255.0。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] ip address 1.1.0.1 255.255.255.0

1.1.7  shutdown

【命令】

shutdown

undo shutdown

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

【描述】

shutdown命令用来关闭VLAN接口。undo shutdown命令用来打开VLAN接口。

缺省情况下,当VLAN接口下所有端口状态为down时,VLAN接口为down状态,即关闭状态;当VLAN接口下有一个或一个以上的端口处于up状态,则VLAN接口处于up状态。

当VLAN接口的相关参数及协议配置好之后,可以使用undo shutdown命令启动接口;或者当VLAN接口出现故障时,可以用shutdown命令将接口先关闭,然后再用undo shutdown命令打开接口,这样有可能使接口恢复正常。

关闭和打开VLAN接口对于属于这个VLAN的任何端口本身都不起作用,端口的状态不随VLAN接口状态的改变而改变。

【举例】

# 关闭VLAN接口后再启动VLAN接口。

<Sysname> system-view

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] shutdown

[Sysname-Vlan-interface2] undo shutdown

1.1.8  vlan

【命令】

vlan { vlan-id1 [ to vlan-id2 ]}

undo vlan { vlan-id1 [ to vlan-id2 ]}

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

vlan-id1:VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:指定VLAN的编号范围。vlan-id1vlan-id2为VLAN的编号,取值范围为1~4094。

 

【描述】

vlan vlan-id命令用来创建VLAN并进入VLAN视图。如果指定的VLAN已创建,则该命令直接用来进入该VLAN的视图。

vlan vlan-id1 to vlan-id2命令用来批量创建vlan-id1vlan-id2之间的所有VLAN。

undo vlan命令用来删除VLAN。

需要注意的是,VLAN1为系统缺省VLAN,用户不能创建和删除。

相关配置可参考命令display vlan

【举例】

# 进入VLAN2的视图。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2]

# 批量创建VLAN4~VLAN100。

<Sysname> system-view

[Sysname] vlan 4 to 100

Please wait............. Done.

1.2  基于端口的VLAN配置命令

1.2.1  display port

【命令】

display port { hybrid | trunk }

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

hybrid:显示系统当前存在的Hybrid端口。

trunk:显示系统当前存在的Trunk端口。

【描述】

display port命令用来显示设备上当前存在的Hybrid或Trunk端口。显示的信息包括端口对应的端口名、缺省VLAN ID和允许通过的VLAN ID号。

【举例】

# 显示当前系统存在的Hybrid端口。

<Sysname> display port hybrid

Interface            PVID  VLAN passing

Eth1/0/1             100   Tagged:  1000, 1002, 1500, 1600-1611, 2000,

                                    2555-2558, 3000, 4000

                           Untagged:1, 10, 15, 18, 20-30, 44, 55, 67, 100,

                                    150-160, 200, 255, 286, 300-302

表1-3 display port命令显示信息描述表

字段

描述

Interface

接口名称

PVID

该端口的缺省VLAN ID

VLAN passing

表示哪些VLAN的报文允许通过该端口

Tagged

表示哪些VLAN的报文通过该端口时必须携带VLAN Tag

Untagged

表示哪些VLAN的报文通过该端口时必须去掉VLAN Tag

 

1.2.2  port

【命令】

port interface-list

undo port interface-list

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

interface-list:以太网接口列表,表示方式为interface-list = { interface-type interface-number [ to interface-type interface-number ] }&<1-10>。其中interface-type interface-number为端口类型和端口号,&<1-10>表示前面的参数最多可以输入10次。

【描述】

port命令用来向当前VLAN中添加一个或一组Access端口。undo port命令用来从当前VLAN中删除一个或一组Access端口。

缺省情况下,系统将所有端口都加入到VLAN1。

需要注意的是:

l              该命令只对Access端口有效。

l              设备上的所有端口的缺省链路类型都是Access类型,但用户可以自行切换端口类型,具体配置可参考命令port link-type

相关配置可参考命令display vlan

【举例】

# 向VLAN2中加入从Ethernet1/0/1到Ethernet1/0/2的以太网端口。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] port ethernet 1/0/1 to ethernet 1/0/2

1.2.3  port access vlan

【命令】

port access vlan vlan-id

undo port access vlan

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定的VLAN编号,取值范围为1~4094。该VLAN必须是设备上已创建的VLAN,否则,该命令执行失败。

【描述】

port access vlan命令用来将当前Access端口加入到指定的VLAN中。undo port access vlan命令用来恢复缺省情况。

缺省情况下,所有Access端口均属于且只属于VLAN1。

【举例】

# 将Ethernet1/0/1端口加入到VLAN3中。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] quit

[Sysname] interface ethernet 1/0/1

[Sysname-Ethernet1/0/1] port access vlan 3

1.2.4  port hybrid pvid vlan

【命令】

port hybrid pvid vlan vlan-id

undo port hybrid pvid

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定接口的缺省的VLAN ID,取值范围为1~4094。

【描述】

port hybrid pvid vlan命令用来设置Hybrid端口的缺省VLAN ID。undo port hybrid pvid命令用来恢复缺省情况。

缺省情况下,Hybrid端口的缺省VLAN为VLAN1。

对Hybrid端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即可以使用已经不存在的VLAN作为缺省VLAN。

需要注意的是:

l              建议本机Hybrid端口的缺省VLAN和相连的对端设备的Hybrid端口的缺省VLAN保持一致。

l              配置缺省VLAN后,必须使用port hybrid vlan命令配置允许缺省VLAN的报文通过,出接口才能转发缺省VLAN的报文。

相关配置可参考命令port link-typeport hybrid vlan

【举例】

# 将端口Ethernet1/0/1(Hybrid类型)的缺省VLAN设为100。

<Sysname> system-view

[Sysname] vlan 100

[Sysname-vlan100] quit

[Sysname] interface ethernet 1/0/1

[Sysname-Ethernet1/0/1] port link-type hybrid tagged 100

[Sysname-Ethernet1/0/1] port hybrid pvid vlan 100

1.2.5  port hybrid vlan

【命令】

port hybrid vlan vlan-id-list { tagged | untagged }

undo port hybrid vlan vlan-id-list

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

vlan-id-list:VLAN列表,Hybrid端口要加入的VLAN的范围。表示方式为vlan-id-list = { vlan-id1 [ to vlan-id2 ] }&<1-10>,vlan-id取值范围为1~4094,&<1-10>表示前面的参数最多可以重复输入10次。该VLAN必须是设备上已创建的VLAN,否则,该命令执行失败。

tagged:该端口在转发指定的VLAN报文时将保留VLAN Tag。

untagged:该端口在转发指定的VLAN报文时将去掉VLAN Tag。

【描述】

port hybrid vlan命令用来允许指定的VLAN通过当前Hybrid端口。undo port hybrid vlan命令用来取消指定的VLAN通过当前Hybrid端口。

缺省情况下,Hybrid端口只允许VLAN1的报文以untagged方式通过,即VLAN1的报文从该端口发送出去后不携带VLAN Tag。

Hybrid端口允许多个VLAN通过。如果多次使用port hybrid vlan命令,那么Hybrid端口上允许通过的VLAN是这些vlan-id-list的合集。

相关配置可参考命令port link-type

【举例】

# 配置端口Ethernet1/0/1(Hybrid类型)允许VLAN2、VLAN4、VLAN50~VLAN100通过(假设指定的VLAN都已经创建),并且发送这些VLAN的报文时保留VLAN标签。

<Sysname> system-view

[Sysname] interface ethernet 1/0/1

[Sysname-Ethernet1/0/1] port link-type hybrid

[Sysname-Ethernet1/0/1] port hybrid vlan 2 4 50 to 100 tagged

1.2.6  port link-type

【命令】

port link-type { access | hybrid | trunk }

undo port link-type

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

access:设置端口的链路类型为Access类型。

hybrid:设置端口的链路类型为Hybrid类型。

trunk:设置端口的链路类型为Trunk类型。

【描述】

port link-type命令用来设置端口的链路类型。undo port link-type命令用来恢复缺省情况。

缺省情况下,所有端口的链路类型均为Access类型。

Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其它类型端口。

 

【举例】

# 将以太网端口Ethernet1/0/1设置为Trunk类型端口。

<Sysname> system-view

[Sysname] interface ethernet 1/0/1

[Sysname-Ethernet1/0/1] port link-type trunk

1.2.7  port trunk permit vlan

【命令】

port trunk permit vlan { vlan-id-list | all }

undo port trunk permit vlan { vlan-id-list | all }

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

vlan-id-list:VLAN列表,为Trunk端口加入的VLAN的范围,表示方式为vlan-id-list = { vlan-id1 [ to vlan-id2 ] }& <1-10>,vlan-id取值范围为1~4094,&<1-10>表示前面的参数最多可以重复输入10次。

all:表示允许所有VLAN通过该Trunk端口,该参数通常只用于GVRP的配置。在没有配置GVRP的情况下,建议用户不要使用port trunk permit all命令,以防止未授权VLAN的用户通过该端口访问受限资源。

【描述】

port trunk permit vlan命令用来允许指定的VLAN通过当前Trunk端口。undo port trunk permit vlan命令用来取消指定的VLAN通过当前Trunk端口。

缺省情况下,Trunk端口只允许VLAN1的报文通过。

Trunk端口可以允许多个VLAN通过。如果多次使用port trunk permit vlan命令,那么Trunk端口上允许通过的VLAN是这些vlan-id-list的集合。

Trunk端口发送出去的报文,只有缺省VLAN的报文不带VLAN Tag,其他VLAN的报文均会保留VLAN Tag。

相关配置可参考命令port link-type

【举例】

# 配置端口Ethernet1/0/1(Trunk类型)允许VLAN2、4、50~100通过。

<Sysname> system-view

[Sysname] interface ethernet 1/0/1

[Sysname-Ethernet1/0/1] port link-type trunk

[Sysname-Ethernet1/0/1] port trunk permit vlan 2 4 50 to 100

Please wait........... Done.

1.2.8  port trunk pvid vlan

【命令】

port trunk pvid vlan vlan-id

undo port trunk pvid

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定接口的缺省VLAN ID,取值范围为1~4094。

【描述】

port trunk pvid vlan命令用来设置Trunk端口的缺省VLAN ID。undo port trunk pvid命令用来恢复缺省情况。

缺省情况下,Trunk端口的缺省VLAN为VLAN1。

对Trunk端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即使用已经不存在的VLAN作为缺省VLAN。

需要注意的是:

l              本端设备Trunk端口的缺省VLAN ID和相连的对端设备的Trunk端口的缺省VLAN ID必须一致,否则报文将不能正确传输。

l              配置缺省VLAN后,必须使用port trunk permit vlan命令配置允许缺省VLAN的报文通过,出接口才能转发缺省VLAN的报文。

相关配置可参考命令port link-typeport trunk permit vlan

【举例】

# 将端口Ethernet1/0/1(Trunk类型)的缺省VLAN设置为100。

<Sysname> system-view

[Sysname] interface ethernet 1/0/1

[Sysname-Ethernet1/0/1] port link-type trunk

[Sysname-Ethernet1/0/1] port trunk pvid vlan 100

1.3  基于MAC的VLAN配置命令

1.3.1  display mac-vlan

【命令】

display mac-vlan { all | dynamic | mac-address mac-address [ mask mac-mask ] | static | vlan vlan-id }

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

all:显示MAC-VLAN表的所有表项。

dynamic:显示动态配置的MAC-VLAN表项。

mac-address mac-address:按MAC显示MAC-VLAN表项。

mask mac-mask:显示指定范围的MAC-VLAN表项。

static:显示静态配置的MAC-VLAN表项。

vlan vlan-id:显示指定VLAN的MAC-VLAN表项。

【描述】

display mac-vlan命令用来显示MAC-VLAN表项。

指定mac-address参数但不带mask参数,则显示单个MAC VLAN表项。

【举例】

# 显示MAC-VLAN表的所有表项。

<Sysname> display mac-vlan all

The following MAC-VLAN address exist:

S: Static   D: Dynamic

MAC ADDR           MASK                    VLAN ID   PRIO    STATE

-------------------------------------------------------------------

0008-0001-0000     FFFF-FF00-0000          5         3       S

0002-0001-0000     FFFF-FFFF-FFFF          5         3       S&D

 

Total MAC VLAN address count:2

表1-4 display mac-vlan命令显示信息描述表

字段

描述

The following MAC-VLAN address exist:

目前设备上存在以下MAC VLAN配置

S: Static

以下显示信息中,S表示静态配置的MAC VLAN

D: Dynamic

以下显示信息中,D表示动态配置的MAC VLAN

MAC ADDR

配置的MAC-VLAN的MAC地址

MASK

配置的MAC-VLAN的MAC地址对应的掩码

VLAN ID

用户配置的MAC地址所对应的VLAN

PRIO

用户配置的MAC地址所对应的802.1P优先级

STATE

该表项的属性,MAC-VLAN表中的表项有三种属性:

l      S表示该表项是通过用户静态配置生成的

l      D表示该表项是通过认证功能自动生成的

l      S&D表示该表项由静态和动态同时配置的

 

1.3.2  display mac-vlan interface

【命令】

display mac-vlan interface

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

【描述】

display mac-vlan interface命令用来显示所有使能了MAC-VLAN功能的接口。

相关配置可参考命令mac-vlan enable

【举例】

# 显示所有使能了MAC-VLAN功能的接口。

<Sysname> display mac-vlan interface

MAC VLAN is enabled on following ports:

---------------------------------------

 Ethernet1/0/1  Ethernet1/0/2

1.3.3  mac-vlan enable

【命令】

mac-vlan enable

undo mac-vlan enable

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

【描述】

mac-vlan enable命令用来使能端口的MAC VLAN功能。undo mac-vlan enable 命令用来禁用端口的MAC VLAN功能。

缺省情况下,没有使能端口的MAC VLAN功能。

【举例】

# 使能端口Ethernet1/0/1的MAC VLAN功能。

<Sysname> system-view

[Sysname] interface ethernet 1/0/1

[Sysname–Ethernet1/0/1] mac-vlan enable

1.3.4  mac-vlan mac-address

【命令】

mac-vlan mac-address mac-address [ mask mac-mask ] vlan vlan-id [ priority pri ]

undo mac-vlan { all | mac-address mac-address [ mask mac-mask ] | vlan vlan-id }

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

mac-address mac-address:指定MAC地址。

mask mac-mask:指定MAC地址的掩码,二进制时高位必须为连续1。

vlan vlan-id:指定VLAN编号,取值为1~4094。

priority pri:指定MAC地址对应VLAN的802.1p优先级,取值为0~7,缺省值为0。

all:删除所有的静态MAC-VLAN表项。

【描述】

mac-vlan mac-address命令用来设置MAC地址所对应的VLAN以及其优先级。undo mac-vlan命令用来删除MAC地址与VLAN的关联。

设备维护两张MAC-VLAN表,一种是通过指定mask参数配置的MAC-VLAN表,该表里的表项描述的是一类MAC地址和VLAN、优先级之间的关系;一种是不指定mask参数直接配置的MAC-VLAN表,该表里的表项描述的是单个MAC地址和VLAN、优先级之间的关系。根据用户的配置,系统将自动往这两个表里添加/删除表项。

【举例】

# 设置单个MAC地址(0-1-1)与VLAN 100的关联,并指定优先级为7。

<Sysname> system-view

[Sysname] mac-vlan mac-address 0-1-1 vlan 100 priority 7

# 设置将MAC地址前6位为111122的用户与VLAN 100关联,优先级为4。

<Sysname> system-view

[Sysname] mac-vlan mac-address 1111-2222-3333 mask ffff-ff00-0000 vlan 100 priority 4

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!