选择区域语言: EN CN HK

ComwareV7常用命令行视图介绍

手册下载

 

1 ComwareV7命令行视图综述·· 1-1

1.1 命令行视图分层结构·· 1-1

1.2 进入视图·· 1-1

1.3 退出视图·· 1-1

2 用户视图·· 2-1

3 系统视图·· 3-1

4 功能视图·· 4-1

4.1 功能视图分类·· 4-1

4.2 物理接口及其对应的子接口视图·· 4-2

4.3 设备虚拟化技术相关视图·· 4-3

4.3.1 IRF功能视图·· 4-3

4.3.2 MDC功能视图·· 4-4

4.3.3 Context功能视图·· 4-4

4.4 网络虚拟化技术相关视图·· 4-5

4.4.1 VXLAN功能视图·· 4-5

4.4.2 EVPN功能视图·· 4-6

4.4.3 NVGRE功能视图·· 4-7

4.4.4 EVB功能视图·· 4-8

4.4.5 EVI功能视图·· 4-8

4.4.6 TRILL功能视图·· 4-9

4.4.7 隧道功能视图·· 4-9

4.4.8 ADVPN功能视图·· 4-9

4.5 设备管理相关功能视图·· 4-10

4.6 接入相关功能视图·· 4-12

4.6.1 VLAN功能视图·· 4-12

4.6.2 生成树功能视图·· 4-12

4.6.3 以太网链路聚合功能视图·· 4-12

4.6.4 Bridge转发功能视图·· 4-13

4.6.5 广域网接入功能视图·· 4-14

4.6.6 终端接入功能视图·· 4-19

4.6.7 FCFCoE功能视图·· 4-19

4.6.8 EPON功能视图·· 4-21

4.7 地址分配和地址转换相关视图·· 4-21

4.7.1 DHCP功能视图·· 4-21

4.7.2 DNS功能视图·· 4-23

4.7.3 NAT功能视图·· 4-23

4.7.4 AFT功能视图·· 4-24

4.8 路由相关功能视图·· 4-24

4.8.1 RIB功能视图·· 4-24

4.8.2 RIPRIPng功能视图·· 4-24

4.8.3 OSPFOSPFv3功能视图·· 4-25

4.8.4 IS-IS功能视图·· 4-26

4.8.5 BGP功能视图·· 4-27

4.8.6 策略路由功能视图·· 4-28

4.8.7 路由策略功能视图·· 4-29

4.8.8 MTR功能视图·· 4-29

4.8.9 DCN功能视图·· 4-29

4.9 组播相关功能视图·· 4-30

4.9.1 IGMP-SnoopingMLD-Snooping功能视图·· 4-30

4.9.2 组播VLAN功能视图·· 4-30

4.9.3 组播路由与转发功能视图·· 4-31

4.9.4 IGMPMLD功能视图·· 4-31

4.9.5 PIMIPv6 PIM功能视图·· 4-32

4.9.6 MSDP功能视图·· 4-32

4.9.7 组播VPN功能视图·· 4-33

4.10 MPLS相关功能视图·· 4-33

4.10.1 LDP功能视图·· 4-34

4.10.2 MPLS TE功能视图·· 4-34

4.10.3 RSVP功能视图·· 4-35

4.10.4 隧道策略功能视图·· 4-35

4.10.5 MPLS L3VPN功能视图·· 4-35

4.10.6 MPLS L2VPN功能视图·· 4-37

4.10.7 VPLS功能视图·· 4-41

4.10.8 L2VPN接入L3VPNIP骨干网功能视图·· 4-44

4.10.9 MPLS-TP OAM功能视图·· 4-45

4.10.10 MPLS保护倒换功能视图·· 4-45

4.11 流量控制相关功能视图·· 4-46

4.11.1 ACL功能视图·· 4-46

4.11.2 QoS功能视图·· 4-48

4.11.3 Flowspec功能视图·· 4-49

4.11.4 WAAS功能视图·· 4-50

4.12 安全相关功能视图·· 4-51

4.12.1 AAA功能视图·· 4-51

4.12.2 Portal功能视图·· 4-53

4.12.3 Web认证功能视图·· 4-54

4.12.4 用户身份识别与管理功能视图·· 4-54

4.12.5 User Profile功能视图·· 4-55

4.12.6 keychain功能视图·· 4-55

4.12.7 公钥管理功能视图·· 4-56

4.12.8 PKI功能视图·· 4-56

4.12.9 IPsec功能视图·· 4-57

4.12.10 Group Domain VPN功能视图·· 4-59

4.12.11 SSL功能视图·· 4-59

4.12.12 SSL VPN功能视图·· 4-59

4.12.13 ASPF功能视图·· 4-61

4.12.14 连接数限制功能视图·· 4-61

4.12.15 对象策略和对象组功能视图·· 4-62

4.12.16 攻击检测与防范功能视图·· 4-63

4.12.17 ND攻击防御功能视图·· 4-63

4.12.18 MACsec功能视图·· 4-63

4.12.19 安全域功能视图·· 4-63

4.12.20 安全策略功能视图·· 4-64

4.12.21 带宽策略功能视图·· 4-64

4.12.22 应用审计与管理功能视图·· 4-64

4.12.23 APR功能视图·· 4-65

4.12.24 DPI深度安全功能视图·· 4-66

4.13 可靠性相关功能视图·· 4-69

4.13.1 进程分布优化功能视图·· 4-69

4.13.2 RPR功能视图·· 4-70

4.13.3 RRPP功能视图·· 4-70

4.13.4 ERPS功能视图·· 4-71

4.13.5 Smart LinkMonitor Link功能视图·· 4-71

4.13.6 多机备份功能视图·· 4-72

4.13.7 备份组功能视图·· 4-72

4.13.8 冗余备份功能相关视图·· 4-73

4.13.9 BFD功能视图·· 4-73

4.13.10 Track功能视图·· 4-73

4.13.11 负载均衡功能视图·· 4-74

4.13.12 接口组联动功能视图·· 4-76

4.14 网络管理和监控相关功能视图·· 4-77

4.14.1 LoopbackNull0接口视图·· 4-77

4.14.2 NQA功能视图·· 4-77

4.14.3 PoE功能视图·· 4-77

4.14.4 Event MIB功能视图·· 4-78

4.14.5 SmartMC功能视图·· 4-79

4.14.6 OpenFlow功能视图·· 4-79

4.14.7 CWMP功能视图·· 4-79

4.14.8 EAA功能视图·· 4-80

4.14.9 镜像功能视图·· 4-80

4.14.10 NetStream功能视图·· 4-80

4.14.11 Flow日志功能视图·· 4-81

4.14.12 服务链功能视图·· 4-81

4.14.13 Neutron功能视图·· 4-81

4.15 语音相关功能视图·· 4-82

4.16 WLAN相关功能视图·· 4-84

4.16.1 AP管理功能视图·· 4-84

4.16.2 射频管理功能视图·· 4-86

4.16.3 WLAN接入功能视图·· 4-86

4.16.4 WIPS功能视图·· 4-86

4.16.5 WLAN漫游功能视图·· 4-87

4.16.6 WLAN负载均衡功能视图·· 4-88

4.16.7 Bonjour功能视图·· 4-88

4.16.8 分层AC功能视图·· 4-88

4.16.9 WLAN Mesh功能视图·· 4-89

4.16.10 物联网AP功能视图·· 4-89

4.16.11 Hotspot 2.0功能视图·· 4-90

4.16.12 WLAN RRM功能视图·· 4-90

4.17 NEMO功能视图·· 4-91

4.18 LISP功能视图·· 4-91

 


1 ComwareV7命令行视图综述

1.1  命令行视图分层结构

ComwareV7提供了丰富的功能,相应的也提供了多样的配置和查询的命令。为便于用户使用这些命令,ComwareV7将命令按功能分类进行组织。功能分类与命令视图对应,当要配置某功能时,需要进入相应的功能视图执行相关命令。每个视图都有唯一的、含义清晰的提示符,例如提示符[Sysname-vlan100]表示当前的命令视图是VLAN视图,VLAN的编号是100,在该视图下可配置VLAN 100的属性。

1-1所示,命令视图采用分层结构。第一层为用户视图,第二层为系统视图,第三层为各个功能视图。

图1-1 命令视图示意图

 

1.2  进入视图

不同视图的进入方式为:

·     用户登录设备后,直接进入用户视图。

·     从用户视图执行system-view命令,可以进入系统视图。

·     在系统视图下输入特定命令,可以进入相应的功能视图。功能视图下可能还包含子视图。

1.3  退出视图

除用户视图、Tcl配置视图、Python shell、公共密钥编辑视图和公共密钥视图外,其他视图的退出方式为:

·     在当前视图执行quit命令可返回上一级视图。

·     执行return命令返回用户视图。

·     快捷键<Ctrl+Z>可返回用户视图,功能等同于return命令。

用户视图下执行quit命令后,会断开与设备的连接;用户视图下不能使用return命令。

Tcl配置视图、Python shell、公共密钥编辑视图和公共密钥视图的退出方式分别为:

·     Tcl配置视图下请使用tclquit返回用户视图。

·     Python shell下请通过执行exit()命令,从Python shell退回到用户视图。

·     公共密钥编辑视图下请使用public-key-code end返回上一级视图(公共密钥视图);公共密钥视图下请使用peer-public-key end命令返回系统视图。


2 用户视图

用户登录设备后,即进入用户视图,在用户视图下可执行的操作主要包括查看操作、调试操作、文件管理操作、设置系统时间、重启设备、FTPTelnet操作等。

用户视图的提示符为<系统名称>,例如,<Sysname>。用户可以自行配置系统名称。

 


3 系统视图

在用户视图下键入system-view命令,即进入系统视图。如下所示:

<Sysname> system-view

System View: return to User View with Ctrl+Z.

[Sysname]

在系统视图下,能对设备运行参数以及部分功能进行配置,例如配置夏令时、配置欢迎信息、配置快捷键等。

 


4 功能视图

说明

本文罗列的功能视图的支持情况与设备型号有关,请以设备的实际情况为准。

 

4.1  功能视图分类

在系统视图下,可以分别进入各功能视图。本节分类介绍设备常用的功能视图及进入各视图的方式。功能视图分类方式如4-1所示。

表4-1 功能视图分类

分类

描述

物理接口及其对应的子接口视图

包括以太网接口、同异步串口等物理接口及其对应的子接口视图

设备虚拟化技术相关视图

包括IRFMDCContext功能视图

网络虚拟化技术相关视图

包括VXLANEVPNNVGREEVB等网络虚拟化功能视图

设备管理相关功能视图

包括用户界面、FTPJob等日常管理操作视图

接入相关功能视图

包括VLAN、生成树、以太网链路聚合等以太网接入和ATMHDLC等广域网接入功能视图

地址分配和地址转换相关视图

包括DHCPDNSNATAFT等用来实现地址分配和地址转换功能的视图

路由相关功能视图

包括RIPOSPFIS-ISBGP和策略路由等IPv4路由协议相关功能视图,以及RIPngOSPFv3IPv6策略路由等IPv6路由协议相关功能视图

组播相关功能视图

包括IGMP SnoopingMLD Snooping、组播VLANIGMPMLDPIMIPv6 PIMMSDP、组播VPN等组播相关功能视图

MPLS相关功能视图

包括LDPMPLS TERSVPMPLS L3VPNMPLS L2VPNVPLSMPLS功能视图

流量控制相关功能视图

包括ACLQoSFlowspec等功能视图

安全相关功能视图

包括AAAPortalPKIIpsecSSLSSH等安全功能视图

可靠性相关功能视图

包括进程分布优化、RPRRRPP、多机备份、备份组、BFD、负载均衡等可靠性功能视图

网络管理和监控相关功能视图

包括NQAPoEEvent MIBSmartMCOpenFlowCWMP、镜像、NetStream等网络管理和监控功能视图

语音相关功能视图

包括语音用户线、语音实体、拨号策略、SIP等功能视图

WLAN相关功能视图

包括AP管理、射频管理、WLAN接入、WLAN漫游、分层AC等功能视图

NEMO功能视图

包括NEMO功能视图

LISP功能视图

包括LISP功能视图

 

4.2  物理接口及其对应的子接口视图

表4-2 物理接口及其对应的子接口视图列表

视图

视图说明

进入命令

示例

以太网接口视图

进入该视图后,可配置以太网端口的相关属性

interface ethernet

[Sysname] interface Ethernet 1/0/1

[Sysname-Ethernet1/0/1]

interface gigabitethernet

[Sysname] interface GigabitEthernet 1/0/1

[Sysname-GigabitEthernet1/0/1]

interface smartrate-ethernet

[Sysname] interface smartrate-ethernet 1/0/1

[Sysname-Smartrate-Ethernet1/0/1]

interface ten-gigabitethernet

[Sysname] interface Ten-GigabitEthernet 1/0/1

[Sysname–Ten-GigabitEthernet1/0/1]

interface twenty-fivegige

[Sysname] interface twenty-fivegige 1/0/1

[Sysname–Twenty-FiveGigE1/0/1]

interface fortygige

[Sysname] interface fortygige 1/0/1

[Sysname–FortyGigE1/0/1]

interface hundredgige

[Sysname] interface hundredgige 1/0/1

[Sysname–HundredGigE1/0/1]

三层以太网子接口视图

进入该视图后,可配置以太网端口的相关属性

interface gigabitethernet interface-number.subnumber

[Sysname] interface GigabitEthernet 2/0/2.1

[Sysname-GigabitEthernet2/0/2.1]

管理以太网接口视图

进入该视图后,可配置管理以太网接口的相关属性

interface M-Ethernet

[Sysname] interface M-Ethernet 0/0/0

[Sysname-M-Ethernet0/0/0]

interface M-GigabitEthernet

[Sysname] interface M-GigabitEthernet 0/0/0

[Sysname-M-GigabitEthernet0/0/0]

同异步串口视图

进入该视图后,可配置同异步串口的相关属性

interface serial interface-number

[Sysname] interface serial 2/1/0

[Sysname-Serial2/1/0]

串口子接口视图

·     创建串口子接口,并进入串口子接口视图

·     进入该视图后,可配置串口子接口的相关属性

interface serial interface-number.subnumber [ p2mp | p2p ]

[Sysname] interface serial 2/1/0.1

[Sysname-Serial2/1/0.1]

异步串口视图

进入该视图后,可配置异步串口接口的相关属性

interface async

[Sysname] interface async 2/4/0

[Sysname-Async2/4/0]

AM接口视图

进入该视图后,可配置AM接口的相关属性

interface analogmodem

[Sysname] interface analogmodem 2/4/0

[Sysname-Analogmodem2/4/0]

FCM接口视图

进入该视图后,可配置FCM接口的相关属性

interface fcm

[Sysname] interface fcm 2/4/0

[Sysname-Fcm2/4/0]

BRI接口视图

进入该视图后,可配置BRI接口的相关属性

interface bri

[Sysname] interface bri 2/4/0

[Sysname-Bri2/4/0]

E1-F接口视图

进入该视图后,可配置E1-F接口的相关属性

interface serial interface-number

[Sysname] interface serial 2/1/0

[Sysname-Serial2/1/0]

T1-F接口视图

进入该视图后,可配置T1-F接口的相关属性

interface serial interface-number

[Sysname] interface serial 2/1/0

[Sysname-Serial2/1/0]

POS通道接口

进入该视图后,可配置POS通道接口的相关属性

interface pos

[Sysname] interface pos 3/1/1

[Sysname-Pos3/1/1]

POS子接口视图

·     创建POS子接口,并进入POS子接口视图

·     进入该视图后,可配置POS子接口的相关属性

interface pos interface-number.subnumber [ p2mp | p2p ]

[Sysname] interface pos 3/1/1.1

[Sysname-Pos3/1/1.1]

Cellular接口视图

进入该视图后,可配置Cellular接口的相关属性

controller cellular cellular-number

[Sysname] controller cellular 2/4/0

[Sysname-Cellular 2/4/0]

 

4.3  设备虚拟化技术相关视图

4.3.1  IRF功能视图

表4-3 设备管理功能视图列表

视图

视图说明

进入命令

示例

IRF端口视图

进入该视图后,可以配置当前IRF端口与物理端口绑定

irf-port

(分布式设备-独立运行模式)

[Sysname] irf-port 1

[Sysname-irf-port 1]

(分布式设备-IRF模式)(集中式IRF设备)

[Sysname] irf-port 1/1

[Sysname-irf-port 1/1]

IRF端口视图(原集群)

进入该视图后,可以配置当前IRF端口与物理端口绑定

(独立运行模式)

irf-port

IRF模式)

irf-port member-id

(分布式设备-独立运行模式)

[Sysname] irf-port

[Sysname-irf-port]

(分布式设备-IRF模式)(集中式IRF设备)

[Sysname] irf-port 1

[Sysname-irf-port1]

 

4.3.2  MDC功能视图

表4-4 MDC功能视图列表

视图

视图说明

进入命令

示例

MDC视图

·     创建MDC,并进入MDC视图

·     进入该视图后,可以启动、为MDC分配资源以及停止运行MDC

mdc

[Sysname] mdc sub1

[Sysname-mdc-2-sub1]

 

4.3.3  Context功能视图

表4-5 Context功能视图列表

视图

视图说明

进入命令

示例

Context视图

·     创建Context,并进入Context视图

·     进入该视图后,可配置Context相关参数

context

[Sysname] context test

[Sysname-context-2-test]

安全引擎组视图

·     创建安全引擎组,并进入安全引擎组视图

·     进入该视图后,可配置安全引擎组相关参数

blade-controller-team

[Sysname] blade-controller-team abc

[Sysname-blade-controller-team-3-abc]

 

4.4  网络虚拟化技术相关视图

4.4.1  VXLAN功能视图

表4-6 VXLAN功能视图列表

视图

视图说明

进入命令

示例

VSI视图

·     需要先开启L2VPN功能,才能创建VSI,并进入VSI视图

·     进入该视图后,可以创建VXLAN、配置当前VSI的相关属性

vsi

[Sysname] l2vpn enable

[Sysname] vsi aaa

[Sysname-vsi-aaa]

VXLAN视图

·     创建VXLAN,并进入VXLAN视图

·     进入该视图后,可以配置当前VXLAN的相关属性

vxlan

[Sysname] vsi vpna

[Sysname-vsi-vpna] vxlan 10000

[Sysname-vsi-vpna-vxlan-10000]

以太网服务实例视图

·     创建以太网服务实例,并进入以太网服务实例视图

·     进入该视图后,可以为当前以太网服务实例配置报文匹配规则等

service-instance

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] service-instance 100

[Sysname-GigabitEthernet1/0/1-srv100]

VSI虚接口视图

·     创建VSI虚接口,并进入VSI虚接口视图

·     进入该视图后,可以配置VSI虚接口的相关参数

interface vsi-interface vsi-interface-id

[Sysname] interface vsi-interface 100

[Sysname-Vsi-interface100]

VSI子接口视图

·     需要先创建VSI虚接口,才能创建该VSI虚接口上的VSI子接口,并进入VSI子接口视图

·     进入该视图后,可以配置VSI子接口的相关参数

interface vsi-interface vsi-interface-id.subid

[Sysname] interface vsi-interface 100

[Sysname-Vsi-interface100] quit

[Sysname] interface vsi-interface 100.1

[Sysname-Vsi-interface100.1]

VXLAN IS-IS视图

·     创建VXLAN IS-IS进程,并进入VXLAN IS-IS视图

·     进入该视图后,可以VXLAN IS-IS协议运行时使用的参数

vxlan-isis

[Sysname] vxlan-isis

[Sysname-vxlan-isis]

 

4.4.2  EVPN功能视图

表4-7 EVPN功能视图列表

视图

视图说明

进入命令

示例

VSI视图

·     需要先开启L2VPN功能,才能创建VSI,并进入VSI视图

·     进入该视图后,可以创建VXLAN、配置当前VSI的相关属性

vsi

[Sysname] l2vpn enable

[Sysname] vsi aaa

[Sysname-vsi-aaa]

VXLAN视图

·     创建VXLAN,并进入VXLAN视图

·     进入该视图后,可以配置当前VXLAN的相关属性

vxlan

[Sysname] vsi vpna

[Sysname-vsi-vpna] vxlan 10000

[Sysname-vsi-vpna-vxlan-10000]

EVPN实例视图

·     创建EVPN实例,并进入EVPN实例视图

·     进入该视图后,可以配置EVPN实例相关参数

evpn encapsulation vxlan

[Sysname] vsi aaa

[Sysname-vsi-aaa] evpn encapsulation vxlan

[Sysname-vsi-aaa-evpn-vxlan]

VPN实例EVPN视图

进入该视图后,可以配置指定VPN实例内EVPN的参数,如EVPNRT属性、应用的出方向路由策略等

address-family evpn

[Sysname] ip vpn-instance tenant

[Sysname-vpn-instance-tenant] address-family evpn

[Sysname-vpn-evpn-tenant]

公网实例视图

·     创建公网实例,并进入公网实例视图

·     进入该视图后,可以配置公网实例相关参数

ip public-instance

[Sysname] ip public-instance

[Sysname-public-instance]

公网实例IPv4 VPN视图

进入该视图后,可以配置公网内IPv4 VPN的参数

address-family ipv4

[Sysname] ip public-instance

[Sysname-public-instance] address-family ipv4

[Sysname-public-instance-ipv4]

公网实例IPv6 VPN视图

进入该视图后,可以配置公网内IPv6 VPN的参数

address-family ipv6

[Sysname] ip public-instance

[Sysname-public-instance] address-family ipv6

[Sysname-public-instance-ipv6]

公网实例EVPN视图

进入该视图后,可以配置公网内EVPN的参数,如EVPNRT属性、应用的出方向路由策略等

address-family evpn

[Sysname] ip public-instance

[Sysname-public-instance] address-family evpn

[Sysname-public-instance-evpn]

BGP EVPN地址族

·     创建BGP EVPN地址族,并进入BGP EVPN地址族视图

·     进入该视图后,可以配置BGP EVPN对等体和路由的相关参数

address-family l2vpn evpn

[Sysname] bgp 100

[Sysname-bgp-default] address-family l2vpn evpn

[Sysname-bgp-default-evpn]

以太网服务实例视图

·     创建以太网服务实例,并进入以太网服务实例视图

·     进入该视图后,可以为当前以太网服务实例配置报文匹配规则等

service-instance

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] service-instance 100

[Sysname-GigabitEthernet1/0/1-srv100]

 

4.4.3  NVGRE功能视图

表4-8 NVGRE功能视图列表

视图

视图说明

进入命令

示例

VSI视图

·     需要先开启L2VPN功能,才能创建VSI,并进入VSI视图

·     进入该视图后,可以创建VXLAN、配置当前VSI的相关属性

vsi

[Sysname] l2vpn enable

[Sysname] vsi aaa

[Sysname-vsi-aaa]

NVGRE网络视图

·     创建NVGRE网络,并进入NVGRE网络视图

·     进入该视图后,可以配置NVGRE网络相关参数

nvgre

[Sysname] l2vpn enable

[Sysname] vsi vpna

[Sysname-vsi-vpna] nvgre 10000

[Sysname-si-vpna-nvgre-10000]

以太网服务实例视图

·     创建以太网服务实例,并进入以太网服务实例视图

·     进入该视图后,可以为当前以太网服务实例配置报文匹配规则等

service-instance

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] service-instance 100

[Sysname-GigabitEthernet1/0/1-srv100]

VSI虚接口视图

·     创建VSI虚接口,并进入VSI虚接口视图

·     进入该视图后,可以配置VSI虚接口的相关参数

interface vsi-interface vsi-interface-id

[Sysname] interface vsi-interface 100

[Sysname-Vsi-interface100]

 

4.4.4  EVB功能视图

表4-9 EVB功能视图列表

视图

视图说明

进入命令

示例

S通道接口视图

·     进入S通道接口视图

·     进入该视图后,可配置S通道接口相关参数

interface s-channel interface-number:channel-id

[Sysname] interface s-channel 1/0/1:10

[Sysname–S-Channel1/0/1:10]

聚合S通道接口视图

·     进入聚合S通道接口视图

·     进入该视图后,可配置聚合S通道接口相关参数

interface schannel-aggregation interface-number:channel-id

[Sysname] interface schannel-aggregation 1:10

[Sysname–Schannel-Aggregation1:10]

VSI接口视图

·     进入VSI接口视图

·     进入该视图后,可配置VSI接口相关参数

interface s-channel interface-number:channel-id.vsi-local-id

[Sysname] interface s-channel 1/0/1:10.1

[Sysname–S-Channel1/0/1:10.1]

聚合VSI接口视图

·     进入聚合VSI接口视图

·     进入该视图后,可配置聚合VSI接口相关参数

interface schannel-aggregation interface-number:channel-id.vsi-local-id

[Sysname] interface schannel-aggregation 1:10.1

[Sysname–Schannel-Aggregation1:10.1]

 

4.4.5  EVI功能视图

表4-10 EVI功能视图列表

视图

视图说明

进入命令

示例

EVI IS-IS视图

·     创建EVI IS-IS进程,并进入EVI IS-IS视图

·     进入该视图后,可配置EVI IS-IS相关参数

evi-isis

[Sysname] evi-isis 101

[Sysname-evi-isis-101]

 

4.4.6  TRILL功能视图

表4-11 TRILL功能视图列表

视图

视图说明

进入命令

示例

TRILL视图

·     全局开启TRILL功能,并进入TRILL视图

·     进入该视图后,可配置TRILL相关功能、参数

trill

[Sysname] trill

[Sysname-trill]

 

4.4.7  隧道功能视图

表4-12 隧道功能视图列表

视图

视图说明

进入命令

示例

Tunnel接口视图

·     创建Tunnel接口,指定隧道模式,并进入该Tunnel接口视图

·     进入该视图后,可配置Tunnel接口的相关属性

interface tunnel

[Sysname] interface tunnel 1 mode gre

[Sysname-Tunnel1]

Tunnel-Bundle接口视图

·     创建Tunnel-Bundle接口,并进入该Tunnel-Bundle接口视图

·     进入该视图后,可配置Tunnel-Bundle接口的相关属性

interface tunnel-bundle

[Sysname] interface tunnel-bundle 2

[Sysname-tunnel-bundle2]

 

4.4.8  ADVPN功能视图

表4-13 ADVPN功能视图列表

视图

视图说明

进入命令

示例

ADVPN域视图

·     创建ADVPN域,并进入ADVPN域视图

·     进入该视图后,可配置ADVPN的相关属性

vam server advpn-domain

[Sysname] vam server advpn-domain 1 id 1

[Sysname-vam-server-domain-1]

Hub组视图

·     首先需要创建并进入ADVPN域视图,才能通过本命令进入Hub组视图

·     创建Hub组,并进入Hub组视图

·     进入该视图后,可配置Hub组的相关属性

hub-group

[Sysname] vam server advpn-domain 1

[Sysname-vam-server-domain-1] hub-group 1

[Sysname-vam-server-domain-1-hub-group-1]

VAM Client视图

·     创建VAM Client,并进入VAM Client视图

·     进入该视图后,可配置VAM Client相关属性

vam client name

[Sysname] vam client name abc

[Sysname-vam-client-abc]

 

4.5  设备管理相关功能视图

表4-14 设备管理功能视图列表

视图

视图说明

进入命令

示例

用户界面视图

进入该视图后,可配置用户界面的相关参数

user-interface aux

[Sysname] user-interface aux 0

[Sysname-ui-aux0]

user-interface vty

[Sysname] user-interface vty 0

[Sysname-ui-vty0]

用户角色视图

·     创建用户角色,并进入用户角色视图

·     进入该视图后,可配置用户角色的相关功能

role name role-name

[Sysname] role name role1

[Sysname-role-role1]

特性组视图

·     创建特性组,并进入特性组视图

·     进入该视图后,可配置特性组的相关功能

role feature-group name feature-group-name

[Sysname] role feature-group name security-features

[Sysname-featuregrp-security-features]

接口策略视图

进入接口策略视图后可以配置接口策略

interface policy deny

[Sysname] role name role1

[Sysname-role-role1] interface policy deny

[Sysname-role-role1-ifpolicy]

安全域策略视图

进入安全域策略视图后,可以配置安全策略

security-zone policy deny

[Sysname] role name role1

[Sysname-role-role1] security-zone policy deny

[Sysname-role-role1-zonepolicy]

VLAN策略视图

进入VLAN策略视图后,可以配置VLAN策略

vlan policy deny

[Sysname] role name role1

[Sysname-role-role1] vlan policy deny

[Sysname-role-role1-vlanpolicy]

VPN策略视图

进入VPN策略视图后,可以配置VPN策略

vpn-instance policy deny

[Sysname] role name role1

[Sysname-role-role1] vpn-instance policy deny

[Sysname-role-role1-vpnpolicy]

FTP客户端视图

进入FTP客户端视图,并配置该视图的相关属性

ftp

<Sysname>ftp

[ftp]

SFTP客户端视图

进入SFTP客户端视图,并配置该视图的相关属性

sftp

<Sysname>sftp

<sftp>

Tcl配置视图

进入Tcl配置视图,输入Tcl脚本命令或Comware系统的命令

tclsh

<Sysname>tclsh

<Sysname-tcl>

Python shell

进入Python shell后,可以使用Python的命令和标准API,也可以使用Comware V7的扩展API

python

<Sysname>python

Python 2.7.3 (default)

[GCC 4.4.1] on linux2

Type "help", "copyright", "credits" or "license" for more information.

>>> 

Slot视图

进入该视图后,可预先配置不在位slot的相关属性

(集中式IRF模式)(分布式设备-独立运行模式)

slot slot-number

(分布式设备-IRF模式)

chassis chassis-number slot slot-number

(集中式IRF模式)(分布式设备-独立运行模式)

[Sysname]slot 1

[Sysname-slot-1]

(分布式设备-IRF模式)

[Sysname]chassis 1 slot 1

[Sysname-chassis-1-slot-1]

Job视图

·     创建定时执行任务,并进入Job视图

·     进入该视图后,可配置定时执行任务的相关属性

job

[Sysname] job task1

[Sysname-job-task1]

 

4.6  接入相关功能视图

4.6.1  VLAN功能视图

表4-15 基本接入功能视图列表

视图

视图说明

进入命令

示例

VLAN视图

·     创建VLAN,并进入VLAN视图

·     进入该视图后,可配置VLAN的相关属性

vlan

[Sysname] vlan 2

[Sysname-vlan2]

VLAN接口视图

·     创建VLAN接口,并进入VLAN接口视图

·     进入该视图后,可配置VLAN接口的相关属性

interface vlan-interface

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1]

 

4.6.2  生成树功能视图

表4-16 生成树功能视图列表

视图

视图说明

进入命令

示例

MST域视图

进入该视图后,可配置MST域的相关属性

stp region-configuration

[Sysname] stp region-configuration

[Sysname-mst-region]

 

4.6.3  以太网链路聚合功能视图

表4-17 以太网链路聚合功能视图列表

视图

视图说明

进入命令

示例

二层聚合接口视图

·     创建二层聚合接口,并进入二层聚合接口视图

·     进入该视图后,可配置二层聚合接口的相关属性

interface bridge-aggregation

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1]

三层聚合接口视图

·     创建三层聚合接口,并进入三层聚合接口视图

·     进入该视图后,可配置三层聚合接口的相关属性

interface route-aggregation

[Sysname] interface route-aggregation 1

[Sysname-Bridge-Aggregation1]

三层聚合子接口试图

·     创建三层聚合子接口,并进入三层聚合子接口视图

·     进入该视图后,可配置三层聚合子接口的相关属性

interface route-aggregation

[Sysname] interface route-aggregation 1.1

[Sysname-Bridge-Aggregation1.1]

S通道聚合接口

·     创建S通道聚合接口,并进入S通道聚合接口视图

·     进入该视图后,可配置S通道聚合接口的相关属性

interface schannel-bundle

[Sysname] interface schannel-bundle 1

[Sysname-Schannel-Bundle1]

引擎聚合接口

·     进入引擎聚合接口视图

·     进入该视图后,可配置引擎聚合接口的相关属性

interface blade-aggregation

[Sysname] interface blade-aggregation 1

[Sysname-Blade-Aggregation1]

 

4.6.4  Bridge转发功能视图

表4-18 Bridge转发功能视图列表

视图

视图说明

进入命令

示例

Bridge视图

·     首次创建并进入Bridge视图时,需要指定Bridge实例的转发模式

·     进入该视图后,可添加接口或VLANBridge转发实例

bridge

[Sysname] bridge 1 forward

[Sysname-bridge1-forward ]quit

[Sysname] bridge 1

[Sysname-bridge1-forward ]

 

4.6.5  广域网接入功能视图

表4-19 广域网接入功能视图列表

视图

视图说明

进入命令

示例

CE1/PRI接口视图

·     进入该视图后,可配置CE1/PRI接口的相关属性

·     CE1/PRI接口工作在不同的模式、进行不同的配置时,系统会自动生成不同类型的接口

controller e1

[Sysname] controller e1 2/3/0

[Sysname-E1 2/3/0]

CE1/PRI接口上形成的逻辑同步串口视图

进入该视图后,可配置串口的相关属性

interface serial interface-number:set-number

[Sysname] controller e1 2/3/0

[Sysname-E1 2/3/0] using ce1

[Sysname-E1 2/3/0] channel-set 0 timeslot-list 1,2,5,10-15,18

[Sysname-E1 2/3/0] quit

[Sysname] interface serial 2/3/0:2

[Sysname-Serial2/3/0:2]

interface serial interface-number:0

[Sysname] controller e1 2/3/0

[Sysname-E1 2/3/0] using e1

[Sysname-E1 2/3/0] quit

[Sysname] interface serial 2/3/0:0

[Sysname-Serial2/3/0:0]

interface serial interface-number:15

[Sysname] controller e1 2/3/0

[Sysname-E1 2/3/0] using ce1

[Sysname-E1 2/3/0] pri-set timeslot-list 1,2,8-12

[Sysname-E1 2/3/0] quit

[Sysname] interface serial 2/3/0:15

[Sysname-Serial2/3/0:15]

CE1/PRI接口上自动创建的电路仿真接口视图

进入该视图后,可配置电路仿真接口的相关属性

interface circuit-emulation interface-number:0

[Sysname] controller e1 2/3/0

[Sysname-E1 2/3/0] using e1

[Sysname-E1 2/3/0] quit

[Sysname] interface circuit-emulation 2/3/0:0

[Sysname-Circuit-Emulation2/3/0:0]

interface circuit-emulation interface-number:set-number

[Sysname] controller e1 2/3/0

[Sysname-E1 2/3/0] using ce1

[Sysname-E1 2/3/0] cem-set 0 timeslot-list 1,2,5,10-15,18

[Sysname-E1 2/3/0] quit

[Sysname] interface circuit-emulation 2/3/0:1

[Sysname-Circuit-Emulation2/3/0:1]

CE1/PRI接口上自动创建的AM接口视图

进入该视图后,可配置AM接口的相关属性

interface analogmodem interface-number:15

[Sysname] controller e1 2/3/0

[Sysname-E1 2/3/0] using ce1

[Sysname-E1 2/3/0] pri-set timeslot-list 1,2,8-12

[Sysname-E1 2/3/0] quit

[Sysname] interface analogmodem 2/3/0:15

[Sysname-Analogmodem2/3/0:15]

CE1/PRI接口上自动创建的FCM接口视图

进入该视图后,可配置FCM接口的相关属性

interface fcm interface-number:15

[Sysname] controller e1 2/3/0

[Sysname-E1 2/3/0] using ce1

[Sysname-E1 2/3/0] pri-set timeslot-list 1,2,8-12

[Sysname-E1 2/3/0] quit

[Sysname] interface fcm 2/3/0:15

[Sysname-FCM2/3/0:15]

CT1/PRI接口视图

·     进入该视图后,可配置CT1/PRI接口的相关属性

·     CT1/PRI接口工作在不同的模式、进行不同的配置时,系统会自动生成不同类型的接口

controller t1

[Sysname] controller t1 2/4/0

[Sysname-T1 2/4/0]

CT1/PRI接口上形成的逻辑同步串口视图

进入该视图后,可配置串口的相关属性

interface serial interface-number:set-number

[Sysname] controller t1 2/4/0

[Sysname-T1 2/4/0] undo using

[Sysname-T1 2/4/0] channel-set 0 timeslot-list 1,2,5,10-15,18

[Sysname-T1 2/4/0] quit

[Sysname] interface serial 2/4/0:2

[Sysname-Serial2/4/0:2]

interface serial interface-number23

[Sysname] controller t1 2/4/0

[Sysname-T1 2/4/0] undo using

[Sysname-T1 2/4/0] pri-set timeslot-list 1,2,8-12

[Sysname-T1 2/4/0] quit

[Sysname] interface serial 2/4/0:23

[Sysname-Serial2/4/0:23]

CT1/PRI接口上自动创建的电路仿真接口视图

进入该视图后,可配置电路仿真接口的相关属性

interface circuit-emulation interface-number:set-number

[Sysname] controller t1 2/4/0

[Sysname-T1 2/4/0] undo using

[Sysname-T1 2/4/0] cem-set 0 timeslot-list 1,2,5,10-15,18

[Sysname-T1 2/4/0] quit

[Sysname] interface circuit-emulation 2/4/0:2

[Sysname-Circuit-Emulation2/4/0:2]

CE3接口视图

·     进入该视图后,可配置CE3接口的相关属性

·     CE3接口工作在不同的模式、进行不同的配置时,系统会自动生成不同类型的接口

controller e3

[Sysname] controller e3 2/4/0

[Sysname-E32/4/0]

CE3接口上形成的逻辑同步串口视图

进入该视图后,可配置串口的相关属性

interface serial number/0:0

[Sysname] controller e3 2/4/0

[Sysname-E3 2/4/0] using e3

[Sysname-E3 2/4/0] quit

[Sysname] interface serial 2/4/0/0:0

[Sysname-Serial2/4/0/0:0]

interface serial number/line-number:0

[Sysname] controller e3 2/4/0

[Sysname-E3 2/4/0] using ce3

[Sysname-E3 2/4/0] e1 1 unframed

[Sysname-E3 2/4/0] quit

[Sysname] interface serial 2/4/0/1:0

[Sysname-Serial2/4/0/1:0]

interface serial number/line-number:set-number

[Sysname] controller e3 2/4/0

[Sysname-E3 2/4/0] using ce3

[Sysname-E3 2/4/0] e1 1 channel-set 1 timeslot-list 1,2

[Sysname-E3 2/4/0] quit

[Sysname] interface serial 2/4/0/1:1

[Sysname-Serial2/4/0/1:1]

CT3接口视图

·     进入该视图后,可配置CT3接口的相关属性

·     CT3接口工作在不同的模式、进行不同的配置时,系统会自动生成不同类型的接口

controller t3

[Sysname] controller t3 2/4/0

[Sysname-T3 2/4/0]

CT3接口上形成的逻辑同步串口视图

进入该视图后,可配置串口的相关属性

interface serial number/0:0

[Sysname] controller t3 2/4/0

[Sysname-T3 2/4/0] using t3

[Sysname-T3 2/4/0] quit

[Sysname] interface serial 2/4/0/0:0

[Sysname-Serial2/4/0/0:0]

interface serial number/line-number:0

[Sysname] controller t3 2/4/0

[Sysname-T3 2/4/0] using ct3

[Sysname-T3 2/4/0] t1 1 unframed

[Sysname-T3 2/4/0] quit

[Sysname] interface serial 2/4/0/1:0

[Sysname-Serial2/4/0/1:0]

interface serial number/line-number:set-number

[Sysname] controller t3 2/4/0

[Sysname-T3 2/4/0] using ct3

[Sysname-T3 2/4/0] t1 1 channel-set 1 timeslot-list 1,2

[Sysname-T3 2/4/0] quit

[Sysname] interface serial 2/4/0/1:1

[Sysname-Serial2/4/0/1:1]

DWDM接口视图

进入该视图后,可配置DWDM接口的相关属性

controller dwdm

[Sysname] controller dwdm 2/1/1

[Sysname-DWDM2/1/1]

以太网通道接口视图

进入该视图后,可配置以太网通道接口的相关属性

interface eth-channel interface-number

[Sysname] interface eth-channel 2/4/0:0

[Sysname-Eth-channel2/4/0:0]

ATM接口

进入该视图后,可配置ATM接口的相关属性

interface atm interface-number

[Sysname] interface atm 3/1/1

[Sysname-ATM3/1/1]

ATM子接口视图

·     创建ATM子接口,并进入ATM子接口视图

·     进入该视图后,可配置ATM子接口的相关属性

interface atm interface-number.subnumber [ p2mp | p2p ]

[Sysname] interface atm 3/1/1.1

[Sysname-ATM3/1/1.1]

EFM接口视图

·     进入EFM接口视图

·     进入该视图后,可配置EFM接口的相关属性

interface efm

[Sysname] interface efm 3/1/1

[Sysname-EFM3/1/1]

EFM子接口视图

·     创建EFM子接口,并进入EFM子接口视图

·     进入该视图后,可配置EFM子接口的相关属性

interface efm interface-number.subnumber

[Sysname] interface efm 3/1/1.1

[Sysname-EFM3/1/1.1]

VE接口视图

·     创建VEVirtual Ethernet,三层虚拟以太网)接口,并进入VE接口视图

·     进入该视图后,可配置VE接口的相关属性

interface virtual-ethernet interface-number

[Sysname] interface virtual-ethernet 2/4/1

[Sysname-Virtual-Ethernet2/4/1]

VE子接口视图

·     创建VEVirtual Ethernet,三层虚拟以太网)子接口,并进入VE子接口视图

·     进入该视图后,可配置VE子接口的相关属性

interface virtual-ethernet interface-number.subnumber

[Sysname] interface virtual-ethernet 2/4/1.1

[Sysname-Virtual-Ethernet2/4/1.1]

HDLC捆绑接口视图

·     创建HDLC捆绑接口并进入HDLC捆绑接口视图

·     进入该视图后,可配置HDLC捆绑接口的相关属性

interface hdlc-bundle bundle-id

[Sysname] interface hdlc-bundle 1

[Sysname-HDLC-bundle1]

虚拟模板接口(VT接口)视图

进入该视图后,可配置虚拟模板接口的相关属性

interface virtual-template number

[Sysname] interface virtual-template 10

[Sysname-Virtual-Template10]

MP-group接口视图

进入该视图后,可配置MP-group接口的相关属性

interface mp-group mp-number

[Sysname] interface mp-group 2/0/0

[Sysname-MP-group2/0/0]

虚拟PPP接口视图

进入该视图后,可配置虚拟PPP接口的相关属性

interface virtual-ppp interface-number

[Sysname] interface virtual-ppp 10

[Sysname-Virtual-PPP10]

Dialer接口视图

·     创建Dialer接口,并进入Dialer接口视图

·     进入该视图后,可配置Dialer接口的相关属性

interface dialer number

[Sysname] interface dialer 1

[Sysname-Dialer1]

MFR接口视图

·     创建MFR接口,并进入该MFR接口视图

·     进入该视图后,可配置MFR接口的相关属性

interface mfr

[Sysname] interface mfr 0/0/4

[Sysname-MFR0/0/4]

MFR子接口视图

·     创建MFR子接口,并进入该MFR子接口视图

·     进入该视图后,可配置MFR子接口的相关属性

interface mfr  interface-number.subnumber [ p2mp | p2p ]

[Sysname] interface mfr 0/0/4

[Sysname-MFR0/0/4] quit

[Sysname] interface mfr 0/0/4.1

[Sysname-MFR0/0/4.1]

帧中继虚电路视图

·     创建帧中继虚电路,并进入帧中继虚电路视图

·     进入该视图后,可配置帧中继虚电路相关属性

fr dlci

[Sysname] interface serial 2/1/0

[Sysname-Serial2/1/0] fr dlci 100

[Sysname-Serial2/1/0-fr-dlci-100]

ANCP邻居视图

创建ANCP邻居,并进入ANCP邻居视图

ancp neighbor neighbor-name

[sysname] ancp neighbor test1

[sysname-ancp-neighbor-test1]

L2TP组视图

创建L2TP组并进入该视图

l2tp-group group-number [ mode { lac | lns } ]

[Sysname] l2tp-group 2 mode lac

[Sysname-l2tp2]

[Sysname] l2tp-group 3 mode lns

[Sysname-l2tp3]

4G Modem参数模板视图

·     创建4G Modem参数模板,并进入4G Modem参数模板视图

·     进入该视图后,可配置4G Modem参数模板的相关属性

apn-profile profile-name

[Sysname] apn-profile test

[Sysname-apn-profile-test]

 

4.6.6  终端接入功能视图

表4-20 终端接入功能视图列表

视图

视图说明

进入命令

示例

POS应用模板视图

·     创建POS应用模板,并进入POS应用模板视图

·     进入该视图后,可配置POS应用模板的相关属性

posa app app-id type { flow | tcp }

[Sysname] posa app 1 type flow

[Sysname-posa-app1]

终端模板视图

·     创建终端模板,并进入终端模板视图

·     进入该视图后,可配置终端模板的相关属性

rta template template-name

[Sysname] rta template abc

[Sysname-rta-template-abc]

 

4.6.7  FCFCoE功能视图

表4-21 FCFCoE功能视图列表

视图

视图说明

进入命令

示例

FC接口视图

·     首先需要配置设备工作在FCoE模式,并将以太网接口切换成FC接口,才能进入FC接口视图

·     进入该视图后,可配置FC接口的相关属性

interface fc

[Sysname] interface fc 1/0/1

[Sysname-Fc1/0/1]

FC聚合接口视图

·     首先需要配置设备工作在FCoE模式,才能创建FC聚合接口,并进入FC聚合接口视图

·     进入该视图后,可配置FC聚合接口的相关属性

interface san-aggregation

[Sysname] interface san-aggregation 1

[Sysname-SAN-Aggregation1]

VFC接口视图

·     首先需要配置设备工作在FCoE模式,才能创建VFC接口,并进入VFC接口视图

·     进入该视图后,可配置VFC接口的相关属性

interface vfc

[Sysname] interface vfc 1

[Sysname-Vfc1]

VSAN视图

·     首先需要配置设备工作在FCoE模式,才能创建VSAN,并进入VSAN视图

·     进入该视图后,可配置VSAN的相关属性

vsan

[Sysname] vsan 1

[Sysname-vsan1]

Zone别名视图

·     首先需要配置设备工作在FCoE模式并创建VSAN,才能创建Zone别名,并进入Zone别名视图

·     进入该视图后,可配置Zone别名的相关属性

zone-alias name

[Sysname] vsan 1

[Sysname-vsan1] zone-alias name za1

[Sysname-vsan1-zone-alias-za1]

Zone视图

·     首先需要配置设备工作在FCoE模式并创建VSAN,才能创建Zone,并进入Zone视图

·     进入该视图后,可配置Zone的相关属性

zone name

[Sysname] vsan 1

[Sysname-vsan1] zone name z1

[Sysname-vsan1-zone-z1]

Zone set视图

·     首先需要配置设备工作在FCoE模式并创建VSAN,才能创建Zone set,并进入Zone set视图

·     进入该视图后,可配置Zone set的相关属性

zoneset name

[Sysname] vsan 1

[Sysname-vsan1] zoneset name zs1

[Sysname-vsan1-zoneset-zs1]

 

4.6.8  EPON功能视图

表4-22 EPON功能视图列表

视图

视图说明

进入命令

示例

FTTH视图

进入该视图后,可配置EPON系统的相关属性

ftth

[Sysname] ftth

[Sysname-ftth]

光纤备份组视图

·     创建光纤备份组,并进入光纤备份组视图

·     进入该视图后,可配置光纤备份组的相关属性

fiber-backup group

[Sysname] ftth

[Sysname-ftth] fiber-backup group 1

[Sysname-fiber-group1]

OLT端口视图

进入该视图后,可配置OLT端口的相关属性

interface olt

[Sysname] interface olt 1/0/1

[Sysname-Olt1/0/1]

ONU端口视图

·     首先需要为当前OLT端口创建虚拟的ONU接口,然后才能进入ONU接口视图

·     进入该视图后,可配置ONU的相关属性

interface onu

[Sysname] interface olt 1/0/1

[Sysname-Olt1/0/1] using onu 1

[Sysname-Olt1/0/1] quit

[Sysname] interface onu 1/0/1:1

[Sysname-Onu1/0/1:1]

 

4.7  地址分配和地址转换相关视图

4.7.1  DHCP功能视图

表4-23 DHCP功能视图列表

视图

视图说明

进入命令

示例

DHCP地址池视图

·     创建DHCP地址池,并进入DHCP地址池视图

·     进入该视图后,可配置DHCP地址池的相关属性

dhcp server ip-pool

[Sysname] dhcp server ip-pool 0

[Sysname-dhcp-pool-0]

DHCP用户类视图

·     创建DHCP用户类,并进入DHCP用户类视图

·     进入该视图后,可配置DHCP用户类的相关属性

dhcp class

[Sysname] dhcp class test

[Sysname-dhcp-class-test]

DHCP选项组视图

·     创建DHCP选项组,并进入DHCP选项组视图

·     进入该视图后,可配置DHCP选项组的相关属性

dhcp option-group

[Sysname] dhcp class test

[Sysname-dhcp-class-test]

DHCP策略视图

·     创建DHCP策略,并进入DHCP策略视图

·     进入该视图后,可配置DHCP策略的相关属性

dhcp policy

[Sysname] dhcp policy test

[Sysname-dhcp-policy-test]

DHCPv6地址池视图

·     创建DHCPv6地址池,并进入DHCPv6地址池视图

·     进入该视图后,可配置DHCPv6地址池的相关属性

ipv6 dhcp pool

[Sysname] ipv6 dhcp pool 1

[Sysname-dhcp6-pool-1]

DHCPv6用户类视图

·     创建DHCPv6用户类,并进入DHCPv6用户类视图

·     进入该视图后,可配置DHCPv6用户类的相关属性

ipv6 dhcp class

[Sysname] ipv6 dhcp class test

[Sysname-dhcp6-class-test]

DHCPv6选项组

·     创建DHCPv6选项组,并进入DHCPv6选项组视图

·     进入该视图后,可配置DHCPv6选项组的相关属性

ipv6 dhcp option-group

[Sysname] ipv6 dhcp option-group 1

[Sysname-dhcp6-option-group1]

DHCPv6策略

·     创建DHCPv6策略,并进入DHCPv6策略视图

·     进入该视图后,可配置DHCPv6策略的相关属性

ipv6 dhcp policy

[Sysname] ipv6 dhcp policy test

[Sysname-dhcp6-policy-test]

 

4.7.2  DNS功能视图

表4-24 DNS功能视图列表

视图

视图说明

进入命令

示例

DDNS策略视图

·     创建DDNS策略,并进入DDNS策略视图

·     进入该视图后,可配置DDNS策略的相关属性

ddns policy

[Sysname] ddns policy steven_policy

[Sysname-ddns-policy-1]

 

4.7.3  NAT功能视图

表4-25 NAT功能视图列表

视图

视图说明

进入命令

示例

NAT地址组视图

·     创建地址组,并进入地址组视图

·     进入该视图后,可配置地址组相关参数

nat address-group

[Sysname] nat address-group 1

NAT端口块组视图

·     创建NAT端口块组,并进入NAT端口块组视图

·     进入该视图后,可配置端口块相关参数

nat port-block-group

[Sysname] nat port-block-group 1

[Sysname-port-block-group-1]

内部服务器组视图

·     创建内部服务器组,并进入内部服务器组视图

·     进入该视图后,可配置服务器组相关参数

nat server-group

[Sysname] nat server-group 1

NAT策略视图

·     创建NAT策略,并进入NAT策略视图

·     进入该视图后,可配置多个接口的地址转换

nat policy

[Sysname] nat policy

[Sysname-nat-policy]

NAT规则视图

·     创建NAT规则,并进入NAT规则视图

·     进入该视图后,可设置报文的过滤条件

rule name

[Sysname] nat policy

[Sysname-nat-policy] rule name aaa

[Sysname-nat-policy-rule-aaa]

 

4.7.4  AFT功能视图

表4-26 AFT功能视图列表

视图

视图说明

进入命令

示例

AFT地址组视图

创建AFT地址组,并进入AFT地址组视图

aft address-group

[Sysname] aft address-group 1

[Sysname-aft-address-group-1]

 

4.8  路由相关功能视图

4.8.1  RIB功能视图

表4-27 RIB功能视图列表

视图

视图说明

进入命令

示例

RIB视图

进入RIB视图,可以配置RIB的相关参数

rib

[Sysname] rib

[Sysname-rib]

RIB IPv4地址族

·     创建RIB IPv4地址族,并进入RIB IPv4地址族视图

·     进入该视图后,可配置IPv4 RIB的相关参数

address-family ipv4

[Sysname] rib

[Sysname-rib] address-family ipv4

[Sysname-rib-ipv4]

RIB IPv6地址族

·     创建RIB IPv6地址族,并进入RIB IPv6地址族视图

·     进入该视图后,可配置IPv6 RIB的相关参数

address-family ipv6

[Sysname] rib

[Sysname-rib] address-family ipv6

[Sysname-rib-ipv6]

 

4.8.2  RIPRIPng功能视图

表4-28 RIPRIPng功能视图列表

视图

视图说明

进入命令

示例

RIP视图

·     开启RIP进程,并进入RIP视图

·     进入该视图后,可配置RIP路由协议的相关参数

rip

[Sysname] rip

[Sysname-rip-1]

RIPng视图

·     开启RIPng进程,并进入RIPng视图

·     进入该视图后,可配置RIPng路由协议的相关参数

ripng

[Sysname] ripng

[Sysname-ripng-1]

 

4.8.3  OSPFOSPFv3功能视图

表4-29 OSPFOSPFv3功能视图列表

视图

视图说明

进入命令

示例

OSPF视图

·     开启OSPF进程,并进入OSPF视图

·     进入该视图后,可配置OSPF路由协议的相关参数

ospf

[Sysname] ospf

[Sysname-ospf-1]

OSPF区域视图

·     创建OPSF区域,进入OSPF域视图

·     进入该视图后,可配置OSPF区域的相关参数

area

[Sysname] ospf

[Sysname-ospf-1] area 0

[Sysname-ospf-1-area-0.0.0.0]

OSPF IPv4地址族视图

·     创建OSPF IPv4地址族,并进入OSPF IPv4地址族视图

·     进入该视图后,可配置IPv4 OSPF路由协议的相关参数

address-family ipv4

[Sysname] ospf

[Sysname-ospf-1] address-family ipv4

[Sysname-ospf-1-ipv4]

OSPF IPv4单播拓扑视图

·     创建OSPF IPv4单播拓扑,并进入OSPF IPv4单播拓扑视图

·     进入该视图后,可配置IPv4 OSPF单播拓扑的相关参数

topology

[Sysname] ospf

[Sysname-ospf-1] address-family ipv4

[Sysname-ospf-1-ipv4] topology voice tid 100

[Sysname-ospf-1-ipv4-topo-voice]

OSPF IPv4单播拓扑区域视图

·     创建OSPF单播拓扑区域,并进入OSPF IPv4单播拓扑区域视图

·     进入该视图后,可配置IPv4 OSPF单播拓扑区域的相关参数

area

[Sysname] ospf 1

[Sysname-ospf-1] address-family ipv4 unicast

[Sysname-ospf-1-ipv4] topology 1 tid 100

[Sysname-ospf-1-ipv4-topo-1] area 0

[Sysname-ospf-1-ipv4-topo-1-area-0.0.0.0]

OSPFv3视图

·     启动OSPFv3进程,并进入OSPFv3视图

·     进入该视图后,可配置OSPFv3路由协议的相关参数

ospfv3

[Sysname] ospfv3

[Sysname-ospfv3-1]

OSPFv3区域视图

·     创建OSPFv3区域,并进入区域视图

·     进入该视图后,可配置OPSFv3区域的相关参数

area

[Sysname] ospfv3

[Sysname-ospfv3-1] area 0

[Sysname-ospfv3-1-area-0.0.0.0]

 

4.8.4  IS-IS功能视图

表4-30 IS-IS功能视图列表

视图

视图说明

进入命令

示例

IS-IS视图

·     开启IS-IS进程,并进入IS-IS视图

·     进入该视图后,可配置IS-IS路由协议的相关参数

isis

[Sysname] isis

[Sysname-isis-1] 

IS-IS IPv4地址族视图

·     创建IS-IS IPv4地址族,并进入IS-IS IPv4地址族视图

·     进入该视图后,可配置IPv4 IS-IS路由协议的相关参数

address-family ipv4

[Sysname] isis

[Sysname-isis-1] address-family ipv4

[Sysname-isis-1-ipv4]

IS-IS IPv6地址族视图

·     创建IS-IS IPv6地址族,并进入IS-IS IPv6地址族视图

·     进入该视图后,可配置IPv6 IS-IS路由协议的相关参数

address-family ipv6

[Sysname] isis 1

[Sysname-isis-1] address-family ipv6

[Sysname-isis-1-ipv6]

IS-IS IPv4单播拓扑视图

创建IS-IS IPv4单播拓扑,并进入IS-IS IPv4单播拓扑视图

topology

[Sysname] isis 1

[Sysname-isis-1] address-family ipv4

[Sysname-isis-1-ipv4] topology voice tid 4000

[Sysname-isis-1-ipv4-topo-voice]

 

4.8.5  BGP功能视图

表4-31 BGP功能视图列表

视图

视图说明

进入命令

示例

BGP视图

·     开启BGP进程,并进入BGP视图

·     进入该视图后,可配置BGP路由协议的相关参数

bgp

[Sysname] bgp 100

[Sysname-bgp-default]

BGP IPv4单播地址族视图

·     创建BGP IPv4单播地址族,并进入地址族视图

·     进入该视图后,可配置IPv4 BGP单播路由的相关参数

address-family ipv4 unicast

[Sysname] bgp 100

[Sysname-bgp-default] address-family ipv4 unicast

[Sysname-bgp-default-ipv4]

BGP IPv6单播地址族视图

·     创建BGP IPv6单播地址族,并进入地址族视图

·     进入该视图后,可配置IPv6 BGP单播路由的相关参数

address-family ipv6 unicast

[Sysname] bgp 100

[Sysname-bgp-default] address-family ipv6 unicast

[Sysname-bgp-default-ipv6]

BGP IPv4组播地址族视图

·     创建BGP IPv4组播地址族,并进入地址族视图

·     进入该视图后,可配置IPv4 BGP组播路由的相关参数

address-family ipv4 multicast

[Sysname] bgp 100

[Sysname-bgp-default] address-family ipv4 multicast

[Sysname-bgp-default-mul-ipv4]

BGP IPv6组播地址族视图

·     创建BGP IPv6组播地址族,并进入地址族视图

·     进入该视图后,可配置IPv6 BGP组播路由的相关参数

address-family ipv6 multicast

[Sysname] bgp 100

[Sysname-bgp-default] address-family ipv6 multicast

[Sysname-bgp-default-mul-ipv6]

BGP-VPN IPv4单播地址族视图

·     创建BGP-VPN IPv4单播地址族,并进入地址族视图

·     进入该视图后,可配置BGP-VPN IPv4单播路由的相关参数

address-family ipv4 unicast

[Sysname] bgp 100

[Sysname-bgp-default] ip vpn-instance vpn1

[Sysname-bgp-default-vpn1] address-family ipv4 unicast

[Sysname-bgp-default-ipv4-vpn1]

BGP-VPN IPv6单播地址族视图

·     创建BGP-VPN IPv6单播地址族,并进入地址族视图

·     进入该视图后,可配置BGP-VPN IPv6单播路由的相关参数

address-family ipv4 unicast

[Sysname] bgp 100

[Sysname-bgp-default] ip vpn-instance vpn1

[Sysname-bgp-default-vpn1] address-family ipv6 unicast

[Sysname-bgp-default-ipv6-vpn1]

BGP LS地址族视图

·     创建BGP LS地址族,并进入地址族视图

·     进入该视图后,可以配置BGP发布链路状态信息的相关参数

address-family link-state

[Sysname] bgp 100

[Sysname-bgp-default] address-family link-state

[Sysname-bgp-default-LS]

BGP RPKI视图

·     创建BGP RPKI,并进入RPKI视图

·     进入该视图后,可以配置BGP RPKI相关参数

RPKI

[Sysname] bgp 100

[Sysname-bgp-default] RPKI

[Sysname--bgp-default-rpki]

BMP Sever视图

·     创建BMP Sever,并进入BMP Sever视图

·     进入该视图后,可以配置BMP Sever相关参数

bmp server

[Sysname] bmp server 5

[Sysname-bmpserver-5]

 

4.8.6  策略路由功能视图

表4-32 策略路由功能视图列表

视图

视图说明

进入命令

示例

策略节点视图

·     创建策略节点,并进入策略节点视图

·     进入该视图后,可以配置策略节点的相关参数

policy-based-route

[Sysname] policy-based-route policy1 permit node 10

[Sysname-pbr-policy1-10]

IPv6策略节点视图

·     创建IPv6策略节点,并进入IPv6策略节点视图

·     进入该视图后,可以配置IPv6策略节点的相关参数

ipv6 policy-based-route

[Sysname] ipv6 policy-based-route aaa permit node 10

[Sysname-pbr6-aaa-10]

 

4.8.7  路由策略功能视图

表4-33 路由策略功能视图列表

视图

视图说明

进入命令

示例

路由策略视图

·     创建路由策略,并进入路由策略视图

·     进入该视图后,可配置具体路由策略

route-policy

[Sysname] route-policy policy1 permit node 10

[Sysname-route-policy-policy1-10]

 

4.8.8  MTR功能视图

表4-34 MTR功能视图列表

视图

视图说明

进入命令

示例

全局地址族视图

·     创建全局地址族,并进入全局地址族视图

·     进入该视图后,可创建拓扑

global-address-family ipv4

[Sysname] global-address-family ipv4 unicast

[Sysname-af]

拓扑视图

创建一个拓扑,并进入拓扑视图

topology

[Sysname] global-address-family ipv4 unicast

[Sysname-af] topology mt

[Sysname-af-topology-mt]

接口IPv4单播拓扑视图

将接口与指定拓扑进行关联,并进入接口IPv4单播拓扑视图

topology ipv4

[Sysname] interface loopback 0

[Sysname-LoopBack0] topology ipv4 unicast mt1

[Sysname-LoopBack0-topology-1]

多拓扑策略节点视图

·     创建多拓扑策略节点,并进入多拓扑策略节点视图

·     进入该视图后,可配置多拓扑策略相关参数

mtr-policy

[Sysname] mtr-policy mtr node 0

[Sysname-mtr-policy-mtr-0]

 

4.8.9  DCN功能视图

表4-35 DCN功能视图列表

视图

视图说明

进入命令

示例

DCN视图

进入RIB视图,可以配置RIB的相关参数

dcn

[Sysname] dcn

[Sysname-dcn]

 

4.9  组播相关功能视图

4.9.1  IGMP-SnoopingMLD-Snooping功能视图

表4-36 IGMP-SnoopingMLD-Snooping功能视图列表

视图

视图说明

进入命令

示例

IGMP-Snooping视图

·     开启IGMP Snooping功能,并进入IGMP Snooping视图

·     进入该视图后,可配置IGMP Snooping的相关功能

igmp-snooping

[Sysname] igmp-snooping

[Sysname-igmp-snooping]

MLD-Snooping视图

·     开启MLD Snooping功能,并进入MLD Snooping视图

·     进入该视图后,可配置MLD Snooping的相关功能

mld-snooping

[Sysname] mld-snooping

[Sysname-mld-snooping]

 

4.9.2  组播VLAN功能视图

表4-37 组播VLAN功能视图列表

视图

视图说明

进入命令

示例

组播VLAN视图

·     只有开启IGMP Snooping功能、创建与组播VLAN对应的VLAN并在该VLAN内开启IGMP Snooping功能后,才能创建组播VLAN,并进入组播VLAN视图

·     进入该视图后,可配置组播VLAN的相关功能

multicast-vlan vlan-id

[Sysname] igmp-snooping

[Sysname-igmp-snooping] quit

[Sysname] vlan 100

[Sysname-vlan100] igmp-snooping enable

[Sysname-vlan100] quit

[Sysname] multicast-vlan 100

[Sysname-mvlan-100]

IPv6组播VLAN视图

·     只有开启MLD Snooping功能创建与IPv6组播VLAN对应的VLAN在该VLAN内开启MLD Snooping功能后,才能创建IPv6组播VLAN,并进入IPv6组播VLAN视图

·     进入该视图后,可配置IPv6组播VLAN的相关功能

ipv6 multicast-vlan vlan-id

[Sysname] mld-snooping

[Sysname-mld-snooping] quit

[Sysname] vlan 100

[Sysname-vlan100] mld-snooping enable

[Sysname-vlan100] quit

[Sysname] ipv6 multicast-vlan 100

[Sysname-ipv6-mvlan-100]

 

4.9.3  组播路由与转发功能视图

表4-38 组播路由与转发功能视图列表

视图

视图说明

进入命令

示例

MRIB视图

·     开启组播路由与转发功能,并进入MRIB视图

·     进入该视图后,可配置组播路由与转发的相关功能

multicast routing [ vpn-instance vpn-instance-name ]

[Sysname] multicast routing

[Sysname-mrib]

IPv6 MRIB视图

·     开启组播路由与转发功能,并进入MRIB视图

·     进入该视图后,可配置IPv6组播路由与转发的相关功能

ipv6 multicast routing [ vpn-instance vpn-instance-name ]

[Sysname] ipv6 multicast routing

[Sysname-mrib6]

 

4.9.4  IGMPMLD功能视图

表4-39 IGMPMLD功能视图列表

视图

视图说明

进入命令

示例

IGMP视图

·     只有开启组播路由功能后,才能进入IGMP视图

·     进入该视图后,可配置IGMP的相关功能

igmp [ vpn-instance vpn-instance-name ]

[Sysname] multicast routing

[Sysname-mrib] quit

[Sysname] igmp

[Sysname-igmp]

MLD视图

·     只有开启IPv6组播路由功能后,才能进入MLD视图

·     进入该视图后,可配置MLD的相关功能

mld [ vpn-instance vpn-instance-name ]

[Sysname] ipv6 multicast routing

[Sysname-mrib6] quit

[Sysname] mld

[Sysname-mld]

 

4.9.5  PIMIPv6 PIM功能视图

表4-40 PIMIPv6 PIM功能视图列表

视图

视图说明

进入命令

示例

PIM视图

·     只有开启组播路由功能后,才能进入PIM视图

·     进入该视图后,可配置PIM的相关功能

pim [ vpn-instance vpn-instance-name ]

[Sysname] multicast routing

[Sysname-mrib] quit

[Sysname] pim

[Sysname-pim]

IPv6 PIM视图

·     只有开启IPv6组播路由功能后,才能进入IPv6 PIM视图

·     进入该视图后,可配置IPv6 PIM的相关功能

ipv6 pim [ vpn-instance vpn-instance-name ]

[Sysname] ipv6 multicast routing

[Sysname-mrib6-mvpn] quit

[Sysname] ipv6 pim

[Sysname-pim6]

 

4.9.6  MSDP功能视图

表4-41 MSDP功能视图列表

视图

视图说明

进入命令

示例

MSDP视图

·     只有开启组播路由功能后,才能进入MSDP视图

·     进入该视图后,可配置MSDP的相关功能

msdp [ vpn-instance vpn-instance-name ]

[Sysname] multicast routing

[Sysname-mrib] quit

[Sysname] msdp

[Sysname-msdp]

 

4.9.7  组播VPN功能视图

表4-42 组播VPN功能视图列表

视图

视图说明

进入命令

示例

MVPN视图

·     创建MVPN,并进入MVPN视图

·     进入该视图后,可配置MVPN的相关功能

multicast-vpn vpn-instance vpn-instance-name mode { mdt | rsvp-te }

[Sysname] multicast-vpn vpn-instance mvpn mode mdt

[Sysname-mvpn-mvpn]

MVPN IPv4地址族视图

·     创建MVPN IPv4地址族,并进入MVPN IPv4地址族视图。

·     进入该视图后,可配置MVPN IPv4相关功能

address-family ipv4

[Sysname] multicast-vpn vpn-instance mvpn mode mdt

[Sysname-mvpn-mvpn] address-family ipv4

[Sysname-mvpn-mvpn-ipv4]

MVPN IPv6地址族视图

·     创建MVPN IPv6地址族,并进入MVPN IPv6地址族视图。

·     进入该视图后,可配置MVPN IPv4相关功能

address-family ipv6

[Sysname] multicast-vpn vpn-instance mvpn mode mdt

[Sysname-mvpn-mvpn] address-family ipv6

[Sysname-mvpn-mvpn-ipv6]

BGP IPv4 MVPN地址族视图

·     创建BGP IPv4 MVPN地址族,并进入BGP IPv4 MVPN地址族视图。

·     进入该视图后,可配置BGP IPv4 MVPN相关功能

address-family ipv4 mvpn

[Sysname] bgp 100

[Sysname-bgp-default] address-family ipv4 mvpn

[Sysname-bgp-default-mvpn]

BGP IPv4 MDT地址族视图

·     创建BGP IPv4 MDT地址族,并进入BGP IPv4 MDT地址族视图。

·     进入该视图后,可配置BGP IPv4 MDT相关功能

address-family ipv4 mdt

[Sysname] bgp 100

[Sysname-bgp-default] address-family ipv4 mdt

[Sysname-bgp-default-mdt]

 

4.10  MPLS相关功能视图

MPLS功能包括LDPMPLS TEMPLS L3VPNMPLS L2VPNVPLS等。为了便于配置管理,每个功能都有其独立的视图。

4.10.1  LDP功能视图

表4-43 LDP功能视图列表

视图

视图说明

进入命令

示例

LDP视图

进入该视图后,可以配置LDP协议的相关参数

mpls ldp

[Sysname] mpls ldp

[Sysname-ldp]

LDP对等体视图

·     创建LDP对等体,并进入LDP对等体视图

·     进入该视图后,可以配置当前设备与该LDP对等体连接时使用的相关参数

targeted-peer

[Sysname] mpls ldp

[Sysname-ldp] targeted-peer 3.3.3.3

[Sysname-ldp-peer-3.3.3.3]

LDP-VPN实例视图

·     首先需要创建VPN实例(请参见4-47),才能配置LDP支持VPN实例并进入LDP-VPN实例视图

·     进入该视图后,可以在VPN实例中配置LDP协议的相关参数

vpn-instance

[Sysname] mpls ldp

[Sysname-ldp] vpn-instance vpn1

[Sysname-ldp-vpn-instance-vpn1]

 

4.10.2  MPLS TE功能视图

表4-44 MPLS TE功能视图列表

视图

视图说明

进入命令

示例

MPLS TE视图

进入该视图后,可以配置MPLS TE相关参数

mpls te

[Sysname] mpls te

[Sysname-te]

显式路径视图

·     创建显式路径,并进入显式路径视图

·     进入该视图后,可以配置显式路径中的节点

explicit-path

[Sysname] explicit-path path1

[Sysname-explicit-path-path1]

MPLS TE自动隧道备份视图

进入该视图后,可以配置MPLS TE自动隧道备份相关功能

auto-tunnel backup

[Sysname] mpls te

[Sysname-te] auto-tunnel backup

[Sysname-te-auto-bk]

 

4.10.3  RSVP功能视图

表4-45 RSVP功能视图列表

视图

视图说明

进入命令

示例

RSVP视图

·     全局开启RSVP能力,并进入RSVP视图

·     进入该视图后,可以配置RSVP相关参数

rsvp

[Sysname] rsvp

[Sysname-rsvp]

RSVP邻居视图

·     创建RSVP认证邻居,并进入RSVP邻居视图

·     进入该视图后,可以配置RSVP邻居相关参数

peer

[Sysname] rsvp

[Sysname-rsvp] peer 1.1.1.1

[Sysname-rsvp-peer-1.1.1.1]

 

4.10.4  隧道策略功能视图

表4-46 隧道策略功能视图列表

视图

视图说明

进入命令

示例

隧道策略视图

·     创建隧道策略,并进入隧道策略视图

·     进入该视图后,可以配置隧道的优先级顺序和负载分担条数

tunnel-policy

[Sysname] tunnel-policy po1

[Sysname-tunnel-policy-po1]

 

4.10.5  MPLS L3VPN功能视图

MPLS L3VPN功能包含的视图以及视图之间的关系如4-1所示。

图4-1 MPLS L3VPN功能视图关系示意图

 

表4-47 MPLS L3VPN功能视图列表

视图

视图说明

进入命令

示例

VPN实例视图

·     创建VPN实例,并进入VPN实例视图

·     进入该视图后,可以配置VPN实例的属性参数

ip vpn-instance

[Sysname] ip vpn-instance vpn1

[Sysname-vpn-instance-vpn1]

VPN实例IPv4 VPN视图

进入该视图后可以配置IPv4 VPN的参数,如IPv4 VPN应用的出方向路由策略、入方向路由策略等

address-family ipv4

[Sysname] ip vpn-instance vpn1

[Sysname-vpn-instance-vpn1] address-family ipv4

[Sysname-vpn-ipv4-vpn1]

VPN实例IPv6 VPN视图

进入该视图后可以配置IPv6 VPN的参数,如IPv6 VPN应用的出方向路由策略、入方向路由策略等

address-family ipv6

[Sysname] ip vpn-instance vpn1

[Sysname-vpn-instance-vpn1] address-family ipv6

[Sysname-vpn-ipv6-vpn1]

BGP VPNv4地址族视图

·     创建BGP VPNv4地址族,并进入BGP VPNv4地址族视图

·     进入该视图后,可以配置BGP VPNv4对等体和路由信息的相关参数

address-family vpnv4

[Sysname] bgp 1

[Sysname-bgp-default] address-family vpnv4

[Sysname-bgp-default-vpnv4]

BGP VPNv6地址族视图

·     创建BGP VPNv6地址族,并进入BGP VPNv6地址族视图

·     进入该视图后,可以配置BGP VPNv6对等体和路由信息的相关参数

address-family vpnv6

[Sysname] bgp 1

[Sysname-bgp-default] address-family vpnv6

[Sysname-bgp-default-vpnv6]

BGP-VPN实例视图

·     只有创建相应的VPN实例并为其配置RD后,才能够进入BGP-VPN实例视图

·     进入该视图后,可以在指定的VPN实例中配置BGP协议的参数

ip vpn-instance

[Sysname] ip vpn-instance vpn1

[Sysname-vpn-instance-vpn1] route-distinguisher 100:1

[Sysname-vpn-instance-vpn1] quit

[Sysname] bgp 100

[Sysname-bgp-default] ip vpn-instance vpn1

[Sysname-bgp-default-vpn1]

BGP-VPN VPNv4地址族视图

·     创建BGP-VPN VPNv4地址族,并进入BGP-VPN VPNv4地址族视图

·     进入该视图后,可以配置嵌套VPN组网中运营商PE和运营商CE之间BGP VPNv4对等体和路由信息的相关参数

address-family vpnv4

[Sysname] bgp 100

[Sysname-bgp-default] ip vpn-instance vpn1

[Sysname-bgp-default-vpn1] address-family vpnv4

[Sysname-bgp-default-vpnv4-vpn1]

 

4.10.6  MPLS L2VPN功能视图

MPLS L2VPN功能包含的视图以及视图之间的关系如4-2所示。

图4-2 MPLS L2VPN功能视图关系示意图

 

表4-48 MPLS L2VPN功能视图列表

视图

视图说明

进入命令

示例

以太网服务实例视图

·     创建以太网服务实例,并进入以太网服务实例视图

·     进入该视图后,可以为当前以太网服务实例配置报文匹配规则等

service-instance

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] service-instance 100

[Sysname-GigabitEthernet1/0/1-srv100]

BGP L2VPN地址族视图

·     创建BGP L2VPN地址族,并进入BGP L2VPN地址族视图

·     进入该视图后,可以配置设备在MPLS L2VPN环境中发布BGP L2VPN路由时的相关参数

address-family l2vpn

[Sysname] bgp 100

[Sysname-bgp-default] address-family l2vpn

[Sysname-bgp-default-l2vpn]

交叉连接组视图

·     需要先开启L2VPN功能,才能创建交叉连接组,并进入交叉连接组视图

·     进入该视图后,可以配置多条交叉连接,每条交叉连接可以使用不同的方式(LDPBGP、静态方式)建立PW

xconnect-group

[Sysname] l2vpn enable

[Sysname] xconnect-group vpn1

[Sysname-xcg-vpn1]

交叉连接视图

·     创建交叉连接,并进入交叉连接视图

·     进入该视图后,可以配置构成交叉连接的ACPW,并配置交叉连接相关参数

connection

[Sysname] xconnect-group vpn1

[Sysname-xcg-vpn1] connection ac2pw

[Sysname-xcg-vpn1-ac2pw]

交叉连接PW视图

·     创建交叉连接的PW,并进入交叉连接PW视图

·     进入该视图后,可以配置交叉连接的备份PW,并可以配置交叉连接的相关参数

peer

[Sysname] xconnect-group vpn1

[Sysname-xcg-vpn1] connection pw2pw

[Sysname-xcg-vpn1-pw2pw] peer 4.4.4.4 pw-id 200

[Sysname-xcg-vpn1-pw2pw-4.4.4.4-200]

交叉连接备份PW视图

创建交叉连接的备份PW,并进入交叉连接备份PW视图

backup-peer

[Sysname] xconnect-group vpn2

[Sysname-xcg-vpn2] connection pw2pw

[Sysname-xcg-vpn2-pw2pw] peer 6.6.6.6 pw-id 100 in-label 16 out-label 17

[Sysname-xcg-vpn2-pw2pw-6.6.6.6-100] backup-peer 7.7.7.7 pw-id 200 in-label 18 out-label 19

[Sysname-xcg-vpn2-pw2pw-6.6.6.6-100-backup]

交叉连接Bypass PW视图

创建交叉连接的Bypass PW,并进入交叉连接Bypass PW视图

bypass-peer

[Sysname] xconnect-group vpn2

[Sysname-xcg-vpn2] connection pw2pw

[Sysname-xcg-vpn2-pw2pw] peer 6.6.6.6 pw-id 100 in-label 16 out-label 17

[Sysname-xcg-vpn2-pw2pw-6.6.6.6-100] bypass-peer 7.7.7.7 pw-id 200 in-label 18 out-label 19

[Sysname-xcg-vpn2-pw2pw-6.6.6.6-100-bypass]

交叉连接组自动发现视图

·     指定交叉连接组采用BGP方式自动发现邻居、建立PW,并进入交叉连接组自动发现视图

·     进入该视图后,可以配置BGP信令协议的相关参数,如本端站点、远端站点、Route Target属性等,以便PE设备通过BGP信令协议自动发现远端PE设备,并建立连接两端站点的PW

auto-discovery bgp

[Sysname] xconnect-group bbb

[Sysname-xcg-bbb] auto-discovery bgp

[Sysname-xcg-bbb-auto]

站点视图

·     创建本地站点,并进入站点视图

·     进入该视图后,可以配置远端站点,以便在本地站点和远端站点之间建立PW

site

[Sysname] xconnect-group bbb

[Sysname-xcg-bbb] auto-discovery bgp

[Sysname-xcg-bbb-auto] site 1 range 30 default-offset 0

[Sysname-xcg-bbb-auto-1]

自动发现交叉连接视图

·     在创建交叉连接的同时,采用BGP方式在当前站点和指定的远端站点之间建立一条PW,该PW与该交叉连接关联,并进入自动发现交叉连接视图

·     进入该视图后,可以指定与交叉连接关联的AC

connection remote-site-id

[Sysname] xconnect-group bbb

[Sysname-xcg-bbb] auto-discovery bgp

[Sysname-xcg-bbb-auto] site 1 range 10

[Sysname-xcg-bbb-auto-1] connection remote-site-id 3

[Sysname-xcg-bbb-auto-1-3]

PW模板视图

·     创建PW模板,并进入PW模板视图

·     进入该视图后,可以配置当前PW模板的内容

pw-class

[Sysname] pw-class pw100

[Sysname-pw-pw100]

电路仿真接口视图

进入该视图后,可以配置电路仿真接口相关参数

interface circuit-emulation

[Sysname] interface circuit-emulation2/3/0:0

[Sysname-Circuit-Emulation2/3/0:0]

电路仿真类视图

·     创建电路仿真类,并进入电路仿真类视图

·     进入该视图后,可以指定电路仿真的一组参数或属性,如Jitter-buffer的大小、每个分组净载荷的大小及分组丢失时的填充字符

cem-class

[Sysname] cem-class satop

[Sysname-cem-satop]

 

4.10.7  VPLS功能视图

VPLS功能包含的视图以及视图之间的关系如4-3所示。

图4-3 VPLS功能视图关系示意图

 

表4-49 VPLS功能视图列表

视图

视图说明

进入命令

示例

以太网服务实例视图

·     创建以太网服务实例,并进入以太网服务实例视图

·     进入该视图后,可以为当前以太网服务实例配置报文匹配规则等

service-instance

[Sysname] interface gigabitethernet 1/0/1

[Sysname-GigabitEthernet1/0/1] service-instance 100

[Sysname-GigabitEthernet1/0/1-srv100]

BGP L2VPN地址族视图

·     创建BGP L2VPN地址族,并进入BGP L2VPN地址族视图

·     进入该视图后,可以配置设备在VPLS环境中发布BGP L2VPN路由时的相关参数

address-family l2vpn

[Sysname] bgp 100

[Sysname-bgp-default] address-family l2vpn

[Sysname-bgp-default-l2vpn]

VSI视图

·     需要先开启L2VPN功能,才能创建VSI实例,并进入VSI视图

·     进入该视图后,可以配置当前VSI实例的相关属性

vsi

[Sysname] l2vpn enable

[Sysname] vsi aaa static

[Sysname-vsi-aaa]

VSI LDP信令视图

·     指定VSI使用LDP信令的FEC 128方式建立PW,并进入VSI LDP信令视图

·     进入该视图后,可以创建LDP PW

pwsignaling ldp

[Sysname] vsi vpn1

[Sysname-vsi-vpn1] pwsignaling ldp

[Sysname-vsi-vpn1-ldp]

VSI静态配置视图

·     指定VSI采用静态配置方式建立PW,并进入VSI静态配置视图

·     进入该视图后,可以创建静态PW

pwsignaling static

[Sysname] vsi vpn1

[Sysname-vsi-vpn1] pwsignaling static

[Sysname-vsi-vpn1-static]

VSI LDP PW视图

·     VSI LDP信令视图下执行peer命令后,可以创建VSI LDP PW,并进入VSI LDP PW视图

·     进入该视图后,可以配置VSI LDP PW的相关参数

peer

[Sysname] vsi vpn1

[Sysname-vsi-vpn1] pwsignaling ldp

[Sysname-vsi-vpn1-ldp] peer 4.4.4.4 pw-id 200 no-split-horizon

[Sysname-vsi-vpn1-ldp-4.4.4.4-200]

VSI静态PW视图

·     VSI静态配置视图下执行peer命令后,可以创建VSI静态PW,并进入VSI静态PW视图

·     进入该视图后,可以配置VSI静态PW的相关参数

peer

[Sysname] vsi vpn1

[Sysname-vsi-vpn1] pwsignaling static

[Sysname-vsi-vpn1-static] peer 5.5.5.5 pw-id 200 in-label 100 out-label 200 no-split-horizon

[Sysname-vsi-vpn1-static-5.5.5.5-200]

VSI LDP备份PW视图或VSI静态备份PW视图

·     创建VPLS的备份PW,并进入VSI LDP备份PW视图或VSI静态备份PW视图

·     VSI LDP PW视图下执行backup-peer命令后,进入VSI LDP备份PW视图;VSI静态PW视图下执行backup-peer命令后,进入VSI静态备份PW视图

backup-peer

[Sysname] vsi vpn1

[Sysname-vsi-vpn1] pwsignaling ldp

[Sysname-vsi-vpn1-ldp] peer 4.4.4.4 pw-id 100

[Sysname-vsi-vpn1-ldp-4.4.4.4-100] backup-peer 5.5.5.5 pw-id 200

[Sysname-vsi-vpn1-ldp-4.4.4.4-100-backup]

VSI自动发现视图

·     指定VSI采用BGP方式自动发现邻居,并进入VSI自动发现视图

·     进入该视图后,可以配置通过BGP协议自动发现远端PE设备后,采用LDP还是BGP信令协议在PE之间建立PW

auto-discovery

[Sysname] vsi aaa

[Sysname-vsi-aaa] auto-discovery bgp

[Sysname-vsi-aaa-auto]

VSI自动发现BGP信令视图

·     指定采用BGP协议建立PW,并进入VSI自动发现BGP信令视图

·     进入该视图后,可以创建本地站点

signaling-protocol bgp

[Sysname] vsi aaa

[Sysname-vsi-aaa] auto-discovery bgp

[Sysname-vsi-aaa-auto] signaling-protocol bgp

[Sysname-vsi-aaa-auto-bgp]

VSI自动发现LDP信令视图

·     指定采用LDP协议的FEC 129方式建立PW,并进入VSI自动发现LDP信令视图

·     进入该视图后,可以配置VSIVPLS ID

signaling-protocol ldp

[Sysname] vsi aaa

[Sysname-vsi-aaa] auto-discovery bgp

[Sysname-vsi-aaa-auto] signaling-protocol ldp

[Sysname-vsi-aaa-auto-ldp]

PW模板视图

·     创建PW模板,并进入PW模板视图

·     进入该视图后,可以配置当前PW模板的内容

pw-class

[Sysname] pw-class pw100

[Sysname-pw-pw100]

 

4.10.8  L2VPN接入L3VPNIP骨干网功能视图

表4-50 L2VPN接入L3VPNIP骨干网功能视图列表

视图

视图说明

进入命令

示例

L2VE接口视图

·     创建一个L2VE接口,并进入L2VE接口视图

·     进入该视图后,可配置L2VE接口相关属性

interface ve-l2vpn  interface-number

[Sysname] interface ve-l2vpn 100

[Sysname-VE-L2VPN100]

L2VE子接口视图

·     创建一个L2VE子接口,并进入L2VE子接口视图,创建L2VE子接口之前,该子接口对应的主接口必须已经存在

·     进入该视图后,可配置L2VE子接口相关属性

interface ve-l2vpn interface-number.subnumber

[Sysname] interface ve-l2vpn 100.10

[Sysname-VE-L2VPN100.10]

L3VE接口视图

·     创建一个L3VE接口,并进入L3VE接口视图

·     进入该视图后,可配置L3VE接口相关属性

interface ve-l3vpn  interface-number

[Sysname] interface ve-l3vpn 100

[Sysname-VE-L3VPN100]

L3VE子接口视图

·     创建一个L3VE子接口,并进入L3VE子接口视图,创建L3VE子接口之前,该子接口对应的主接口必须已经存在

·     进入该视图后,可配置L3VE子接口相关属性

interface ve-l3vpn interface-number.subnumber

[Sysname] interface ve-l3vpn 100.10

[Sysname-VE-L3VPN100.10]

 

4.10.9  MPLS-TP OAM功能视图

表4-51 MPLS-TP OAM功能视图列表

视图

视图说明

进入命令

示例

MEG视图

·     创建MEGMaintenance Entity Group,维护实体组),并进入MEG视图

·     进入该视图后,可以创建MEMaintenance Entity,维护实体)、配置MPLS-TP OAM检测类型及检测参数

mpls-tp meg

[Sysname] mpls-tp meg meg1

[Sysname-meg-meg1]

ME视图

创建ME,并进入ME视图

me

[Sysname] mpls-tp meg meg1

[Sysname-meg-meg1] me 100 remote-mep-id 101 pw peer 1.1.1.1 pw-id 102

[Sysname-meg-meg1-100]

 

4.10.10  MPLS保护倒换功能视图

表4-52 MPLS保护倒换视图列表

视图

视图说明

进入命令

示例

MPLS保护倒换视图

·     开启MPLS保护倒换功能,并进入MPLS保护倒换视图

·     进入该视图后,可以配置MPLS保护倒换相关参数

mpls protection

[Sysname] mpls protection

[Sysname-mpls-protection]

 

4.11  流量控制相关功能视图

4.11.1  ACL功能视图

表4-53 ACL功能视图列表

视图

视图说明

进入命令

示例

IPv4基本ACL视图

·     创建IPv4基本ACL,并进入IPv4基本ACL视图

·     进入该视图后,可以配置当前ACL的匹配规则、ACL描述信息、ACL规则的描述信息、ACL规则的步长和开启ACL规则的加速匹配功能

·     acl number

·     acl basic

[Sysname] acl number 2000

[Sysname-acl-ipv4-basic-2000]

[Sysname] acl basic 2000

[Sysname-acl-ipv4-basic-2000]

IPv4高级ACL视图

·     创建IPv4高级ACL,并进入IPv4高级ACL视图

·     进入该视图后,可以配置当前ACL的匹配规则、ACL描述信息、ACL规则的描述信息、ACL规则的步长和开启ACL规则的加速匹配功能

·     acl number

·     acl advanced

[Sysname] acl number 3000

[Sysname-acl-ipv4-adv-3000]

[Sysname] acl advanced 3000

[Sysname-acl-ipv4-adv-3000]

二层ACL视图

·     创建二层ACL,并进入二层ACL视图

·     进入该视图后,可以配置当前ACL的匹配规则、ACL描述信息、ACL规则的描述信息、ACL规则的步长和开启ACL规则的加速匹配功能

·     acl number

·     acl mac

[Sysname] acl number 4000

[Sysname-acl-mac-4000]

[Sysname] acl mac 4000

[Sysname-acl-mac-4000]

 

IPv6基本ACL视图

·     创建IPv6基本ACL,并进入IPv6基本ACL视图

·     进入该视图后,可以配置当前ACL的匹配规则、ACL描述信息、ACL规则的描述信息、ACL规则的步长和开启ACL规则的加速匹配功能

·     acl ipv6 number

·     acl ipv6 basic

[Sysname] acl ipv6 number 2000

[Sysname-acl-ipv6-basic-2000]

[Sysname] acl ipv6 basic 2000

[Sysname-acl-ipv6-basic-2000]

IPv6高级ACL视图

·     创建IPv6高级ACL,并进入IPv6高级ACL视图

·     进入该视图后,可以配置当前ACL的匹配规则、ACL描述信息、ACL规则的描述信息、ACL规则的步长和开启ACL规则的加速匹配功能

·     acl ipv6 number

·     acl ipv6 advanced

[Sysname] acl ipv6 number 3000

[Sysname-acl-ipv6-adv-3000]

[Sysname] acl ipv6 advanced 3000

[Sysname-acl-ipv6-adv-3000]

用户自定义ACL视图

·     创建用户自定义ACL,并进入用户自定义ACL视图

·     进入该视图后,可以配置当前ACL的匹配规则、ACL描述信息、ACL规则的描述信息

·     acl number

·     acl user-defined

[Sysname] acl number 5000

[Sysname-acl-user-5000]

[Sysname] acl user-defined 5000

[Sysname-acl-user-5000]

无线客户端ACL视图

·     创建无线客户端ACL,并进无线客户端ACL视图

·     进入该视图后,可以配置当前ACL的匹配规则、ACL描述信息、ACL规则的描述信息和ACL规则的步长

acl wlan client

<Sysname> system-view

[Sysname] acl wlan client 100

[Sysname-acl-client-100]

无线接入点ACL视图

·     创建无线接入点ACL,并进入无线接入点ACL视图

·     进入该视图后,可以配置当前ACL的匹配规则、ACL描述信息、ACL规则的描述信息和ACL规则的步长

acl wlan ap

<Sysname> system-view

[Sysname] acl wlan ap 200

[Sysname-acl-ap-200]

 

4.11.2  QoS功能视图

表4-54 QoS功能视图列表

视图

视图说明

进入命令

示例

QoS策略视图

·     创建QoS策略,并进入QoS策略视图

·     进入该视图后,可以为当前QoS策略配置流分类与流行为的对应关系

qos policy

[Sysname] qos policy user1

[Sysname-qospolicy-user1]

流行为视图

·     创建流行为,并进入流行为视图

·     进入该视图后,可以配置当前流行为中的各种动作

traffic behavior

[Sysname] traffic behavior behavior1

[Sysname-behavior-behavior1]

流分类视图

·     创建流分类,并进入流分类视图

·     进入该视图后,可以为当前流分类配置匹配条件

traffic classifier

[Sysname] traffic classifier class1

[Sysname-classifier-class1]

优先级映射表视图

进入该视图后,可以修改当前映射表中的优先级映射关系

qos map-table

[Sysname] qos map-table dot1p-dp

[Sysname-maptbl-dot1p-dp]

WRED表视图

·     创建WRED表,并进入WRED表视图

·     进入该视图后,可以为当前的WRED表配置相应的流量丢弃参数

qos wred queue table

[Sysname] qos wred queue table table1

[Sysname-wred-table-table1]

控制平面视图

进入该视图后,可以在当前的控制平面上应用QoS策略

control-plane

[Sysname] control-plane slot 3

[Sysname-cp-slot3]

管理口控制平面视图

进入该视图后,可以在当前的管理口控制平面上应用QoS策略

control-plane management

<Sysname> system-view

[Sysname] control-plane management

[Sysname-cp-management]

转发策略视图

·     创建HQoS转发策略,并进入转发策略视图

·     进入该视图后,可以配置转发策略的调度规则和带宽保证等参数

qos forwarding-profile

[Sysname] qos forwarding-profile test

[Sysname_51-hqos-fp-test]

丢弃策略视图

·     创建丢弃策略,并进入丢弃策略视图

·     进入该视图后,可以配置丢弃策略

qos drop-profile

<Sysname> system-view

[Sysname] qos drop-profile testdp

[Sysname-dp-testdp]

调度策略视图

·     创建HQoS调度策略,并进入调度策略视图

·     进入该视图后,可以在调度策略中嵌套转发组并为该转发组指定转发策略

qos scheduler-policy

[Sysname] qos scheduler-policy test

[Sysname-hqos-sp-test]

转发组视图

·     创建HQoS转发组,并进入转发组视图

·     进入该视图后,可以配置转发组下嵌套的子转发组,并指定子转发组的转发策略

qos forwarding-group

[Sysname] qos forwarding-group test

[Sysname-hqos-fg-test]

 

4.11.3  Flowspec功能视图

表4-55 Flowspec功能视图列表

视图

视图说明

进入命令

示例

Flowspec视图

·     创建Flowspec,并进入Flowspec视图

·     进入该视图后,可以创建Flowspec IPv4地址族

flowspec

<Sysname> system-view

[Sysname] flowspec

[Sysname-flowspec]

Flowspec路由视图

·     创建Flowspec路由,并进入Flowspec路由视图

·     进入该视图后,可以配置Flowspec路由中的流量动作、匹配规则

flow-route

<Sysname> system-view

[Sysname] flow-route route1

[Sysname-flow-route-route1]

IPv4 Flowspec VPN视图

·     创建IPv4 Flowspec VPN,并进入IPv4 Flowspec VPN视图

·     进入该视图后,可以配置IPv4 Flowspec VPNVPN target

address-family ipv4 flowspec

<Sysname> system-view

[Sysname] ip vpn-instance vpn1

[Sysname-vpn-instance-vpn1] address-family ipv4 flowspec

[Sysname-vpn-ipv4-vpn1-flowspec]

BGP IPv4 Flowspec地址族

·     创建BGP IPv4 Flowspec地址族,并进入BGP IPv4 Flowspec地址族视图

·     进入该视图后,可以配置BGP Flowspec邻居的Flowspec路由的合法性验证功能BGP Flowspec邻居的Flowspec路由的重定向下一跳合法性验证功能

address-family ipv4 flowspec

<Sysname> system-view

[Sysname] bgp 100

[Sysname-bgp-default] address-family ipv4 flowspec

[Sysname-bgp-default-ipv4-flowspec]

 

4.11.4  WAAS功能视图

表4-56 WAAS功能视图列表

视图

视图说明

进入命令

示例

WAAS策略视图

·     创建WAAS策略,并进入WAAS策略视图

·     进入该视图后,可配置WAAS策略的相关属性

waas policy

[Sysname] waas policy waas_default

[Sysname-waaspolicy-waas_default]

WAAS类视图

·     创建WAAS类,并进入WAAS类视图

·     进入该视图后,可配置WAAS类的相关属性

waas class

[Sysname] waas class waas_global

[Sysname-waasclass-waas_global]

WAAS策略类动作视图

·     创建WAAS策略引用的指定类,并进入WAAS策略类动作视图

·     进入该视图后,可配置WAAS策略类动作视图的相关属性

class

[Sysname] waas policy waas_global

[Sysname-waaspolicy-waas_global] class AFS

[Sysname-waaspolicy-waas_global-AFS]

 

4.12  安全相关功能视图

4.12.1  AAA功能视图

表4-57 AAA功能视图列表

视图

视图说明

进入命令

示例

ISP域视图

·     创建ISP域,并进入ISP域视图

·     进入该视图后,可配置ISP域的相关属性

domain

domain name

[Sysname] domain test

[Sysname-isp-test] 

本地用户视图

·     创建本地用户,并进入本地用户视图

·     进入该视图后,可配置本地用户的相关属性

local-user

[Sysname] local-user abc class manage

[Sysname-luser-manage-abc]

用户组视图

·     创建本地用户组,并进入本地用户组视图

·     进入该视图后,可配置本地用户组的相关属性

user-group

[Sysname] user-group guest

[Sysname-ugroup-guest] 

NAS-ID-Profile视图

·     创建NAS-ID Profile,并进入NAS-ID-Profile视图

·     进入该视图后,可配置NAS-ID-Profile的相关属性

aaa nas-id profile

[Sysname] aaa nas-id profile aaa

[Sysname-nas-id-prof-aaa]

RADIUS方案视图

·     创建RADIUS方案,并进入RADIUS方案视图

·     进入该视图后,可配置RADIUS方案的相关属性

radius scheme

[Sysname] radius scheme rad

[Sysname-radius-rad]

RADIUS DAE服务器视图

·     开启RADIUS DAE服务,并进入RADIUS DAE服务器视图

·     进入该视图后,可配置RADIUS DAE服务相关信息

radius dynamic-author server

[Sysname] radius dynamic-author server

[Sysname-radius-da-server]

RADIUS服务器用户视图

·     创建RADIUS用户并进入RADIUS服务器用户视图

·     进入该视图后,可配置RADIUS用户

radius-server user user-name

[Sysname] radius-server user user1

[Sysname-rdsuser-user1]

HWTACACS方案视图

·     创建HWTACACS方案,并进入HWTACACS方案视图

·     进入该视图后,可配置HWTACACS方案的相关属性

hwtacacs scheme

[Sysname] hwtacacs scheme hwtac

[Sysname-hwtacacs-hwtac]

LDAP服务器视图

·     创建LDAP服务器,并进入LDAP服务器视图

·     进入该视图后,可配置LDAP服务器的相关属性

ldap server

[Sysname] ldap server abc

[Sysname-ldap-server-abc]

LDAP的属性映射表视图

·     创建LDAP的属性映射表,并进入属性映射表视图

·     进入该视图后,可配置LDAP属性映射表

ldap attribute-map

[Sysname] ldap attribute-map abc

[Sysname-ldap-attr-map-abc]

LDAP方案视图

·     创建LDAP方案,并进入LDAP方案视图

·     进入该视图后,可配置LDAP方案的相关属性

ldap scheme

[Sysname] ldap scheme abc

[Sysname-ldap-abc]

ITA业务策略视图

·     创建ITA业务策略,并进入ITA业务策略视图

·     进入该视图后,可配置ITA业务策略的相关属性

ita policy

[Sysname] ita policy abc

[Sysname-ita-policy-abc]

连接记录策略视图

·     创建连接计录策略,并进入连接记录策略视图

·     进入该视图后,可配置连接计录策略的相关属性

aaa connection-recording policy

[Sysname] aaa connection-recording policy

[Sysname-connection-recording-policy]

EDSG业务策略视图

·     创建EDSG业务策略,并进入EDSG业务策略视图

·     进入该视图后,可配置EDSG业务策略的相关属性

service policy

[Sysname] service policy abc

[Sysname-service-policy-abc]

 

4.12.2  Portal功能视图

表4-58 Portal功能视图列表

视图

视图说明

进入命令

示例

MAC绑定服务器视图

·     创建MAC绑定服务器,并进入MAC绑定服务器视图

·     进入该视图后,可配置MAC绑定服务器的相关属性

portal mac-trigger-server

[Sysname] portal mac-trigger-server mts

[Sysname-portal-mac-trigger-server-mts]

QQ认证服务器视图

·     创建QQ认证服务器视图,并进入微信认证服务器视图

·     进入该视图后,可配置QQ认证服务器的相关属性

portal extend-auth-server qq

[Sysname] portal extend-auth-server qq

[Sysname-portal-extend-auth-server-qq]

微信认证服务器视图

·     创建微信认证服务器视图,并进入微信认证服务器视图

·     进入该视图后,可配置微信认证服务器的相关属性

portal extend-auth-server wechat

[Sysname] portal extend-auth-server wechat

[Sysname-portal-extend-auth-server-wechat]

邮箱认证服务器视图

·     创建邮箱认证服务器视图,并进入邮箱认证服务器视图

·     进入该视图后,可配置邮箱认证服务器的相关属性

portal extend-auth-server mail

[Sysname] portal extend-auth-server mail

[Sysname-portal-extend-auth-server-mail]

Portal Web服务器视图

·     创建Portal Web服务器视图并进入Portal Web服务器视图

·     进入该视图后,可配置Portal Web服务器的相关属性

portal web-server

[Sysname] portal web-server abc

[Sysname-portal-local-websvr-abc]

本地Portal Web服务器视图

·     创建本地Portal Web服务器视图并进入本地Portal Web服务器视图

·     进入该视图后,可配置本地Portal Web服务器的相关属性

portal local-web-server

[Sysname] portal local-web-server http

[Sysname-portal-local-websvr-http]

Portal认证服务器视图

·     创建Portal认证服务器视图,并进入Portal认证服务器视图

·     进入该视图后,可配置Portal认证服务器的相关属性

portal server

[Sysname] portal server pts

[Sysname-portal-server-pts]

 

4.12.3  Web认证功能视图

表4-59 Web认证功能视图列表

视图

视图说明

进入命令

示例

Web认证服务器视图

·     创建Web认证服务器,并进入Web认证服务器视图

·     进入该视图后,可配置Web认证服务器的相关属性

web-auth server

[Sysname] web-auth server wbs

[Sysname-web-auth-server-wbs]

 

4.12.4  用户身份识别与管理功能视图

表4-60 用户身份识别与管理功能视图列表

视图

视图说明

进入命令

示例

RESTful服务器

·     创建RESTful服务器,并进入RESTful服务器视图

·     进入该视图后,可配置RESTful服务器的相关属性

user-identity restful-server

[Sysname] user-identity restful-server rest1

[Sysname-restfulserver-rest1]

身份识别用户导入策略

·     创建身份识别用户导入策略,并进入身份识别用户导入策略视图

·     进入该视图后,可配置身份识别用户导入策略的相关属性

user-identity user-import-policy

[Sysname] user-identity user-import-policy policy1

[Sysname-identity-user-impt-policy-policy1]

 

4.12.5  User Profile功能视图

表4-61 User Profile功能视图列表

视图

视图说明

进入命令

示例

User Profile视图

·     创建User Profile,并进入User Profile视图

·     进入该视图后,可以为当前用户应用QoS策略

user-profile

[Sysname] user-profile a123

[Sysname-user-profile-a123]

Session Group Profile视图

·     创建Session Group,并进入Session Group视图

·     进入该视图后,可以为当前用户组应用QoS策略

user-profile profile-name type session-group

<Sysname> system-view

[Sysname] user-profile a123 type session-group

[Sysname-session-group-profile-a123]

 

4.12.6  keychain功能视图

视图

视图说明

进入命令

示例

keychain视图

·     创建一个keychain,并进入keychain视图

·     进入该视图后,可配置keychain相关参数

keychain

[Sysname] keychain abc mode absolute

[Sysname-keychain-abc]

key视图

·     创建一个key,并进入key视图

·     进入该视图后,可配置key的相关参数

key

[Sysname] keychain abc mode absolute

[Sysname-keychain-abc] key 1

[Sysname-keychain-abc-key-1]

 

4.12.7  公钥管理功能视图

表4-62 公钥管理功能视图列表

视图

视图说明

进入命令

示例

公钥视图

·     配置公共密钥名称,并进入公共密钥视图

·     进入该视图后,可对公共密钥进行配置

public-key peer

[Sysname] public-key peer key1

[Sysname-pkey-public-key]

 

4.12.8  PKI功能视图

表4-63 PKI功能视图列表

视图

视图说明

进入命令

示例

PKI实体视图

·     创建PKI实体,并进入PKI实体视图

·     进入该视图后,可配置PKI实体的相关属性

pki entity

[Sysname] pki entity test

[Sysname-pki-entity-test]

PKI域视图

·     创建PKI域,并进入PKI域视图

·     进入该视图后,可配置PKI域的相关属性

pki domain

[Sysname] pki domain test

[Sysname-pki-domain-test]

PKI证书属性组视图

·     创建证书属性组,并进入证书属性组视图

·     进入该视图后,可配置PKI证书属性

pki certificate attribute-group

[Sysname] pki certificate attribute-group test

[Sysname-pki-cert-attribute-group-test]

PKI证书属性访问控制策略视图

·     创建证书属性访问控制策略,并进入证书属性访问控制策略视图

·     进入该视图后,可配置PKI证书属性访问控制策略的相关参数

pki certificate access-control-policy

[Sysname] pki certificate access-control-policy test

[Sysname-pki-cert-acp-test]

 

4.12.9  IPsec功能视图

表4-64 IPsec功能视图列表

视图

视图说明

进入命令

示例

IPsec安全提议视图

·     创建IPsec安全提议,并进入IPsec安全提议视图

·     进入该视图后,可配置IPsec安全提议的相关属性

ipsec transform-set transform-set-name

[Sysname] ipsec transform-set tran1

[Sysname-transform-set-tran1]

IPsec安全策略视图

·     创建IPsec安全策略,并进入IPsec安全策略视图

·     进入该视图后,可配置IPsec安全策略的相关属性

ipsec { ipv6-policy | policy } policy-name seq-number [ gdoi | isakmp | manual ]

[Sysname] ipsec policy policy1 100 isakmp

[Sysname-ipsec-policy-isakmp-policy1-100]

IPsec安全策略视图

·     创建IPsec安全策略,并进入IPsec安全策略视图

·     进入该视图后,可配置IPsec安全策略的相关属性

ipsec { ipv6-policy | policy } policy-name seq-number [ gdoi | isakmp | manual ]

[Sysname] ipsec policy policy1 100 isakmp

[Sysname-ipsec-policy-isakmp-policy1-100]

IPsec安全策略模板视图

·     创建IPsec安全策略模板,并进入IPsec安全策略模板视图

·     进入该视图后,可配置IPsec安全策略模板的相关属性

ipsec { ipv6-policy-template | policy-template } template-name seq-number

[Sysname] ipsec policy-template template1 100

[Sysname-ipsec-policy-template-template1-100]

IPsec安全框架视图

·     创建IPsec安全策略模板,并进入IPsec安全策略模板视图

·     进入该视图后,可配置IPsec安全策略模板的相关属性

ipsec profile profile-name [ manual | isakmp ]

[Sysname] ipsec profile profile1 isakmp

[Sysname-ipsec-profile-isakmp-profile1]

IKE profile视图

·     创建IKE profile,并进入IKE profile视图

·     进入该视图后,可配置IKE profile的相关属性

ike profile profile-name

[Sysname] ike profile 1

[Sysname-ike-profile-1]

IKE提议视图

·     创建IKE提议,并进入IKE提议视图

·     进入该视图后,可配置IKE提议的相关属性

ike proposal proposal-number

[Sysname] ike proposal 1

[Sysname-ike-proposal-1]

IKE keychain视图

·     创建IKE keychain,并进入IKE keychain视图

·     进入该视图后,可配置IKE keychain的相关属性

ike keychain keychain-name [ vpn-instance vpn-instance-name ]

[Sysname] ike keychain key1

[Sysname-ike-keychain-key1]

IKEv2 profile视图

·     创建IKEv2 profile,并进入IKEv2 profile视图

·     进入该视图后,可配置IKEv2 profile的相关属性

Ikev2 profile profile-name

[Sysname] ikev2 profile profile1

[Sysname-ikev2-profile- profile1]

IKEv2提议视图

·     创建IKEv2提议,并进入IKEv2提议视图

·     进入该视图后,可配置IKEv2提议的相关属性

Ikev2 proposal proposal-name

[Sysname] ikev2 proposal prop1

[Sysname-ikev2-proposal-prop1]

IKEv2 keychain视图

·     创建IKEv2 keychain,并进入IKEv2 keychain视图

·     进入该视图后,可配置IKEv2 keychain的相关属性

Ikev2 keychain keychain-name [ vpn-instance vpn-instance-name ]

[Sysname] ikev2 keychain key1

[Sysname-ikev2-keychain-key1]

IKEv2 peer视图

·     创建IKEv2 peer,并进入IKEv2 peer视图

·     进入该视图后,可配置IKEv2 peer的相关属性

peer name

[Sysname] ikev2 keychain key1

[Sysname-ikev2-keychain-key1] peer peer1

[Sysname-ikev2-keychain-key1-peer-peer1]

IKEv2安全策略视图

·     创建IKEv2安全策略,并进入IKEv2安全策略视图

·     进入该视图后,可配置IKEv2安全策略的相关属性

ikev2 policy policy-name

[Sysname] ikev2 policy policy1

[Sysname-ikev2-policy-policy1]

IPsec智能选路策略视图

·     创建IPsec智能选路策略,并进入智能选路策略视图

·     进入该视图后,可配置IPsec智能选路策略的相关属性

ipsec smart-link policy policy-name

[Sysname] ipsec smart-link policy smlkpolicy1

[Sysname-ipsec-smart-link-policy-smlkpolicy1]

 

4.12.10  Group Domain VPN功能视图

表4-65 Group Domain VPN功能视图列表

视图

视图说明

进入命令

示例

GDOI GM组视图

·     创建一个GDOI GM组,并进入GDOI GM组视图

·     进入该视图后,可配置Group Domain VPN的相关参数

gdoi gm group

[Sysname] gdoi gm group abc

[Sysname-gdoi-gm-group-abc]

 

4.12.11  SSL功能视图

表4-66 SSL功能视图列表

视图

视图说明

进入命令

示例

SSL服务器端策略视图

·     创建SSL服务器端策略,并进入SSL服务器端策略视图

·     进入该视图后,可配置SSL服务器端策略的相关参数

ssl server-policy

[Sysname] ssl server-policy test

[Sysname-ssl-server-policy-test]

SSL客户端策略视图

·     创建SSL客户端策略,并进入SSL客户端策略视图

·     进入该视图后,可配置SSL客户端策略的相关参数

ssl client-policy

[Sysname] ssl client-policy test

[Sysname-ssl-client-policy-test]

 

4.12.12  SSL VPN功能视图

表4-67 SSL VPN功能视图列表

视图

视图说明

进入命令

示例

SSL VPN网关视图

·     创建SSL VPN网关,并进入SSL VPN网关视图

·     进入该视图后,可配置SSL VPN网关的相关参数

sslvpn gateway gateway-name

[Sysname] sslvpn gateway gw1

[Sysname-sslvpn-gateway-gw1]

SSL VPN访问实例视图

·     创建SSL VPN访问实例,并进入SSL VPN访问实例视图

·     进入该视图后,可配置SSL VPN网关的相关参数

sslvpn context context-name

[Sysname] sslvpn context ctx1

[Sysname-sslvpn-context-ctx1]

文件策略视图

·     创建文件策略,并进入文件策略视图

·     进入该视图后,可配置文件策略的相关参数

file-policy policy-name

[Sysname] sslvpn context ctx

[Sysname-sslvpn-context-ctx] file-policy fp

[Sysname-sslvpn-context-ctx-file-policy-fp]

改写规则视图

·     创建改写规则,并进入改写规则视图

·     进入该视图后,可配置改写规则的相关参数

rewrite-rule rule-name

[Sysname] sslvpn context ctx

[Sysname-sslvpn-context-ctx] file-policy fp

[Sysname-sslvpn-context-ctx-file-policy-fp] rewrite-rule rule1

[Sysname-sslvpn-context-ctx-file-policy-fp-rewrite-rule-rule1]

端口转发表项视图

·     创建端口转发表项,进入端口转发表项视图

·     进入该视图后,可配置端口转发表项的相关参数

port-forward-item item-name

[Sysname] sslvpn context ctx1

[Sysname-sslvpn-context-ctx1] port-forward-item pfitem1

[Sysname-sslvpn-context-ctx1-port-forward-item-pfitem1]

SSL VPN策略组视图

·     进入SSL VPN策略组视图

·     进入该视图后,可配置SSL VPN策略组的相关参数

policy-group group-name

[Sysname] sslvpn context ctx1

[Sysname-sslvpn-context-ctx1] policy-group pg1

[Sysname-sslvpn-context-ctx1-policy-group-pg1]

SSL VPN AC接口视图

·     创建SSL VPN AC接口,并进入SSL VPN AC接口视图

·     进入该视图后,可配置SSL VPN AC接口的相关参数

interface sslvpn-ac interface-number

[Sysname]interface SSLVPN-AC 1000

[Sysname-SSLVPN-AC1000]

路由列表视图

·     创建路由列表,并进入路由列表视图

·     进入该视图后,可配置路由列表的相关参数

ip-route-list list-name

[Sysname] sslvpn context ctx1

[Sysname-sslvpn-context-ctx1] ip-route-list rtlist

[Sysname-sslvpn-context-ctx1-route-list-rtlist]

SSL VPN用户视图

·     创建SSL VPN用户,并进入SSL VPN用户视图

·     进入该视图后,可配置SSL VPN用户的相关参数

user username

[Sysname] sslvpn context ctx

[Sysname-sslvpn-context-ctx] user user1

[Sysname-sslvpn-context-ctx-user-user1]

SSL VPN SNAT地址池视图

·     创建SSL VPN SNAT地址池,并进入SSL VPN SNAT地址池视图

·     进入该视图后,可配置SSL VPN SNAT地址池的相关参数

sslvpn snat-pool pool-name

[Sysname] sslvpn snat-pool spool1

[Sysname-sslvpn-snatpool-spool1]

快捷方式视图

·     创建快捷方式,并进入快捷方式视图

·     进入该视图后,可配置快捷方式的相关参数

shortcut shortcut-name

[Sysname] sslvpn context ctx1

[Sysname-sslvpn-context-ctx1] shortcut shortcut1

[Sysname-sslvpn-context-ctx1-shortcut-shortcut1] quit

快捷方式列表视图

·     创建快捷方式列表,并进入快捷方式列表视图

·     进入该视图后,可配置快捷方式列表的相关参数

shortcut-list list-name

[Sysname] sslvpn context ctx1

[Sysname-sslvpn-context-ctx1] shortcut-list list1

[Sysname-sslvpn-context-ctx1-shortcut-list-list1]

 

4.12.13  ASPF功能视图

表4-68 ASPF功能视图列表

视图

视图说明

进入命令

示例

ASPF策略视图

·     首先需要创建ASPF策略并进入ASPF策略视图

·     进入该视图后,可以对ASPF进行配置

aspf policy aspf-policy-number

[Sysname] aspf policy 1

[Sysname-aspf-policy-1]

 

4.12.14  连接数限制功能视图

视图

视图说明

进入命令

示例

进入连接数限制策略视图

创建并进入该视图后,可配置连接数限制规则

connection-limit { ipv6-policy | policy } policy-id

[Sysname] connection-limit policy 1

[Sysname-connlmt-policy-1]

 

4.12.15  对象策略和对象组功能视图

表4-69 对象策略和对象组功能视图列表

视图

视图说明

进入命令

示例

IPv4对象策略视图

·     首先需要创建IPv4对象策略并进入IPv4对象策略视图

·     进入该视图后,可以对IPv4对象策略进行配置

object-policy ip object-policy-name

[Sysname] object-policy ip permit

[Sysname-object-policy-ip-permit]

IPv6对象策略视图

·     首先需要创建IPv6对象策略并进入IPv6对象策略视图

·     进入该视图后,可以对IPv6对象策略进行配置

object-policy ipv6 object-policy-name

[Sysname] object-policy ipv6 permit

[Sysname-object-policy-ipv6-permit]

IPv4地址对象组视图

·     首先需要创建IPv4地址对象组并进入IPv4地址对象组视图

·     进入该视图后,可以对IPv4地址对象组进行配置

object-group ip address object-group-name

[Sysname] object-group ip address ipgroup

[Sysname-obj-grp-ip-ipgroup]

IPv6地址对象组视图

·     首先需要创建IPv6地址对象组并进入IPv6地址对象组视图

·     进入该视图后,可以对IPv6地址对象组进行配置

object-group ipv6 address object-group-name

[Sysname] object-group ipv6 address ipv6group

[Sysname-obj-grp-ipv6-ipv6group]

服务对象组视图

·     首先需要创建服务对象组并进入服务对象组视图

·     进入该视图后,可以对服务对象组进行配置

object-group service object-group-name

[Sysname] object-group service servicegroup

[Sysname-obj-grp-service-servicegroup]

端口对象组视图

·     首先需要创建端口对象组并进入端口对象组视图

·     进入该视图后,可以对端口对象组进行配置

object-group port object-group-name

[Sysname] object-group port portgroup

[Sysname-obj-grp-port-portgroup]

 

4.12.16  攻击检测与防范功能视图

视图

视图说明

进入命令

示例

攻击防范策略视图

创建并进入该视图后,可配置攻击防范策略的相关属性

attack-defense policy policy-name

[Sysname] attack-defense policy atk-policy-1

[Sysname-attack-defense-policy-atk-policy-1]

 

4.12.17  ND攻击防御功能视图

表4-70 ND攻击防御功能视图列表

视图

视图说明

进入命令

示例

RA Guard策略视图

·     创建RA Guard策略,并进入RA Guard策略视图

·     进入该视图后,可以配置RA Guard策略

ipv6 nd raguard policy

[Sysname] ipv6 nd raguard policy policy1

[Sysname-raguard-policy-policy1]

 

4.12.18  MACsec功能视图

表4-71 MACsec功能视图列表

视图

视图说明

进入命令

示例

MKA策略视图

·     创建一个MKA策略,并进入MKA策略视图

·     进入该视图后,可以配置MKA策略

mka policy policy-name

[Sysname] mka policy abcd

[Sysname-mka-policy-abcd]

 

 

4.12.19  安全域功能视图

表4-72 安全域功能视图列表

视图

视图说明

进入命令

示例

安全域视图

·     创建安全域,并进入安全域视图

·     进入该视图后,可配置安全域相关参数

security-zone

[Sysname] security-zone name zonetest

[Sysname-security-zone-zonetest]

 

4.12.20  安全策略功能视图

表4-73 安全策略功能视图列表

视图

视图说明

进入命令

示例

安全策略视图

进入该视图后,可配置安全策略相关参数

security-policy { ip | ipv6 }

[Sysname] security-policy ip

[Sysname-security-policy-ip]

安全策略规则视图

·     创建安全策略规则,并进入安全策略规则视图

·     进入该视图后,可配置安全策略规则相关参数

rule

[Sysname-security-policy-ip] rule 0 name rule1

[Sysname-security-policy-ip-0-rule1]

 

4.12.21  带宽策略功能视图

表4-74 带宽策略功能视图列表

视图

视图说明

进入命令

示例

带宽策略视图

进入该视图后,可配置带宽策略相关参数

traffic-policy

[Sysname] traffic-policy

[Sysname-traffic-policy]

带宽策略规则视图

·     创建带宽策略规则,并进入带宽策略规则视图

·     进入该视图后,可配置带宽策略规则相关参数

rule name

[Sysname-traffic-policy] rule name rule1

[Sysname-traffic-policy-rule-rule1]

带宽通道视图

·     创建带宽通道,并进入带宽通道视图

·     进入该视图后,可配置带宽通道相关参数

profile name

Sysname-traffic-policy] profile name profile1

[Sysname-traffic-policy-profile-profile1]

 

4.12.22  应用审计与管理功能视图

表4-75 应用审计与管理功能视图列表

视图

视图说明

进入命令

示例

应用审计与管理视图

进入该视图后,可配置应用审计与管理相关参数

uapp-control

[Sysname] uapp-control

[Sysname-uapp-control]

应用审计与管理策略视图

·     创建应用审计与管理策略,并进入应用审计与管理策略视图

·     进入该视图后,可配置应用审计与管理策略相关参数

policy name

[Sysname-uapp-control] policy name mypolicy1 audit

[Sysname-uapp-control-policy-mypolicy1]

关键字组视图

·     创建关键字组,并进入关键字组视图

·     进入该视图后,可配置关键字组相关参数

keyword-group name

[Sysname-uapp-control] keyword-group name mykeywordgroup

[Sysname-uapp-control-keyword-group-mykeywordgroup]

 

4.12.23  APR功能视图

表4-76 APR功能视图列表

视图

视图说明

进入命令

示例

应用组视图

·     创建应用组,并进入应用组视图

·     进入该视图后,可配置应用组的相关参数

app-group group-name

[Sysname] app-group aaa

[Sysname-app-group-aaa]

NBAR规则视图

·     创建自定义NBAR规则,并进入NBAR规则视图

·     进入该视图后,可配置自定义NBAR规则的相关参数

nbar application application-name protocol { http | tcp | udp }

[Sysname] nbar application abcd protocol http

[Sysname-nbar-application-abcd]

自动升级配置视图

·     开启定期自动在线升级APR特征库功能,并进入自动升级配置视图

·     进入该视图后,可配置APR特征库自动升级参数

apr signature auto-update

[Sysname] apr signature auto-update

[Sysname-apr-autoupdate]

 

4.12.24  DPI深度安全功能视图

表4-77 应用层检测引擎功能视图列表

视图

视图说明

进入命令

示例

DPI应用profile视图

·     创建DPI应用profile,并进入DPI应用profile视图

·     进入该视图后,可引用DPI各业务策略并应用于对象策略或安全策略规则中

app-profile profile-name

[Sysname] app-profile abc

[Sysname-app-profile-abc]

应用层检测引擎邮件动作参数profile视图

·     创建应用层检测引擎的邮件动作参数profile,并进入邮件动作参数profile视图

·     进入该视图后,可配置邮件动作的相关参数

inspect email parameter-profile parameter-name

[Sysname] inspect email parameter-profile c1

[Sysname-inspect-email-c1]

应用层检测引擎的源阻断动作参数profile视图

·     创建应用层检测引擎的源阻断动作参数profile,并进入源阻断动作参数profile视图

·     进入该视图后,可配置源阻断动作的相关参数

inspect block-source parameter-profile parameter-name

[Sysname] inspect block-source parameter-profile b1

[Sysname-inspect-block-para-b1]

应用层检测引擎的捕获动作参数profile视图

·     创建应用层检测引擎的捕获动作参数profile,并进入捕获动作参数profile视图

·     进入该视图后,可配置捕获动作的相关参数

inspect capture parameter-profile parameter-name

[Sysname] inspect capture parameter-profile c1

[Sysname-inspect-capture-para-b1]

应用层检测引擎的日志动作的参数profile视图

·     创建应用层检测引擎的日志动作参数profile,并进入日志动作参数profile视图

·     进入该视图后,可配置日志动作的相关参数

inspect logging parameter-profile parameter-name

[Sysname] inspect logging parameter-profile log1

[Sysname-inspect-logging-para-log1]

应层检测引擎的重定向动作参数profile视图

·     创建应用层检测引擎的重定向动作参数profile,并进入重定向动作参数profile视图

·     进入该视图后,可配置重定向动作的相关参数

inspect redirect parameter-profile parameter-name

[Sysname] inspect redirect parameter-profile r1

[Sysname-inspect-redirect-r1]

 

表4-78 IPS功能视图列表

视图

视图说明

进入命令

示例

IPS策略视图

·     创建IPS策略,并进入IPS策略视图

·     进入该视图后,可配置IPS策略相关参数

ips policy policy-name

[Sysname] ips policy ips1

[Sysname-ips-policy-ips1]

自动升级配置视图

·     开启定期自动在线升级IPS特征库功能,并进入自动升级配置视图

·     进入该视图后,可配置IPS特征库自动升级相关参数

ips signature auto-update

[Sysname] ips signature auto-update

[Sysname-ips-autoupdate]

 

表4-79 URL过滤功能视图列表

视图

视图说明

进入命令

示例

URL过滤策略视图

·     创建URL过滤策略,并进入URL过滤策略视图

·     进入该视图后,可配置URL过滤策略相关参数

url-filter policy policy-name

[Sysname] url-filter policy news

[Sysname-url-filter-policy-news]

URL过滤分类视图

·     创建URL过滤分类,并进入URL过滤分类视图

·     进入该视图后,可配置自定义URL过滤分类的相关参数

url-filter category category-name [ severity severity-level ]

[Sysname] url-filter category news severity 2000

[Sysname-url-filter-category-news]

自动升级配置视图

·     开启定期自动在线升级URL过滤特征库功能,并进入自动升级配置视图

·     进入该视图后,可配置URL过滤特征库自动升级的相关参数

url-filter signature auto-update

[Sysname] url-filter signature auto-update

[Sysname-url-filter-autoupdate]

 

表4-80 数据过滤功能视图列表

视图

视图说明

进入命令

示例

数据过滤策略视图

·     创建数据过滤策略,并进入数据过滤策略视图

·     进入该视图后,可配置数据过滤策略相关参数

data-filter policy policy-name

[Sysname] data-filter policy def

[Sysname-data-filter-policy-def]

数据过滤规则视图

·     首先需要进入数据过滤策略视图,才可创建数据过滤规则,并进入数据过滤规则视图

·     进入该视图后,可配置数据过滤规则相关参数

rule rule-name

[Sysname] data-filter policy def

[Sysname-data-filter-policy-def] rule r1

[Sysname-data-filter-policy-def-rule-r1]

关键字组视图

·     创建关键字组,并进入关键字组视图

·     进入该视图后,可配置关键字组相关参数

data-filter keyword-group keywordgroup-name

[Sysname] data-filter keyword-group kg1

[Sysname-data-filter-keygroup-kg1]

 

表4-81 文件过滤功能视图列表

视图

视图说明

进入命令

示例

文件过滤策略视图

·     创建文件过滤策略,并进入文件过滤策略视图

·     进入该视图后,可配置文件过滤策略相关参数

file-filter policy policy-name

[Sysname] file-filter policy def

[Sysname-file-filter-policy-def]

文件过滤规则视图

·     首先需要进入文件过滤策略视图,才可创建文件过滤规则,并进入文件过滤规则视图

·     进入该视图后,可配置文件过滤规则相关参数

rule rule-name

[Sysname] file-filter policy def

[Sysname-file-filter-policy-def]rule ch1

[Sysname-file-filter-policy-def-rule-ch1]

文件类型组视图

·     创建文件类型组,并进入文件类型组视图

·     进入该视图后,可配置文件类型组相关参数

file-filter filetype-group group-name

[Sysname] file-filter filetype-group fg1

[Sysname-file-filter-fgroup-fg1]

 

表4-82 防病毒功能视图列表

视图

视图说明

进入命令

示例

防病毒策略视图

·     创建防病毒策略,并进入防病毒策略视图

·     进入该视图后,可配置防病毒策略相关参数

anti-virus policy policy-name

[Sysname] anti-virus policy abc

[Sysname-anti-virus-policy-abc]

自动升级配置视图

·     开启定期自动在线升级病毒特征库功能,并进入自动升级配置视图

·     进入该视图后,可配置防病毒特征库自动升级相关参数

anti-virus signature auto-update

[Sysname] anti-virus signature auto-update

[Sysname-anti-virus-autoupdate]

 

4.13  可靠性相关功能视图

4.13.1  进程分布优化功能视图

表4-83 进程分布优化功能视图列表

视图

视图说明

进入命令

示例

分布策略视图

·     进入进程的分布策略视图

·     进入该视图后,可以配置进程的偏好

placement program

[Sysname] placement program staticroute

[Sysname-program-staticroute]

 

4.13.2  RPR功能视图

表4-84 RPR功能视图列表

视图

视图说明

进入命令

示例

RPRGE接口视图

·     创建RPRGE接口,并进入RPRGE接口视图

·     进入该视图后,可配置RPRGE接口的相关属性

interface rprge

[Sysname] interface rprge 1/0/1

[Sysname-RPRGE1/0/1]

RPRXGE接口视图

·     创建RPRXGE接口,并进入RPRXGE接口视图

·     进入该视图后,可配置RPRXGE接口的相关属性

interface rprxge

[Sysname] interface rprxge 1/0/1

[Sysname-RPRXGE1/0/1]

RPRPOS接口视图

·     创建RPRPOS接口,并进入RPRPOS接口视图

·     进入该视图后,可配置RPRPOS接口的相关属性

interface rprpos

[Sysname] interface rprpos 1/0/1

[Sysname-RPRPOS1/0/1]

二层RPR逻辑接口视图

·     创建二层RPR逻辑接口,并进入二层RPR逻辑接口视图

·     进入该视图后,可配置二层RPR逻辑接口的相关属性

interface rpr-bridge

[Sysname] interface rpr-bridge 1

[Sysname-RPR-Bridge1]

三层RPR逻辑接口视图

·     创建三层RPR逻辑接口,并进入三层RPR逻辑接口视图

·     进入该视图后,可配置三层RPR逻辑接口的相关属性

interface rpr-router

[Sysname] interface rpr-router 1

[Sysname-RPR-Router1]

 

4.13.3  RRPP功能视图

表4-85 RRPP功能视图列表

视图

视图说明

进入命令

示例

RRPP域视图

·     创建RRPP域并进入RRPP域视图

·     进入该视图后,可配置RRPP域的相关属性

rrpp domain

[Sysname] rrpp domain 1

[Sysname-rrpp-domain1]

RRPP环组视图

·     创建RRPP环组,并进入RRPP环组视图

·     进入该视图后,可配置RRPP环组的相关属性

rrpp ring-group

[Sysname] rrpp ring-group 1

[Sysname-rrpp-ring-group1]

 

4.13.4  ERPS功能视图

表4-86 ERPS功能视图列表

视图

视图说明

进入命令

示例

ERPS环视图

·     创建ERPS环,并进入ERPS环视图

·     进入该视图后,可配置ERPS环的相关属性

erps ring

[Sysname] erps ring 1

[Sysname-erps-ring1]

ERPS实例视图

·     首先需要进入ERPS环视图,才能创建ERPS实例,并进入ERPS实例视图

·     进入该视图后,可配置ERPS实例的相关属性

instance

[Sysname] erps ring 1

[Sysname-erps-ring1] instance 1

[Sysname-erps-ring1-inst1]

 

4.13.5  Smart LinkMonitor Link功能视图

表4-87 Smart LinkMonitor Link功能视图列表

视图

视图说明

进入命令

示例

Smart Link组视图

·     创建Smart Link组,并进入Smart Link组视图

·     进入该视图后,可配置Smart Link组的相关属性

smart-link group

[Sysname] smart-link group 1

[Sysname-smlk-group1]

Monitor Link组视图

·     创建Monitor Link组,并进入Monitor Link组视图

·     进入该视图后,可配置Monitor Link组的相关属性

monitor-link group

[Sysname] monitor-link group 1

[Sysname-mtlk-group1]

联动组视图

·     创建联动组,并进入联动组视图

·     进入该视图后,可配置联动组的相关属性

collaboration-group

[Sysname] collaboration-group 1

[Sysname-collaboration-group1]

 

4.13.6  多机备份功能视图

表4-88 多机备份功能视图列表

视图

视图说明

进入命令

示例

多机备份对端视图

·     创建多机备份对端,并进入多机备份对端视图

·     进入该视图后,可以配置多机备份对端相关特性

vsrp peer

[Sysname] vsrp peer pname

[Sysname-vsrp-peer-pname]

多机备份实例视图

·     创建多机备份实例,并进入多机备份实例视图

·     进入该视图后,可以配置多机备份实例相关特性

vsrp instance

[Sysname] vsrp instance aaa

[Sysname-vsrp-instance-aaa]

 

4.13.7  备份组功能视图

表4-89 备份组功能视图列表

视图

视图说明

进入命令

示例

备份组视图

·     创建备份组,并进入备份组视图

·     进入该视图后,可以配置备份组的相关参数

failover group

[Sysname] failover group group1

[Sysname-failover-group-group1]

 

4.13.8  冗余备份功能相关视图

表4-90 冗余备份功能相关视图列表

视图

视图说明

进入命令

示例

以太网冗余接口视图

·     创建以太网冗余接口,并进入该接口视图

·     进入该视图后,可以配置以太网冗余接口的相关参数

interface reth

[Sysname] interface reth 1

[Sysname-Reth1]

冗余组视图

·     创建冗余组,并进入该冗余组视图

·     进入该视图后,可以配置冗余组绑定的节点和成员等参数

redundancy group

[Sysname] redundancy group aaa

[Sysname-redundancy-group-aaa]

冗余组节点视图

·     创建冗余组节点,并进入冗余组节点视图

·     进入该视图后,可以将冗余组和IRF成员设备、物理接口、Track绑定,还可以配置节点的优先级

node

[Sysname] redundancy group aaa

[Sysname-redundancy-group-aaa] node 1

[Sysname-redundancy-group-aaa-node1]

 

4.13.9  BFD功能视图

表4-91 BFD功能视图列表

视图

视图说明

进入命令

示例

BFD模板视图

创建BFD模板,并进入BFD模板视图

bfd template

[Sysname] bfd template bfd1

[Sysname-bfd-template-bfd1]

 

4.13.10  Track功能视图

表4-92 Track功能视图列表

视图

视图说明

进入命令

示例

Track视图

·     创建Track项,并进入Track视图

·     进入该视图后,可以配置对Track对象的运算来确定总的Track项状态

track bfd

[Sysname] track 1 bfd echo interface GigabitEthernet 1/0/1 remote ip 1.1.1.1 local ip

 1.1.1.2

[Sysname-track-1]]

track cfd

[Sysname] track 2 cfd cc service-instance 1 mep 1

[Sysname -track-2]

track interface

[Sysname] track 1 interface gigabitethernet 1/0/1

[Sysname-track-1]

track interface physical

[Sysname] track 1 interface gigabitethernet 1/0/1 physical

[Sysname-track-1]

track interface protocol

[Sysname] track 1 interface gigabitethernet 1/0/1 protocol ipv4

[Sysname-track-1]

track ip route reachability

[Sysname] track 1 ip route 10.1.1.0 24 reachability

[Sysname-track-1]

track list boolean

[Sysname] track 101 list boolean or

[Sysname-track-101]

track list threshold percentage

[Sysname] track 101 list threshold percentage

[Sysname-track-101]

track list threshold weight

[Sysname] track 101 list threshold weight

[Sysname-track-101]

track nqa

[Sysname] track 1 nqa entry admin test reaction 3

[Sysname-track-1]

 

4.13.11  负载均衡功能视图

表4-93 负载均衡功能视图列表

视图

视图说明

进入命令

示例

虚服务器视图

创建并进入该视图后,可配置虚服务器的相关属性

virtual-server virtual-server-name [ type { fast-http | http | ip | link-ip | radius | tcp | udp } ]

[Sysname] virtual-server vs3 type ip

[Sysname-vs-ip-vs3]

实服务组视图

创建并进入该视图后,可配置实服务组的相关属性

server-farm server-farm-name

[Sysname] server-farm sf

[Sysname-sfarm-sf]

实服务器视图

创建并进入该视图后,可配置实服务器的相关属性

real-server real-server-name

[Sysname] real-server rs

[Sysname-rserver-rs]

SNAT地址池视图

创建并进入该视图后,可配置SNAT地址池的相关属性

loadbalance snat-pool pool-name

[Sysname] loadbalance snat-pool lbsp

[Sysname-lbsnat-pool-lbsp]

就近性视图

创建并进入该视图后,可配置就近性的相关属性

loadbalance proximity [ vpn-instance vpn-instance-name ]