13-Basic network configuration

HomeSupportResource CenterH3C Access Controllers Configuration Examples(V7)-6W10213-Basic network configuration
03-Layer 2 Multicast Configuration Examples
Title Size Download
03-Layer 2 Multicast Configuration Examples 84.41 KB

 

H3C Access Controllers

Comware 7 Layer 2 Multicast

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides examples for configuring Layer 2 multicast.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of Layer 2 multicast.

Example: Configuring Layer 2 multicast

Network configuration

As shown in Figure 1:

·     The AC acts as a DHCP server to assign IP addresses to the AP and clients.

·     The AP provides wireless services service1 and service2 for Client 1 and Client 2, respectively.

·     The AC forwards client traffic.

Configure Layer 2 multicast so that Client 1 can receive video stream for multicast group 224.1.1.1 and Client 2 cannot receive the video stream.

Figure 1 Network diagram

 

Restrictions and guidelines

Use the serial ID labeled on the AP's rear panel to specify an AP.

Procedures

Configuring the AC

1.     Configure interfaces on the AC:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The AC will use this IP address to establish a CAPWAP tunnel with the AP.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 2.2.1.1 24

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. The AC will use VLAN 200 for client access.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 2.2.2.1 24

[AC-Vlan-interface200] quit

# Configure GigabitEthernet 1/0/1 as a trunk port. Remove the port from VLAN 1, assign the port to VLAN 100 and VLAN 200, and set the PVID to 100.

[AC] interface gigabitethernet1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC-GigabitEthernet1/0/1] quit

2.     Configure DHCP:

# Enable DHCP.

[AC] dhcp enable

# Configure DHCP address pool vlan100 and specify subnet 112.12.0.0/16 and gateway address 112.12.1.25 in the address pool.

[AC] dhcp server ip-pool vlan100

[AC-dhcp-pool-vlan100] network 112.12.0.0 mask 255.255.0.0

[AC-dhcp-pool-vlan100] gateway-list 112.12.1.25

[AC-dhcp-pool-vlan100] quit

# Configure a DHCP address pool vlan200, specify subnet 112.13.0.0/16 and gateway address 112.13.1.25 in this address pool, and specify the gateway as the DNS server. Configure the DNS server according to the actual network plan.

[AC] dhcp server ip-pool vlan200

[AC-dhcp-pool-vlan200] network 112.13.0.0 mask 255.255.0.0

[AC-dhcp-pool-vlan200] gateway-list 112.13.1.25

[AC-dhcp-pool-vlan200] dns-list 112.13.1.25

[AC-dhcp-pool-vlan200] quit

3.     Configure the AP:

# Create an AP named ap1, and specify its model and serial ID.

[AC] wlan ap ap1 model WA4320i-ACN

[AC-wlan-ap-ap1] serial-id 210235A1GQC157001570

[AC-wlan-ap-ap1] quit

4.     Configure wireless services:

# Create a service template named service1.

[AC] wlan service-template service1

# Set the SSID to service1.

[AC-wlan-st-service1] ssid service1

# Assign clients coming online through the service template to VLAN 200.

[AC-wlan-st-service1] vlan 200

# Enable the service template.

[AC-wlan-st-service1] service-template enable

[AC-wlan-st-service1] quit

# Create a service template named service2.

[AC] wlan service-template service2

# Set the SSID to service2.

[AC-wlan-st-service2] ssid service2

# Assign clients coming online through the service template to VLAN 200.

[AC-wlan-st-service2] vlan 200

# Enable the service template.

[AC-wlan-st-service2] service-template enable

[AC-wlan-st-service2] quit

# Enable radio 1 and bind service template service1 to radio 1.

[AC] wlan ap ap1

[AC-wlan-ap-ap1] radio 1

[AC-wlan-ap-ap1-radio-1] radio enable

[AC-wlan-ap-ap1-radio-1] service-template service1

[AC-wlan-ap-ap1-radio-1]quit

# Enable radio 2 and bind service template service2 to radio 2.

[AC-wlan-ap-ap1] radio 2

[AC-wlan-ap-ap1-radio-2] radio enable

[AC-wlan-ap-ap1-radio-2] service-template service2

[AC-wlan-ap-ap1-radio-2]quit

[AC-wlan-ap-ap1] quit

5.     Configure IGMP snooping:

# Enable IGMP snooping globally.

[AC] igmp-snooping

[AC-igmp-snooping] quit

# Enable IGMP snooping and then enable dropping unknown multicast data packets for VLAN 200.

[AC] vlan 200

[AC-vlan200] igmp-snooping enable

[AC-vlan200] igmp-snooping drop-unknown

[AC-vlan200] quit

Configuring the switch

# Create VLAN 100. The switch will use this VLAN to forward the traffic on the CAPWAP tunnel between the AC and the AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# Create VLAN 200. The switch will use this VLAN to forward client traffic.

[Switch] vlan 200

[Switch-vlan200] quit

# Configure GigabitEthernet 1/0/1 as a trunk port. Remove the port form VLAN 1, assign the port to VLAN 100, and set the PVID to VLAN 100.

[Switch] interface gigabitethernet1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 as an access port and assign the port to VLAN 100.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# Enable PoE.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

Verifying the configuration

1.     Connect Client 1 and Client 2 to wireless services service1 and service2, respectively. (Details not shown.)

2.     Verify that Client 1 can successfully associate with service1.

[AC] display wlan client service-template service1

Total number of clients: 1

 

MAC address     Username   AP name         RID  IP address      IPv6 address   VLAN

0024-d705-c600  N/A        ap1             1    112.13.1.26     N/A            200

3.     Verify that Client 2 can successfully associate with service2.

[AC] display wlan client service-template service2

Total number of clients: 1

 

MAC address     Username   AP name         RID  IP address      IPv6 address   VLAN

0024-d710-18a4  N/A        ap1             2    112.13.1.27     N/A            200

4.     Verify that Client 1 can successfully receive demanded video stream.

# Demand video stream of multicast group 224.1.1.1 from Client 1. (Details not shown.)

# Send video stream from the source to multicast group 224.1.1.1. (Details not shown.)

# Display IGMP snooping group entries on the AC.

[AC] display igmp-snooping group

Total 1 entries.

 

VLAN 200: Total 1 entries.

  (0.0.0.0, 224.1.1.1)

    Host slots (0 in total):

    Host ports (2 in total):

      WLAN-BSS1/0/1                       (00:02:45)

The output shows that WLAN-BSS 1/0/1 (connected to Client 1) is a member port of multicast group 224.1.1.1.

# Display Layer 2 multicast fast forwarding entries on the AC.

[AC] display l2-multicast fast-forwarding cache

Total 1 entries, 1 matched

 (1.1.1.100,224.1.1.1)

    Status      : Enable                VLAN            : 200

    Source port : 63                    Destination port: 63

    Protocol    : 17                    Flag            : 0x2

    Ingress port: GigabitEthernet1/0/1

    List of 1 egress ports:

        WLAN-BSS1/0/1

          Status: Enable                Flag: 0x10

The output shows that only Client 1 can receive video stream of multicast group 224.1.1.1.

Configuration files

·     AC:

#

igmp-snooping

#

dhcp enable

#

vlan 100

#

vlan 200

#

dhcp server ip-pool vlan100

 gateway-list 112.12.1.25

 network 112.12.0.0 mask 255.255.0.0

#

dhcp server ip-pool vlan200

 gateway-list 112.13.1.25

 network 112.13.0.0 mask 255.255.0.0

 dns-list 112.13.1.25

#

vlan 200

 igmp-snooping enable

 igmp-snooping drop-unknown

#

wlan service-template service1

 ssid service1

 vlan 200

 service-template enable

#

wlan service-template service2

 ssid service2

 vlan 200

 service-template enable

#

interface Vlan-interface100

 ip address 112.12.1.25 255.255.0.0

#

interface Vlan-interface200

 ip address 112.13.1.25 255.255.0.0

#

wlan ap ap1 model WA4320i-ACN

 serial-id 210235A1GQC157001570

 radio 1

  radio enable

  service-template service1

radio 2

  radio enable

  service-template service2

#

·     Switch:

#

vlan 100

#

vlan 200

#

interface GigabitEthernet1/0/1

 port link-type trunk

undo port trunk permit vlan 1 

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

interface GigabitEthernet1/0/2

 port access vlan 100

poe enable

#

Related documentation

·     Network Connectivity Command Reference in H3C Access Controllers Command References

·     Network Connectivity Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Access Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides