08-WLAN security

HomeSupportResource CenterH3C Access Controllers Configuration Examples(V7)-6W10208-WLAN security
04-IP Source Guard (IPv6) Configuration Examples
Title Size Download
04-IP Source Guard (IPv6) Configuration Examples 105.08 KB

 

H3C Access Controllers

Comware 7 IP Source Guard (IPv6)

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example for configuring IPv6 source guard (IPv6SG).

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

This document assumes that you have basic knowledge of IPv6SG and WLAN.

Example: Configuring IPv6SG

Network configuration

As shown in Figure 1, Client 1 supports stateful IPv6 address configuration and obtains an IPv6 address through the DHCPv6 server. Client 2 is assigned a static IPv6 address. Both of the clients access the same wireless network.

Enable IPv6SG to generate IPv6SG bindings based on DHCPv6 so that the AP forwards the packets only from Client 1.

Figure 1 Network diagram

 

Restrictions and guidelines

Use the serial ID labeled on the AP's rear panel to specify an AP.

Procedures

Configuring the AC

1.     Configure interfaces on the AC:

# Create VLAN 100 and VLAN-interface 100, and assign an IPv6 address to the VLAN interface. The AC will establish a CAPWAP tunnel with the AP in this VLAN.

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ipv6 address 2000:10::10/64

[AC-Vlan-interface100] quit

# Create VLAN 200. The AC will use this VLAN for client access.

[AC] vlan 200

[AC-vlan200] quit

# Configure GigabitEthernet 1/0/1 (port that connects the AC and the switch) as a trunk port, remove the port from VLAN 1, and assign the port to VLAN 100 and VLAN 200.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

# Set the PVID of GigabitEthernet 1/0/1 to VLAN 100.

[AC-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC-GigabitEthernet1/0/1] quit

2.     Configure a wireless service:

# Create a service template named 1 and configure the SSID of the service template as service.

[AC] wlan service-template 1

[AC-wlan-st-1] ssid service

# Enable snooping DHCPv6 and ND packets on the service template.

[AC-wlan-st-1] client ipv6-snooping dhcpv6-learning enable

[AC-wlan-st-1] client ipv6-snooping nd-learning enable

# Enable IPv6SG on the service template.

[AC-wlan-st-1] ipv6 verify source

# Enable the service template.

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

3.     Configure an AP:

# Create an AP named officeap with model WA4320i-CAN, and set its serial ID to 210235A1GQB147031200.

[AC] wlan ap officeap model WA4320i-ACN

[AC-wlan-ap-officeap] serial-id 210235A1GQB147031200

# Enter radio view of radio 1, and bind service template 1 to radio 1 and specify VLAN 100 for the service template.

[AC-wlan-ap-officeap] radio 1

[AC-wlan-ap-officeap-radio-1] service-template 1 vlan-id 200

# Enable radio 1.

[AC-wlan-ap-officeap-radio-1] radio enable

[AC-wlan-ap-officeap-radio-1] quit

Configuring the switch

# Create VLAN 100. The switch will use this VLAN to forward the traffic on the CAPWAP tunnel between the AC and AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# Create VLAN 200. The switch will use this VLAN to forward packets for wireless clients.

[Switch] vlan 200

[Switch-vlan200] quit

# Configure GigabitEthernet 1/0/1 (port that connects the switch and the AC) as a trunk port, and assign the trunk port to VLAN 100 and VLAN 200.

[Switch] interface GigabitEthernet1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

# Set the PVID of GigabitEthernet 1/0/1 to VLAN 100.

[Switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 (port that connects the switch and the AP) as an access port, and assign the access port to VLAN 100.

[Switch] interface GigabitEthernet1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# Enable PoE on GigabitEthernet 1/0/2.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

Verifying the configuration

# Client 1 at MAC address 0024-d774-e6f4 comes online and obtains IPv6 address 2000:10::2/64 through DHCP. (Details not shown.)

# Client 2 at MAC address 0024-0130-696b comes online and obtains statically configured IPv6 address 2000:10::3/64. (Details not shown.)

# Verify that Client 1 can ping the host on the same subnet.

C:\Users\>ping -S 2000:10::2  2000:10::1

 

Pinging 2000:10::1 from 2000:10::2 with 32 bytes of data:

Reply from 2000:10::1 : time=22ms

Reply from 2000:10::1 : time=61ms

Reply from 2000:10::1 : time=32ms

Reply from 2000:10::1 : time=16ms

 

Ping statistics for 2000:10::1 :

    Packets: Sent = 4,Received = 4,Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 16ms,Maximum = 61ms,Average = 32ms

# Verify that Client 2 cannot ping the host.

C:\Users\>ping -S 2000:10::3 2000:10::1

 

Pinging 2000:10::1  from 2000:10::3  with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

 

Ping statistics for 2000: 10::1 :

    Packets: Sent = 4,Received = 0,Lost = 4 (100% loss),

Configuration files

·     AC:

#

vlan 100

#

vlan 200

#

wlan service-template 1 clear

 ssid service

 ipv6 verify source

client ipv6-snooping nd-learning enable

 client ipv6-snooping dhcpv6-learning enable

 service-template enable

#

interface Vlan-interface100

 ip address 2000:10::10/64

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

wlan ap officeap model WA4320i-ACN

 serial-id 210235A1GQB147031200

 radio 1

  service-template 1 vlan 200

  radio enable

radio 2

#

·     Switch:

#

vlan 100

#

vlan 200

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 100 200

 port trunk pvid vlan 100

#

interface GigabitEthernet1/0/2

 port link-mode bridge

 port access vlan 100

 poe enable

#

Related documentation

·     Network Connectivity Command Reference in H3C Access Controllers Command References

·     Network Connectivity Configuration Guide in H3C Access Controllers Configuration Guides

·     Security Command Reference in H3C Access Controllers Command References

·     Security Configuration Guide in H3C Access Controllers Configuration Guides

·     AP and WT Management Command Reference in H3C Access Controllers Command References

·     AP and WT Management Configuration Guide in H3C Access Controllers Configuration Guides