07-Local forwarding

HomeSupportResource CenterH3C Access Controllers Configuration Examples(V7)-6W10207-Local forwarding
04-Local Forwarding Configuration Examples
Title Size Download
04-Local Forwarding Configuration Examples 355.79 KB

 

H3C Access Controllers

Comware 7 Local Forwarding

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example for configuring WLAN local forwarding.

Prerequisites

This document applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

This document assumes that you have basic knowledge of WLAN local forwarding.

Example: Configuring local forwarding

Network configuration

As shown in Figure 1, the switch acts as a DHCP server to assign IP addresses to the AP and the clients. The AP establishes CAPWAP tunnels with the AC in VLAN 100 and clients use VLAN 200 to access the WLAN. Configure local forwarding on the AC to enable the AP to forward client traffic.

Figure 1 Network diagram

 

Restrictions and guidelines

When you configure WLAN local forwarding, follow these restrictions and guidelines:

·     Make sure there is no Tab or space at the end of the map-configuration command.

·     Use the serial ID labeled on the AP's rear panel to specify an AP.

·     If a backup AC is available, make sure the map-configuration file has been upgraded to the backup AC.

Procedures

Configuring the configuration file

# Create a .txt file named apcfg.txt and enter the following content:

system-view

vlan 200

quit

interface GigabitEthernet 1/0/1

port link-type trunk

port trunk permit vlan 200

# Upload the file to the AC.

Configuring the AC

1.     Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The AC will use this IP address to establish a CAPWAP tunnel with the AP.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.1.1 16

[AC-Vlan-interface100] quit

2.     Configure wireless services:

# Create service template 1 and enter its view.

[AC] wlan service-template 1

# Configure the SSID as service.

[AC-wlan-st-1] ssid service

# Enable local forwarding for traffic in VLAN 200.

[AC-wlan-st-1] client forwarding-location ap vlan 200

# Enable the service template.

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

3.     Configure the AP:

# Create manual AP officeap, and specify the AP model and serial ID.

[AC] wlan ap officeap model WA4320i-ACN

[AC-wlan-ap-officeap] serial-id 219801A0T78159E09083

# Bind service template 1 and VLAN 200 to radio 2.

[AC-wlan-ap-officeap] radio 2

[AC-wlan-ap-officeap-radio-2] service-template 1 vlan 200

# Enable radio 2.

[AC-wlan-ap-officeap-radio-2] radio enable

[AC-wlan-ap-officeap-radio-2] quit

4.     Deploy configuration file apcfg.txt to AP officeap.

[AC-wlan-ap-officeap] map-configuration apcfg.txt

[AC-wlan-ap-officeap] quit

Configuring the switch

1.     Configure switch interfaces:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The switch will use VLAN 100 to forward packets between the AC and the AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.1.1.2 16

[Switch-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. The switch will use VLAN 200 to forward client traffic.

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.2.1.2 24

[Switch-Vlan-interface200] quit

# Configure GigabitEthernet 1/0/1 that connects the switch to the AC as a trunk port, remove the port from VLAN 1, and set the PVID to VLAN 100.

[Switch] interface GigabitEthernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 that connects the switch to the AP as a trunk port, remove the port from VLAN 1, set the PVID to VLAN 100, and assign the port to VLANs 100 and 200.

[Switch] interface GigabitEthernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type trunk

[Switch-GigabitEthernet1/0/2] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/2] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/2] port trunk pvid vlan 100

# Enable PoE on GigabitEthernet 1/0/2.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

2.     Configure DHCP:

# Enable DHCP.

[Switch] dhcp enable

# Create DHCP address pool vlan100 to assign an IP address to the AP, and specify subnet 192.1.0.0/16 in the DHCP address pool.

[Switch] dhcp server ip-pool vlan100

[Switch-dhcp-pool-vlan100] network 192.1.0.0 mask 255.255.0.0

# Exclude IP address 192.1.1.1 from dynamic allocation in the address pool.

[Switch-dhcp-pool-vlan100] forbidden-ip 192.1.1.1

# Specify the gateway address as 192.1.1.2 in the DHCP address pool.

[Switch-dhcp-pool-vlan100] gateway-list 192.1.1.2

[Switch-dhcp-pool-vlan100] quit

# Create DHCP address pool vlan200 to assign IP addresses to clients, and specify subnet 192.2.1.0/24 in the DHCP address pool.

[Switch] dhcp server ip-pool vlan200

[Switch-dhcp-pool-vlan200] network 192.2.1.0 mask 255.255.255.0

# Exclude IP address 192.2.1.1 from dynamic allocation in the address pool.

[Switch-dhcp-pool-vlan200] forbidden-ip 192.2.1.1

# Specify the gateway address as 192.2.1.2 and specify the DNS server address in the DHCP address pool. In this example, the gateway also acts as a DNS server.

[Switch-dhcp-pool-vlan200] gateway-list 192.2.1.2

[Switch-dhcp-pool-vlan200] dns-list 192.2.1.2

[Switch-dhcp-pool-vlan200] quit

Verifying the configuration

# Ping Client 1 on Client 2 and ping Client 2 on Client 1.

# Capture packets and verify that client traffic is forwarded by the AP.

Figure 2 ICMP packets from clients

 

Configuration files

·     AC:

#

Vlan 100

#

vlan 200

#

wlan service-template 1

 ssid service

 client forwarding-location ap vlan 200

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.1.1 255.255.0.0

#

wlan ap officeap model WA4320i-ACN

 map-configuration flash:/apcfg.txt

 serial-id 219801A0T78159E09083

 radio 1

 radio 2

  radio enable

  service-template 1 vlan 200

#

·     Switch:

#

 dhcp enable

#

vlan 100

#

vlan 200

#

dhcp server ip-pool vlan100

 gateway-list 192.1.1.2

 network 192.1.0.0 mask 255.255.0.0

 forbidden-ip 192.1.1.1

#

dhcp server ip-pool vlan200

gateway-list 192.2.1.2

 network 192.2.1.0 mask 255.255.255.0

 dns-list 192.2.1.2

 forbidden-ip 192.2.1.1

#

interface Vlan-interface100

 ip address 192.1.1.2 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.1.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-mode bridge

port link-type trunk

undo port trunk permit vlan 1

port trunk pvid vlan 100

#

interface GigabitEthernet1/0/2

 port link-mode bridge

port link-type trunk

undo port trunk permit vlan 1

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

Related documentation

·     WLAN Access Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides