06-Wireless authentication

HomeSupportResource CenterH3C Access Controllers Configuration Examples(V7)-6W10206-Wireless authentication
Table of Contents
Related Documents
28-802.1X Authentication with ACL Assignment Through IMC Server Configuration Examples

 

H3C Access Controllers

Comware 7 802.1X Authentication with ACL Assignment Through IMC Server

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example for configuring 802.1X authentication with ACL assignment through an IMC server.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of 802.1X, AAA, WLAN authentication, and WLAN access.

Example: Configuring 802.1X authentication with ACL assignment through an IMC server

Network configuration

As shown in Figure 1, the client must pass 802.1X authentication to access the wireless network. The RADIUS server runs on IMC and provides AAA services for the client.

Configure RADIUS-based ACL assignment to deny the access of the client to the TFTP server.

Figure 1 Network diagram

 

Table 1 Interface and IP address assignment

Device

Interface

IP address

AC

VLAN-interface 100

138.100.1.101/16

 

VLAN-interface 200

138.200.1.101/16

RADIUS server

 

8.1.1.50/16

TFTP server

 

8.1.1.5/16

Switch

VLAN-interface 100

138.100.1.100/16

 

VLAN-interface 200

138.200.1.100/16

 

VLAN-interface 8

8.1.1.100/16

 

Restrictions and guidelines

Use the serial ID labeled on the AP's rear panel to specify an AP.

Procedures

Configuring the AC

1.     Configure interfaces on the AC:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The AC will use this IP address to establish CAPWAP tunnels with the AP.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 138.100.1.101 16

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. VLAN 200 will be used for client access.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 138.200.1.101 16

[AC-Vlan-interface200] quit

# Configure GigabitEthernet 1/0/1 (the port connected to the switch) as a trunk port, remove the port from VLAN 1, and assign the port to VLANs 100 and 200.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

# Set the PVID of GigabitEthernet 1/0/1 to VLAN 100.

[AC-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC-GigabitEthernet1/0/1] quit

2.     Configure 802.1X authentication:

# Enable port security globally.

[AC] port-security enable

# Configure the AC to use EAP relay to authenticate 802.1X clients.

[AC] dot1x authentication-method eap

# Create a RADIUS scheme named office and enter its view.

[AC] radius scheme office

# Specify the IP addresses of the primary authentication and accounting RADIUS servers.

[AC-radius-office] primary authentication 8.1.1.50

[AC-radius-office] primary accounting 8.1.1.50

# Set the shared key to 12345678 in plain text for secure communication with the servers.

[AC-radius-office] key authentication simple 12345678

[AC-radius-office] key accounting simple 12345678

# Specify IP address 138.100.1.101 as the source IP address for outgoing RADIUS packets.

[AC-radius-office] nas-ip 138.100.1.101

[AC-radius-office] quit

# Create an ISP domain named office and enter its view.

[AC] domain office

# Apply RADIUS scheme office to ISP domain office for LAN user authentication and authorization, and do not perform accounting for LAN users in the domain.

[AC-isp-office] authentication lan-access radius-scheme office

[AC-isp-office] authorization lan-access radius-scheme office

[AC-isp-office] accounting lan-access none

[AC-isp-office] quit

3.     Configure a wireless service:

# Create a service template named 1 and enter its view.

[AC] wlan service-template 1

# Configure the SSID of the service template as service.

[AC-wlan-st-1] ssid service

# Assign clients coming online through the service template to VLAN 200.

[AC-wlan-st-1] vlan 200

# Set the AKM mode to 802.1X.

[AC-wlan-st-1] akm mode dot1x

# Set the authentication mode to 802.1X.

[AC-wlan-st-1] client-security authentication-mode dot1x

# Specify ISP domain office for authenticating 802.1X clients.

[AC-wlan-st-1] dot1x domain office

# Set the cipher suite to CCMP.

[AC-wlan-st-1] cipher-suite ccmp

# Enable the RSN IE in beacon and probe responses.

[AC-wlan-st-1] security-ie rsn

# Enable the service template.

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

4.     Configure a manual AP:

# Create a manual AP named ap1, and specify the AP model and serial ID

[AC] wlan ap ap1 model WA4320i-ACN

[AC-wlan-ap-ap1] serial-id 210235A1GQC14C000225

# Enter the view of radio 1.

[AC-wlan-ap-ap1] radio 1

# Bind service template 1 to radio 1, and enable radio 1.

[AC-wlan-ap-ap1-radio-1] service-template 1

[AC-wlan-ap-ap1-radio-1] radio enable

[AC-wlan-ap-ap1-radio-1] quit

[AC-wlan-ap-ap1] quit

5.     Configure ACL 3001 to deny packets destined for IP address 8.1.1.5.

[AC] acl advanced 3001

[AC-acl-ipv4-adv-3001] rule 1 deny ip destination 8.1.1.5 0

[AC-acl-ipv4-adv-3001] quit

6.     Configure a static route whose next hop address is 138.100.1.100.

[AC] ip route-static 0.0.0.0 0.0.0.0 138.100.1.100

Configuring the switch

1.     Configure interfaces on the switch:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The switch will use this VLAN to communicate with the AC.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 138.100.1.100 16

[Switch-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. The switch will use this VLAN to communicate with the client.

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 138.200.1.100 16

[Switch-Vlan-interface200] quit

# Create VLAN 8 and VLAN-interface 8, and assign an IP address to the VLAN interface. The switch will use this VLAN to communicate with the RADIUS servers.

[Switch] vlan 8

[Switch-vlan8] quit

[Switch] interface vlan-interface 8

[Switch-Vlan-interface8] ip address 8.1.1.100 16

[Switch-Vlan-interface8] quit

# Configure GigabitEthernet 1/0/1 (the port connected to the AC) as a trunk port, and assign the trunk port to all VLANs.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan all

# Set the PVID of GigabitEthernet 1/0/1 to VLAN 100.

[Switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/1] quit

2.     Configure DHCP:

# Enable DHCP.

[Switch] dhcp enable

# Configure DHCP pool vlan100 to assign an IP address to the AP. Specify subnet 138.100.0.0/16 and gateway address 138.100.1.100 in the pool.

[Switch] dhcp server ip-pool vlan100

[Switch-dhcp-pool-vlan100] network 138.100.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan100] gateway-list 138.100.1.100

[Switch-dhcp-pool-vlan100] quit

# Configure DHCP pool vlan200 to assign an IP address to the client. Specify subnet 138.200.0.0/16 and gateway address 138.200.1.100 in the pool. In this example, the address of the DNS server is 138.200.1.100 (the gateway address). You must replace it with the actual address of the DNS server on your network.

[Switch] dhcp server ip-pool vlan200

[Switch-dhcp-pool-vlan200] network 138.200.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan200] gateway-list 138.200.1.100

[Switch-dhcp-pool-vlan200] dns-list 138.200.1.100

[Switch-dhcp-pool-vlan200] quit

Configuring the RADIUS server

In this example, the RADIUS server runs IMC PLAT 7.1(E0302) and IMC WSM 7.1(E0303).

1.     Add an access device:

a.     Log in to IMC and click the User tab.

b.     From the navigation tree, select User Access Policy > Access Device Management > Access Device.

c.     Click Add.

The Add Access Device page opens.

d.     In the Access Configuration area, configure the following parameters, as shown in Figure 2:

-     Enter 12345678 in the Shared Key and Confirm Shared Key fields.

-     Use the default values for other parameters.

e.     In the Device List area, click Add Manually to add the device at 138.100.1.101 as an access device.

f.     Click OK.

Figure 2 Adding an access device

 

2.     Add an access policy:

a.     Click the User tab.

b.     From the navigation tree, select User Access Policy > Access Policy.

c.     Click Add.

d.     On the Add Access Policy page, configure the following parameters, as shown in Figure 3:

-     Enter wjh1x in the Access Policy Name field.

-     Select EAP for the Certificate Authentication field.

-     Select EAP-PEAP Auth from the Certificate Type list, and select MS-CHAPV2 Auth from the Certificate Sub-Type list.

-     Select Deploy ACL and Add Manually, and enter an ACL number that is the same as the ACL configured on the AC.

-     Use the default values for other parameters.

e.     Click OK.

Figure 3 Adding an access policy

 

3.     Add an access service:

a.     Click the User tab.

b.     From the navigation tree, select User Access Policy > Access Service.

c.     Click Add.

d.     On the Add Access Service page, configure the following parameters, as shown in Figure 4:

-     Enter wjh1x in the Service Name field.

-     Select wjh1x from the Default Access Policy list.

-     Use the default values for other parameters.

e.     Click OK.

Figure 4 Adding an access service

 

4.     Add an access user:

a.     Click the User tab.

b.     From the navigation tree, select Access User > All Access Users.

The access user list opens.

c.     Click Add.

The Add Access User page opens.

d.     In the Access Information area, configure the following parameters, as shown in Figure 5:

-     Click Add User. On the dialog box that opens, enter wjh1x and 123456 in the User Name and Identity Number fields, respectively. Click Check Availability to verify the validity of the username and identity number, and then click OK.

-     Enter wjh1x in the Account Name field.

-     Enter 12345678 in the Password and Confirm Password fields.

e.     In the Access Service area, select wjh1x from the list.

f.     Click OK.

Figure 5 Adding an access user account

 

Verifying the configuration

# On the client, use the username and password configured on the RADIUS server for wireless access. (Details not shown.)

# Verify that the client has passed authentication and come online.

<AC> display wlan client verbose

 

Total number of clients: 1

 MAC address                       : 0015-00ba-0428

 IPv4 address                      : 138.200.0.1

 IPv6 address                      : N/A

 Username                          : wjh1x

 AID                               : 1

 AP ID                             : 1

 AP name                           : ap1

 Radio ID                          : 1

 SSID                              : service

 BSSID                             : 5866-ba71-3960

 VLAN ID                           : 200

 Sleep count                       : 0

 Wireless mode                     : 802.11ac

 Channel bandwidth                 : 40MHz

 SM power save                     : Disabled

 Short GI for 20MHz                : Supported

 Short GI for 40MHz                : Supported

 STBC RX capability                : Supported

 STBC TX capability                : Not supported

 LDPC RX capability                : Not supported

 Block Ack                         : N/A

 Supported HT MCS set              : 0, 1, 2, 3, 4, 5, 6, 7,

                                     8, 9, 10, 11, 12, 13, 14,

                                     15

 Supported rates                   : 6, 9, 12, 18, 24, 36,

                                     48, 54 Mbps

 QoS mode                          : WMM

 Listen interval                   : 250

 RSSI                              : 0

 Rx/Tx rate                        : 0/0

 Authentication method             : Open system

 Security mode                     : RSN

 AKM mode                          : 802.1X

 Cipher suite                      : CCMP

 User authentication mode          : 802.1X

 Authorization ACL ID              : 3001

 Authorization user profile        : N/A

 Roam status                       : N/A

 Key derivation                    : SHA1

 PMF status                        : N/A

 Forwarding policy name            : N/A

 Online time                       : 0days 0hours 0minutes 17seconds

 FT status                         : Inactive

# Verify that the client can ping 8.1.1.50 successfully and cannot ping 8.1.1.5. (Details not shown.)

Configuration files

·     AC:

#

port-security enable

#

dot1x authentication-method eap

#

vlan 100

#

vlan 200

#

wlan service-template 1

 ssid service

 vlan 200

 akm mode dot1x

 cipher-suite ccmp

 security-ie rsn

 client-security authentication-mode dot1x

 dot1x domain office

 service-template enable

#

interface Vlan-interface100

 ip address 138.100.1.101 255.255.0.0

#

interface Vlan-interface200

 ip address 138.200.1.101 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

ip route-static 0.0.0.0 0.0.0.0 138.100.1.100

#

acl advanced 3001

 rule 1 deny ip destination 8.1.1.5 0

#

radius scheme office

 primary authentication 8.1.1.50

 primary accounting 8.1.1.50

 key authentication cipher $c$3$h7ouSYGGL5EgJZ6HpwIIgRdgiLKJCd6zZxE4

 key accounting cipher $c$3$qf3E+i6hAgx/rpYxDApL0E0NSDWHZCZ3OI1g

 nas-ip 138.100.1.101

#

domain office

 authentication lan-access radius-scheme office

 authorization lan-access radius-scheme office

 accounting lan-access none

#

wlan ap ap1 model WA4320i-ACN

 serial-id 210235A1GQC14C000225

 radio 1

  radio enable

  service-template 1

 radio 2

·     Switch:

#

vlan 8

#

vlan 100

#

vlan 200

#

dhcp server ip-pool vlan100

network 138.100.0.0 mask 255.255.0.0

gateway-list 138.100.1.100

#

dhcp server ip-pool vlan200

network 138.200.0.0 mask 255.255.0.0

gateway-list 138.200.1.100

dns-list 138.200.1.100

#

interface Vlan-interface8

 ip address 8.1.1.100 255.255.0.0

#

interface Vlan-interface100

 ip address 138.100.1.100 255.255.0.0

#

interface Vlan-interface200

 ip address 138.200.1.100 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan all

 port trunk pvid vlan 100

#

dhcp enable

Related documentation

·     AP and WT Management Configuration Guide in H3C Access Controllers Configuration Guides

·     AP and WT Management Command Reference in H3C Access Controllers Command References

·     Network Connectivity Configuration Guide in H3C Access Controllers Configuration Guides

·     Network Connectivity Command Reference in H3C Access Controllers Command References

·     User Access and Authentication Configuration Guide in H3C Access Controllers Configuration Guides

·     User Access and Authentication Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Access Command Reference in H3C Access Controllers Command References