06-Wireless authentication

HomeSupportResource CenterH3C Access Controllers Configuration Examples(V7)-6W10206-Wireless authentication
Table of Contents
Related Documents
21-MAC Authentication with Guest VLAN Assignment (IPv6) Configuration Examples

 

H3C Access Controllers

Comware 7 MAC Authentication with Guest VLAN Assignment (IPv6)

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example for configuring a guest VLAN to accommodate clients that fail MAC authentication on an IPv6 network.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of AAA, MAC authentication, WLAN authentication, and WLAN access.

Example: Configuring MAC authentication with guest VLAN assignment (IPv6)

Network configuration

As shown in Figure 1, the AC acts as a DHCPv6 server to provide IPv6 addresses for the AP and its attached clients. The AC centrally forwards client traffic.

To control the access of clients to network resources:

·     Configure VLAN 200 as the access VLAN of the clients.

·     Use the AC with a RADIUS server to perform MAC authentication for the clients.

·     Configure VLAN 300 as the guest VLAN in the service template for the clients. A client is moved to the guest VLAN if it fails authentication and will stay in the guest VLAN until it passes re-authentication, which is performed every 30 seconds.

Figure 1 Network diagram

 

Restrictions and guidelines

When you configure MAC authentication for wireless clients, follow these restrictions and guidelines:

·     Use the serial ID labeled on the AP's rear panel to specify an AP.

·     To prevent too many packets from entering VLAN 1, configure the switch's interface that connects the switch to the AP to deny packets from VLAN 1.

·     Some endpoints by default use random MAC addresses. To ensure successful MAC authentication for such an endpoint, disable the endpoint from using a random MAC address.

Procedures

Configuring the AC

1.     Configure interfaces on the AC:

# Create VLAN 100 and VLAN-interface 100, and assign an IPv6 address to the VLAN interface. The AC will use this IP address to establish CAPWAP tunnels with the AP.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ipv6 address 2001::1 64

# Disable RA message suppression on VLAN-interface 100.

[AC-Vlan-interface100] undo ipv6 nd ra halt

# Set the managed address configuration flag (M) to 1 in RA advertisements to be sent.

[AC-Vlan-interface100] ipv6 nd autoconfig managed-address-flag

# Set the other stateful configuration flag (O) to 1 in RA advertisements to be sent.

[AC-Vlan-interface100] ipv6 nd autoconfig other-flag

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IPv6 address to the VLAN interface. The client will use VLAN 200 to access the WLAN.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ipv6 address 2004::1 64

# Disable RA message suppression on VLAN-interface 200.

[AC-Vlan-interface200] undo ipv6 nd ra halt

# Set the managed address configuration flag (M) to 1 in RA advertisements to be sent.

[AC-Vlan-interface200] ipv6 nd autoconfig managed-address-flag

# Set the other stateful configuration flag (O) to 1 in RA advertisements to be sent.

[AC-Vlan-interface200] ipv6 nd autoconfig other-flag

[AC-Vlan-interface200] quit

# Create VLAN 300 and VLAN-interface 300, and assign an IPv6 address to the VLAN interface. The AC will use VLAN 300 as a guest VLAN to accommodate clients that fail MAC authentication.

[AC] vlan 300

[AC-vlan300] quit

[AC] interface vlan-interface 300

[AC-Vlan-interface300] ipv6 address 2003::1 64

# Disable RA message suppression on VLAN-interface 300.

[AC-Vlan-interface300] undo ipv6 nd ra halt

# Set the managed address configuration flag (M) to 1 in RA advertisements to be sent.

[AC-Vlan-interface300] ipv6 nd autoconfig managed-address-flag

# Set the other stateful configuration flag (O) to 1 in RA advertisements to be sent.

[AC-Vlan-interface300] ipv6 nd autoconfig other-flag

[AC-Vlan-interface300] quit

# Configure GigabitEthernet 1/0/1 (the port connected to the switch) as a trunk port, remove the port from VLAN 1, and assign the port to VLANs 100, 200, and 300.

[AC] interface gigabitEthernet1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200 300

# Set the PVID of GigabitEthernet 1/0/1 to VLAN 100.

[AC-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC-GigabitEthernet1/0/1] quit

2.     Configure the DHCPv6 service:

# Enable the DHCPv6 server on VLAN-interface 100 and VLAN-interface 200, apply address pool vlan100 to VLAN-interface 100, and apply address pool vlan200 to VLAN-interface 200.

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ipv6 dhcp select server

[AC-Vlan-interface100] ipv6 dhcp server apply pool vlan100

[AC-Vlan-interface100] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ipv6 dhcp select server

[AC-Vlan-interface200] ipv6 dhcp server apply pool vlan200

[AC-Vlan-interface200] quit

# Create a DHCPv6 address pool named vlan100, and specify subnet 2001::/64 in the DHCPv6 address pool.

[AC] ipv6 dhcp pool vlan100

[AC-dhcpv6-pool-vlan100] network 2001::/64

[AC-dhcpv6-pool-vlan100] quit

# Create a DHCPv6 address pool named vlan200, and specify subnet 2004::/64 in the DHCPv6 address pool.

[AC] ipv6 dhcp pool vlan200

[AC-dhcpv6-pool-vlan200] network 2004::/64

[AC-dhcpv6-pool-vlan200] quit

# Create a DHCPv6 address pool named vlan300, and specify subnet 2003::/64 in the DHCPv6 address pool.

[AC] ipv6 dhcp pool vlan300

[AC-dhcpv6-pool-vlan300] network 2003::/64

[AC-dhcpv6-pool-vlan300] quit

3.     Configure RADIUS-based MAC authentication:

# Create a RADIUS scheme named office and enter its view.

[AC] radius scheme office

# Specify the IP addresses of the primary authentication and accounting RADIUS servers.

[AC-radius-office] primary authentication ipv6 2001::2 64

[AC-radius-office] primary accounting ipv6 2001::2 64

# Specify the shared keys for RADIUS authentication and accounting.

[AC-radius-office] key authentication simple 123456789

[AC-radius-office] key accounting simple 123456789

# Exclude ISP domain names from usernames sent to the RADIUS servers.

[AC-radius-office] user-name-format without-domain

# Specify IPv6 address 2001::1 as the source IPv6 address of outgoing RADIUS packets.

[AC-radius-office] nas-ip ipv6 2001::1

[AC-radius-office] quit

# Create an ISP domain named office1 and enter its view.

[AC] domain office1

# Apply RADIUS scheme office to ISP domain office1 for LAN user authentication, authorization, and accounting.

[AC-isp-office1] authentication lan-access radius-scheme office

[AC-isp-office1] authorization lan-access radius-scheme office

[AC-isp-office1] accounting lan-access radius-scheme office

# Configure the idle cut feature for clients in ISP domain office1.

[AC-isp-office1] authorization-attribute idle-cut 15 1024

[AC-isp-office1] quit

# Configure the AC to use the MAC address of each user as both the username and password for MAC authentication. The MAC addresses are in hexadecimal notation without hyphens, and letters are in lower case. (The configuration in this step is the default configuration. This step is optional.)

[AC] mac-authentication user-name-format mac-address without-hyphen lowercase

4.     Configure a wireless service:

# Create a service template named 1 and enter its view.

[AC] wlan service-template 1

# Set the SSID of service template 1 to service.

[AC-wlan-st-1] ssid service

# Assign clients coming online through the service template to VLAN 200.

[AC-wlan-st-1] vlan 200

# Enable snooping ND packets.

[AC-wlan-st-1] client ipv6-snooping nd-learning enable

# Enable snooping DHCPv6 packets.

[AC-wlan-st-1] client ipv6-snooping dhcpv6-learning enable

# Set the authentication mode to MAC authentication.

[AC-wlan-st-1] client-security authentication-mode mac

# Specify the MAC authentication domain as ISP domain office1.

[AC-wlan-st-1] mac-authentication domain office1

5.     Configure a guest VLAN:

# Specify VLAN 300 as the guest VLAN for clients that fail MAC authentication on service template 1.

[AC-wlan-st-1] client-security authentication fail-vlan 300

# Enable the service template.

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

6.     Configure manual AP officeap, and bind service template 1 to an AP radio:

# Create a manual AP named officeap, and specify the AP model and serial ID.

[AC] wlan ap officeap model WA4320i-ACN

[AC-wlan-ap-officeap] serial-id 210235A1Q2C159000020

# Enter the view of radio 2, and bind service template 1 to radio 2.

[AC-wlan-ap-officeap] radio 2

[AC-wlan-ap-officeap-radio-2] service-template 1

# Enable radio 2.

[AC-wlan-ap-officeap-radio-2] radio enable

[AC-wlan-ap-officeap-radio-2] quit

[AC-wlan-ap-officeap] quit

Configuring the switch

# Create VLAN 100. The switch will use this VLAN to forward the traffic on the CAPWAP tunnels between the AC and AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# Create VLAN 200. The switch will use this VLAN to forward packets for wireless clients.

[Switch] vlan 200

[Switch-vlan200] quit

# Create VLAN 300. The switch will use this VLAN to forward packets in the guest VLAN.

[Switch] vlan 300

[Switch-vlan300] quit

# Configure GigabitEthernet 1/0/1 (the port connected to the AC) as a trunk port, remove the port from VLAN 1, and assign the trunk port to VLAN 100.

[Switch] interface gigabitEthernet1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100

# Set the PVID of GigabitEthernet 1/0/1 to VLAN 100.

[Switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 (the port connected to the AP) as an access port. Assign the access port to VLAN 100.

[Switch] interface gigabitEthernet1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# Enable PoE on GigabitEthernet 1/0/2.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

Configuring the RADIUS server

This example uses IMC PLAT 7.1 (E0303P10) and IMC UAM 7.1 (E0303P10) to show the procedure.

1.     Add an access device:

a.     Log in to IMC.

b.     Click the User tab.

c.     From the navigation tree, select User Access Policy > Access Device Management > Access Device.

d.     Click Add.

The Add Access Device page opens.

e.     In the Device List area, click Add IPv6 Dev.

f.     Enter 2001::1 as the start IPv6 address, and then click OK.

This IPv6 address is the source IPv6 address specified on the AC for outgoing RADIUS packets.

g.     In the Access Configuration area, configure the following parameters, as shown in Figure 2:

-     Enter 123456789 in the Shared Key and Confirm Shared Key fields.

The key is consistent with the shared key configured on the AC.

-     Use the default values for other parameters.

h.     Click OK.

Figure 2 Adding an access device

 

2.     Add an access policy:

a.     Click the User tab.

b.     From the navigation tree, select User Access Policy > Access Policy.

c.     Click Add.

d.     On the Add Access Policy page, configure the following parameters, as shown in Figure 3:

-     Enter office in the Access Policy Name field.

-     Use the default values for other parameters.

e.     Click OK.

Figure 3 Adding an access policy

 

3.     Add an access service:

a.     Click the User tab.

b.     From the navigation tree, select User Access Policy > Access Service.

c.     Click Add.

d.     On the Add Access Service page, configure the following parameters, as shown in Figure 4:

-     Enter office_mac in the Service Name field.

-     Select office from the Default Access Policy list.

-     Use the default values for other parameters.

e.     Click OK.

Figure 4 Adding an access service

 

4.     Add an access user:

a.     Click the User tab.

b.     From the navigation tree, select Access User > Access User.

The access user list opens.

c.     Click Add.

The Add Access User page opens.

d.     In the Access Information area, add a user, as shown in Figure 5:

-     Click Add User.

-     On the dialog box that opens, enter adm_office_mac in the User Name and Identity Number fields.

-     Click Check Availability to verify the validity of the username and identity number.

-     Click OK.

e.     In the Access Information area, configure the MAC authentication user account, as shown in Figure 6:

-     Enter admin in the Account Name field.

-     Enter 123456 in the Password and Confirm Password fields.

 

 

NOTE:

To test the guest VLAN functionality, the user account settings in this example are inconsistent with the MAC authentication username and password format configured on the AC. On a live network, you must make sure the usernames and passwords for the clients are their MAC addresses in the format specified on the AC.

 

f.     In the Access Service area, select office_mac from the list.

g.     Click OK.

Figure 5 Adding a user

 

Figure 6 Adding an access user account

 

Verifying the configuration

# Attempt to access the network from a client.

# On the AC, verify that the wireless client fails MAC authentication and is assigned to VLAN 300.

[AC] display wlan client

 Total Number of Clients           : 1

 

MAC address     Username      AP name         RID  IP address      IPv6 address   VLAN

3ca9-f414-4c20  N/A           officeap        2    N/A             2003::2        300

# Verify that the wireless client in the guest VLAN can access network resources only in VLAN 300 before passing MAC authentication. (Details not shown.)

# Modify the username and password on the RADIUS server to the MAC address of the client. The MAC address is in hexadecimal notation without hyphens, and letters are in lower case. (Details not shown.)

# Display MAC authentication information after the wireless client in the guest VLAN passes MAC authentication.

[AC] display mac-authentication

Global MAC authentication parameters:

 MAC authentication     : Enabled

 User name format       : MAC address in lowercase(xxxxxxxxxxxx)

           Username       : mac

           Password       : Not configured

   Offline detect period  : 300 s

 Quiet period           : 60 s

 Server timeout         : 100 s

 Authentication domain  : Not configured, use default domain

 Online MAC-auth wired users    : 0

 Online MAC-auth wireless users : 1

 

Silent MAC users:

          MAC address       VLAN ID  From port               Port index

 

 AP name: officeap  Radio ID: 2  SSID: service

   BSSID                      : 741f-4ad4-8d50

   MAC authentication         : Enabled

   Authentication domain      : office1

   Max online users           : 4096

   Authentication attempts    : successful 0, failed 42

Configuration files

·     AC:

#

vlan 100

#

vlan 200

#

vlan 300

#

ipv6 dhcp pool vlan100

 network 2001::/64

#

ipv6 dhcp pool vlan200

 network 2004::/64

#

ipv6 dhcp pool vlan300

 network 2003::/64

#

wlan service-template 1

 ssid service

 vlan 200

 client-security authentication-mode mac

 client-security authentication fail-vlan 300

 mac-authentication domain office1

 client ipv6-snooping nd-learning enable

 client ipv6-snooping dhcpv6-learning enable

 service-template enable

#

interface Vlan-interface100

 ipv6 dhcp select server

 ipv6 dhcp server apply pool vlan100

 ipv6 address 2001::1/64

 ipv6 nd autoconfig managed-address-flag

 ipv6 nd autoconfig other-flag

 undo ipv6 nd ra halt

#

interface Vlan-interface200

 ipv6 dhcp select server

 ipv6 dhcp server apply pool vlan100

 ipv6 address 2004::1/64

 ipv6 nd autoconfig managed-address-flag

 ipv6 nd autoconfig other-flag

 undo ipv6 nd ra halt

#

interface Vlan-interface300

 ipv6 address 2003::1/64

 ipv6 nd autoconfig managed-address-flag

 ipv6 nd autoconfig other-flag

 undo ipv6 nd ra halt

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200 300

 port trunk pvid vlan 100

#

radius scheme office

 primary authentication ipv6 2001::2 64

 primary accounting ipv6 2001::2 64

 key authentication cipher $c$3$IrnigzRDMkG7Jk1FNf2+tm04+zvnCwiaJzI9TA==

 key accounting cipher $c$3$ehledYNyJ+vTlcYcyUEisTa+ZXvWqU1O2QlSYg==

 user-name-format without-domain

 nas-ip ipv6 2001::1

#

domain office1

 authorization-attribute idle-cut 15 1024

 authentication lan-access radius-scheme office

 authorization lan-access radius-scheme office

 accounting lan-access radius-scheme office

#

wlan ap officeap model WA4320i-ACN

 serial-id 210235A1Q2C159000020

 radio 1

 radio 2

  radio enable

  service-template 1

#

·     Switch:

#

vlan 100

#

vlan 200

#

vlan 300

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100

 port trunk pvid vlan 100

#

interface GigabitEthernet1/0/2

 port access vlan 100

 poe enable

#

Related documentation

·     AP and WT Management Configuration Guide in H3C Access Controllers Configuration Guides

·     AP and WT Management Command Reference in H3C Access Controllers Command References

·     Network Connectivity Configuration Guide in H3C Access Controllers Configuration Guides

·     Network Connectivity Command Reference in H3C Access Controllers Command References

·     User Access and Authentication Configuration Guide in H3C Access Controllers Configuration Guides

·     User Access and Authentication Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Access Command Reference in H3C Access Controllers Command References