06-Wireless authentication

HomeSupportResource CenterH3C Access Controllers Configuration Examples(V7)-6W10206-Wireless authentication
Table of Contents
Related Documents
08-Local Forwarding Mode and Local Portal MAC-Trigger Authentication Configuration Examples

 

H3C Access Controllers

Comware 7 Local Forwarding Mode and Local Portal MAC-Trigger Authentication

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example of configuring local portal MAC-trigger authentication for clients on a wireless network where APs forward client traffic locally.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of AAA, portal, and WLAN.

Example: Configuring local forwarding mode and local portal MAC-trigger authentication

Network configuration

As shown in Figure 1:

·     The AP and the client obtain IP addresses from the DHCP server.

·     The AC acts as the portal authentication server, portal Web server, and MAC binding server.

Configure the devices to meet the following requirements:

·     The AC performs local portal MAC-trigger authentication on the wireless client. The client can access only the portal Web server before passing portal authentication and can access other network resources after passing portal authentication.

·     The client can access the network without portal authentication before the network traffic reaches 1024000 bytes. Once the threshold is reached, MAC-trigger authentication (MAC-based quick portal authentication) is performed.

·     The AP forwards the client traffic locally.

·     The client can access the network resources through any Layer 2 ports in its access VLAN without re-authentication.

Figure 1 Network diagram

 

Analysis

For the client to access network resources through any Layer 2 ports in its access VLAN without re-authentication, enable portal roaming.

To use GigabitEthernet 1/0/1 on the AP to forward client traffic, edit a .txt configuration file and upload the file to the AC.

Restrictions and guidelines

Use the serial ID labeled on the AP's rear panel to specify an AP.

By default, the URL of the portal Web server to which the AC redirects portal users does not carry any parameters. You can add parameters to be carried in the URL as needed.

To avoid portal authentication failure caused by frequent logins and logouts in a short time, disable the Rule ARP entry feature.

Some types of endpoints use random MAC by default, which might cause failure of the MAC-trigger authentication. As a best practice, disable the random MAC feature on the endpoints.

Procedures

Editing the AP configuration file

# Use a text editor to edit the AP's configuration file. Name the configuration file map.txt, and then upload the file to the storage medium of the AC.

The content of the configuration file is as follows:

System-view

vlan 200

interface gigabitethernet1/0/1

port link-type trunk

port trunk permit vlan 200

Configuring the AC

1.     Configure interfaces on the AC:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The AC will use this IP address to establish CAPWAP data and control tunnels with the AP.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 2.2.1.1 24

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. The AC will use VLAN 200 for client access.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 2.2.2.1 24

[AC-Vlan-interface200] quit

2.     Configure a wireless service:

# Create a service template named st1 and enter its view.

[AC] wlan service-template st1

# Set the SSID of service template st1 to service.

[AC-wlan-st-st1] ssid service

# Assign clients coming online through service template st1 to VLAN 200.

[AC-wlan-st-st1] vlan 200

# Configure APs to forward client data traffic from all VLANs.

[AC–wlan-st-st1] client forwarding-location ap

[AC-wlan-st-st1] quit

# Create an AP named office with model WA4320i-ACN and specify its serial ID of the AP.

[AC] wlan ap office model WA4320i-ACN

[AC-wlan-ap-office] serial-id 219801A0CNC138011454

# Deploy configuration file map.txt to the AP.

[AC-wlan-ap-office] map-configuration map.txt

# Enter the view of radio 2.

[AC-wlan-ap-office] radio 2

# Bind service template st1 to radio 2 in AP office.

[AC-wlan-ap-office-radio-2] service-template st1

# Enable radio 2.

[AC-wlan-ap-office-radio-2] radio enable

[AC-wlan-ap-office-radio-2] quit

[AC-wlan-ap-office] quit

3.     Configure an ISP domain:

# Create an ISP domain named dm1 and enter its view.

[AC] domain dm1

# Configure the AC to perform local authentication and not to perform authorization or accounting on portal users in the ISP domain.

[AC-isp-dm1] authentication portal local

[AC-isp-dm1] authorization portal none

[AC-isp-dm1] accounting portal none

# Set the idle timeout period to 15 minutes and the minimum traffic that must be generated in the idle timeout period to 1024 bytes.

[AC-isp-dm1] authorization-attribute idle-cut 15 1024

[AC-isp-dm1] quit

4.     Configure portal authentication:

# Create a portal Web server named newpt and specify http://2.2.2.1:8080/portal as the URL of portal Web server newpt.

[AC] portal web-server newpt

[AC-portal-websvr-newpt] url http://2.2.2.1:8080/portal

# Add the wlanuserip parameter to the URL of the portal Web server and specify the user IP address as the parameter value.

[AC-portal-websvr-newpt] url-parameter wlanuserip source-address

[AC-portal-websvr-newpt] quit

# Configure two destination-based portal-free rules to permit the traffic destined for the DNS server.

[AC] portal free-rule 1 destination ip any udp 53

[AC] portal free-rule 2 destination ip any tcp 53

# Create an HTTP-based local portal Web service.

[AC] portal local-web-server http

# Specify file abc.zip as the default authentication page file and 8080 as the service port number for the local portal Web service. (Make sure the file already exists under the root directory of the device storage media.)

[AC–portal-local-websvr-http] default-logon-page abc.zip

[AC–portal-local-websvr-http] tcp-port 8080

[AC–portal-local-websvr-http] quit

# Add a local network access user named portaluser, set the password of the user, and assign the portal service to the user.

[AC] local-user portaluser class network

[AC-luser-network-portaluser] password simple abc123

[AC-luser-network-portaluser] service-type portal

[AC-luser-network-portaluser] quit

# Enable portal roaming.

[AC] portal roaming enable

# Disable the Rule ARP entry feature for portal clients.

[AC] undo portal refresh arp enable

# Enable validity check on wireless portal clients.

[AC] portal host-check enable

5.     Configure portal MAC-trigger authentication:

# Create a MAC binding server named mts and enter its view.

[AC] portal mac-trigger-server mts

# Specify 2.2.2.1 as the IP address of MAC binding server mts.

[AC-portal-mac-trigger-server-mts] ip 2.2.2.1

# Enable local portal MAC-trigger authentication, and set the aging time for local MAC-account binding entries to 60 minutes.

[AC-portal-mac-trigger-server-mts] local-binding enable

[AC-portal-mac-trigger-server-mts] local-binding aging-time 60

[AC-portal-mac-trigger-server-mts] quit

# Enable direct portal authentication on service template st1.

[AC] wlan service-template st1

[AC-wlan-st-st1] portal enable method direct

# Specify ISP domain dm1 as the authentication domain for portal users on service template st1.

[AC-wlan-st-st1] portal domain dm1

# Specify portal Web server newpt on service template st1.

[AC-wlan-st-st1] portal apply web-server newpt

# Specify MAC binding server mts on service template st1.

[AC] wlan service-template st1

[AC-wlan-st-st1] portal apply mac-trigger-server mts

# Enable service template st1.

[AC-wlan-st-service1] service-template enable

[AC-wlan-st-st1] quit

Configuring the switch

# Create VLAN 100. The switch will use this VLAN to forward traffic on the CAPWAP tunnel between the AC and the AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# Create VLAN 200. The switch will use this VLAN to forward client traffic.

[Switch] vlan 200

[Switch-vlan200] quit

# Create VLAN 2.

[Switch] vlan 2

[Switch-vlan2] quit

# Configure GigabitEthernet 1/0/1 (the port connected to the AC) as a trunk port and assign the port to VLAN 100 and VLAN 200.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 (the port connected to the AP) as a trunk port, assign the port to VLAN 100 and VLAN 200, and set the PVID to VLAN 100.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type trunk

[Switch-GigabitEthernet1/0/2] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/2] port trunk pvid vlan 100

# Enable PoE on GigabitEthernet 1/0/2.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

# Assign an IP address to VLAN-interface 200.

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 2.2.2.100 255.255.255.0

[Switch-Vlan-interface200] quit

Verifying the configuration

# Display information about MAC binding server mts.

[AC] display portal mac-trigger-server name mts

[AC] display portal mac-trigger-server name mts

Portal mac trigger server name: mts

  Version                    : 1.0

  Server type                : IMC

  IP                         : 2.2.2.1

  Port                       : 50100

  VPN instance               : Not configured

  Aging time                 : 300 seconds

  Free-traffic threshold     : 0 bytes

  NAS-Port-Type              : Not configured

  Binding retry times        : 3

  Binding retry interval     : 1 seconds

  Authentication timeout     : 3 minutes

  Local-binding              : Enabled

  Local-binding aging-time   : 60 minutes

  aaa-fail nobinding         : Disabled

  Excluded attribute list    : Not configured

  Cloud-binding              : Disabled

  Cloud-server URL           : Not configured

# Use the configured user account to perform portal authentication through a Web browser. Before passing portal authentication, the user can access only the authentication page http://2.2.2.1:8080/portal. All Web requests from the user will be redirected to the authentication page. After passing portal authentication, the user can access other network resources. (Details not shown.)

# Display information about all portal users.

[AC] display portal user all

Total portal users: 1

Username: portaluser

  AP name: office

  Radio ID: 2

  SSID: service

  Portal server: newpt

  State: Online

  VPN instance: N/A

  MAC             IP                    VLAN    Interface

  0021-6330-0933  2.2.2.2               200     WLAN-BSS1/0/2

  Authorization information:

    DHCP IP pool: N/A

    User profile: N/A

    Session group profile: N/A

    ACL number: N/A

    Inbound CAR: N/A

    Outbound CAR: N/A

The output shows that the user has passed portal authentication.

# Log out the user and then get the user to come online again to verify that the user can directly access network resources without entering the username and password.

Configuration files

·     AC:

#

vlan 100

#

vlan 200

#

wlan service-template st1

 ssid service

 vlan 200

client forwarding-location ap

 portal enable method direct

 portal domain dm1

 portal apply web-server newpt

 portal apply mac-trigger-server mts

 service-template enable

#

interface Vlan-interface100

 ip address 2.2.1.1 255.255.255.0

#

interface Vlan-interface200

 ip address 2.2.2.1 255.255.255.0

#

domain dm1

 authorization-attribute idle-cut 15 1024

 authentication portal local

 authorization portal none

 accounting portal none

#

portal host-check enable

portal free-rule 1 destination ip any udp 53

portal free-rule 2 destination ip any tcp 53

#

 portal roaming enable

 undo portal refresh arp enable

#

 portal web-server newpt

 url http://2.2.2.1:8080/portal

 server-type imc

 url-parameter wlanuserip source-address

#

portal local-web-server http

 default-logon-page abc.zip

tcp-port 8080

#

portal mac-trigger-server mts

 ip 2.2.2.1

 server-type imc

#

wlan ap office model WA4320i-ACN

 serial-id 219801A0CNC138011454

map-configuration flash:/map.txt

 radio 1

 radio 2

  radio enable

  service-template st1

#

·     Switch:

#

vlan 2

#

vlan 100

#

vlan 200

#

interface Vlan-interface2

 ip address 192.168.0.100 255.255.255.0

#

interface Vlan-interface200

 ip address 2.2.2.100 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 100 200

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan 1 100 200

port trunk pvid vlan 100

 poe enable

Related documentation

·     User Access and Authentication Command Reference in H3C Access Controllers Command References

·     User Access and Authentication Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Access Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides

·     AP Management Command Reference in H3C Access Controllers Command References

·     AP Management Configuration Guide in H3C Access Controllers Configuration Guides