05-WLAN access

HomeSupportResource CenterH3C Access Controllers Configuration Examples(V7)-6W10205-WLAN access
06-Scheduled Configuration Deployment by AP Group Configuration Examples

 

H3C Access Controllers

Comware 7 Scheduled Configuration Deployment by AP Group

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example for configuring scheduled configuration deployment by AP group.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of WLAN access.

Example: Configuring scheduled configuration deployment by AP group

Network configuration

As shown in Figure 1, the AP connects to the AC through a Layer 2 switch and the Layer 2 switch supplies power to the AP through PoE. The AC acts as a DHCP server to assign IP addresses to the AP and the client.

Configure a schedule to enable radio 1 on the AP at 8:00 and disable the radio at 20:00 every day.

Figure 1 Network diagram

 

Analysis

For the AC to act as a DHCP server, enable the DHCP server feature on the AC.

For the Layer 2 switch to supply power to the AP, enable the PoE feature on the switch.

Restrictions and guidelines

When you configure scheduled configuration deployment by AP group, follow these restrictions and guidelines:

·     Use the serial ID labeled on the AP's rear panel to specify an AP.

·     To prevent packets from accumulating in VLAN 1, configure the switch's interface that connects the switch to the AP to deny packets from VLAN 1.

Procedures

Configuring the AC

1.     Configure the DHCP server:

# Enable DHCP server.

<AC> system-view

[AC] dhcp enable

# Create DHCP address pool 1, specify subnet 192.168.201.0/24 in the address pool, and specify the gateway address as 192.168.201.1.

[AC] dhcp server ip-pool 1

[AC-dhcp-pool-1] network 192.168.201.0 mask 255.255.255.0

[AC-dhcp-pool-1] gateway-list 192.168.201.1

[AC-dhcp-pool-1] quit

# Create DHCP address pool 2 and specify subnet 192.168.202.0/24 in the address pool. Specify the gateway address as 192.168.202.1, and specify the address of the DNS server. In this example, the gateway also acts as the DNS server.

[AC] dhcp server ip-pool 2

[AC-dhcp-pool-2] network 192.168.202.0 mask 255.255.255.0

[AC-dhcp-pool-2] gateway-list 192.168.202.1

[AC-dhcp-pool-2] dns-list 192.168.202.1

[AC-dhcp-pool-2] quit

2.     Configure AC interfaces:

# Create VLAN 100 and VLAN-interface 100, and assign IP address 192.168.201.1 to the interface. The AC will use this IP address to establish CAPWAP tunnels with the AP.

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.168.201.1 255.255.255.0

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign IP address 192.168.202.1 to the interface. Clients will use this VLAN to access the WLAN.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 192.168.202.1 24

[AC-Vlan-interface200] quit

# Set the link type of GigabitEthernet 1/0/1 that connects the AC to the switch to trunk. Remove the port from VLAN 1 and assign the port to VLANs 100 and 200. Set the PVID to 100.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC-GigabitEthernet1/0/1] quit

# Create job radio_disable to disable radio 1 of WA4620i-ACN APs in AP group 1.

[AC] scheduler job radio_disable

[AC-job-radio_disable] command 1 system-view

[AC-job-radio_disable] command 2 wlan ap-group 1

[AC-job-radio_disable] command 3 ap-model WA4620i-ACN

[AC-job-radio_disable] command 4 radio 1

[AC-job-radio_disable] command 5 radio disable

[AC-job-radio_disable] quit

# Create schedule stop_radio, assign job radio_disable to the schedule, and configure the AC to execute the schedule at 20:00 every day.

[AC] scheduler schedule stop_radio

[AC-schedule-stop_radio] job radio_disable

[AC-schedule-stop_radio] time repeating at 20:00

[AC-schedule-stop_radio] quit

# Create job radio_enable to enable radio 1 of WA4620i-ACN APs in AP group 1.

[AC] scheduler job radio_enable

[AC-job-radio_enable] command 1 system-view

[AC-job-radio_enable] command 2 wlan ap-group 1

[AC-job-radio_enable] command 3 ap-model WA4320i-ACN

[AC-job-radio_enable] command 4 radio 1

[AC-job-radio_enable] command 5 radio enable

[AC-job-radio_enable] quit

# Create schedule start_radio, assign job radio_enable to the schedule, and configure the AC to execute the schedule at 8:00 every day.

[AC] scheduler schedule start_radio

[AC-schedule-start_radio] job radio_enable

[AC-schedule-start_radio] time repeating at 8:00

[AC-schedule-start_radio] quit

3.     Configure wireless services:

# Create service template 1.

[AC] wlan service-template 1

# Set the SSID to service.

[AC-wlan-st-1] ssid service

# Enable the service template.

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

4.     Configure AP settings:

# Create AP officeap, and specify the AP model and serial ID.

[AC] wlan ap officeap model WA4320i-ACN

[AC-wlan-ap-officeap] serial-id 210235A1Q2C159000018

# Bind service template 1 and VLAN 200 to radio 1 of the AP.

[AC-wlan-ap-officeap] radio 1

[AC-wlan-ap-officeap-radio-1] service-template 1 vlan 200

# Enable radio 1.

[AC-wlan-ap-officeap-radio-1] radio enable

[AC-wlan-ap-officeap-radio-1] return

Configuring the Layer 2 switch

# Create VLAN 100 and VLAN 200. The switch will use VLAN 100 to forward CAPWAP tunnel traffic and use VLAN 200 for client access.

<L2 switch> system-view

[L2 switch] vlan 100

[L2 switch-vlan100] quit

[L2 switch] vlan 200

[L2 switch-vlan200] quit

# Set the link type of GigabitEthernet 1/0/1 that connects the switch to the AC to trunk and assign the port to VLANs 100 and 200. Set the PVID to 100.

[L2 switch] interface gigabitEthernet 1/0/1

[L2 switch-GigabitEthernet1/0/1] port link-type trunk

[L2 switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[L2 switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[L2 switch-GigabitEthernet1/0/1] quit

# Set the link type of GigabitEthernet 1/0/2 that connects the switch to the AP to trunk. Remove the port from VLAN 1, assign the port to VLANs 100 and 200, set the PVID to 100, and enable PoE.

[L2 switch] interface gigabitEthernet 1/0/2

[L2 switch-GigabitEthernet1/0/2] port link-type trunk

[L2 switch-GigabitEthernet1/0/2] undo port trunk permit vlan 1

[L2 switch-GigabitEthernet1/0/2] port trunk permit vlan 100 200

[L2 switch-GigabitEthernet1/0/2] port trunk pvid vlan 100

[L2 switch-GigabitEthernet1/0/2] poe enable

[L2 switch-GigabitEthernet1/0/2] quit

Verifying the configuration

# Use the display wlan ap name officeap verbose command to view the admin state of radio 1 on the AP. Verify that the state is UP from 8:00 to 20:00 and is DOWN at any other time.

<Sysname> display wlan ap name officeap verbose

AP name                       : officeap

AP ID                         : 1

AP group name                 : default-group

State                         : Run

Backup type                   : Master

Online time                   : 0 days 1 hours 25 minutes 12 seconds

System uptime                 : 0 days 2 hours 22 minutes 12 seconds

Model                         : WA4320i-ACN

Region code                   : CN

Region code lock              : Disable

Serial ID                     : 219801A0CNC138011454

MAC address                   : 0AFB-423B-893C

IP address                    : 192.168.1.50

UDP control port number       : 18313

UDP data port number          : N/A

H/W version                   : Ver.C

S/W version                   : E2321

Boot version                  : 1.01

USB state                     : N/A

Power level                   : N/A

Power info                    : N/A

Description                   : wtp1

Priority                      : 4

Echo interval                 : 10 seconds

Echo count                    : 3 counts

Keepalive interval            : 10 seconds

Discovery-response wait-time  : 2 seconds

Statistics report interval    : 50 seconds

Fragment size (data)          : 1500

Fragment size (control)       : 1450

MAC type                      : Local MAC & Split MAC

Tunnel mode                   : Local Bridging & 802.3 Frame & Native Frame

CWPCAP data-tunnel status     : Down

Discovery type                : Static Configuration

Retransmission count          : 3

Retransmission interval       : 5 seconds

Firmware upgrade              : Enabled

Sent control packets          : 1

Received control packets      : 1

Echo requests                 : 147

Lost echo responses           : 0

Average echo delay            : 3

Last reboot reason            : User soft reboot

Last reboot reason (AP check) : The radio physical status was down

Last reboot reason (AC check) : The radio physical status was down

Latest IP address             : 10.1.0.2

Current AC IP                 : 192.168.1.1

Tunnel down reason            : Request wait timer expired

Connection count              : 1

Backup IPv4                   : Not configured

Backup IPv6                   : Not configured

Ctrl-tunnel encryption        : Disabled

Ctrl-tunnel encryption state  : Not encrypted

Data-tunnel encryption        : Disabled

Data-tunnel encryption state  : Not encrypted

LED mode                      : Normal

Remote configuration          : Enabled

Radio 1:

    Basic BSSID               : 7848-59f6-3940

    Admin state               : Up

    Radio type                : 802.11ac

    Antenna type              : internal

    Client dot11ac-only       : Disabled

    Client dot11n-only        : Disabled

    Channel band-width        : 20/40/80MHz

    Active band-width         : 20/40/80MHz

    Secondary channel offset  : SCB

    Short GI for 20MHz        : Supported

    Short GI for 40MHz        : Supported

    Short GI for 80MHz        : Supported

    Short GI for 160MHz       : Not supported

    mimo                      : Not Config

    Green-Energy-Management   : Disabled

    A-MSDU                    : Enabled

    A-MPDU                    : Enabled

    LDPC                      : Not Supported

    STBC                      : Supported

    Operational VHT-MCS Set:

        Mandatory             : Not configured

        Supported             : NSS1 0,1,2,3,4,5,6,7,8,9

                                NSS2 0,1,2,3,4,5,6,7,8,9

        Multicast             : Not configured

    Operational HT MCS Set:

        Mandatory             : Not configured

        Supported             : 0, 1, 2, 3, 4, 5, 6, 7, 8, 9,

                                10, 11, 12, 13, 14, 15

        Multicast             : Not configured

    Channel                   : 44(auto)

    Channel usage(%)          : 15

    Max power                 : -102 dBm

    Operational rate:

        Mandatory             : 6, 12, 24 Mbps

        Multicast             : Auto

        Supported             : 9, 18, 36, 48, 54 Mbps

        Disabled              : Not configured

    Distance                  : 1 km

    ANI                       : Enabled

    Fragmentation threshold   : 2346 bytes

    Beacon interval           : 100 TU

    Protection threshold      : 2346 bytes

    Long retry threshold      : 4

    Short retry threshold     : 7

    Maximum rx duration       : 2000 ms

    Noise Floor               : 5 dBm

    Smart antenna             : Enabled

    Smart antenna policy      : Auto

    Protection mode           : rts-cts

    Continuous mode           : N/A

    HT protection mode        : No protection

Radio 2:

    Basic BSSID               : 7848-59f6-3950

    Admin state               : Down

    Radio type                : 802.11b

    Antenna type              : internal

    Client dot11n-only        : Disabled

    Channel band-width        : 20MHz

    Active band-width         : 20MHz

    Secondary channel offset  : SCN

    Short GI for 20MHz        : Supported

    Short GI for 40MHz        : Supported

    A-MSDU                    : Enabled

    A-MPDU                    : Enabled

    LDPC                      : Not Supported

    STBC                      : Supported

    Operational HT MCS Set:

        Mandatory             : Not configured

        Supported             : 0, 1, 2, 3, 4, 5, 6, 7, 8, 9,

                                10, 11, 12, 13, 14, 15

        Multicast             : Not configured

    Channel                   : 5(auto)

    Channel usage(%)          : 0

    Max power                 : 20 dBm

    Preamble type             : Short

    Operational rate:

        Mandatory             : 1, 2, 5.5, 11 Mbps

        Multicast             : Auto

        Supported             : 6, 9, 12, 18, 24, 36, 48, 54 Mbps

        Disabled              : Not configured

    Distance                  : 1 km

    ANI                       : Enabled

    Fragmentation threshold   : 2346 bytes

    Beacon interval           : 100 TU

    Protection threshold      : 2346 bytes

    Long retry threshold      : 4

    Short retry threshold     : 7

    Maximum rx duration       : 2000 ms

    Noise Floor               : 0 dBm

    Smart antenna             : Enabled

    Smart antenna policy      : Auto

    Protection mode           : rts-cts

    Continuous mode           : N/A

    HT protection mode        : No protection

Configuration files

·     AC:

#

 dhcp enable

#

vlan 1

#

vlan 100

#

vlan 200

#

dhcp server ip-pool 1

 gateway-list 192.168.201.1

 network 192.168.201.0 mask 255.255.255.0

#

dhcp server ip-pool 2

 gateway-list 192.168.202.1

network 192.168.202.0 mask 255.255.255.0

dns-list 192.168.202.1

#

wlan service-template 1

 ssid service

 service-template enable

#

interface Vlan-interface1

#

interface Vlan-interface100

 ip address 192.168.201.1 255.255.255.0

#

interface Vlan-interface200

 ip address 192.168.202.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

port trunk permit vlan 100 200

port trunk pvid vlan 100

#

wlan ap officeap model WA4320i-ACN

 serial-id 210235A1Q2C159000018

vlan 1

 radio 1

  radio enable

  service-template 1 vlan 200

 radio 2

#

scheduler job radio_disable

 command 1 system-view

 command 2 wlan ap-group 2

 command 3 ap-model WA4620i-ACN

 command 4 radio 1

 command 5 radio disable

#

scheduler job radio_enable

 command 1 system-view

 command 2 wlan ap-group 1

 command 3 ap-model WA4320i-ACN

 command 4 radio 1

 command 5 radio enable

#

scheduler schedule start_radio

 user-role network-admin

 job radio_enable

 time repeating at 08:00

#

scheduler schedule stop_radio

 user-role network-admin

 job radio_disable

 time repeating at 20:00

#

·     Layer 2 switch:

 

#

vlan 100

#

vlan 200

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1 100 200

port trunk pvid vlan 100

#

interface GigabitEthernet1/0/2

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

 poe enable

#

Related documentation

·     AP and WT Management Command Reference in H3C Access Controllers Command References

·     AP and WT Management Configuration Guide in H3C Access Controllers Configuration Guides

·     Network Connectivity Command Reference in H3C Access Controllers Command References

·     Network Connectivity Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Access Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides