06-MPLS Configuration Guide

HomeSupportResource CenterSwitchesS12500R SeriesS12500R SeriesTechnical DocumentsConfigure & DeployConfiguration GuidesH3C S12500R Switch Router Series Configuration Guides(R3606)-6W10006-MPLS Configuration Guide
10-VPLS configuration
Title Size Download
10-VPLS configuration 492.08 KB

Configuring VPLS

About VPLS

Virtual Private LAN Service (VPLS) delivers a point-to-multipoint L2VPN service over an MPLS or IP backbone. The provider backbone emulates a switch to connect all geographically dispersed sites of each customer network. The backbone is transparent to the customer sites. The sites can communicate with each other as if they were on the same LAN.

Basic VPLS architecture

Figure 1 Basic VPLS architecture

As shown in Figure 1, the VPLS architecture mainly includes the following components:

·     CE—A customer edge device is directly connected to the service provider network.

·     PE—A provider edge device connects one or more CEs to the service provider network. A PE implements VPN access by mapping and forwarding packets between private networks and public network tunnels. A PE can be a UPE or NPE in a hierarchical VPLS.

·     AC—An attachment circuit, physical or virtual, connects a CE and a PE, such as an Ethernet link or a VLAN.

·     PW—A pseudowire is a bidirectional virtual connection between two PEs. An MPLS PW consists of two unidirectional MPLS LSPs in opposite directions.

·     Tunnel—A tunnel can be an LSP tunnel, an MPLS TE tunnel, or a GRE tunnel. It carries one or more PWs over an IP/MPLS backbone. If a PW is carried on an LSP or MPLS TE tunnel, each packet on the PW contains two labels. The inner label is the PW label, which identifies the PW and ensures that the packet is forwarded to the correct VSI. The outer label is the public LSP or MPLS TE tunnel label, which ensures that the packet is correctly forwarded to the remote PE.

·     VPLS instance—A customer network might contain multiple geographically dispersed sites (such as site 1 and site 3 in Figure 1.) The service provider uses VPLS to connect all the sites to create a single Layer 2 VPN, which is referred to as a VPLS instance. Sites in different VPLS instances cannot communicate with each other at Layer 2.

·     VSI—A virtual switch instance provides Layer 2 switching services for a VPLS instance on a PE. A VSI acts as a virtual switch that has all the functions of a conventional Ethernet switch, including source MAC address learning, MAC address aging, and flooding. VPLS uses VSIs to forward Layer 2 data packets in VPLS instances.

Creating a PW

In a VPLS network, PEs use PWs to forward packets among VPN sites.

A PW is created as follow:

1.     Specify the address of the remote PE or configure an auto-discovery protocol to automatically find the remote PE. BGP is the most commonly used auto-discovery protocol.

2.     Specify the incoming label and the outgoing label for the PW on the two PEs to create the PW. You can also use LDP or BGP to advertise the PW-label binding to the remote PE to establish the unidirectional LSPs. The PW is created once the two unidirectional LSPs are created.

PW types

PEs use PWs to forward packets among VPN sites. PWs include static PWs, LDP PWs, BGP PWs, and BGP auto-discovery LDP PWs.

Static PW

To create a static PW, specify the address of the remote PE, the incoming label, and the outgoing label.

LDP PW

To create an LDP PW, specify the address of the remote PE, and use LDP to advertise the PW-label binding to the remote PE. After the two PEs receive the PW-label binding from each other, they establish an LDP PW. The FEC type in the LDP message is PWid FEC Element that includes the PW ID field (FEC 128). The PW ID identifies the PW bound to the PW label.

BGP PW

To create a BGP PW, configure BGP to advertise label block information to the remote PE. After the two PEs receive label block information from each other, they use the label block information to calculate the incoming and outgoing labels and create the BGP PW. A PE also uses the received label block information to automatically find the remote PE.

BGP auto-discovery LDP PW

To create a BGP auto-discovery LDP PW, configure BGP to automatically find the remote PE, and use LDP to advertise the PW-label binding to the remote PE. After the two PEs receive the PW-label binding from each other, they establish a BGP auto-discovery LDP PW.

The information advertised by BGP includes the ID (for example, LSR ID) and VPLS ID of the advertising PE. The receiving PE compares the received VPLS ID with its own VPLS ID. If the two VPLS IDs are identical, the two PEs use LDP to establish a PW. If not, the PEs do not establish a PW. The FEC type in the LDP message is Generalized PWid FEC Element (FEC 129), which contains the VPLS ID, Source Attachment Individual Identifier (SAII), and Target Attachment Individual Identifier (TAII). The SAII is the LSR ID of the advertising PE. The TAII identifies the remote PE and is advertised by the remote PE. VPLS ID+SAII+TAII uniquely identifies a PW in a VPLS instance.

MAC address learning, aging, and withdrawal

Source MAC address learning

VPLS provides reachability through source MAC learning. A PE maintains a MAC address table for each VSI.

As shown in Figure 2, a PE learns source MAC addresses in the following ways:

·     Learning the source MAC addresses of directly connected sites.

If the source MAC address of a packet from a CE does not exist in the MAC address table, the PE learns the source MAC address of the AC connected to the CE.

·     Learning the source MAC addresses of remote sites connected through PWs.

A VSI regards a PW as a logical Ethernet interface. If the source MAC address of a packet from a PW does not exist in the MAC address table, the PE learns the source MAC address on the PW of the VSI.

Figure 2 Source MAC address learning on a PE

MAC address aging

The MAC address table uses an aging timer for each dynamic MAC address entry. If no packet is received from a MAC address before the aging timer expires, VPLS deletes the MAC address.

MAC address withdrawal

When an AC or a PW goes down, the PE deletes MAC addresses on the AC or PW. Then it sends an LDP address withdrawal message to notify all other PEs in the VPLS instance to delete those MAC addresses.

Traffic forwarding and flooding

Unicast traffic forwarding and flooding

After a PE receives a unicast packet from an AC, the PE searches the MAC address table of the VSI bound to the AC for packet forwarding.

·     If a match is found, the PE forwards the packet according to the matching entry.

¡     If the outgoing interface in the entry is a PW, the PE inserts the PW label to the packet, and adds the public tunnel header to the packet. It then forwards the packet to the remote PE over the PW. If the PW is carried on an LSP or MPLS TE tunnel, each packet on the PW contains two labels. The inner label is the PW label, which identifies the PW and ensures that the packet is forwarded to the correct VSI. The outer label is the public LSP or MPLS TE tunnel label, which ensures that the packet is correctly forwarded to the remote PE.

¡     If the outgoing interface in the entry is a local interface, the PE directly forwards the packet to the local interface.

·     If no match is found, the PE floods the packet to all other ACs and PWs in the VSI.

After a PE receives a unicast packet from a PW, the PE searches the MAC address table of the VSI bound to the PW for packet forwarding.

·     If a match is found, the PE forwards the packet through the outgoing interface in the matching entry.

·     If no match is found, the PE floods the packet to all ACs in the VSI.

Multicast and broadcast traffic forwarding and flooding

After a PE receives a multicast or broadcast packet from an AC, the PE floods the packet to all other ACs and the PWs in the VSI bound to the AC.

After a PE receives a multicast or broadcast packet from a PW, the PE floods the packet to all ACs in the VSI bound to the PW.

PW full mesh and split horizon

A Layer 2 network requires a loop prevention protocol such as STP to avoid loops. However, a loop prevention protocol on PEs brings management and maintenance difficulties. Therefore, VPLS uses the following methods to prevent loops:

·     Full mesh—Every two PEs in a VPLS instance must establish a PW. The PWs form a full mesh among PEs in the VPLS instance.

·     Split horizon—A PE does not forward packets received from a PW to any other PWs in the same VSI but only forwards those packets to ACs.

PW redundancy

PW redundancy provides redundant links between PEs so that the customer networks can communicate when the path over one PW fails. As shown in Figure 3, PE 1 establishes two PWs (one primary and one backup). The CEs communicate through the primary PW. When the primary PW fails, PE 1 brings up the backup PW and forwards packets from CE 1 to CE 2 through the backup PW. When CE 2 receives the packets, it updates its MAC address table, so that packets from CE 2 to CE 1 also travel through the backup PW. Only static PWs and LDP PWs support PW redundancy.

Figure 3 PW redundancy

VPLS determines whether the primary PW fails according to the LDP session status or the BFD result. The backup PW is used when one of the following conditions exists:

·     The public tunnel of the primary PW is deleted, or BFD detects that the public tunnel has failed.

·     The primary PW is deleted because the LDP session between PEs goes down, or BFD detects that the primary PW has failed.

·     A manual PW switchover is performed.

A PW can be in either of the following states:

·     Active—The PW is in active state and can forward packets.

·     Standby—The PW is in standby state and cannot forward packets.

LDP PWs support the independent and master/slave PW redundancy operation modes.

·     Independent mode—The two PEs of a PW use LDP to advertise their respective PW active/standby state to each other. A PW can forward traffic only when it is up and active at both ends of the PW. In this mode, make sure both PEs of a PW use the independent PW redundancy operation mode.

·     Master/slave mode—One PE of a PW operates as the master node and the other PE operates as the slave node. The master PE determines the PW active/standby state and then uses LDP to advertise the PW state to the slave PE. The slave PE uses the same PW state as the master PE based on the information received from the master PE. In this way, the master and slave PEs for the set of redundant PWs can use the same active PW to forward user packets.

A slave node does not advertise the PW active/standby state to the master node, and the master node ignores the PW active/standby state received from the slave nodes.

VPLS tasks at a glance

Perform the following configuration tasks on a PE:

1.     Enabling L2VPN

2.     Configuring an AC

3.     Configuring a VSI

4.     Configuring a PW

Choose the following tasks as needed:

¡     (Optional.) Configuring a PW class

¡     Configuring a static PW

¡     Configuring an LDP PW

¡     Configuring a BGP PW

¡     Configuring a BGP auto-discovery LDP PW

¡     (Optional.) Configuring the BGP L2VPN address family

You can configure this task to control route advertisement and selection in BGP L2VPN address family when you configure a BGP PW or BGP auto-discovery LDP PW.

¡     (Optional.) Maintaining BGP sessions

If BGP configuration is changed, you can reset or soft-reset BGP sessions to validate the new configuration for BGP PWs and BGP auto-discovery LDP PWs.

5.     Binding an AC to a VSI

In an H-VPLS using MPLS access, this task is not needed on the access NPEs of the UPEs.

6.     (Optional.) Configuring PW redundancy

7.     (Optional.) Configuring MAC address learning for a VSI

8.     (Optional.) Enabling SNMP notifications for L2VPN PW

9.     (Optional.) Enabling L2VPN logging

Prerequisites for VPLS

To configure a VPLS network, perform the following tasks:

·     Configure an IGP to ensure IP connectivity within the backbone.

·     Configure basic MPLS, LDP, GRE, or MPLS TE to establish public tunnels on the backbone network.

Enabling L2VPN

1.     Enter system view.

system-view

2.     Enable L2VPN.

l2vpn enable

By default, L2VPN is disabled.

Configuring an AC

Configuring a Layer 3 interface

When the PE is connected to a CE through a Layer 3 interface, you must configure the Layer 3 interface to establish an AC to the CE.

The Layer 3 interface can be a Layer 3 Ethernet interface (including physical Layer 3 Ethernet interface and VE-L2VPN interface) or Layer 3 Ethernet subinterface.

For more information about Ethernet interfaces, see Interface Configuration Guide. For more information about VE-L2VPN interfaces, see "Configuring L2VPN access to L3VPN or IP backbone."

If the system operating mode is bridgee and the AC is a Layer 3 Ethernet subinterface, you must configure VLAN termination on the interface. If you do not configure VLAN termination, ARP suppression might be unavailable.

Configuring an Ethernet service instance

About this task

When the PE is connected to a CE through a Layer 2 Ethernet or Layer 2 aggregate interface, configure an Ethernet service instance on the interface to match packets from the AC. The Ethernet service instance provides flexible methods for matching packets to be forwarded in the VSI.

Restrictions and guidelines

You cannot repeat the encapsulation command to modify the packet match criterion of an Ethernet service instance. To change the packet match criterion, first execute the undo encapsulation command to remove the original match criterion.

If the packet match criterion of an Ethernet service instance is removed, the binding between the Ethernet service instance and the VSI is removed automatically.

Procedure

1.     Enter system view.

system-view

2.     Enter interface view.

¡     Enter Layer 2 Ethernet interface view.

interface interface-type interface-number

¡     Enter Layer 2 aggregate interface view.

interface bridge-aggregation interface-number

3.     Create an Ethernet service instance and enter Ethernet service instance view.

service-instance instance-id

4.     Configure a packet match criterion for the Ethernet service instance.

¡     Match packets with the specified outer VLAN IDs.

encapsulation s-vid vlan-id-list

¡     Match packets with the specified outer VLAN IDs and inner VLAN IDs.

encapsulation s-vid vlan-id-list c-vid vlan-id-list

¡     Match packets that do not have a VLAN tag.

encapsulation untagged

¡     Match packets that do not match any other Ethernet service instances on the interface.

encapsulation default

On an interface, you can configure the default criterion in only one Ethernet service instance. The Ethernet service instance matches all packets if it is the only Ethernet service instance  on the interface.

By default, no packet match criterion is configured.

Configuring a VSI

1.     Enter system view.

system-view

2.     Create a VSI and enter VSI view.

vsi vsi-name

3.     (Optional.) Configure a description for the VSI.

description text

By default, no description is configured for a VSI.

4.     (Optional.) Set the default PW ID for the VSI.

default-pw-id default-pw-id

By default, no default PW ID is configured for the VSI.

5.     Set an MTU for the VSI.

mtu size

By default, the MTU of a VSI is 1500 bytes.

6.     (Optional.) Enable the VSI.

undo shutdown

By default, a VSI is enabled.

Configuring a PW

Configuring a PW class

About this task

In a PW class, you can configure PW attributes such as the PW data encapsulation type, and whether to enable control word. To simplify PW configuration, you can configure PWs with the same attributes by referencing the same PW class.

Procedure

1.     Enter system view.

system-view

2.     Create a PW class and enter PW class view.

pw-class class-name

By default, no PW classes exist.

3.     (Optional.) Enable control word.

control-word enable

By default, control word is disabled.

4.     (Optional.) Specify the PW data encapsulation type.

pw-type { ethernet | vlan } [ force-for-vpls ]

By default, the PW data encapsulation type for a PW class is VLAN when the device operates in Bridgee mode. The PW data encapsulation type for a PW class is Ethernet when the device operates in Standard mode.

Configuring a static PW

1.     Enter system view.

system-view

2.     Enter VSI view.

vsi vsi-name

3.     Specify static signaling for PWs, and enter VSI static view.

pwsignaling static

By default, no PW signaling protocol is specified.

4.     Configure a static PW, and enter VSI static PW view.

peer ip-address [ pw-id pw-id ] in-label label-value out-label label-value [ no-split-horizon | pw-class class-name | tunnel-policy tunnel-policy-name ] *

 

Parameter

Description

pw-id pw-id

If both the default PW ID in the default-pw-id command and a PW ID in the peer command are configured, the PW ID in the peer command is used. If only the default PW ID is configured, the default PW ID is used. If no default PW ID is configured, you must provide a PW ID in the peer command.

no-split-horizon

You must specify the no-split-horizon keyword to disable split horizon when you configure an NPE to establish a U-PW with a UPE.

Configuring an LDP PW

Prerequisites

Before you configure an LDP PW, enable global and interface MPLS LDP on the PE. For information about MPLS LDP configuration, see "Configuring LDP."

Procedure

1.     Enter system view.

system-view

2.     Enter VSI view.

vsi vsi-name

3.     Specify LDP signaling for PWs, and enter VSI LDP signaling view.

pwsignaling ldp

By default, no PW signaling protocol is specified.

4.     (Optional.) Disable PW MTU negotiation.

mtu-negotiate disable

By default, PW MTU negotiation is enabled.

Configure this command if you want to establish a PW between two PEs that are configured with different PW MTUs.

5.     Configure an LDP PW, and enter VSI LDP PW view.

peer ip-address [ pw-id pw-id ] [ ignore-standby-state | no-split-horizon | pw-class class-name | tunnel-policy tunnel-policy-name ] *

 

Parameter

Description

pw-id pw-id

If both the default PW ID in the default-pw-id command and a PW ID in the peer command are configured, the PW ID in the peer command is used. If only the default PW ID is configured, the default PW ID is used. If no default PW ID is configured, you must provide a PW ID in the peer command.

no-split-horizon

You must specify the no-split-horizon keyword to disable split horizon when you configure an NPE to establish a U-PW with a UPE.

Configuring a BGP PW

Configuring BGP to advertise VPLS label block information

1.     Enter system view.

system-view

2.     Enable BGP instance and enter BGP instance view.

bgp as-number [ instance instance-name ]

By default, BGP is disabled.

For more information about this command, see BGP in Layer 3—IP Routing Command Reference.

3.     Configure the remote PE as a BGP peer.

peer { group-name | ip-address [ mask-length ] } as-number as-number

For more information about this command, see BGP in Layer 3—IP Routing Command Reference.

4.     Create the BGP L2VPN address family and enter BGP L2VPN address family view.

address-family l2vpn

5.     Enable BGP to exchange L2VPN information with the specified peer or peer group.

peer { group-name | ip-address [ mask-length ] } enable

By default, BGP cannot exchange L2VPN information with any peer or peer group.

For more information about this command, see BGP in Layer 3—IP Routing Command Reference.

6.     Enable BGP to exchange label block information with the specified peer or peer group.

peer { group-name | ip-address [ mask-length ] } signaling

By default, BGP can exchange label block information with a BGP L2VPN peer or peer group.

7.     (Optional.) Configure the BGP L2VPN address family.

For more information, see "Configuring the BGP L2VPN address family."

8.     (Optional.) Maintain BGP sessions.

For more information, see "Maintaining BGP sessions."

Creating a BGP PW

1.     Enter system view.

system-view

2.     Enter VSI view.

vsi vsi-name

3.     Configure the VSI to automatically discover neighbors through BGP and enter auto-discovery VSI view.

auto-discovery bgp

By default, a VSI does not automatically discover neighbors through BGP.

4.     Configure an RD for the auto-discovery VSI.

route-distinguisher route-distinguisher

By default, no RD is configured for the auto-discovery VSI.

5.     Configure route targets for the auto-discovery VSI.

vpn-target vpn-target&<1-8> [ both | export-extcommunity | import-extcommunity ]

By default, no route targets are configured for the auto-discovery VSI.

6.     (Optional.) Specify a PW class for the auto-discovery VSI.

pw-class class-name

By default, no PW class is specified.

7.     (Optional.) Specify a tunnel policy for the auto-discovery VSI.

tunnel-policy tunnel-policy-name

By default, no tunnel policy is specified.

8.     Use BGP to create a PW to an automatically discovered remote PE and enter auto-discovery VSI BGP signaling view.

signaling-protocol bgp

By default, no signaling protocol is specified.

9.     Create a local site.

site site-id [ range range-value ] [ default-offset default-offset ]

Configuring a BGP auto-discovery LDP PW

Prerequisites for configuring a BGP auto-discovery LDP PW

Before you perform this configuration, enable MPLS LDP on interfaces and globally. For more information, see "Configuring LDP."

Configuring BGP to advertise VPLS PE information

1.     Enter system view.

system-view

2.     Enable BGP instance and enter BGP instance view.

bgp as-number [ instance instance-name ]

By default, BGP is disabled.

For more information about this command, see BGP in Layer 3—IP Routing Command Reference.

3.     Configure the remote PE as a BGP peer.

peer { group-name | ip-address [ mask-length ] } as-number as-number

For more information about this command, see BGP in Layer 3—IP Routing Command Reference.

4.     Create the BGP L2VPN address family and enter BGP L2VPN address family view.

address-family l2vpn

5.     Enable BGP to exchange VPLS PE information with the specified peer or peer group.

peer { group-name | ip-address [ mask-length ] } enable

By default, BGP cannot exchange VPLS PE information with a peer or peer group.

For more information about this command, see BGP in Layer 3—IP Routing Command Reference.

6.     Enable BGP to exchange VPLS PE information with the specified peer or peer group.

peer { group-name | ip-address [ mask-length ] } auto-discovery [ non-standard ]

By default, BGP can exchange VPLS PE information with a BGP L2VPN peer or peer group by using RFC 6074 MP_REACH_NLRI.

7.     (Optional.) Configure the BGP L2VPN address family.

For more information, see "Configuring the BGP L2VPN address family."

8.     (Optional.) Maintain BGP sessions.

For more information, see "Maintaining BGP sessions."

Creating a BGP auto-discovery LDP PW

1.     Enter system view.

system-view

2.     Enter VSI view.

vsi vsi-name [ hub-spoke ]

3.     Configure the VSI to automatically discover neighbors through BGP and enter auto-discovery VSI view.

auto-discovery bgp

By default, a VSI does not automatically discover neighbors through BGP.

4.     Configure an RD for the auto-discovery VSI.

route-distinguisher route-distinguisher

By default, no RD is configured for the auto-discovery VSI.

5.     Configure route targets for the auto-discovery VSI.

vpn-target vpn-target&<1-8> [ both | export-extcommunity | import-extcommunity ]

By default, no route targets are configured for the auto-discovery VSI.

6.     (Optional.) Specify a PW class for the auto-discovery VSI.

pw-class class-name

By default, no PW class is specified.

7.     (Optional.) Specify a tunnel policy for the auto-discovery VSI.

tunnel-policy tunnel-policy-name

By default, no tunnel policy is specified.

8.     Use LDP to create a PW to an automatically discovered remote PE and enter auto-discovery VSI LDP signaling view.

signaling-protocol ldp

By default, no signaling protocol is specified.

9.     Configure a VPLS ID for the VSI.

vpls-id vpls-id

By default, no VPLS ID is configured.

Configuring the BGP L2VPN address family

About this task

When you configure a BGP PW or a BGP auto-discovery LDP PW, you can perform this task to control route advertisement and selection in the BGP L2VPN address family.

Procedure

1.     Enter system view.

system-view

2.     Enter BGP instance view.

bgp as-number [ instance instance-name ]

3.     Enter BGP L2VPN address family view.

address-family l2vpn

4.     Permit the local AS number to appear in routes from the specified peer or peer group and specify the maximum number of the appearances.

peer { group-name | ip-address [ mask-length ] } allow-as-loop [ number ]

By default, the local AS number is not allowed in routes from a peer or peer group.

5.     Enable route target-based filtering of incoming BGP L2VPN information.

policy vpn-target

By default, route target-based filtering of incoming BGP L2VPN information is enabled.

6.     Configure BGP route reflection.

¡     Configure the device as a route reflector and specify a peer or peer group as its client.

peer { group-name | ip-address [ mask-length ] } reflect-client

By default, no route reflector or client is configured.

¡     Enable L2VPN information reflection between clients.

reflect between-clients

By default, L2VPN information reflection is enabled between clients.

¡     Configure the cluster ID of the route reflector.

reflector cluster-id { cluster-id | ip-address }

By default, a route reflector uses its own router ID as the cluster ID.

¡     Configure the route reflector to filter reflected L2VPN information.

rr-filter ext-comm-list-number

By default, a route reflector does not filter reflected L2VPN information.

7.     (Optional.) Set the BGP optimal route selection delay timer.

route-select delay delay-value

By default, the BGP optimal route selection delay timer is 0 seconds, which means optimal route selection is not delayed.

For more information about this command, see BGP commands in Layer 3—IP Routing Command Reference.

Maintaining BGP sessions

About this task

If BGP configuration is changed, you can reset or soft-reset BGP sessions to validate the new configuration for BGP PWs and BGP auto-discovery LDP PWs.

A soft reset updates BGP routing information without tearing down BGP connections. A reset operation updates BGP routing information by tearing down, and then re-establishing BGP connections. Soft reset requires that BGP peers have route refresh capability (support the ROUTE-REFRESH message).

For more information about the commands in this task, see BGP in Layer 3—IP Routing Command Reference.

Procedure

To maintain BGP sessions, execute one of the following commands in user view:

·     Soft-reset L2VPN BGP sessions.

refresh bgp [ instance instance-name ] { ip-address [ mask-length ] | all | external | group group-name | internal } { export | import } l2vpn

·     Reset L2VPN BGP sessions.

reset bgp [ instance instance-name ] { as-number | ip-address [ mask-length ] | all | external | group group-name | internal } l2vpn

Binding an AC to a VSI

About binding an AC to a VSI

After you bind a Layer 3 interface to a VSI, packets received from the Layer 3 interface are forwarded based on the MAC address table of the VSI.

After you bind an Ethernet service instance on a Layer 2 Ethernet or Layer 2 aggregate interface to a VSI, the Ethernet service instance matches packets received on that interface. The matching packets are then forwarded based on the MAC address table of the VSI. An Ethernet service instance can match all packets, tagged packets, or untagged packets.

When you bind an AC to a VSI, you can associate Track with the AC. Then, the AC is up only when one or more of the associated track entries are positive.

Associating Track with an AC helps detecting AC failure. For example, when an AC is a VE-L2VPN interface, the interface will not go down upon a link failure because the interface is a virtual interface. To resolve the problem, you can associate Track with the AC to detect failures on the link that connects the PE-agg to the L3VPN or IP backbone. When a failure occurs on the link, the VE-L2VPN interface is set to down. Consequently, the PW bound to the AC goes down. If the PW has a backup PW, traffic can be switched to the backup PW. For more information about VE-L2VPN interfaces and L2VPN access to L3VPN or IP backbone, see "Configuring L2VPN access to L3VPN or IP backbone."

Restrictions and guidelines for binding an AC to a VSI

If a Layer 3 Ethernet interface has been added to a link aggregation group, you cannot bind the Layer 3 interface to a VSI, and vice versa.

If a Layer 2 Ethernet interface has been added to a link aggregation group, you cannot bind an Ethernet service instance on the interface to a VSI, and vice versa.

Binding a Layer 3 interface to a VSI

1.     Enter system view.

system-view

2.     Enter Layer 3 interface view.

interface interface-type interface-number

3.     Bind the interface to a VSI.

xconnect vsi vsi-name [ access-mode { ethernet | vlan } ] [ track track-entry-number&<1-15> ]

By default, an interface is not bound to any VSI.

 

Parameter

Description

access-mode { ethernet | vlan }

The AC access mode determines how the device (PE) considers the VLAN tag in Ethernet frames received from the CE and how the PE forwards Ethernet frames to the CE.

·     VLAN access mode—Ethernet frames received from the CE must carry a VLAN tag in the Ethernet header. The PE considers the VLAN tag as a P-tag assigned by the service provider. Ethernet frames sent to the CE must also carry the P-tag.

·     Ethernet access mode—If Ethernet frames from the CE have a VLAN tag in the header, the PE considers it as a U-tag and ignores it. Ethernet frames sent to the CE do not carry the P-tag.

Binding an Ethernet service instance to a VSI

1.     Enter system view.

system-view

2.     Enter interface view.

¡     Enter Layer 2 Ethernet interface view:

interface interface-type interface-number

¡     Enter Layer 2 aggregate interface view:

interface bridge-aggregation interface-number

3.     Create an Ethernet service instance and enter Ethernet service instance view.

service-instance instance-id

By default, no Ethernet service instances exist.

4.     Bind the Ethernet service instance to a VSI.

xconnect vsi vsi-name [ access-mode { ethernet | vlan } ] [ track track-entry-number&<1-15> ]

By default, an Ethernet service instance is not bound to any VSI.

If the hub-spoke capability is enabled for a VSI, an AC in the VSI is a spoke link by default. You can use the hub keyword to specify the AC as a hub link.

Configuring PW redundancy

Configuring static PW redundancy

1.     Enter system view.

system-view

2.     Enter VSI view.

vsi vsi-name [ hub-spoke ]

3.     Specify static signaling for PWs, and enter VSI static view.

pwsignaling static

By default, no PW signaling protocol is specified for the VSI.

4.     (Optional.) Specify the switchover mode and set the wait time for the switchover.

revertive { wtr wtr-time | never }

By default, the switchover mode is revertive and the switchover wait time is 0 seconds.

5.     Configure a static PW and enter VSI static PW view.

peer ip-address [ pw-id pw-id ] [ in-label label-value out-label label-value ] [ no-split-horizon | pw-class class-name | tunnel-policy tunnel-policy-name ] *

6.     Configure a backup static PW and enter VSI static backup PW view.

backup-peer ip-address [ pw-id pw-id ] in-label label-value out-label label-value [ pw-class class-name | tunnel-policy tunnel-policy-name ] *

If both the default PW ID in the default-pw-id command and a PW ID in the backup-peer command are configured, the PW ID in the backup-peer command is used. If only the default PW ID is configured, the default PW ID is used. If no default PW ID is configured, you must provide a PW ID in the backup-peer command.

7.     (Optional.) Manually switch the traffic:

a.     Return to user view.

return

b.     Manually switch traffic of the PW to its backup PW.

l2vpn switchover peer ip-address pw-id pw-id

Configuring LDP PW redundancy

1.     Enter system view.

system-view

2.     Enter VSI view.

vsi vsi-name

3.     Specify LDP signaling for PWs, and enter VSI LDP signaling view.

pwsignaling ldp

By default, no PW signaling protocol is specified for the VSI.

4.     (Optional.) Specify a PW redundancy operation mode.

pw-redundancy { independent | master }

By default, the PW redundancy operation mode is master/slave and the local PE operates as the slave node.

Do not configure this command on the local PE if the remote PE does not support the PW redundancy operation mode configuration.

5.     (Optional.) Specify the switchover mode and set the wait time for the switchover.

revertive { wtr wtr-time | never }

By default, the switchover mode is revertive and the switchover wait time is 0 seconds.

6.     Configure an LDP PW and enter VSI LDP PW view.

peer ip-address [ pw-id pw-id ] [ no-split-horizon | pw-class class-name | tunnel-policy tunnel-policy-name ] *

7.     Configure a backup LDP PW and enter VSI LDP backup PW view.

backup-peer ip-address [ pw-id pw-id ] [ pw-class class-name | tunnel-policy tunnel-policy-name ] *

If both the default PW ID in the default-pw-id command and a PW ID in the backup-peer command are configured, the PW ID in the backup-peer command is used. If only the default PW ID is configured, the default PW ID is used. If no default PW ID is configured, you must provide a PW ID in the backup-peer command.

8.     (Optional.) Manually switch the traffic:

a.     Return to user view.

return

b.     Manually switch traffic of the PW to its backup PW.

l2vpn switchover peer ip-address pw-id pw-id

Configuring MAC address learning for a VSI

1.     Enter system view.

system-view

2.     Enter VSI view.

vsi vsi-name [ hub-spoke ]

3.     Enable MAC address learning for the VSI.

mac-learning enable

By default, MAC address learning is enabled for a VSI.

Enabling SNMP notifications for L2VPN PW

About this task

This feature enables L2VPN to generate SNMP notifications when PW deletions, PW switchovers, or PW status changes occur. For L2VPN event notifications to be sent correctly, you must also configure SNMP on the device. For more information about SNMP configuration, see the network management and monitoring configuration guide for the device.

Procedure

1.     Enter system view.

system-view

2.     Enable SNMP notifications for L2VPN PW.

snmp-agent trap enable l2vpn [ pw-delete | pw-switch | pw-up-down ] *

By default, SNMP notifications for L2VPN PW are disabled.

Enabling L2VPN logging

About this task

This feature enables L2VPN to generate logs for running state changes. The generated logs are sent to the information center. The information center processes the logs according to user-defined output rules (whether to output logs and where to output).

For more information about the information center, see information center configuration in Network Management and Monitoring Configuration Guide.

Procedure

1.     Enter system view.

system-view

2.     Enable L2VPN logging.

l2vpn log enable

By default, L2VPN logging is enabled.

Display and maintenance commands for VPLS

Execute display commands in any view and reset commands in user view.

 

Task

Command

Display LDP PW label information.

display l2vpn ldp [ peer ip-address [ pw-id pw-id | vpls-id vpls-id ] | vsi vsi-name ] [ verbose ]

Display L2VPN forwarding information.

display l2vpn forwarding { ac | pw } [ vsi vsi-name ] [ slot slot-number ] [ verbose ]

Display MAC address entries for L2VPNs.

display l2vpn mac-address [ interface interface-type interface-number [ service-instance instance-id ]  | peer ip-address pw-id pw-id | vsi vsi-name [ ac | pw ] ] [ dynamic ] [ count ]

Display L2VPN information for Layer 3 interfaces bound to VSIs.

display l2vpn interface [ vsi vsi-name | interface-type interface-number ] [ verbose ]

Display L2VPN PW information.

display l2vpn pw [ vsi vsi-name ] [ protocol { bgp | ldp | static } ] [ verbose ]

Display L2VPN PW state machine information.

display l2vpn pw state-machine [ vsi vsi-name ]

Display PW class information.

display l2vpn pw-class [ class-name ] [ verbose ]

Display Ethernet service instance information.

display l2vpn service-instance [ interface interface-type interface-number [ service-instance instance-id ] ] [ verbose ]

Display VSI information.

display l2vpn vsi [ name vsi-name | evpn-vxlan | evpn-vxlan | vpls | vxlan ] [ count | verbose ]

Display information about automatically discovered VPLS PEs.

display l2vpn auto-discovery [ peer ip-address ] [ vsi vsi-name ]

Display VPLS label block information.

display l2vpn bgp [ instance instance-name ] [ peer ip-address | local ] [ vsi vsi-name ] [ verbose ]

Display BGP L2VPN peer group information.

display bgp [ instance instance-name ] group l2vpn [ group-name group-name ]

Display VPLS PE information discovered by BGP.

display bgp [ instance instance-name ] l2vpn auto-discovery [ peer ip-address { advertised | received } [ statistics ] | route-distinguisher route-distinguisher [ pe-address ip-address [ advertise-info ] ] | statistics ]

Display VPLS label block information discovered by BGP.

display bgp [ instance instance-name ] l2vpn signaling [ peer ip-address { advertised | received } [ statistics ] | route-distinguisher route-distinguisher [ site-id site-id [ label-offset label-offset [ advertise-info ] ] ] | statistics ]

Display BGP L2VPN peer information.

display bgp [ instance instance-name ] peer l2vpn [ ip-address mask-length | group-name group-name log-info | ip-address { log-info | verbose } | verbose ]

Display BGP L2VPN update group information.

display bgp [ instance instance-name ] update-group l2vpn [ ip-address ]

Clear MAC address entries for one or all VSIs.

reset l2vpn mac-address [ vsi vsi-name ]

Reset L2VPN BGP sessions.

reset bgp { as-number | ip-address [ mask-length ] | all | external | group group-name | internal } l2vpn

For more information about the display bgp group l2vpn, display bgp peer l2vpn, display bgp update-group l2vpn, and reset bgp l2vpn commands, see Layer 3—IP Routing Command Reference.

VPLS configuration examples

Example: Configuring static PWs

Network configuration

Configure a VSI on each PE, and establish static PWs between the PEs to interconnect the CEs.

Configure an Ethernet service instance on HundredGigE 1/0/1 to match untagged packets on each PE. Bind the Ethernet service instance to the VSI to forward the matching packets through the VSI.

Figure 4 Network diagram

Procedure

 

IMPORTANT

IMPORTANT:

By default, interfaces on the device are disabled (in ADM or Administratively Down state). To have an interface operate, you must use the undo shutdown command to enable that interface.

1.     Configure PE 1:

# Configure an LSR ID.

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 1.1.1.9 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 1.1.1.9

# Enable L2VPN.

[PE1] l2vpn enable

# Enable global LDP.

[PE1] mpls ldp

[PE1-ldp] quit

# Configure HundredGigE 1/0/2 (the interface connected to PE 2), and enable LDP on the interface.

[PE1] interface hundredgige 1/0/2

[PE1-HundredGigE1/0/2] ip address 20.1.1.1 24

[PE1-HundredGigE1/0/2] mpls enable

[PE1-HundredGigE1/0/2] mpls ldp enable

[PE1-HundredGigE1/0/2] quit

# Configure HundredGigE 1/0/3 (the interface connected to PE 3), and enable LDP on the interface.

[PE1] interface hundredgige 1/0/3

[PE1-HundredGigE1/0/3] ip address 30.1.1.1 24

[PE1-HundredGigE1/0/3] mpls enable

[PE1-HundredGigE1/0/3] mpls ldp enable

[PE1-HundredGigE1/0/3] quit

# Configure OSPF for LDP to create LSPs.

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# Create a VSI, specify the peer PEs, and establish static PWs to the peer PEs.

[PE1] vsi svc

[PE1-vsi-svc] pwsignaling static

[PE1-vsi-svc-static] peer 2.2.2.9 pw-id 3 in-label 100 out-label 100

[PE1-vsi-svc-static-2.2.2.9-3] quit

[PE1-vsi-svc-static] peer 3.3.3.9 pw-id 3 in-label 200 out-label 200

[PE1-vsi-svc-static-3.3.3.9-3] quit

[PE1-vsi-svc-static] quit

[PE1-vsi-svc] quit

# Create Ethernet service instance 10 on HundredGigE 1/0/1 to match untagged packets, and bind the Ethernet service instance to the VSI svc.

[PE1] interface hundredgige 1/0/1

[PE1-HundredGigE1/0/1] port link-mode bridge

[PE1-HundredGigE1/0/1] service-instance 10

[PE1-HundredGigE1/0/1-srv10] encapsulation untagged

[PE1-HundredGigE1/0/1-srv10] xconnect vsi svc access-mode ethernet

[PE1-HundredGigE1/0/1-srv10] quit

[PE1-HundredGigE1/0/1] quit

2.     Configure PE 2:

# Configure an LSR ID.

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 2.2.2.9 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 2.2.2.9

# Enable L2VPN.

[PE2] l2vpn enable

# Enable global LDP.

[PE2] mpls ldp

[PE2-ldp] quit

# Configure HundredGigE 1/0/2 (the interface connected to PE 1), and enable LDP on the interface.

[PE2] interface hundredgige 1/0/2

[PE2-HundredGigE1/0/2] ip address 20.1.1.2 24

[PE2-HundredGigE1/0/2] mpls enable

[PE2-HundredGigE1/0/2] mpls ldp enable

[PE2-HundredGigE1/0/2] quit

# Configure HundredGigE 1/0/3 (the interface connected to PE 3), and enable LDP on the interface.

[PE2] interface hundredgige 1/0/3

[PE2-HundredGigE1/0/3] ip address 40.1.1.2 24

[PE2-HundredGigE1/0/3] mpls enable

[PE2-HundredGigE1/0/3] mpls ldp enable

[PE2-HundredGigE1/0/3] quit

# Configure OSPF for LDP to create LSPs.

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] network 40.1.1.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# Create a VSI, specify the peer PEs, and establish static PWs to the peer PEs.

[PE2] vsi svc

[PE2-vsi-svc] pwsignaling static

[PE2-vsi-svc-static] peer 1.1.1.9 pw-id 3 in-label 100 out-label 100

[PE2-vsi-svc-static-1.1.1.9-3] quit

[PE2-vsi-svc-static] peer 3.3.3.9 pw-id 3 in-label 300 out-label 300

[PE2-vsi-svc-static-3.3.3.9-3] quit

[PE2-vsi-svc-static] quit

[PE2-vsi-svc] quit

# Create Ethernet service instance 10 on HundredGigE 1/0/1 to match untagged packets, and bind the Ethernet service instance to the VSI svc.

[PE2] interface hundredgige 1/0/1

[PE2-HundredGigE1/0/1] port link-mode bridge

[PE2-HundredGigE1/0/1] service-instance 10

[PE2-HundredGigE1/0/1-srv10] encapsulation untagged

[PE2-HundredGigE1/0/1-srv10] xconnect vsi svc access-mode ethernet

[PE2-HundredGigE1/0/1-srv10] quit

[PE2-HundredGigE1/0/1] quit

3.     Configure PE 3:

# Configure an LSR ID.

<PE3> system-view

[PE3] interface loopback 0

[PE3-LoopBack0] ip address 3.3.3.9 32

[PE3-LoopBack0] quit

[PE3] mpls lsr-id 3.3.3.9

# Enable L2VPN.

[PE3] l2vpn enable

# Enable global LDP.

[PE3] mpls ldp

[PE3-ldp] quit

# Configure HundredGigE 1/0/2 (the interface connected to PE 1), and enable LDP on the interface.

[PE3] interface hundredgige 1/0/2

[PE3-HundredGigE1/0/2] ip address 30.1.1.3 24

[PE3-HundredGigE1/0/2] mpls enable

[PE3-HundredGigE1/0/2] mpls ldp enable

[PE3-HundredGigE1/0/2] quit

# Configure HundredGigE 1/0/3 (the interface connected to PE 2), and enable LDP on the interface.

[PE3] interface hundredgige 1/0/3

[PE3-HundredGigE1/0/3] ip address 40.1.1.3 24

[PE3-HundredGigE1/0/3] mpls enable

[PE3-HundredGigE1/0/3] mpls ldp enable

[PE3-HundredGigE1/0/3] quit

# Configure OSPF for LDP to create LSPs.

[PE3] ospf

[PE3-ospf-1] area 0

[PE3-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255

[PE3-ospf-1-area-0.0.0.0] network 40.1.1.0 0.0.0.255

[PE3-ospf-1-area-0.0.0.0] network 3.3.3.9 0.0.0.0

[PE3-ospf-1-area-0.0.0.0] quit

[PE3-ospf-1] quit

# Create a VSI, specify the peer PEs, and establish static PWs to the peer PEs.

[PE3] vsi svc

[PE3-vsi-svc] pwsignaling static

[PE3-vsi-svc-static] peer 1.1.1.9 pw-id 3 in-label 200 out-label 200

[PE3-vsi-svc-static-1.1.1.9-3] quit

[PE3-vsi-svc-static] peer 2.2.2.9 pw-id 3 in-label 300 out-label 300

[PE3-vsi-svc-static-2.2.2.9-3] quit

[PE3-vsi-svc-static] quit

[PE3-vsi-svc] quit

# Create Ethernet service instance 10 on HundredGigE 1/0/1 to match untagged packets, and bind the Ethernet service instance to the VSI svc.

[PE3] interface hundredgige 1/0/1

[PE3-HundredGigE1/0/1] port link-mode bridge

[PE3-HundredGigE1/0/1] service-instance 10

[PE3-HundredGigE1/0/1-srv10] encapsulation untagged

[PE3-HundredGigE1/0/1-srv10] xconnect vsi svc access-mode ethernet

[PE3-HundredGigE1/0/1-srv10] quit

[PE3-HundredGigE1/0/1] quit

Verifying the configuration

# Verify that two static PWs in up state have been established on PE 1.

[PE1] display l2vpn pw verbose

VSI Name: svc

  Peer: 2.2.2.9          PW ID: 3

    Signaling Protocol  : Static

    Link ID             : 8          PW State : Up

    In Label            : 100        Out Label: 100

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x160000001

    Tunnel NHLFE IDs    : 1027

    Admin PW            : -

  Peer: 3.3.3.9          PW ID: 3

    Signaling Protocol  : Static

    Link ID             : 9          PW State : Up

    In Label            : 200        Out Label: 200

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x260000002

    Tunnel NHLFE IDs    : 1028

    Admin PW            : -

Example: Configuring LDP PWs

Network configuration

Configure a VSI on each PE, and establish LDP PWs between the PEs to interconnect the CEs.

Configure an Ethernet service instance on HundredGigE 1/0/1 to match untagged packets on each PE. Bind the Ethernet service instance to the VSI to forward the matching packets through the VSI.

Figure 5 Network diagram

Procedure

 

IMPORTANT

IMPORTANT:

By default, interfaces on the device are disabled (in ADM or Administratively Down state). To have an interface operate, you must use the undo shutdown command to enable that interface.

1.     Configure an IGP and public tunnels. (Details not shown.)

2.     Configure PE 1:

# Configure basic MPLS.

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 1.1.1.9 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 1.1.1.9

[PE1] mpls ldp

[PE1-ldp] quit

# Enable L2VPN.

[PE1] l2vpn enable

# Configure VSI aaa that uses LDP as the PW signaling protocol, and establish PWs to PE 2 and PE 3.

[PE1] vsi aaa

[PE1-vsi-aaa] pwsignaling ldp

[PE1-vsi-aaa-ldp] peer 2.2.2.9 pw-id 500

[PE1-vsi-aaa-ldp-2.2.2.9-500] quit

[PE1-vsi-aaa-ldp] peer 3.3.3.9 pw-id 500

[PE1-vsi-aaa-ldp-3.3.3.9-500] quit

[PE1-vsi-aaa-ldp] quit

[PE1-vsi-aaa] quit

# Create Ethernet service instance 10 on HundredGigE 1/0/1 to match untagged packets, and bind the Ethernet service instance to the VSI aaa.

[PE1] interface hundredgige 1/0/1

[PE1-HundredGigE1/0/1] port link-mode bridge

[PE1-HundredGigE1/0/1] service-instance 10

[PE1-HundredGigE1/0/1-srv10] encapsulation untagged

[PE1-HundredGigE1/0/1-srv10] xconnect vsi aaa access-mode ethernet

[PE1-HundredGigE1/0/1-srv10] quit

[PE1-HundredGigE1/0/1] quit

3.     Configure PE 2:

# Configure basic MPLS.

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 2.2.2.9 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 2.2.2.9

[PE2] mpls ldp

[PE2-ldp] quit

# Enable L2VPN.

[PE2] l2vpn enable

# Configure VSI aaa that uses LDP as the PW signaling protocol, and establish PWs to PE 1 and PE 3.

[PE2] vsi aaa

[PE2-vsi-aaa] pwsignaling ldp

[PE2-vsi-aaa-ldp] peer 1.1.1.9 pw-id 500

[PE2-vsi-aaa-ldp-1.1.1.9-500] quit

[PE2-vsi-aaa-ldp] peer 3.3.3.9 pw-id 500

[PE2-vsi-aaa-ldp-3.3.3.9-500] quit

[PE2-vsi-aaa-ldp] quit

[PE2-vsi-aaa] quit

# Create Ethernet service instance 10 on HundredGigE 1/0/1 to match untagged packets, and bind the Ethernet service instance to the VSI aaa.

[PE2] interface hundredgige 1/0/1

[PE2-HundredGigE1/0/1] port link-mode bridge

[PE2-HundredGigE1/0/1] service-instance 10

[PE2-HundredGigE1/0/1-srv10] encapsulation untagged

[PE2-HundredGigE1/0/1-srv10] xconnect vsi aaa access-mode ethernet

4.     Configure PE 3:

# Configure basic MPLS.

<PE3> system-view

[PE3] interface loopback 0

[PE3-LoopBack0] ip address 3.3.3.9 32

[PE3-LoopBack0] quit

[PE3] mpls lsr-id 3.3.3.9

[PE3] mpls ldp

[PE3-ldp] quit

# Enable L2VPN.

[PE3] l2vpn enable

# Configure VSI aaa that uses LDP as the PW signaling protocol, and establish PWs to PE 1 and PE 2.

[PE3] vsi aaa

[PE3-vsi-aaa] pwsignaling ldp

[PE3-vsi-aaa-ldp] peer 1.1.1.9 pw-id 500

[PE3-vsi-aaa-ldp-1.1.1.9-500] quit

[PE3-vsi-aaa-ldp] peer 2.2.2.9 pw-id 500

[PE3-vsi-aaa-ldp-2.2.2.9-500] quit

[PE3-vsi-aaa-ldp] quit

[PE3-vsi-aaa] quit

# Create Ethernet service instance 10 on HundredGigE 1/0/1 to match untagged packets, and bind the Ethernet service instance to the VSI aaa.

[PE3] interface hundredgige 1/0/1

[PE3-HundredGigE1/0/1] port link-mode bridge

[PE3-HundredGigE1/0/1] service-instance 10

[PE3-HundredGigE1/0/1-srv10] encapsulation untagged

[PE3-HundredGigE1/0/1-srv10] xconnect vsi aaa access-mode ethernet

Verifying the configuration

# Verify that two LDP PWs in up state have been established on PE 1.

[PE1] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1279       Out Label: 1279

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x260000000

    Tunnel NHLFE IDs    : 1028

    Admin PW            : -

  Peer: 3.3.3.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1278       Out Label: 1277

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x360000001

    Tunnel NHLFE IDs    : 1029

    Admin PW            : -

Example: Configuring BGP PWs

Network configuration

Configure a VSI on each PE, and establish BGP PWs between the PEs to interconnect CEs.

Configure an Ethernet service instance on HundredGigE 1/0/1 to match untagged packets on each PE.

Bind the Ethernet service instance to the VSI to forward the matching packets through the VSI.

Figure 6 Network diagram

Procedure

 

IMPORTANT

IMPORTANT:

By default, interfaces on the device are disabled (in ADM or Administratively Down state). To have an interface operate, you must use the undo shutdown command to enable that interface.

1.     Configure an IGP and public tunnels. (Details not shown.)

2.     Configure PE 1:

# Configure basic MPLS.

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 1.1.1.9 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 1.1.1.9

[PE1] mpls ldp

[PE1-ldp] quit

# Establish IBGP connections to PE 2 and PE 3, and use BGP to advertise VPLS label block information.

[PE1] bgp 100

[PE1-bgp-default] peer 2.2.2.9 as-number 100

[PE1-bgp-default] peer 2.2.2.9 connect-interface loopback 0

[PE1-bgp-default] peer 3.3.3.9 as-number 100

[PE1-bgp-default] peer 3.3.3.9 connect-interface loopback 0

[PE1-bgp-default] address-family l2vpn

[PE1-bgp-default-l2vpn] peer 2.2.2.9 enable

[PE1-bgp-default-l2vpn] peer 3.3.3.9 enable

[PE1-bgp-default-l2vpn] quit

[PE1-bgp-default] quit

# Enable L2VPN.

[PE1] l2vpn enable

# Configure VSI aaa to use BGP to establish BGP PWs to PE 2 and PE 3.

[PE1] vsi aaa

[PE1-vsi-aaa] auto-discovery bgp

[PE1-vsi-aaa-auto] route-distinguisher 1:1

[PE1-vsi-aaa-auto] vpn-target 1:1

[PE1-vsi-aaa-auto] signaling-protocol bgp

[PE1-vsi-aaa-auto-bgp] site 1 range 10 default-offset 0

[PE1-vsi-aaa-auto-bgp] quit

[PE1-vsi-aaa-auto] quit

[PE1-vsi-aaa] quit

# Create Ethernet service instance 10 on HundredGigE 1/0/1 to match untagged packets, and bind the Ethernet service instance to the VSI aaa.

[PE1] interface hundredgige 1/0/1

[PE1-HundredGigE1/0/1] port link-mode bridge

[PE1-HundredGigE1/0/1] service-instance 10

[PE1-HundredGigE1/0/1-srv10] encapsulation untagged

[PE1-HundredGigE1/0/1-srv10] xconnect vsi aaa access-mode ethernet

[PE1-HundredGigE1/0/1-srv10] quit

[PE1-HundredGigE1/0/1] quit

3.     Configure PE 2:

# Configure basic MPLS.

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 2.2.2.9 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 2.2.2.9

[PE2] mpls ldp

[PE2-ldp] quit

# Establish IBGP connections to PE 1 and PE 3, and use BGP to advertise VPLS label block information.

[PE2] bgp 100

[PE2-bgp-default] peer 1.1.1.9 as-number 100

[PE2-bgp-default] peer 1.1.1.9 connect-interface loopback 0

[PE2-bgp-default] peer 3.3.3.9 as-number 100

[PE2-bgp-default] peer 3.3.3.9 connect-interface loopback 0

[PE2-bgp-default] address-family l2vpn

[PE2-bgp-default-l2vpn] peer 1.1.1.9 enable

[PE2-bgp-default-l2vpn] peer 3.3.3.9 enable

[PE2-bgp-default-l2vpn] quit

[PE2-bgp-default] quit

# Enable L2VPN.

[PE2] l2vpn enable

# Configure VSI aaa to use BGP to establish BGP PWs to PE 1 and PE 3.

[PE2] vsi aaa

[PE2-vsi-aaa] auto-discovery bgp

[PE2-vsi-aaa-auto] route-distinguisher 1:1

[PE2-vsi-aaa-auto] vpn-target 1:1

[PE2-vsi-aaa-auto] signaling-protocol bgp

[PE2-vsi-aaa-auto-bgp] site 2 range 10 default-offset 0

[PE2-vsi-aaa-auto-bgp] quit

[PE2-vsi-aaa-auto] quit

[PE2-vsi-aaa] quit

# Create Ethernet service instance 10 on HundredGigE 1/0/1 to match untagged packets, and bind the Ethernet service instance to the VSI aaa.

[PE2] interface hundredgige 1/0/1

[PE2-HundredGigE1/0/1] port link-mode bridge

[PE2-HundredGigE1/0/1] service-instance 10

[PE2-HundredGigE1/0/1-srv10] encapsulation untagged

[PE2-HundredGigE1/0/1-srv10] xconnect vsi aaa access-mode ethernet

[PE2-HundredGigE1/0/1-srv10] quit

[PE2-HundredGigE1/0/1] quit

4.     Configure PE 3:

# Configure basic MPLS.

<PE3> system-view

[PE3] interface loopback 0

[PE3-LoopBack0] ip address 3.3.3.9 32

[PE3-LoopBack0] quit

[PE3] mpls lsr-id 3.3.3.9

[PE3] mpls ldp

[PE3-ldp] quit

# Establish IBGP connections to PE 1 and PE 2, and use BGP to advertise VPLS label block information.

[PE3] bgp 100

[PE3-bgp-default] peer 1.1.1.9 as-number 100

[PE3-bgp-default] peer 1.1.1.9 connect-interface loopback 0

[PE3-bgp-default] peer 2.2.2.9 as-number 100

[PE3-bgp-default] peer 2.2.2.9 connect-interface loopback 0

[PE3-bgp-default] address-family l2vpn

[PE3-bgp-default-l2vpn] peer 1.1.1.9 enable

[PE3-bgp-default-l2vpn] peer 2.2.2.9 enable

[PE3-bgp-default-l2vpn] quit

[PE3-bgp-default] quit

# Enable L2VPN.

[PE3] l2vpn enable

# Configure VSI aaa to use BGP to establish BGP PWs to PE 1 and PE 2.

[PE3] vsi aaa

[PE3-vsi-aaa] auto-discovery bgp

[PE3-vsi-aaa-auto] route-distinguisher 1:1

[PE3-vsi-aaa-auto] vpn-target 1:1

[PE3-vsi-aaa-auto] signaling-protocol bgp

[PE3-vsi-aaa-auto-bgp] site 3 range 10 default-offset 0

[PE3-vsi-aaa-auto-bgp] quit

[PE3-vsi-aaa-auto] quit

[PE3-vsi-aaa] quit

# Create Ethernet service instance 10 on HundredGigE 1/0/1 to match untagged packets, and bind the Ethernet service instance to the VSI aaa.

[PE3] interface hundredgige 1/0/1

[PE3-HundredGigE1/0/1] port link-mode bridge

[PE3-HundredGigE1/0/1] service-instance 10

[PE3-HundredGigE1/0/1-srv10] encapsulation untagged

[PE3-HundredGigE1/0/1-srv10] xconnect vsi aaa access-mode ethernet

[PE3-HundredGigE1/0/1-srv10] quit

[PE3-HundredGigE1/0/1] quit

Verifying the configuration

# Verify that two BGP PWs in up state have been established on PE 1.

[PE1] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.9          Remote Site: 2

    Signaling Protocol  : BGP

    Link ID             : 9          PW State : Up

    In Label            : 1295       Out Label: 1025

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x800000160000001

    Tunnel NHLFE IDs    : 1027

    Admin PW            : -

  Peer: 3.3.3.9          Remote Site: 3

    Signaling Protocol  : BGP

    Link ID             : 10         PW State : Up

    In Label            : 1296       Out Label: 1025

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x800000060000000

    Tunnel NHLFE IDs    : 1026

    Admin PW            : -

# Display VPLS label block information received from PE 2 and PE 3 on PE 1.

[PE1] display l2vpn bgp verbose

VSI Name: aaa

 Remote Site ID     : 2

 Offset             : 0

 RD                 : 1:1

 PW State           : Up

 Encapsulation      : BGP-VPLS

 MTU                : 1500

 Nexthop            : 2.2.2.9

 Local VC Label     : 1295

 Remote VC Label    : 1025

 Link ID            : 9

 Local Label Block  : 1293/10/0

 Remote Label Block : 1024/10/0

 Local Flow Label   : -

 Reomote Flow Label : -

 Export Route Target: 1:1

 

 Remote Site ID     : 3

 Offset             : 0

 RD                 : 1:1

 PW State           : Up

 Encapsulation      : BGP-VPLS

 MTU                : 1500

 Nexthop            : 3.3.3.9

 Local VC Label     : 1296

 Remote VC Label    : 1025

 Link ID            : 10

 Local Label Block  : 1293/10/0

 Remote Label Block : 1024/10/0

 Local Flow Label   : -

 Reomote Flow Label : -

 Export Route Target: 1:1

Example: Configuring BGP auto-discovery LDP PWs

Network configuration

Configure a VSI on each PE. Use BGP to discover remote PEs and use LDP to create PWs among PEs so CEs in different sites of VPN 1 can communicate with each other.

Configure an Ethernet service instance on HundredGigE 1/0/1 to match untagged packets on each PE. Bind the Ethernet service instance to the VSI to forward the matching packets through the VSI.

Figure 7 Network diagram

Procedure

 

IMPORTANT

IMPORTANT:

By default, interfaces on the device are disabled (in ADM or Administratively Down state). To have an interface operate, you must use the undo shutdown command to enable that interface.

1.     Configure an IGP and public tunnels. (Details not shown.)

2.     Configure PE 1:

# Configure basic MPLS.

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 1.1.1.9 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 1.1.1.9

[PE1] mpls ldp

[PE1-ldp] quit

# Establish IBGP connections to PE 1 and PE 2, and use BGP to advertise VPLS PE information.

[PE1] bgp 100

[PE1-bgp-default] peer 2.2.2.9 as-number 100

[PE1-bgp-default] peer 2.2.2.9 connect-interface loopback 0

[PE1-bgp-default] peer 3.3.3.9 as-number 100

[PE1-bgp-default] peer 3.3.3.9 connect-interface loopback 0

[PE1-bgp-default] address-family l2vpn

[PE1-bgp-default-l2vpn] peer 2.2.2.9 enable

[PE1-bgp-default-l2vpn] peer 3.3.3.9 enable

[PE1-bgp-default-l2vpn] quit

[PE1-bgp-default] quit

# Enable L2VPN.

[PE1] l2vpn enable

# Configure VSI aaa to use BGP to discover remote PEs and use LDP to establish LDP PWs to PE 2 and PE 3.

[PE1] vsi aaa

[PE1-vsi-aaa] auto-discovery bgp

[PE1-vsi-aaa-auto] route-distinguisher 1:1

[PE1-vsi-aaa-auto] vpn-target 1:1

[PE1-vsi-aaa-auto] signaling-protocol ldp

[PE1-vsi-aaa-auto-ldp] vpls-id 100:100

[PE1-vsi-aaa-auto-ldp] quit

[PE1-vsi-aaa-auto] quit

[PE1-vsi-aaa] quit

# Create Ethernet service instance 10 on HundredGigE 1/0/1 to match untagged packets, and bind the Ethernet service instance to the VSI aaa.

[PE1] interface hundredgige 1/0/1

[PE1-HundredGigE1/0/1] port link-mode bridge

[PE1-HundredGigE1/0/1] service-instance 10

[PE1-HundredGigE1/0/1-srv10] encapsulation untagged

[PE1-HundredGigE1/0/1-srv10] xconnect vsi aaa access-mode ethernet

[PE1-HundredGigE1/0/1-srv10] quit

[PE1-HundredGigE1/0/1] quit

3.     Configure PE 2:

# Configure basic MPLS.

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 2.2.2.9 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 2.2.2.9

[PE2] mpls ldp

[PE2-ldp] quit

# Establish IBGP connections to PE 1 and PE 3, and use BGP to advertise VPLS PE information.

[PE2] bgp 100

[PE2-bgp-default] peer 1.1.1.9 as-number 100

[PE2-bgp-default] peer 1.1.1.9 connect-interface loopback 0

[PE2-bgp-default] peer 3.3.3.9 as-number 100

[PE2-bgp-default] peer 3.3.3.9 connect-interface loopback 0

[PE2-bgp-default] address-family l2vpn

[PE2-bgp-default-l2vpn] peer 1.1.1.9 enable

[PE2-bgp-default-l2vpn] peer 3.3.3.9 enable

[PE2-bgp-default-l2vpn] quit

[PE2-bgp-default] quit

# Enable L2VPN.

[PE2] l2vpn enable

# Configure VSI aaa to use BGP to discover remote PEs and use LDP to establish LDP PWs to PE 1 and PE 3.

[PE2] vsi aaa

[PE2-vsi-aaa] auto-discovery bgp

[PE2-vsi-aaa-auto] route-distinguisher 1:1

[PE2-vsi-aaa-auto] vpn-target 1:1

[PE2-vsi-aaa-auto] signaling-protocol ldp

[PE2-vsi-aaa-auto-ldp] vpls-id 100:100

[PE2-vsi-aaa-auto-ldp] quit

[PE2-vsi-aaa-auto] quit

[PE2-vsi-aaa] quit

# Create Ethernet service instance 10 on HundredGigE 1/0/1 to match untagged packets, and bind the Ethernet service instance to the VSI aaa.

[PE2] interface hundredgige 1/0/1

[PE2-HundredGigE1/0/1] port link-mode bridge

[PE2-HundredGigE1/0/1] service-instance 10

[PE2-HundredGigE1/0/1-srv10] encapsulation untagged

[PE2-HundredGigE1/0/1-srv10] xconnect vsi aaa access-mode ethernet

[PE2-HundredGigE1/0/1-srv10] quit

[PE2-HundredGigE1/0/1] quit

4.     Configure PE 3:

# Configure basic MPLS.

<PE3> system-view

[PE3] interface loopback 0

[PE3-LoopBack0] ip address 3.3.3.9 32

[PE3-LoopBack0] quit

[PE3] mpls lsr-id 3.3.3.9

[PE3] mpls ldp

[PE3-ldp] quit

# Establish IBGP connections to PE 1 and PE 2, and use BGP to advertise VPLS PE information.

[PE3] bgp 100

[PE3-bgp-default] peer 1.1.1.9 as-number 100

[PE3-bgp-default] peer 1.1.1.9 connect-interface loopback 0

[PE3-bgp-default] peer 2.2.2.9 as-number 100

[PE3-bgp-default] peer 2.2.2.9 connect-interface loopback 0

[PE3-bgp-default] address-family l2vpn

[PE3-bgp-default-l2vpn] peer 1.1.1.9 enable

[PE3-bgp-default-l2vpn] peer 2.2.2.9 enable

[PE3-bgp-default-l2vpn] quit

[PE3-bgp-default] quit

# Enable L2VPN.

[PE3] l2vpn enable

# Configure VSI aaa to use BGP to discover remote PEs and use LDP to establish LDP PWs to PE 1 and PE 2.

[PE3] vsi aaa

[PE3-vsi-aaa] auto-discovery bgp

[PE3-vsi-aaa-auto] route-distinguisher 1:1

[PE3-vsi-aaa-auto] vpn-target 1:1

[PE3-vsi-aaa-auto] signaling-protocol ldp

[PE3-vsi-aaa-auto-ldp] vpls-id 100:100

[PE3-vsi-aaa-auto-ldp] quit

[PE3-vsi-aaa-auto] quit

[PE3-vsi-aaa] quit

# Create Ethernet service instance 10 on HundredGigE 1/0/1 to match untagged packets, and bind the Ethernet service instance to the VSI aaa.

[PE3] interface hundredgige 1/0/1

[PE3-HundredGigE1/0/1] port link-mode bridge

[PE3-HundredGigE1/0/1] service-instance 10

[PE3-HundredGigE1/0/1-srv10] encapsulation untagged

[PE3-HundredGigE1/0/1-srv10] xconnect vsi aaa access-mode ethernet

[PE3-HundredGigE1/0/1-srv10] quit

[PE3-HundredGigE1/0/1] quit

Verifying the configuration

# Verify that two PWs in up state have been established on PE 1.

[PE1] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.9          VPLS ID: 100:100

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1555       Out Label: 1555

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x800000060000000

    Tunnel NHLFE IDs    : 1029

    Admin PW            : -

  Peer: 3.3.3.9          VPLS ID: 100:100

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1554       Out Label: 1416

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x800000160000001

    Tunnel NHLFE IDs    : 1030

    Admin PW            : -

# Display LDP PW label information on PE 1.

[PE1] display l2vpn ldp verbose

Peer: 2.2.2.9          VPLS ID: 100:100

  VSI Name: aaa

  PW State: Up

  PW Status Communication: Notification method

  PW ID FEC (Local/Remote):

    Local AII       : (1.1.1.9, 2.2.2.9)

    Remote AII      : (2.2.2.9, 1.1.1.9)

    PW Type         : VLAN/VLAN

    Group ID        : 0/0

    Label           : 1555/1555

    Control Word    : Disabled/Disabled

    VCCV CV Type    : -/-

    VCCV CC Type    : -/-

    Flow Label      : -/-

    MTU             : 1500/1500

    MTU Negotiation : Enabled

    PW Status       : PW forwarding/PW forwarding

Peer: 3.3.3.9          VPLS ID: 100:100

  VSI Name: aaa

  PW State: Up

  PW Status Communication: Notification method

  PW ID FEC (Local/Remote):

    Local AII       : (1.1.1.9, 3.3.3.9)

    Remote AII      : (3.3.3.9, 1.1.1.9)

    PW Type         : VLAN/VLAN

    Group ID        : 0/0

    Label           : 1554/1416

    Control Word    : Disabled/Disabled

    VCCV CV Type    : -/-

    VCCV CC Type    : -/-

    Flow Label      : -/-

    MTU             : 1500/1500

    MTU Negotiation : Enabled

    PW Status       : PW forwarding/PW forwarding

Example: Configuring H-VPLS using MPLS access

Network configuration

Configure an H-VPLS network using MPLS access to avoid full-mesh PW configuration. The H-VPLS uses LDP as the PW signaling protocol.

Figure 8 Network diagram

Procedure

 

IMPORTANT

IMPORTANT:

By default, interfaces on the device are disabled (in ADM or Administratively Down state). To have an interface operate, you must use the undo shutdown command to enable that interface.

1.     Configure an IGP and public tunnels. (Details not shown.)

2.     Configure UPE:

# Configure basic MPLS.

<UPE> system-view

[UPE] interface loopback 0

[UPE-LoopBack0] ip address 1.1.1.9 32

[UPE-LoopBack0] quit

[UPE] mpls lsr-id 1.1.1.9

[UPE] mpls ldp

[UPE-ldp] quit

# Enable L2VPN.

[UPE] l2vpn enable

# Configure VSI aaa to use LDP to establish a U-PW to NPE 1.

[UPE] vsi aaa

[UPE-vsi-aaa] pwsignaling ldp

[UPE-vsi-aaa-ldp] peer 2.2.2.9 pw-id 500

[UPE-vsi-aaa-ldp-2.2.2.9-500] quit

[UPE-vsi-aaa-ldp] quit

[UPE-vsi-aaa] quit

# Create Ethernet service instance 10 on HundredGigE 1/0/1 to match untagged packets, and bind the Ethernet service instance to the VSI aaa.

[UPE] interface hundredgige 1/0/1

[UPE-HundredGigE1/0/1] port link-mode bridge

[UPE-HundredGigE1/0/1] service-instance 10

[UPE-HundredGigE1/0/1-srv10] encapsulation untagged

[UPE-HundredGigE1/0/1-srv10] xconnect vsi aaa access-mode ethernet

[UPE-HundredGigE1/0/1-srv10] quit

[UPE-HundredGigE1/0/1] quit

3.     Configure NPE 1:

# Configure basic MPLS.

<NPE1> system-view

[NPE1] interface loopback 0

[NPE1-LoopBack0] ip address 2.2.2.9 32

[NPE1-LoopBack0] quit

[NPE1] mpls lsr-id 2.2.2.9

[NPE1] mpls ldp

[NPE1–ldp] quit

# Enable L2VPN.

[NPE1] l2vpn enable

# Configure VSI aaa that uses LDP as the PW signaling protocol, establish a U-PW to the UPE, and establish N-PWs to NPE 2 and NPE 3.

[NPE1] vsi aaa

[NPE1-vsi-aaa] pwsignaling ldp

[NPE1-vsi-aaa-ldp] peer 1.1.1.9 pw-id 500 no-split-horizon

[NPE1-vsi-aaa-ldp-1.1.1.9-500] quit

[NPE1-vsi-aaa-ldp] peer 3.3.3.9 pw-id 500

[NPE1-vsi-aaa-ldp-3.3.3.9-500] quit

[NPE1-vsi-aaa-ldp] peer 4.4.4.9 pw-id 500

[NPE1-vsi-aaa-ldp-4.4.4.9-500] quit

[NPE1-vsi-aaa-ldp] quit

[NPE1-vsi-aaa] quit

4.     Configure NPE 2:

# Configure basic MPLS.

<NPE2> system-view

[NPE2] interface loopback 0

[NPE2-LoopBack0] ip address 3.3.3.9 32

[NPE2-LoopBack0] quit

[NPE2] mpls lsr-id 3.3.3.9

[NPE2] mpls ldp

[NPE2–ldp] quit

# Enable L2VPN.

[NPE2] l2vpn enable

# Configure VSI aaa that uses LDP as the PW signaling protocol, and establish N-PWs to NPE 1 and NPE 3.

[NPE2] vsi aaa

[NPE2-vsi-aaa] pwsignal ldp

[NPE2-vsi-aaa-ldp] peer 2.2.2.9 pw-id 500

[NPE2-vsi-aaa-ldp-2.2.2.9-500] quit

[NPE2-vsi-aaa-ldp] peer 4.4.4.9 pw-id 500

[NPE2-vsi-aaa-ldp-4.4.4.9-500] quit

[NPE2-vsi-aaa-ldp] quit

[NPE2-vsi-aaa] quit

# Create Ethernet service instance 10 on HundredGigE 1/0/1 to match untagged packets, and bind the Ethernet service instance to the VSI aaa.

[NPE2] interface hundredgige 1/0/1

[NPE2-HundredGigE1/0/1] port link-mode bridge

[NPE2-HundredGigE1/0/1] service-instance 10

[NPE2-HundredGigE1/0/1-srv10] encapsulation untagged

[NPE2-HundredGigE1/0/1-srv10] xconnect vsi aaa access-mode ethernet

[NPE2-HundredGigE1/0/1-srv10] quit

[NPE2-HundredGigE1/0/1] quit

5.     Configure NPE 3:

# Configure basic MPLS.

<NPE3> system-view

[NPE3] interface loopback 0

[NPE3-LoopBack0] ip address 4.4.4.9 32

[NPE3-LoopBack0] quit

[NPE3] mpls lsr-id 4.4.4.9

[NPE3] mpls ldp

[NPE3–ldp] quit

# Enable L2VPN.

[NPE3] l2vpn enable

# Configure VSI aaa that uses LDP as the PW signaling protocol, and establish N-PWs to NPE 1 and NPE 2.

[NPE3] vsi aaa

[NPE3-vsi-aaa] pwsignal ldp

[NPE3-vsi-aaa-ldp] peer 2.2.2.9 pw-id 500

[NPE3-vsi-aaa-ldp-2.2.2.9-500] quit

[NPE3-vsi-aaa-ldp] peer 3.3.3.9 pw-id 500

[NPE3-vsi-aaa-ldp-3.3.3.9-500] quit

[NPE3-vsi-aaa-ldp] quit

[NPE3-vsi-aaa] quit

# Create Ethernet service instance 10 on HundredGigE 1/0/1 to match untagged packets, and bind the Ethernet service instance to the VSI aaa.

[NPE3] interface hundredgige 1/0/1

[NPE3-HundredGigE1/0/1] port link-mode bridge

[NPE3-HundredGigE1/0/1] service-instance 10

[NPE3-HundredGigE1/0/1-srv10] encapsulation untagged

[NPE3-HundredGigE1/0/1-srv10] xconnect vsi aaa access-mode ethernet

[NPE3-HundredGigE1/0/1-srv10] quit

[NPE3-HundredGigE1/0/1] quit

Verifying the configuration

# Verify that PWs in up state have been established on each PE.

[UPE] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1277       Out Label: 1277

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x460000000

    Tunnel NHLFE IDs    : 1030

    Admin PW            : -

[NPE1] display l2vpn pw verbose

VSI Name: aaa

  Peer: 1.1.1.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1277       Out Label: 1277

    MTU                 : 1500

    PW Attributes       : Main, No-split-horizon

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x460000000

    Tunnel NHLFE IDs    : 1030

    Admin PW            : -

  Peer: 3.3.3.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1276       Out Label: 1275

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x560000001

    Tunnel NHLFE IDs    : 1031

    Admin PW            : -

  Peer: 4.4.4.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 10          PW State : Up

    In Label            : 1278       Out Label: 1279

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x570000001

    Tunnel NHLFE IDs    : 1032

    Admin PW            : -

[NPE2] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1275       Out Label: 1276

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x660000000

    Tunnel NHLFE IDs    : 1031

    Admin PW            : -

  Peer: 4.4.4.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1277       Out Label: 1277

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x670000000

    Tunnel NHLFE IDs    : 1032

    Admin PW            : -

[NPE3] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1279       Out Label: 1278

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x660000000

    Tunnel NHLFE IDs    : 1031

    Admin PW            : -

  Peer: 3.3.3.9          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1277       Out Label: 1277

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x670000000

    Tunnel NHLFE IDs    : 1032

    Admin PW            : -

Example: Configuring H-VPLS UPE dual homing

Network configuration

To improve reliability of the H-VPLS network, the UPE establishes a U-PW with NPE 1 and NPE 2. The U-PW between UPE and NPE 1 is the primary PW and that between UPE and NPE 2 is the backup PW. The backup PW works only when the primary PW fails.

The H-VPLS uses LDP as the PW signaling protocol.

Figure 9 Network diagram

Procedure

 

IMPORTANT

IMPORTANT:

By default, interfaces on the device are disabled (in ADM or Administratively Down state). To have an interface operate, you must use the undo shutdown command to enable that interface.

1.     Configure an IGP and public tunnels. (Details not shown.)

2.     Configure UPE:

# Configure basic MPLS.

<UPE> system-view

[UPE] interface loopback 0

[UPE-LoopBack0] ip address 1.1.1.1 32

[UPE-LoopBack0] quit

[UPE] mpls lsr-id 1.1.1.1

[UPE] mpls ldp

[UPE-ldp] quit

# Enable L2VPN.

[UPE] l2vpn enable

# Configure VSI aaa that uses LDP as the PW signaling protocol, and establish the primary PW to NPE 1 and the backup PW to NPE 2.

[UPE] vsi aaa

[UPE-vsi-aaa] pwsignaling ldp

[UPE-vsi-aaa-ldp] peer 2.2.2.2 pw-id 500

[UPE-vsi-aaa-ldp-2.2.2.2-500] backup-peer 3.3.3.3 pw-id 500

[UPE-vsi-aaa-ldp-2.2.2.2-500-backup] quit

[UPE-vsi-aaa-ldp-2.2.2.2-500] quit

[UPE-vsi-aaa-ldp] quit

[UPE-vsi-aaa] quit

# Create Ethernet service instance 1000 on HundredGigE 1/0/1 (the interface connected to CE 1), and bind the Ethernet service instance to the VSI aaa.

[UPE] interface hundredgige 1/0/1

[UPE-HundredGigE1/0/1] port link-mode bridge

[UPE-PE-HundredGigE1/0/1] service-instance 1000

[UPE-HundredGigE1/0/1-srv1000] encapsulation untagged

[UPE-HundredGigE1/0/1-srv1000] xconnect vsi aaa access-mode ethernet

[UPE-HundredGigE1/0/1-srv1000] quit

[UPE-HundredGigE1/0/1] quit

# Create Ethernet service instance 1000 on HundredGigE 1/0/2 (the interface connected to CE 2), and bind the Ethernet service instance to the VSI aaa.

[UPE] interface hundredgige 1/0/2

[UPE-HundredGigE1/0/2] port link-mode bridge

[UPE-PE-HundredGigE1/0/2] service-instance 1000

[UPE-HundredGigE1/0/2-srv1000] encapsulation untagged

[UPE-HundredGigE1/0/2-srv1000] xconnect vsi aaa access-mode ethernet

[UPE-HundredGigE1/0/2-srv1000] quit

[UPE-HundredGigE1/0/2] quit

3.     Configure NPE 1:

# Configure basic MPLS.

<NPE1> system-view

[NPE1] interface loopback 0

[NPE1-LoopBack0] ip address 2.2.2.2 32

[NPE1-LoopBack0] quit

[NPE1] mpls lsr-id 2.2.2.2

[NPE1] mpls ldp

[NPE1–ldp] quit

# Enable L2VPN.

[NPE1] l2vpn enable

# Configure VSI aaa that uses LDP as the PW signaling protocol, and establish PWs to UPE, NPE 2, and NPE 3.

[NPE1] vsi aaa

[NPE1-vsi-aaa] pwsignaling ldp

[NPE1-vsi-aaa-ldp] peer 1.1.1.1 pw-id 500 no-split-horizon

[NPE1-vsi-aaa-ldp-1.1.1.1-500] quit

[NPE1-vsi-aaa-ldp] peer 3.3.3.3 pw-id 500

[NPE1-vsi-aaa-ldp-3.3.3.3-500] quit

[NPE1-vsi-aaa-ldp] peer 4.4.4.4 pw-id 500

[NPE1-vsi-aaa-ldp-4.4.4.4-500] quit

[NPE1-vsi-aaa-ldp] quit

[NPE1-vsi-aaa] quit

4.     Configure NPE 2:

# Configure basic MPLS.

<NPE2> system-view

[NPE2] interface loopback 0

[NPE2-LoopBack0] ip address 3.3.3.3 32

[NPE2-LoopBack0] quit

[NPE2] mpls lsr-id 3.3.3.3

[NPE2] mpls ldp

[NPE2–ldp] quit

# Enable L2VPN.

[NPE2] l2vpn enable

# Configure VSI aaa that uses LDP as the PW signaling protocol, and establish PWs to UPE, NPE 1, and NPE 3.

[NPE2] vsi aaa

[NPE2-vsi-aaa] pwsignaling ldp

[NPE2-vsi-aaa-ldp] peer 1.1.1.1 pw-id 500 no-split-horizon

[NPE2-vsi-aaa-ldp-1.1.1.1-500] quit

[NPE2-vsi-aaa-ldp] peer 2.2.2.2 pw-id 500

[NPE2-vsi-aaa-ldp-2.2.2.2-500] quit

[NPE2-vsi-aaa-ldp] peer 4.4.4.4 pw-id 500

[NPE2-vsi-aaa-ldp-4.4.4.4-500] quit

[NPE2-vsi-aaa-ldp] quit

[NPE2-vsi-aaa] quit

5.     Configure NPE 3:

# Configure basic MPLS.

<NPE3> system-view

[NPE3] interface loopback 0

[NPE3-LoopBack0] ip address 4.4.4.4 32

[NPE3-LoopBack0] quit

[NPE3] mpls lsr-id 4.4.4.4

[NPE3] mpls ldp

[NPE3–ldp] quit

# Enable L2VPN.

[NPE3] l2vpn enable

# Configure VSI aaa that uses LDP as the PW signaling protocol, and establish PWs to NPE 1 and NPE 2.

[NPE3] vsi aaa

[NPE3-vsi-aaa] pwsignaling ldp

[NPE3-vsi-aaa-ldp] peer 2.2.2.2 pw-id 500

[NPE3-vsi-aaa-ldp-2.2.2.2-500] quit

[NPE3-vsi-aaa-ldp] peer 3.3.3.3 pw-id 500

[NPE3-vsi-aaa-ldp-3.3.3.3-500] quit

[NPE3-vsi-aaa-ldp] quit

[NPE3-vsi-aaa] quit

# Create Ethernet service instance 1000 on HundredGigE 1/0/1 (the interface connected to CE 3), and bind the Ethernet service instance to the VSI aaa.

[NPE3] interface hundredgige 1/0/1

[NPE3-HundredGigE1/0/1] port link-mode bridge

[NPE3-HundredGigE1/0/1] service-instance 1000

[NPE3-HundredGigE1/0/1-srv1000] encapsulation untagged

[NPE3-HundredGigE1/0/1-srv1000] xconnect vsi aaa access-mode ethernet

[NPE3-HundredGigE1/0/1-srv1000] quit

[NPE3-HundredGigE1/0/1] quit

Verifying the configuration

# Verify that PWs in up state have been established on each PE.

[UPE] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.2          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1151       Out Label: 1279

    Wait to Restore Time: 0 sec

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x260000002

    Tunnel NHLFE IDs    : 1027

    Admin PW            : -

  Peer: 3.3.3.3          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Blocked

    In Label            : 1150       Out Label: 1279

    MTU                 : 1500

    PW Attributes       : Backup

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x360000003

    Tunnel NHLFE IDs    : 1025

    Admin PW            : -

[NPE1] display l2vpn pw verbose

VSI Name: aaa

  Peer: 1.1.1.1          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1279       Out Label: 1151

    MTU                 : 1500

    PW Attributes       : Main, No-split-horizon

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x60000000

    Tunnel NHLFE IDs    : 1026

    Admin PW            : -

  Peer: 3.3.3.3          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1280       Out Label: 1290

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x160000005

    Tunnel NHLFE IDs    : 1027

    Admin PW            : -

  Peer: 4.4.4.4          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 10         PW State : Up

    In Label            : 1278       Out Label: 1279

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x160000001

    Tunnel NHLFE IDs    : 1028

    Admin PW            : -

[NPE2] display l2vpn pw verbose

VSI Name: aaa

  Peer: 1.1.1.1          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1279       Out Label: 1150

    MTU                 : 1500

    PW Attributes       : Main, No-split-horizon

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x60000000

    Tunnel NHLFE IDs    : 1026

    Admin PW            : -

  Peer: 2.2.2.2          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1290       Out Label: 1280

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x160000008

    Tunnel NHLFE IDs    : 1027

    Admin PW            : -

  Peer: 4.4.4.4          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 10         PW State : Up

    In Label            : 1278       Out Label: 1278

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x160000001

    Tunnel NHLFE IDs    : 1028

    Admin PW            : -

[NPE3] display l2vpn pw verbose

VSI Name: aaa

  Peer: 2.2.2.2          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 8          PW State : Up

    In Label            : 1279       Out Label: 1278

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x60000000

    Tunnel NHLFE IDs    : 1026

    Admin PW            : -

  Peer: 3.3.3.3          PW ID: 500

    Signaling Protocol  : LDP

    Link ID             : 9          PW State : Up

    In Label            : 1278       Out Label: 1278

    MTU                 : 1500

    PW Attributes       : Main

    VCCV CC             : -

    VCCV BFD            : -

    Flow Label          : -

    Tunnel Group ID     : 0x160000001

    Tunnel NHLFE IDs    : 1027

    Admin PW            : -

 

  • Cloud & AI
  • InterConnect
  • Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网