06-IP Multicast Configuration Examples

HomeSupportResource CenterSwitchesH3C S7500X Switch SeriesH3C S7500X Switch SeriesTechnical DocumentsConfigureConfiguration ExamplesH3C S7500X Switch Series Configuration Examples-R7595-6W10006-IP Multicast Configuration Examples
06-H3C_IPv6_Multicast_VLAN_Configuration_Examples

 

H3C IPv6 Multicast VLAN

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Software version: Release 7595

Document version: 6W100-20201031

 

Copyright © 2020 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

This document provides IPv6 multicast VLAN configuration examples.

Prerequisites

The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

This document assumes that you have basic knowledge of IPv6 multicast VLAN.

Example: Configuring sub-VLAN-based IPv6 multicast VLANs

Network configuration

As shown in Figure 1:

·     VLAN 10 and VLAN 20 are Department 1 and Department 2, respectively.

·     VLAN-interface 10 and VLAN-interface 20 on Layer 3 device Switch A are the gateways of VLAN 10 and VLAN 20, respectively.

·     MLDv1 runs in VLAN 10 on Switch A, and MLDv1 snooping runs in VLAN 10 on Layer 2 device Switch B.

·     Source sends IPv6 multicast data to IPv6 multicast group FF1E::101.

·     Host A and Host B in VLAN 10 join the group FF1E::101. They can receive the IPv6 multicast data that Source sends to the group.

Figure 1 Network diagram

 

Now, Host C and Host D in VLAN 20 also join the group to receive the IPv6 multicast data, as shown in Figure 2. To meet the requirement, you can enable MLDv1 for VLAN 20 on Switch A and MLDv1 snooping for VLAN 20 on Switch B. However, this method occupies a large amount of bandwidth and increases the burden on Switch A.

To avoid the problems, you can configure a sub-VLAN-based IPv6 multicast VLAN on Switch B.

Figure 2 Network diagram

 

Analysis

To meet the network requirements, you must perform the following tasks:

·     Create VLAN 30 on Switch A and Switch B, and assign Ten-GigabitEthernet 1/0/1 on them to VLAN 10 through VLAN 30 as tagged VLAN members.

·     Create VLAN-interface 30 on Switch A, and enable MLD on the interface.

·     Enable MLD snooping for VLAN 10 through VLAN 30 on Switch B.

·     Configure VLAN 30 on Switch B as an IPv6 multicast VLAN, and assign VLAN 10 and VLAN 20 to IPv6 multicast VLAN 30 as sub-VLANs.

Restrictions and guidelines

When you configure sub-VLAN-based IPv6 multicast VLANs, follow these restrictions and guidelines:

·     As a best practice, do not configure IPv6 multicast VLANs on the device that is enabled with IPv6 multicast routing.

·     The IPv6 address assigned to the VLAN interface of the IPv6 multicast VLAN must be unique on the user network.

Procedures

1.     Assign IPv6 addresses to VLAN-interface 10 and VLAN-interface 20 on Switch A. (Details not shown.)

2.     Configure a unicast routing protocol so that all devices on the network can interoperate at the network layer. (Details not shown.)

3.     Configure Switch A:

# Enable IPv6 multicast routing.

<SwitchA> system-view

System View: return to User View with Ctrl+Z.

[SwitchA] ipv6 multicast routing

[SwitchA-mrib6] quit

# Create VLAN 30, configure Ten-GigabitEthernet 1/0/1 as a hybrid port, and assign it to VLAN 10 through VLAN 30 as a tagged VLAN member.

[SwitchA] vlan 30

[SwitchA-vlan30] quit

[SwitchA] interface ten-gigabitethernet 1/0/1

[SwitchA-Ten-GigabitEthernet1/0/1] port link-type hybrid

[SwitchA-Ten-GigabitEthernet1/0/1] port hybrid vlan 10 20 30 tagged

# Create VLAN-interface 30, assign it an IPv6 address, and enable MLD on it.

[SwitchA] interface vlan-interface 30

[SwitchA-Vlan-interface30] ipv6 address 2001::1 64

[SwitchA-Vlan-interface30] mld enable

[SwitchA-Vlan-interface30] quit

# Create VLAN 40, and assign Ten-GigabitEthernet 1/0/2 to VLAN 40.

[SwitchA] vlan 40

[SwitchA-vlan40] port ten-gigabitethernet 1/0/2

[SwitchA-vlan40] quit

# Create VLAN-interface 40, assign it an IPv6 address, and enable IPv6 PIM-DM on it.

[SwitchA] interface vlan-interface 40

[SwitchA-Vlan-interface40] ipv6 address 1::1 64

[SwitchA-Vlan-interface40] ipv6 pim dm

[SwitchA-Vlan-interface40] quit

4.     Configure Switch B:

# Enable MLD snooping globally.

<SwitchB> system-view

[SwitchB] mld-snooping

[SwitchB-mld-snooping] quit

# Create VLAN 10, and enable MLD snooping for VLAN 10.

[SwitchB] vlan 10

[SwitchB-vlan10] mld-snooping enable

[SwitchB-vlan10] quit

# Create VLAN 20, and enable MLD snooping for VLAN 20.

[SwitchB] vlan 20

[SwitchB-vlan20] mld-snooping enable

[SwitchB-vlan20] quit

# Create VLAN 30, and enable MLD snooping for VLAN 30.

[SwitchB] vlan 30

[SwitchB-vlan30] mld-snooping enable

[SwitchB-vlan30] quit

# Configure Ten-GigabitEthernet 1/0/1 as a hybrid port, and assign it to VLAN 10 through VLAN 30 as a tagged VLAN member.

[SwitchB] interface ten-gigabitethernet 1/0/1

[SwitchB-Ten-GigabitEthernet1/0/1] port link-type hybrid

[SwitchA-Ten-GigabitEthernet1/0/1] port hybrid vlan 10 20 30 tagged

# Configure VLAN 30 as an IPv6 multicast VLAN, and assign VLAN 10 and VLAN 20 to IPv6 multicast VLAN 30 as sub-VLANs.

[SwitchB] ipv6 multicast-vlan 30

[SwitchB-ipv6-mvlan-30] subvlan 10 20

[SwitchB-ipv6-mvlan-30] quit

Verifying the configuration

# Display information about all IPv6 multicast VLANs on Switch B.

[SwitchB] display ipv6 multicast-vlan

Total 1 IPv6 multicast VLANs.

 

IPv6 multicast VLAN 30:

  Sub-VLAN list(2 in total):

     10,20

  Port list(0 in total):

# Display information about multicast groups in IPv6 multicast VLANs on Switch B.

[SwitchB] display ipv6 multicast-vlan group

Total 1 entries.

 

IPv6 multicast VLAN 30: Total 1 entries.

  (::, FF1E::101)

    Sub-VLANs (2 in total):

      VLAN 10

      VLAN 20

The output shows that IPv6 multicast VLAN (VLAN 30) contains sub-VLANs VLAN 10 and VLAN 20. Switch B will forward IPv6 multicast data for VLAN 30 to VLAN 10 and VLAN 20.

Configuration files

·     Switch A:

#

vlan 10

#

vlan 20

#

vlan 30

#

vlan 40

#

interface Vlan-interface10

 ipv6 address 2002::1/64

#

interface Vlan-interface20

 ipv6 address 2003::1/64

#

interface Vlan-interface30

 ipv6 address 2001::1/64

 mld enable

#

interface Vlan-interface40

 ipv6 address 1::1/64

 ipv6 pim dm

#

interface Ten-GigabitEthernet1/0/1

 port link-mode bridge

port link-type hybrid

 port hybrid vlan 10 20 30 tagged

 port hybrid vlan 1 untagged

#

interface Ten-GigabitEthernet1/0/2

 port link-mode bridge

port access vlan 40

#

ipv6 multicast routing

#

·     Switch B:

#

mld-snooping

#

vlan 10

 mld-snooping enable

#

vlan 20

 mld-snooping enable

#

vlan 30

 mld-snooping enable

#

ipv6 multicast-vlan 30

 subvlan 10 20

#

interface Ten-GigabitEthernet1/0/1

 port link-mode bridge

port link-type hybrid

port hybrid vlan 10 20 30 tagged

port hybrid vlan 1 untagged

#

interface Ten-GigabitEthernet1/0/2

 port link-mode bridge

 port access vlan 10

#

interface Ten-GigabitEthernet1/0/3

 port link-mode bridge

 port access vlan 10

#

interface Ten-GigabitEthernet1/0/4

 port link-mode bridge

 port access vlan 20

#

interface Ten-GigabitEthernet1/0/5

 port link-mode bridge

 port access vlan 20

#

Example: Configuring port-based IPv6 multicast VLANs

Network configuration

As shown in Figure 3:

·     VLAN 10 and VLAN 20 are Department 1 and Department 2, respectively.

·     VLAN-interface 10 and VLAN-interface 20 on Layer 3 device Switch A are the gateways of VLAN 10 and VLAN 20, respectively.

·     MLDv1 runs in VLAN 10 on Switch A, and MLDv1 snooping runs in VLAN 10 on Layer 2 device Switch B.

·     Source sends IPv6 multicast data to IPv6 multicast group FF1E::101.

·     Host A and Host B in VLAN 10 join the group FF1E::101. They can receive the IPv6 multicast data that Source sends to the group.

Figure 3 Network diagram

 

Now, Host C and Host D in VLAN 20 also join the group to receive the IPv6 multicast data, as shown in Figure 4. To meet the requirement, you can enable MLDv1 for VLAN 20 on Switch A and MLDv1 snooping for VLAN 20 on Switch B. However, this method occupies a large amount of bandwidth and increases the burden on Switch A.

To avoid the problems, you can configure a port-based IPv6 multicast VLAN on Switch B.

Figure 4 Network diagram

 

Analysis

To meet the network requirements, you must perform the following tasks:

·     Create VLAN 30 on Switch A and Switch B, and assign Ten-GigabitEthernet 1/0/1 on them to VLAN 10 through VLAN 30 as tagged VLAN members.

·     Create VLAN-interface 30 on Switch A, and enable MLD on the interface.

·     On Switch B, configure the ports that have receiver hosts attached as hybrid ports, and assign the ports to their port VLAN IDs and VLAN 30 as untagged VLAN members.

·     On Switch B, configure VLAN 30 as an IPv6 multicast VLAN, and assign the ports that have receiver hosts attached to IPv6 multicast VLAN 30.

·     Enable MLD snooping for VLAN 10 through VLAN 30 on Switch B.

Restrictions and guidelines

When you configure port-based IPv6 multicast VLANs, follow these restrictions and guidelines:

·     As a best practice, do not configure IPv6 multicast VLANs on a device that is enabled with IPv6 multicast routing.

·     A port can belong to only one IPv6 multicast VLAN.

·     The IPv6 address assigned to the VLAN interface of the IPv6 multicast VLAN must be unique on the user network.

Procedures

1.     Assign IPv6 addresses to VLAN-interface 10 and VLAN-interface 20 on Switch A. (Details not shown.)

2.     Configure a unicast routing protocol so that all devices on the network can interoperate at the network layer. (Details not shown.)

3.     Configure Switch A:

# Enable IPv6 multicast routing.

<SwitchA> system-view

System View: return to User View with Ctrl+Z.

[SwitchA] ipv6 multicast routing

[SwitchA-mrib6] quit

# Create VLAN 30, configure Ten-GigabitEthernet 1/0/1 as a hybrid port, and assign it to VLAN 10 through 30 as a tagged VLAN member.

[SwitchA] vlan 30

[SwitchA-vlan30] quit

[SwitchA] interface ten-gigabitethernet 1/0/1

[SwitchA-Ten-GigabitEthernet1/0/1] port link-type hybrid

[SwitchA-Ten-GigabitEthernet1/0/1] port hybrid vlan 10 20 30 tagged

# Create VLAN-interface 30, assign it an IPv6 address, and enable MLD on it.

[SwitchA] interface vlan-interface 30

[SwitchA-Vlan-interface30] ipv6 address 2001::1 64

[SwitchA-Vlan-interface30] mld enable

[SwitchA-Vlan-interface30] quit

# Create VLAN 40, and assign Ten-GigabitEthernet 1/0/2 to VLAN 40.

[SwitchA] vlan 40

[SwitchA-vlan40] port ten-gigabitethernet 1/0/2

[SwitchA-vlan40] quit

# Create VLAN-interface 40, assign it an IPv6 address, and enable IPv6 PIM-DM on it.

[SwitchA] interface vlan-interface 40

[SwitchA-Vlan-interface40] ipv6 address 1::1 64

[SwitchA-Vlan-interface40] ipv6 pim dm

[SwitchA-Vlan-interface40] quit

4.     Configure Switch B:

# Enable MLD snooping globally.

<SwitchB> system-view

[SwitchB] mld-snooping

[SwitchB-mld-snooping] quit

# Create VLAN 10, and enable MLD snooping for VLAN 10.

[SwitchB] vlan 10

[SwitchB-vlan10] mld-snooping enable

[SwitchB-vlan10] quit

# Create VLAN 20, and enable MLD snooping for VLAN 20.

[SwitchB] vlan 20

[SwitchB-vlan20] mld-snooping enable

[SwitchB-vlan20] quit

# Create VLAN 30, and enable MLD snooping for VLAN 30.

[SwitchB] vlan 30

[SwitchB-vlan30] mld-snooping enable

[SwitchB-vlan30] quit

# Configure Ten-GigabitEthernet 1/0/1 as a hybrid port, and assign it to VLAN 10 through VLAN 30 as a tagged VLAN member.

[SwitchB] interface ten-gigabitethernet 1/0/1

[SwitchB-Ten-GigabitEthernet1/0/1] port link-type hybrid

[SwitchA-Ten-GigabitEthernet1/0/1] port hybrid vlan 10 20 30 tagged

# Configure Ten-GigabitEthernet 1/0/2 as a hybrid port.

[SwitchB] interface ten-gigabitethernet 1/0/2

[SwitchB-Ten-GigabitEthernet1/0/2] port link-type hybrid

# Configure the PVID of Ten-GigabitEthernet 1/0/2 to be VLAN 10, and assign the port to VLAN 10 and VLAN 30 as an untagged VLAN member.

[SwitchB-Ten-GigabitEthernet1/0/2] port hybrid pvid vlan 10

[SwitchB-Ten-GigabitEthernet1/0/2] port hybrid vlan 10 30 untagged

[SwitchB-Ten-GigabitEthernet1/0/2] quit

# Configure Ten-GigabitEthernet 1/0/3 as a hybrid port.

[SwitchB] interface ten-gigabitethernet 1/0/3

[SwitchB-Ten-GigabitEthernet1/0/3] port link-type hybrid

# Configure the PVID of the Ten-GigabitEthernet 1/0/3 to be VLAN 10, and assign the port to VLAN 10 and VLAN 30 as an untagged VLAN member.

[SwitchB-Ten-GigabitEthernet1/0/3] port hybrid pvid vlan 10

[SwitchB-Ten-GigabitEthernet1/0/3] port hybrid vlan 10 30 untagged

[SwitchB-Ten-GigabitEthernet1/0/3] quit

# Configure Ten-GigabitEthernet 1/0/4 as a hybrid port.

[SwitchB] interface ten-gigabitethernet 1/0/4

[SwitchB-Ten-GigabitEthernet1/0/4] port link-type hybrid

# Configure the PVID of Ten-GigabitEthernet 1/0/4 to be VLAN 20, and assign the port to VLAN 20 and VLAN 30 as an untagged VLAN member.

[SwitchB-Ten-GigabitEthernet1/0/4] port hybrid pvid vlan 20

[SwitchB-Ten-GigabitEthernet1/0/4] port hybrid vlan 20 30 untagged

[SwitchB-Ten-GigabitEthernet1/0/4] quit

# Configure Ten-GigabitEthernet 1/0/5 as a hybrid port.

[SwitchB] interface ten-gigabitethernet 1/0/5

[SwitchB-Ten-GigabitEthernet1/0/5] port link-type hybrid

# Configure the PVID of Ten-GigabitEthernet 1/0/5 to be VLAN 20, and assign the port to VLAN 20 and VLAN 30 as an untagged VLAN member

[SwitchB-Ten-GigabitEthernet1/0/5] port hybrid pvid vlan 20

[SwitchB-Ten-GigabitEthernet1/0/5] port hybrid vlan 20 30 untagged

[SwitchB-Ten-GigabitEthernet1/0/5] quit

5.     Configure VLAN 30 as an IPv6 multicast VLAN, and assign Ten-GigabitEthernet 1/0/1 through Ten-GigabitEthernet 1/0/5 to IPv6 multicast VLAN 30.

[SwitchB] ipv6 multicast-vlan 30

[SwitchB-ipv6-mvlan-30] port ten-gigabitethernet 1/0/2 to ten-gigabitethernet 1/0/5

[SwitchB-ipv6-mvlan-30] quit

Verifying the configuration

# Display information about IPv6 multicast VLANs on Switch B.

[SwitchB] display ipv6 multicast-vlan

Total 1 IPv6 multicast VLANs.

 

IPv6 multicast VLAN 30:

  Sub-VLAN list(0 in total):

  Port list(4 in total):

    XGE1/0/2

    XGE1/0/3

    XGE1/0/4

    XGE1/0/5

# Display information about IPv6 multicast groups in IPv6 multicast VLANs.

[SwitchB] display mld-snooping group

Total 1 entries.

 

VLAN 30: Total 1 entries.

  (::, FF1E::101)

    Host slots (0 in total):

    Host ports (4 in total):

      XGE1/0/2         (00:03:23)

      XGE1/0/3         (00:04:07)

      XGE1/0/4         (00:04:16)

      XGE1/0/5         (00:05:10)

The output shows that MLD snooping maintains the user ports in the multicast VLAN (VLAN 30). Switch B will forward the IPv6 multicast data of VLAN 10 through these user ports.

Configuration files

·     Switch A:

#

vlan 10

#

vlan 20

#

vlan 30

#

vlan 40

#

ipv6 multicast-vlan 30

#

interface Vlan-interface10

 ipv6 address 2002::1/64

#

interface Vlan-interface20

 ipv6 address 2003::1/64

#

interface Vlan-interface30

 ipv6 address 2001::1/64

 mld enable

#

interface Vlan-interface40

 ipv6 address 1::1/64

 ipv6 pim dm

#

interface Ten-GigabitEthernet1/0/1

 port link-mode bridge

port link-type hybrid

 port hybrid vlan 10 20 30 tagged

 port hybrid vlan 1 untagged

#

interface Ten-GigabitEthernet1/0/2

 port link-mode bridge

port access vlan 40

#

ipv6 multicast routing

#

·     Switch B:

#

mld-snooping

#

vlan 10

 mld-snooping enable

#

vlan 20

 mld-snooping enable

#

vlan 30

 mld-snooping enable

#

ipv6 multicast-vlan 30

#

interface Ten-GigabitEthernet1/0/1

 port link-mode bridge

port link-type hybrid

port hybrid vlan 10 20 30 tagged

port hybrid vlan 1 untagged

#

interface Ten-GigabitEthernet1/0/2

 port link-mode bridge

 port link-type hybrid

port hybrid vlan 10 30 untagged

port hybrid pvid vlan 10

ipv6 port multicast-vlan 30

#

interface Ten-GigabitEthernet1/0/3

 port link-mode bridge

port link-type hybrid

port hybrid vlan 10 30 untagged

port hybrid pvid vlan 10

ipv6 port multicast-vlan 30

#

interface Ten-GigabitEthernet1/0/4

 port link-mode bridge

port link-type hybrid

port hybrid vlan 20 30 untagged

port hybrid pvid vlan 20

ipv6 port multicast-vlan 30

#

interface Ten-GigabitEthernet1/0/5

 port link-mode bridge

port link-type hybrid

port hybrid vlan 20 30 untagged

port hybrid pvid vlan 20

ipv6 port multicast-vlan 30

#

Related documentation

·     H3C S7500X Switch Series IP Multicast Command Reference-R759X

·     H3C S7500X Switch Series IP Multicast Configuration Guide-R759X