07-MPLS Configuration Examples

HomeSupportResource CenterSwitchesH3C S7500E Switch SeriesH3C S7500E Switch SeriesTechnical DocumentsConfigureConfiguration ExamplesH3C S7500E Switch Series Configuration Examples-R7577P04-6W10007-MPLS Configuration Examples
09-H3C_GRE Tunnel Access to MPLS L3VPN Configuration Examples

H3C GRE tunnel access to MPLS L3VPN Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Software version: Release 7577P04

Document version: 6W100-20190330

 

Copyright © 2019 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

In an MPLS L3VPN, a CE is typically connected to a PE directly. In some networks, a direct connection might not be available between a CE and a PE. In such scenarios, you can configure a GRE tunnel between the CE and the PE to assume the direct connection between them.

Prerequisites

The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

This document assumes that you have basic knowledge of GRE and MPLS L3VPN.

Example: Configuring GRE tunnel access to MPLS L3VPN

Network configuration

As shown in Figure 1, Customer A and Customer B belong to VPN 1. A network VPN 2 exists between CE 1 and PE 1. Configure MPLS L3VPN for Customer A and Customer B to communicate with each other through VPN.

Figure 1 Network diagram

 

Analysis

For packets to be transported over the MPLS network, configure an IGP on the MPLS backbone to ensure IP connectivity, and configure LDP to distribute public network labels (outer labels).

To transport VPN routes and distribute private network labels (inner labels), configure MP-BGP and establish BGP peers between the PEs.

For CE1 to access MPLS L3VPN successfully, establish a GRE tunnel between CE 1 and PE 1 to implement logical direct connection between them.

Restrictions and guidelines

Binding a VPN instance to an interface deletes some configuration (such as the IP address) of the interface. Therefore, bind the VPN instance before configure other settings on an interface.

Procedures

Before configuring GRE and OSPF, configure an IPv4 routing protocol on the gateways so that they can reach one another. (Details not shown.)

Configuring an IGP on the MPLS backbone

This example uses OSPF to implement IP connectivity between the PE and P devices on the MPLS backbone.

1.        Configure PE 1:

# Configure interface IP addresses.

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 1.1.1.9 32

[PE1-LoopBack0] quit

[PE1] vlan 2

[PE1-vlan2] port ten-gigabitethernet 1/0/2

[PE1-vlan2] quit

[PE1] interface vlan-interface 2

[PE1-Vlan-interface2] ip address 10.1.1.1 24

[PE1-Vlan-interface2] quit

# Configure OSPF to advertise backbone network routes.

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

2.        Configure P:

# Configure interface IP addresses.

<P> system-view

[P] interface loopback 0

[P-LoopBack0] ip address 2.2.2.9 32

[P-LoopBack0] quit

[P] vlan 2

[P-vlan2] port ten-gigabitethernet 1/0/2

[P-vlan2] quit

[P] vlan 5

[P-vlan5] port ten-gigabitethernet 1/0/3

[P-vlan5] quit

[P] interface vlan-interface 2

[P-Vlan-interface2] ip address 10.1.1.2 24

[P-Vlan-interface2] quit

[P] interface vlan-interface 5

[P-Vlan-interface5] ip address 10.1.4.1 24

[P-Vlan-interface5] quit

# Configure OSPF to advertise backbone network routes.

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 10.1.4.0 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

3.        Configure PE 2:

# Configure interface IP addresses.

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 3.3.3.9 32

[PE2-LoopBack0] quit

[PE2] vlan 5

[PE2-vlan5] port ten-gigabitethernet 1/0/1

[PE2-vlan5] quit

[PE2] interface vlan-interface 5

[PE2-Vlan-interface5] ip address 10.1.4.2 24

[PE2-Vlan-interface5] quit

# Configure OSPF to advertise backbone network routes.

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 10.1.4.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] network 3.3.3.9 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

4.        Verify that OSPF adjacencies in Full state have been established between PE 1, P, and PE 2.

[PE1] display ospf peer verbose

          OSPF Process 1 with Router ID 1.1.1.9

                  Neighbors

 Area 0.0.0.0 interface 10.1.1.1(Vlan-interface2)'s neighbors

 Router ID: 2.2.2.9          Address: 10.1.1.2        GR State: Normal

   State: Full  Mode: Nbr is Master  Priority: 1

   DR: 10.1.1.2  BDR: 10.1.1.1  MTU: 0

   Options is 0x02 (-|-|-|-|-|-|E|-)

   Dead timer due in 38  sec

   Neighbor is up for 17:30:25

   Authentication Sequence: [ 0 ]

   Neighbor state change count: 6

   BFD status: Disabled

5.        Verify that the PEs have learned the routes to the loopback interfaces of each other.

[PE1] display ip routing-table protocol ospf

Summary Count : 5

OSPF Routing table Status : <Active>

Summary Count : 3

Destination/Mask    Proto  Pre  Cost         NextHop         Interface

2.2.2.9/32          OSPF   10   1            10.1.1.2        Vlan2

3.3.3.9/32          OSPF   10   2            10.1.1.2        Vlan2

10.1.4.0/24         OSPF   10   2            10.1.1.2        Vlan2

OSPF Routing table Status : <Inactive>

Summary Count : 2

Destination/Mask    Proto  Pre  Cost         NextHop         Interface

1.1.1.9/32          OSPF   10   0            1.1.1.9         Loop0

10.1.1.0/24         OSPF   10   1            10.1.1.1        Vlan2

Configuring basic MPLS and MPLS LDP on the MPLS backbone to establish LDP LSPs

1.        Configure PE 1.

[PE1] mpls lsr-id 1.1.1.9

[PE1] mpls ldp

[PE1-ldp] quit

[PE1] interface vlan-interface 2

[PE1-Vlan-interface2] mpls enable

[PE1-Vlan-interface2] mpls ldp enable

[PE1-Vlan-interface2] quit

2.        Configure P.

[P] mpls lsr-id 2.2.2.9

[P] mpls ldp

[P-ldp] quit

[P] interface vlan-interface 2

[P-Vlan-interface2] mpls enable

[P-Vlan-interface2] mpls ldp enable

[P-Vlan-interface2] quit

[P] interface vlan-interface 5

[P-Vlan-interface5] mpls enable

[P-Vlan-interface5] mpls ldp enable

[P-Vlan-interface5] quit

3.        Configure PE 2.

[PE2] mpls lsr-id 3.3.3.9

[PE2] mpls ldp

[PE2-ldp] quit

[PE2] interface vlan-interface 5

[PE2-Vlan-interface5] mpls enable

[PE2-Vlan-interface5] mpls ldp enable

[PE2-Vlan-interface5] quit

4.        Verify that LDP sessions in Operational state have been established between PE 1, P, and PE 2.

 [PE1] display mpls ldp peer

Total number of peers: 1

Peer LDP ID             State         Role     GR   MD5  KA Sent/Rcvd

2.2.2.9:0               Operational   Passive  Off  Off  5/5

5.        Verify that the LSPs have been established by LDP.

[PE1] display mpls ldp lsp

Status Flags: * - stale, L - liberal, B - backup

FECs: 4            Ingress: 1          Transit: 1      Egress: 3

 

FEC                In/Out Label        Nexthop         OutInterface

1.1.1.9/32         3/-

                   -/1151(L)

2.2.2.9/32         -/3                 10.1.1.2        Vlan2

                   1151/3              10.1.1.2        Vlan2

3.3.3.9/32         -/1150              10.1.1.2        Vlan2

                   1150/1150           10.1.1.2        Vlan2

Configuring CE 1 access to PE 1

Configuring VPN instances

1.        Configure PE 1:

# Create a VPN instance named VPN1.

[PE1] ip vpn-instance vpn1

# Configure an RD for the VPN instance.

[PE1-vpn-instance-vpn1] route-distinguisher 100:1

# Configure route targets for the VPN instance.

[PE1-vpn-instance-vpn1] vpn-target 100:1 import-extcommunity

[PE1-vpn-instance-vpn1] vpn-target 100:1 export-extcommunity

[PE1-vpn-instance-vpn1] quit

# Bind the VPN instance to VLAN-interface 100.

[PE1] vlan 100

[PE1-vlan100] port ten-gigabitethernet 1/0/1

[PE1-vlan100] quit

[PE1] interface vlan-interface 100

[PE1-Vlan-interface100] ip binding vpn-instance vpn1

[PE1-Vlan-interface100] ip address 200.1.1.2 24

[PE1-Vlan-interface100] quit

2.        Configure CE 1:

# Create a VPN instance named VPN1.

[CE1] ip vpn-instance vpn1

# Configure an RD for the VPN instance.

[CE1-vpn-instance-vpn1] route-distinguisher 100:1

# Configure route targets for the VPN instance.

[CE1-vpn-instance-vpn1] vpn-target 100:1 import-extcommunity

[CE1-vpn-instance-vpn1] vpn-target 100:1 export-extcommunity

[CE1-vpn-instance-vpn1] quit

# Bind the VPN instance to VLAN-interface 101.

[CE1] vlan 101

[CE1-vlan101] port ten-gigabitethernet 1/0/1

[CE1-vlan101] quit

[CE1] interface vlan-interface 101

[CE1-Vlan-interface101] ip binding vpn-instance vpn1

[CE1-Vlan-interface101] ip address 100.1.1.1 24

[CE1-Vlan-interface101] quit

Configuring a GRE tunnel between CE 1 and PE 1

1.        Configure CE 1:

# Create service loopback group 1 and configure the service type as tunnel.

[CE1] service-loopback group 1 type tunnel

# Add interface Ten-GigabitEthernet 1/0/3 to service loopback group 1.

[CE1] interface ten-gigabitethernet 1/0/3

[CE1-Ten-gigabitethernet1/0/3] port service-loopback group 1

[CE1-Ten-gigabitethernet1/0/3] quit

# Create tunnel interface Tunnel 1, and configure the tunnel mode as GRE/IPv4.

[CE1] interface tunnel 1 mode gre

# Specify a VPN instance for the tunnel source address.

[CE1-Tunnel1] ip binding vpn-instance vpn1

# Configure an IP address for the tunnel interface.

[CE1-Tunnel1] ip address 20.1.1.1 255.255.255.0

# Configure the tunnel source address as the IP address of VLAN-interface 101 on CE 1.

[CE1-Tunnel1] source vlan-interface 101

# Configure the tunnel destination address as the IP address of VLAN-interface 100 on PE 1.

[CE1-Tunnel1] destination 200.1.1.2

# Specify a VPN instance for the tunnel destination address.

[CE1-Tunnel1] tunnel vpn-instance vpn1

[CE1-Tunnel1] quit

# Configure a static route to Customer B through interface Tunnel 1.

[CE1] ip route-static vpn-instance vpn1 172.2.0.0 24 tunnel 1

2.        Configure PE 1:

# Create service loopback group 1 and configure the service type as tunnel.

[PE1] service-loopback group 1 type tunnel

# Add interface Ten-GigabitEthernet 1/0/3 to service loopback group 1.

[PE1] interface ten-gigabitethernet 1/0/3

[PE1-Ten-gigabitethernet1/0/3] port service-loopback group 1

[PE1-Ten-gigabitethernet1/0/3] quit

# Create tunnel interface Tunnel 1, and configure the tunnel mode as GRE/IPv4.

[PE1] interface tunnel 1 mode gre

# Specify a VPN instance for the tunnel source address.

[PE1-Tunnel1] ip binding vpn-instance vpn1

# Configure an IP address for the tunnel interface.

[PE1-Tunnel1] ip address 20.1.1.2 255.255.255.0

# Configure the tunnel source address as the IP address of VLAN-interface 100 on PE 1.

[PE1-Tunnel1] source vlan-interface 100

# Configure the tunnel destination address as the IP address of VLAN-interface 101 on CE 1.

[PE1-Tunnel1] destination 100.1.1.1

# Specify a VPN instance for the tunnel destination address.

[PE1-Tunnel1] tunnel vpn-instance vpn1

[PE1-Tunnel1] quit

# Configure a static route to Customer A through interface Tunnel 1.

[PE1] ip route-static vpn-instance vpn1 172.1.0.0 24 Tunnel 1

Configuring CE 2 access to PE 2

1.        Configure PE 2:

# Create a VPN instance named VPN1.

[PE2] ip vpn-instance vpn1

# Configure an RD for the VPN instance.

[PE2-vpn-instance-vpn1] route-distinguisher 100:1

# Configure route targets for the VPN instance. Make sure the import and export targets are the same as the export and import targets configured on PE 1.

[PE2-vpn-instance-vpn1] vpn-target 100:1 import-extcommunity

[PE2-vpn-instance-vpn1] vpn-target 100:1 export-extcommunity

[PE2-vpn-instance-vpn1] quit

# Bind the VPN instance to VLAN-interface 101.

[PE2] vlan 101

[PE2-vlan101] port ten-gigabitethernet 1/0/2

[PE2-vlan101] quit

[PE2] interface vlan-interface 101

[PE2-Vlan-interface101] ip binding vpn-instance vpn1

[PE2-Vlan-interface101] ip address 101.1.1.1 24

[PE2-Vlan-interface101] quit

2.        Configure CE 2:

Configure IP addresses for the CE according to Figure 1. (Details not shown.)

3.        Verify the VPN instance configuration on PE 2.

[PE2] display ip vpn-instance

  Total VPN-Instances configured : 1

  VPN-Instance Name               RD                     Create time

  vpn1                            100:1                  2016/06/22 13:20:08

4.        Verify that PE 2 can ping CE 2.

[PE2] ping -vpn-instance vpn1 101.1.1.2

Ping 10.1.4.2 (101.1.1.2): 56 data bytes, press CTRL_C to break

56 bytes from 101.1.1.2: icmp_seq=0 ttl=255 time=1.000 ms

56 bytes from 101.1.1.2: icmp_seq=1 ttl=255 time=2.000 ms

56 bytes from 101.1.1.2: icmp_seq=2 ttl=255 time=0.000 ms

56 bytes from 101.1.1.2: icmp_seq=3 ttl=255 time=1.000 ms

56 bytes from 101.1.1.2: icmp_seq=4 ttl=255 time=0.000 ms

 

--- Ping statistics for 10.1.1.1 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 0.000/0.800/2.000/0.748 ms

Establishing EBGP peer relationships between PEs and CEs, and redistributing VPN routes into BGP

1.        Configure PE 1:

# Create BGP process 100.

[PE1] bgp 100

# Specify CE 1 as a BGP peer, and redistribute the direct routes of PE 1 to the routing table of the BGP VPN instance.

[PE1-bgp-default] ip vpn-instance vpn1

[PE1-bgp-default-vpn1] peer 20.1.1.1 as-number 65410

[PE1-bgp-default-vpn1] address-family ipv4 unicast

[PE1-bgp-default-ipv4-vpn1] peer 20.1.1.1 enable

[PE1-bgp-default-ipv4-vpn1] import-route direct

[PE1-bgp-default-ipv4-vpn1] quit

[PE1-bgp-default-vpn1] quit

2.        Configure PE 2:

# Create BGP process 100.

[PE2] bgp 100

# Specify CE 2 as a BGP peer, and redistribute the direct routes of PE 2 to the routing table of the BGP VPN instance.

[PE2-bgp-default] ip vpn-instance vpn1

[PE2-bgp-default-vpn1] peer 101.1.1.2 as-number 65410

[PE2-bgp-default-vpn1] address-family ipv4 unicast

[PE2-bgp-default-ipv4-vpn1] peer 101.1.1.2 enable

[PE2-bgp-default-ipv4-vpn1] import-route direct

[PE2-bgp-default-ipv4-vpn1] quit

[PE2-bgp-default-vpn1] quit

3.        Configure CE 1:

# Create BGP process 65410 on CE 1, and specify PE 1 as a BGP peer and set the AS number to 100.

<CE1> system-view

[CE1] bgp 65410

[CE1-bgp-default] peer 20.1.1.2 as-number 100

# Enable IPv4 unicast route exchange with peer PE 1.

[CE1-bgp-default] address-family ipv4 unicast

[CE1-bgp-default-ipv4] peer 20.1.1.2 enable

# Redistribute the direct routes of CE 1 into EBGP.

[CE1-bgp-default-ipv4] import-route direct

[CE1-bgp-default-ipv4] quit

[CE1-bgp-default] quit

4.        Configure CE 2:

# Create BGP process 65410 on CE 2, and specify PE 2 as a BGP peer and set the AS number to 100.

<CE2> system-view

[CE2] bgp 65410

[CE2-bgp-default] peer 101.1.1.1 as-number 100

# Enable IPv4 unicast route exchange with peer PE 2.

[CE2-bgp-default] address-family ipv4 unicast

[CE2-bgp-default-ipv4] peer 101.1.1.1 enable

# Redistribute the direct routes of CE 2 into EBGP.

[CE2-bgp-default-ipv4] import-route direct

[CE2-bgp-default-ipv4] quit

[CE2-bgp-default] quit

5.        Verify that a BGP peer relationship in Established state has been established between a PE and a CE.

This example uses PE 2 and CE 2.

[PE2] display bgp peer ipv4 vpn-instance vpn1

 BGP local router ID: 3.3.3.9

 Local AS number: 100

 Total number of peers: 1                  Peers in established state: 1

  Peer             AS        MsgRcvd  MsgSent OutQ PrefRcv Up/Down    State

  101.1.1.2        65430     4        4       0    2       13:35:25   Established

Creating an MP-IBGP peer relationship between PEs

1.        Configure PE 1:

# Configure PE 2 as a BGP peer, and specify interface Loopback 0 as the source interface for TCP connections to the peer.

[PE1] bgp 100

[PE1-bgp-default] peer 3.3.3.9 as-number 100

[PE1-bgp-default] peer 3.3.3.9 connect-interface loopback 0

# Enable BGP VPNv4 route exchange with peer PE 2.

[PE1-bgp-default] address-family vpnv4

[PE1-bgp-default-vpnv4] peer 3.3.3.9 enable

[PE1-bgp-default-vpnv4] quit

[PE1-bgp-default] quit

2.        Configure PE 2:

# Configure PE 1 as a BGP peer, and specify interface Loopback 0 as the source interface for TCP connections to the peer.

[PE2] bgp 100

[PE2-bgp-default] peer 1.1.1.9 as-number 100

[PE2-bgp-default] peer 1.1.1.9 connect-interface loopback 0

# Enable BGP VPNv4 route exchange with peer PE 1.

[PE2-bgp-default] address-family vpnv4

[PE2-bgp-default-vpnv4] peer 1.1.1.9 enable

[PE2-bgp-default-vpnv4] quit

[PE2-bgp-default] quit

3.        Verify that a BGP peer relationship in Established state has been established between the PEs.

[PE1] display bgp peer vpnv4

BGP local router ID: 1.1.1.9

 Local AS number: 100

 Total number of peers: 1                  Peers in established state: 1

  Peer                    AS  MsgRcvd  MsgSent OutQ PrefRcv Up/Down  State

  3.3.3.9                100        8        8    0       0 00:00:08 Established

Verifying the configuration

# Display the VPN routing table of a PE and verify that the PE has a route to the peer CE. (This example uses PE 1.)

[PE1] display ip routing-table vpn-instance vpn1

Destinations : 13        Routes : 13

Destination/Mask    Proto  Pre  Cost         NextHop         Interface

0.0.0.0/32          Direct 0    0            127.0.0.1       InLoop0

20.1.1.0/24         Direct  0   0            20.1.1.2        Tun0

20.1.1.0/32         Direct  0   0            20.1.1.2        Tun0

20.1.1.2/32         Direct  0   0            127.0.0.1       InLoop0

200.1.1.0/24        Direct 0    0            200.1.1.2       Vlan100

200.1.1.0/32        Direct 0    0            200.1.1.2       Vlan100

200.1.1.2/32        Direct 0    0            127.0.0.1       InLoop0

200.1.1.255/32      Direct 0    0            100.1.1.2       Vlan100

101.1.1.0/24        BGP    255  0            3.3.3.9         Vlan2

127.0.0.0/8         Direct 0    0            127.0.0.1       InLoop0

127.0.0.0/32        Direct 0    0            127.0.0.1       InLoop0

127.0.0.1/32        Direct 0    0            127.0.0.1       InLoop0

127.255.255.255/32  Direct 0    0            127.0.0.1       InLoop0

224.0.0.0/4         Direct 0    0            0.0.0.0         NULL0

224.0.0.0/24        Direct 0    0            0.0.0.0         NULL0

255.255.255.255/32  Direct 0    0            127.0.0.1       InLoop0

Configuration files

·          On PE 1:

#

ip vpn-instance vpn1

 route-distinguisher 100:1

 vpn-target 100:1 import-extcommunity

 vpn-target 100:1 export-extcommunity

#

 service-loopback group 1 type tunnel

#

ospf 1

 area 0.0.0.0

  network 1.1.1.9 0.0.0.0

  network 10.1.1.0 0.0.0.255

#

 mpls lsr-id 1.1.1.9

#

vlan 2

#

vlan 100

#

mpls ldp

#

interface LoopBack0

 ip address 1.1.1.9 255.255.255.255

#

interface Vlan-interface2

 ip address 10.1.1.1 255.255.255.0

 mpls enable

 mpls ldp enable

#

interface Vlan-interface100

 ip binding vpn-instance vpn1

 ip address 200.1.1.2 255.255.255.0

#

interface Ten-GigabitEthernet1/0/1

 port link-mode bridge

 port access vlan 100

#

interface Ten-GigabitEthernet1/0/2

 port link-mode bridge

 port access vlan 2

#

#

interface Ten-GigabitEthernet1/0/3

 port link-mode bridge

 port service-loopback group 1

#

interface Tunnel1 mode gre

 ip binding vpn-instance vpn1

 ip address 20.1.1.2 255.255.255.0

 source Vlan-interface100

 tunnel vpn-instance vpn1

 destination 100.1.1.1

#

bgp 100

 peer 3.3.3.9 as-number 100

 peer 3.3.3.9 connect-interface LoopBack0

 #

 address-family vpnv4

  peer 3.3.3.9 enable

 #

 ip vpn-instance vpn1

  peer 20.1.1.1 as-number 65410

  #

  address-family ipv4 unicast

   import-route direct

   peer 20.1.1.1 enable

#

 ip route-static vpn-instance vpn1 172.1.0.0 24 Tunnel1

·          On P:

#

ospf 1

 area 0.0.0.0

  network 2.2.2.9 0.0.0.0

  network 10.1.1.0 0.0.0.255

  network 10.1.4.0 0.0.0.255

#

 mpls lsr-id 2.2.2.9

#

vlan 2

#

vlan 5

#

mpls ldp

#

interface LoopBack0

 ip address 2.2.2.9 255.255.255.255

#

interface Vlan-interface2

 ip address 10.1.1.2 255.255.255.0

 mpls enable

 mpls ldp enable

#

interface Vlan-interface5

 ip address 10.1.4.1 255.255.255.0

 mpls enable

 mpls ldp enable

#

interface Ten-GigabitEthernet1/0/2

 port link-mode bridge

 port access vlan 2

#

interface Ten-GigabitEthernet1/0/3

 port link-mode bridge

 port access vlan 5

#

·          On PE 2:

#

ip vpn-instance vpn1

 route-distinguisher 100:1

 vpn-target 100:1 import-extcommunity

 vpn-target 100:1 export-extcommunity

#

ospf 1

 area 0.0.0.0

  network 3.3.3.9 0.0.0.0

  network 10.1.4.0 0.0.0.255

#

 mpls lsr-id 3.3.3.9

#

 lldp global enable

#

vlan 5

#

vlan 101

#

mpls ldp

#

interface LoopBack0

 ip address 3.3.3.9 255.255.255.255

#

interface Vlan-interface5

 ip address 10.1.4.2 255.255.255.0

 mpls enable

 mpls ldp enable

#

interface Vlan-interface101

 ip binding vpn-instance vpn1

 ip address 101.1.1.1 255.255.255.0

#

interface Ten-GigabitEthernet1/0/1

 port link-mode bridge

 port access vlan 5

#

interface Ten-GigabitEthernet1/0/2

 port link-mode bridge

 port access vlan 101

#

bgp 100

 peer 1.1.1.9 as-number 100

 peer 1.1.1.9 connect-interface LoopBack0

 #

 address-family vpnv4

  peer 1.1.1.9 enable

 #

 ip vpn-instance vpn1

  peer 101.1.1.2 as-number 65410

  #

  address-family ipv4 unicast

   import-route direct

   peer 101.1.1.2 enable

#

·          On CE 1:

#

ip vpn-instance vpn1

 route-distinguisher 100:1

 vpn-target 100:1 import-extcommunity

 vpn-target 100:1 export-extcommunity

#

 service-loopback group 1 type tunnel

#

vlan 101

#

interface Vlan-interface101

 ip binding vpn-instance vpn1

 ip address 100.1.1.1 255.255.255.0

#

interface Ten-GigabitEthernet1/0/1

 port link-mode bridge

 port access vlan 101

#

interface Ten-GigabitEthernet1/0/3

 port link-mode bridge

 port service-loopback group 1

#

interface Tunnel1 mode gre

 ip binding vpn-instance vpn1

 ip address 20.1.1.1 255.255.255.0

 source Vlan-interface101

 tunnel vpn-instance vpn1

 destination 200.1.1.2

#

bgp 65410

 peer 20.1.1.2 as-number 100

 #

 address-family ipv4 unicast

  import-route direct

  peer 20.1.1.2 enable

#

 ip route-static vpn-instance vpn1 172.2.0.0 24 Tunnel1

#

·          On CE 2:

#

vlan 101

#

interface Vlan-interface101

 ip address 101.1.1.2 255.255.255.0

#

interface Ten-GigabitEthernet1/0/1

 port link-mode bridge

 port access vlan 101

#

bgp 65410

 peer 101.1.1.1 as-number 100

 #

 address-family ipv4 unicast

  import-route direct

  peer 101.1.1.1 enable

#

Related documentation

·          H3C S7500E Switch Series MPLS Command Reference-R757X

·          H3C S7500E Switch Series MPLS Configuration Guide-R757X