07-MPLS Configuration Guide

HomeSupportResource CenterH3C S6800[S6860][S6861] (R27xx) & S6820 (R630x) Switch Series Configuration Guide-6W10107-MPLS Configuration Guide
01-MPLS SR configuration
Title Size Download
01-MPLS SR configuration 357.80 KB

Contents

Configuring MPLS SR·· 1

About MPLS SR· 1

MPLS SR characteristics· 1

Basic concepts· 1

How MPLS SR works· 1

Static segment configuration· 2

Dynamic SID allocation· 2

Label forwarding entry installation based on SIDs· 2

SRLSP setup· 3

Packet forwarding in MPLS SR· 4

MPLS SR and LDP interworking· 6

Protocols and standards· 7

Restrictions and guidelines: MPLS SR configuration· 7

MPLS SR tasks at a glance· 7

IP traffic forwarding over SRLSPs tasks at a glance· 7

MPLS TE traffic forwarding over static SRLSPs tasks at a glance· 8

Configuring static segments· 8

Prerequisites for static segment configuration· 8

Configuring a static adjacency segment 8

Configuring a static prefix segment 9

Configuring IGP-based SID advertisement 9

IGP-based SID advertisement tasks at a glance· 9

Prerequisites for configuring IGP-based SID advertisement 9

Configuring the IGP to support MPLS SR· 10

Configuring prefix SIDs· 10

Enabling MPLS SR adjacency label allocation for the IGP· 11

Configuring the MPLS SRGB· 11

Configuring the device to prefer SRLSPs in traffic forwarding· 11

Configuring an MPLS TE tunnel to use static SRLSPs· 12

Tasks at a glance· 12

Configuring a static SRLSP· 12

Binding a static SRLSP to an MPLS TE tunnel interface· 12

Display and maintenance commands for MPLS SR· 13

MPLS SR configuration examples· 13

Example: Configuring MPLS SR based on static segments· 13

Example: Configuring MPLS SR based on ISIS-advertised SIDs· 19

Example: Configuring MPLS SR and LDP interworking· 26

 


Configuring MPLS SR

About MPLS SR

Segment Routing (SR) is a source routing technology. The source node selects a path for the packets, and then encodes the path in the packet header as an ordered list of segments. Each segment is identified by the segment identifier (SID). The SR nodes along the path forward the packets based on the SIDs in the packets. Only the source node needs to maintain the path status.

SR can operate with MPLS. In an MPLS network, SR uses MPLS labels as SIDs to forward packets on an LSP.

MPLS SR characteristics

MPLS SR has the following characteristics:

·     MPLS SR forwards packets based on the existing MPLS infrastructure. No infrastructure modifications are needed to implement SR on an MPLS network. For more information about the MPLS infrastructure, see MPLS basics configuration in MPLS Configuration Guide.

·     MPLS SR expands and optimizes existing IGPs and uses the IGPs to distribute labels.

·     MPLS SR implements network features such as MPLS TE in a simpler way, eliminating issues such as heavy and complicated routing protocol deployment.

Basic concepts

·     SR node—A node enabled with the MPLS SR feature. The ingress node (source node) adds labels to packets. The transit nodes forward packets based on labels. The egress node removes labels and forwards packets to the destination networks. SR nodes form an SR domain.

·     Segment—An instruction an SR node executes on the incoming packet.

·     SID—Segment ID, which is MPLS label in MPLS SR.

·     Segment type—The following types of segments are available:

¡     Prefix segment—SIDs are assigned to nodes based on destination address prefix. The nodes create prefix-specific forwarding entries.

¡     Adjacency segment—SIDs are assigned to nodes based on adjacency.

·     SRLSP—Segment routing label switched path, an LSP along which SR uses MPLS labels as SIDs to forward packets.

·     SRGB—Segment routing global block, a range of global labels dedicated for MPLS SR prefix SIDs. Different nodes can have different SRGBs. The minimum label value of an SRGB label range is referred to as the base value of the SRGB. Labels 16000 through 24000 are reserved for SRGBs.

How MPLS SR works

MPLS SR involves the following steps:

1.     Label allocation for all nodes and links along the packet forwarding paths.

The following methods are available:

¡     Static segment configuration

¡     Dynamic SID allocation

2.     Label forwarding entry installation based on SIDs. All MPLS SR devices in the SR domain use the allocated labels to create label forwarding entries.

3.     SRLSP setup. You can manually configure SRLSPs, or use an IGP or a controller to dynamically create SRLSPs.

When the ingress node of an SRLSP receives a packet, it adds labels to the packet and forwards the packet to the egress node through the SRLSP. After receiving a packet from the SRLSP, the egress node removes the label and forwards the packet based on the routing table.

You can bind a higher layer application (for example, MPLS TE) to an SRLSP to forward traffic of the application through the SRLSP.

Static segment configuration

Static MPLS SR provides the following methods for configuring static segments for a destination:

·     Prefix segment method—Manually configure the incoming label, outgoing label, and next hop for the destination address prefix on each SR node.

·     Adjacency segment method—Manually configure the incoming label and next hop for the adjacency to the neighbor on each SR node.

Dynamic SID allocation

MPLS SR expands IGP protocols such as IS-IS to advertise SIDs in IGP protocol packets. MPLS SR provides the following methods for dynamically allocating and advertising SIDs:

·     Prefix SID—After you configure an SID for the loopback address on each SR node, the SIDs uniquely identify the SR nodes. All SR nodes in the SR domain use an IGP to advertise their own prefix SIDs. After receiving advertised prefix SIDs, each SR node calculates the prefix SIDs to the advertisers.

The prefix SID advertisement can be one of the following types:

¡     Absolute value advertisement—Each SR node advertises the prefix SID absolute value and the SRGB.

¡     Index value advertisement—Each SR node advertises the prefix SID index and the SRGB.

Each SR node is assigned a globally unique index value for the node's prefix. The prefix SID an SR node allocates for a prefix equals the SRBG base of the SR node plus the index for that prefix.

 

 

NOTE:

The device supports only the index value advertisement in the current software release.

 

·     Adjacency SID—Each SR node with adjacency SID allocation enabled allocates SIDs for the IGP adjacencies (that is, the links to its IGP neighbors), and uses the SIDs to identify the links.

Label forwarding entry installation based on SIDs

Label forwarding entry installation based on prefix SIDs

Label forwarding entries based on prefix SIDs can be static or dynamic.

·     Static label forwarding entries—The device creates local label forwarding entries based on manually configured incoming labels, outgoing labels, and next hops.

·     Dynamic label forwarding entries—The device uses the IGP to flood in the SR domain the local SRGB and the index of the prefix SID for the local loopback interface. Based on the flooded information, the other devices in the domain calculates their local label forwarding entries by using the following rules:

¡     Incoming label = Local SRGB base value + Index

¡     Outgoing label = SRGB base value of the next hop + Index

Figure 1 Creating label forwarding entries based on prefix SIDs

 

Figure 1 shows how dynamic label forwarding entries are created. After you assign index value 201 to loopback address 1.1.1.1/32 on Device C, Device C uses an IGP packet to advertise the index value and its local SRGB. Then, the devices calculate incoming and outgoing labels according to the previously mentioned label calculation rules.

·     Devices C calculates its incoming label, which is 18201.

·     Device B calculates its incoming label and outgoing label and creates a label forwarding entry. The incoming label is 17201. The outgoing label is 18201. The next hop is Device C.

·     Device A calculates its incoming label and outgoing label and creates a label forwarding entry. The incoming label is 16201. The outgoing label is 17201. The next hop is Device B.

Label forwarding entry installation based on adjacency SIDs

When using adjacency SIDs, each device allocates a static or dynamic incoming label to the link to its neighbor. The label has local significance. Multiple devices can use the same adjacency SID.

Figure 2 Creating label forwarding entries based on adjacency SIDs

 

As shown in Figure 2, the devices are running the same IGP. After IGP adjacencies are established between the devices, Device A, Device B, and Device C allocates labels and creates label forwarding entries as follows:

·     Device A allocates label 203 to the link to its neighbor Device B.

·     Device B allocates label 202 to the link to its neighbor Device C.

·     Device C allocates label 201 to the link to its neighbor Device D.

·     Device A creates a label forwarding entry with incoming label 203 and next hop Device B.

·     Device B creates a label forwarding entry with incoming label 202 and next hop Device C.

·     Device C creates a label forwarding entry with incoming label 201 and next hop Device D.

SRLSP setup

You can use the following methods to create SRLSPs:

·     Manually configure an SRLSP.

To configure an SRLSP, you must specify the label stack for packets to be forwarded along the SRLSP on the ingress node. Each label in the stack corresponds to a prefix SID or adjacency SID. The system can look for the outgoing label and next hop based on the prefix SID or adjacency SID.

·     Configure SR nodes to use an IGP to dynamically establish an SRLSP.

SR nodes follow these steps to establish SRLSPs:

a.     Use an IGP to collect prefix SID information from the MPLS SR network.

b.     Calculate the shortest paths to other SR nodes based on the collected prefix SID information and the IGP network topology.

c.     Establish SRLSPs based on the shortest paths.

·     Configure a controller to deploy SRLSP configuration to the device so the device creates SRLSPs.

For more information about controller configuration, see the user guide for the controller.

Packet forwarding in MPLS SR

Based on the SID allocation method, MPLS SR uses one of the following packet forwarding methods:

·     Prefix SID-based packet forwarding—The ingress node encapsulates the prefix SID for the egress node to a packet. The transit nodes forward the packet based on label forwarding entries.

·     Adjacency SID-based packet forwarding—The ingress node encapsulates the label stack that contains the adjacency SIDs of all links along the forwarding path to a packet. Each transit node uses the top label in the label stack to determine the next hop and pops the top label before forwarding the packet to the next hop.

·     Prefix and adjacency SID-based packet forwarding—The nodes use prefix SID-based packet forwarding in combination with adjacency-based packet forwarding.

Prefix SID-based packet forwarding

Figure 3 shows how a packet is forwarded along the SRLSP from Device A to Device E based on prefix SIDs. In this example, the outgoing label for the packet is 21201 on Device A.

1.     Ingress node Device A searches for a forwarding entry for label 21201, adds outgoing label 20201 to the packet and sends the packet to the next hop (Device B).

2.     When transit node Device B receives the packet, it searches for a label forwarding entry that matches the label in the packet. Then, Device B uses the outgoing label of the matched entry (19201) to replace the label in the packet and forwards the packet to the next hop (Device C).

3.     Transit nodes Device C and Device D process the packet in the same way Device B does.

4.     When egress node Device E receives the packet, it removes the label and forwards the packet by IP address.

Figure 3 Prefix SID-based packet forwarding

 

Adjacency SID-based packet forwarding

Figure 4 shows how a packet is forwarded along the SRLSP from Device A to Device E based on adjacency SIDs. In this example, the label stack for the packet is configured as (200, 201, 202, and 203) on Device A.

1.     Ingress node Device A searches for a forwarding entry for the top label (200) to determine the next hop. Then, Device A adds label stack (201, 202, and 203) to the packet, and forwards the packet to the next hop (Device B).

2.     When transit node Device B receives the packet, it searches for a forwarding entry for the top label (201) to determine the next hop. Then, Device B removes the top label from the stack and forwards the packet to the next hop (Device C).

3.     When transit node Device C receives the packet, it searches for a forwarding entry for the top label (202) to determine the next hop. Then, Device C removes the top label from the stack and forwards the packet to the next hop (Device D).

4.     When transit node Device D receives the packet, it searches for a forwarding entry for the label (203) to determine the next hop. Then, Device D removes the label stack from the packet and forwards the packet to the next hop (Device E).

5.     When egress node Device E receives the packet, it forwards the packet by IP address.

Figure 4 Adjacency SID-based packet forwarding

 

Prefix and adjacency SID-based packet forwarding

Figure 5 shows how a packet is forwarded along the SRLSP from Device A to Device E based on prefix SIDs and adjacency SIDs. In this example, the index value for the prefix SID of Device C is 1. The prefix SIDs for Device A, Device B, and Device C are 18001, 17001, and 16001, respectively. The Adjacency SIDs that Device C and Device D allocate for the adjacent links are 16 and 17, respectively. On Device A, the label stack for the packet is (18001, 16, 17).

1.     Ingress node Device A searches for a forwarding entry for label 18001 to determine the outgoing label (17001) and next hop (Device B). Device A swaps label 18001 with 17001. Then, it adds label stack (17001, 16, 17) to the packet and sends the packet to the next hop (Device B).

2.     When transit node Device B receives the packet, it searches for a label forwarding entry that matches the top label in the label stack (17001). Then, Device B uses the outgoing label of the matched entry (16001) to replace the top label and forwards the packet to the next hop (Device C).

3.     When transit node Device C receives the packet, it removes the top label 16001 and searches for a forwarding entry for the next label (16) to determine the next hop. Then, Device C removes label 16 from the stack and forwards the packet to the next hop (Device D).

4.     When transit node Device D receives the packet, it searches for a forwarding entry for the label (17) to determine the next hop. Then, Device D removes the label stack from the packet and forwards the packet to the next hop (Device E).

5.     When egress node Device E receives the packet, it forwards the packet by IP address.

Figure 5 Prefix and adjacency SID-based packet forwarding

 

MPLS SR and LDP interworking

IMPORTANT

IMPORTANT:

For an MPLS SR network to communicate with an LDP network, make sure SRLSPs use prefix SIDs.

 

For an MPLS SR network and an LDP network to communicate, the SR/LDP border devices must be able to connect the SR LSP and the LDP LSP as follows:

·     MPLS SR to LDP interwoking—The border device installs SR-to-LDP label forwarding entries. For a packet from the MPLS SR network to the LDP network, the MPLS SR label forwarding entry on the border device does not have an outgoing label. The border device uses the outgoing label of the LDP label forwarding entry for the same destination address as the outgoing label of the packet.

·     LDP to MPLS SR interwoking—The border device installs LDP-to-SR label forwarding entries. For a packet from the LDP network to the MPLS SR network, the LDP forwarding entry on the border device does not have an outgoing label. The border device must use the outgoing label of the MPLS SR forwarding entry for the same destination address as the outgoing label of the packet.

Figure 6 MPLS SR and LDP interworking

 

As shown in Figure 6, Device A, Device B, Device D, and Device E are running MPLS SR. After you assign index value 201 to loopback interface address 3.3.3.3/32 on Device E, Device E will advertise the index value and the local SRGB. After Device A, Device B, and Device D receive the message, they will install their respective MPLS SR label forwarding entries. Device B, Device C, and Device D are running LDP. They allocate labels to destination address 3.3.3.3/32 to generate the LDP label forwarding entries.

A packet that Device A sends to Device E will be forwarded as follows:

1.     Ingress node Device A encapsulates label 18201 to the packet and forwards the packet to transit node Device B.

2.     Transit node Device B searches for an MPLS SR label forwarding entry for incoming label 18201 and finds that the entry does not have an outgoing label. Because an LDP label forwarding entry with outgoing label 20 exists for the destination address (3.3.3.3/32), Device B encapsulates outgoing label 20 in the packet. Then Device B sends the packet to transit node Device C.

3.     Device C forwards the packet to Device D based on its LDP label forwarding entries. The outgoing label is 30.

4.     Device D searches for an LDP label forwarding entry for incoming label 30 and finds that the entry does not have an outgoing label. Because an MPLS SR label forwarding entry with outgoing label 16201 exists for the destination address (3.3.3.3/32), Device B encapsulates outgoing label 16201 in the packet. Then Device D sends the packet to egress node Device E.

5.     Egress node Device E removes the incoming label and forwards the packet by IP address.

Protocols and standards

·     draft-ietf-spring-segment-routing-mpls-00

·     draft-ietf-spring-segment-routing-02

·     draft-ietf-isis-segment-routing-extensions-06

·     draft-ietf-spring-segment-routing-11

Restrictions and guidelines: MPLS SR configuration

On the following switches, MPLS and VXLAN can share hardware resources only if the VXLAN hardware resource mode is Layer 2 gateway:

·     S6860 and S6861 switch series.

·     S6800-54HF, S6800-54HT, and S6800-2C-FC switches.

·     Switches labeled with product code LS-6800-32Q-H1, LS-6800-54QF-H3, LS-6800-54QT-H3, LS-6800-2C-H1, or LS-6800-4C-H1.

If the VXLAN hardware resource mode is not Layer 2 gateway, MPLS is not available. For more information about VXLAN hardware resource modes, see VXLAN Configuration Guide.

MPLS SR tasks at a glance

IP traffic forwarding over SRLSPs tasks at a glance

To forward IP traffic over SRLSPs, perform the following configuration tasks:

1.     Configuring segments

Select one of the following tasks:

¡     Configuring static segments

¡     Configuring IGP-based SID advertisement

2.     (Optional.) Configuring the device to prefer SRLSPs in traffic forwarding

MPLS TE traffic forwarding over static SRLSPs tasks at a glance

To forward MPLS TE traffic over static SRLSPs, perform the following configuration tasks:

1.     Configuring segments

Select one of the following tasks:

¡     Configuring static segments

¡     Configuring IGP-based SID advertisement

2.     Configuring an MPLS TE tunnel to use static SRLSPs

Configuring static segments

Prerequisites for static segment configuration

Before you configure static segments for a static SRLSP, perform the following tasks:

·     Determine the ingress node, transit nodes, and egress node of the static SRLSP.

·     Determine the incoming label for the adjacency segment from a node to next hop of the node. Determine the incoming label of the prefix segment for the destination IP address on each node. On a device, a static SRLSP, a static LSP, and a static CRLSP cannot use the same incoming label. For more information about CRLSP, see MPLS TE configuration in MPLS Configuration Guide.

·     Enable MPLS on all nodes and interfaces that will participate in MPLS forwarding. For information about enabling MPLS, see basic MPLS configuration in MPLS Configuration Guide.

Configuring a static adjacency segment

Restrictions and guidelines

This task is required on all nodes of a static SRLSP.

Multiple static SRLSPs can share an adjacency segment.

If you specify the next hop address for a static adjacency segment, make sure the following requirements are met:

·     The device has a route to the next hop address.

·     MPLS is enabled on the output interface of the route.

If you specify an output interface for a static adjacency segment, make sure the following requirements are met:

·     The interface is up.

·     The interface can receive direct routes.

·     MPLS is enabled on the interface.

A static adjacency segment must use a different incoming label than existing static LSPs, static PWs, and static CRLSPs. If not, the configured adjacency segment is unavailable. The adjacency segment cannot become available even if you change the incoming label of the static LSP, static PW, or static CRLSP. To resolve this problem, you must delete the existing adjacency segment and configure a new one with a different incoming label.

Procedure

1.     Enter system view.

system-view

2.     Configure a static adjacency segment.

static-sr-mpls adjacency adjacency-path-name in-label label-value { nexthop ip-address | outgoing-interface interface-type interface-number }

The next hop address for a static adjacency segment cannot be a local public IP address.

Configuring a static prefix segment

Restrictions and guidelines

This task is required on all nodes of a static SRLSP.

Multiple static SRLSPs to the same destination can share a prefix segment.

A prefix segment must use the next hop or output interface of the optimal route to the destination address of the prefix segment. You can configure multiple prefix segments to the destination address for load sharing if the optimal route has more than one next hop or output interface. To avoid configuration failure, make sure all prefix segments use the same prefix segment name and incoming label.

Procedure

1.     Enter system view.

system-view

2.     Configure a static prefix segment.

static-sr-mpls prefix prefix-path-name destination ip-address { mask-length | mask } in-label in-label-value [ { nexthop ip-address | outgoing-interface interface-type interface-number } out-label out-label-value ]

The next hop address for a static prefix segment cannot be a local public IP address.

Configuring IGP-based SID advertisement

IGP-based SID advertisement tasks at a glance

Perform the following tasks on each node along an SRLSP:

1.     Configuring the IGP to support MPLS SR

2.     Perform one or more of the following tasks:

¡     Configuring prefix SIDs

¡     Enabling MPLS SR adjacency label allocation for the IGP

3.     Configuring the MPLS SRGB

Perform this task if you are configuring prefix SIDs.

Prerequisites for configuring IGP-based SID advertisement

Before you configure IGP-based SID advertisement, perform the following tasks:

·     Determine the ingress node, transit nodes, and egress node of an SRLSP.

·     Determine the following items for each node:

¡     Index value for the prefix SID.

¡     MPLS SRGB.

·     Enable MPLS on all nodes and interfaces that will participate in MPLS forwarding. For information about enabling MPLS, see basic MPLS configuration in MPLS Configuration Guide.

Configuring the IGP to support MPLS SR

Prerequisites

For MPLS SR to take effect, set the IS-IS cost style to wide, compatible, or wide-compatible before configuring IS-IS to support MPLS SR. For more information about the cost style, see IS-IS configuration in Layer 3IP Routing Configuration Guide.

Configuring IS-IS to support MPLS SR

1.     Enter system view.

system-view

2.     Enter IS-IS view.

isis process-id

3.     Enter IS-IS IPv4 unicast address family view.

address-family ipv4

4.     Enable MPLS SR.

segment-routing mpls

By default, MPLS SR is disabled.

Configuring prefix SIDs

About prefix SID configuration

Configuring a prefix SID in lookback interface view binds the SID with the IP address of the loopback interface.

To configure a prefix SID, use one of the following methods:

·     Specify an absolute value in the SRGB. The absolute value is used as the prefix SID.

·     Specify an index value. The sum of the index value and the SRGB base value is used as the prefix SID. The prefix SID must be in the SRGB.

Restrictions and guidelines

To use a prefix SID for a group of SR nodes in anycast scenarios, specify the n-flag-clear keyword to set the Node-SID flag bit of the prefix SID to 0.

To configure an IS-IS prefix SID, you must enable an IS-IS process on the loopback interface.

Configuring an IS-IS prefix SID

1.     Enter system view.

system-view

2.     Enter loopback interface view.

interface loopback interface-number

3.     Configure an IS-IS prefix SID.

isis prefix-sid { absolute absolute-value | index index-value } [ n-flag-clear ] [ explicit-null ]

By default, no IS-IS prefix SID is configured.

Enabling MPLS SR adjacency label allocation for the IGP

Restrictions and guidelines

For this feature to take effect, you must enable MPLS SR.

Enabling MPLS SR adjacency label allocation for IS-IS

1.     Enter system view.

system-view

2.     Enter IS-IS view.

isis process-id

3.     Enter IS-IS IPv4 unicast address family view.

address-family ipv4

4.     Enable MPLS SR adjacency label allocation.

segment-routing adjacency enable

By default, MPLS SR adjacency label allocation is disabled.

Configuring the MPLS SRGB

Restrictions and guidelines

To configure the SRGB of a node successfully, make sure the SRGB contains the prefix SID configured for the node.

MPLS reserves labels in the range of 16000 to 24000 for SRGB. The minimum and maximum label values of the SRBG must be in the range.

Configuring the MPLS SRGB for IS-IS

1.     Enter system view.

system-view

2.     Enter IS-IS view.

isis process-id

3.     Configure the MPLS SRGB.

segment-routing global-block minivalue maxivalue

By default, the minimum label value is 16000, and the maximum label value is 24000.

Configuring the device to prefer SRLSPs in traffic forwarding

About preferring SRLSPs in traffic forwarding

This feature enables the device to preferentially use SRLSPs to forward traffic when both SRLSPs and LDP LSPs are available for traffic forwarding. If you do not configure this feature, the device prefers to use LDP LSPs for traffic forwarding.

Restrictions and guidelines

This feature takes effect only when MPLS SR is enabled and SRLSPs use prefix SIDs.

Configuring the device to prefer SRLSPs established by IS-IS in traffic forwarding

1.     Enter system view.

system-view

2.     Enter IS-IS view.

isis process-id

3.     Configure the device to prefer SRLSPs in traffic forwarding.

segment-routing sr-prefer [ prefix-list prefix-list-name ]

By default, the device prefers LDP LSPs to SRLSPs.

Configuring an MPLS TE tunnel to use static SRLSPs

Tasks at a glance

1.     Enable MPLS TE.

Perform this task on all nodes that the MPLS TE tunnel traverses. For more information, see MPLS TE configuration in MPLS Configuration Guide.

2.     Configuring a static SRLSP

Perform this task on the ingress node of the MPLS TE tunnel.

3.     Create the tunnel interface and specify the destination address of the tunnel.

Perform this task on the ingress node of the MPLS TE tunnel. For more information, see MPLS TE configuration in MPLS Configuration Guide.

4.     Binding a static SRLSP to an MPLS TE tunnel interface

Perform this task on the ingress node of the MPLS TE tunnel.

5.     Configure static routes or policy-based routing to direct traffic to the MPLS TE tunnel.

Perform this task on the ingress node of the MPLS TE tunnel. For more information, see MPLS TE configuration in MPLS Configuration Guide.

Configuring a static SRLSP

1.     Enter system view.

system-view

2.     Configure a static SRLSP.

static-sr-mpls lsp lsp-name out-label out-label-value&<1-n>

Binding a static SRLSP to an MPLS TE tunnel interface

1.     Enter system view.

system-view

2.     Enter MPLS TE tunnel interface view.

interface tunnel tunnel-number [ mode mpls-te ]

3.     Set the MPLS TE tunnel establishment mode to static.

mpls te signaling static

By default, MPLS TE uses RSVP-TE to establish a tunnel.

For more information about this command, see MPLS Command Reference.

4.     Bind a static SRLSP to the MPLS TE tunnel interface.

mpls te static-sr-lsp lsp-name [ backup ]

By default, an MPLS TE tunnel does not use a static SRLSP.

The specified SRLSP must be already created by using the static-sr-mpls lsp command.

You can specify the backup keyword to bind a backup static SRLSP only if both the main and backup SRLSPs are established by using the adjacency segment method.

Display and maintenance commands for MPLS SR

Execute display commands in any view.

 

Task

Command

Display IS-IS SR adjacency segment information.

display isis segment-routing adjacency [ process-id ]

Display IS-IS SRGB information.

display isis segment-routing global-block [ level-1 | level-2 ] [ process-id ]

Display static SRLSP and adjacency segment information.

display mpls static-sr-mpls { lsp [ lsp-name ] | adjacency [ adjacency-path-name ] }

Display static prefix segment information.

display mpls static-sr-mpls prefix [ path lsp-name | destination ip-address [ mask | mask-length ] ]

 

MPLS SR configuration examples

Example: Configuring MPLS SR based on static segments

Network configuration

As shown in Figure 7, Switch A, Switch B, Switch C, Switch D, and Switch E run IS-IS.

Establish an MPLS TE tunnel over a static SRLSP from Switch A to Switch D to transmit data between the two IP networks. The static SRLSP traverses three adjacency segments: Switch A—Switch B, Switch B—Switch C, and Switch C—Switch D.

Establish an MPLS TE tunnel over a static SRLSP from Switch A to Switch E to transmit data between the IP networks. The static SRLSP traverses three segments: Switch A—Switch B (adjacency segment), Switch B—Switch C (prefix segment), and Switch C—Switch E (adjacency segment).

Figure 7 Network diagram

 

Table 1 Interface and IP address assignment

Device

Interface

IP address

Device

Interface

IP address

Switch A

Loop0

1.1.1.9/32

Switch B

Loop0

2.2.2.9/32

 

Vlan-int10

100.1.1.1/24

 

Vlan-int10

10.1.1.2/24

 

Vlan-int20

10.1.1.1/24

 

Vlan-int20

20.1.1.1/24

 

 

 

 

Vlan-int30

60.1.1.1/24

Switch C

Loop0

3.3.3.9/32

Switch D

Loop0

4.4.4.9/32

 

Vlan-int10

30.1.1.1/24

 

Vlan-int10

100.1.2.1/24

 

Vlan-int20

20.1.1.2/24

 

Vlan-int20

30.1.1.2/24

 

Vlan-int30

50.1.1.1/24

 

 

 

 

Vlan-int40

60.1.1.2/24

 

 

 

Switch E

Loop0

5.5.5.9/32

 

 

 

 

Vlan-int10

200.1.2.1/24

 

 

 

 

Vlan-int20

50.1.1.2/24

 

 

 

 

Procedure

1.     Configure IP addresses and masks for interfaces. (Details not shown.)

2.     Configure IS-IS to advertise interface addresses, including the loopback interface addresses. (Details not shown.)

3.     Execute the display ip routing-table command on each switch to verify that the switches have learned the routes to one another, including the routes to the loopback interfaces. (Details not shown.)

4.     Configure LSR IDs, and enable MPLS and MPLS TE:

# Configure Switch A.

<SwitchA> system-view

[SwitchA] mpls lsr-id 1.1.1.9

[SwitchA] mpls te

[SwitchA-te] quit

[SwitchA] interface vlan-interface 20

[SwitchA-Vlan-interface20] mpls enable

[SwitchA-Vlan-interface20] quit

# Configure Switch B.

<SwitchB> system-view

[SwitchB] mpls lsr-id 2.2.2.9

[SwitchB] mpls te

[SwitchB-te] quit

[SwitchB] interface vlan-interface 10

[SwitchB-Vlan-interface10] mpls enable

[SwitchB-Vlan-interface10] quit

[SwitchB] interface vlan-interface 20

[SwitchB-Vlan-interface20] mpls enable

[SwitchB-Vlan-interface20] quit

[SwitchB] interface vlan-interface 30

[SwitchB-Vlan-interface30] mpls enable

[SwitchB-Vlan-interface30] quit

# Configure Switch C.

<SwitchC> system-view

[SwitchC] mpls lsr-id 3.3.3.9

[SwitchC] mpls te

[SwitchC-te] quit

[SwitchC] interface vlan-interface 10

[SwitchC-Vlan-interface10] mpls enable

[SwitchC-Vlan-interface10] quit

[SwitchC] interface vlan-interface 20

[SwitchC-Vlan-interface20] mpls enable

[SwitchC-Vlan-interface20] quit

[SwitchC] interface vlan-interface 30

[SwitchC-Vlan-interface30] mpls enable

[SwitchC-Vlan-interface30] quit

[SwitchC] interface vlan-interface 40

[SwitchC-Vlan-interface40] mpls enable

[SwitchC-Vlan-interface40] quit

# Configure Switch D.

<SwitchD> system-view

[SwitchD] mpls lsr-id 4.4.4.9

[SwitchD] mpls te

[SwitchD-te] quit

[SwitchD] interface vlan-interface 20

[SwitchD-Vlan-interface20] mpls enable

[SwitchD-Vlan-interface20] quit

# Configure Switch E.

<SwitchE> system-view

[SwitchE] mpls lsr-id 5.5.5.9

[SwitchE] mpls te

[SwitchE-te] quit

[SwitchE] interface vlan-interface 20

[SwitchE-Vlan-interface20] mpls enable

[SwitchE-Vlan-interface20] quit

5.     Configure adjacency segment labels on each node:

# On Switch A, create adjacency segment adjacency-1, and bind incoming label 16 to the next hop address 10.1.1.2.

[SwitchA] static-sr-mpls adjacency adjacency-1 in-label 16 nexthop 10.1.1.2

# On Switch B, create adjacency segment adjacency-2, and bind incoming label 21 to next hop address 20.1.1.2.

[SwitchB] static-sr-mpls adjacency adjacency-2 in-label 21 nexthop 60.1.1.2

# On Switch B, create prefix segments prefix-1 to destination IP address 5.5.5.9. Bind incoming label 16000 to next hop addresses 20.1.1.2 and 60.1.1.2, and specify outgoing label 16001.

[SwitchB] static-sr-mpls prefix prefix-1 destination 5.5.5.9 32 in-label 16000 nexthop 20.1.1.2 out-label 16001

[SwitchB] static-sr-mpls prefix prefix-1 destination 5.5.5.9 32 in-label 16000 nexthop 60.1.1.2 out-label 16001

# On Switch C, create adjacency segment adjacency-1, and bind incoming label 30 to next hop address 30.1.1.2. Create adjacency segment adjacency-2, and bind incoming label 31 to next hop address 50.1.1.2.

[SwitchC] static-sr-mpls adjacency adjacency-1 in-label 30 nexthop 30.1.1.2

[SwitchC] static-sr-mpls adjacency adjacency-2 in-label 31 nexthop 50.1.1.2

# On Switch C, create prefix segment prefix-1 to destination IP address 5.5.5.9, and specify incoming label 16001.

[SwitchC] static-sr-mpls prefix prefix-1 destination 5.5.5.9 32 in-label 16001

6.     On Switch A, establish static SRLSP static-sr-lsp-1 to Switch D and static SRLSP static-sr-lsp-2 to Switch E:

# Configure Switch A as the ingress node of static SRLSP static-sr-lsp-1 and configure a label stack of [16, 21, 30].

[SwitchA] static-sr-mpls lsp static-sr-lsp-1 out-label 16 21 30

# Configure Switch A as the ingress node of static SRLSP static-sr-lsp-2 and configure a label stack of [16, 16000, 31].

[SwitchA] static-sr-mpls lsp static-sr-lsp-2 out-label 16 16000 31

7.     Configure MPLS TE tunnels over static SRLSPs on Switch A:

# Establish static MPLS TE tunnel 1 to Switch D and specify the LSR ID of Switch D as the tunnel destination address. Bind static SRLSP static-sr-lsp-1 to MPLS TE tunnel interface 1.

[SwitchA] interface tunnel 1 mode mpls-te

[SwitchA-Tunnel1 ip address 6.1.1.1 255.255.255.0

[SwitchA-Tunnel1] destination 4.4.4.9

[SwitchA-Tunnel1] mpls te signaling static

[SwitchA-Tunnel1] mpls te static-sr-mpls static-sr-lsp-1

[SwitchA-Tunnel1] quit

# Establish static MPLS TE tunnel 2 to Switch E and specify the LSR ID of Switch E as the tunnel destination address. Bind static SRLSP static-sr-lsp-2 to MPLS TE tunnel interface 2.

[SwitchA] interface tunnel 2 mode mpls-te

[SwitchA-Tunnel2] ip address 7.1.1.1 255.255.255.0

[SwitchA-Tunnel2] destination 5.5.5.9

[SwitchA-Tunnel2] mpls te signaling static

[SwitchA-Tunnel2] mpls te static-sr-mpls static-sr-lsp-2

[SwitchA-Tunnel2] quit

8.     On Switch A, configure two static routes to direct traffic destined for 100.1.2.0/24 and 200.1.2.0/24 to MPLS TE tunnel 1 and tunnel 2, respectively.

[SwitchA] ip route-static 100.1.2.0 24 tunnel 1 preference 1

[SwitchA] ip route-static 200.1.2.0 24 tunnel 2 preference 1

Verifying the configuration

# Display the MPLS TE tunnel information on Switch A.

[SwitchA] display mpls te tunnel-interface

Tunnel Name            : Tunnel 1

Tunnel State           : Up (Main CRLSP up)

Tunnel Attributes      :

  LSP ID               : 1               Tunnel ID            : 0

  Admin State          : Normal

  Ingress LSR ID       : 1.1.1.9         Egress LSR ID        : 4.4.4.9

  Signaling            : Static          Static CRLSP Name    : -

  Static SRLSP Name    : static-sr-lsp-1/-

  Resv Style           : -

  Tunnel mode          : -

  Reverse-LSP name     : -

  Reverse-LSP LSR ID   : -               Reverse-LSP Tunnel ID: -

  Class Type           : -               Tunnel Bandwidth     : -

  Reserved Bandwidth   : -

  Setup Priority       : 0               Holding Priority     : 0

  Affinity Attr/Mask   : -/-

  Explicit Path        : -

  Backup Explicit Path : -

  Metric Type          : TE

  Record Route         : -               Record Label         : -

  FRR Flag             : -               Backup Bandwidth Flag: -

  Backup Bandwidth Flag: -               Backup Bandwidth Type: -

  Backup Bandwidth     : -

  Bypass Tunnel        : -               Auto Created         : -

  Route Pinning        : -

  Retry Limit          : 3               Retry Interval       : 2 sec

  Reoptimization       : -               Reoptimization Freq  : -

  Backup Type          : -               Backup LSP ID        : -

  Auto Bandwidth       : -               Auto Bandwidth Freq  : -

  Min Bandwidth        : -               Max Bandwidth        : -

  Collected Bandwidth  : -

 

Tunnel Name            : Tunnel 2

Tunnel State           : Up (Main CRLSP up)

Tunnel Attributes      :

  LSP ID               : 1               Tunnel ID            : 1

  Admin State          : Normal

  Ingress LSR ID       : 1.1.1.9         Egress LSR ID        : 5.5.5.9

  Signaling            : Static          Static CRLSP Name    : -

  Static SRLSP Name    : static-sr-lsp-2/-

  Resv Style           : -

  Tunnel mode          : -

  Reverse-LSP name     : -

  Reverse-LSP LSR ID   : -               Reverse-LSP Tunnel ID: -

  Class Type           : -               Tunnel Bandwidth     : -

  Reserved Bandwidth   : -

  Setup Priority       : 0               Holding Priority     : 0

  Affinity Attr/Mask   : -/-

  Explicit Path        : -

  Backup Explicit Path : -

  Metric Type          : TE

  Record Route         : -               Record Label         : -

  FRR Flag             : -               Bandwidth Protection : -

  Backup Bandwidth Flag: -               Backup Bandwidth Type: -

  Backup Bandwidth     : -

  Bypass Tunnel        : -               Auto Created         : -

  Route Pinning        : -

  Retry Limit          : 3               Retry Interval       : 2 sec

  Reoptimization       : -               Reoptimization Freq  : -

  Backup Type          : -               Backup LSP ID        : -

  Auto Bandwidth       : -               Auto Bandwidth Freq  : -

  Min Bandwidth        : -               Max Bandwidth        : -

  Collected Bandwidth  : -

# Display static SRLSP establishment on each switch by using the display mpls lsp or display mpls static-sr-lsp command.

[SwitchA] display mpls lsp

FEC                         Proto       In/Out Label    Interface/Out NHLFE

1.1.1.9/0/46565             StaticCR    -/21            Vlan20

                                        30  

1.1.1.9/1/46565             StaticCR    -/16000         Vlan20

                                        31

-                           StaticCR    16/-            Vlan20

10.1.1.2                    Local       -/-             Vlan20

Tunnel0                     Local       -/-             NHLFE1

Tunnel1                     Local       -/-             NHLFE2

[SwitchB] display mpls lsp

FEC                         Proto       In/Out Label    Interface/Out NHLFE

5.5.5.9/32                  StaticCR    16000/16001     Vlan20

5.5.5.9/32                  StaticCR    16000/16001     Vlan30

-                           StaticCR    21/-            Vlan20

20.1.1.2                    Local       -/-             Vlan20

60.1.1.2                    Local       -/-             Vlan30

[SwitchC] display mpls lsp

FEC                         Proto       In/Out Label    Interface/Out NHLFE

5.5.5.9/32                  StaticCR    16001/-         -

-                           StaticCR    30/-            Vlan10

-                           StaticCR    31/-            Vlan30

30.1.1.2                    Local       -/-             Vlan10

50.1.1.2                    Local       -/-             Vlan30

Example: Configuring MPLS SR based on ISIS-advertised SIDs

Network configuration

As shown in Figure 8, Switch A, Switch B, Switch C and Switch D are running IS-IS.

Configure dynamic SID allocation on loopback interfaces of the switches. Then, establish an SRLSP from Switch A to Switch D based on the allocated SIDs and configure an MPLS TE tunnel over the SRLSP to transmit data.

Figure 8 Network diagram

 

Table 2 Interface and IP address assignment

Device

Interface

IP address

Device

Interface

IP address

Switch A

Loop1

1.1.1.1/32

Switch B

Loop1

2.2.2.2/32

 

Vlan-Int100

10.0.0.1/24

 

Vlan-Int100

10.0.0.2/24

 

 

 

 

Vlan-Int200

11.0.0.1/24

Switch C

Loop1

3.3.3.3/32

Switch D

Loop1

4.4.4.4/32

 

Vlan-Int100

12.0.0.1/24

 

Vlan-Int100

12.0.0.2/24

 

Vlan-Int200

11.0.0.2/24

 

Vlan-Int200

100.1.2.1/24

 

Procedure

1.     Configure IP addresses and masks for interfaces. (Details not shown.)

2.     Configure IS-IS on the switches and set the IS-IS cost style to wide:

# Configure Switch A.

<SwitchA> system-view

[SwitchA] isis 1

[SwitchA-isis-1] network-entity 00.0000.0000.0001.00

[SwitchA-isis-1] cost-style wide

[SwitchA-isis-1] quit

[SwitchA] interface vlan-interface 100

[SwitchA-vlan-interface100] isis enable 1

[SwitchA-vlan-interface100] quit

[SwitchA] interface loopback 1

[SwitchA-LoopBack1] isis enable 1

[SwitchA-LoopBack1] quit

# Configure Switch B.

<SwitchB> system-view

[SwitchB] isis 1

[SwitchB-isis-1] network-entity 00.0000.0000.0002.00

[SwitchB-isis-1] cost-style wide

[SwitchB-isis-1] quit

[SwitchB] interface vlan-interface 100

[SwitchB-vlan-interface100] isis enable 1

[SwitchB-vlan-interface100] quit

[SwitchB] interface vlan-interface 200

[SwitchB-vlan-interface200] isis enable 1

[SwitchB-vlan-interface200] quit

[SwitchB] interface loopback 1

[SwitchB-LoopBack1] isis enable 1

[SwitchB-LoopBack1] quit

# Configure Switch C.

<SwitchC> system-view

[SwitchC] isis 1

[SwitchC-isis-1] network-entity 00.0000.0000.0003.00

[SwitchC-isis-1] cost-style wide

[SwitchC-isis-1] quit

[SwitchC] interface vlan-interface 100

[SwitchC-vlan-interface100] isis enable 1

[SwitchC-vlan-interface100] quit

[SwitchC] interface vlan-interface 200

[SwitchC-vlan-interface200] isis enable 1

[SwitchC-vlan-interface200] quit

[SwitchC] interface loopback 1

[SwitchC-LoopBack1] isis enable 1

[SwitchC-LoopBack1] quit

# Configure Switch D.

<SwitchD> system-view

[SwitchD] isis 1

[SwitchD-isis-1] network-entity 00.0000.0000.0004.00

[SwitchD-isis-1] cost-style wide

[SwitchD-isis-1] quit

[SwitchD] interface vlan-interface 100

[SwitchD-vlan-interface100] isis enable 1

[SwitchD-vlan-interface100] quit

[SwitchD] interface vlan-interface 200

[SwitchD-vlan-interface200] isis enable 1

[SwitchD-vlan-interface200] quit

[SwitchD] interface loopback 1

[SwitchD-LoopBack1] isis enable 1

[SwitchD-LoopBack1] quit

3.     Configure LSR IDs, and enable MPLS and MPLS TE:

# Configure Switch A.

[SwitchA] mpls lsr-id 1.1.1.1

[SwitchA] mpls te

[SwitchA-te] quit

[SwitchA] interface vlan-interface 100

[SwitchA-vlan-interface100] mpls enable

[SwitchA-vlan-interface100] quit

# Configure Switch B.

[SwitchB] mpls lsr-id 2.2.2.2

[SwitchB] mpls te

[SwitchB-te] quit

[SwitchB] interface vlan-interface 100

[SwitchB-vlan-interface100] mpls enable

[SwitchB-vlan-interface100] quit

[SwitchB] interface vlan-interface 200

[SwitchB-vlan-interface200] mpls enable

[SwitchB-vlan-interface200] quit

# Configure Switch C.

[SwitchC] mpls lsr-id 3.3.3.3

[SwitchC] mpls te

[SwitchC-te] quit

[SwitchC] interface vlan-interface 100

[SwitchC-vlan-interface100] mpls enable

[SwitchC-vlan-interface100] quit

[SwitchC] interface vlan-interface 200

[SwitchC-vlan-interface200] mpls enable

[SwitchC-vlan-interface200] quit

# Configure Switch D.

[SwitchD] mpls lsr-id 4.4.4.4

[SwitchD] mpls te

[SwitchD-te] quit

[SwitchD] interface vlan-interface 100

[SwitchD-vlan-interface100] mpls enable

[SwitchD-vlan-interface100] quit

4.     Configure SRGBs and enable MPLS SR on the switches:

# Configure Switch A.

[SwitchA] isis 1

[SwitchA-isis-1] segment-routing global-block 16000 16999

[SwitchA-isis-1] address-family ipv4

[SwitchA-isis-1-ipv4] segment-routing mpls

[SwitchA-isis-1-ipv4] quit

[SwitchA-isis-1] quit

# Configure Switch B.

[SwitchB] isis 1

[SwitchB-isis-1] segment-routing global-block 17000 17999

[SwitchB-isis-1] address-family ipv4

[SwitchB-isis-1-ipv4] segment-routing mpls

[SwitchB-isis-1-ipv4] quit

[SwitchB-isis-1] quit

# Configure Switch C.

[SwitchC] isis 1

[SwitchC-isis-1] segment-routing global-block 18000 18999

[SwitchC-isis-1] address-family ipv4

[SwitchC-isis-1-ipv4] segment-routing mpls

[SwitchC-isis-1-ipv4] quit

[SwitchC-isis-1] quit

# Configure Switch D.

[SwitchD] isis 1

[SwitchD-isis-1] segment-routing global-block 19000 19999

[SwitchD-isis-1] address-family ipv4

[SwitchD-isis-1-ipv4] segment-routing mpls

[SwitchD-isis-1-ipv4] quit

[SwitchD-isis-1] quit

5.     Configure IS-IS prefix SIDs for the switches:

# Configure Switch A.

[SwitchA] interface loopback 1

[SwitchA-LoopBack1] isis prefix-sid index 10

# Configure Switch B.

[SwitchB] interface loopback 1

[SwitchB-LoopBack1] isis prefix-sid index 20

# Configure Switch C.

[SwitchC] interface loopback 1

[SwitchC-LoopBack1] isis prefix-sid index 30

# Configure Switch D.

[SwitchD] interface loopback 1

[SwitchD-LoopBack1] isis prefix-sid index 40

6.     On Switch A, establish static SRLSP static-sr-lsp-1 to Switch D and configure an MPLS TE tunnel over the static SRLSP:

# Configure Switch A as the ingress node of static SRLSP static-sr-lsp-1 and specify the prefix label that Switch A allocated for Switch D (16040) as the outgoing label.

[SwitchA] static-sr-mpls lsp static-sr-lsp-1 out-label 16040

# Establish static MPLS TE tunnel 1 to Switch D and specify the LSR ID of Switch D as the tunnel destination address. Bind static SRLSP static-sr-lsp-1 to MPLS TE tunnel interface 1.

[SwitchA] interface tunnel 1 mode mpls-te

[SwitchA-Tunnel1] ip address 6.1.1.1 255.255.255.0

[SwitchA-Tunnel1] destination 4.4.4.4

[SwitchA-Tunnel1] mpls te signaling static

[SwitchA-Tunnel1] mpls te static-sr-mpls static-sr-lsp-1

[SwitchA-Tunnel1] quit

7.     On Switch A, configure a static route to direct traffic destined for 100.1.2.0/24 to MPLS TE tunnel 1.

[SwitchA] ip route-static 100.1.2.0 24 tunnel 1 preference 1

Verifying the configuration

# Display IS-IS process information on Switch A.

[SwitchA] display isis

 

           IS-IS(1) Protocol Information

 

Network entity                  : 00.0000.0000.0001.00

IS level                        : level-1

Cost style                      : Wide

Fast reroute                    : Disabled

Preference                      : 15

LSP length receive              : 1497

LSP length originate

    level-1                     : 1497

Maximum imported routes         : 100000

Timers

    LSP-max-age                 : 1200

    LSP-refresh                 : 900

    SPF mode                    : Normal

    SPF intervals               : 5 50 200

Segment routing

    MPLS                        : Enabled

    Adjacency                   : Disabled

    global block                : 16000 16999

# Display detailed IS-IS interface information on Switch A to view SID information for the loopback interface.

[SwitchA] display isis interface verbose

 

                       Interface information for IS-IS(1)

                       ----------------------------------

  Interface:  LoopBack1

  Index     IPv4 state      IPv6 state     Circuit ID   MTU   Type   DIS

  00002     Up              Down           1            1536  L1/L2  --

  SNPA address                     : 0000-0000-0000

  IP address                       : 1.1.1.1

  Secondary IP address(es)         :

  IPv6 link-local address          :

  Extended circuit ID              : 2

  CSNP timer value                 : L1        10  L2        10

  Hello timer value                :           10

  Hello multiplier value           :            3

  LSP timer value                  : L12       33

  LSP transmit-throttle count      : L12        5

  Cost                             : L1         0  L2         0

  IPv6 cost                        : L1         0  L2         0

  Priority                         : L1        64  L2        64

  Retransmit timer value           : L12        5

  MPLS TE status                   : L1  Disabled  L2  Disabled

  IPv4 BFD                         : Disabled

  IPv6 BFD                         : Disabled

  IPv4 FRR LFA backup              : Enabled

  IPv6 FRR LFA backup              : Enabled

  IPv4 prefix suppression          : Disabled

  IPv6 prefix suppression          : Disabled

  IPv4 tag                         : 0

  IPv6 tag                         : 0

  Prefix-SID type                  : Index

  Value                            : 10

  Prefix-SID validity              : Valid

# Display SRGB information on Switch A.

[SwitchA] display isis segment-routing global-block

 

             Segment routing global block information for IS-IS(1)

             -----------------------------------------------------

 

                                  Level-1 SRGB

                                  ------------

 

System ID                          Base                Range

-------------------------------------------------------------------------------

0000.0000.0001                     16000               1000

0000.0000.0002                     17000               1000

0000.0000.0003                     18000               1000

0000.0000.0004                     19000               1000

# Display detailed IS-IS routing information on Switch A to view information about routes bound with labels.

[SwitchA] display isis route verbose

 

                         Route information for IS-IS(1)

                         ------------------------------

 

                         Level-1 IPv4 Forwarding Table

                         -----------------------------

 

 IPv4 Dest : 10.0.0.0/24         Int. Cost  : 10               Ext. Cost  : NULL

 Admin Tag : -                   Src Count  : 2                Flag       : D/L/-

 InLabel   : 4294967295          InLabel Flag: -/-/-/-/-/-

 NextHop   :                     Interface  :                  ExitIndex  :

    Direct                             Vlan100                    0x00000102

 Nib ID    : 0x0                 OutLabel   : 4294967295       OutLabelFlag: -

 

 IPv4 Dest : 11.0.0.0/24         Int. Cost  : 20               Ext. Cost  : NULL

 Admin Tag : -                   Src Count  : 2                Flag       : R/-/-

 InLabel   : 4294967295          InLabel Flag: -/-/-/-/-/-

 NextHop   :                     Interface  :                  ExitIndex  :

    10.0.0.2                           Vlan100                    0x00000102

 Nib ID    : 0x14000004          OutLabel   : 4294967295       OutLabelFlag: -

 

 IPv4 Dest : 12.0.0.0/24         Int. Cost  : 30               Ext. Cost  : NULL

 Admin Tag : -                   Src Count  : 2                Flag       : R/-/-

 InLabel   : 4294967295          InLabel Flag: -/-/-/-/-/-

 NextHop   :                     Interface  :                  ExitIndex  :

    10.0.0.2                           Vlan100                    0x00000102

 Nib ID    : 0x14000004          OutLabel   : 4294967295       OutLabelFlag: -

 

 IPv4 Dest : 1.1.1.1/32          Int. Cost  : 0                Ext. Cost  : NULL

 Admin Tag : -                   Src Count  : 1                Flag       : D/L/-

 InLabel   : 16010               InLabel Flag: -/N/-/-/-/-

 NextHop   :                     Interface  :                  ExitIndex  :

    Direct                             Loop1                      0x00000584

 Nib ID    : 0x0                 OutLabel   : 4294967295       OutLabelFlag: -

 

 IPv4 Dest : 2.2.2.2/32          Int. Cost  : 10               Ext. Cost  : NULL

 Admin Tag : -                   Src Count  : 1                Flag       : R/-/-

 InLabel   : 16020               InLabel Flag: -/N/-/-/-/-

 NextHop   :                     Interface  :                  ExitIndex  :

    10.0.0.2                           Vlan100                    0x00000102

 Nib ID    : 0x14000003          OutLabel   : 17020            OutLabelFlag: I

 

 IPv4 Dest : 3.3.3.3/32          Int. Cost  : 20               Ext. Cost  : NULL

 Admin Tag : -                   Src Count  : 1                Flag       : R/-/-

 InLabel   : 16030               InLabel Flag: -/N/-/-/-/-

 NextHop   :                     Interface  :                  ExitIndex  :

    10.0.0.2                           Vlan100                    0x00000102

 Nib ID    : 0x14000002          OutLabel   : 17030            OutLabelFlag: -

 

 IPv4 Dest : 4.4.4.4/32          Int. Cost  : 20               Ext. Cost  : NULL

 Admin Tag : -                   Src Count  : 1                Flag       : R/-/-

 InLabel   : 16040               InLabel Flag: -/N/-/-/-/-

 NextHop   :                     Interface  :                  ExitIndex  :

    10.0.0.2                           Vlan100                    0x00000102

 Nib ID    : 0x14000002          OutLabel   : 17040            OutLabelFlag: -

 

      Flags: D-Direct, R-Added to Rib, L-Advertised in LSPs, U-Up/Down Bit Set

 

      InLabel flags: R-Readvertisement, N-Node SID, P-no PHP

                     E-Explicit null, V-Value, L-Local

 

      OutLabelFlags: E-Explicit null, I-Implicit null, N-Normal

# Display MPLS LSP information on Switch A.

[SwitchA] display mpls lsp

FEC                         Proto     In/Out Label    Interface/Out NHLFE

10.0.0.2                    Local     -/-             Vlan100

1.1.1.1/32                  ISIS      16010/-         -

2.2.2.2/32                  ISIS      16020/3         Vlan100

2.2.2.2/32                  ISIS      -/3             Vlan100

3.3.3.3/32                  ISIS      16030/17030     Vlan100

3.3.3.3/32                  ISIS      -/17030         Vlan100

4.4.4.4/32                  ISIS      16040/17040     Vlan100

4.4.4.4/32                  ISIS      -/17040         Vlan100

Example: Configuring MPLS SR and LDP interworking

Network configuration

As shown in Figure 9, complete the following tasks so the two SR networks can communicate across the LDP network:

·     Configure Switch A, Switch B, Switch C, Switch D, and Switch E to run IS-IS.

·     Configure Switch B, Switch C, and Switch D to run LDP.

·     Configure Switch A, Switch B, Switch D, and Switch E to run MPLS SR.

Figure 9 Network diagram

 

Table 3 Interface and IP address assignment

Device

Interface

IP address

Device

Interface

IP address

Switch A

Loop1

1.1.1.1/32

Switch B

Loop1

2.2.2.2/32

 

Vlan-Int100

10.0.0.1/24

 

Vlan-Int100

10.0.0.2/24

Switch C

Loop1

3.3.3.3/32

 

Vlan-Int200

11.0.0.1/24

 

Vlan-Int100

12.0.0.1/24

Switch D

Loop1

4.4.4.4/32

 

Vlan-Int200

11.0.0.2/24

 

Vlan-Int100

12.0.0.2/24

Switch E

Loop1

5.5.5.5/32

 

Vlan-Int200

13.0.0.1/24

 

Vlan-Int200

13.0.0.2/24

 

 

 

 

Procedure

1.     Configure IP addresses and masks for interfaces. (Details not shown.)

2.     Configure IS-IS on the switches to achieve network level connectivity and set the IS-IS cost style to wide:

# Configure Switch A.

<SwitchA> system-view

[SwitchA] isis 1

[SwitchA-isis-1] network-entity 00.0000.0000.0001.00

[SwitchA-isis-1] cost-style wide

[SwitchA-isis-1] quit

[SwitchA] interface vlan-interface 100

[SwitchA-Vlan-interface100] isis enable 1

[SwitchA-Vlan-interface100] quit

[SwitchA] interface loopback 1

[SwitchA-LoopBack1] isis enable 1

[SwitchA-LoopBack1] quit

# Configure Switch B.

<SwitchB> system-view

[SwitchB] isis 1

[SwitchB-isis-1] network-entity 00.0000.0000.0002.00

[SwitchB-isis-1] cost-style wide

[SwitchB-isis-1] quit

[SwitchB] interface vlan-interface 100

[SwitchB-Vlan-interface100] isis enable 1

[SwitchB-Vlan-interface100] quit

[SwitchB] interface vlan-interface 200

[SwitchB-Vlan-interface200] isis enable 1

[SwitchB-Vlan-interface200] quit

[SwitchB] interface loopback 1

[SwitchB-LoopBack1] isis enable 1

[SwitchB-LoopBack1] quit

# Configure Switch C.

<SwitchC> system-view

[SwitchC] isis 1

[SwitchC-isis-1] network-entity 00.0000.0000.0003.00

[SwitchC-isis-1] cost-style wide

[SwitchC-isis-1] quit

[SwitchC] interface vlan-interface 100

[SwitchC-Vlan-interface100] isis enable 1

[SwitchC-Vlan-interface100] quit

[SwitchC] interface vlan-interface 200

[SwitchC-Vlan-interface200] isis enable 1

[SwitchC-Vlan-interface200] quit

[SwitchC] interface loopback 1

[SwitchC-LoopBack1] isis enable 1

[SwitchC-LoopBack1] quit

# Configure Switch D.

<SwitchD> system-view

[SwitchD] isis 1

[SwitchD-isis-1] network-entity 00.0000.0000.0004.00

[SwitchD-isis-1] cost-style wide

[SwitchD-isis-1] quit

[SwitchD] interface vlan-interface 100

[SwitchD-Vlan-interface100] isis enable 1

[SwitchD-Vlan-interface100] quit

[SwitchD] interface vlan-interface 200

[SwitchD-Vlan-interface200] isis enable 1

[SwitchD-Vlan-interface200] quit

[SwitchD] interface loopback 1

[SwitchD-LoopBack1] isis enable 1

[SwitchD-LoopBack1] quit

# Configure Switch E.

<SwitchE> system-view

[SwitchE] isis 1

[SwitchE-isis-1] network-entity 00.0000.0000.0005.00

[SwitchE-isis-1] cost-style wide

[SwitchE-isis-1] quit

[SwitchE] interface vlan-interface 200

[SwitchE-Vlan-interface200] isis enable 1

[SwitchE-Vlan-interface200] quit

[SwitchE] interface loopback 1

[SwitchE-LoopBack1] isis enable 1

[SwitchE-LoopBack1] quit

3.     Configure LSR IDs on the switches:

# Configure Switch A.

[SwitchA] mpls lsr-id 1.1.1.1

# Configure Switch B.

[SwitchB] mpls lsr-id 2.2.2.2

# Configure Switch C.

[SwitchC] mpls lsr-id 3.3.3.3

# Configure Switch D.

[SwitchD] mpls lsr-id 4.4.4.4

# Configure Switch E.

[SwitchE] mpls lsr-id 5.5.5.5

4.     Configure LDP on Switch B, Switch C, and Switch D:

# Configure Switch B.

[SwitchB] mpls ldp

[SwitchB-ldp] quit

[SwitchB] interface vlan-interface 200

[SwitchB-Vlan-interface200] mpls enable

[SwitchB-Vlan-interface200] mpls ldp enable

[SwitchB-Vlan-interface200] quit

# Configure Switch C.

[SwitchC] mpls ldp

[SwitchC-ldp] quit

[SwitchC] interface vlan-interface 100

[SwitchC-Vlan-interface100] mpls enable

[SwitchC-Vlan-interface100] mpls ldp enable

[SwitchC-Vlan-interface100] quit

[SwitchC] interface vlan-interface 200

[SwitchC-Vlan-interface200] mpls enable

[SwitchC-Vlan-interface200] mpls ldp enable

[SwitchC-Vlan-interface200] quit

# Configure Switch D.

[SwitchD] mpls ldp

[SwitchD-ldp] quit

[SwitchD] interface vlan-interface 100

[SwitchD-Vlan-interface1001] mpls enable

[SwitchD-Vlan-interface100] mpls ldp enable

[SwitchD-Vlan-interface100] quit

5.     Enable MPLS SR on Switch A, Switch B, Switch D, and Switch E:

# Configure Switch A.

[SwitchA] isis 1

[SwitchA-isis-1] address-family ipv4

[SwitchA-isis-1-ipv4] segment-routing mpls

[SwitchA-isis-1-ipv4] quit

# Configure Switch B.

[SwitchB] isis 1

[SwitchB-isis-1] address-family ipv4

[SwitchB-isis-1-ipv4] segment-routing mpls

[SwitchB-isis-1-ipv4] quit

# Configure Switch D.

[SwitchD] isis 1

[SwitchD-isis-1] address-family ipv4

[SwitchD-isis-1-ipv4] segment-routing mpls

[SwitchD-isis-1-ipv4] quit

# Configure Switch E.

[SwitchE] isis 1

[SwitchE-isis-1] address-family ipv4

[SwitchE-isis-1-ipv4] segment-routing mpls

[SwitchE-isis-1-ipv4] quit

6.     Configure SRGBs on Switch A, Switch B, Switch D, and Switch E:

# Configure Switch A.

[SwitchA-isis-1] segment-routing global-block 16000 16999

[SwitchA-isis-1] quit

# Configure Switch B.

[SwitchB-isis-1] segment-routing global-block 17000 17999

[SwitchB-isis-1] quit

# Configure Switch D.

[SwitchD-isis-1] segment-routing global-block 18000 18999

[SwitchD-isis-1] quit

# Configure Switch E.

[SwitchE-isis-1] segment-routing global-block 19000 19999

[SwitchE-isis-1] quit

7.     Configure IS-IS prefix SIDs for Switch A, Switch B, Switch D, and Switch E:

# Configure Switch A.

[SwitchA] interface loopback 1

[SwitchA-LoopBack1] isis prefix-sid index 10

[SwitchA-LoopBack1] quit

# Configure Switch B.

[SwitchB] interface loopback 1

[SwitchB-LoopBack1] isis prefix-sid index 20

[SwitchB-LoopBack1] quit

# Configure Switch D.

[SwitchD] interface loopback 1

[SwitchD-LoopBack1] isis prefix-sid index 40

[SwitchD-LoopBack1] quit

# Configure Switch E.

[SwitchE] interface loopback 1

[SwitchE-LoopBack1] isis prefix-sid index 50

[SwitchE-LoopBack1] quit

Verifying the configuration

# Display LDP LSP information on Switch B.

[SwitchB] display mpls ldp lsp

Status Flags: * - stale, L - liberal, B - backup, N/A - unavailable

FECs: 5           Ingress: 3           Transit: 3           Egress: 2

 

FEC                In/Out Label        Nexthop         OutInterface

1.1.1.1/32         2171/-

                   -/2169(L)

2.2.2.2/32         2175/-

                   -/2170(L)

3.3.3.3/32         -/2174              11.0.0.2        Vlan200

                   2172/2174           11.0.0.2        Vlan200

4.4.4.4/32         -/2144              11.0.0.2        Vlan200

                   2167/2144           11.0.0.2        Vlan200

5.5.5.5/32         -/2162              11.0.0.2        Vlan200

                   2161/2162           11.0.0.2        Vlan200

# Display IS-IS SRLSP information on Switch B.

[SwitchB] display mpls lsp protocol isis

FEC                         Proto       In/Out Label    Interface/Out NHLFE

1.1.1.1/32                  ISIS        17010/3         Vlan100

1.1.1.1/32                  ISIS        -/3             Vlan100

2.2.2.2/32                  ISIS        17020/-         -

4.4.4.4/32                  ISIS        17040/2144      Vlan200

4.4.4.4/32                  ISIS        -/2144          Vlan200

5.5.5.5/32                  ISIS        17050/2162      Vlan200

5.5.5.5/32                  ISIS        -/2162          Vlan200

The output shows that the IS-IS SRLSP entries for Switch D and Switch E are using LDP labels.