国家 / 地区

03-典型配置案例(AC+FIT AP)

60-H3C无线控制器本地转发模式下本地Portal认证典型配置举例(V7)

本章节下载  (202.20 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202007/1313749_30005_0.htm

60-H3C无线控制器本地转发模式下本地Portal认证典型配置举例(V7)

H3C 无线控制器

本地转发模式下本地Portal认证典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍本地转发模式下本地Portal认证配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解AAA、Portal、WLAN接入特性。

3  配置举例

3.1  组网需求

图1所示,AP和Client通过DHCP服务器获取IP地址,AC同时作为Portal认证服务器、Portal Web服务器,要求:

·            AC采用直接方式的Portal认证。

·            Client在通过Portal认证前,只能访问Portal Web服务器;Client通过Portal认证后,可以访问外部网络。

·            Client的数据流量直接由AP进行转发。

·            用户可以在VLAN内的任何二层端口上访问网络资源,且移动接入端口时无须重复认证。

图1 本地转发模式下本地Portal认证组网图

 

3.2  配置思路

·            为了使用户可以在VLAN内的任何二层端口上访问网络资源,且移动接入端口时无须重复认证,必须开启Portal用户漫游功能。

·            在采用本地转发模式的无线组网环境中,AC上没有Portal客户端的ARP表项,为了保证合法用户可以进行Portal认证,需要开启无线Portal客户端合法性检查功能。

·            短时间内Portal客户端的频繁上下线可能会造成Portal认证失败,需要关闭Portal客户端ARP表项固化功能。

·            为了将AP的GigabitEthernet1/0/1接口加入本地转发的VLAN 200,需要使用文本文档编辑AP的配置文件,并将配置文件上传到AC存储介质上。

3.3  配置注意事项

·            配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

·            设备重定向给用户的Portal Web服务器的URL默认是不携带参数,需要根据实际应用手动添加需要携带的参数信息。

3.4  配置步骤

3.4.1  编辑AP配置文件

# 使用文本文档编辑AP的配置文件,将配置文件命名为map.txt,并将配置文件上传到AC存储介质上。配置文件内容和格式如下:

System-view

vlan 200

interface gigabitethernet1/0/1

port link-type trunk

port trunk permit vlan 200

3.4.2  配置AC

(1)       配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将获取该IP地址与AC建立CAPWAP隧道。

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 2.2.1.1 24

[AC-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IP地址。Client将使用该VLAN接入无线网络。

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 2.2.2.1 24

[AC-Vlan-interface200] quit

(2)       配置无线服务

# 创建无线服务模板st1,并进入无线服务模板视图。

[AC] wlan service-template st1

# 配置SSID为service。

[AC-wlan-st-st1] ssid service

# 配置无线服务模板VLAN为VLAN200。

[AC-wlan-st-st1] vlan 200

# 配置客户端数据报文转发位置为AP。

[AC–wlan-st-st1] client forwarding-location ap

[AC-wlan-st-st1] quit

# 创建AP,配置AP名称为office,型号名称选择WA4320i-ACN,并配置序列号219801A0CNC138011454。

[AC] wlan ap office model WA4320i-ACN

[AC-wlan-ap-office] serial-id 219801A0CNC138011454

# 指定AP的配置文件为map.txt。

[AC-wlan-ap-office] map-configuration map.txt

# 进入Radio 2视图。

[AC-wlan-ap-office] radio 2

# 将无线服务模板st1绑定到radio 2,并开启射频。

[AC-wlan-ap-office-radio-2] service-template st1

[AC-wlan-ap-office-radio-2] radio enable

[AC-wlan-ap-office-radio-2] quit

[AC-wlan-ap-office] quit

(3)       配置认证域

# 创建名称为dm1的ISP域并进入其视图。

[AC] domain dm1

# 为Portal用户配置AAA认证方法为Local。

[AC-isp-dm1] authentication portal local

# 为Portal用户配置AAA授权方法为none。

[AC-isp-dm1] authorization portal none

# 为Portal用户配置AAA计费方法为none。

[AC-isp-dm1] accounting portal none

# 指定ISP域dm1下的用户闲置切断时间为15分钟,闲置切断时间内产生的流量为1024字节。

[AC-isp-dm1] authorization-attribute idle-cut 15 1024

[AC-isp-dm1] quit

(4)       配置Portal认证

# 配置Portal Web服务器的URL为http://2.2.2.1:8080/portal。

[AC] portal web-server newpt

[AC-portal-websvr-newpt] url http://2.2.2.1:8080/portal

# 配置设备重定向给用户的Portal Web服务器的URL中携带参数。

[AC-portal-websvr-newpt] url-parameter wlanuserip source-address

[AC-portal-websvr-newpt] quit

# 创建本地Portal Web服务器,进入本地Portal Web服务器视图,并指定使用HTTP协议和客户端交互认证信息。

[AC] portal local-web-server http

# 配置本地Portal Web服务器提供的缺省认证页面文件为abc.zip(设备的存储介质的根目录下必须已存在该认证页面文件,否则功能不生效)。

[AC–portal-local-websvr-http] default-logon-page abc.zip

[AC–portal-local-websvr-http] quit

# 配置本地Portal认证的用户名和密码。

[AC] local-user 123 class network

[AC-luser-network-123] password simple 123

[AC-luser-network-123] service-type portal

[AC-luser-network-123] quit

# 开启无线Portal漫游功能。

[AC] portal roaming enable

# 关闭无线Portal客户端ARP表项固化功能。

[AC] undo portal refresh arp enable

# 开启无线Portal客户端合法性检查功能。

[AC] portal host-check enable

# 在无线服务模板st1上使能直接方式的Portal认证。

[AC] wlan service-template st1

[AC-wlan-st-st1] portal enable method direct

# 配置接入的Portal用户使用认证域为dm1。

[AC-wlan-st-st1] portal domain dm1

# 在无线服务模板st1上引用Portal Web服务器newpt。

[AC-wlan-st-st1] portal apply web-server newpt

# 使能无线服务模板st1。

[AC–wlan-st-st1] service-template enable

[AC-wlan-st-st1] quit

3.4.3  配置Switch

# 创建VLAN 100,用于转发AC和AP间CAPWAP隧道内的流量。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# 创建VLAN 200,用于转发Client无线报文。

[Switch] vlan 200

[Switch-vlan200] quit

# 配置Switch与AC相连的GigabitEthernet1/0/1接口的属性为Trunk,允许VLAN 100和VLAN 200通过。

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# 配置Switch与AP相连的GigabitEthernet1/0/2接口属性为Access,并允许VLAN 100通过。

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# 使能PoE功能。

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

# 配置VLAN 200接口的IP地址。

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 2.2.2.100 255.255.255.0

[Switch-Vlan-interface200] quit

3.5  验证配置

# 用户通过网页方式进行Portal认证。用户在通过认证前,发起的所有Web访问均被重定向到Portal认证页面(http://2.2.2.1:8080/portal),在通过认证后,可访问非受限的互联网资源。

通过执行以下显示命令查看AC上生成的Portal在线用户信息。

[AC] display portal user all

Total portal users: 1

Username: Client

  Portal server: newpt

  State: Online

  VPN instance: N/A

  MAC             IP                    VLAN    Interface

  0021-6330-0933  2.2.2.2               200     Vlan-interface200

  Authorization information:

    DHCP IP pool: N/A

    User profile: N/A

    Session group profile: N/A

    ACL number: N/A

    Inbound CAR: N/A

Outbound CAR: N/A

# 开启本地转发后,AC上无法查看Portal下发的ACL表项,AP上可以查看Portal下发的ACL表项。

[AC] display portal rule all ap office

Slot 1:

[AP] display portal rule all

 

IPv4 portal rules on WLAN-BSS1/0/16:

Rule 1:

 Type                : Static

 Action              : Permit

 Protocol            : Any

 Status              : Active

 Source:

    IP             : 0.0.0.0

    Mask           : 0.0.0.0

    Port           : Any

    MAC            : 0000-0000-0000

    Interface      : WLAN-BSS1/0/16

    VLAN           : Any

 Destination:

    IP             : 2.2.2.1

    Mask           : 255.255.255.255

    Port           : Any

 

Rule 2:

 Type                : Dynamic

 Action              : Permit

 Status              : Active

 Source:

    IP             : 2.2.2.2

    MAC            : 0021-6330-0933

    Interface      : WLAN-BSS1/0/16

    VLAN           : Any

 

Rule 3:

 Type                : Static

 Action              : Redirect

 Status              : Active

 Source:

    IP             : 0.0.0.0

    Mask           : 0.0.0.0

    Interface      : WLAN-BSS1/0/16

    VLAN           : Any

    Protocol       : TCP

 Destination:

    IP             : 0.0.0.0

    Mask           : 0.0.0.0

    Port           : 443

 

Rule 4:

 Type                : Static

 Action              : Redirect

 Status              : Active

 Source:

    IP             : 0.0.0.0

    Mask           : 0.0.0.0

    Interface      : WLAN-BSS1/0/16

    VLAN           : Any

    Protocol       : TCP

 Destination:

    IP             : 0.0.0.0

    Mask           : 0.0.0.0

    Port           : 80

 

Rule 5:

 Type                : Static

 Action              : Deny

 Status              : Active

 Source:

    IP             : 0.0.0.0

    Mask           : 0.0.0.0

    Interface      : WLAN-BSS1/0/16

    VLAN           : Any

 Destination:

    IP             : 0.0.0.0

    Mask           : 0.0.0.0

3.6  配置文件

·            AC:

#

vlan 100

#

vlan 200

#

wlan service-template st1

 ssid service

 vlan 200

 client forwarding-location ap

 portal enable method direct

portal domain dm1

 portal apply web-server newpt

 service-template enable

#

interface Vlan-interface100

 ip address 2.2.1.1 255.255.255.0

#

interface Vlan-interface200

 ip address 2.2.2.1 255.255.255.0

#

domain dm1

authorization-attribute idle-cut 15 1024

 authentication portal local

 authorization portal none

 accounting portal none

#

portal host-check enable

#

portal roaming enable

 undo portal refresh arp enable

#

 portal web-server newpt

 url http://2.2.2.1:8080/portal

 url-parameter wlanuserip source-address

#

wlan ap office model WA4320i-ACN

 serial-id 219801A0CNC138011454

 map-configuration flash:/map.txt

 radio 1

 radio 2

  radio enable

  service-template st1

#

·            Switch:

#

vlan 100

#

vlan 200

#

interface Vlan-interface200

 ip address 2.2.2.100 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 100 200

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

poe enable

#

4  相关资料

·            《H3C 无线控制器产品 配置指导》中的“用户接入与认证配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“用户接入与认证命令参考”。

·            《H3C 无线控制器产品 配置指导》中的“WLAN接入配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“WLAN接入命令参考”。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部